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1
Getting Started

For the same characteristic simultaneously to belong and not belong
to the same object in the same way is impossible. Aristotle (384 BC–322 BC)

The point of philosophy is to start with something so simple as not to seemworth stating, and to end with something so
paradoxical that no one will believe it. Bertrand Russell (1872–1970)

W elcome to Version 6! ScientiĖc WorkPlace (SWP), Sci- For Existing Users

For New Users

Before You Begin

Conventions

entiĖc Word (SW), and ScientiĖc Notebook (SNB) have
always provided easy text-entry, natural-notation math-

ematics, powerful symbolic and numeric computation, and Ĕexible
output of online, printed, and typeset documents in a Windows en-
vironment. With Version 6, these features are available for Linux and
Macintosh OS X users as well.

Because of the substantial changes to the program for this version,
existing users should take time to familiarize themselves with SWP’s
new features every bit asmuch as new users should, although the exact
topics of interest to each group will be different. Recognizing this,
we have divided this introductory chapter into a section for existing
users and one for new users. Existing users will đnd information about
important changes to the functionality of SWP in Version 6. New
users will get an introduction to the product with suggestions on how
best to learn it.

Fromthere, this book takes an incremental approach tousingSWP.
Early chapters outline basic document-creation tasks. Later chapters
discuss different methods of document production, structuring docu-
ments for typesetting, andothermore advanced tasks. ăe appendices
summarize the command menus, toolbars, and keyboard shortcuts.

1
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Chapter 1 | Getting Started

ăe book itself was produced using SWP Version 6, and serves as
an example of the kinds of things you can do: Dropped capitals, mar-
gin notes, references, inline graphics with text that runs around them,
and of course attractive and accurately formatted mathematics.

For Existing Users

ăe new program features introduced in this version enhance the
important features present in earlier versions of the program: compat-
ibility with other soĕware and systems; a rich interface based on the
logical separation of content and appearance; the natural entry of text
and mathematics; the ability to perform mathematical computations
inside your SWP and SNB documents; and easy creation and produc-
tion of complex, highly formatted printed documents.

With Version 6 you can work on Windows, Linux, or Macintosh
OS X and share your work seamlessly with colleagues, regardless of
their system environment. With its entirely new Mozilla-based archi-
tecture, Version 6 provides more Ĕexibility for your workplace. You
can save or export your documents in multiple formats according to
your publication and portability needs.

Cross-platform capability

SWP, SW, and SNB now operate on Windows systems running
Windows XP and up; Macintosh systems running OS X.5 Intel and
later; and systems running Linux. For SWP and SNB, Macintosh sys-
tems should be Intel 64-bit capable. Version 6 saves your documents as
 đles, making them completely portable across platforms. Sharing
your work and collaborating with colleagues is easier than ever.
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For Existing Users

New look

ăe program window has an updated look with streamlined lay-
outs for the toolbars and symbol panels. Most tools work the same
way they did in earlier versions. As before, a mouse-activated tooltip
gives the name of each toolbar button and panel symbols.

Seamless TEX in an XML environment
You can seamlessly import TEX đles created with earlier versions

of the program, and you can export any document as a TEX đle.

Create XHTML web öles with ease
Make representations of yourmathematics available onvariousplat-

forms over the Internet with a browser.

Mathematics in MathML
In  and  đles, Version 6 represents your mathemat-

ics as MML.
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Chapter 1 | Getting Started

Multiple display options
Display yourdocumentwithorwithout tags, as source

code, or  (except SNB).

Multiple document production options
When you’re ready for output, you can choose whether to preview

and print directly from the program window or view your document
in a browser. And in SWP or SW, you can typeset your document
when you need the extensive document formatting that LATEX and
pdfLATEX provide.

Easy sharing of documents
Documents and all đles related to them (embedded đles, plot đles,

etc.) are automatically bundled to include all necessary đles. To share
a document, you need only share a single đle bearing the extension .sci.
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For Existing Users

Copy selections more accurately to other applications
Preserve the appearance of information in your document when

you use the enhanced copy operation to copy selections to other ap-
plications. ăe copy operation writes your selection to the clipboard
in /MML. ăe new format is more easily recognized by
other applications.

Context-sensitive status bar indicates xhtml code
Version 6makesmore information available to you as youwork. A

glance at the status bar tells youwhich tags are in effect at the insertion
point.

Deöne automatic substitution sequences for text
and mathematics

Speed the entry of the text and mathematical expressions you use
most oĕen with an enhanced automatic substitution feature.

Speed document formatting with new interactive dialogs
ăe page layout you deđne in a new WYSIWYG interface trans-

lates directly to TEX. ăere’s little or no need to use the document
preamble or rawTEX commands to achieve the page format youwant.
Common tasks such as section head and footnote formatting are sim-
pler.

5
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Chapter 1 | Getting Started

Enter content quickly with fragments
WithVersion 6 you can create fragments containing  code,

TEX code, graphics, or anything else that can go on the clipboard.

Change your mind
Invoke the new Unlimited Undo capability with the standard

Ctrl+z (Command+z for Macintosh) shortcut.

Enter tables precisely
Use the new visual interface to create a table of the exact dimen-

sions you need.

Work faster from the keyboard
Use new keyboard shortcuts to enter or remove section tags and

quickly structure your document. ăe keyboard shortcuts for per-
forming basic operations and entering symbols, characters, and the
most common mathematical objects are faster to use than the mouse.

Edit efficiently
Save time by leaving dialog boxes open while you make replace-

ments and corrections.

Check your spelling in realtime
With inline spell checking from MySpell, you can catch any mis-

Tip:
Use the context menu (right-click) to see
suggested corrections.

spellings. MySpell includes dictionaries in over 40 languages. Mis-
spelled words have a wavy red underline.

Search from the keyboard
Use the arrowkeys to initiate fast character search and incremental

đnd.

Use improved and scalable fonts
Use pdfLATEX and X ETEX to create documents with a wide va-

riety of scalable fonts. ăe soĕware supports the New Font Selec-
tion Scheme (NFSS); with X ETEX you can use any OpenType font in-
stalled on your computer, as well as Unicode and associated extended
Unicode TrueType fonts. ăe program includes the latest version of
LATEX and AMS macros. ăe packages yield ligatures and improved
kerning in Times text when documents are typeset, and both use the
widely acceptedPostScriptNewFontSelectionScheme (PSNFSS) for
LATEX.

6
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For New Users

CreateAMS-LATEX documents
Create documents inAMS-LATEX format automatically by choos-

ing a shell that usesAMS-LATEX typesetting speciđcations.

Produce documents using REVTEX
REVTEX is a package of LATEX macros designed for preparing

physics manuscripts. ăe soĕware includes a shell with typesetting
speciđcations for producing typeset documents for several different
publications.

Create and operate on matrices
Build matrices quickly with Fill Matrix. Carry out implied opera-

tions simply by applying Evaluate to a sum, product, or power. Apply
the numerousmathematical operations displayed on theMatrices sub-
menu.

Operate with the names of functions, after deöning them
by expressions

Deđne generic functions and use them to illustrate rules for differ-
entiation, or use the names of generic functions in deđning new func-
tions.

Make use of user-deöned functions
Use the Deđne Name dialog box to access and take advantage of

functions that have been programmed in MuPAD or that reside in
the standard computational engine libraries, or to create custom pro-
grammed functions.

For New Users
One of themost important things to understandwhen usingMac-

Kichanproducts is the difference between semantic and formative tag-
ging. Most people are used to the latter: You wish to emphasize a
word, so you select it and choose bold, italics, underline, or some other
format option. In ScientiĖcWorkplace (SWP), however, you select the
text and apply a meaningful tag; say, ”Emphasis.” ăe exact way the
text is displayed is independent of this tagging. It could be changed at
production time to suit different requirements: italics for print, bold
for the Web, underline for a screenplay, etc.

Working this way, you don’t have to go back and retag everything
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Chapter 1 | Getting Started

that youmight have tagged ”italic” if you need for it to be underlined;
you simply change how the tag ”Emphasis” is printed and displayed.
One change instead of many. ăe logical separation of the creative
process of writing documents from the mechanical process of format-
ting them has always been at the heart of the user interface in ScientiĖc
Workplace (SWP) and ScientiĖc Word (SW).

As you write, the tags you apply to your content not only establish
the document’s structure but also consistently deđne its printed, on-
line, or typeset appearance, all according to the properties associated
with each tag. Tag properties are determined by the document’s style,
a collection of commands that deđne the way the document appears
when you display it on the screen or in a browser, and when you pro-
duce it without typesetting. In SWP and SW, tag properties are also
determined by the document’s typesetting speciđcations.

While you are doing thework of creating content, you donot need
to be distracted by formatting tasks. ăe program does that work for
you. In other words, while you do the work of creating a good docu-
ment, the programdoes theworkof creating a beautiful one. Andwith
so many available output options, each with a different purpose and
appearance, taking the time-consuming approach of trying to make
the document on the screen look as much as possible like the docu-
ment in print is simply not necessary.

Because the document window doesn’t correspond directly to the
size of online or printed pages, the program doesn’t display page divi-
sions or đxed line lengths on the screen; lines are broken to đt the size
of the window. If you resize the window, the program reshapes the
text to đt it. When you preview your document, you’ll see the page
divisions correctly.

MacKichan products share an easy-to-use scientiđc word proces-
sor that accepts mathematics entered using familiar mathematical no-
tation on the same screen as text. ăe programs use styles and tags
for formatting documents, which can be printed directly or saved as
 đles for use on your website. Version 6 provides direct ac-
cess to the Internet fromwithin the program. ăe onlineHelp system
provides fast information when you need it. SWP and SW support
typesetting with LATEX, pdfLATEX or X ETEX, as well as direct printing
without typesetting. SWP and ScientiĖc Notebook (SNB) support a
wide range of symbolic and numericmathematical computations with
MuPAD, including plotting and animation of various two- and three-
dimensional expressions, computing with named physical units, and

8
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For New Users

performing dynamic calculations with formula objects.
Capabilities and Features SWP SW SNB
Document creation and printing ✓ ✓ ✓
Typesetting with ✓ ✓
 output with MML ✓ ✓ ✓
Computation, plotting, and animations ✓ ✓
Arrange your workplace

Hide the toolbars you don’t need; and display the symbol panels
in sidebars while you work.

Conögure the symbol panels
Customize the symbol panels by removing the symbols that you

don’t use. Revert easily to the original conđguration of the cache and
the panels.

Choose document shells that meet your requirements
Select the typeset and non-typeset appearance of your document

by choosing from among numerous shells, or sets of speciđcations,
for producing books, articles, reports, and other types of documents.
View typeset images of sample documents for each shell providedwith
the program in A Gallery of Document Shells for ScientiĖc WorkPlace
and ScientiĖc Word, on the program DVD. Because the speciđcations
contain complete document formatting instructions, you can concen-
trate on writing your document instead of on formatting its appear-
ance.

9
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Chapter 1 | Getting Started

Use the programwith non-Roman languages
You can use any TrueType or OpenType font installed on your

computer to create documents in languages other than English. Enter
documents from non-U.S. keyboards, including those for right-to-leĕ
languages. ăe program also provides fonts and hyphenation support
for European languages other than English. If you typeset, you can
switch languages in the same document by using Babel, the multilin-
gual LATEX package, and Polyglossia for X ELATEX (designed for Uni-
code).

Get help
Documentation available online includes extensive information

about creatingdocuments andperformingmathematical computations.
Use the Help search feature to đnd information quickly when you
need it.

Before You Begin
Before you attempt to install and use the program, make sure your

personal computer or network client computer meets the hardware
and soĕware requirements shown in the DVD booklet supplied with
the program.

Conventions
Understanding the notation and the terms used in our documen-

tationwill help you understand the instructions. We assume you’re fa-
miliar with the basic procedures and terminology for your operating
system. In our manuals, we use the notation and terms listed below.

General Notations
Text like this indicates information you should type exactly as it

is shown.
Text like this indicates information that you must supply, such as

a đlename.
Typeset your đle means to process your document with LATEX or

pdfLATEX.
Commands on menus and submenus are shown as Menu, [Sub-

menu,]Command,with arrows separating each part. For instance, the
Save As... command on the File menu is shown as File →Save As... ăe

10
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Direct Print Preview command on the Print Preview submenu of the
File menu is given by File →Print Preview →Direct Print Preview.

Keyboard Conventions
We use standard computer conventions to give keyboard instruc-

tions
ăe names of keys in the instructions match the names shown on Macintosh Users Note

most keyboards. Ctrl (Windows) and Cmd (Mac) are synonymous,
as are Enter (Windows) and Return (Mac). Names of keys are always
shown in Windows format. Macintosh users should substitute Mac
keys (e.g. Cmd and Return) as appropriate. For right-clicking, Mac-
intosh users with a single-button mouse should substitute Ctrl+click.

A plus sign (+) between the names of two keys indicates that you
must press the đrst key and hold it down while you press the second
key. For example, Ctrl+gmeans that you press and hold down theCtrl
key, press g, and then release both keys.

Press the Alt key followed by the indicated letter(s) (F for File, S
for Save, e.g.) to quickly access menus and commands. Press Esc to
cancel.

Press Enter in an empty paragraph to terminate any structure (sub- Important:
Terminating Lists, Subsections, etc.section, list, etc.) and return to the next level up. (Pressing Enter twice

is the same.) ăis does mean that you can’t ordinarily press Enter
multiple times to create white space. To create vertical space, either
use Insert →Spacing Objects... →Vertical Space... OR use Conđgura-
tion to change how pressing Enter in an empty paragraph works.

Mouse Conventions
ăe instructions in this manual assume you have not changed any

mouse button defaults. You can use the right mouse button to dis-
play a Context menu for the current selection or the item under the
mouse pointer. (MacUsers: Ctrl+click.) Pressing theApplication key
or Command key also displays the menu.

In any dialog box, click the OK button to put changes into effect
and dismiss the dialog box. Click the Cancel button to dismiss the
dialog box without taking any other action. You may also click the
Close button in the upper right corner of the dialog box.

11
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2
Basics

[I]f we want to subject science itself to a rigorous scrutiny...wemust begin by reawakening the basic experience of the world, of which science is the
second-order expression Maurice Merleau-Ponty (1908–1961)

T he ScientiĖcWorkPlace (SWP), ScientiĖcWord (SW), and Sci- Menus

Toolbars

Sidebars

Display Modes

Status Bar

Additional Information

entiĖc Notebook (SNB) Version 6 program window has been
completely redesigned to provide easy access to the tools you

need to create and navigate documents. In addition to the standard
menu bar at the top, there is a status bar at the bottom and several
other customizable toolbars just above the text entry area. Optional
sidebars display a navigable outline of your document, symbol panels,
a link to a web page on our web site that gives current information
about updates, new shells, extensions, etc., and/or a list of available
fragments. Tabs at the bottom of the screen change the display mode
of your document: normal text entry, a viewwith the  tags shown,
a view of the source code, or a  preview.

Program tools are available from themenus, toolbar buttons, tabs,
and via keyboard shortcuts. Many tools may be invoked in multiple
ways to suit your style of work: via menu, button, or keyboard. In this
manual, we generally indicate only one of the possible ways of access-
ing a tool, generally via the menus. A table of alternative methods is
given at the end of each subsequent chapter of this manual. Appendix
A lists all command shortcuts.

13
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Chapter 2 | Basics

Menus
ăe command menus are the same no matter what MacKichan

product you have installed, with these exceptions: In SW, the Com-
pute menu isn’t available. In SNB, the Typeset menu isn’t available.
Menu Function
File Open, close, save, import, and export new and

existing đles; print, and preview documents; leave
the program

Edit Edit, delete, move, or copy and paste text or
mathematics; undo; đnd and replace content; check
spelling

Insert Insert graphics, tables, breaks, lines, and spacing;
insert mathematical objects and typeset objects;
insert markers, notes, formulas, and hypertext links

View Change the display mode; open the sidebar; toggle
the display of items like notes, markers, and invisible
characters

Go Move to marker or to paragraph
Tag Apply tags; change the non-typeset appearance of

tagged text; assign tags to function keys
Typeset Work with packages and settings; compile your

document in SWP and SW using pdfTEX or X ETEX
Tools Provide user setup and system settings; access tools;

execute jumps; set automatic substitution sequences
Compute Perform mathematical computations in SWP and

SNB
Window Navigate among open documents
Help Access the online Help system and MacKichan

website; register your system; obtain system
information

Program
(Macin-
tosh
only)

On the Macintosh only, the About..., Preferences,
and õuit commands are on the Program menu,
SWP.

When you choose a menu, the program displays a pull-down list
of available commands. When you move the mouse over a command
that is followed by an arrow, the program displays a list of associated

14
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Menus

commands so you can choose among them. When you choose a com-
mand that is followed by an ellipsis (dots), the program displays a di-
alog box so you can make additional choices. Some commands are
available only in certain environments or circumstances; for example,
the Paste command isn’t available if you haven’t already copied a se-
lection to the clipboard. Unavailable commands are dimmed.

FILE Menu
Commands in the đle menu apply to documents as a whole.

New Document...
Opens the Select Shell for a New Document dialog box.

A shell document contains all information needed to create a new
document, including the document type, the LATEX style, tags for for-
matting and structuring the document, etc. When you select a shell,
a document is created with a made up name. You should change this
title the đrst time you save the document.

A document can be fairly complex, consisting of an  đle,
many graphics đles, MuPAD plots, .css đles (which determine the on-
screen presentation of the document tags), and generated đles such as
TEX and  đles. ăese are all collected together in a document đle
which has the đle extension .sci, and which is, in fact, a complete di-
rectory of đles zipped together. ăis makes it easier to move đles on a
single computer or between computers, as all the needed components
are contained in the .sci đle rather than in multiple đles and locations.
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Chapter 2 | Basics

Open File...
Accesses the Open File dialog box, with which you may select an

existing đle for editing.

ăe program works with .sci and .xhtml đles. (You may choose to
open other text-based đle types, but these will generally all open and
be edited as straight, unformatted text.)

When you open a .sci đle, the zip đle is unwrapped and written to
a working directory. When your editing is completed, this directory
and its altered đles are zipped up again into an .sci đle and theworking
directory is deleted. An  đle is converted to an .sci đle. Any
graphics that it refers to will be copied đrst into the working directory
and then into the zipped up .sci đle.
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Import TEX...
Allows you to open and edit TEX documents and documents cre-

ated with previous versions ofMacKichan soĕware. ăese documents
will be converted to .sci format.

Export TEX...
Gives you the ability to share documents with a TEX user who

does not have access toMacKichan soĕware. Choosing this command
brings up a dialog box with which you may choose to save the current
document in TEX format.
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Chapter 2 | Basics

Export to Web...
Saves current document in .html format, copying internal .css đles,

etc., into the .sci đle and changing the internal links.

Recent Files
Shows a list of the most recent đles with which you have worked,

making it easier to select one for editing.

Clean Up
Cleans up temporary đles created during  previews.

Close
Closes the current document. If you have any unsaved changes,

you will be asked if you wish to save or discard them. You may also
choose to cancel the Close operation as this point. You may also close
a document by clicking the Close box (marked with a small x) in the
upper right corner.

Save
Opens the Save Document As dialog box the đrst time you select Note:

In Version 6, you can save by pressing Ctrl + s,
which is the accepted standard Save shortcut.

this command with a new document open, allowing you to choose a
name and location under which to save it and to choose the đle type.
Aĕer a document has been saved, choosing this command again saves
the document without the dialog box appearing.
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Save As...
Opens the Save Document As dialog box every time you choose

it. ăis allows you to save a copy of the current document under a
different name, and to work on the copy.

Save Copy As...
Save a copyof the current document, either to anewdirectory or as

an .sci đle. Note that you continue working on the original document,
not on the copy as you do with Save As...

Revert
Discards all unsaved changes, rolling document back to the last

saved version. ăis command is not available if no changes have been
made since the document was last opened or saved or if the document
has never been saved.

Page Setup...
Brings up thePage Setupdialogbox, inwhich youmaymake choic-

Note:
TEX typsetting features will not be used when
you choose to direct print.

es regarding your printer and its speciđcations for use in direct print-
ing. ăe Format and Options tab controls page orientation and the
scale at which to print. ăe Margins & Header/Footer tab controls
the overall margins on top, bottom, leĕ and right and also lets you
determine the placement of headers and footers.

Print Preview
Choose topreviewwhat yourdocumentwill look likewhenprinted.

You may choose Direct Print or Typeset  previews. You may also
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Chapter 2 | Basics

select a default print preview choice from among the two. When you
choose one of these commands, the preview version of your document
is displayed in the program window. Click Close to return to editing.

Print
Choose to print your document via Direct Print or Typeset .

Doing so opens the Print dialog box in which you may specify print
options such as the page range to print, the number of copies, whether
to print to a đle, and how to handle frames.

Document Info....
Accesses the Document Info dialog box, which has tabs for view-

ing and editing various information items associated with the current
document. ăese include:
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Tab Description
General Name of đle, exact path to đle’s directory, date and time created and

last revised, original language of composition, shell used to create
document, full document title.

Comments User-deđned comments and description đelds.
Print Options Specify how to direct-print document, including whether to display

or suppress invisible items like returns and spaces, color and zoom
factor to use.

Document Links
and Metadata

Wide variety of user-deđned đelds that may be deđned with text
entries or with links.

Save Options Specify how to store different parts of the document’s working đles.

Style...
Opens theDocument style sheets dialogbox, allowing you tobrowse

for and attach different styles to your document, altering its overall
appearance without changing its contents. Tabs let you select from
among style sheets, scripts, tagdeđnitions,XSLTtranslators, andLATEX
styles to use with the current document.

Quit
Exits the program, closing all documents in the process. If you

have unsaved changes in any open documents, you will be asked if you
wish to save, discard changes, or cancel the õuit operation. On the
Macintosh version, this command is on the SWP (Application)menu. Macintosh Users Note

EDIT Menu
ăe Edit menu contains commands for working with document

content, most of which should be familiar from your work with other
applications

Undo
New toVersion 6, youmay undo an unlimited amount of previous

editing changes from your current session with the document
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Redo
ăis command is unavailable until you have chosen to Undo one

or more changes. At that point, you may choose Redo to reapply the
last undone editing change. Note that if you choose to undo the last
change, and thenmake another editing change, Redo is no longer avail-
able.

Properties
Accesses a properties dialog box; the exact one that appears de-

Note:
There may be an entire nested chain of items
whose properties may be changed, e.g.
chapter, section, subsection, bodyText.

pends uponwhat sort of object (paragraph, math expression, etc.) the
cursor is in when you select the command and which speciđc choice
you make among properties. Use the dialog box that appears to apply
special properties to the item at the insertion point.

Cut
Delete the current selection and place it on the clipboard, from

which it may be moved and reinserted elsewhere in the current docu-
ment or other documents. ăis command is unavailable if there is no
current selection.

Copy
Copy the current selection and place it on the clipboard. From

here it may be replicated elsewhere in the current document or other
documents. ăis command is unavailable if there is no current selec-
tion.

Paste
Place a copyof the current clipboard contents at the insertionpoint.

ăis command is unavailable if nothing has been cut or copied to the
clipboard (including from other applications).

Paste Without Formatting
Place a copyof the current clipboard contents at the insertionpoint

without any tag or formatting information. ăis command is unavail-
able if nothing has been cut or copied to the clipboard (including from
other applications).

Delete
Delete the current selection or the character to the right of the

insertion point if there is no selection.
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Select All
Select the entire contents of the current document. Useful for ap-

plying certain global changes, or for copying an entire document to
the clipboard.

Find and Replace...
Opens the Find and Replace dialog box. Enter a word or phrase

for which you would like to search. You may also specify a word or
phrase with which to replace found instances of the search text. You
may apply tags to the search and/or replacement text.

Find Again
Starting with the current insertion point, locate the next instance

of text matching what you entered using Find and Replace.

Find Previous
Starting from the current insertion point, locate the đrst previous

instance of text matching what you entered using Find and Replace.

Check Spelling
Accesses the dedicated spelling checker, as opposed to the inline

spell checking that is always operative. (Misspelled words are Ĕagged
with awavy redunderline; right-click to get suggested corrections from
the context menu.) With the Check Spelling dialog, you can choose
to replace a misspelled word or to ignore the suggested corrections.
You may also specify which language to use.

Count Words
Returns the word count for the current document in a dialog box.

ăecount is obtainedby looking at thenumberof sequences of charac-
ters separated by spaces, returns, tabs, and the like. (Someword counts
are obtained by taking the whole number of characters in a document
and dividing by đve, which is the average number of characters in an
English word.) Click OK to dismiss it.

Special Characters
On the Macintosh there is an OS X dialog box that allows you to Macintosh Users Note

select special characters.
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INSERT Menu
ăe Insert menu contains commands for placing a number of dif-

ferent special items into your document, including images, tables, and
math objects.

Image...
Brings up the Image dialog box. Use it to select a graphics đle

to put into your document at the current insertion point. You may
set a number of different properties for the selected image, including
its size, placement, whether it should be put into a container (frame),
whether to import or reference it, and so on.

When you import an image đle, it is copied and the copy is placed
in a special location in the document’s .sci đle. If you reference an
external image, the đle is kept in its original location. It is easier to
share documents with images handled in the former manner. Look
on page 63 for instructions on working with images.

Table...
Specify the size of and insert a table in your document at the cur-

rent insertion point. You can click and drag to specify the number of
rows and columns (õuickly tab), enter the exact number (Precisely),
and specify the format for a selected cell (Cell tab). Look on page 63
for information on inserting tables.

Line...
Insert a horizontal rule in the document at the insertion point,

with speciđed color, liĕ (position above the text baseline), width (length),
and height (thickness). Units are initially speciđed in points, but you
may choose inches,millimeters, or centimeters aswell. Lookonpage62
for usage information.
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Frame...
Create a frame at the insertion point. A frame is a box that may

contain text, tables, images, or other objects. ăere are many options
youmay specifywhen creating a frame, including themargins, the bor-
der thickness and color, and theway the frame is displayed (at a certain
position, Ĕoating, etc.). Additional information onpage 64 shows you
how to enter frames.

Breaks...
Place a division in the text at the insertion point, such as a discre-

tionary hyphen, line break, or page break.
Breaks
Allowbreak Line break is permitted if necessary
Discretionary
hyphen

Use to control exactly where a word
breaks. If word occurs at end of line,
insert hyphen in word at this point and
break.

No break Do not break line ever at speciđed point
Pagebreak Break page at speciđed point
Newpage Start a new page at speciđed point
Linebreak Break line at speciđed point
Newline Start a new line at speciđed point
Custom newline Start a new line with user-deđned

settings
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Spacing Objects

Horizontal Spaces

Specify the kind or amount of horizontal space to add at the in-
sertion point.

Horizontal
Normal Standard space; 2

9 em (width of letter
’m’)

Required 2
9 em; space must be included

Non-breaking
space

2
9 em; word following space must
appear on same line as word preceding
space

Em space Width of letter ’m’
2 em space 2 ’m’ widths
ăin space 1

6 em
ăick space 5

18 em
Italic correction Varies; used to maintain correct offset

from top of preceding italic character
Negative thin
space

- 1
6 em

Zero space 0 em
No ident Do not indent at space
Custom User-deđned space

Vertical Spaces

Specify the kind or amount of vertical space to add at the insertion
point.

Vertical (based on 12pt font)
Small skip 5

16 inch
Medium skip 3

8 inch
Big skip 7

16 inch
Strut 3

16 inch
Math strut 7

32 inch
Custom User-speciđed
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Math

Toggles text entry mode to Math entry. Subsequent editing will
enter math objects.

Text

Toggles entry mode to Text entry. Subsequent editing will enter
text objects.

Math Objects

Insert one of the speciđed Math objects at the insertion point.
ăere are a number of math objects you may enter; see Chapter 5 for
information on working with them and other mathematical entities.

Marker...

A marker is an invisible object with a speciđc name that may be
referenced from elsewhere; for example, as the target of a hyperlink or
cross reference. Use this command to set up a marker at the insertion
point. Although invisible, the marker can appear in the direct view of
the document.

Footnote

Places a numbered footnote in the text at the insertion point.

Note...

Place a note (footnote, endnote,margin note, etc.) at the insertion
point. Look on page 64 for information on the type of notes you may
insert and how to work with them.

Typeset Object

A typeset object contains information about the typeset form of
the document, such as citations, index locations, cross-references, TEX
đelds, and bibliographic references. ăis command brings up one of
several dialog boxes with which you may customize one of these ob-
jects to place at the insertion point. Consult Chapter 6 for more in-
formation about various typeset objects.
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Hyperlink...
Insert a hyperlink at the current location of the insertion point.

Youmay specify an external đle orweb location, or amarker (identiđed
by its key) within the current document.

HTML Field...
Insert the contents of a named  đeld at the insertion point.

VIEWMenu
ăe View menu has commands to adjust how you see the current

document and the program window itself.
ăe đrst four commands in the View menu replicate the action of

the tabs along the bottom of the document pane.

Normal Edit Mode
Set document display to standard edit mode.

XML Tags
Show  tags within the document display.

XML Source
Show the  source code for the current document.

Preview
Display a print preview of the current document. ăe exact pre-

view shown (Direct, ) depends on the default preview method
chosen using the File > Print Preview > Select Default command.

ăe next two commands in the View menu apply to TEX.

TEX Log
Display the most recent TEX processing log. ăe log shows results

of running TEX on your document and may provide information to
aid in troubleshooting should you have difficulties.
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TEX File
Show the TEX đle for the current document. A separate window

opens containing the TEX code for the document on which you’re
working.

ăe next two sets of commands in the View menu let you select
which sidebars and toolbars you wish to see in the program window.

Sidebars
Toggle display of the leĕ and right program sidebars.

Toolbars
Toggle display of the Standard, Editing, Math, and Symbol tool-

bars that appear at the top of the program window, just below the
menus.

ăe next set of commands in the View menu toggle the display of
various special objects.

Footnotes
Choose whether to show footnotes at their document locations.

Other Notes
Choose whether to show other notes at their document locations.

Invisibles
Toggles display of generally hidden items such as spaces, returns,

discretionary hyphens, frames around lists, list items, environments,
and the like.

Helper Lines
Toggles display of guide lines.

Input Boxes
Toggles display of input boxes.

Index Entries
Choose whether to show index entries at their document loca-

tions.
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Markers
Choose whether to show markers at their document locations.
ăeđnal command in theViewmenu adjusts the size atwhich you

view the current document.

Zoom
Choose whether to enlarge or reduce the size of the current docu-

ment. You may also reset to the original zoom factor.

GO Menu
ăe Go menu contains commands for navigating within a docu-

ment.

To Marker...
Brings up a dialog box allowing you to go to a selected marker lo-

cation from among those shown.

To Paragraph...
Advance to a speciđed paragraph number or forward or backward

by a given number of paragraphs.
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TAG Menu
ăe Tag menu has commands to change the format and appear-

ance of the current document.

Function Keys...
Accesses the Function key dialog box. Use this to assign format-

ting commands to speciđc function keys to speed editing. You may
also assign scripts to function keys. Note that certain function keys
are reserved for operating system use.

Advanced...
Select font, font size and line spacing, or font color to use at the

insertion point or on the current selection.

CSS Editor
Accesses the Tag Appearance dialog box, with which you may cre-

ate and edit the CSS stylesheets to adjust a wide variety of on-screen
appearance options (paragraph styles, font styles, etc.)
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TYPESET Menu
ăe Typeset menu contains commands for determining the type-

set appearance of a document.

Document Format...
Accesses theDocumentFormatdialogbox, giving you awide range

of choices for alteringor overridingdocument appearanceoptions spec-
iđed by the document shell (page formatting, font choice, number of
columns, section styles, and so on.) If you leave the đrst checkbox
blank (on the General tab it’s labeled Enable overriding the document
style), all the options on the dialog box will be grayed out.

Preamble...
Opens the Preamble dialog box. Use it to add commands to the

document’s preamble. ăis is helpful in case you employ LATEX pack-
ages which SW and SWP do not support directly.

Bibliography Choice...
Specifywhether to use BTEXormanual bibliography item entry.

Options and Packages...
Manage the class options andTEXpackages used by the document.

TOOLS Menu
Contains various items for conđguring and customizing your SW,

SWP, and SNB experience..

JavaScript debugger...
Use to troubleshoot embedded JavaScript code.
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DOM Inspector...
Lets you view DOM information for the current document and

others.

Extensions...
Lets you view and manage Mozilla extensions.

Themes...
Lets you choose between Mozilla themes.

Automatic Substitution...
Lets you specify text or a script to insert when a speciđed combi-

nation of keystrokes is entered. You may restrict substitution to Math
or Text entry modes, or have it occur in both.

Preferences...
Adjust how you want the program to appear and operate. ăe

Preferences dialog box has tabs for general settings, editor controls,
computation, plots, and typesetting. On the Macintosh, this com- Macintosh Users Note
mand is available through the SWP (Application) menu.
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Tab Purpose
General Adjust auto-saving, using arrow keys to đnd, which shell to use when

starting a new document, default size and placement for new images.
Editor Enable realtime spellchecking, etc.
Computation Adjust input, output, matrices, derivatives, entities, and the

computational engine.
Plots Adjust axes, layout, labeling, and the view
Typesetting Specify BTEX, , and miscellaneous options.

COMPUTE Menu
ăeComputemenu contains awide variety of commands for eval-

uatingmathematical expressions. ăecommands in theComputemenu
are not documented in this book. Learn about them and their use in
Doing Mathematics with ScientiĖc Workplace and ScientiĖc Notebook,
Version 6 .

WINDOWMenu
Use theWindowMenu tomove between open documents. ăere

will be one entry in the Window menu for each document you have
open.
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HELP Menu
ăe Help menu accesses the online help system, the MacKichan

web site, and product registration and licensing.
ăe đrst three commands in theHelpmenu access the online help

system.

Contents...
Accesses the online help table of contents.

Search...
Accesses a dialog box with which you may search the online help

for speciđed text.

Index
Accesses the online help index.

MacKichan Software Website
If you have Internet access, choosing this command launches your

default browser and/or opens the MacKichan web site http://www.
mackichan.com) in a new tab. ărough this web site you can đnd out
how to contact MacKichan for technical support and other needs.

ăe last commands on theHelpmenu deal with licensing and reg-
istration.

Register....
Lets you register your copy of MacKichan soĕware.

System Features...
Shows a dialog box with your product name, serial number, com-

puter identiđcation, etc.

License Information
Accesses a windowwith information aboutMacKichan Soĕware’s

licensing policies.

About product
Shows a dialog box with a few speciđcs on the currently installed

MacKichan product. ăis includes information about the soĕware
version with which you are working. On the Macintosh, this com- Macintosh Users Note
mand is available through the SWP (Application) menu.
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Toolbars
ăe Version 6 program window has four customizable toolbars.

ăe Standard toolbar contains buttons for invoking common đle op-
erations (New,Open, Save, Print, Preview), toggling fromtext tomath,
and the list boxes for tag lists (character, paragraph, division, front
matter). Text in gray identiđes the purpose of the tags in each list:

ăe Editing toolbar buttons invoke ordinary editing tools (Check
spelling, Copy, Cut, Paste), Undo and Redo, Search, Space, bold and
italic tags, and several others:

ăeMath toolbar buttons insertmathematical objects such as frac-
tions, integrals, matrices, and radicals directly into your document or
open dialog boxes so that you canmake additional speciđcations. Cer-
tain buttons invoke common computational operations.

ăe Symbol toolbar has palettes of buttons for adding a wide va-
riety of symbols to your documents.

ăe Plot toolbar appears if you have a plot in your document. Re-
fer toDoing Mathematics for information about plots.

Hint:
Tooltips let you knowwhat various interface
features (buttons, symbols) are for.

With the exception of those on the Symbol toolbar, the buttons
on the toolbars are identical in function to commands on the menus.
Point the mouse at each toolbar button for a few seconds to display
a brief tooltip that identiđes the button. As with menu commands,
buttons that appear dimmed are unavailable.

36



i
i

“CreatingDocs60” — 2011/12/19 — 10:43 — page 37 — #45 i
i

i
i

i
i

Sidebars

Sidebars
ăeVersion6 sidebars display several palettes thatmakedocument

Leĕ sidebar with Symbols palette
and Fragments pane

editing easier. You may toggle the display of sidebars on either side
of the document pane, and you may choose which palettes/panes to
display in either sidebar using theAdd drop-downmenu. ăeActions
drop-down menu lets you close or move palettes in a sidebar.

Youmay toggle thedisplay of either sidebar. Note the small graphic
on the inside border of each, containing two arrowheads separated by
a columnof dots. Click this graphic to toggle sidebar display. Youmay
also toggle sidebar display from the View menu. Click on any button
in the Symbols palette to place the associated symbol at the insertion
point.

Display Modes
In addition to working in the normal editing view, you can display

your document as an  đle, shown either in ASCII representation
or with all  tags depicted as icons. You can also preview your doc-
ument as a  đle. Click the tabs along the bottom of the document
window.

Status Bar
New in Version 6,the context-sensitive Status bar operates in two

display modes, Normal and  Tags, to indicate the active 
tags. You can easily tell which tags are in effect at the insertion point.
In the image shown below, the insertion point is in a bodyText para-
graph within a section within a chapter.
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Additional Information
For informationonprogramshortcuts, consult theAppendix. You

may also consult theGetting StartedDVD booklet for a brief orienta-
tion to the user interface and the bookDoingMathematics with Scien-
tiĖc WorkPlace and ScientiĖc Notebook for information on mathemat-
ics and computation.

In the remainder of this book, we take an increasingly in-depth
look at using the soĕware. ăe đrst item under consideration is how
to create and edit a simple document.
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Creating a Simple Document

I have found that all ugly things are made by those who strive to make something beautiful, and that all beautiful things are made by those who
strive to make something useful. Oscar Wilde (1854–1900)

A t itsmost basic level, yourwork inScientiĖcWorkPlace (SWP), About Document Shells

Opening Existing Documents

Saving Documents in Other
Formats and Location

Information for Power Users

ScientiĖcWord (SW), and ScientiĖc Notebook (SNB) consists
of creating newdocuments orworkingwith existing ones and

then preserving thework you do by saving the đles. By default, Version
6 saves your documents as  đles and gives them a đle extension
of .sci. ăis is a change from earlier versions of the program, which
saved all đles as LATEX đles with a đle extension of .tex. Of course, in
Version 6 you can import, modify, and export existing .tex đles created
with earlier versions, and you can create new LATEX đles by exporting
your documents as TEX đles.

ăis chapter explains how to create new documents and how to
open existing documents saved in various đle formats. It also explains
how Version 6 saves and closes documents and describes the export
options that are available to you. ăe chapter also discusses creating
document copies.
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About Document Shells
Every new document is created from a document shell. ăe pro-

gram includes a number of shells that produce both general-purpose
documents and documents designed to meet the speciđc publication
requirements of various universities and scholarly journals. Document
shells, which have a đle extension of .shl, are installed in the Shells
folder of your program folder.

ăe shells have different purposes. Some have been designed to
create articles; others, to create books, reports, or other types of docu-
ments. Some of the shells in the international folder support creating
documents with non-Roman character sets, including Chinese, Ko-
rean, and Japanese. ăese documentsmust be produced by typesetting
with X ETEX.

Some shells contain predeđned information that you can use or
modify. ăe tags available for structuring documents differ from shell
to shell. Each shell has several sets of appearance speciđcation đles.
ăe program uses some of the đles when you display the document
in the program window, view it as an  đle, or print it directly
from the programwindowwithout typesetting. ăese đles include the
style speciđcation (.css đle) and the print options. ăe program uses
the typesetting speciđcations associated with the shell only when you
export the document as a .tex đle and produce a typeset đle (in SWP
or SW).

Occasionally, youmaywant to use a shell that isn’t provided as part
of the program installation. Please note that although youmay be able
to create a document using a shell from another source, we support
only those documents created with shells and speciđcations that are
provided with the program.

Choosing an appropriate shell is an important decision. It’s easier Please Note
to choose a shell that has all the formats and capabilities you’ll need
right at the start rather than trying to add capabilities later as you dis-
cover you need them.

Documents shells provided with your program installation are or-
ganized by type: articles, books, theses, etc. ăis helps make it easier
to choose what shell to use based on what type of document you’re
creating. Are you writing an article for publication? Look in the Ar-
ticles folder and see if the organization (publisher, journal, etc.) for
whom you’re writing has a predeđned shell. Are you writing a book?
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Look in the Books folder for a shell adapted to the kind of book you’re
writing. If a speciđc shell does not exist for what you’re writing, there
are generalized article, book, and thesis shells you can use.

Standard Document Shell
When you đrst open the program, a template article appears using

the Standard_LaTeX_Article shell. If this shellmeets your needs, you
can begin working in it immediately.

Opening a New Document
In most cases, the default document shell will not be appropriate

for your needs. You need to create a new document and choose a new
shell for it.
Tocreate a newdocument

1. Choose File →New Document... ăe Select Shell for New Doc-
ument dialog box appears.

2. Navigate in the Shell Directories pane until you đnd the shell
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you wish to use. Click to select it in the Shell Files pane.

3. Click OK. A new document appears using the shell you chose.

Aĕer you create the initial document, you can set a few of its initial
properties using the Document Info dialog box. Among other things,
you can set the document title.

Togive a newdocument a title
1. Choose File →Document Info... ăeDocument Info dialog box

appears.

2. Click to place the cursor in the Title đeld at the bottom of the
items on the General tab.

3. Enter the title for the document.

4. Click OK. ăe title for the document will now appear in the
title bar of the main window. Try clicking the different tabs on Tip
the Document Info dialog box to see the various items you can
deđne for a document.

Having created a new document and given it a title, you can pro-
ceed to save it for the đrst time.

To save a newdocument
1. Choose File →Save... ăe đrst time you do this in a new docu-

ment, the Save Document As dialog box appears.
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2. Enter a valid đle name for the document. (Remember not to use
characters that may be reserved by your operating system, such
as * and /.)

3. Use the directory pane to navigate to a different location if you
wish to save the đle elsewhere from the default location shown.

4. Click Save. ăe đle name for the document will now appear in
the title bar of the main window.

Whenyour editingwork is done, you can either chooseFile →Close
to leave the document without exiting the program, or you can choose
File →õuit to close the document and the program together. On the
Macintosh the õuit command is found on the SWP (Application) Macintosh Users Note
menu.

Opening Existing Documents
ăere are two broad categories of existing documents that you can

open with Version 6. Naturally, there are documents that you (or
someone else) created with Version 6 itself, like the simple one de-
scribed in the preceding pages. Opening such a document can be as
simple as đnding the icon for the đle and double-clicking it, or choos-
ing Open File... from the File menu, locating the document đle, and
clicking Open.

Alternatively, you may have documents created with previous ver- Please Note
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sions of MacKichan soĕware or with other programs. ăese docu-
ments need to be converted into Version 6 format before they can be
edited. You do so using the File > Import and File > OpenWeb Loca-
tion commands. When you choose to import a document in Version
6, the original document đle is undisturbed. ăe soĕware creates a
new version of the document in .sci format while preserving the orig-
inal intact.
Toopen adocument createdwithVersion 6

If the icon for the đle you want to open is not readily visible, you
can use the Open File... command to access it.

1. Choose File →Open File... ăe Open Scientiđc Workplace đle
dialog box appears.

2. Navigate to the location of the desired đle.

3. Click to select the đle.

4. Click Open. ăe đle opens in a new window.

If the document you wish to work with was opened recently on
your system, and you have Version 6 running, you need only locate it
on the Recent Files submenu on the File menu. ăe last ten đles with
which you’ve worked are displayed there.
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Toopen adocument createdwith an earlier version
Version 5.5 and earlier documents are saved in .tex format. ăese

documentsmust be imported intoVersion 6 before you canworkwith
them.

1. Choose File →Import Tex... ăe Import Tex File dialog box ap-
pears.

2. Navigate to đnd the đle you wish to import.

3. Click to select the đle’s name.

4. ClickOpen. ăeđle is opened and converted, and then appears
in a new window.

Note that you’ll need to save the new document you created by
importing.

Saving Documents in Other Formats and Location
At times you may wish to share Version 6 đles with others who do

not have the soĕware. ăe easiest way to do this is to export the đle
and save it as a .tex đle. You can also export yourwork in format
for use in Web publications.
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Toexport a document as aLATEXđle
1. Open the document and choose File →Export TEX... ăe Ex-

port TEX File dialog box appears.

2. Select a location and name for the đle.

3. Click Save. ăe đle is exported; the original Version 6 đle stays
open.

Toexport a document as aWebđle
1. Choose File →Export to Web... ăe Export to Web dialog box

appears.
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2. Select a location and enter a name for the đle.

3. Click Save. ăe đle is exported in  format; the original
đle stays open.

To save a copy of an opendocument
You can create a copy of an open document using a new location.

ăe copy is like a snapshot of your document. When you save a copy
of your document, the program creates the copy but keeps the original
document open so you can continue working in it. Any subsequent
changes you make appear in the original đle but not the copy.

1. Choose File →Save Copy As... ăe Save Document As dialog
box appears.

2. Select a location and type a name for the document copy.

3. Click Save. ăe copy is created and the original document is
leĕ open.
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Chapter 3 | Creating a Simple Document

Information for Power Users

Setting Program Options
Use Tools →Preferences to see and set certain options relevant to

saving and opening documents and much more (E.g. change default
startup shell, whether to automatically save, etc.).

Click through the tabs to see what kind of preferences you can set.
Of particular interest is the automatic saving option. You can have
the program automatically save your work at an interval you specify
in seconds. Your work will be protected even if you should be called
away before you can remember to save.

Shortcuts
Here is a list of shortcuts for the commands covered in this chap-

ter:
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Shortcuts

Command Shortcut

Save Ctrl+s or Alt f s or

New Document Ctrl+n or Alt f n or

Open Document Ctrl+o or Alt f o or

õuit program Ctrl+q or Alt f q

Close Document Alt f c

Save As Alt f a

Revert Alt f v
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4
Editing Documents

Is not this a lamentable thing, that the skin of an innocent lamb should be made parchment? That parchment, being scribbled o'er,
should undo a man? William Shakespeare (1564–1616), II Henry VI,IV:ii

E ntering text is straightforward in ScientiĖc WorkPlace (SWP), Before You Begin

Basic Text Editing

Entering Text with Special Tools

Enhancing Text

Creating Section Headings

Creating Lists

Adding Non-Text Elements

Information for Power Users

ScientiĖcWord (SW), andScientiĖcNotebook (SNB) evenwhen
special characters are needed. In Version 6, enhanced tools for

using fragments, automatic substitution strings, and tags make enter-
ing text simpler than ever.

ăis chapter explains how to enter text and text elements such as
lists.

Before You Begin
Just as grasping the concept of a document shell was important

to the process of creating a new document, understanding how Mac-
Kichan soĕware treats different kinds of information is important be-
fore you enter and edit text. ăe next sections of this chapter note the
differences between entering text and entering mathematics, and talk
about the importance of tagging.
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Chapter 4 | Editing Documents

Text vs. Mathematics
At all times during information entry you are either entering text

or mathematics, and the results obtained from keystrokes and other
user interface actions will differ depending on whether you are enter-
ing text or math. ăus we refer to being in either text mode or math
mode. ăe default state is text mode; it is easy to toggle between the
two modes and it is also easy to determine what mode you are in. Un-
less you actively change tomathematics, the programdisplays a “T“ on
the Standard toolbar and

• Interprets anything you type as text, displaying it in black in the
program window.

• Displays alphabetic characters as upright, not italicized.

• Inserts a space when you press the spacebar.

When you start the program, the insertion point is in text mode.

To toggle between text andmathematics
Click the “T” on the standard toolbar. ăe “T” changes to “M,”

the insertion point changes to red and appears between brackets.
You may also choose the Math command from the Insert menu.
When you toggle to mathematics, the Math/Text button changes

to an “M” and the program

• Displays the insertion point between brackets for mathematics.

• Interprets anything you type asmathematics, displaying it in red
in the program window.

• Italicizes alphabetic characters and displays numbers upright.

• Automatically formats mathematical expressions, inserting cor-
rect spacing around operators such as + and relations such as =.

• Advances the insertion point to the next mathematical object
when you press the spacebar.

ăe remainder of this chapter focuses on entering and editing text
items. ăe next chapter discusses how to enter mathematics.
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Before You Begin

About Tagging
In MacKichan soĕware, all information is tagged. As was stated

in the New User’s section of the đrst chapter, this tagging is seman-
tic, or meaningful, in nature. ăe tags you apply to your content not
only establish the document’s structure but also consistently deđne
its printed, online, or typeset appearance, all according to the prop-
erties associated with each tag. Tag properties are determined by the
document’s style, a collection of commands that deđne the way the
document appears when you display it on the screen or in a browser,
and when you produce it without typesetting. In SWP and SW, tag
properties are also determined by the document’s typesetting speci-
đcations, items generally set using the Typeset > Document Format
command.

In general there are four types of tags, set by using the four drop-
down menus on the standard toolbar: text; paragraph or list; division
or environment; and frontmatter. In a sense these are organized in de-
scending order of the level of organization to which they apply. Text
tags can apply to entire blocks of text or to a single character; para-
graph tags apply to an entire paragraph, structure tags apply to multi-
ple paragraphs.

ăe exact set of tags you have available at any time depends upon Note
your original choice of document shell. ăis is one of the reasons why
it is important to choose an appropriate shell.

In general, you use text tags for a word or phrase you wish to set
off from the rest of text; for example, using italics to indicate a foreign
wordor phrase. Use paragraph tags to indicate the purpose of an entire
paragraph: to serve as the heading for a section, to serve as a body
paragraph, a bibliography entry, and so on. ăese will also affect a
paragraph’s alignment. Section tags deđne thepurpose of entire blocks
of paragraphs: as a subsection in the current section, as a preface, and
the like. ăere is a (removesection) tag to take off a previous section
choice. Use a frontmatter tag at the appropriate place in a document
to automatically generate items such as the title page, table of contents,
or a list of đgures. (Appearance of such items is controlled by the shell
and may be adjusted via the Document Format dialog box.)
Toapply a tag to a part of a document

1. Click to move the insertion point to the relevant part OR
Click-and-drag to select a section of text.

2. Choose the desired tag from the menu.
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Chapter 4 | Editing Documents

Additional information about applying speciđc kinds of tags is
provided later in the chapter.

Basic Text Editing
Information entry in SW, SWP, and SNB consists of typing and

selecting characters and other elements for entry and tagging same.
ăere are a number of menu and palette choices to support informa-
tion entry.

Entering Symbols
Entering standard characters is easy: You just type. Not all char-

acters you may wish to enter are available directly from the keyboard,
however. In many cases, they can be found on palettes, such as the
Symbols palette. You can also enter them using macros.
Toenter a character froma symbols palette or toolbar

1. Ensure that the relevant palette is visible. If the Symbol tool-
bar isn’t visible and you want it to be, choose View →Toolbars
→Symbol toolbar. If the symbols palette isn’t visible, choose it
from the Add menu on either the leĕ or right sidebar.

2. Place the insertion point where you want the character to ap-
pear.

3. Click the desired tab to display the characters on the palette.

4. Click the character you want.

Symbols shown in black on the palettes are text; those shown in Tip
red are math.

If youpreferworking strictly from the keyboard, you can enter spe-
cial characters with macros. ăe macro for each character in any sym-
bols palette appears in the corresponding tooltip. So to identify the
macro for a special character or symbol, just let the mouse hover over
the character to display the macro.
Toenter a characterwith amacro

1. Place the insertion point where you want the character to ap-
pear.

2. Press Ctrl+spacebar. ăe program opens a Macro box on the
Status bar.
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Basic Text Editing

3. Type the macro for the character or select the macro from the
list that appears as you type. As you type, the program displays
the macro in the Macro box, completing it if possible.

4. Press Enter. ăe character is inserted.

ăe next time you open the Macro box, it displays the name of
the macro you entered most recently, allowing you to enter the same
character or symbol repeatedly.

Non-Roman Character Sets
You can create documents that require non-Roman character sets

using any TrueType or OpenType font that is installed on your com-
puter. You can enter documents from non-US keyboards, including
those for right-leĕ languages. If you typeset your document, you can
use the Babel or Polyglossia packages to switch languages inside the
document.

Typing Special Punctuation
Besides the standard symbols on your keyboard, the program rec-

ognizes several specialized punctuation marks and symbols: curled
opening and closingquotationmarks (“ and ”), invertedquestionmarks
(¿), and inverted exclamation points (¡). ăe program also recognizes
the en dash (–) and the em dash (—). You can enter all these punctu-
ation marks from the symbols palettes or from the keyboard.

Entering a punctuationmark from a symbols palette is identical to
entering any other special character; punctuation appears on the last
tab at the bottom leĕ.

Toenter a punctuationmark from the keyboard
Use the keystrokes in this table:

To enter From the keyboard
- (hyphen) Press -
– (en dash) Press - twice
— (em dash) Press - three times
¿ Press ? and then press ‘ (backprime)
¡ Press ! and then press ‘ (backprime)
“ Press ‘ (backprime) twice
” Press ’ (apostrophe) twice

ăeprogramautomatically hyphenates textwhen you typeset your
document, but not when you produce it without typesetting or when
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you use SNB. However, you can request discretionary, or conditional,
hyphenation for speciđc words in case they occur at the end of a line.
If you place a discretionary hyphen in a word, the program breaks the
word at that point if necessary, both in print (and, if View →Invisibles
is selected) in the program window.

Toenter a discretionary hyphen
1. Place the insertion point where you want the word to break.

2. Choose Insert →Breaks... ăe Breaks dialog box appears.

3. Select Discretionary hyphen.

4. Click OK.

Entering Text with Special Tools
In addition to using the redesigned symbols palettes and entering

characters with macros, you can use several new and enhanced tools
to speed the entry of text.

Entering Text with Fragments
You may need to type some text items repeatedly, such as your

name or affiliation. You can store these frequently typed items as Ěag-
ments—information saved in separate đles for later recall—and im-
port them into your documents quickly. Fragments can contain text,
mathematics,TEXstrings, code, graphics, or anything else that
can go on the clipboard. Information in fragments can carry tags.
Fragments from each document are available to all.

ăe program comes with a few pre-deđned fragments. ăe most
commonly used fragments are stored in the res/fragments folder of
yourprogram installation. ăeconstants subfolderhouses somemath-
ematics fragments.

Todisplay a list of all fragments
1. Display a sidebar with enough space.

2. Choose Fragments from the Add menu on the sidebar, if Frag-
ments are not already visible. ăe program opens the sidebar
and displays the Fragments folder tree.
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To import a fragment
1. Place the insertion point where you want the fragment to ap-

pear.

2. Select the fragment you want and press Enter, double-click it,
or drag the fragment to your document.

You may also use the Macro box, accessed with Ctrl+spacebar, to Note
enter the name of a fragment to place at the insertion point. (To close
the macro box, press Return with the cursor in the Macro box.)

Creating a new fragment is easy. When you do so, the program
saves it by default with a đle extension of .frg in the res/fragments
folder.
Tocreate a fragment

1. Ensure the Fragments area is open on the sidebar.

2. Ensure that the information you wish to turn into a fragment is
visible in the program window.

3. Select the desired information and drag it to the fragments area.
ăe Fragment Name and Description dialog box appears.

4. Enter a unique name for the fragment and, if desired, provide a
description. ăis description will become a tooltip.

5. Click OK. ăe new fragment appears in the Fragment area on
the sidebar.

To delete a fragment, right-click its name and choose the Delete
Fragment.frg command from the context menu.

Entering Text with Automatic Substitution
With automatic substitution, the program substitutes predeđned

expressions for typed sequences of letters and numbers. In earlier ver-
sions, automatic substitution was available only for fast entry of math-
ematics. In Version 6, it is extended to text. See the next chapter for
information about using automatic substitution to entermathematics.

As with fragments, you can deđne and edit your own automatic
substitution sequences. For example, if you frequently use the phrase
”Version 6 of Scientiđc WorkPlace”, you might deđne an automatic
substitution sequence called swp so that you can enter the phrase
quickly. You can enable or disable automatic substitution at any time.
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Chapter 4 | Editing Documents

If you disable it, the program doesn’t make a substitution when you
type the corresponding sequences of letters and numbers.

Your program installation includes many predeđned autosubsti-
tution sequences. You can view them by choosing Tools →Automatic
Substitution... Click an item in the Keystrokes list at the right to view
its deđnition.

To turn automatic substitutionon andoff
1. Choose Tools →Automatic Substitution... ăe Automatic Sub-

stitution dialog box appears.

2. Automatic substitution is turned on by default. To disable it
for text entry, click the In Text checkbox under Disable Auto
Substitution.

To enter text with automatic substitution, you need only type the
characters that stand for the text you want to enter. For instance,
typing three hyphens will enter an em-dash. You can view which se-
quences are available by choosing the Keystrokes menu in the Auto-
matic Substitution dialog box.

You must type exactly the keystrokes shown in the order shown. Note
ăat is, if you type sp, thenuse theback arrowkey to insert awbetween
the other two letters, there will be no automatic substitution.

Toenter your own automatic substitution sequence for use in text
1. Open the Automatic Substitution dialog box.

2. Enter the desired keystrokes in the Keystrokes text edit box.

3. Click the In Text radio button in the Content for Substitution
pane.
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Enhancing Text

4. Enter the text that will be substituted in the Substitution text
edit box.

5. Click Save.

Try testing your automatic substitution text by entering thekeystrokes
you chose. (Make sure automatic substitution is enabled đrst.) For
straight text items, you may wish to enter a space as the last character
to be substituted.

Enhancing Text
To emphasizewords inphrases inside aparagraphby changing their Note:

You can apply more than one text tag to a
selection.

appearance, you can use text tags, which are collections of text format-
ting properties. Text tags common to most document shells include
Bold, Em (emphasized), and Sub (subscript). Many shells have ad-
ditional text tags. Text that doesn’t carry any special emphasis tag is
tagged as Normal. Some tags, such as Calligraphic and Blackboard
Bold, start mathematics automatically.

ăe text tags available to the active document appear in the Text
Tag list on the Standard toolbar.

ăe appearance and behavior of tagged information depends on
the tag properties, which are deđned twice in SWP and SW: once in
the typesetting speciđcations, which are used when you typeset your
document; and, once in the .css đle, which is usedwhen the document
is directly printed or displayed. ăe two sets of properties may differ
signiđcantly even though the name of the tag is the same. ăus, the
appearance of your document depends on which set of properties is
used. In SNB tag properties are deđned only once in the .css đle.
Toapply a text tag to a selection

1. Select the text you want to tag.

2. Click the arrow at the right of the Text Tag box.

3. Click the tag you want.

You can also apply a text tag to the next information you type. Se-
lect the text tag, type the text to have the tag, then be sure to select the
(normal) tag to return to standard text entry. To remove a tag, select
the tagged text and apply the (normal) tag.

Bold and Italic have buttons on the Editing toolbar. Click the but- Note
ton to apply the tag.
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Chapter 4 | Editing Documents

Also, several function keys on your keyboard are assigned to cer-
tain text tags. To apply the tag, press the function key assigned to the
tag youwant. F4 applies (normal); F5 applies Bold. ăese settings can
be changed using the Functions Keys... command in the Tag menu.
Tochange a functionkey assignment

1. Choose Tag > Function Keys... ăe Function Keys dialog box
appears.

2. Press the Function key you wish to assign.

3. Select a tag to apply from the drop-down list.

4. Click the Save changes to đle button then click Done. ăe new
function key assignment is put into effect.

Creating Section Headings
Divisions are the major parts of a document. Usually, they are sig-

naled with headings. ăe division headings provide the document’s
heading structure. Each heading is a whole paragraph. By applying
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Creating Lists

various section tags to the paragraphs in your document, you can cre-
ate multiple levels of headings, such as parts, chapters, sections, sub-
sections, and subsubsections, depending on the document shell you
use. ăe section tags available to the active document appear in the
Section Tag list on the Standard toolbar.

Tocreate a sectionheading
1. Place the insertionpointwhere youwant the heading paragraph

to begin or in the paragraph you want to use as a section head-
ing.

2. Click the arrow at the right of the Section Tag box, then click
the tag you want.

3. Type the heading paragraph if it doesn’t yet exist.

Creating Lists
A list is a series of items, each consisting of one ormore paragraphs

and each beginning with a speciđc lead-in object—an automatically
generated number, a bullet, or some customized text that you supply.
You can create nested lists up to four levels deep; within a list, the levels
can be of different types; that is, you can create a bulleted list within
a numbered list. On the screen, indention of the list items indicates
their level.

Lists are created with Item tags. ăe available tags and their ap-
pearance in the program window and in print depend on the docu-
ment shell. Most shells have tags for numbered and bulleted lists, as
well as lists without lead-in objects. ăe paragraph box lists the avail-
able tags.

You can enter a list tag đrst and then create the list item, or apply
a list tag to an existing paragraph. ăe paragraph box names the item
tag in effect at the insertion point. List tags aren’t available in certain
environments, such as section headings.

Toenter a new list
1. Move the insertion point to the location of the đrst item in the

new list.

2. In the paragraph tag menu, choose the tag for the type of list
you want.

61



i
i

“CreatingDocs60” — 2011/12/19 — 10:43 — page 62 — #70 i
i

i
i

i
i

Chapter 4 | Editing Documents

3. To enter an additional paragraph that is part of the current list
entry, press Enter.

4. To enter a paragraph that represents a new list entry, press Enter
in an empty paragraph.

5. To terminate the list, press Enter in an empty list item.

Tocreate a nested list item
1. Start a list, type a list item, and press Enter.

2. With the insertion point in the new paragraph, start a new list
by choosing the appropriate list item tag from the paragraph tag
menu.

Note
Depending on the style sheet in use, you may not see different num-
ber styles for nested items. ăese will appear when the document is
typeset.

Adding Non-Text Elements
In addition to text, you can addhorizontal rules (lines), tables, and

images.

Adding Lines
Although the document style determines where lines typically ap-

pear in your document, you may want to add solid lines to set off cer-
tain portions of the text. You can specify the color, width, height, and
liĕ—thepositionof the line in relation to thebaseline of the surround-
ing text.

Toadd a line
1. Choose Insert →Line... ăe Lines dialog box appears.

2. Select a unit of measure and then specify the liĕ, width, and
height of the line in the corresponding boxes.

3. Click the color box and choose a color from the color palette, if
desired, clicking OK on the palette to conđrm your choice.

4. Click OK on the Lines dialog box to insert the line.
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Adding Tables
Rather than attempting to line everything up with tabs, spaces,

and returns, you can present tabular information neatly using a table
with a speciđed number of rows and columns. Rows and columns will
resize automatically to đt the amount of information being entered,
but you can also manually resize them.
Toadd a table quickly

1. Choose Insert →Table... ăe Insert Table dialog box appears.

2. On the õuickly tab, click-and-drag the number of rows and
columns desired.

3. ClickOK.A tablewith thedesirednumberof rows and columns
appears at the insertion point.

4. To enter information in a table cell, click to move the insertion
point to the relevant cell and type. (Youmay also use other text-
entry methods discussed in this chapter.)

Other tabs on the Insert Table dialog box allow you to exactly Note
specify the number of rows and columns and to adjust how the
table is displayed. Use the context menu to make other editing
adjustments such as deleting a cell, adding rows, and the like.

Adding Images
You may insert graphic images in your documents. Version 6 sup-

ports the current standard graphics đle formats.
Some formats that were supported previously have been dropped

in Version 6 because they have turned out to be non-standard.
To insert an image

1. Choose Insert →Image... ăe Image dialog box appears.

2. Use the Choose File... button on the Image tab to select the
image đle to insert.

3. Choose whether to Import the image, which brings a copy of it
into the .sci đle, or to Reference external image, which relies on
the image being in a speciđc place on your computer. ăe for-
mer is recommended because it makes document management
easier; you don’t have to keep track of graphics đles when you
move or share your document.
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4. Use thePlacement tab todetermine exactlywhere the imagewill
be displayed when the document is typeset.

5. Use the Frame tab to provide a frame for the image, if desired.

6. Use the Labeling tab to give the image a caption and determine
caption placement, if desired.

7. Click OK to insert the image.

Inserting Frames
A frame is a bordered area that can contain other objects such as

images, tables, and even text. You could use a frame to set up a sidebar,
which could be anchored to a speciđc part of your text or to a speciđc
location on a page.
To insert a frame

1. Click to move the insertion point to the location where you
want the frame to appear.

2. Choose Insert →Frame... ăe Frame dialog box appears.

3. Choose the size for the frame by entering a width and height.
Units are in pixels but youmay change this using the drop-down
menu at the top.

4. Specify a placement for the frame. It may be In-Line (displayed
within a text line), Displayed (on a line by itself ), or Floating.
Floating frames get placed in the best possible position at type-
setting time. You can anchor them to a speciđc location (Here)
and also indicate where in reference that that position they
should be placed (Leĕ, Right, Inside, etc.).

5. On the Frame tab, choose margins and borders as desired.

6. Click OK. ăe frame is inserted.

Inserting Notes
A note is an extra item of text appearing outside the normal Ĕow,

such as a footnote or a heading appearing in themargin. Notes appear
near their insertion point when you are working with your document,
but appear in the correct place (i.e., at the bottom of the page for foot-
notes) at typeset time.
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To insert a note
1. Click to move the insertion point to the location where you

want the note to appear.

2. Choose Insert →Note... ăe Note dialog box appears.

3. Choose the type of note from the drop-down list. You may
choose footnote, margin note, margin hint, solution note,
problem-solving hint, note, and answer note. ăe placement
of each varies; try experimenting with them to get the desired
effect.

4. Click OK. ăe note is inserted; you’ll see a frame for it.

5. Click to move the insert point to the note’s frame and enter the
text, images, or other items you wish to appear.

Information for Power Users

Hints and Tips
Use the arrow keys for quick navigation and editing.

• To search forward for a speciđc character, hold down the right
arrow key and type the character.

• To search backward for a speciđc character, hold down the leĕ
arrow key and type the character.

• To search forward for agroupof characters, holddown thedown
arrow key and type the characters.

• To search backward for a group of characters, hold down the up
arrow key and type the characters.

Because of this functionality, holding down any of the arrow keys
will not repeatedlymove the insertion point. To do so, press the arrow
key twice, holding it down the second time.

Edit itemswith the contextmenu. For instance, to change a table,
right-click the table. ăe context menu that appears has commands
for adding and deleting rows and columns, among other things.

65



i
i

“CreatingDocs60” — 2011/12/19 — 10:43 — page 66 — #74 i
i

i
i

i
i

Chapter 4 | Editing Documents

Shortcuts
ăe following table shows shortcuts relevant to topics covered in

this chapter.
Command Shortcut

Undo Ctrl+z or Alt e u

Select All Ctrl+a or Alt e a

Cut Ctrl+x or Alt e t

Copy Ctrl+c or Alt e c

Paste Ctrl+v or Alt e p

Bold text

Italic text
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Working with Mathematics

[T]urning a page is not the same as writing the next chapter. E.J. Dionne (b. 1952)

A s with all versions of ScientiĖc WorkPlace (SWP), ScientiĖc Before You Begin

Entering and Editing Symbols
and Characters

Tagging Mathematics

Entering and Editing
Mathematical Objects

Information for Power Users

Word (SW), and ScientiĖc Notebook (SNB) entering math is
straightforward in Version 6. Working right in the program

window, you use familiar notation to enter mathematical characters,
symbols, and objects into your document. Simple commands let you
create displayed or inline mathematics.

Editing mathematics is equally straightforward. You can use stan-
dard clipboard and drag-and-drop operations to cut, copy, paste, and
delete selections. You can also use the search and replace features to lo-
cate or change mathematical information. Although the program au-
tomatically formatsmathematics correctly, youmay occasionally want
tomodify the appearance of yourmathematics. Special editing proce-
dures are available for certain mathematical objects.

ăis chapter gives instructions for entering and editingmathemat-
ical information. It explains how to enter mathematical symbols and
characters and how to create automatically formatted objects, such as
fractions, radicals, and operators.

Before You Begin
ăe next sections of this chapter recapitulate the differences be-

tween entering text and entering mathematics.
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Text vs. Mathematics
As we stated in the previous chapter, the default state for Version

6 is text mode; it is easy to toggle between the twomodes and it is also
easy to determine what mode you are in. Unless you actively change
to mathematics, the program displays a “T“ on the Standard toolbar
and

• Interprets anything you type as text, displaying it in black in the
program window.

• Displays alphabetic characters as upright, not italicized.

• Inserts a space when you press the spacebar.

When you start the program, the insertion point is in text mode.
To toggle between text andmathematics

Click the “T” on the standard toolbar. ăe “T” changes to “M,”
the insertion point changes to red and appears between brackets.

You may also choose the Math command from the Insert menu.
When you toggle to mathematics, the Math/Text button changes

to an “M” and the program

• Displays the insertion point between brackets for mathematics.

• Interprets anything you type asmathematics, displaying it in red
in the program window.

• Italicizes alphabetic characters and displays numbers upright.

• Automatically formats mathematical expressions, inserting cor-
rect spacing around operators such as + and relations such as =.

• Advances the insertion point to the next mathematical object
when you press the spacebar.

About Tagging
Tocreate aBodyMathparagraph

1. Place the insertion pointwhere youwant themathematics para-
graph to begin.

2. Apply the Body Math tag.
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On the screen, most document shells use color to distinguish be-
tweenmathematics and text. ăedefault color formathematics is red;
the default color for text is black. Math names for functions, opera-
tors, and variables appear in gray. ăe program automatically formats
yourmathematics correctly when you display or print your document.
By default, you enter mathematics in the current line of text, but you
can also enter it on a separate line as a mathematical display.

Mathematics behaves differently in the two environments. For in-
linemathematics, any operators are sized to đtwithin the line and lim-
its are positioned to the right of operators and functions. ăe numer-
ators and denominators of fractions are set in small type.

Displayedmathematics appears centered on a separate line and set
off from the information above and belowby additional space. Opera-
tors within the display are larger than inline operators, limits are posi-
tioned above and below operators and functions, and the numerators
and denominators of fractions are set in full-size type.

Entering and Editing Symbols and Characters
In SWP, SW, and SNB you can enter symbols and characters:

• With themouse, from the symbols palettes, especially the Sym-
bol Cache.

Let the mouse hover over each item on the palettes to display
the name of the symbol or character.

• With thekeyboard, using shortcutmacros (usually theTEXname
of the symbol).

ăe Macro list shows the name you entered most recently.

• With an alternate keyboard.

Greek characters are mapped to a Greek keyboard, and many
common mathematical symbols and characters are mapped to
the Symbol keyboard.

Toenter symbols and characters from the symbols palettes
Click the symbol or character youwant on the Symbol pane on the

sidebar, or click the symbol palette you want on the Symbol toolbar
and then from the list of available symbols, click the symbol youwant.
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Toenter symbols and characterswith shortcutmacros
1. Press Ctrl+spacebar to open the Macro box on the Status bar.

2. Type the name of the symbol or character, or type the đrst letter
of the name and select the name from the list that opens.

ăe Macro list self-completes, so entering macros is a fast way
to enter mathematics.

3. Press Enter.

To repeat themost recently enteredmacro
Press Ctrl+spacebar and then press Enter.

Toenter symbols and characters froman alternate keyboard
1. Press Ctrl+7 to change to the Symbol keyboard or Ctrl+g to

change to the Greek keyboard.

2. Press the key for the symbol you want.

Toconvert text tomathematics
1. Select the text.

2. Toggle to mathematics.

ăe program converts the selection to mathematics, removing all
ordinary spaces in the selection, italicizing alphabetic characters and
displaying numbers in ordinary text.

Tagging Mathematics
You can add emphasis andmeaning tomathematics with text tags.

In mathematics, calligraphic text denotes sets or integral transforms;
blackboard bold denotes the set of real numbers or natural numbers;
and boldface text oĕen indicates vectors and matrices. You can ap-
ply these conventions in your document by applying text tags to your
mathematical content.

ăeBlackboardBold,Calligraphic, Fraktur, andBold Symbol tags
automatically start mathematics. If you apply one of these tags to a
selection, the selection is changed to mathematics even if it was origi-
nally text. If you apply one of the tagswithout havingmade a selection,
the next thing you enter will be mathematics. Calligraphic and Black-
board Bold are valid only for uppercase letters.
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Entering and Editing Mathematical Objects

ăe Bold and Bold Symbol text tags have similar names but dif-
ferent behaviors. ăe Bold tag is for text; it doesn’t start mathematics.
If you apply the Bold tag to a selection in mathematics, the program
bolds the selection and changes the mathematics to an upright font.
On the other hand, the Bold Symbol tag automatically starts mathe-
matics, bolding the informationwhilemaintaining correctmathemat-
ical formatting.

Toapply a text tag tomathematics
1. Select the mathematics you want to tag.

2. Click the tag you want on the Text tag list.

To remove a text tag frommathematics
1. Select the mathematics.

2. Click the (normal) tag on the Text tag list.

Entering and Editing Mathematical Objects
Entering mathematical objects such as fractions, subscripts, radi-

cals, and operators with limits is as straightforward as entering sim-
ple symbols and characters. Mathematical objects are available on the
Math toolbar and also from the Insertmenu. Many also have keyboard
shortcuts and some are available from the alternate Symbol keyboard.

Entering and Editing Objects with Templates
When you enter amathematical object in your document, the pro-

gram inserts an expanding template representing the object and places
the insertion point inside it in an input box so you can complete the
object. Until you move the insertion point outside the template, any-
thing you enter becomes part of the mathematical object. ăe input
boxes appear in the program window if you turn on Input boxes from
the View menu.

Depending on the object it represents, a templatemay have several Note
input boxes, such as for limits. Some input boxes are hidden.

Templates expand as necessary. Bracket and radical templates ex-
pand both horizontally and vertically to encompass their contents;
fraction bars extend as far as necessary to encompass the longest string
of characters within the fraction; and matrix cells expand as needed.
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Chapter 5 | Working with Mathematics

Toenter amathematical object
Choose Insert →MathObjects and then choose theobject youwant.
ăe program inserts a template representing the object and places

the insertion point in the template so you can complete the object.

Tomove the insertionpoint outside amathematical object
Press spacebar or right arrow repeatedly until the insertion point

moves outside the template. Youmay also click themouse to the right
of the template.

Entering Fractions and Binomials
ăe program treats fractions and binomials similarly, automati-

cally extending the bar of a vertical fraction or binomial as far as nec-
essary to encompass the entire fraction. By default, the numerator and
denominator are set in a small-size font for inline mathematics.

Toenter a vertical fraction
Choose Insert →Math object and then choose Fraction.
ăe program treats binomials, the Legendre symbol, and Euler

numbers as generalized fractions. ăe appearance of delimiters and
fraction lines and the size of the numerator and denominator aremod-
iđable.

Toenter a binomial or generalized fraction
1. Choose Insert →Math object and then choose Binomial

2. Select the leĕ and right delimiters you want, if any.

If you don’t want delimiters, uncheck With Delimiters.

3. Make any necessary changes to the fraction line and size.

4. Click OK and then enter the expression.

Entering Radicals
By default, the program enters a radical with the insertion point

underneath. You can open an additional input box to enter a root.

Toenter a radical
Choose Inserst →Math object and then choose Radical.

Toadd a root to a radical
Enter a radical and press Tab.
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Entering Subscripts and Superscripts
ăe program automatically uses a smaller size type for subscripts

and superscripts, which are available from the Insert menu and the
Math toolbar. You can enter them quickly with keyboard shortcuts.
Aswithothermathematical templates, you can apply the subscript and
superscript templates to selections.
Toenter a subscript

Choose Insert →Math object and then choose Subscript.
Toenter a superscript

Choose Insert →Math Objects and then choose Superscript.
If you enter anew subscript or superscriptwhen the insertionpoint

is inside an existing subscript or superscript, the program adds a new
object. However, if the insertion point is outside and to the right of an
existing subscript and you enter a new subscript, the program moves
the insertion point into the existing subscript instead of creating a new
one. Similarly, if the insertionpoint is outside and to the right of an ex-
isting superscript and you enter a new superscript, the programmoves
the insertion point into the existing superscript instead of creating a
new one.
Toapply a subscript or superscript template to a selection

Select the mathematics and enter a subscript or superscript.
Toenter an expressionwith a simultaneous subscript and superscript

1. Enter the expression.

2. Enter the subscript and press Tab.
ăeprogram creates a superscript and places the insertion point
in it.

3. Enter the superscript.
Alternatively, you can enter the superscript đrst.

4. Press spacebar or right arrow to move the insertion point back
to the baseline.

Entering Operators and Limits
A number of mathematical operators are available from the Oper-

ators dialog box. Others, such as ∑ and ∫, are also available from the
Math toolbar. Inline operators are set in small type; displayed opera-
tors are set in larger type.
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Toenter amathematical operator
1. Place the insertionpointwhere youwant the operator to appear.

2. Choose Insert →Math Objects →Operator. ăe Operators dia-
log box appears.

3. Select the operator you want and change the size as necessary.

4. Click OK.

You add limits to operators by entering subscripts and superscripts.
Bydefault, when theoperator is inline, limits are set to the right. When
an operator is displayed, limits are set above and below. ăe exception
is the integral operator, for which limits are always set to the right.

Toenter limits for an operator
1. Enter the operator.

2. Enter a subscript and type the lower limit.

3. Press Tab.

4. Type the upper limit.

5. Press spacebar or right arrow to move the insertion point back
to the baseline.

Some operators require multiline limits.
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Toenter amultiline limit
1. Enter the operator.

2. Enter a subscript or superscript.

3. Type the đrst line of the limit.

4. With the insertion point at the end of the limit, press Enter.

5. Type the next line of the limit.

6. Press spacebar or right arrow to leave the limit.

Entering Brackets
ăe program has two kinds of brackets. Standard brackets, which

you type from any standard keyboard, can be entered singly and don’t
change in size to encompass their contents. In contrast, expanding
brackets are available fromthe Insertmenuand theMath toolbar. ăey
are always entered in matched pairs. As the name implies, expanding
brackets are elastic, expanding or contracting with their contents.

You can complete thepair of bracketswith an emptybracket. Empty
brackets don’t appear in print. ăey are shown as vertical dotted lines
in the Brackets dialog box and, if you have turned on View →Helper
Lines, in the program window.
Toenter expandingbrackets

1. Choose Insert →Math Objects and choose Brackets.

2. From the Brackets dialog box, select the leĕ and right brackets
you want.

3. Click OK.

Toenclose an existing expression in expandingbrackets
Select the expression and enter the brackets.

Entering and Editing Matrices and Vectors
A matrix is a rectangular array; a vector is a matrix with one col-

umn or one row. You can perform computations with matrices and
vectors in SWP and SNB, but remember that computations aren’t
possible with tables, because they are not mathematical objects, even
if they contain mathematics.

ăe cells of a matrix or vector are elastic and expand to encompass
their contents. To work with a matrix or vector more easily, you can
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outline the cells on the screen with the View →Helper lines command;
the outlines don’t appear in print.

Matrices and vectors can be placed inline or in displays.
Toenter amatrix

1. Choose Insert →Math Objects and choose Matrix. ăe Matrix
dialog box appears.

2. In the Matrix dialog box, drag the mouse then click to describe
the matrix you want, or enter the number of rows and columns.

3. Click OK.
ăe program places the insertion point in the top leĕ cell of the
matrix.

4. Enter the contents of the cell and press Tab to move to the next
cell.

5. When the matrix is complete, press spacebar or right arrow to
leave the matrix.

Options for editing matrices are more varied than for other math-
ematical objects. Once you’ve created a matrix, use the context menu
(right-click) to change its dimensions by adding or deleting rows and
columns, changing the alignment of its contents or baseline, andmod-
ifying the delimiters.

Entering Math Names
ăe program deđnes a special set of multicharacter math names.

ăemathnames includemany commonvariables, operators, and func-
tions, such as log and sin, that have meaning for the computational
engine. (See Doing Mathematics with ScientiĖc WorkPlace and Scien-
tiĖc Notebook for detailed information.) You can also create your own
math names. Entering a math name automatically starts mathematics.
Math names appear in the program window in gray upright text.

Many of the math names deđned in your program installation are
alsodeđned as automatic substitution sequences. You canworkquickly
by entering these sequences directly from the keyboard. When auto-
matic substitution is turned on, the program recognizes math names
automatically as you type them. For example, the math name cos is
deđned as an automatic substitution sequence. When you type cos

in mathematics, the co appears on the screen in italics until you type
the s, and then the entire functionname changes to upright, gray text.
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ăe program has substituted the function for the three-character se-
quence.
Toenter a recognizedmathname

1. Choose Insert →Math Objects and choose Math Name. ăe
Math Name dialog box appears.

2. Scroll through the Name list in the Math Name dialog box to
select the name youwant, or type the name in the box at the top
of the Name area.

3. ClickOK.ăeprogram inserts the namedirectly into your doc-
ument.

Some math names, such as max and lim, can have limits. When a
math name is inline, the program places the limits to the right. When
the math name is displayed, the program places the limits above or
below.
Toadd limits to amathname

1. Enter the math name.

2. Use the Subscript or Superscript command to enter the limits.

In addition to using predeđned math names, you can create your
own multicharacter variable names for use in mathematics. ăe pro-
gram can automatically recognize the math names you create if you
deđne them as automatic substitution sequences. If you designate a
math name as an operator, you can also designate the placement of its
limits, if any. With SWP and SNB, you can use math names in com-
putations. For example, you can create the names Force, Mass, and
Acceleration, and assign a value to Mass and Acceleration. ăen,
you can use the math names to write the equation

Force=Mass×Acceleration

and compute the value of Force. However, if you start mathematics
and enter the words Force, Mass, and Acceleration without having
đrst deđned them as multicharacter variable names, the program con-
siders each letter in each word to be a variable.
Tocreate amathname

1. Choose Insert →Math Objects →Math Name. ăe Math Name
dialog box appears.

2. Enter your unique math name in the text area at the top leĕ.
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3. Choose the type of name to create.

4. Choose the kind of operator limit placement.

5. Choose whether to support auto-substitution.

6. Click Add. ăe new math name is added to the list of choices.

If you clickOKtodismiss thedialogbox, thenewly createdmathname
is added at the insertion point. If you click Cancel, it is not.

Entering Decorations and Labeled Expressions
You can add decorations including wide accents, bars, arrows, and

boxes above, below, and around expressions. Additionally, you can
add labels above and below expressions. When you enter a decora-
tion or a label, the program creates a template with two parts: the
expression to be decorated or labeled and the decoration or label it-
self. Decorations are elastic; they expand to encompass the expression
they decorate. Labels are set in small type.

Toenter a decorationor label
1. Choose Insert →MathObjects and then chooseDecoration. ăe

Decorations dialog box appears.

2. Select the template for the decoration or label you want and
click OK.

ăe program inserts a template for the decoration or label you
selected.
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3. If you entered a decoration, complete the expression.

If you entered a label, enter both the expression and the label.
Press Tab to move between the two.

4. Press Spacebar or Right arrow to leave the expression.

Toapply a decorationor label to an existing expression

Select the expression and enter the decoration or label.

Entering Horizontal Space in Mathematics
Because the program automatically provides appropriate spacing

for mathematics, you don’t need to use the spacebar to type horizon-
tal spaces in mathematics. In fact, by default the spacebar doesn’t add
space when the insertion point is in mathematics. Occasionally, how-
ever, you may want to add extra space to an expression. Additionally,
you can enter positive and negative custom space, which the program
applies when you typeset your document. You can indicate places in
an expression where a break is appropriate, required, or prohibited.

Toenter a horizontal space inmathematics

1. Choose Insert →SpacingObjects and chooseHorizontal Spaces.
ăe Horizontal Spaces dialog box appears.

2. In the Horizontal Spaces dialog box, select the space you want
and click OK.

Entering Units of Measure
In SWP and SNB, you can add units ofmeasure for physical quan-

tities tomathematical values. You can convert the values fromoneunit
of measure to another and perform computations on equations con-
taining values that have units of measure. Also, you can enter com-
pound unit names, such as ((ĕ )/(s )) or ĕ lb, by writing them as frac-
tions or products. You can enter a unit ofmeasure fromtheUnitName
dialog box. You can also enter units using automatic substitution; a
number of units are predeđned.
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To enter units of measure Type
hour symbol h uhr
meter symbol and its derivatives m ume
angstrom symbol Å uan
Columb symbol C uCo
Tesla symbol T uTe
Liter symbol l uli
symbols for ohm and ist derivatives Ω uohm
degrees Celsius ◦C ucel
degrees Fahrenheit ◦F ufahr
degree symbol (plane angle) ◦ udeg
(degree) minute ′ udmn
(degree) second ′′ uds
pound-force lbf ulbf
pound-mass lb ulbm

Although you can enter units of measure by typing them as text Note
or by using symbols or characters available from the symbols palettes,
units entered in these ways have no computational value.

Toenter a unit ofmeasure
1. Start mathematics and enter a value.

2. Enter the unit:

Type u followed by the symbol for the unit you want.

OR

Choose Insert →Math Objects →Unit Name... ăe Unit Name
dialog box appears.

3. Select ameasurement category and a unit, then click Insert. ăe
unit is inserted.

Entering and Editing Mathematical Displays
By default, the program enters mathematics on the same line as

text, but you can createmathematical displays that appear centered on
a separate line. You can also change inline mathematics to displayed
mathematics, and vice versa.

SeveralViewmenucommandshelp youworkwithdisplayedmath-
ematics. If you check Helper lines, the program displays a box out-
lining the display. If you check Input boxes, the program displays

80



i
i

“CreatingDocs60” — 2011/12/19 — 10:43 — page 81 — #89 i
i

i
i

i
i

Entering and Editing Mathematical Objects

outlines for the template input boxes. ăese outlines don’t appear in
print when you typeset.

ăeprogramcorrectly formats displayedmathematics, but youmay
want to add custom equation numbers or custom labels. A display can
have a key, or unique name, so that you can create automatic cross-
references or hypertext links to the display fromelsewhere in your doc-
ument.

Tocreate amathematical display

Choose Insert →Math Objects and choose Display.
ăe program centers an input box for a display on a new line and

places the insertion point inside the display in an input box so you can
enter your mathematics.

Todisplay inlinemathematics

1. Select the mathematics to be displayed.
2. Create a display.
ăe program places the selection in a new display, formatting the

size and position of mathematical elements appropriately.

About Automatic Equation Numbers
SWP, SW, and SNBcan automatically number the displayed equa-

tions in your document. By default, the program numbers displayed
equations, but you can change the default using the Document For-
mat dialog box.

a2 +b2 = c2 (5.1)

Adding Custom Equation Numbers and Labels
Instead of numbering a display automatically, you can give the dis-

play a custom number or use text to label it. If automatic numbering
is turned on in SWP or SW, the custom numbers and labels you enter
replace the automatically generated numbers.

Toadd a customnumber or label to amathematical display

1. Right-click the automatic number for the display and choose
Equation Array Properties from the Properties submenu of the
context menu. ăe Display Properties dialog box appears.
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2. Enter information todeđne the customernumber/label and click
OK. ăe number is changed to your entered values.

Entering Theorem Statements
ăe program creates theorems, corollaries, lemmas, axioms, and Note

Not all shells support theorem tags.other theorem-like statements with tags. ăeorem tags aren’t avail-
able in all shells. If you need to include theorem statements in your
document, make sure the shell you use includes the tags you need.

If you have SWP or SW, you can number theorem statements au-
tomatically. When you typeset, the program automatically formats
and numbers any theorems and, if you’ve created keys for the theo-
rems, creates any cross-references to them. ăe typesetting speciđca-
tions formost shells number theorems sequentially throughout a doc-
ument and display cross-references as the number of the theorem.

Once you’ve created a theorem, you can add an explanatory label
for it.
Toenter a theorem statement

1. Place the insertion point at the end of the paragraph that is to
precede the theorem statement and press Enter.

2. Apply the theorem tag you want.

ăe program indicates the tag by placing a corresponding word,
such as ăeorem or Corollary in a lead-in object at the begin-
ning of a new paragraph.
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3. Type the statement of the theorem and press Enter.

Toconvert one ormore existing paragraphs to a theorem statement
1. Select the paragraphs.

2. Apply the theorem tag you want.

3. If the selection included more than one paragraph, delete the
lead-in object at the start of each continuation paragraph to
avoid creating a series of separate theorem statements.

Using Fragments to Enter Mathematics
ăeprogramcontains predeđned fragments formathematical con-

stants, expressions, and theorems. ăe instructions given for entering
text fragments in the previous chapter apply to entering/editingmath-
ematical fragments. Fragments are shown on the sidebar.

When you import a mathematical fragment, the program pastes
its contents into your document at the insertion point, toggling be-
tween text andmathematics as necessary. Youdon’t have to startmath-
ematics đrst.
To import a fragment

1. Place the insertion point where you want the fragment to ap-
pear.

2. On the Fragments pane, select the fragment youwant and press
Enter, or drag the fragment to your document.

As with text, you can create any new mathematical fragments that
you need. When you create a fragment, the program saves it by default
with an extension of .frg in the fragments folder of your user prođle.
If you prefer, you can create subfolders for your fragments. If you save
fragments outside the prođle/fragments folder tree, they will not ap-
pear in the sidebar list. Any fragments that you save while working in
one document are available to all other documents.
Tocreate a fragment containingmathematics

1. Ensure the Fragments pane is visible on an open sidebar.

2. In your document, select the information you want to save and
drag it to the sidebar. ăe Enter Fragment Name and Descrip-
tion dialog box appears.

3. Enter a name and description for the fragment and click OK.

83



i
i

“CreatingDocs60” — 2011/12/19 — 10:43 — page 84 — #92 i
i

i
i

i
i

Chapter 5 | Working with Mathematics

Using Automatic Substitution to Enter Mathematics
You can enter mathematics quickly using automatic substitution.

When automatic substitution is turned on and the insertionpoint is in
mathematics the program replaces special sequences of letters or num-
bers that you enter with predeđned mathematical expressions.

Automatic substitution of mathematics works like automatic sub-
stitution for text. You activate it for mathematics just as you do for
text, using the Autosubstitution dialog box accessed via Tools →Auto
Substitution. Using this dialog box, you can view the various pre-
deđned mathematical auto substitution sequences. For more infor-
mation on auto substitution in general, consult the previous chapter.

Information for Power Users

Hints and Suggestions
Use the spacebar to advance through an expression.

Shortcuts
ăefollowing table shows shortcuts and accelerators for commands

covered in this chapter.
Command Shortcut

Toggle text/math Ctrl+m or Ctrl+t

Enter fraction Ctrl+/ or

Insert radical Ctrl+r or

Insert superscript Ctrl+h, Ctrl+ or

Insert subscript Ctrl+l, Ctrl+ or

Insert display Ctrl+d or
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Final Touches: Document

Production

Virgil is related to have poured out a great number of lines in the morning, and to have passed the day in reducing them to fewer.
Samuel Johnson (1709–1784), Dryden (Lives of the Poets)

S cientiĖcWorkPlace (SWP), ScientiĖcWord (SW), and ScientiĖc Understanding Differences in
Document Production

Readying a Document for
Production

Previewing and Printing a
Document

Creating Documents for the Web

Information for Power Users

Notebook (SNB) offer different ways to produce printed doc-
uments. With SWP and SW, you have different ways to pro-

duce printed documents. With SWP and SW, you can typeset with
LATEX when you want to create formatted documents with automati-
cally generated cross-references, citations, numbered elements, tables
of contents, and other document elements. When you don’t need
typeset formatting or when you’re using SNB, you can directly pro-
duce documents without TEX.

ăis chapter looks at various aspects of preparing a document for
đnal production: adding index and bibliographic entries, spell-check-
ing, making overall formatting adjustments, and the like. It also ex-
plains the important differences between the two methods of docu-
ment production and provides detailed information about using di-
rect previewing and printing. Finally, the chapter shows you how to
prepare documents for use on the web.

Understanding Differences in Document Production
Whether or not you typeset, you can create appealing documents

with SWP, SW, and SNB. Understanding the differences in the docu-
ment production methods will help you decide when to use each one.
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About Typesetting
When you typeset your document, SWPor SWpreviews or prints

yourdocument aĕer compiling it. (Typesetting isn’t available inSNB.)
ăe compilation process invokes TEX to provide automatic hyphen-
ation, kerning, ligatures, sophisticated paragraph and line breaking,
sophisticated mathematics layout, and other đne formatting features.
It also provides automatic generation or placement of document el-
ements including tables of contents, lists of đgures and tables, cross-
references, footnotes and margin notes, automatically numbered sec-
tions and equations, indexes, and bibliographies.

InVersion 6, TEX typesetting yields a PortableDocument Format,
or  đle that contains your typeset document embedded with all
necessary fonts andwith graphics that have been converted. Note that
the previewed or printed appearance of your document depends on
speciđcations initially set by the document shell. ăese speciđcations
have no effect on your document when you don’t typeset it.

You can override options speciđed by the shell and set others us-
ing the Document Format dialog box accessed via the Typeset menu.
Information on doing so is given later in this chapter.

About Direct Production
Whenyouuse direct previewor direct print instead of typesetting,

the appearance of your document depends on speciđcations in the .css
đle, which are initially set by the document shell you choose. ăese
speciđcations have no effect on your document when you typeset it,
although they do control how the document appears on theWeb. You
canmodify the speciđcations as needed using theCSSEditor accessed
via the Tag menu.

Whenyouproduce yourdocumentwithout typesetting it, thepro-
gram sends the document to a previewer or to the printer using many
of the same routines with which it displays the document in the pro-
gram window. ăat means that what you see in the preview window
or on paper is similar to what you see as you work on your document.

Because the programwindowdoesn’t reĔect the page setup speciđ- Note
cations or the print options, you don’t see page breaks, margins, head-
ers, footers, or page numbers on the screen unless you use Print Pre-
view.
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Differences in the Final Product
We emphasize that producing your document with and without

typesetting yields noticeably different results. While direct produc-
tion yields a document similar in appearance to what you see in the
programwindow, typesetting your document usually yields an appear-
ance much different.

If you have SWPor SW,we suggest you follow these general guide-
lines to choose how to produce your document:

• When a đnely typeset document appearance is a high priority,
typeset preview or typeset print the document with pdfLATEX
or X ETEX.

• When a đnely typeset appearance and automatically generated
document elements aren’t a priority, when you need output
quickly, or when you’re producing for Web viewing, use direct
print.

Readying a Document for Production
Once you understand the differences between direct and typeset

production, you can begin getting a document ready for completion.
ăis includes adding items such as index entries and cross references,
preparing a bibliography, and adjusting the document’s appearance.

Adding Typeset Objects
Version6gives you the tools to easily create indexes, cross-references,

and citations. Commands for creating all such entries are foundon the
Insert menu.

Index Entries
Add index entries to a document using the Index Entry dialog box

accessed via Insert →Typeset Objects.
If you wish to specify different item levels, you can use the Sec-

ondary and Tertiary index entry đelds. For example, if the primary
entry is Files, the secondary entry might be Opening, and the tertiary
entry might be With Scientiđc Workplace. ăis allows you to create
indexes that are organized and easier for a reader to search. For in-
stance:
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Files
Opening

with Scientiđc Workplace
with another program

Saving

Toadd an index entry
1. Move the insertion point to the location you wish to index.

2. Choose Insert →Typeset Object →Index Entry. ăe Index Entry
dialog box appears.

3. Choose and enter the form for the Primary Index Entry and the
Secondary and Tertiary entries, if desired.

4. Specify the locator (page number or cross-reference) and the
style.

5. Click OK. ăe entry is created.
ăe appearance of the index itself is controlled by your docu-
ment shell and by settings in the Document Format dialog un-
der the Typeset menu. For instance, you can choose whether
to actually display an index and also whether to show entries in
your draĕ (working) document.

Cross-References
Cross-references are useful tools to point readers in the direction

of material elsewhere in a manuscript that has bearing upon the topic
immediately at hand. Cross-references in Version 6 are deđned based
on keys that youmust previously deđne using the InsertMarker dialog
box.
To insert a cross-reference

1. Move to the location you want to reference. Access the Marker
dialog box, enter the desired key for the location, and clickOK.

2. Move the insertionpoint to the location for your cross-reference.
Choose Insert →Typeset Object →Cross Reference. ăe Cross
Reference dialog box appears.

3. Choose the previously deđned key from the Key drop-down
list.

4. Choose whether to use a page number or an object counter.

5. Click OK. ăe cross-reference is established.
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Preparing a Bibliography
Bibliographies, or reference lists, usually appear at the endof a doc-

ument. ăe body of the document can contain citations, which are
cross-references to the individual items in the bibliography list. When
you typeset your document, the formatter automatically generates the
cross-references between the citations and the bibliography item to
which they refer. ăe appearance of the bibliography and the cita-
tions depends on the typesetting speciđcations for the shell. You can
create a bibliography manually or automatically using BTEX.
Creating Manual Bibliographies

A manual bibliography, which works just like a series of
cross-references, is convenient when the list of references is short and
you don’t plan to use those references in other articles or books. You
must format entries yourself, a disadvantage if you later decide to
change the style of the bibliography to suit a different requirement.
For example, if you format the bibliography of an article for a journal
that requires book titles in italics, then later decide to submit the ar-
ticle to a different journal that requires those same titles in boldface,
you must make the format changes manually.
Toestablish amanual bibliography

1. Choose Typeset →Bibliography Choice... ăe Bibliography
Choice dialog box appears.

2. Choose Manual entry.

3. Click OK.

Tocreate a list of bibliography items
1. Move the insertion point to the end of the line that is to precede

the bibliography and press enter.

2. In the paragraph tag menu, choose the tag bibitem. ăe pro-
gram displays a dialog box so that you can assign a key and an
optional label to the item.

3. Enter a unique key for the item.
You use this name when you create a citation for the bibliogra-
phy item. Click the arrow next to the Key box to display a list
of keys already in use in your document, or press down arrow to
scroll through the list. ăe keys don’t appear when you typeset
your document.
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4. If you want the item to appear in the list with a label instead of
the number automatically generated for the item, enter the label
in the Label box.

ăe label can include mathematics. If you include a label for a
list item, the program continues sequential numbering with the
next list item. ăe label can also be used to create author/date
citations.

5. Choose OK.

In the document window, the key for the item appears in the
lead-in box.

6. Type the bibliographic information for the item, using text tags
to format the information correctly.

In the document window, the information appears next to the
lead-in box.

7. If youwant to create another bibliographic item, press enter and
repeat steps 3–6.

8. At the end of the bibliography, press enter to complete the last
item.

9. Choose Cancel and then apply the Remove Item Tag to com-
plete the list.

Tocreate a citation for amanually createdbibliography item
1. Place the insertion point where youwant the citation to appear.

2. Choose Insert →Typeset Object →Citation. ăeCitation dialog
box appears.

3. Enter the key for the bibliographic item you want to cite.

Click the arrow next to the Key box to display a list of all keys
deđned for the document.

4. If you want to add a comment to the citation, enter it in the
Remark box.

Comments, which can contain both text and mathematics, ap-
pear only when you typeset preview or print your document.
ăey don’t appear in the document window.
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5. Choose OK.

ăe citation is displayed on the screen in a small box containing
the word Cite and the key you entered. When you typeset the docu-
ment, the formatter creates the correct reference by replacing the key
with the number of the keyed bibliography item. If you also entered a
comment, it appears aĕer the number.

ăe typesetting speciđcations for the shell determine the citation
appearance in print.
Creating Automatic Bibliographies

You can create an automatic bibliographywith BTEX. ABTEX
bibliography is convenient if you have a long list of references that you
plan to use in other articles or books, because you don’t have to create
the bibliography list yourself. BTEX generates the list automatically
by extracting references from a database using the citations you insert
into your document. BTEX bibliographies, which are ASCII đles
that you create and edit with a standard text editor, can be used as of-
ten as you like in other documents. Also, you can change the appear-
ance of a BTEX bibliography automatically by specifying a differ-
ent bibliography style. Creating a BTEX bibliography involves these
steps:

• Creating or obtaining a BTEX database.

• Specifying a BTEX bibliography and bibliography style, and
inserting an instruction to include the bibliography.

• Creating a series of citations in the body of your document.

• Generating the bibliography.

When you typeset compile your document to generate a BTEX
bibliography, theprogrampasses thedocument throughBTEXwhich
generates the bibliography by extracting the cited references from the
database. ăe đle is formatted according to the speciđed bibliography
style. ăe next time you typeset the document, the formatter includes
the bibliography đle in the document, formatting the citations accord-
ing to the typesetting speciđcations.

Before you can create a BTEX bibliography for your document,
you must đrst create or obtain a database of bibliographic items in
BTEX form.
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Toestablish an automatic bibliography
1. ChooseTypeset →BibliographyChoice... ăeBibliographyChoice

dialog box appears.

2. Choose BibTeX.

3. Click OK.

To insert an instruction to include the bibliography
1. Move the insertion point to the end of the line that is to precede

the bibliography and press enter.

2. Choose Insert →TypesetObject →Bibliography to open the Bib-
TeX Bibliography dialog box.

3. Select the BTEX database đles containing your references.

You can select more than one database.

4. Select a BTEX style for formatting the references.

5. Choose OK.

ăe program inserts into your document a gray [BibTeX] box.

Creating a citation for a BTEX reference ensures that it will be
included in the bibliography list when you generate the bibliography.
You can also use the citation process to include a reference in the bib-
liography without citing it in the body of your document.

Specifying a BTEXbibliography changes theCitation dialog box
so that you can select citations fromaBTEXdatabase. If yourdatabase
of bibliography entries is very large, đnding the reference you want to
cite can be time-consuming. You can narrow your search by specifying
search criteria, or key đlters, for the database items, then choosing the
reference you want from among those that đt the đlters.

If you add the authordate1-4, chicago, or harvard package to your
document, you can create author/date citations for BTEX bibliogra-
phies.
Tocreate a citation for an item in aBibTeXdatabase

1. Place the insertion point in your document where you want the
citation to appear.

2. Choose Insert →Typeset Object →Citation. ăeCitation dialog
box appears.
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3. If the selected database is the one you want and you know the
key for the database item you want to cite, enter it in the Key
box. Otherwise, select thekey for the itemdirectly fromaBTEX
database:

a. Scroll the Database File list to select one of the databases
listed. If necessary, choose Select BibTeX Directory to
navigate to thedirectory containing yourBTEXdatabase.

b. Choose View Keys to display a Keys dialog box. ăe box
lists the keys for those items in the selected database that
satisfy the current search criteria.

c. Scroll the list to select the item you want.
If the item doesn’t appear on the list, change the search
criteria.

d. If you want to view the full text of the item, choose View
Entry.
ăe program displays the item in a BibTeX Database En-
try dialog box.

e. Choose Cancel to return to the list of keys.

4. When you have selected the item you want, choose OK to re-
turn to the BibTeX Citation dialog box.

5. If youwant to add a text comment to the citation, enter it in the
Remark box.

Comments appear only when you typeset, not in the document
window.

6. If you want the reference to be uncited—that is, you want it
to appear in the bibliography without a corresponding citation
in your document—check the box labeled Bibliography Entry
Only - No Citation.

7. Choose OK to return to your document.

ăe program inserts a citation for the item whose key you se-
lected.
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Adding a TEX Field
If you are prođcient with TEX, you can insert a TEX đeld wherever

you like to achieve certain special effects. For instance, the drop capital
letters used in this document were created with objects that reference
the lettrine package.

Toadd aTEXđeld
1. Choose Insert →Typeset Object →Tex Field. ăe Tex Button

Contents dialog box appears.

2. Enter a name for the đeld, if desired. ăis can make it easier to
locate đelds for reuse.

3. Specify whether it uses a speciđc package and any options for
that package.

4. Enter the code for the đeld.

5. Click OK. ăe TEX đeld is inserted.

ăe following illustration shows the dialog box as đlled out for
the dropped-capital đeld.
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Adjusting a Document’s Appearance
Although much of a document’s appearance is established by the

document shell, you have certain choices available to you for either
supplementingor overriding the shell defaults. You can choose to spec-
ifyTEXoptions and addpackages to give you additional formatting ca-
pabilities. You can also use the Document Format dialog box to over-
ride default options and set preferences for how a document appears.
In Version 6, virtually all of the ways to set a document’s appearance
outside of shell choice are controlled with the Document Format di-
alog box.

Using Options and Packages
To specify shell and package options, and to call for the use of de-

sired packages, use the Options and Packages dialog box accessed via
the Typeset menu.

Tomodify document class options
1. Choose Typeset →Options and Packages... ăe Options and

Packages dialog box appears.

2. On the Class Options tab, click Modify. ăeClassOptions di-
alog box appears.
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3. Click a category on the leĕ to see the options available for that
category. Click an option on the leĕ to select the option you
want for that category. In the dialog shown above, the 10pt.
option has been selected for the body font point size.

4. Click OK on the ClassOptions dialog.

5. Click OK on the Options and Packages dialog. Your choice is
put into effect.

Tomodify package options
1. ChooseTypeset →Options andPackages. ăeOptions andPack-

ages dialog box appears.

2. Click the Package Options tab.

3. Click to set a package in use.
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4. Click Modify Packages to access the Modify packages dialog
box. Make desired changes and click OK.

5. ClickOKon theOptions andPackages dialogbox toput changes
into effect.

Toadd apackage
1. ChooseTypeset →Options andPackages. ăeOptions andPack-

ages dialog box appears.

2. Click the Package Options tab.

3. Click Add Package... ăe Add Package dialog box appears.

4. Click in the list to choose the package to add.

5. Click OK.

6. If desired, select package options for the package you just added.

7. Click OK on the Options and Packages dialog box.

Setting the Document Format
Version 6 has centralized almost all of a document’s appearance

options in the Document Format dialog box. Using this dialog, you
may:

• Specify font choices for speciđc contexts

• Control the appearance of front-and backmatter items.

• Set thedocumentmargins, page size, andother page layout items

• Set the appearance of headers and footers

• Choose footnotes or endnotes

• Turn sectionnumbering on andoffand specify the style of num-
bering to use

• Set the number of columns

and much more.
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To set document formatting
1. Choose Typeset →Document Format. ăe Document Format

dialog box appears.

2. When the dialog boxđrst appears, options on the đrst three tabs
are likely to be grayed out. To specify that you want to be able
to change them, click the relevant override checkbox at the top
of the tab.

3. If you wish to use OpenType fonts or Unicode for a variety of
languages, click the X ELATEX option.

4. ăere are tabs for general settings, page layout, fonts, and sec-
tions. Make your desired choices for each tab.

5. Click OK to put your choices into effect.
Your changeswill appear in the typeset versionof thedocument. Note
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Previewing and Printing a Document
ăe previous notes about typeset vs. direct production apply to

printing.

Direct Preview and Print
You can preview and print without typesetting in SWP, SW, and

SNB.ăeprogrampreviews or prints your document according to the
style, print options, and page setup speciđcations in effect for the doc-
ument, and the page orientation and paper size speciđcations in effect
for the default printer.

When you preview or print without typesetting, you can set op-
tions to turn on or off certain items such as helper lines and invisibles.
You can also print using the zoom factor in effect for the programwin-
dow or using a different zoom factor that you set, which can be use-
ful when creating presentation materials. If you have a color printer,
you can enable the color printing of lines, text, and backgrounds. ăe
print options available are controlled from the Print Options tab in
theDocument Infodialog boxon theFilemenu. Remember that these
options don’t affect typesetting in any way.

Topreview andprint a documentwithout typesetting
1. Choose File →Print Preview →Direct print preview. ăe docu-

ment window changes to the direct print preview mode.

99



i
i

“CreatingDocs60” — 2011/12/19 — 10:43 — page 100 — #108 i
i

i
i

i
i

Chapter 6 | Final Touches: Document Production

2. You may change page setup and page orientation options if de-
sired.

3. To print the previewed document, click the Print button. ăe
Print dialogbox appropriate to yourprinter appears, fromwhich
youmay specify further options and begin the printing process.

Typeset Preview and Print
WithVersion 6, obtaining a typeset preview is easy. You need only

click the  Preview tab at the bottom of the document window. If
you have edited your document since the last such preview, your doc-
ument is compiled and a new .pdf đle is generated. You may directly
print this .pdf if you wish.
Toprint a typeset document

1. Choose File →Print → Print... Your document is compiled
and the display changes to the  Preview.
ăe printer and disk icons at the top leĕ of the  display Tip
(above Bookmarks) allow you to print and save the .pdf đle out-
side of the program.

2. Click the printer icon at the upper leĕ corner of the  display
to access the print dialog box. From here you may specify print
options and send the job to the printer.

Creating Documents for the Web
Youcanproducedocuments for use online aswell as inprint. With

Version 6, the variety of formats available for online use makes it easy
to share your documents across platforms, installations, and systems,
on a network or on the Web.

When you create information for use online rather than in print,
the information doesn’t have to be contained in a single linear docu-
ment. Instead, from any place in your information, you can include
hypertext links, or jumps, that point readers to key ideas, related top-
ics, and supplementary material located inside or outside your docu-
ment.

Creating Hypertext Links
You can create hypertext links to information located in the same

document, in other SWP, SW, and SNB documents on the current
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systemor network, or in documents on theWeb. Hypertext links have
two parts: the link and the target. ăe link creates a pointer to a target
and deđnes how that pointer appears in your document. By default,
text for hypertext links appears in the document window in color and
in print as ordinary text.

ăe target can be a đle, including đles on the Web, or an object
in a đle—such as a đgure, a section, or equation in SWP, SW, or SNB
documents—to which you’ve assigned an identifying key or marker.
Speciđcally, you can create links from your document to

• A marker elsewhere in the current document.

• A different document located on your computer or network,
or a marker in that document.

• Any URL location or đle on the Web.

ăe link speciđes the address of the target. ăe formof the address
differs depending on the target itself and following the model used in
standard Web browsers.

When you want to link to a place within the current document,
you must đrst establish a marker to which to link.

Toadd amarker for a future hyperlink
1. Click to move the insertion point to the place where you’d like

to be able to link.

2. Choose Insert →Marker... ăe InsertMarker dialog box appears.

3. Provide a unique name for the link.

4. Click OK. ăe marker is added at the insertion point.

Markers may be used for hyperlink and for cross-reference des-
tinations

Tocreate a hyperlink to amarked location
1. Click to place the insertion point where you want the link to

appear.

2. Choose Insert →Hyperlink. ăe Hypelink dialog box appears.
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3. Enter text to display for the link, if desired.

4. Select the marker to which to link from the Marker or anchor
pop-up list.

5. Click OK.

Using the Link Location đeld, you can specify an external web
page to which to link. Clicking Choose File... allows you to specify
a location in an external đle.

Exporting Web Documents
Exporting your SWP, SW, or SNB documents as web đles pro-

vides a way for others to view your documents on a variety of plat-
forms via the Internet. ăeWeb export feature in Version 6 provides a
fast way to create accurate  versions of your SWP, SW, or SNB
documents. ăe đles can be viewed with recent versions of the most
popular browsers, provided they displayMML(if your document
contains mathematics). Several export formats are available.

When you export documents as  đles, the program uses de- Note
The program no longer saves mathematics as
graphics. html5-compliant browsers will
display math, as will Firefox or Internet
Explorer with the Math Player plug-in
installed.

fault formats for graphics used to represent mathematics, plots, and
graphics. Also by default, the đlter exports any graphics contained
in your document as PNG đles, saving them to a subdirectory of the
folder containing the  đle.

Whenyou export to, theprogramautomatically createsALT
text for each graphic in your document. By default, theALT text is the
full path name of the graphic.

Because  đles are designed for use online instead of in print,
the  đlter doesn’t create those document elements that are au-
tomatically generated when you typeset your document. ăose ele-
ments, which include indexes, tables of contents, section and equa-
tion numbers, and internal cross-references, don’t appear in the 
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đle you export. ăe  đlter completes any cross-references in the
document with the key for the cross-reference target instead of the au-
tomatically generated number for the target.

Toexport a document as anHTMLđle
1. With the document open, choose File →Export to Web... ăe

Export to Web dialog box appears.

2. Enter a name for the đle.

3. Choose whether the đle should be saved as a compressed đle or
as a set of uncompressed đles in a directory.

4. Click OK. ăe đle is exported.

Information for Power Users

Hints and Suggestions
As youwrite, pay attention to items that youmightwant to refer to

either with index entries or cross references. It’s easier to put markers
in as you write than it is to go back later.

Keep a list of the important terms and concepts in your document.
Such a ’project vocabulary’ is a useful tool later on when you’re build-
ing an index.
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Be sure and check out your print preview documents thoroughly,
particularly for pagination. ăis can save you time, trouble, and paper.

You can set your preferred default method (direct, .pdf ) for pre-
viewing and printing. Use the drop-down icon on the toolbar next to
the button for either command. Choose Select Default and then your
preferred method.

Shortcuts
ăe following shows shortcuts and accelerators for the commands

and capabilities covered in this chapter.
Command Shortcut

Print (default method) Ctrl+p or Alt f p or

Preview

Document Format Alt p d

Insert marker

Insert cross reference

Insert citation

Insert hyperlink

Insert index entry

Insert TEX đeld

104



i
i

“CreatingDocs60” — 2011/12/19 — 10:43 — page 105 — #113 i
i

i
i

i
i

A
Shortcut Reference

A complete list of all the shortcuts documented in the book is in-
cluded here.

Document Creation Shortcuts
Command Shortcut

Save Ctrl+s or Alt f s or

New Document Ctrl+n or Alt f n or

Open Document Ctrl+o or Alt f o or

õuit program Ctrl+q or Alt f q

Close Document Alt f c

Save As Alt f a

Revert Alt f v
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Appendix A | Shortcut Reference

Document Editing Shortcuts

Command Shortcut

Undo Ctrl+z or Alt e u

Redo Ctrl+y or Alt e r

Select All Ctrl+a or Alt e a

Cut Ctrl+x or Alt e t

Copy Ctrl+c or Alt e c

Paste Ctrl+v or Alt e p

Bold text

Italic text

Math Editing Shortcuts

Command Shortcut

Toggle text/math Ctrl+m or Alt i m

Enter fraction Ctrl+/ or

Insert radical Ctrl+r or

Insert superscript Ctrl+h, Ctrl+ or

Insert subscript Ctrl+l, Ctrl+ ?or

Insert display Ctrl+d or
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Document Production

Document Production Shortcuts
Command Shortcut

Print (default method) Ctrl+p or Alt f p or

Preview

Document Format Alt p d

Insert marker

Insert cross reference

Insert citation

Insert hyperlink

Insert index entry

Insert TEX object
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A
About

on Help menu, 35
accents

as decorations, 78
Actions menu, 37
adding white space, 11
addresses for hypertext links, 101
Advanced

on Tag menu, 31
alignment

matrix columns, 76
paragraphs, 53
tables, 63

allowbreak, 25
arrays, seematrices
arrow keys, 6, 65
arrows

as decorations, 78
from Symbol pane, 69

Automatic Substitution
on Tools menu, 33

automatic substitution, 5, 33, 57,
84

mathematics, 84
text, 57

axioms, 82

B
Babel, 10, 55
backmatter, 97
bars

as decorations, 78
bibliography, 89

automatic, 92
BTEX, 32, 92
manual, 32, 89
paragraph tag, 53

Bibliography Choice
on Typeset menu, 32

binomials, 72
blackboard bold, 59, 70
body math, 68
body tags, 53

applying, 53
body math, 68

bold, 59
on Editing toolbar, 36

boxes
as decorations, 78

brackets, 75
Breaks

on Insert menu, 25
breaks, 25

allowbreak, 25
line, 25, 86
paragraphs, 86

bullet lists
paragraph tag, 61

C
calligraphic, 59, 70
cells

column width, 24
deleting, 63
formatting, in table, 24
in matrix, 71
moving between, 63

characters
non-Roman, 55

Check Spelling
on Edit menu, 23
on Editing toolbar, 36

citations, see bibliography
class options, 95
Clean Up

on File menu, 18
Close
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in dialog boxes, 11
on File menu, 18
on symbol panes, 37

columns, 32, 97
in matrices, 76
in tables, 63, 65

commands
with keyboard, 11
with mouse, 11

compile
description, 100
PDF command, 100

computation
commands, 34
defaults, preferences, 33
MuPAD, 8

Compute menu, 34
Contents

on Help menu, 35
conventions, 10

mouse, 11
Copy

on Edit menu, 22
on Editing toolbar, 36

copying, 22
corollaries, 82
Count Words

on the Edit menu, 23
creating

documents, 41
mathematics, 67

cross-references, 86, 88
CSS Editor

on Tag menu, 31
customizing

automatic substitution, 58
breaks, 25
defaults, 33

Cut
on Edit menu, 22

on Editing toolbar, 36

D
decorations, 78
default settings, 33
Delete

on Edit menu, 22
dialog boxes, 11
dictionaries, see spell checking
Direct Print command, 99
direct printing, 86
display modes, 37
displays, 80
division tags, 53, 60

on Standard toolbar, 36
Document Format

on Typeset menu, 32
Document Info

dialog box, 42
on File menu, 20
print options, 99
save options, 21

documents
closing, 18
copying, 47
creating, 15, 41
export as LATEX, 46
format, 97
formatting, 32
new, 41
open, 16
opening, 44
opening existing, 44
opening one created with

earlier soĕware version, 45
portability, 4
print, 20
production, 85
save, 18
saving, 42

shells, 40
title, 42

DOM Inspector
on Tools menu, 33

E
Edit menu, 21
editing documents, 51
Editing toolbar, 36
emphasis, 59

on Text Tag menu, 59
entering mathematics, 67

automatic substitution, 76
body math tag, 68
changing text to math, 70
characters and symbols, 71
fragments, 83
math objects, 27
Math/Text toggle, 68

entering text, 54
characters and symbols, 54
fragments, 56
section headings, 60
tables, 63

equations, 79
numbering, 81

exit command, seeõuit
expanding operators, 71

brackets, 75
fractions, 72
matrices, 75
radicals, 72

Export TeX
on File menu, 17
to the web, 46

Export to Web
on File menu, 18

Extensions
on Tools menu, 33
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F
features

existing users, 2
new users, 9

File menu, 15
Find

on Edit menu, 23
Find Again

on Edit menu, 23
Find and Replace

on Editing toolbar, 36
Find Previous

on Edit menu, 23
fonts

improved, 6
non-Roman, 40
scalable, 6
size, 31
text tags, 53

Footnote
on Insert menu, 27

Footnotes
on View menu, 29

footnotes, see notes
forced breaks (line, page), 25
fractions, 72

button, 36
generalized, 69

fragments, 56, 83
creating
mathematics, 83
text, 57

deleting, 57
fraktur, 70
Frame

on Insert menu, 25
frames, 25, 64

inserting, 64
front matter tags

on Standard toolbar, 36

Function Keys
on Tag menu, 31

function keys
assignments, 60
changing assignments, 31

functions, seemath names

G
Go menu, 30
graphics, 24
Greek characters, 69

on Symbols palette, 54

H
hard breaks, see forced breaks
headers, 97
headings, 61
Help menu, 35
Helper Lines

on View menu, 29
horizontal space, 26, 79
HTML

on Insert menu, 28
Hyperlink

on Insert menu, 28
hyperlinks, 28, 100

target, 27
hyphen

discretionary, 56

I
Image

on Insert menu, 24
image, 24, 63
import

image, 24
TeX, 45
TEX, 17

Import TeX
on File menu, 17

Index

on Help menu, 35
Index Entries

on View menu, 29
indexing, 87

cross-references, 88
Input Boxes

on View menu, 29
Insert menu, 24
insertion point

and Math/Text toggle, 52
in tables, 63
moving, 53

integral
on Insert menu, 74
on Math toolbar, 36

Invisibles
on View menu, 29

italics
on Editing toolbar, 36
on Text tag menu, 53

item tags
bullet item, 61
numbered item, 61

J
JavaScript debugger

on Tools menu, 32

K
kerning, 86
keyboard conventions, 11

shortcuts, 48, 55, 66, 84,
105–107

L
labels

for equations, 81
for images, 64
in mathematics, 78

Legendre symbol, 72
lemmas, see division tags, 82
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License Information
on Help menu, 35

ligatures, 86
limits, 69, 73, 74
Line

on Insert menu, 24
line breaks, 25
lines, 24, 62
links, see hyperlinks
lists, 61

of đgures, 86
of tables, 86

M
MacKichan Soĕware Website

on Help menu, 35
macros, see automatic

substitution
margin notes, see notes
margins, 97
Marker

on Editing toolbar, 104
on Insert menu, 27

Markers
on View menu, 30

markers, 27, 30
Math

on Insert menu, 27
on Standard toolbar, 36

Math command
description, 68

math defaults
behavior, 68

math names, 76
Math Objects

on Insert menu, 27
math objects, 27, 71

on Math toolbar, 36
math symbols, see symbols
Math toolbar, 36

Math vs. Text, 68
Math/Text

default, 52
on Standard toolbar, 36
toggle, 52

mathematical displays
creating, 81
numbering, 81

mathematics
and fragments, 83
and text, 68
creating a paragraph, 68
displayed, 69
editing/entering, 67
formatting, 70
inline, 69
math/text toggle, 68
natural notation, 2
properties, 22
symbols, 37
tagging, 70

Mathematics Markup Language
(MathML), 102

matrices, 75
context menu, 76
editing, 76
entering, 76

Matrix
on Math toolbar, 36

measurement
units, 80

menus
commands, 14
conventions, 10
descriptions, 15, 21, 24, 28,

30–32, 34, 35
dialog boxes, 15

miscellaneous symbols, see
Symbols palette

modes

toggling between text and
math, 52

mouse conventions, 11
moving

cutting and pasting, 22
documents, 4
to a marker, 30
with toolbar buttons, 36

multiline limits, 75
MuPAD commands

on Compute menu, 34

N
navigation, seemoving

quick, 65
nested lists, 62
New Document

on File menu, 15
on Standard toolbar, 36

Normal Edit Mode
on View menu, 28

Note
on Insert menu, 27

notes, 64
footnotes, etc., 27
inserting, 65

numbered equations, 81
numbered lists, 61

entering, 61, 62, 79

O
online documents, 100

export defaults, 102
HTML đles, 102
hyperlinks in, creating, 101
markers, 101

online help, seeHelp menu, 35
Open File

on File menu, 16
on Standard toolbar, 36
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opening documents, see
documents

Operator
entering, 73
on Insert menu, 73
with limits, 74, 75

operators, 73
Options and Packages

on Typeset menu, 32
using, 95

Other Notes
on View menu, 29

output choices, see Preview
command

P
packages, 95
page

breaks, 25
formatting, 95
numbers, 86

Page Setup, 100
on File menu, 19

paragraph
Go To command, 30
tags, 53

paragraph or list tags
on Standard toolbar, 36

Paste
on Edit menu, 22
on Editing toolbar, 36

Paste Without Formatting
on Edit menu, 22

PDF đles, 86
creating, 100
hyperlinks, 100
print
on File menu, 19

typeset preview, 100
Polyglossia, 10, 55

portability across platforms, 2
Preamble

on Typeset menu, 32
preface, 53
Preferences

on Applications menu
(Macintosh), 33

on Tools menu, 33
Preview

on File menu, 19
on Standard toolbar, 36
on View menu, 28

Preview command
direct print, 86, 99
typeset PDF, 100

Print
on File menu, 20
on Standard toolbar, 36

Print command, seeDirect Print
command

printing
direct, 99
options, 19
typeset PDF, 100

program
compatibility, 2
defaults, 48
customizing, 33
Math/Text, 52

preferences, 33
setting, 48
window, 13
description, 3
display options, 37

Properties
on Edit menu, 22

properties
changing, 22

punctuation
special, 55

Q
õuit

on Application menu
(Macintosh), 21

on File menu, 21

R
Radical

on Insert menu, 72
on Math toolbar, 36

radicals, 72
Recent Files

on File menu, 18
Redo

on Edit menu, 22
on Editing toolbar, 36

references, see bibliography
Register

on Help menu, 35
registering the program, 35
remove section tag, 53
replace, see Find and Replace
Revert

on File menu, 19
REVTEX, 7
rows

adding horizontal space, in
matrix, 75

adding to matrix, 76
in tables, 63

S
Save

on File menu, 18
on Standard toolbar, 36

Save As
on File menu, 19

Save Copy As
on File menu, 19

saving options
automatic setting, 48
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new document, 18, 42
Search

on Help menu, 35
search, see Find and Replace
section

headings, 60
tags, 53

Select All
on Edit menu, 23

send, see Export TeX
shells, 9

choosing, 40
overriding defaults, 95
standard document, 41

shortcuts, see keyboard
conventions

Sidebars
on View menu, 29
use, 37

size options, see zoom
soĕware requirements, 10
space, 26

button, 36
Spacing Objects

on Insert menu, 26
spell checking, 6, 23

appearance, 23
on Editing toolbar, 36

square roots, see radicals
standard document shell, 41
Standard toolbar, 36
status bar, 37
structure or environment tags

on Standard toolbar, 36
Style

editing, 21
on File menu, 21

subscripts, superscripts, 73
substitution, see automatic

substitution

symbols
entering and editing, 54
math, 69
shortcuts, 54
toolbar buttons, 36

Symbols palette, 37
System Features

on Help menu, 35

T
Table

on Insert menu, 24
table of contents, 53, 86
Tables, 63

editing, 63
tables, 24
Tag menu, 31
tag properties

determined by document style,
40

tags
and mathematics, 68
and text, 53
applying, 53

technical support, 35
templates, seeMath toolbar
TEX

import, 17
in preamble, 32
seamless, 3

TeX đelds, 94
TeX File

on View menu, 29
TeX Log

on View menu, 28
Text

on Insert menu, 27
on Standard toolbar, 36

text
automatic substitution, 57

emphasizing, 59
fragments, 56
tagging, 53

text tag, 59
(normal), 59

text tags
on Standard toolbar, 36

Text vs. Math, 52
ăemes

on Tools menu, 33
theorem statements, 82
title page, 53
To Marker

on Go menu, 30
To Paragraph

on Go menu, 30
Toolbars

on View menu, 29
toolbars, 36
Tools menu, 32
troubleshooting, see technical

support
Typeset menu, 32
Typeset Object

on Insert menu, 27
typeset objects

inserting, 87
typesetting, 86

preferences, 33

U
Undo

on Edit menu, 21
on Editing toolbar, 36

Unit Name command, 79
units of measure, 79
user preferences, 33

V
vectors, 75
vertical space, 26
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View menu, 28

W
web documents

creating, 102
website, MacKichan, 35
Window menu, 34

word count, 23

X
XML Source

on View menu, 28
XML Tags

on View menu, 28

Z
Zoom

on View menu, 30
zoom, 30
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