
i
i

“Compute60” — 2011/12/20 — 14:27 — page i — #1 i
i

i
i

i
i

DoingMathematics
with Scientiöc WorkPlace

R⃝

& Scientiöc Notebook
R⃝

Version 6

by Darel Hardy
& Carol Walker



i
i

“Compute60” — 2011/12/20 — 14:27 — page ii — #2 i
i

i
i

i
i

Copyright ©2011 by MacKichan Soĕware, Inc. All rights reserved. No part of
this book may be reproduced, stored in a retrieval system, or transcribed, in any
form or by any means–electronic, mechanical, photocopying, recording, or
otherwise–without the prior written permission of the publisher, MacKichan
Soĕware, Inc., Poulsbo, Washington, USA. Information in this document is
subject to change without notice and does not represent a commitment on the
part of the publisher. ăe soĕware described in this document is furnished under
a license agreement and may be used or copied only in accordance with the terms
of the agreement. It is against the law to copy the soĕware on any medium except
as speciđcally allowed in the agreement.

Printed in the United States of America
10 9 8 7 6 5 4 3 2 1

Trademarks
ScientiĖc WorkPlace, ScientiĖc Word, ScientiĖc Notebook, and EasyMath are
registered trademarks of MacKichan Soĕware, Inc. EasyMath is the sophisticated
parsing and translating system included in ScientiĖc WorkPlace, ScientiĖc Word,
and ScientiĖc Notebook that allows the user to work in standard mathematical
notation, request computations from the underlying computational system
(MuPAD 5 in this version) based on the implied commands embedded in the
mathematical syntax or via menu, and receive the response in typeset standard
notation or graphic form in the current document. MuPad is a registered
trademark of SciFace GmbH & Co. KG. Acrobat is a registered trademark of
Adobe Systems, Inc. TEX is a trademark of the American Mathematical Society.
pdfTEX is the copyright of Hàn ăế ăành and is available under the GNU
public license. VCam is based on VRS, which is a product developed by Hasso
Plattner Institute of the University of Potsdam. Windows is a registered
trademark of the Microsoĕ Corporation. Macintosh is a registered trademark of
the Apple Corporation. Linux is a registered trademark of Linus Torvalds. RLM
is a registered trademark of Reprise Soĕware. Activation system licensed under
patent No. 5,490,216. All other brand and product names are trademarks of their
respective companies.

ăis document was produced with ScientiĖc WorkPlace. R⃝

Authors:Darel Hardy and Carol Walker
Manuscript Editor: JohnMacKendrick
Compositor:MacKichan Soěware Inc.
Designer: Patti Kearney
Printing and Binding: Malloy Lithographing, Inc.



i
i

“Compute60” — 2011/12/20 — 14:27 — page iii — #3 i
i

i
i

i
i

Contents

1 Basic Techniques for Doing Mathematics . . . . . . . . . . . . . . . . . . . 1

Conventions. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2
Inserting Text and Mathematics . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3
Basic Guidelines for Computing . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7

2 Numbers, Functions, and Units . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19

Integers and Fractions. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19
Elementary Number ăeory. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 21
Real Numbers . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 23
Functions and Relations . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27
Complex Numbers. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 32
Units and Measurements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33
Exercises . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 36

3 Algebra . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 39

Polynomials and Rational Expressions. . . . . . . . . . . . . . . . . . . . . . . 39
Substitution . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 47
Solving Equations . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 48
Deđning Variables and Functions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 59
Exponents and Logarithms . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 65
Toolbars and Keyboard Shortcuts . . . . . . . . . . . . . . . . . . . . . . . . . . . . 69
Exercises . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 70

iii



i
i

“Compute60” — 2011/12/20 — 14:27 — page iv — #4 i
i

i
i

i
i

Contents

4 Trigonometry . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 75

Trigonometric Functions. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 75
Trigonometric Identities. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 80
Inverse Trigonometric Functions. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 83
Hyperbolic Functions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 86
Complex Numbers and Complex Functions . . . . . . . . . . . . . . . 89
Exercises . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 93

5 Function Deđnitions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 99

Function and Expression Names . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 99
Deđning Variables and Functions . . . . . . . . . . . . . . . . . . . . . . . . . . . . .103
Handling Deđnitions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .115
Formulas . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .115
External Functions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .119
Trigtype Functions. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .122
Exercises . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .124

6 Plotting Curves and Surfaces . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .129

Getting Started With 2D Plots . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .130
Interactive Tools for 2D Plots . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .138
Graph User Settings . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .140
2D Plots of Functions and Expressions . . . . . . . . . . . . . . . . . . . . . .151
Creating Animated 2D Plots . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .165
Creating 3D Plots . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .171
Creating Animated 3D Plots . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .189
Exercises . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .196

7 Calculus . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .201

Evaluating Calculus Expressions. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .201
Limits . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .202
Differentiation .. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .209
Indeđnite Integration . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .226
Methods of Integration . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .228
Deđnite Integrals. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .231
Sequences and Series . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .260
Multivariable Calculus. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .268
Exercises . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .277

iv



i
i

“Compute60” — 2011/12/20 — 14:27 — page v — #5 i
i

i
i

i
i

8 Matrix Algebra . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .285

Creating and Editing Matrices . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .286
Standard Operations . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .294
Row Operations and Echelon Forms. . . . . . . . . . . . . . . . . . . . . . . . .298
Equations . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .301
Matrix Operators. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .307
Polynomials and Vectors Associated with a Matrix . . . . . . .317
Vector Spaces Associated with a Matrix . . . . . . . . . . . . . . . . . . . . .321
Normal Forms of Matrices . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .326
Matrix Decompositions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .334
Exercises . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .337

9 Vector Calculus . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .341

Vectors . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .341
Gradient, Divergence, Curl, and Related Operators. . . . . .358
Plots of Vector Fields and Gradients . . . . . . . . . . . . . . . . . . . . . . . . .363
Scalar and Vector Potentials . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .372
Matrix-Valued Operators . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .375
Plots of Complex Functions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .379
Exercises . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .381

10 Differential Equations . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .385

Ordinary Differential Equations . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .385
Systems . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .397
Numerical Methods . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .400
Exercises . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .407

11 Statistics. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .409

Introduction to Statistics . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .409
Measures of Central Tendency. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .411
Measures of Dispersion . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .416
Distributions and Densities . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .421
Families of Continuous Distributions . . . . . . . . . . . . . . . . . . . . . . .423
Families of Discrete Distributions . . . . . . . . . . . . . . . . . . . . . . . . . . . .432
Random Numbers . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .435
Curve Fitting . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .436
Exercises . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .440

v



i
i

“Compute60” — 2011/12/20 — 14:27 — page vi — #6 i
i

i
i

i
i

Contents

12 Applied Modern Algebra. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .445

Solving Equations . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .445
Integers Modulo m .. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .448
Other Systems Modulo m.. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .454
Polynomials Modulo Polynomials . . . . . . . . . . . . . . . . . . . . . . . . . . . .456
Linear Programming .. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .463
Exercises . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .466

A Menus and Shortcuts for Doing Mathematics . . . . . . . . . . . . .473

Compute Menu .. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .473
Toolbar and Keyboard Shortcuts for Compute Menu .. .488

B Menus and Shortcuts for Entering Mathematics . . . . . . . . . .489

Entering Mathematics and Text . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .490
Entering Mathematical Objects . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .491
Entering Symbols and Characters . . . . . . . . . . . . . . . . . . . . . . . . . . . . .492
Entering Units of Measure . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .496

C Customizing the Program for Computing . . . . . . . . . . . . . . . . . .505

Customizing the Toolbars . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .506
Customizing the Sidebars . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .507
Customizing the Compute Settings . . . . . . . . . . . . . . . . . . . . . . . . . .507
Customizing the Plot Settings . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .511
Automatic Substitution. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .512

D MuPAD Functions and Expressions . . . . . . . . . . . . . . . . . . . . . . . . . .515

Constants . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .515
Compute Menu Items. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .516
Functions and Expressions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .522

Index . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .527

vi



i
i

“Compute60” — 2011/12/20 — 14:27 — page vii — #7 i
i

i
i

i
i

Preface

How can it be that mathematics, being after all a product of human thought independent of experience, is so admirably adapted to the
objects of reality? Albert Einstein (1879–1955)

W elcome to Version 6 of ScientiĖc WorkPlace and ScientiĖc About ScientiöcWorkPlace and
Scientiöc Notebook

Technical Support

Notebook. ăeseprogramshave always provided easy text-
entry, natural-notation mathematics, powerful symbolic

and numeric computation, and Ĕexible output of online, printed, and
typeset documents in aWindows environment. WithVersion 6, these
features are available for Linux and Mac OS/X users as well. With its
entirely newMozilla-based architecture, Version 6 providesmore Ĕex-
ibility for your workplace. You can save or export your documents in
multiple formats according to your publication and portability needs.

About Scientiöc WorkPlace and Scientiöc Notebook
ăetwoproducts ScientiĖcWorkPlace and ScientiĖcNotebook pro- New in Version 6

MuPAD 5 computer algebra system
Smoother plots
Customizable toolbars
Optional sidebars
Undo multiple changes

vide a free-form interface to a computer algebra system that is inte-
grated with a scientiđc word processor. ăe essential components of
this interface are Ěee-form editing and natural mathematical notation.
ScientiĖcWorkPlace and ScientiĖc Notebookmake sense out of as many
different forms as possible, rather than requiring the user to adhere to
a rigid syntax or just one way of writing an expression.

vii
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Preface

ăey are designed to đt the needs of a wide range of users, from
the beginning student trying to solve a linear equation to the profes-
sional scientist whowants to produce typeset-quality documents with
embedded advanced mathematical calculations. ăe text editors in
ScientiĖc WorkPlace and ScientiĖc Notebook accept mathematical for-
mulas and equations entered in natural notation. ăe symbolic com-
putation system produces mathematical output inside the document
that is formatted in natural notation, can be edited, and can be used
directly as input to subsequent mathematical calculations.

ăe computational components of ScientiĖc WorkPlace and Sci-
entiĖc Notebook use a MuPAD engine. All versions use standard li-
braries furnished by SciFace Soĕware. ScientiĖcWorkPlace and Scien-
tiĖcNotebook provide easy, direct access to all themathematics needed
by many users. For the user familiar with MuPAD, they also allow
access to the full range of MuPAD functions and to functions pro-
grammed inMuPAD.By providing an interface with little or no learn-
ing cost, ScientiĖc WorkPlace and ScientiĖc Notebook make symbolic
computation as accessible as any word processor. Students can use Scientiöc Notebook as an

experimental mathematics lab and to create
clear, well-written homework and reports.

ScientiĖcWorkPlace and ScientiĖc Notebook have great potential in
educational settings. In a classroom equipped with appropriate pro-
jection equipment, the program’s ease of use and its combination of a
free-form scientiđc word processor and computational package make
it a natural replacement for the chalkboard. You can use it in the same
ways you would a chalkboard and you have the added advantage of
the computational system. You do not need to erase as you go along,
so previous work can be recalled. Class notes can be edited and made
available for viewing on line or printed. ScientiĖc WorkPlace and Sci-
entiĖc Notebook provide a ready laboratory in which students can ex-
periment with mathematics to develop new insights and to solve in-
teresting problems; they also provide a vehicle for students to produce
clear, well-written homework.

ăis document,DoingMathematics with ScientiĖcWorkPlace and
ScientiĖc Notebook, describes the use of the underlying computer al-
gebra system for doing mathematical calculations. In particular, it ex-
plains how to use the built-in computer algebra system MuPAD to do
a wide range of mathematics without dealing directly with MuPAD
syntax.

ăis document is organized around standard topics in the under-
graduate mathematics curriculum. Users can đnd the guidance they
need without going to chapters involving mathematics beyond their

viii
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current level. ăe đrst four chapters introduce basic procedures for
using the system and cover the content of the standard precalculus
courses. Later chapters cover analytic geometry and calculus, linear
algebra, vector analysis, differential equations, statistics, and applied
modern algebra. Exercises are provided to encourage users to practice
the ideas presented and to explore possibilities beyond those covered
in this document.

Users with an interest in doing mathematical calculations are ad-
vised to read and experiment with the đrst đve chapters—Basic Tech-
niques for Doing Mathematics; Numbers, Functions, and Units; Alge-
bra; Trigonometry; and Function DeĖnitions—which provide a good
foundation for doing mathematical calculations. You may also đnd it
helpful to read parts of the sixth chapter Plotting Curves and Surfaces
to get started creating plots. You can approach the remaining chapters
in any order. In addition to the built-in links to MuPAD, users

familiar with MuPAD can now access MuPAD
directly by using Passthru Code to Engine.

Experienced MuPAD users will đnd it helpful to read about ac-
cessingotherMuPADfunctions and addinguser-deđnedMuPADfunc-
tions in Appendix D, “MuPAD Functions and Expressions.” You will
alsowant to refer to the tables in that chapter that pairMuPADnames
with ScientiĖcWorkPlace and ScientiĖc Notebook names for constants,
functions, and operations.

For information on the document-editing features of your system,
refer to the onlineHelp or to the document,Creating Documents with
ScientiĖc Word and ScientiĖc WorkPlace.

Technical Support
If you can’t đnd the answer to your questions in themanuals or the

online Help, you can obtain technical support from the website at

http://www.mackichan.com/support.htm

or at the Web-based Technical Support forum at

http://www.mackichan.com/forum.htm

You can also contact theTechnical Support staffby email or telephone.
We urge you to submit questions by email whenever possible in case
the technical staff needs to obtain your đle to diagnose and solve the
problem.

Whenyou contactTechnical Support by email, please provide com-
plete information about the problem you’re trying to solve. ăeymust
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Preface

be able to reproduce theproblemexactly fromyour instructions. When
you contact themby telephone, you shouldbe sitting at your computer
with the program running.

Please be prepared to provide the following information any time
you contact Technical Support:

• ăe MacKichan Soĕware product you have installed.

• ăe version and build numbers of your installation (see Help /
About).

• ăe serial number of your installation (see Help / System Fea-
tures).

• ăe type of hardware and operating system you’re using, (e.g.,
Windows 7, Mac OS X Leopard, Ubuntu 10.10, openSUSE
11.3, etc.).

• What happened and what you were doing when the problem
occurred.

• ăe exact wording of any messages that appeared on your com-
puter screen.

Tocontact technical support
• Contact Technical Support by email or telephone between 8

 and 5  Paciđc Time:

Internet electronic mail address: support@mackichan.com
Telephone number: 360-394-6033

Toll-free telephone: 877-SCI-WORD (877-724-9673)
Fax number: 360-394-6039

You can learn more about ScientiĖcWorkPlace and ScientiĖc Note-
book on the MacKichan web site, which is updated regularly to pro-
vide the latest technical information about the program. ăe site also
houses links to other TEX and LATEX resources. ăere is also an un-
moderated discussion forum and an unmoderated email list so users
can share information, discuss commonproblems, and contribute tech-
nical tips and solutions. You can link to these valuable resources from
the home page at http://www.mackichan.com.

Darel W. Hardy
Carol L . Walker
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1
Basic Techniques

for Doing Mathematics

Howmany times can you subtract 7 from 83, and what is left afterwards? You can subtract it as many times as you want, and it
leaves 76 every time. Author Unknown

I n this chapter, we give a brief explanation, with examples, of each Conventions

Inserting Text and Mathematics

Basic Guidelines for Computing

of the basic computational features of ScientiĖc WorkPlace and
ScientiĖc Notebook. You can begin computing as soon as you have

opened a đle. You are encouraged to open a new document and work
the examples as you proceed.
To type and evaluate an expression

1. Place the insert pointwhere youwant the expression and choose
Insert>Math.

2. Type amathematical expression in thedocument—for example,
2+2. (It will appear red in the document window.) Note

If Insert>Math is checked, your insert point is
already in mathematics mode and you are
ready for step 2.

3. Choose Compute> Evaluate.

ăe expression 2+2 will be replaced by the evaluation 2+2 = 4.
Although there are substantial changes to ScientiĖcWorkPlace and

ScientiĖc Notebook for Version 6, the computational behavior of the
program is largely unchanged. ăe Compute menu will look very fa-
miliar to experiencedusers. ăere are some logical changes in the struc-
ture of othermenus. Mathematics objects on earlier Insertmenus have General procedure

• Enter an expression in mathematics

• Choose an appropriate command

been gathered together under the heading Math Objects, a new item
on the Insert menu. Symbol panels are available in a sidebar as well as
on a Symbol toolbar.

1
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Chapter 1 | Basic Techniques for Doing Mathematics

Conventions
Program tools are available frommenus, toolbar buttons, and key-

board shortcuts. Many tools may be invoked in multiple ways to suit
your style of work—via menus, toolbar buttons, or the keyboard. In
this manual, we generally indicate only one of the possible ways of ac-
cessing a tool, usually via the menus. Appendices A and B list com-
mand shortcuts for doing or entering mathematics.

Understanding the notation and the terms used in our documen-
tationwill help you understand the instructions. We assume you’re fa-
miliar with the basic procedures and terminology for your operating
system. In our manuals, we use the notation and terms listed below.

General Notation
• Text like this indicates text you should type exactly as it is shown.

• Text like this indicates information that you must supply, such
as a đlename.

• Text like this indicates an expression that is typed inmathemat-
ics mode.

• ăe word choose means to designate a command for the pro-
gram to carry out. As with all standard applications, you can
choose a commandwith themouse orwith the keyboard. Com-
mandsmay be listed on amenu or shown on a button or in a di-
alog box. For example, the instruction “Choose File > Open”
means you should đrst choose the Filemenu and then from that
menu, choose the Open command. ăe instruction “choose
OK” means to click OK with the mouse, or to press Tab to se-
lect the OK button and then press Enter.

• ăe word checkmeans to turn on an option in a dialog box.

Keyboard Conventions
We also use standard computer conventions to give keyboard in-

structions.

• ăe names of keys in the instructions match the names shown
on most keyboards. Ctrl (Windows) and Cmd (Mac) are syn-
onymous, as are Enter (Windows) and Return (Mac), and right

2
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Inserting Text and Mathematics

click (Windows) and Cmd+click (Mac). Names of keys are al-
ways shown in Windows format. Mac users should substitute
Mac keys (e.g. Cmd and Return) as appropriate.

• A plus sign (+) between the names of two keys indicates that
youmust press the đrst key and hold it downwhile you press the
second key. For example, Ctrl+gmeans that you press and hold
down theCtrl key, press g, and then release both keys. Similarly,
the notation Ctrl+word means that you must hold down the
Ctrl key, type the word that appears aĕer the +, then release the
Ctrl key. Note that if a letter appears capitalized, you should
type that letter as a capital.

Inserting Text and Mathematics
ScientiĖcWorkPlace and ScientiĖc Notebook are modal in the sense

that at all times during information entry you are either entering text
or mathematics, and the results obtained from keystrokes and other
user interface actions will differ depending on whether you are enter-
ing text or mathematics. ăus we refer to being in either text mode or
mathematics mode. ăe default state is text mode; it is easy to toggle
between the two modes and it is also easy to determine what mode
you are in. Unless you actively change to mathematics, the program
displays a “T” on the Standard toolbar and

• Interprets anything you type as text, displaying it in black in the
program window.

• Displays alphabetic characters as upright, not italicized.

• Inserts a space when you press the spacebar.

When you start the program, the insert point is in text mode. Mathematics mode
When you switch from text to mathematics,
the “T” changes to “M” on the toolbar, and the
insert point changes to red and appears
between brackets.

To switch from text tomathematics
• Click the “T” on the standard toolbar, or

Choose Insert>Math.

When in mathematics mode, the program

• Displays the insert point between brackets for mathematics.

3
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Chapter 1 | Basic Techniques for Doing Mathematics

• Interprets anything you type asmathematics, displaying it in red
in the program window.

• Italicizes alphabetic characters and displays numbers upright.

• Automatically formats mathematical expressions, inserting cor-
rect spacing around operators such as + and relations such as =. Spacing

Mathematics is automatically spaced
differently from text as you enter it—for
example, “2+2” rather than “2+2”—so
you do not have to make adjustments.

• Advances the insert point to thenextmathematical objectwhen
you press the spacebar.

To switch frommathematics to text
• Click the “M” on the standard toolbar, or

Choose Insert>Text. Text mode
When you switch frommathematics to text,
the “M” changes to “T” and the insert point
changes to black.

On the screen, mathematics appears in red and text in black. ăe
blinking vertical line on your screen is referred to as the insert point.
You may have heard it called the insert cursor, or simply the cursor.
ăe insert point marks the position where characters or symbols are
entered when you type or click a symbol. You can change the position
of the insert point with the arrow keys or by clicking a different screen
position with the mouse. ăe position of the mouse is indicated by
themouse pointer, which assumes the shape of an I-beam over text and
an arrow over mathematics.

Basic Guidelines
You can type information in a document in either text or mathe-

matics. ăemathematics that you type is recognized by the underlying
computing engine as mathematics, and the text is ignored by the com-
puting engine. Text and Mathematics

The state of the Toggle Text/Math button
reøects the state at the position of the insert
point.

• Text is entered at the position of the insertion point when the
Toggle Text/Math button in the Standard toolbar shows T.

• Mathematics is entered at the position of the insert point when
the Toggle Text/Math button on the Standard toolbar shows a
red M.

You can toggle betweenmathematics and text by clicking the Tog-
gle Text/Math button or by pressing Ctrl+m or Ctrl+t on the key-
board. Entering a mathematics symbol by clicking a button on a tool-
bar automatically puts the state inmathematics at theposition inwhich
the symbol is entered. ăe state remains in mathematics as you type

4
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Inserting Text and Mathematics

characters or symbols to the right of existing mathematics, until you
either toggle back into text or move the insert point into text by using
the mouse or by pressing right arrow, leĕ arrow, or the spacebar.

Choose View>Toolbars if any toolbar youwould like to use does
not automatically appear above your Document Window.
To type a fraction, radical, exponent, or subscript

1. Choose Insert>MathObjects>Fraction, Radical, Superscript,
or Subscript for input boxes:

□
□
√
□ x□ y□

2. Enter expressions in the input boxes:

2
3

√
5 x2 y1

ăe spacebar and arrow keys move the insertion point through
mathematical expressions and the tabkey toggles between input boxes.
Touse symbols for addition,multiplication anddivision

• Use standard symbols on the keyboard.

• ChooseView>Toolbars and check SymbolToolbar. Click one
of the buttons on the Symbol Toolbar and a row of symbols will
appear.

• Click the leĕ or right sidebar pointer and choose Add > Sym-
bol. Click one of the buttons and a panel of symbolswill appear.

You select a piece of text with the mouse by holding down the leĕ
mouse buttonwhilemoving themouse, or from the keyboard by hold-
ing down shiĕ and pressing right arrow or leĕ arrow. Your selection
appears on the screen in reversed colors. ăis technique is sometimes Expanding brackets

Expanding parentheses, brackets, and braces
grow to an appropriate size, depending on
what they enclose, such as fractions or
matrices. Their use also tends to minimize
errors associated with unbalanced
parentheses.

referred to as highlighting an area of the screen. ăis is also one of
the ways you can select mathematics. See page 12 for a discussion of
automatic and user selections for mathematics.

ăere are many brackets available for mathematics expressions.
Brackets entered from buttons or dialogs, or from the keyboard with
Ctrl/Cmdpressed, are expanding brackets (sometimes called fences)—
both sides are entered and the resulting brackets change size (both
height and width) depending on the contents. Expanding brackets
will not break at the end of a line so lengthy expressions enclosed in

5
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Chapter 1 | Basic Techniques for Doing Mathematics

expanding brackets may need to be displayed. Leĕ and right brackets
entered from the keyboard (without Ctrl/Cmd pressed) act indepen-
dently. ăey also have đxed height. Caution

Mix brackets with care. Although the
expanding parentheses, expanding brackets,
and non-expanding brackets from the
keyboard are generally interchangeable (when
properly matched), the use of nonexpanding
or unusual brackets can lead to
misinterpretations. For example, if (2)(3) is
entered with the outer parentheses “()”
expanding brackets and the inner parentheses
“)(” non-expanding parentheses, then
evaluating this non-matched expression gives
(2)(3) = 2, which is probably not what is
intended!

To insert expandingbrackets in amathematics expression
• Choose Insert > Math Objects > Brackets and select the de-

sired brackets from the panel that appears.

Expanding parentheses and square brackets are also available on
the Math toolbar.

Displaying Mathematics
Mathematics can be centered on a separate line in a display.

y = ax+b

Tocreate a display
1. Choose Insert>Math Objects>Display.

2. Type or paste a mathematical expression in the display.
Spacing around a display
Pressing enter immediately before a display
will add extra vertical space. If you do not want
this space, place the insert point immediately
before the display and press backspace. (This
removes the “new paragraph” symbol.)
Pressing enter immediately after a display will
add extra vertical space and cause the next
line to start a new paragraph. If you do not
want this space or indention, place the insert
point at the start of the next line and press
backspace. (This removes the “new paragraph”
symbol.)

You can begin with an existingmathematical expression and put it
into a display.

Toputmathematics in a display
1. Select themathematicswith click anddrag or Shiĕ+right arrow.

2. Choose Insert>Math Objects>Display.

ăe default environment in a display is mathematics. You can,
however, enter text in a display by toggling to text.

Centering Plots, Graphics and Text
If you have text that you wish to center on a separate line, the nat-

ural way to do this operation is with Centered, which you can choose
from the Section/Body Tag pop-up menu.

If you have a plot or graphic that you wish to center on a separate
line, you should choose the Displayed setting in the Layout dialog, as
discussed in Chapter 6, “Plotting Curves and Surfaces.” To center a
group of plots or graphics, choose the In Line setting in the Layout
dialog and then use Centered.

6
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Basic Guidelines for Computing
When you respond to the request, “place the insert point in the ex-

pression,” place the insert point within, or immediately to the right of,
the expression. ăe position immediately to the leĕ of amathematical
expression is not part of the mathematics.

Evaluating expressions
To type a mathematics expression for a computation, begin a new

line with the mathematics expression or type the expression immedi-
ately to the right of text or a text space. If you type mathematics im-
mediately to the right of other mathematics, the expressions may be
combined in ways you do not intend. Compute> Evaluate

This sequence of actions insert= 11 to the
right of 3+8, resulting in the equation
3+8 = 11.

Tocompute the sum3+ 8
1. Choose Insert>Math

2. Type 3+8

3. Choose Compute> Evaluate
Rules
Except that it be mathematically correct, there
are almost no rules about the form for entering
a mathematical expression.

By following the same procedure, you can add, subtract, multiply,
and divide, and perform a vast variety of other mathematical compu-
tations.

Compute> Evaluate Compute> Evaluate
235+813 = 1048 49.2+23.6 = 72.8
235−813 =−578 49.2−23.6 = 25.6
235×813 = 191055 49.2 ·23.6 = 1161.1
235/813 = 235

813
49.2
23.6 = 2.0847

Compute> Evaluate Compute> Evaluate
2
3 +

3
7 = 23

21 (x+3)+(x− y) = 2x− y+3
2
3 −

3
7 = 5

21 (x+3)− (x− y) = y+3
2
3

3
7 = 2

7 (x+3)∗ (x− y) = (x− y)(x+3)
2
3 ÷

3
7 = 14

9 (x+3)/(x− y) = (x+3)
x−y

7
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Chapter 1 | Basic Techniques for Doing Mathematics

One of the few exceptions to the claim of “no rules” is that vertical
notation such as

24
+15 and

234
−47 and 2 35

used when doingmathematics by hand is not recognized. Write sums,
differences, products, and quotients of numbers in natural linear no-
tation, such as 24+15 and 235−47 and 24.7/19.5 and 13÷22, or
natural fractional notation, such as 78.9

43.4 and 3
7 ·

2
3 .

Certain constants are recognized in their usual forms—such as π ,
i, and e—as long as the context is appropriate. On the other hand,
they are recognized as arbitrary constants, variables, or indices when
appropriate to the context, helping to provide a completely natural
way for you to type and perform mathematical computations.

Interpreting Expressions
If yourmathematical notation is ambiguous, itmay still be accepted.

However, the way it is interpreted may or may not be what you in-
tended. To be safe, remove an ambiguity by placing additional paren-
theses in the expression.
Tocheck the interpretationof amathematical expression

1. Leave the insert point in the expression.

2. Choose Compute> Interpret.

Compute> Interpret
1/3x+4 = 1

3 x+4 1/(3x+4) = 1
(3x+4)

1/(3x)+4 = 1
3x +4 1/3(x+4) = 1

3 (x+4)

Math and Symbol Toolbars
Instructions in this manual rely almost entirely on menu items.

However, toolbars and keyboard shortcuts offer efficient alternative
methods. For descriptions of toolbars and keyboard shortcuts that
performtheComputemenucommands, seeAppendixA“Menus,Tool-
bars, and Shortcuts for Doing Mathematics.” For descriptions of tool-
bar buttons and keyboard shortcuts for enteringmathematics, see Ap-
pendixB “Menus, Toolbars, and Shortcuts for EnteringMathematics.”
For information about other toolbars and keyboard shortcuts, choose
Help> Search or consult the manualCreating Documents with Scien-
tiĖc WorkPlace and ScientiĖc Word.

8
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Basic Guidelines for Computing

Todisplay theMathToolbar
• Choose View>Toolbars and check Math Toolbar.

ăe buttons on this toolbar duplicate items on the Compute and In-
sert>Math Objects menus.

Example Here is how you can type the mathematical expression
2x−1√

x+3 using the mouse:

1. Click Fraction and type 2x−1.

2. Click the denominator input box.

3. Click Radical and type x.

4. Click to the right of the square root symbol.

5. Type+3.

Todisplay the SymbolsToolbar
• Choose View>Toolbars and check Symbols Toolbar.

From this toolbar, you can access Greek letters, many binary op-
eration and binary relation symbols, and other common and not-so-
common mathematical symbols.

Greek letters
Toenter a lowercaseGreek letter

• Click the Lowercase Greek button, then click the desired letter.

Toenter anuppercaseGreek letter
• Click theUppercase Greek button, then click the desired letter.

9
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Chapter 1 | Basic Techniques for Doing Mathematics

Binary Operations
Toenter a binary operation

• Click the Binary Operations button and click the desired sym-
bol.

Binary Relations
Toenter a binary relation

• Click the Binary Relations button and click the desired symbol.

Negated Relations
Toenter a negated relation

• Click the Negated Relations button and click the desired sym-
bol.

Arrows
Toenter an arrow

• Click the Arrows button and click the desired symbol.

Miscellaneous Symbols
Toenter amiscellaneous symbol

• Click the Miscellaneous Symbols button and click the desired
symbol

10
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Basic Guidelines for Computing

Delimiters
Toenter a delimiter

• Click the Delimiters button and click the desired symbol

Sidebar tools

Symbol Sidebar
You will see leĕ and right sidebar tools on the leĕ and right edges

of your window.
Toview the leĕor right sidebar

• Click the leĕ or right sidebar tool.

Toview the Symbol sidebar
• Choose Add> Symbols

Keyboard Shortcuts
Keyboard shortcuts are available for many common tasks. For Tip

For additional shortcuts, choose Help and
search for Keyboard Shortcuts. More detail is
also available in the Creating Documents users’
manual.

example, to toggle between mathematics and text, press Ctrl+m or
Ctrl+t. See Appendix B, Keyboard Shortcuts for Entering Mathe-
matics, for some useful keyboard shortcuts for entering symbols and
mathematical objects.

Example Here is how you can type the mathematical expression
2x−1√

x+3 using keyboard shortcuts.

11
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Chapter 1 | Basic Techniques for Doing Mathematics

1. Press Ctrl+/.

2. Type 2x−1.

3. Press Tab.

4. Press Ctrl+r.

5. Type x.

6. Press spacebar.

7. Type+3.

8. Press spacebar.

Selecting Mathematical Expressions
ăere are more ways than one to select a mathematical expression,

as explained in the following sections. When you perform a mathe-
matical operation, a mathematical expression is automatically selected
for the operation, depending on the position of the insert point and
the operation involved. ăese will be called automatic selections. You
can also force other selections by selectingmathematicswith themouse.
ăe latter will be called user selections.

Understanding Automatic Selections
When you place the insert point in amathematical expression and

choose an operation from theComputemenu, the automatic selection
depends primarily on the operation you choose. It also depends on the
location of the mathematics, such as inline, in a matrix, or in a display.
ăe following twopossibilities occur formathematical objects that are
typed inline:

• Selection of an expression, that part of the mathematics con-
taining the insert point that is enclosed between a combination
of text and the class of symbols—such as =, <, or≤—known
as binary relations.

• Selection of the entiremathematical object, such as an equation
or inequality.

ăe following examples illustrate situations where these two types
of selections occur.

12
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Operations that Select an Expression
ăe majority of operations select an expression enclosed between

text and binary relations.

To select an expression enclosedbetween text andbinary relations
• Place the insert point anywhere inside the expression or imme-

diately to the right of the expression, and choose a command
that operates on expressions.

For example, place the insert point anywhere in the leĕ side of the
equals sign in the equation 2x+3x = 1+4 except to the leĕ of the 2,
and choose Evaluate.

Compute> Evaluate
(Insert point in leĕ side of the equation)
2x+3x = 5x = 1+4

ăe expression = 5x is inserted immediately aĕer the expression
2x+ 3x, because only the expression on the leĕ side of the equation
was selected for evaluation. ăe leĕ side of the equation is bounded
on the leĕ by text and on the right by the binary operation “=.”

Since the result of the evaluation was equal to the original expres-
sion, the resultwas placednext to the expression, precededby an equals
sign. Aĕer the operation is performed, the insert point appears at the
right end of the result so that you can select another operation to apply
to the result without moving the insert point.

Other commands, including Evaluate Numeric, Simplify, Com-
bine, Factor, and Expand, make similar selections under similar con-
ditions.

Operations that Select an Equation or Inequality
To select an equation

1. Place the insert point anywhere inside the equation or immedi-
ately to the right of the equation.

2. Choose a command that operates on equations.

Compute> Solve> Exact
2x+3x = 1, Solution: 1

5
3x+5≤ 5x−3, Solution: [4,∞)

13
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Chapter 1 | Basic Techniques for Doing Mathematics

In these cases, the entire mathematical object—that is, the equa-
tion or inequality—was selected. ăe solution is not equal to the se-
lection, so it is not presented as a part of the original equation. Note

If the mathematics is not appropriate for the
operation, no action is taken.

ăeother choices on the Solve submenu and the operationCheck
Equality also select an equation.

Selections Inside Displays and Matrices
Operations may behave somewhat differently when mathematics

is entered in a display or in amatrix. If you place the insert point inside
a display ormatrix, the automatic selection is the entire array of entries,
for any operation. Some operations apply to a matrix, and others to
the entries of a matrix or contents of a display. If the operation is not
appropriate for either a matrix or its entries or for all the contents of a
display, you may receive a report of a syntax error.
Selections Inside a Display

Inside a one-line display, the automatic selection is the samemath-
ematics as outside a display, and the result is generally returned inside
the display.
To selectmathematics in a display

• Place the insert point inside the display, and choose a command
that operates on expressions or equations.

Tip
Press Enter at the end of a display line to create
a new display line.

When you choose Evaluate with the insert point in the leĕ side of
the displayed equation

2x+3x = 3+5

you get the result
2x+3x = 5x = 3+5

and when you choose Evaluate with the insert point in the right side
of the displayed equation you get the result

2x+3x = 3+5 = 8

A multiple-line display, however, behaves like a matrix (see next
section). Note that multiple line displays are useful for solving sys-
tems of equations, or equations with initial-value conditions. Apply-
ing Compute> Solve> Exact to the following display yields

5x+2y = 3
6x− y = 5

Solution:
[
x = 13

17 ,y =−
7
17

]
14
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Selections Inside a Matrix
You can use amatrix to arrangemathematical expressions in a rect-

angular array.

Tocreate amatrix
1. Choose Insert>Math Objects>Matrix.

2. Set the number of rows and columns.

3. Choose OK.

4. If you see nothing on your screen, choose View>Helper Lines,
or

Choose View> Input Boxes.

5. Type a number or any mathematical expression in each of the
input boxes of the matrix.

To selectmathematics in amatrix
• Place the insert point anywhere inside the matrix or immedi-

ately to the right of the matrix, and choose a command that op-
erates on expressions. Tip

With Compute> Evaluate, all expressions in
the matrix will be evaluated and the result
displayed as a matrix. Evaluate Numeric,
Simplify, Factor, and choices from Combine
behave similarly.

Compute> Evaluate(
x+ x 5+3
5/2 62

)
=

(
2x 8
5
2 36

)
Compute> Evaluate Numeric(

x+ x 5+3
5/2 62

)
≈
(

2.0x 8.0
2.5 36.0

)
Compute> Factor(

x+ x 5+3
5/2 62

)
=

(
2x 23

5×2−1 22×32

)
Understanding User Selections

You can restrict a computation to a selection you have made and
so override the automatic choice.
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Chapter 1 | Basic Techniques for Doing Mathematics

Tomake a user selection
• Hold down the leĕmouse buttonwhilemoving themouse over

the material you want to select, then release the leĕ mouse but-
ton.

Your selection is the expression that appears on the screen in re-
versed colors. ăis procedure will oĕen be referred to as select with the
mouse.

ăere are two options for applying operations to a user selection—
operating on a selection displays the result of the operation but leaves
the selection intact, and replacing a selection replaces the selectionwith
the result of the operation. Following are two examples illustrating the
behavior of the system when operating on a selection. ăe option of
replacing a selection is referred to as computing in place, and examples
are shown in the following section.
Tooperate on a user selection

• Use the mouse to make a selection, and apply an operation.

Compute> Evaluate
(2+3 selected)
2+3− x : 5

Tip
When you operate on a user selection, the
answer appears to the right of the entire
expression, following a colon.In general, the result of applying an operation to a user selection is

not equal to the entire original expression, so the result is placed at the
end of the mathematics, separated by something in text (in this case,
a colon). You can use the word-processing capabilities of your system
to put the result where you want it in your document.

Replacing a user selection, an in-place computation, is described in
the following section.

Computing in Place Computing in place
This “computing in place”— that is, holding
down the Ctrl key as you choose an operation
from the Compute menu—is a key feature. It
provides a convenient way for you to
manipulate expressions into the forms you
desire.

You can replace part of an expression with the result of a compu-
tation on that part.
To replace a user selection

1. Use the mouse to select an expression.

2. Press and hold Ctrl while applying a command to the expres-
sion.

Old Expression Selection Compute> Expand

(x−2)2 (3x−1) (x−2)2 x2−4x+4(3x−1)

16
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Basic Guidelines for Computing

ăe expression x2−4x+4 remains selected. Enclose it in paren-
theses to complete the replacement.

Old Expression Selection Compute> Factor(
x2−4x+4

)
(3x−1)

(
x2−4x+4

)
(x−2)2 (3x−1)

With the help of theCtrl key, you canperformany computation in
place; that is, you can replace an expression directly with the results of
that computation. ăis feature, combinedwith copy and paste, allows
you to “đll in the steps” in demonstrating a computation.

Stopping a Computation
Most computations are donemoreor less instantaneously, but some

may take several minutes to complete, and some may take a (much)
longer time.
To stop a computation

• Press Ctrl+Break (Windows) or Cmd+period (Mac), or

Click .

Menus, Toolbars, and Shortcuts
SeeAppendixA for a summary of theComputemenu commands,

corresponding commands on the Math Toolbar, and keyboard short-
cuts for these commands. See Appendix B for a complete summary of
Insert > Math Objects menu choices, corresponding choices on the
Math and Symbols Toolbars, and keyboard shortcuts related speciđ-
cally to entering mathematics. For additional shortcuts, consult Cre-
atingDocuments with ScientiĖcWorkPlace and ScientiĖcWord, Version
6 or choose Help and search for keyboard shortcuts.

Customizing Your Program
ăere are many ways to customize your program to đt your spe-

cial needs and preferences. See Appendix C for information on set-
tings for computation. You can set the number of digits to be used in
computations, the number of digits to be displayed, defaults for plot
intervals, set various debugging choices, customize the appearance of
solutions, and choose different defaults for input, output, matrices,
derivatives, and other entities. ăere are also many possibilities for
customizing the editing features of the program. ăese are described
in detail in the Help and in the manual Creating Documents with Sci-
entiĖc WorkPlace and ScientiĖc Word.
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Chapter 1 | Basic Techniques for Doing Mathematics

Computational Engine
ăe computational engine provided with ScientiĖcWorkPlace and

ScientiĖc Notebook version 6 isMuPAD 5. To see if the computational
engine is in active mode, or to deactivate the engine, choose Tools >
Preferences > Computation, click Engine tab, and check or uncheck
Engine On. (ăe path for a Mac is SWPPro > Preferences > Com-
putation.)

See AppendixD “MuPADFunctions and Expressions” for a list of
built-in functions and constants, descriptions ofComputemenu com-
mands in terms of the native commands of MuPAD, and descriptions
of built-in functions in terms of the MuPAD syntax.
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No human investigation can be called real science if it cannot be demonstrated mathematically. Leonardo da Vinci (1452–1519)

N umbers and functions to be used for computing should be Integers and Fractions

Elementary Number Theory

Real Numbers

Functions and Relations

Complex Numbers

Units and Measurements

entered in mathematics mode and appear red (or gray) on
your screen. If that is not the case, choose Insert > Math

and retype the expression. Units to be used for computing must be
entered as a Unit Name (see Units, page 34).
Toenter amathematics expression for a computation

• Begin a new line with the mathematics expression, or

Type the expression immediately to the right of text or a text
space.

If you enter mathematics immediately to the right of othermathe-
matics, the expressions will be combined in ways you may not intend.
A safe way to begin is to press Enter and start on a new line. New in Version 6

Rewrite fraction as mixed number
Arithmetic with mixed numbers
Choice of letters and fonts for imaginary unit
and exponential e
Overbar for complex conjugate
More control over thresholds for scientiöc
notation

Integers and Fractions
ăe đrst examples are centered around rational numbers—that is,

integers and fractions. You will đnd examples of many of the same
operations later in this chapter, using real numbers and then complex
numbers. Similar operations will be illustrated in later chapters with a
variety of different mathematical objects.
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Chapter 2 | Numbers, Functions, and Units

Addition and Subtraction
Toadd3, 6, and14 Shortcuts

Toolbar and keyboard shortcuts for computing
are summarized in Appendix A “Menus,
Toolbars, and Shortcuts for Doing
Mathematics” and Appendix B “Menus,
Toolbars, and Shortcuts for Entering
Mathematics.”

1. Choose Insert > Math to put the insert point in mathematics
mode.

2. Type3+6+14 (ăis expression should appear red in your doc-
ument window.)

3. Leave the insert point in the expression 3+6+14.

4. Choose Compute> Evaluate.

ăis sequence prompts the system to insert = 23 to the right of the
3+6+14, resulting in the equation 3+6+14 = 23. Compute> Evaluate

The mathematics shown in this table depicts
both what you enter (235+813) and the
result after choosing Compute> Evaluate
(= 1048)

By following the same steps, you can carry out subtraction and per-
form a vast variety of other mathematical computations. With the in-
sert point in the sum (or difference), choose Compute> Evaluate.

Compute> Evaluate
235+813 = 1048 2

3 −
8
7 = − 10

21 96−27+2 = 71

Toobtain the fraction template
• Place the insert point in the position where you want the frac-

tion, and choose Insert>Math Objects> Fraction.

ăe template will appear with the insert point in the upper input
box, ready for you to begin entering numbers or expressions.

Multiplication and Division
Use any standard linear or fractional notation for multiplication

and division, and with the insert point in the product (or quotient),
choose Compute> Evaluate.

Compute> Evaluate
16×37 = 592 (84)(−39) =−3276 8.2/3.7 = 2.2162

103÷37 = 103
37

2
9

13
7 = 26

63
− 2

9
13
7

=− 14
117
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Elementary Number Theory

Mixed Numbers and Long Division
A number written in the form 14 5

9 is interpreted as the mixed
number 14+ 5

9 . With the factory default, most commands applied
to a mixed number return a fraction. For example, applying Evaluate
or Simplify to 14 5

9 gives the result 131
9 . ăe reverse is accomplished by

Compute > Rewrite > Mixed, which converts a fraction to a mixed
number.

Compute> Evaluate
1 2

3 = 5
3 193 87

94 = 18229
94 1 2

3 +2 3
4 = 53

12

Compute> Rewrite>Mixed
5
3 = 1 2

3
18229

94 = 193 87
94

53
12 = 4 5

12
Long Division
The expansion of a fraction to a mixed number
uses the familiar long-division algorithm. For
example, 18229 divided by94 is equal to
193with remainder 87.

You can change this default so that fractions are output as mixed
numbers.
To setmixednumbers as default for rational numbers

1. Choose Tools> Preferences>Computation, Output tab.

2. Check “Output fractions as mixed numbers.”
New in Version 6
Do arithmetic with mixed numbers.With mixed number checked as the output default for fractions,

the system behaves as follows.

Compute> Evaluate
5 3

5 +1 2
3 = 7 4

15

Elementary Number Theory

Prime Factorization
A prime is an integer greater than 1 whose only positive factors

are itself and 1. You can factor integers into products of powers of
primes. Place the insert point inside the number and chooseCompute
> Factor.

Compute> Factor
12345 = 3×5×823 −24 =−23×3 210 +37 = 132×19
24! = 222×310×54×73×112×13×17×19×23
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Chapter 2 | Numbers, Functions, and Units

Greatest Common Divisor Function recognition
If you enter the function gcd from the
keyboard while in mathematics mode, the gc
appears in red italics until you type the d, then
the function name gcd changes to a gray,
non-italic gcd. Alternately, choose Insert>
Math Objects>Math Name, type gcd in the
input box and choose OK.

ăe greatest common divisor of two integers is the largest integer
that divides both integers evenly. You can đnd the greatest common
divisor of a collection of integers by evaluating the function gcd ap-
plied to the list of numbers enclosed in parentheses or square brackets
and separated by commas. Leave the insert point in the expression and
choose Compute> Evaluate.

Compute> Evaluate
gcd(35,15,65) = 5
gcd
(
214 +38 +59,34 +73

)
= 2

gcd [−104,221] = 13

Least Common Multiple
You can đnd the least common multiple of a collection of integers

by evaluating the function lcm applied to the list of numbers enclosed
in parentheses or square brackets and separated by commas. Leave the
insert point in the expression and choose Compute> Evaluate.

Compute> Evaluate
lcm(35,15,65) = 1365
lcm [6,8] = 24
lcm(104,221) = 1768

Factorials
Factorial is the function of a nonnegative integer n denoted by n!

and deđned for positive integers n as the product of all positive inte-
gers up to and including n; that is, n! = 1×2×3×4×·· ·×n. It is
deđned for zero by 0! = 1.

You can evaluate factorials.

Compute> Evaluate
3! = 6 7! = 5040 10! = 3628800

Binomial Coefficients
An expression of the form a+b is called a binomial. ăe formula

that gives the expansion of (a+b)n for any natural number n is

(a+b)n =
n

∑
k=0

n!
k!(n− k)!

an−kbk
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Real Numbers

ăis is the same formula that gives the number of combinations of n
things taken k at a time. ăe coefficients n!

k!(n−k)! that occur in this
formula are called binomial coefficients. ăese coefficients are oĕen
denoted by the symbols

(n
k

)
or Cn,k or nCk. Use the symbol

(n
k

)
to

compute these coefficients.
Toenter a binomial coefficient

(n
k

)
1. Choose Insert>Math Objects> Binomial.

2. Check None for Line and choose OK.

3. Type numbers in the input boxes.

Compute> Evaluate(
5
2

)
= 10

(
35
7

)
= 6724520

ARewrite commandwill change a symbolic binomial to a factorial
expression.

Compute> Rewrite> Factorial(
m
n

)
=

m!
(m−n)!n!

(
m
5

)
=

m!
120(m−5)!

Real Numbers
Reminder
Numbers used in computing must be in
mathematics mode.

ăereal numbers include the integers and fractions (rational num-
bers), as well as irrational numbers such as

√
2 and π that cannot be

expressed as quotients of integers.

Arithmetic
You can do arithmetic with real numbers using Evaluate.

Compute> Evaluate
9.6π−2.7π = 6.9π 42

( 2
3 +

1
7

)√
2 = 34

√
2 2

3 ÷
8
7 = 7

12

If any of the components of a combination of numbers is written
in Ĕoating point form—that is, with a decimal—the result will be in
decimal notation. Symbolic real numbers such as

√
2 and π will retain

symbolic form unless evaluated numerically.
ChooseCompute>Rewrite>Rational to change aĔoatingpoint

number to a rational number.
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Chapter 2 | Numbers, Functions, and Units

Compute> Rewrite> Rational

0.125 = 1
8 4.72 = 118

25

6.9π = 69
10 π 3.1416 = 3927

1250

ChooseCompute>Rewrite> Float to change a rational number
or a symbolic number to a Ĕoating point number.

Compute> Rewrite> Float
1
8 = 0.125 118

25 = 4.72
69
10 π = 21.677 3927

1250 = 3.1416

Typing ęoat while in mathematics gives the grayed function float.
Evaluating float at a rational number gives the Ĕoating point form of
the number.

Compute> Evaluate

float
( 1

8

)
= 0.125 float

( 118
25

)
= 4.72

Powers and Radicals
To raise numbers to powers, use common notation for powers and

apply Evaluate.

Compute> Evaluate

34 = 81 (2.5)4/5 = 2.0814

3−4 = 1
81 0.432 = 1.8447×10−13

To insert the superscript templateN□ or subscript templateN□
1. Place the insert point in the position where you want the super-

script (subscript).

2. Choose Insert>Math Objects> Superscript (Subscript).

ăe templatewill appearwith the insert point in the upper (lower)
input box, ready for you to begin entering numbers or expressions.

Radical notation for roots Input Boxes
To see input boxes on the screen, choose View
and check Input Boxes.

Evaluate andSimplifywill compute real roots of positive real num-
berswritten in either symbolic or Ĕoatingpointnotation. ăe result of
either of these operations is presented in symbolic orĔoatingpointno-
tation according to the form of the input. Evaluate and Simplify pro-
duce the same result from Ĕoating point numbers. Sometimes Sim-
plify is useful with symbolic numbers.
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Real Numbers

To insert the radical template
√
□

1. Place the insert point where you want the radical.

2. Choose Insert>Math Objects> Radical.

ăe template will appear with the insert point in the input box,
ready for you to begin entering numbers or expressions.

You can also Evaluate the built-in function simplify. Type sim-
plify in mathematics mode and it will automatically turn gray.
Toenter the expression 3√2

1. Choose Insert>Math Objects> Radical and type 2.

2. Press tab, type 3, and press space.

Compute> Evaluate
3
√

0.008 = 0.20 5
√

18.234 = 1.7872
√

24 = 2
√

6
3
√

16
27 = 1

3
3√16 4√16 = 2 3

√
−8 =−2

Compute> Simplify
3
√

16
27 = 2

3
3√2 4√162π6 = 3 4√2π 3

2

Compute> Evaluate

simplify
(

3
√
− 16

27

)
=− 2

3
3√2 simplify

(
4√162π6

)
= 3π 3

2
4√2

Rationalizing a Denominator
To rationalize the denominator of a fraction

1. Place the insert point in the fraction.

2. Choose Compute> Simplify.

Compute> Simplify
1√
2
= 1

2

√
2

1√
2+
√

3
=
√

3−
√

2
√

2+
√

3√
5−
√

7
= − 1

2

(√
2+
√

3
)(√

5+
√

7
)
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Numerical Approximations
Numerical calculations are exact whenever appropriate. You can

force a result to be in decimal notation either by choosing Evaluate
Numeric or by starting with numbers in decimal notation. Contrast
the responses to evaluation of the following expressions.

Compute> Evaluate Compute> Evaluate Numeric
82÷37 = 82

37 82÷37≈ 2.2162
936/14 = 468

7 936/14≈ 66.857
936/14.0 = 66.857 936/14.0≈ 66.857
14.2
85.5 = 0.16608 14.2

85.5 ≈ 0.16608
2
3 ÷

8
7 = 7

12
2
3 ÷

8
7 ≈ 0.58333√

234 = 3
√

26
√

234≈ 15.297(
54
)5

= 95367431640625
(
54
)5 ≈ 9.5367×1013

Digits Rendered
To set the number of digits displayed when
applying Evaluate Numeric, choose Tools>
Preferences> Computation, Output page, and
reset Digits Rendered. (For Mac users, choose
SWPPro> Preferences.)

Evaluate Numeric gives decimal approximations, or ęoating point
numbers.

Compute> Evaluate Numeric
9.6π−2.7π ≈ 21.677 42

( 2
3 +

1
7

)√
2≈ 48.083

Rewrite> Float has a similar behavior.

Compute> Rewrite> Float
9.6π−2.7π = 21.677 42

( 2
3 +

1
7

)√
2 = 48.083

Typing ęoat while in mathematics gives the grayed function float.
Evaluating float at a rational number gives the Ĕoating point form of
the number.

Compute> Evaluate

float(9.6π−2.7π) = 21.677 float
(

42
( 2

3 +
1
7

)√
2
)
= 48.083

You can specify the number of decimal places to be displayed. See
Appendix C “Customizing the Program for Computing.”

Scientiöc Notation
Any nonzero real number x can be written in the form

x = c×10n
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with 1≤ |c|< 10 and n an integer. A number in this form is in scien-
tiĖc notation. Following are some examples of scientiđc notation:

12 = 1.2×10
8274.9837 = 8.2749837×103

0.000001234 = 1.234×10−6

−54163.02 = −5.416302×104

Towrite a number in scientiđc notation
1. Enter the number c (in mathematics mode) to as many decimal

places as appropriate.

2. Click the Binary Operations button on the Symbols Toolbar

3. Click× in the symbols palette.

4. Type the number 10.

5. Choose Insert>Math Objects> Superscript and enter the in-
teger n in the input box.

ăe results of a numerical computation are sometimes returned in
scientiđc notation. ăis happens when the number of digits exceeds
the setting for Upper ăreshold for scientiđc notation output. See
Appendix C “Customizing the Program for Computing” for details
on changing this setting.

Functions and Relations
Numbers or expressions to be used for computing should be en-

tered in mathematics mode and appear red on your screen. If that is
not the case, choose Insert>Math to change the expression to math-
ematics.

Following are some of the basic built-in functions (absolute value,
maximumandminimum, greatest and smallest integer functions), and
built-in relations (union, intersection, and difference of sets).

See Absolute Value, page 33 for information on absolute values of
complex numbers.

Absolute value
ăe absolute value of a number z, the distance of z from zero, is

denoted |z|.
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Toput vertical bars around an expression
1. Select the expression. Caution

The vertical lines from the symbol panel of
Binary Relations will not be interpreted as
absolute-value symbols in computations.
Although they appear similar, they are not the
same symbols.
The keyboard vertical line will work to build an
absolute value, but expanding brackets are less
vulnerable to misinterpretation. Type Ctrl+\
for expanding absolute value bars.

2. Choose Insert>Math Objects> Brackets.

3. Click the vertical bracket and click OK.

Tocompute an absolute value
1. Place the insert point in an expression between vertical bars.

2. Choose Compute> Evaluate.

Compute> Evaluate
|−7|= 7 |−11.3|= 11.3 |43|= 43

Maximum and Minimum
ăe functions max and min đnd the largest and smallest numbers

in a list of numbers separated by commas and enclosed in brackets.
Leave the insert point in the expression and choose Evaluate.

Compute> Evaluate

max
(

13
2 ,−
√

63,7.3
)
= 7.3 min

(
13
2 ,−
√

63,7.3
)
=−3

√
7

Toenter functionnames formaximumandminimum
1. Choose Insert>Math Objects>Math Name.

2. Select from the list.

Or

1. Choose Insert>Math.

2. Type max or min.
Making the symbol toolbar visible

• Choose View> Toolbars

• Check Symbol toolbar

ăe binary operations join ∨ and meet ∧ also give maximum and
minimum.

Compute> Evaluate
27∨ 65

2 ∨−14 = 65
2 27∧ 65

2 ∧−14 =−14
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Toenter vee andwedge symbols formaximumandminimum Integer Variables
The expression max

−2≤x≤2

(
x3−6x+3

)
is

not the maximum of the continuous
polynomial function x3−6x+3 on the
interval−2≤ x≤ 2.

1. Click Binary Operations ±+ ▼ on the Symbol toolbar

2. Select∨ or∧ from the panel

To đnd the maximum or minimum of a đnite sequence, enter the
limits on the integer variable as a subscript on max or min, either in
the form of a double inequality such as 1≤ n≤ 10 or as membership
in an interval such as k ∈ [1,10].

Compute> Evaluate Compute> Evaluate Numeric
max1≤n≤10 (sinn) = sin8 max1≤n≤10 (sinn)≈ 0.98936

max1≤n≤10 (sin1.5n) = 0.99749 max−2≤x≤2
(
x3−6x+3

)
≈ 8.0

mink∈[1,10] (cosk) = cos3 mink∈[1,10] (cosk)≈−0.98999

mink∈[1,10] (cos2.6k) =−0.99418 mink∈[1,10] (cos2.6k)≈−0.9941

Note that the functions max and min look only at the sequence of
values for integer variables. ăenotations x∈ [−2,2] and−2≤ x≤ 2
both indicate that x assumes the range of values in the 5-element set
{−2,−1,0,1,2}. In the last example the maximum is picked from
among values of x3−6x+3 for x =−2,−1,0,1,2.

Greatest and Smallest Integer Functions
You can đnd the greatest integer less than or equal to a number by

using the Ĕoor function, denoted ⌊z⌋ .
Toput Ĕoor brackets around an expression

1. Select the expression with click and drag.

1. Choose Insert>Math Objects> Brackets.

2. Select the leĕ Ĕoor bracket ⌊ , and click OK.

Tođnd a greatest integer value
1. Place the insert point in an expression between Ĕoor brackets.

2. Choose Compute> Evaluate.

Compute> Evaluate
⌊5.6⌋= 5

⌊ 43
5

⌋
= 8

⌊−11.3⌋=−12 ⌊π + e⌋= 5

To đnd the smallest integer greater than or equal to a number, use
the ceiling function, denoted ⌈z⌉.
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Toput ceiling brackets around an expression
1. Select the expression with click and drag.

2. Choose Insert>Math Objects> Brackets.

3. Select the leĕ ceiling bracket ⌈ , and choose OK.

Tođnd a smallest integer value
1. Place the insert point in a number between ceiling brackets.

2. Choose Compute> Evaluate.

Compute> Evaluate
⌈5.6⌉= 6

⌈ 43
5

⌉
= 9

⌈−11.3⌉=−11 ⌈π + e⌉= 6

ăe Ĕoor and ceiling brackets are also available from the Delim-
iters tab ⟩⌉▼ , although these are not expanding brackets.

Checking Equality and Inequality
Youcanverify equalities and inequalitieswith the commandCheck

Equality orwith the function istrue. ăere are three possible responses:
true, false, and undecidable. ăe latter means that the test is inconclu-
sive and the equality may be either true or false. ăe computational
engine may use probabilistic methods to check equality, and there is a
very small probability that an equation judged as true is actually false.
Some expressions cannot be compared by this method—hence the in-
conclusive response.

Checking Equalities and Inequalities using Check Equality
Tocheckwhether an equality is true or false

1. Place the insert point in the equation.

2. Choose Check Equality.

Compute> Check Equality
eiπ = −1 is TRUE π = 3.14 is FALSE
arcsinsinx = x is FALSE

You can also use Check Equality to check an inequality between
two numbers. Set the difference of the two numbers equal to the ab-
solute value of the difference, place the insert point in the equation,
and choose Check Equality.
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Compute> Check Equality
9
8 −

8
9 =

∣∣ 9
8 −

8
9

∣∣ is TRUE πe− eπ = |πe− eπ | is FALSE

ăese results verify that 9
8 −

8
9 ≥ 0, or 9

8 ≥
8
9 ; and that πe− eπ < 0,

or πe < eπ .

Checking Equalities and Inequalities Using istrue
Type istrue inmathematicsmode to get the function name istrue,

or create it as a Math Name in the Insert > Math Objects > Math
Name dialog box. Evaluate this function at an equation or inequality
to test it.

Compute> Evaluate
istrue

( 9
8 < 8

9

)
=FALSE istrue(2+2 = 4) =TRUE

istrue(πe < eπ) =TRUE istrue
((√

2
)2

= 2
)
=TRUE

Checking Equalities and Inequalities Using Logical Operators
ăe operators∧ (AND) and∨ (OR) can be used as logical opera-

tors. ăe statement α ∧β is true if and only if both α and β are true.
ăe statementα∨β is true if and only if at least one ofα andβ is true.
Using a tautology such as 0 = 0 or 1 = 1 as one of the statements, you
can test the truth or falsity of another equation or inequality.

Compute> Evaluate(
56 < 65

)
∧ (1 = 1) =FALSE

(
56 > 65

)
∧ (1 = 1) =TRUE(

56 > 65
)
∨ (1 = 1) =TRUE

(
56 < 65

)
∨ (1 = 1) =TRUE

(1 = 1)∨ (1 = 0) =TRUE (eπ = πe)∧ (0 = 0) =FALSE

Checking Inequalities with Evaluate Numeric
In some cases, you can recognize an inequality by inspection aĕer

applying Evaluate Numeric to each of the numbers.

Compute> Evaluate Numeric
9
8 ≈ 1.125 8

9 ≈ 0.88889

πe ≈ 22.459 eπ ≈ 23.141

From this we see that 9
8 > 8

9 and πe < eπ .
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Union, Intersection, and Difference
You can đnd the union of two ormore đnite sets with Evaluate, by

using the symbol∪ between the sets.

Compute> Evaluate
{1,2,3}∪{a,b,c}= {1,2,3,a,b,c}
{1,2,3}∪ ({3,5}∪{7}) = {1,2,3,5,7}{√

2,π,3.9,r
}
∪{a,b,c}=

{
3.9,π,a,b,c,r,

√
2
}

You can đnd the intersection of two or more đnite sets with Eval-
uate, using the symbol∩ between the sets.

Compute> Evaluate
{1,2,3}∩{2,4,6}= {2} {a,b,c,d}∩{d,e, f}= {d}
{1,2,3}∩{a,b,c}= /0 {1,2,3}∩{}= /0

If two sets have no elements in common, their intersection is the
empty set, denoted by empty brackets {} or the symbol /0. To enter the
symbol /0 for the empty set, select it from the Miscellaneous Symbols
panel under ∞∂ .

You canđnd the difference of twođnite setswithEvaluate, by plac-
ing between the sets a backslash \ or the setminus symbol \ from the
Binary Operations panel.

Compute> Evaluate
{1,2,3,4}\{2,4}= {1,3} {a,b,c,d}\{d,e, f}= {a,b,c}
{1,2,3}\{a,b,c}= {1,2,3} {1,2,3}\{1,2,3}= /0

You can evaluate combinations of union, intersection, and differ-
ence aĕer grouping expressions appropriately with expanding paren-
theses.

Compute> Evaluate
{1,2,3,c}∩ ({2,4,6}∪{a,b,c}) = {2,c}
({1,2,3,c}∩{2,4,6})∪ ({1,2,3,c}∩{a,b,c}) = {2,c}
({2,4,6}∪{a,b,c})\{2,a,b}= {4,6,c}

Choice of imaginary unit
You may prefer to use the letter j instead of i.
If so, choose Tools> Preferences>
Computation, Input tab, and select Recognize
j as imaginary i.

Complex Numbers
ăe usual notation for a complex number is a+bi where a and b

are real numbers and i satisđes i2 =−1.
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Arithmetic
You can do arithmetic with complex numbers using Evaluate. ăe

result is the rectangular form a+bi of the complex number.
Appearance of imaginary unit
You may prefer a distinguished font for the
imaginary i. If so, choose Tools> Preferences
> Computation, Entities tab, and check
ImaginaryI. If you do not want i recognized as
the imaginary unit, click the Input tab, and
uncheck Recognize plain i as imaginary.
Choose OK.

Compute> Evaluate√
−5 = i

√
5 i

1+i =
1
2 +

1
2 i

(1+ i)(3−2i) = 5+ i (1+ i)÷ (3−2i) = 1
13 +

5
13 i

Absolute Value
ăeabsolute valueof a complexnumbera+bi is givenby |a+bi|=√

a2 +b2. You can compute the absolute value of a complex number
using Evaluate.

Compute> Evaluate
|1+ i|=

√
2

∣∣eiπ ∣∣= 1

Complex Conjugate
ăe complex conjugate of a+bi is written (a+bi)∗ or a+bi.

Complex Conjugate
To use overbar notation for complex conjugate,
choose Tools> Preferences> Computation,
Input tab, and check Overbar accent means
conjugate. Choose OK.

Compute> Evaluate
(1+ i)∗ = 1− i 1+ i = 1− i
(5−3i)∗ = 5+3i 5−3i = 5+3i

Real and Imaginary Parts
You can đnd the real and imaginary parts of a complex number

using the functions Re and Im. Entering functions
When you enter the functionsRe and Im in
mathematics mode, they will automatically
turn gray.

Compute> Evaluate
Re(1+ i) = 1 Im(5−3i) =−3

SeeComplexNumbers andComplexFunctions, page 89, formore
advanced topics concerning complex numbers.

Units and Measurements
ăe available units include units from the System of International

Units (SI units), an internationally agreed upon system of coherent
units that is now in use for all scientiđc and most technological pur-
poses in many countries. SI units are of three kinds: the base, supple-
mentary, and derived units. ăere are seven base units for the seven di-
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Chapter 2 | Numbers, Functions, and Units

mensionally independent physical quantities: length, mass, time, elec-
tric current, thermodynamic temperature, amount of substance, and lu-
minous intensity. Units from some other commonly used systems are
also implemented. You can deđne other units in terms of the ones
available in the Unit Name list.

Units
Units appear on your screen as dark green characters (unless you

have changed this default to another color). Units are in mathematics
mode and are active mathematical objects.

Compute> Solve> Exact
1mi = xkm, Solution: 1.6093
10cm = x in, Solution: 3.937

Toenter a unit name
1. Place the insert point at the position where you want the unit

name.

2. Choose Insert>Math Objects>Unit Name.

3. Select a category from the Physical õuantity list.

4. Select a name from the Unit Name list and choose OK.

ăe unit name will appear at the position of the insert point. ăe
Unit Name dialog will remain on your screen for further use. To close
it, click the× in the upper right corner of the dialog.
To replace a unit

1. Select the unit name you want to replace, either with click and
drag or by placing the insert point to the right of the unit name.

2. Choose Insert>Math Objects>Unit Name.

3. Select a category from the Physical õuantity list.

4. Select a name from the Unit Name list.

5. Choose Replace.

ăe new unit name will replace the previous unit name. ăe Unit
Name dialog will remain on your screen for further use. To close it,
click the× in the upper right corner of the dialog.
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Units are automatically recognized and can be entered from the
keyboard. See page 496 in Appendix B “Menus, Toolbars, and Short-
cuts for EnteringMathematics,” for a complete list of unit symbols and
keyboard shortcuts for each of the built-in physical quantities.

Arithmetic Operations with Units
You can carry out normal arithmetic operations with units using

Evaluate. If the units differ, the results will be returned in terms of
the basic unit in the category. Measurements will be returned in the
metric system.

Compound names are written as fractions or products, such as
ft/s, ft lbf, and acreft.

Compute> Evaluate
6ft+8ft = 14ft 4d+3min = 345780s
6ft×8ft = 48ft2 10m×5m = 50m2

4ft+16in = 1.6256m
10mi
15s

= 1072.9
m
s

1acreft = 1233.5m3 1acre+1hectare = 14047.m2

Converting Units
You can convert fromone unit to another. Place the insert point in

an equation of the form 47ft= xm or 47 ft
m = x and chooseCompute

> Solve> Exact.

Compute> Solve> Exact
7ft = x in, Solution: 84.0
458.4◦ = x rad, Solution: 8.0006

50
mi
h

= x km
h , Solution is: 80.467

1acreft = xgal, Solution: 3.2585×105

47lb = xkg, Solution: 21.319
7ft = xm, Solution: 2.1336
8rad = x ◦, Solution: 1440

π
10acre = xhectare, Solution: 4.0469
47 lb

kg = x, Solution: 21.319

ăedifferencebetween thenotionsof pound-mass ( lb) andpound-
force ( lbf) is illustrated in the following examples.
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Compute> Solve> Exact
1lbf = x lb, Solution: 9.8066 m

s2

47lbf = xkg, Solution: 209.07 m
s2

Exercises
1. Find all the primes between 100 and 120.

2. Find twopositive integers between1000 and1100whose great-
est common divisor is 23.

3. Evaluate numerically the power
(
1+ 1

n

)n for n = 2, 4, 8, 16,
32, 64, 128, and 256. What well-known number is starting to
emerge?

4. Experiment with numbers to test the potential identities

a∧ (b∨ c) = (a∧b)∨ (a∧ c)
a∨ (b∧ c) = (a∨b)∧ (a∨ c)

5. Test the potential identity

A∩ (B∪C) = (A∩B)∪ (A∩C)

using the sets A = {1,3,5,7,9}, B = {1,4,9,16}, and C =
{2,3,5,7,11}.

6. ăeweight of a block of aluminum is 403.2 lbf and the density
is 168 lbf

ft3
. What is its volume?

7. If a toy rocket shoots vertically upward with an initial velocity
of 80m/s, at t seconds aĕer the rocket takes off, until it returns
to the ground, it is at the height 80t−16t2 m. Find the time it
takes for the rocket to return to the ground. When does it reach
its highest point?

Solutions
1. Test the odd integers between 100 and 120 by factoring:

101 = 101 103 = 103 105 = 3×5×7 107 = 107
109 = 109 111 = 3×37 113 = 113 115 = 5×23
117 = 3213 119 = 7×17

ăus the primes in this range are 101, 103, 107, 109, and 113.
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2. Rewrite>Mixed gives 1000
23 = 43 11

23 . Note that 44 ·23 = 1012
and 45 ·23= 1035. Checking, we see that gcd(1012,1035) =
23. Find more pairs.

3. Note that
(
1+ 1

2

)2
= 2.25

(
1+ 1

4

)4
= 2.4414(

1+ 1
8

)8
= 2.5658

(
1+ 1

16

)16
= 2.6379(

1+ 1
32

)32
= 2.677

(
1+ 1

64

)64
= 2.6973(

1+ 1
128

)128
= 2.7077

(
1+ 1

256

)256
= 2.713

ăe number e = 2.7182818284590452354 is beginning to
emerge.

4. With the numbers 1, 2, and 3 we have

1∧ (2∨3) = 1 and (1∧2)∨ (1∧3) = 1
2∧ (3∨1) = 2 and (2∧3)∨ (2∧1) = 2
3∧ (1∨2) = 2 and (3∧1)∨ (3∧2) = 2

Similarly,

1∨ (2∧3) = 2 and (1∨2)∧ (1∨3) = 2
2∨ (1∧3) = 2 and (2∨1)∧ (2∨3) = 2
3∨ (1∧2) = 3 and (3∨1)∧ (3∨2) = 3

ăeseprovide experimental evidence that the following are iden-
tities:

a∧ (b∨ c) = (a∧b)∨ (a∧ c)
a∨ (b∧ c) = (a∨b)∧ (a∨ c)

5. Note that{1,3,5,7,9}∩({1,4,9,16}∪{2,3,5,7,11})= {1,3,5,7,9}
and ({1,3,5,7,9}∩{1,4,9,16})∪
({1,3,5,7,9}∩{2,3,5,7,11}) = {1,3,5,7,9}.

6. ăe volume of the block of aluminum is

403.2 lbf
168 lbf

ft3
= 0.06796m3

ăe volume in cubic feet is the solution to the equation
0.06796m3 = x ft3. ăe solution is x = 2.4.

37



i
i

“Compute60” — 2011/12/20 — 14:27 — page 38 — #48 i
i

i
i

i
i

Chapter 2 | Numbers, Functions, and Units

7. ăe rocket returns to the ground when its height is 0m. Solv-
ing
(
80t−16t2

)
m = 0m gives the two solutions t = 0 and

t = 5. ăe rocket thus returns to the ground in 5s. ăe rocket
reaches its highest point in half this time, that is, in 5

2 s = 2.5s.
ăe maximum height of the rocket is 80(2.5)− 16(2.5)2 =
100.0m.
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3
Algebra

[Algebra's] a merry science. When the animal that we are hunting cannot be caught, we call it X temporarily and continue to hunt
until it is bagged. Jakob Einstein (1850–1912)

A lgebraic operations are generalizations of arithmetic opera- Polynomials and Rational
Expressions

Substitution

Solving Equations

Deöning Variables and Functions

Exponents and Logarithms

Toolbars and Keyboard Shortcuts

tions. Algebraic expressions are obtained by starting with
variables and constants and combining them using addition,

subtraction, multiplication, division, exponentiation, and roots. ăe
simplest types of algebraic expressions use only addition, subtraction,
and multiplication; these are called polynomials. ăe general form of
a polynomial of degree n in the variable x is

anxn +an−1xn−1 + · · ·+a1x+a0

where a0, a1, . . ., an are constants and an ̸= 0.

Polynomials and Rational Expressions
You canperform the usual operations onpolynomials. ăe general

procedure is as described below.
Toworkwith a polynomial expression

1. Enter the expression in mathematics mode and leave the insert
point in the expression.

2. Apply one of the commands from the Compute menu.

You will đnd a variety of useful commands.
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Chapter 3 | Algebra

ăe commands on the Compute menu that operate on polyno-
mials include Evaluate, Simplify, Factor, Expand, Combine > Pow-
ers, and, from the Polynomials submenu,Collect, Divide, Partial Frac-
tions, Roots, Sort, and Companion Matrix. See Companion Matrix
and Rational Canonical Form on page 329 of Chapter 8 “Matrix Al-
gebra” for a discussion of the Companion Matrix command. ăe re-
maining commands are discussed in this chapter.

Sums, Differences, Products, and Quotients of Polynomials
Toperformbasic operations onpolynomials

1. Type the expression in mathematics mode and leave the insert
point in the expression.

2. Choose Compute> Evaluate. Reminder
The mathematics shown here depicts both
what you enter(

3x2 +3x
)
+
(
8x2 +7

)
and the result of the command Compute>
Evaluate

= 11x2 +3x+7

Compute> Evaluate(
3x2 +3x

)
+
(
8x2 +7

)
= 11x2 +3x+7(

3x2 +3x
)
/
(
8x2 +7

)
= 3x2+3x

8x2+7

(x+1)−1 (x−1)−1 = 1
(x−1)(x+1)

x÷ y = x
y

Toexpandproducts or quotients of polynomials
• With the insert point in thepolynomial expression, chooseCom-

pute> Expand.

Compute> Expand(
3x2 +3x−1

)(
8x2 +7

)
= 24x4 +24x3 +13x2 +21x−7

(x+1)−1 (x−1)−1 = 1
x2−1

Toenter the function expand Auto substitution
Choose Tools> Auto Substitution and make
appropriate choices to enable auto
substitution.

• Choose Insert > Math Objects > Math Name, type expand in
the dialog box, check Function, and choose OK, or

In mathematics mode, type xpnd.

Compute> Evaluate
expand

((
3x2 +3x−1

)(
8x2 +7

))
= 24x4 +24x3 +13x2 +21x−7
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Division by Polynomials
You can convert a quotient of polynomials f (x)

g(x) with rational coef-

đcients to the form q(x)+ r(x)
g(x) , where r(x) and q(x) are polynomials

and degr(x)< degg(x).

Todivide polynomials Polynomials> Divide
This algorithm is the familiar long-division
algorithm for polynomials.

1. Enter a quotient of polynomials.

2. Leave the insert point in the expression.

3. Choose Compute> Polynomials>Divide.

Compute> Polynomials> Divide

3x5+3x3−4x2+5
8x2+7 = 3

64 x−
21
64 x− 17

2
8x2+7 + 3

8 x3− 1
2

5y2−3y+4
3y−5 = 5

3 y+ 116
9(3y−5) +

16
9

Summation Notation
A polynomial in general form can be written in summation nota-

tion
n

∑
k=0

akxk = anxn +an−1xn−1 + · · ·+a1x+a0

Toenter a polynomial as a summation∑5
k=0 akxk

1. Choose Insert>Math Objects>Operator and choose ∑.

2. Choose Insert>Math Objects> Subscript and type k = 0.

3. Press tab and type 5.

4. Press the spacebar and type akxk.

Compute> Evaluate
∑5

k=0 akxk = a5x5 +a4x4 +a3x3 +a2x2 +a1x+a0

Sums and Differences of Rational Expressions
A quotient of two polynomials is called a rational expression.
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To rewrite inverse notation as a rational expression
1. Type or select the expression.

2. Choose Compute> Rewrite> Rational (ăis preserves a fac-
torization), or

Choose Compute> Simplify, or

Choose Compute> Rewrite>Normal Form (ăis expands a
factorization.)

Compute> Rewrite> Rational(
8x2 +7

)−1 (x+2x2 +7
)−1

= 1
(8x2+7)(2x2+x+7)

The mathematics shown here depicts both
what you enter(

8x2 +7
)−1 (

x+2x2 +7
)−1

and the result of the command Compute>
Rewrite> Rational

=
1

(8x2 +7)(2x2 + x+7)

Compute> Simplify(
8x2 +7

)−1 (x+2x2 +7
)−1

= 1
(x+2x2+7)(8x2+7)

Compute> Rewrite> Normal Form(
8x2 +7

)−1 (x+2x2 +7
)−1

= 1
16x4+8x3+70x2+7x+49

Tocombine rational expressions over a commondenominator
1. Enter the expressions.

2. Choose Compute> Rewrite>Normal Form, or

Choose Compute> Simplify, or

Choose Compute> Factor.

Compute> Rewrite> Normal Form
x

x2−1 +
3x−1

x2−3x+2 =− 4x2−1
−x3+2x2+x−2

Compute> Simplify
x

x2−1 +
3x−1

x2−3x+2 =− 4x2−1
−x3+2x2+x−2

Compute> Factor
x

x2−1 +
3x−1

x2−3x+2 = (2x+1)(2x−1)
(x−1)(x−2)(x+1)
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Partial Fractions
ăe command Partial Fractions appears on both the Polynomials

and Calculus submenus. With this command, you can write a ratio-
nal expression as a sum of simpler fractions—essentially the reverse of
the operation demonstrated in the previous section. See page 230 in
Chapter 7 “Calculus” for an application of Partial Fractions.

ăe Partial Fractions command expands a rational expression into
a sum of rational expressions having denominators that are multiples
of powers of linear and irreducible quadratic factors of the denomi-
nator. In this case irreduciblemeans the roots are neither rational nor
rational combinations of the coefficients of the polynomials.

ăenumerators of the partial fractions are constants or, in the case
the denominator is a power of an irreducible quadratic, linear. ăus
each partial fraction is of the form

A
(ax+b)n or

Ax+B
(ax2 +bx+ c)m

If more than one variable occurs in the expression, specify your
choice of variable in the dialog box that appears. ăe other variables
will be treated as arbitrary constants.
Towrite a rational expression as a sumof simpler rational expressions

1. Enter the rational expression in mathematics mode and leave
the insert point in the expression.

2. Choose Polynomials> Partial Fractions, or
Choose Calculus> Partial Fractions.

3. Specify variable if Need Polynomial Variable dialog appears.

Compute> Polynomials> Partial Fractions
36

(x−2)(x−1)2(x+1)2 = 4
x−2 −

9
(x−1)2 − 3

(x+1)2 − 4
x+1

x3+x2+1
x(x−1)(x2+x+1)(x2+1)

3 =
3
4 x+ 3

4

(x2+1)
2 −

1
2 x− 1

2

(x2+1)
3 +

15
8 x− 1

8
x2+1 + 1

8(x−1) −
x+1

x2+x+1 −
1
x

(Variable: y) y
(x−y)2(x+1) =

x
(x−y)2(x+1)

− 1
(x−y)(x+1)

(Variable: x) y
(x−y)2(x+1) =

y
(x+1)(y2+2y+1)

− y
(x−y)(y2+2y+1)

−

(
y2

y2+2y+1
− 2y2+y

y2+2y+1

)
(x−y)2

ăis operation does not accept decimal or Ĕoating-point numbers,
so write the coefficients as integers or quotients of integers. Use
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Compute>Rewrite>Rational if you have expressions with decimal
or Ĕoating-point numbers (see Real Numbers, page 23).

Collecting and Ordering Terms
ăeSort command on the Polynomials submenu collects numeric

coefficients of terms of a polynomial expression and returns the terms
in order of decreasing degree. ăe Collect command on the Polyno-
mials submenu collects all coefficients of terms of a polynomial expres-
sion, but does not necessarily sort the terms by degree. Specify your
choice of polynomial variable in the dialog box that appears.

Compute> Polynomials> Sort

x2 +3x+5−3x3 +5x2 +4x3 +13+2x4 = 2x4 + x3 +6x2 +3x+18

5t2 +3xt2−16t5 + y3−2xt2 +9 = t2x−16t5 +5t2 + y3 +9 (Variable: x)

5t2 +3xt2−16t5 + y3−2xt2 +9 =−16t5 + t2 (x+5)+ y3 +9 (Variable: t)

Compute> Polynomials> Collect

5t2 +3xt2−16t5 + y3−2xt2 +9 = t2x−
(
16t5 +5t2− y3−9

)
(Variable: x)

5t2 +3xt2−16t5 + y3−2xt2 +9 =−16t5 +(x+5) t2 + y3 +9 (Variable: t)

Factoring Polynomials Floating-point numbers
Numbers such as 1.5 are interpreted as
øoating-point numbers, and Factor does not
handle polynomials with øoating-point
coefficients. Replace decimal numbers with
fractions (such as 1.5 = 3

2 ) using Rewrite>
Rational, and then choose Factor.

ăe ability to factor polynomials is an important algebraic tool.
You will đnd that the factoring capabilities of your computer algebra
system are powerful and useful. You can factor polynomials with inte-
ger or rational roots and with other roots directly related to the coeffi-
cients of the expanded polynomial. To factor a polynomial, you must
type it without using decimal notation.

To factor a polynomialwith exact coefficients
• With the insert point in the polynomial, choose Compute >

Factor.

Compute> Factor

5x5 +5x4−10x3−10x2 +5x+5 = 5(x−1)2 (x+1)3

1
16 x2− 7

5 x+ 1
6 ix− 56

15 i = 1
16

(
x− 112

5

)(
x+ 8

3 i
)

120x3 +20
(
−3+2

√
3
)

x2− 5
2

(
8
√

3−3
)

x+ 5
2

√
3 = 120

(
x+ 1

3

√
3
)(

x− 1
4

)2
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ăe Factor command is effective primarily for polynomials with
integer or rational coefficients, although it also factors polynomials
whose roots are closely related to the coefficients, as demonstrated in
two of the preceding examples. Technically, the polynomial is fac-
tored over the đeld generated by its coefficients. If all the coefficients
are rational, then the polynomial is factored over the rationals. If you
know the form of the root, you canmultiply by an appropriate expres-
sion to obtain a factorization.

Compute> Factor

5x2 + x+3 = 5x2 + x+3

i
√

59
(
5x2 + x+3

)
= 5i
√

59
(
x+ 1

10 −
1

10 i
√

59
)(

x+ 1
10 +

1
10 i
√

59
)

Alternatively, while in mathematics mode, type f actor, enter the
polynomial inside parentheses, and choose Evaluate. For the com-
mand expand, type xpnd in mathematics mode. If your system is
not set for automatic recognition, you can enter factor or expand as a
Math Name.

Compute> Evaluate
factor

(
5x5 +5x4−10x3−10x2 +5x+5

)
= 5(x−1)2 (x+1)3

expand
(

5(x−1)2 (x+1)3
)
= 5x5 +5x4−10x3−10x2 +5x+5

You can factor not only the difference of two squares and the sum
and difference of two cubes, but also the difference of any two equal
powers.

Compute> Factor

x2− y2 = (x− y)(x+ y)

x3− y3 = (x− y)
(
x2 + xy+ y2

)
x4− y4 = (x− y)(x+ y)

(
x2 + y2

)
You can also factor the sum of any two equal odd powers.

Compute> Factor

x3 + y3 = (x+ y)
(
x2− xy+ y2

)
x5 + y5 = (x+ y)

(
x4− x3y+ x2y2− xy3 + y4

)
x7 + y7 = (x+ y)

(
x6− x5y+ x4y2− x3y3 + x2y4− xy5 + y6

)
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Greatest Common Divisor of Two Polynomials
ăe greatest common divisor of two or more polynomials is com-

puted in the same way as the greatest common divisor of two or more
integers. (See Greatest Common Divisor, page 22.)
Tođnd the greatest commondivisor of twoormore polynomials

1. Type gcd in mathematics mode. (ăis changes to a gray gcd as
you type the đnal d.)

2. Type the polynomials enclosed by parentheses and separated by
commas.

3. Choose Compute> Evaluate.

Compute> Evaluate

gcd(5x2−5x,10x−10) = 5x−5

gcd
(
x2 +3x+ yx+3y, x2−4yx−5y2,3x2 +2yx− y2

)
= x+ y

You can check these results by factoring the polynomials and com-
paring the factors.

Compute> Factor
x2 +3x+ yx+3y = (x+3)(x+ y)

x2−4yx−5y2 = (x−5y)(x+ y)

3x2 +2yx− y2 = (3x− y)(x+ y)

ăe least common multiple function (see Least Common Multi-
ple, page 22) is also available for polynomials.
Tođnd the least commonmultiple of twoormore polynomials

1. Type lcm in mathematics mode. (It will turn gray.)

2. Type the polynomials enclosed by parentheses and separated by
commas.

3. Choose Evaluate.

Compute> Evaluate
lcm(yx+3x−5y−15,xz−53x−5z+265)

= 265y−159x−15z−53xy+3xz−5yz+ xyz+795
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Apply Factor to the polynomials and to their least common mul-
tiple to reveal the relationship among these polynomials.

Compute> Factor
yx+3x−5y−15 = (y+3)(x−5)

xz−53x−5z+265 = (z−53)(x−5)

265y−159x−15z−53xy+3xz−5yz+ xyz+795 = (z−53)(y+3)(x−5)

Substitution
Use common notation for variable substitution:

[F (x)]x=a = F (a) and [F (x)]x=b
x=a = F (b)−F (a)

Substituting for a Variable
To substitute a number or new expression for a variable

1. Enclose the expression in square brackets.

2. Choose Insert>Math Objects> Subscript.

3. Type an assignment for the variable in the subscript input box.

4. Choose Compute> Evaluate.

Compute> Evaluate[
x2 +2x−3

]
x=a = a2 +2a−3

[
x2 +2x−3

]
x=5 = 32

[x+ y]x=y+z = 2y+ z [x+ y]y=x−z = 2x− z[
x2 +2x−3

]
x=y−z = 2y−2z+(y− z)2−3

Assignments
The expression in the subscript is an
assignment for the variable on the left of the
equals sign. Notice that, in particular, x = a
and a = x are not equivalent assignments;
and x = y+ z, y = x− z, and z = x−y
are not equivalent assignments.

Evaluating at Endpoints
To substitute two expressions for a variable and compute the difference

1. Enclose the expression in square brackets.

2. Choose Insert>Math Objects> Subscript.

3. Type an assignment for the variable in the subscript input box.

4. Press tab to create a superscript box.

5. Type another assignment for the variable in the superscript in-
put box.
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6. Choose Compute> Evaluate.

Compute> Evaluate
[x]x=b

x=a = b−a
[
x2 +2x−3

]x=5
x=3 = 20[

x2 +2x−3
]x=b

x=a =−a2−2a+b2 +2b

Solving Equations
Youcan solvepolynomial equationsby choosingCompute>Poly-

nomials > Roots or by choosing Compute > Solve. We đrst look at
examples for đnding roots of polynomials. ăen we look at the more
general problems of solving equations with one or more variables.

Roots of Polynomials
If zero is obtained when a number is substituted for the variable in

a polynomial, then that number is a root of the polynomial. In other
words, the roots of a polynomial p(x) are the solutions to the equation
p(x) = 0. For example, 1 is a root of x2−1 since

[
x2−1

]
x=1 = 0. Useful Fact

A number r is a root of a polynomial if and
only if x− r is a factor of that polynomial.

Youcanđndall real and complex roots of a real or complexpolyno-
mial with rational coefficients by choosing Compute > Polynomials
> Roots.
Tođnd the roots of a polynomial

1. Type the polynomial and leave the insert point in the expres-
sion.

2. Choose Compute> Polynomials> Roots.

Compute> Polynomials> Roots

5x2 +2x−3, roots: −1, 3
5 x2 +1, roots: −i, i

x3− 13
5 ix2−8x2 + 29

5 ix+ 81
5 x+6i− 18

5 , roots: 3,5+3i,− 2
5 i

Youcan simplify complex radical expressionswithRewrite>Rect-
angular.

Compute> Rewrite> Rectangular( 5
2 +

13
10 i
)
− 1

10

√
(336+850i) = 2

5 i(−1)

1
10

√
(336+850i)+

( 5
2 +

13
10 i
)
= 5+3i

You can change settings so that only real roots will be computed.
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Solving Equations

Tođnd (only) real roots of a polynomial
1. While in mathematics mode, type assume(x, real) and choose

Compute> Evaluate.

2. Place the insert point in the polynomial and choose Compute
> Polynomials> Roots.

Compute> Evaluate
assume(x, real) = R

Compute> Polynomials> Roots

x3− 13
5 ix2−8x2 + 29

5 ix+ 81
5 x+6i− 18

5 , roots: 3

5x2 + x+3, roots: /0

ăe symbol /0 denotes the empty set, meaning there is no real so-
lution.
To return to the defaultmode

1. While in mathematics mode, type unassume(x).

2. Choose Compute> Evaluate.

It follows fromtheFundamentalăeoremofAlgebra that thenum-
ber of roots (including complex roots and counting multiplicities) is
the same as the degree of the polynomial. For polynomials with ratio-
nal (real or complex) coefficients, the computer algebra system uses
the usual formulas for đnding roots symbolically for polynomials of
degree 4 or less, and it đnds the roots numerically for polynomials of
higher degree. ăis implementation was dictated by the mathemati-
cal phenomenon that there is no general formula in terms of radical
expressions for the roots of polynomials of degree 5 and higher. For
polynomials of any degree with Ĕoating point or decimal coefficients,
the computer algebra system đnds the roots numerically.

Second-Degree Polynomials
You can obtain the familiar quadratic formula for roots of ax2 +

bx+c. ăe solution includes all cases. ăe logical symbol∧ is used for
AND, so a = 0∧b = 0∧ c = 0 is the case that all three coefficients,
a,b,c, are zero. (Interpret this as (a = 0)∧ (b = 0)∧ (c = 0).) ăe
symbol C denotes the set of all complex numbers. ăe symbol /0 de-
notes the empty set; that is, the case when there are no solutions.
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Compute> Polynomials> Roots (Variable: x)

ax2 +bx+ c, roots:

{
−
(

b−
√
−4ac+b2

)
2a ,−

(
b+
√
−4ac+b2

)
2a

}
if a ̸= 0{

− c
b

}
if a = 0∧b ̸= 0

C if a = 0∧b = 0∧ c = 0
/0 if a = 0∧b = 0∧ c ̸= 0

Third- and Fourth-Degree Polynomials
ăe roots of third- and fourth-degree polynomials can be com-

plicated, with multiple embedded radicals in the expressions. To put
those roots in simpler form, youmay want numerical approximations.
You get numerical results if you enter at least one coefficient in decimal
notation. You can also get a numerical formdirectly fromthe symbolic
one by applying Evaluate Numeric to the matrix of roots. ăe follow-
ing examples show both a symbolic solution and a numerical solution
(with Digits Shown in Results set to 6).

Compute> Polynomials> Roots

x3 +3x+1, roots:

3
√

1
2

√
5− 1

2 −
1

3
√

1
2
√

5− 1
2

1

2 3
√

1
2
√

5− 1
2

− 1
2

3
√

1
2

√
5− 1

2 −
1
2 i
√

3

(
1

3
√

1
2
√

5− 1
2

+ 3
√

1
2

√
5− 1

2

)

1

2 3
√

1
2
√

5− 1
2

− 1
2

3
√

1
2

√
5− 1

2 +
1
2 i
√

3

(
1

3
√

1
2
√

5− 1
2

+ 3
√

1
2

√
5− 1

2

)

x3 +3x+1.0, roots: −0.32219, 0.16109−1.7544i, 0.16109+1.7544i

Substituting the exact roots for x in the polynomial x3 + 3x+ 1
gives zero, as it should. ApplyingEvaluate has little effect, but Simplify
gives the following result.

Compute> Simplify[
x3 +3x+1

]
x= 1

2 3
√

1
2
√

5− 1
2
− 1

2
3
√

1
2
√

5− 1
2+

1
2 i
√

3

(
1

3
√

1
2
√

5− 1
2
+ 3
√

1
2
√

5− 1
2

) = 0
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Solving Equations

Using the numerical approximations to the roots, you may get a
very small, but nonzero, value. To get closer approximations to the
roots, increase the number of digits shown in the display of these roots
bymaking changes in the computation output settings. For details, see
Appendix C “Customizing the Program for Computing.”

Compute> Evaluate
(−0.322185)3 +3(−0.322185)+1.0 = 1.174312318×10−6

(−0.32218535462608559291)3 +3(−0.32218535462608559291)+1
= 4.870126439×10−21

Compute> Polynomials> Roots
x4 +3x3−2x2 + x+1.0,

roots: −3.6096,−0.42898,0.51928+0.61332i,0.51928−0.61332i
x4−7x3 +2x2 +64x−96, roots: −3, 2, 4, 4

Example ăe factorization

x3− 8
3

x2− 5
3

x+2 =
1
3
(x−3)(3x−2)(x+1)

identiđes the three roots 3, 2
3 ,−1, which are precisely the values of the

x-coordinate where the graph of y = x3− 8
3 x2− 5

3 x+2 crosses the x-
axis. ăe plot depicts this polynomial expression. Chapter 6 “Plotting
Curves and Surfaces” tells how to create plots.

­2 ­1 1 2 3 4

­20

­10

10

x

y

Example ăe factorization of the complex polynomial

x3− 13
5

ix2−8x2+
29
5

ix+
81
5

x+6i− 18
5

=(x−3)
(
x+ 2

5 i
)
(x− (5+3i))

displays the three roots 3,− 2
5 i, 5+3i.

Polynomials of Degree 5 and Higher
Numerical approximations are returned for roots of polynomials

of degree 5 and higher. You can change the number of digits shown
in the display of these roots by making changes in the Scientiđc No-
tation Output settings at Tools > Preferences > Computation, Out-
put page. For details, see Appendix C “Customizing the Program for
Computing.”
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Compute> Polynomials> Roots
5x5 +5x4−10x3−10x2 +5x+5, roots: −1.0,−1.0,−1.0,1.0,1.0

x8 + x7 + x6 + x5 + x4 + x3 + x2 + x+1, roots: 0.76604−0.64279i,
−0.5+0.86603i,−0.93969+0.34202i,−0.5−0.86603i,0.76604+0.64279i,
0.17365+0.98481i,0.17365−0.98481i,−0.93969−0.34202i

Since

x9−1 =
(

x8 + x7 + x6 + x5 + x4 + x3 + x2 + x+1
)
(x−1)

the roots of x8 +x7 +x6 +x5 +x4 +x3 +x2 +x+1 consist of ninth
roots of 1. In the complex plane, these points lie on a circle of radius
1.

Equations with One Variable
ăere are four options on the Solve submenu: Exact, Integer, Nu-

meric, and Recursion. ăe option Exact is general in nature and is
used in most situations. It returns symbolic solutions when it can and
numerical solutions otherwise. If any of the components of the prob-
lem use numerical notation, the response is a numerical solution. ăe
three options Integer, Numeric, and Recursion are used in more spe-
cialized situations. ăese will be discussed later—see Numerical So-
lutions, page 56, Numerical Solutions to Equations, page 215, Integer
Solutions, page 445, and Recursive Solutions, page 447.

Solutions given for polynomial equations include complex solu-
tions.
To solve an equationwith one variable

1. Place the insert point in the equation.

2. Choose Compute> Solve> Exact.

Your system returns an explicit or implicit solution.
Note that in the following examples, integer or rational coefficients

yield algebraic solutions and real (Ĕoating-point) coefficients yielddec-
imal approximations.

Compute> Solve> Exact
5x2 +3x = 1, Solution: 1

10

√
29− 3

10 ,−
1

10

√
29− 3

10

5x2 +3x = 1.0, Solution: 0.23852,−0.83852

x3−3x2 + x−3 = 0, Solution: i,−i,3
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When there are multiple roots, only distinct roots are displayed.

Compute> Solve> Exact
(x−5)3 (x+1) = 0, Solution: 5,−1

You can solve equations with rational expressions, and equations
involving absolute values.

Compute> Solve> Exact
14

a+2
− 1

a−4
= 1, Solution: 5,10

|3x−2|= 5, Solution:
{ 5

3 e2ix + 2
3 |x ∈ [0,π]

}
If you want only real roots, đrst evaluate assume(x, real). When

you enter these words in mathematics mode, they automatically turn
upright and gray. You can also use Insert >Math Objects > Math
Name to enter assume(x, real). (See Assumptions About Variables,
page 111 for more information on the “assume” function.)

Compute> Evaluate
assume(x, real) = R

Compute> Solve> Exact
x = i, No solution found.
x3−3x2 + x−3 = 0, Solution: 3
|3x−2|= 5, Solution: −1, 7

3

In general, explicit solutions in terms of radicals for polynomial
equations of degree greater than 4 do not exist. In these cases, implicit
solutions are given in terms of roots of a polynomial. When the equa-
tion is a polynomial equation with degree 3 or 4, the explicit solution
can be very complicated—and too large to preview, print, or save. To
avoid this problem, you can set the engine to return large complicated
solutions in implicit form for smaller degree polynomials as well. See
Appendix C “Customizing the Program for Computing” for details.

With a setting of 1 for maximum degree, only rational or other
relatively simple solutions are computed for all polynomials. With a
setting of 2 or 3, this behavior occurs for polynomials of degree greater
than 2.

Compute> Solve> Exact
(Maximum Degree set to 1)
5x2 +3x = 1, Solution: RootOf

( 3
5 Z +Z2− 1

5

)
x4 + x = 0, Solution: {−1,0}∪RootOf

(
−Z +Z2 +1

)
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Compute> Solve> Exact
(Maximum Degree set to 2 or 3)
5x2 +3x = 1, Solution: 1

10

√
29− 3

10 ,−
1

10

√
29− 3

10

x4 + x = 0, Solution: 1
2 +

1
2 i
√

3, 1
2 −

1
2 i
√

3,−1,0

x4 + x−1 = 0, Solution: RootOf
(
Z +Z4−1

)
Compute> Solve> Exact
(Maximum Degree set to 4)

x4 + x = 0, Solution: 1
2 +

1
2 i
√

3, 1
2 −

1
2 i
√

3,−1,0

x4 + x−1 = 0 (Solution too long to display here)

ăe function solve takes an equation as input. Evaluate solve at
an equation and the output is a list of solutions. Tomake the function
name, type solve while inmathematicsmode and it will automatically
gray, or create the name with Insert>Math Objects>Math Name.

Compute> Evaluate

solve
(
5x2 +3x = 1

)
=
{[

x =− 1
10

√
29− 3

10

]
,
[
x = 1

10

√
29− 3

10

]}
Checking the Answer

Substitution provides a convenient way of testing solutions.

Example Check the solutions to several of the preceding equations.

Compute> Evaluate Compute> Simplify[ 14
a+2 −

1
a−4

]
a=5 = 1

[
5x2 +3x

]
x=− 3

10+
1

10
√

29 = 1[
5x2 +3x

]
x=0.23852 = 1.0[

5x2 +3x
]

x=−0.83852 = 1.0

Equations with Several Variables
If there is more than one variable, enter the Variable(s) to Solve

for in the dialog box that opens when you choose Compute > Solve
> Exact.
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Compute> Solve> Exact

1
x
+

1
y
= 1, (Enter x), Solution:

 /0 if y = 1{
− 1

1
y−1

}
if y ̸= 1

1
y
+

1
z
+

1
x
= 1, (Enter z), Solution:


/0 if 1

x +
1
y = 1{

− 1
1
x +

1
y−1

}
if 1

x +
1
y ̸= 1

1
r1

+
1
r2

=
1
R

, (Enter R), Solution:

{
/0 if r1 + r2 = 0{

r1r2
r1+r2

}
if r1 + r2 ̸= 0

Systems of Equations
Youcan create a systemof equations either by entering equations in

a one-column matrix or by entering equations in a multi-row display.
Tocreate a systemof equations using amatrix

1. Choose Insert>Math Objects>Matrix.

2. Set the number of rows equal to the number of equations.

3. Set the number of columns to 1, and choose OK. Tip
From the Viewmenu, check Helper Lines or
Input Boxes to help place equations in a matrix
or display.

4. Type the equations in the matrix, one equation to a row.

Tocreate a systemof equations using a display
1. Choose Insert>Math Objects>Display.

2. Type the equations in the display, one equation to a row, adding
rows as needed with the Enter key.

To solve a systemof equations
1. Create a system of equations and leave the insert point in the

system.

2. Choose Compute> Solve> Exact.

3. If a dialog box opens asking Variable(s) to Solve for, type the
variable name(s) in the box, separated by commas.

Following are examples for systems of two equations.
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Compute> Solve> Exact
2x− y = 5
x+3y = 4 , Solution:

[
x = 19

7 ,y =
3
7

]
x2− y2 = 5
x+ y = 1 , Solution: [x = 3,y =−2]

x2−3y = 7
6x+4y = 9 , Solution:

[
x = 1

4

√
301− 9

4 ,y =
45
8 −

3
8

√
301
]
,[

x =− 1
4

√
301− 9

4 ,y =
3
8

√
301+ 45

8

]
When the number of unknowns is larger than the number of equa-

tions, you are asked to specify variables in a dialog box.

Compute> Solve> Exact
x+3y = 4
3x−4z = 7 , Variable(s): x,y

Solution:
[
x = 4

3 z+ 7
3 ,y =

5
9 −

4
9 z
]

2x− y = 1
x+3z = 4

w+ x =−3
, Variable(s): x,y,z

Solution:
[
x =−w−3,y =−2w−7,z = 1

3 w+ 7
3

]
Numerical Solutions

You can đnd numerical solutions in two ways. You can choose
Compute > Solve > Exact aĕer entering at least one coefficient in
Ĕoating-point form—that is, with a decimal.

Compute> Solve> Exact
x2 +7x−5.2 = 0, Solution: 0.67732,−7.6773

x3−3.8x−15.6 = 0, Solution: 3.0,−1.5+1.7176i,−1.5−1.7176i

You can choose Compute > Solve > Numeric. ăis gives all so-
lutions, both real and complex, to a polynomial equation or system of
polynomial equations.
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Compute> Solve> Numeric
x2 +7x−5.2 = 0, Solution: {[x = 0.67732] , [x =−7.6773]}
x3−3.8x−15.6 = 0, Solution: {[x =−1.5+1.7176i] , [x =−1.5−1.7176i] , [x = 3.0]}

x8 +3x2−1 = 0, Solution: {[x =−1.0023+0.63210i], [x =−1.0023−0.63210i],
[x = 1.0023+0.63210i], [x = 1.0023−0.63210i], [x =−0.57394],
[x = 0.57394], [x =−1.2408i], [x = 1.2408i]}[
x2 + y2 = 5
x2− y2 = 1

]
, Solution: {[x =−1.7321,y =−1.4142],

[x =−1.7321,y = 1.4142], [x = 1.7321,y =−1.4142], [x = 1.7321,y = 1.4142]}

ăe choice Compute > Solve > Numeric is particularly useful
when solving transcendental equations or systems of transcendental
equations, or when you want to specify a search interval for the solu-
tion.
Tođnd anumerical solutionwithin a speciđed range of the variable

1. Add a row to the bottom of the matrix, or

Press Enter to generate a new input box in a display.

2. Write the intervals of your choice, anduse themembership sym-
bol∈ to indicate that the variable lies in that interval.

Compute> Solve> Numeric
x2 + y2 = 5
x2− y2 = 1
x ∈ (−2,0)
y ∈ (0,2)

, Solution: [x =−1.7321,y = 1.4142]

Tođnd all numerical solutions to a systemof polynomial equations
1. Change at least one of the coefficients to Ĕoating-point form.

2. Choose Compute> Solve> Exact.

Compute> Solve> Exact

x2 + y2 = 5.0
x2− y2 = 1.0

, Solution :

{y =−1.4142,x = 1.7321}
{y =−1.4142,x =−1.7321}
{y = 1.4142,x = 1.7321}
{y = 1.4142,x =−1.7321}
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ăese four solutions are illustrated in the graph on the right, as the
four points of intersection of two curves. See Implicit Plots on page
132 for guidelines on making such graphs.

­4 ­2 2 4

­4

­2

2

4

x

y

x2 + y2 = 5
x2− y2 = 1

See Appendix C “Customizing the Program for Computing” for
details on changing the appearance of these numerical solutions by re-
setting Digits Rendered, Upper ăreshold, and Lower ăreshold for
Scientiđc Notation Output.

Inequalities
You can đnd exact solutions for many inequalities.

To solve an inequality
• With the insert point in the inequality, choose Compute >

Solve> Exact.

Compute> Solve> Exact

16−7y≥ 10y−4, Solution:
(
−∞,

20
17

]
x3 +1 > x2 + x, Solution: (−1,1)∪ (1,∞)

x2 +2x−3 > 0, Solution: (1,∞)∪ (−∞,−3)
|2x+3| ≤ 1, Solution:

{ 1
2 xeiy− 3

3 |x ∈ [0,1] ,y ∈ [0,2π]
}

7−2x
x−2

≥ 0, Solution:
(
2, 7

2

]
ăese solutions are intervals—open, closed, or half-open and half-

closed:

­4 ­2 2 4

10

20

x

y

x2 +2x−3

(a,b) = {x : a < x < b} [a,b] = {x : a≤ x≤ b}
(a,b] = {x : a < x≤ b} [a,b) = {x : a≤ x < b}

For two sets (intervals) A and B,

A∪B = {x : x ∈ A or x ∈ B}
A∩B = {x : x ∈ A and x ∈ B}

ăe solution to the last inequality, x2 + 2x− 3 > 0, can also be
read from the graph of the polynomial y = x2+2x−3. In the plot on
the right, you see the graph passes through the x-axis at x = −3 and
x = 1, and the solution includes every point to the leĕ of−3 or to the
right of 1.
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Deöning Variables and Functions
ăe Deđnitions commands enable you to deđne a symbol to be

a mathematical object and to deđne a function using an expression
or a collection of expressions. Four operations on the Deđne sub-
menu—New Deđnition, Undeđne, Show Deđnitions, Clear Deđni-
tions—are explained brieĔy in this section for the types of expressions
and functions that occur in precalculus. Deöned expressions

The symbol p deöned here represents the
expression x3 +3x2−5x+1. It is not a
function, and in particular, p(2) is not the
expression evaluated at x = 2. In fact, p(2)
is interpreted simply as the product 2p =
2x3 +6x2−10x+2.

See Chapter 5 “Function Deđnitions,” for greater detail on these
operations and other aspects of deđnitions. For examples of these op-
erations pertinent to topics such as calculus, vector calculus, and ma-
trix algebra, see the chapter covering the topic.

Assigning Values to Variables
You can assign a value to a variable using Deđnitions>New Def-

inition.
Toassign the value 5 to z

1. Type z = 5 in mathematics mode.

2. Choose Compute>Deđnitions>New Deđnition.
Deöned Functions
Deöning f (y) = ay2 +by+ c deönes
the same function as deöning f (x) = ax2

+bx+ c. The symbol used for the function
argument in making the deönition does not
matter. This point illustrates the subtle but
essential difference between expressions and
functions. In particular, the two expressions
y = x2 +

√
x and y = t2 +

√
t are

different (because y gets replaced by an
expression in x under the örst deönition and y
gets replaced by an expression in t under the
second deönition). However, the functions
f (x) = x2 +

√
x and f (t) = t2 +

√
t

are identical.

ăereaĕer, until you undeđne the variable, the system recognizes
z as 5 and will evaluate the expression 3+ z as 8.

Variables normally have single-character names. (See ValidNames
for Functions and Expressions or Variables on page 100 for other pos-
sibilities.) ăe value assigned can, however, be any mathematical ex-
pression. For example, you could deđne a variable to be any of the
following:

• Number: a = 245

• Polynomial: p = x3 +3x2−5x+1

• Rational expression: b = x2−1
x2+1

• Matrix: z =
[

a b
c d

]
Deöning Functions of One Variable

You follow a similar procedure to deđne a function. Write a func-
tionname followedbyparentheses containing the variable, and set this
equal to an expression.

59



i
i

“Compute60” — 2011/12/20 — 14:27 — page 60 — #70 i
i

i
i

i
i

Chapter 3 | Algebra

Todeđne the function f whose value at x isax2 +bx+ c
1. In mathematics mode, type f (x) = ax2 +bx+ c.

2. Choose Compute>Deđnitions>New Deđnition

ăereaĕer, until you undeđne the function, the symbol f repre-
sents the deđned function and behaves like a function.

Compute> Deönitions> New Deönition Compute> Evaluate
f (x) = ax2 +bx+ c f (t) = at2 +bt + c

f (−6) = 36a−6b+ c
f (17) = 289a+17b+ c

Ifg andh are previously deđned functions, then the following equa-
tions are examples of legitimate deđnitions:

• f (x) = 2g(x)

• f (x) = g(x)+h(x)

• f (x) = g(x)h(x)

• f (x) = g(h(x))

Make a deđnition for g and h, and then apply Evaluate to f (t)
for each deđnition of f . Each time you redeđne f , the new deđni-
tion replaces the old one. Also, once you have deđned both g(x) and
f (x) = 2g(x), then changing the deđnition of g(x) redeđnes f (x).

ăe algebra of functions includes objects such as f ±g, f ◦g, f g,
and f−1. For the value of f +g at x, write f (x)+g(x); for the value
of the composition of two deđned functions f and g, write f (g(x)) or
( f ◦g)(x); and for the value of the product of two deđned functions,
write f (x)g(x).

You can obtain the inverse for some functions f (x) by applying
Solve > Exact to the equation f (y) = x and specifying y as the Vari-
able to Solve for.
Tođnd the inverse (if it exists) of a function y = f (x)

• Solve the equation x = f (y) (variable y)

In particular, if f (x) = 5x− 3, then f (y) = 5y− 3. Solve the
equation x = 5y−3 for y to get y = 1

5 x+ 5
3 .

Compute> Deönitions> New Deönition
f (x) = 5x−3

60



i
i

“Compute60” — 2011/12/20 — 14:27 — page 61 — #71 i
i

i
i

i
i

Deöning Variables and Functions

Compute> Solve> Exact
x = f (y), (Enter y), Solution: 1

5 x+ 3
5

ăus f−1 (x) = 1
5 x+ 5

3 . To check this result, deđne f (x) = 5x−
3 and g(x) = 1

5 x + 3
5 . (ăe symbol f−1 will not work as a func-

tion name.) Evaluating the expressions f (g(x)) and g( f (x)) gives
f (g(x)) = x and g( f (x)) = x, demonstrating that the function g is
indeed the inverse of the function f .

You can use a matrix of inputs to đnd a matrix of outputs of a de-
đned function.

Tođnd the value of the expression x2 +3x+5 at x = 0,1, 2,3,4
1. Choose Insert>MathObjects>Matrix and set the number of

rows at 6 and the number of columns at 1.

2. Enter x and đve input values in the matrix:


x
0
1
2
3
4


3. Deđne the function f (x) = x2+3x+5 withCompute>Def-

initions>New Deđnition.

4. Choose Compute>Matrices>Map function.

5. Enter f (x) in the Function or Expression dialog box that ap-
pears.

Compute>Matrices>Map Function
(Enter f (x) for function.)

x
0
1
2
3
4

, result of map


x2 +3x+5

5
9

15
23
33


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Compute>Matrices> Concatenate
x
0
1
2
3
4




x2 +3x+5

5
9

15
23
33

, Concatenation:


x x2 +3x+5
0 5
1 9
2 15
3 23
4 33


Deöning Functions of Several Variables
Todeđne a functionof several variables

1. Write an equation such as f (x,y,z) = ax+y2+2z or g(x,y) =
2x+ sin3xy.

2. Choose Compute>Deđnitions>New Deđnition

Compute> Evaluate
f (1,2,3) = a+10
g(1,2) = sin6+2

Piecewise-Deöned Functions
You can deđne functions of one variable that are described by dif-

ferent expressions on different parts of their domain. ăese functions
are referred to as piecewise-deĖned functions, case functions ormulticase
functions. Most of the operations introduced in calculus are supported
for piecewise-deđned functions. You can evaluate, plot, differentiate,
and integrate piecewise-deđned functions. Note

Piecewise-deöned functions must be speciöed
by a two- or three-columnmatrix with at least
two rows. The function values must be in the
örst column, and the range conditions must be
in the last column. If there are only two
columns, the “if” must be in text. The matrix
must be enclosed by expanding brackets with
a left brace and a “null” right delimiter. (The
null right delimiter appears as a red dashed
line on the screen when Helper Lines are
selected on the Viewmenu, and does not
appear when the document is printed or when
Helper Lines are turned off.)

Todeđne a piecewise-deđned function f
1. Type an expression of the form f (x) =.

2. Choose Insert>Math Objects> Brackets, and choose a curly
brace { for the leĕ bracket and the dashed vertical line (or null

bracket)
... for the right bracket.

3. Choose Insert>Math Objects>Matrix.

4. Set the number of rows equal to the number of “pieces.”

5. Set the number of columns to 3 or 2.
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6. Choose OK.

7. Type function values in the đrst column.

8. Type if in the second column (in text or mathematics mode if
you use 3 columns, and text if 2 columns).

9. Type the range condition in the third column (or in the second
column aĕer the “if ” if you use only 2 columns), preferably be-
ginning with the smallest values of the variable.

Compute> Deönitions> New Deönition

f (x) =

 x+2 if x < 0
2 if 0≤ x≤ 1

2/x if 1 < x

g(t) =


t if t < 0
0 if 0≤ t < 1
1 if 1≤ t < 2
2 if 2≤ t < 3

6− t if 3≤ t

Note
The function f has three “cases” or range
conditions on the independent variable, and
the function g has öve. Note that the intervals
for the range conditions are arranged in order
with the smallest values of the independent
variable in the örst row and the largest values
in the bottom row.

Compute> Evaluate
f (−14) =−12 f (1/2) = 2 f (21) = 2

21

Deöning Generic Functions and Generic Constants
You can choose Compute>Deđnitions>NewDeđnition to de-

clare an expression of the form f (x) to be a function without spec-
ifying any of the function values or behavior. ăus you can use the
function name as input when deđning other functions or performing
various operations on the function.
Todeđne a generic function

• Place the insert point to the right of an expression of the form
f (x) and choose Compute>Deđnitions>New Deđnition.

In the following example, we deđne f as a generic function andwe
deđne a particular function h to illustrate the behavior of f .

Compute> Deönitions> New Deönition
f (x)
h(x) = x−1

x+1
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Compute> Evaluate
h( f (x)) = f (x)−1

f (x)+1

f (h(x)) = f
( x−1

x+1

)
You can choose Compute>Deđnitions>NewDeđnition to de-

clare a character to be a constant.
Todeclare a character to be a (generic) constant

• Place the insert point to the right of the character and choose
Compute>Deđnitions>New Deđnition.

Compute> Deönitions> New Deönition
a

Showing and Removing Deönitions
Aĕer making deđnitions of functions or expressions, you need to Show Deönitions

Show Deönitions opens a window showing the
active deönitions. In general, the deöned
variables and functions are listed in the order
in which the deönitions were made.
Check the Show Deönitions list from time to
time. If your mathematics is behaving
strangely, this list is a place to look for a
possible explanation.

know techniques for keeping track of them, saving them, and deleting
them.
Toview the list of currently deđned variables and functions

• Choose Compute>Deđnitions> Show Deđnitions.

Example Deđne a = b, p = ax, and f (x) = ax. Choose Compute>
Deđnitions> Show Deđnitions to see the list

f (x) = ax
p = ax
a = b

of deđned functions and expressions. Evaluation of p and f (x) pro-
duces p = bx and f (x) = bx. Redeđning a with the equation a = c
and again evaluating p and f (x) produces p = cx and f (x) = cx.
To remove a deđnition fromadocument

1. Place the insert point in the equation you wish to undeđne, or Caution
It is easy to forget that a symbol has been
deöned to be some expression. If you use that
symbol later, you can get surprising results. For
example, if you deöne a = x2, forget about
it, and later compute f (a) for some function
f that you have just deöned, you are in for a
surprise. In complicated computations the
error may not be apparent.

select the name of the function or expression.

2. Choose Compute>Deđnitions>Undeđne.

Choose Compute > Deđnitions > Show Deđnitions to verify
that the deđnition has been removed from the list of deđned func-
tions and expressions.
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To remove all deđnitions fromadocument
• Choose Compute>Deđnitions>Clear Deđnitions.

If you have worked the preceding examples, you havemade several
deđnitions and you should remove them before continuing. Deđni-
tions that you do not remove remain active as long as a document is
open. As a default, deđnitions are saved and then restored when you
reopen a document.
Tocheck for overlookeddeđnitions

• Choose Compute>Deđnitions> Show Deđnitions

Exponents and Logarithms
You can work with exponential and logarithmic functions writ-

ten in their natural forms: ex, expx, log5 x, lnx, and so forth. ăese
functions are inverses of one another, as exempliđed by the identities
elnx = x and lnex = x.

Exponents and Exponential Functions
Exponential functions are used in modeling many real-life situa-

tions. ăe laws of exponents are an important feature of these func-
tions.

Combining Exponentials
Tocombine expressions involving exponential functionswith base e Note

In some cases, the Expand and Combine
commands act as inverses of one another.

• Choose Compute>Combine> Exponentials or Compute>
Expand

Compute> Combine> Exponentials Compute> Expand
(ex)y = eyx ex+3lny = y3ex

exey = ex+y ex+y = exey

Combining Powers
Tocombineexpressions involvingexponential functionswith symbolicbase

• Choose Compute>Combine> Powers (or Compute> Sim-
plify)

Compute> Combine> Powers
axay = ax+y
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Laws of Exponents
You can demonstrate some of the laws of exponents with some of

the menu commands. ăese laws apply for real or complex exponents
and for other expressions as well.

Todemonstrate laws of exponents
• Choose a menu command.

Compute> Combine> Powers
2x2y = 2x+y

ax

ay = ax−y

10x+310x−3 = 102x

Compute> Combine> Exponentials
exey = ex+y

Compute> Expand
2x+y = 2x×2y ax−y = ax

ay

ăe function exp satisđes exp(x) = ex. (Note that exp is a gray Function Name
Typing the letters exp in mathematics mode
automatically returns the grayed function
name exp.

Math Name.) Exponential expressions are normally returned to your
document in the form e f (x) rather than exp( f (x)), unless the expres-
sion f (x) is unusually complicated.

Evaluating Exponential Expressions
Toevaluate an exponential expression

• Choose Compute> Evaluate, or

Choose Compute> Evaluate Numeric

For numerical approximations, use Evaluate Numeric or use
Ĕoating-point notation. You can change the number of digits shown
in these approximations by changing the number for Digits rendered
in the Scientiđc Notation Output settings at Tools > Preferences >
Computation, Output page. For details, see Appendix C “Customiz-
ing the Program for Computing.” In these examples, Digits rendered
is set to 5.

Evaluate Evaluate Numeric
e2 = e2 e2 ≈ 7.3891

e0.0025 = 1.0025 e0.0025 ≈ 1.0025

54 = 625 54 ≈ 625.0

2
√

5 = 2
√

5 2
√

5 ≈ 4.7111
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Logarithms and Logarithmic Functions Function Names
Typing the letters ln in mathematics mode
automatically returns the grayed function
name ln.
Similarly, typing the letters log in mathematics
mode returns the grayed function name log.

ăe function lnx is interpreted as the natural logarithm—that is,
the logarithm with base e. Logarithms to other bases are entered with
a subscript on the function log. Evaluation gives log5 25 = 2 and
log10 103 = 3. By default, the symbol logx is also interpreted as the
natural logarithm (base e). You can change this default.

Tochange the default for the functionname log frombase e to base 10
1. Choose Tools> Preferences>Computation, Input page.

2. Click the box to remove the check mark from the line “Base of
log is e (otherwise 10).”

Properties of Logarithms
You can demonstrate properties of logarithms with Simplify and

Combine. Assume x,y,a,b are positive for the results below.

Evaluate Evaluate
assume(x,positive) = (0,∞) assume(a,positive) = (0,∞)

assume(y,positive) = (0,∞) assume(b,positive) = (0,∞)

Compute> Simplify
lnxy = y lnx
log38 = 8log3

Compute> Combine> Logs
lnx+ lny = ln(xy)
lna− lnb = ln a

b
2ln3 = ln9

Evaluating Logarithmic Expressions
Toevaluate a logarithmic expression

• Choose Compute> Evaluate, or

Choose Compute> Evaluate Numeric

For numerical approximations, use Evaluate Numeric or use
Ĕoating-point notation. You can change the number of digits shown
in these approximations by changing the number for Digits rendered
in the Scientiđc Notation Output settings at Tools > Preferences >
Computation, Output page. For details, see Appendix C “Customiz-
ing the Program for Computing.” In these examples, Digits rendered
is set to 5.
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Compute> Evaluate Compute> Evaluate Numeric
ln2 = ln2 ln2≈ 0.69315
log10 5 = log10 5 log10 5≈ 0.69897

ln0.0025 =−5.9915 ln0.0025≈−5.9915

Solving Exponential and Logarithmic Equations
Tođnd a symbolic solution to an exponential and logarithmic equation

• ChooseCompute>Solve>Exact. EnterVariable(s) if requested.

Compute> Solve> Exact (Variable(s): x)

3x = 8, Solution:
{

3log3 2+ 2πik
ln3 | k ∈ Z

}
ex = y, Solution:

{
/0 if y = 0

{lny+2iπk | k ∈ Z} if y ̸= 0

sinx = 1/2, Solution:
{ 1

6 π +2πk | k ∈ Z
}
∪
{ 5

6 π +2πk | k ∈ Z
}

ln(3x+ y) = 8, Solution: 1
3 e8− 1

3 y

Note that the solution to ex = y includes both a special case, y= 0,
and multiple values. Also the solution to sinx = 1/2 includes multi-
ple values.
To ignore special cases of a solution Note

For simpliöed results, you may want to use the
options Principal Values Only and Ignore
Special Cases.

• ChooseTools>Preferences>Computation, Engine page, and
check Ignore Special Cases.

Compute> Solve> Exact (Variable(s): x)
3x = 8, Solution:

{
3log3 2+ 2πik

ln3 |k ∈ Z
}

Tocompute only the principal values of a solution
• ChooseTools>Preferences>Computation, Engine page, and

check Principal Value Only.

Compute> Solve> Exact (Variable(s): x)
3x = 8, Solution: 3log3 2
ln4x2 = 5, Solution: 1

2 e
5
2

sinx = 1/2, Solution: 1
6 π

Tođnd anumerical solution to an exponential and logarithmic equation
• Enter a coefficient in decimal notation and choose Compute>

Solve> Exact, or
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Choose Compute> Solve> Exact and then choose Compute
> Evaluate Numeric, or

With a single variable, choose Compute> Solve>Numeric.

Compute> Solve> Exact (Variable: x)
3x = 8.0, Solution: 1.8928

log5
(
4x2−3y

)
= 5

5
ln5 , Solution: − 1

2

√
3y+55

5
ln5

Compute> Evaluate Numeric

− 1
2

√
3y+55

5
ln5 ≈−0.5

√
3.0y+5.4494×10103

Compute> Solve> Numeric
3x = 8, Solution: {[x = 1.8928]}

Toolbars and Keyboard Shortcuts
ăismanual givesmost instructions in terms ofmenu items. Tool-

bars and keyboard shortcuts are designed tomake common tasks both
easier and faster. SeeAppendixA “Menus, Toolbars, and Shortcuts for
Doing Mathematics” and Appendix B “Menus, Toolbars, and Short-
cuts for Entering Mathematics” for details. See Appendix C “Cus-
tomizing theProgram forComputing” for details on customizing tool-
bars to suit your needs.

Math Toolbar Tooltips
Use your mouse and hover over a tool to learn
what it does.

ăe Math Toolbar contains clickable buttons that duplicate many
menu items. If it doesnot appear above yourdocumentwindow, choose
View>Toolbars and check Math Toolbar.

Symbol Toolbar
ăeSymbol Toolbarmakes it convenient to enter a wide variety of

special symbols. If it does not appear above your document window,
choose View > Toolbars and check Symbol Toolbar. ăese buttons
are also available in a Sidebar.

Keyboard Shortcuts
A standard keyboard contains several mathematical symbols such

as +,−, /, <, and > that can be typed directly. You can also use the
following keyboard shortcuts:
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Menu Item Keyboard Shortcut
Compute> Evaluate Ctrl+e

Compute> Deönitions> New Deönition Ctrl+=

Insert>Math Ctrl+m

Insert>Math Objects> Fraction Ctrl+/

Insert>Math Objects> Radical Ctrl+r

Insert>Math Objects> Superscript Ctrl+h or Ctrl+↑
Insert>Math Objects> Subscript Ctrl+l or Ctrl+↓
Insert>Math Objects> Brackets ( ) Ctrl+9

Insert>Math Objects> Brackets [ ] Ctrl+[

Insert>Math Objects> Brackets { } Ctrl+{

Insert>Math Objects> Brackets | | Ctrl+\
Insert>Math Objects> Brackets ∥ ∥ Ctrl+|
Insert>Math Objects> Display Ctrl+d

Exercises
1. Given that when x2−3x+5k is divided by x+4 the remainder

is 9, đnd the value of k by choosing Compute> Polynomials>
Divide and then choosing Compute> Solve> Exact.

2. Deđne functions f (x)= x3+x lnx andg(x)= x+ex. Evaluate
f (g(x)), g( f (x)), f (x)g(x), and f (x)+g(x).

3. Find the equation of the line passing through the two points
(x1,y1), (x2,y2).

4. Find the equation of the line passing through the two points
(2,5), (3,−7).

5. Find the equation of the line passing through the two points
(1,2), (2,4).

6. Find the slope of the line given by the equation sx+ ty = c.

7. Factor the difference of powers xn− yn for several values of n,
and deduce a general formula.
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8. Applying Factor to x2 +
(√

5−3
)

x− 3
√

5 gives the factor-
ization

x2 +
(√

5−3
)

x−3
√

5 =
(

x+
√

5
)
(x−3)

showing that the system can factor some polynomials with irra-
tional roots. However, applying Factor to x2−3 and x3 +3x2−
5x+ 1 does not do anything. Find a way to factor these poly-
nomials.

9. Find the standard form for the equation of the circle x2−6x+
18+ y2 +10y = 0 by “completing the square.” Determine the
center and radius of this circle.

Solutions
1. Choose Compute> Polynomials>Divide to get

x2−3x+5k
x+4

= x+
(5k+28)

x+4
−7

ăus, the remainder is 5k+28. Solve the equation 5k+28 = 9
to get k =− 19

5 .

2. Deđning functions f (x) = x3 + x lnx and g(x) = x+ ex and
evaluating gives

f (g(x)) = (x+ ex)3 + ln(x+ ex)(x+ ex)

g( f (x)) = ex lnx+x3
+ x lnx+ x3

f (x)g(x) = (x+ ex)
(
x lnx+ x3)

f (x)+g(x) = x+ ex + x lnx+ x3

3. For any two distinct points (x1,y1) and (x2,y2) in the plane,
there is a unique line ax+by+c = 0 through these two points.
Substituting these points in the equation for the line gives the
two equations ax1 + by1 + c = 0 and ax2 + by2 + c = 0. Set
Tools>Preferences>Computation, Engine page, to Principal
Value Only and Ignore Special Cases, then choose Compute>
Solve> Exact with the insert point in this system

ax1 +by1 + c = 0
ax2 +by2 + c = 0
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Chapter 3 | Algebra

of linear equations, solving for the variables a,b.

Solution:
[

a =
cy1− cy2

x1y2− x2y1
,b =− cx1− cx2

x1y2−y1x2

]
Consequently, the equation for the line is

cy1− cy2

x1y2− x2y1
x− cx1− cx2

x2y1− x1y2
y+ c = 0

or, clearing fractions and collecting coefficients,

(y1− y2)x− (x1− x2)y+(x1y2− y1x2) = 0
Note
An interesting method for önding the equation
of a line through two speciöed points using
determinants is described in a matrix algebra
exercise on page 337.

4. For the points (2,5), (3,−7), the system of equations is

2a+5b+ c = 0
3a−7b+ c = 0

Choose Compute> Solve> Exact to get

Solution:
[
a =− 12

29 c,b =− 1
29 c
]
.

Consequently, the equation for the line is− 12
29 cx−

(
− 1

29

)
cy+

c = 0, or, clearing fractions and simplifying,

−12x+ y+29 = 0.

5. Since thepoint (0,0) lies on the line, youdonot get a unique so-
lution to the system of equations for the pair a,b. ăus, choos-
ing Solve + Exact and specifying a,b for the variables gives no
response. However, specifying a,c for Variable(s) to Solve for
gives the solution

[a =−2b,c = 0]

ăus, the equation for the line is

−2bx+by = 0

or, dividing by b and applying Simplify,

(−2bx+by)
1
b
=−2x+ y = 0
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Exercises

6. ăe slope-intercept form of the equation for a line is y = mx+b,
where m is the slope and b the y-intercept. If a line is given as a
linear equation in the form sx+ ty = c, you can đnd the slope
by solving the equation for y. Expand the solution y = − sx−c

t

to get y =
c
t
− s

t
x, revealing the slope to be−s

t
.

7. Apply Factor to several differences:

x2− y2 = (x− y)(x+ y)

x3− y3 = (x− y)
(
x2 + xy+ y2

)
x4− y4 = (x− y)(x+ y)

(
x2 + y2

)
x5− y5 = (x− y)

(
x4 + x3y+ x2y2 + xy3 + y4

)
x6− y6 = (x− y)(x+ y)

(
x2 + xy+ y2

)(
x2− xy+ y2

)
x7−y7 = (x− y)

(
x6 + x5y+ x4y2 + x3y3 + x2y4 + xy5 + y6

)
Aĕer looking at only these few examples, you might đnd it rea-
sonable to conjecture that, for n odd,

xn− yn = (x− y)
n−1

∑
k=0

xn−k−1yk

We leave the general conjecture for you. Experiment.

8. Using the clue from the example that the systemwill factor over
roots that appear as coefficients, factor theproduct

√
3
(
x2−3

)
to get

√
3
(
x2−3

)
=
√

3
(
x−
√

3
)(

x+
√

3
)
. Now you can

divideout the extraneous
√

3 to getx2−3=
(
x−
√

3
)(

x+
√

3
)
.

For thepolynomialx3+3x2−5x+1, chooseCompute>Poly-
nomials>Roots tođnd the roots:

[
1,
√

5−2,−
√

5−2
]
. You

can multiply by
√

5 to factor this polynomial:

√
5
(
x3 +3x2−5x+1

)
=
√

5
(

x+
√

5+2
)(

x−
√

5+2
)
(x−1)

ăen, dividing out the extraneous factor of
√

5, you have

x3 +3x2−5x+1 = (x−1)
(

x+2+
√

5
)(

x+2−
√

5
)
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Chapter 3 | Algebra

9. To đnd the center and radius of the circle

x2−6x+18+ y2 +10y = 0,

đrst subtract the constant term 18 from both sides of the equa-
tion to get

x2−6x+18+ y2 +10y−18 = 0−18

Simplify each side of the equation. ăis gives the equation x2−
6x+ y2 +10y =−18. Add parentheses to put the equation in
the form (

x2−6x
)
+
(
y2 +10y

)
=−18.

To complete the squares, add the square of one-half the coeffi-
cient of x to both sides. Do the same for the coefficient of y.(

x2−6x+
(
− 6

2

)2
)
+
(

y2 +10y+
( 10

2

)2
)
=−18+

(
− 6

2

)2
+
( 10

2

)2

Factor the terms
(

x2−6x+
(−6

2

)2
)

and
(

y2 +10y+
( 10

2

)2
)
:

(x−3)2 +(y+5)2 =−18+
(
− 6

2

)2
+
( 10

2

)2

Simplify the right side of the equation to get

(x−3)2 +(y+5)2 = 16.

You can read the solution to this problem from this form of the
equation. ăe center of the circle is (3,−5) and the radius is√

16 = 4.
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4
Trigonometry

Since you are now studying geometry and trigonometry, I will give you a problem. A ship sails the ocean. It left Boston with a cargo of wool. It
grosses 200 tons. It is bound for Le Havre. The main mast is broken, the cabin boy is on deck, there are 12 passengers aboard, the wind is blowing

east-north-east, the clock points to a quarter past three in the afternoon. It is the month of May. How old is the captain?
Gustave Flaubert (1821–1880)

T rigonometry developed from the study of triangles, particu- Trigonometric Functions

Trigonometric Identities

Inverse Trigonometric Functions

Hyperbolic Functions

Complex Numbers and Complex
Functions

larly right triangles, and the relations between the lengths of
their sides and the sizes of their angles. ăe trigonometric

functions that measure the relationships between the sides of simi-
lar triangles have far-reaching applications that extend well beyond
their use in the study of triangles. While the history of trigonome-
try is closely connected with geometry and with astronomical studies,
it has become essential in many branches of science and technology.

Trigonometric Functions
Most of the trigonometric computations demonstrated here use

six basic trigonometric functions. ăe two fundamental trigonomet-
ric functions, sine and cosine, can be deđned in terms of the unit cir-
cle—the set of points in the Euclidean plane of distance 1 from the
origin.

A point on this circle has coordinates (cos t,sin t), where t is a
measure (in radians) of the angle at the origin between the positive
x-axis and the ray from the origin through the point measured in the
counterclockwise direction.

­1.0 ­0.5 0.5 1.0 1.5

­1.0

­0.5

0.5

1.0

t

cos t, tsin( )
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Chapter 4 | Trigonometry

For 0 < t < π/2, these functions can be found as a ratio of certain
sides of a right triangle that has one angle of radian measure t .

ăe other four basic trigonometric functions can be deđned in
terms of these two—namely,

tanx =
sinx
cosx

secx =
1

cosx

cotx =
cosx
sinx

cscx =
1

sinx

Toenter a trigonometric function Function names
The symbols used for the six basic
trigonometric functions—sin, cos, tan,
cot, sec, csc—are abbreviations for the
words sine, cosine, tangent, cotangent, secant,
and cosecant, respectively.

• Put the insert point in mathematics mode and type the three
letters of the function name. (ăe function name automatically
turns gray when you type the đnal letter of the name.)

On the domain of real numbers, the sine and cosine functions take
values in the interval [−1,1]. To restrict computations to real num-
bers, you can use the function “assume.”
Tomake the assumption that variables are real

1. Type assume in mathematics mode. It will automatically turn
upright and gray when you type the đnal letter. Note

The sine and cosine functions are deöned for
all real and complex numbers. In this section,
we address only real numbers. For complex
arguments, see page 92.

2. Inside parentheses, type x,real (or any variable name in place
of x). ăe math “real” will automatically turn upright and gray
when you type the đnal letter.

3. Choose Compute> Evaluate.

Compute> Evaluate
assume(x, real) = R

Tip
See page 111 for further information on
making assumptions about variables.

Ordinary functions require parentheses around the function argu-
ment, while trigonometric functions commonly do not (see Trigtype
Functions, page 122). You can modify this behavior so that evalua-
tions of trigonometric functions appear with parentheses. Caution

The default behavior of your system allows
trigonometric functions without parentheses.

Toaddparentheses for trigonometric functions in output
1. Choose Tools> Preferences>Computation>Output

2. Select Use Parentheses for Trig Functions.

Compute> Evaluate
sinx = sin(x)
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Trigonometric Functions

Radians and Degrees
ăe notation you use determines whether the argument is inter-

preted as radians or degrees.

Compute> Evaluate Numeric
sin30≈−0.98803
sin30◦ ≈ 0.5 (small red circle as superscript)
sin30 ◦ ≈ 0.5 (green Unit Name)

Unit Names
Unit names appear in green on the screen. See
Appendix B for details about entering unit
names.

ăe degree symbol is available in two forms—a green Unit Name
or a small red circle entered as a superscript. With no symbol, the ar-
gument of a trigonometric function is interpreted as radians, andwith
either a green or red degree symbol, the argument is interpreted as de-
grees. All operations will convert angle measure to radians.
Toenter the angle 33◦47 ′13 ′′ with greendegrees,minutes, and seconds

1. In mathematics mode type 33. Tip
Enter the symbols for degree, minutes, and
seconds by typing in math mode udeg,
udmn, and uds. The red letters will be
replaced by the symbols ◦, ′, and ′′ when you
type each of the last letters.

2. Choose Insert>Math Objects>Unit Name and select Plane
Angle, Degree.

3. Type 47.

4. Choose Insert>Math Objects>Unit Name and select Plane
Angle, Minute.

5. Type 13.

6. Choose Insert>Math Objects>Unit Name and select Plane
Angle, Second.

Toenter the angle 33◦47′13′′ with reddegrees,minutes, and seconds
• In mathematics mode type 33.

• Choose Insert>MathObjects>Superscript and fromtheSym-
bol toolbar select the Binary operations tool and click the small
red circle ◦.

• Press Enter and type 47′13′′ where the double quote is entered
by typing ′ twice.

Numerically evaluating an angle in degrees gives a numerical result
in radians.
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Chapter 4 | Trigonometry

Compute> Evaluate Numeric
33 ◦47 ′13 ′′ ≈ 0.58969rad (Green Unit Names)
33◦47′13′′ ≈ 0.58969rad (Small red degrees, minutes, seconds)

Whenanyoperation is applied, degrees are automatically converted
to radians. To go in the other direction, solve for the number of de-
grees.
Toconvert radians to degrees symbolically

1. Startwith an equation such as2= θ ◦, using the red degree sym-
bol.

2. Choose Compute> Solve> Exact.

Compute> Solve> Exact
2 = θ ◦, Solution: 360

π

ăus 2 radians= 360
π degrees.

Toconvert radians to degrees numerically
1. Start with an equation such as 2rad = θ ◦, using the green unit

name symbol.

2. Choose Compute> Solve> Exact.

Compute> Solve> Exact
2rad = θ ◦, Solution: 114.59

ăus 2rad = 114.59◦.

Solving Trigonometric Equations
When evaluating the trigonometric functions, translations by in-

teger multiples of π are eliminated from the argument. Further, argu-
ments that are rational multiples of π lead to simpliđed results. Ex-
plicit expressions are returned for the arguments

0,
π
2
,

π
3
,

π
4
,

3π
4
,

π
5
,

2π
5
,

π
6
,

π
8
,

3π
8
,

π
10

,
3π
10

,
π
12

,
5π
12

as well as for the same angles expressed in degrees.
Tođnd values of the trigonometric functions

1. Place the insert point in a trigonometric expression.

2. Choose Compute> Evaluate, or
Choose Compute> Evaluate Numeric.
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Compute> Evaluate Compute> Evaluate Numeric
sin 3π

4 = 1
2

√
2 sin 3π

4 ≈ 0.70711
sin1 = sin1 sin1≈ 0.84147
sin60◦ = 1

2

√
3 sin60◦ ≈ 0.86603

sin(−x) =−sinx sin(−x)≈−1.0sinx
cos(x+7π) =−cosx cos(x+7π)≈−1.0cosx
cot π

8 =
√

2+1 cot π
8 ≈ 2.4142

Tip
Choose Tools> Preferences> Computation
> Output to set the number of digits rendered
in response to Evaluate Numeric.

All arguments that are rational multiples of π are transformed to
arguments from the interval

[
0, π

2

)
.

Compute> Evaluate
sin 4π

7 = sin
( 3

7 π
)

cos
(
− 20π

9

)
= cos

( 2
9 π
)

tan 123π
11 = tan

( 2
11 π
)

You can choose both Compute> Solve> Exact and Compute>
Solve>Numeric to đnd solutions to trigonometric equations. ăese
operations also convert degrees to radians. Use of decimal notation in
the equation gives you a numerical solution.

With radians orwith red degree symbols, Solve>Exact gives sym-
bolic solutions and Solve>Numeric gives numerical solutions.

Compute> Solve> Exact Compute> Solve> Numeric
x = sin π

4 , Solution: 1
2

√
2 x = sin π

4 , Solution: {[x = 0.70711]}
sin22◦ = 14

c , Solution: 14
sin 11

90 π
sin22◦ = 14

c , Solution: {[c = 37.373]}

x = 3◦54′, Solution: 13
600 π x = 3◦54′, Solution: {[x = 0.068068 ]}

With green unit name symbols, Solve> Exact gives numerical so-
lutions.

Compute> Solve> Exact
sin22 ◦ = 14

c , Solution: 37.373
x = 3◦54 ′, Solution: 0.068068 rad

To solve a trigonometric equation
1. Place the insert point in the equation.

2. Choose Compute> Solve> Exact, or

Choose Compute> Solve>Numeric.
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Chapter 4 | Trigonometry

ăe command Solve > Exact đnds a complete solution in many
cases, either symbolic or numerical dependingon the formof the equa-
tion.

Compute> Solve> Exact
sin t = sin2t , Solution: {2πk | k ∈ Z}∪

{ 1
3 π + 2

3 πk | k ∈ Z
}

2sinx+5cosx = 5, Solution: {2πk | k ∈ Z}∪
{
−i ln

( 21
29 +

20
29 i
)
+2πk | k ∈ Z

}
ăe command Solve>Numeric đnds one numerical solution. Note

The union symbol∪ is used for OR. The letter
Z denotes the set of integers.

Compute> Solve> Numeric
sin t = sin2t , Solution: {[t = 0.0]}
2sinx+5cosx = 5, Solution: {[x = 0.0]}

Tođnd anumerical solution in a speciđed interval
1. Enter the equation and a range indifferent rowsof a one-column

matrix.

2. Choose Compute> Solve>Numeric.

Compute> Solve> Numeric[
sin t = sin2t
t ∈ (0.5,2.5)

]
, Solution: [t = 1.0472]

Here is an example illustrating how plots of functions are helpful
for selecting intervals for numeric solutions—especially when the so-
lutions are not periodic in nature.

Compute> Solve> Numeric[
x = 10sinx
x ∈ (5,7.5)

]
, Solution: [x = 7.0682]

Intersection points

­10 ­5 5 10

­10

10

x

y
ăe interval (5,7.5) was speciđed for the solution. By specify-

ing other intervals, you can đnd all seven solutions: x = 0,±2.8523,
±7.0682,±8.4232. ăese are depicted as the intersection points of
the graphs of y = x and y = 10sinx.

Trigonometric Identities
ăis section illustrates the effects of some operations on trigono-

metric functions. First, simpliđcations and expansionsof various trigono-
metric expressions illustrate many of the familiar trigonometric iden-
tities.
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Deönitions in terms of Basic Trigonometric Functions
Toexpress a trigonometric function in terms of sine and cosine

• Place the insert point in the function and choose Compute >
Rewrite> Sin and Cos.

Compute> Rewrite> Sin and Cos
secx = 1

cosx tanx = sinx
cosx

cscx = 1
sinx cotx = cosx

sinx
cosxsinx−2secxcscx = cosxsinx− 2

cosxsinx

Alternatively, for sec and csc, choose Simplify.

Compute> Simplify
secx = 1

cosx cscx = 1
sinx

Toexpress a trigonometric function in terms of the sine function
1. Place the insert point in the function.

2. Choose Compute> Rewrite> Sin.

Compute> Rewrite> Sin
cosxsinx−2secxcscx = 2

(2sin2( 1
2 x)−1)sinx

− sinx
(
2sin2 ( 1

2 x
)
−1
)

Toexpress a trigonometric function in terms of the cosine function
1. Place the insert point in the function.

2. Choose Compute> Rewrite>Cos.

Compute> Rewrite> Cos
cosxsin2 x =−(cosx)

(
cos2 x−1

)
Toexpress a trigonometric function in terms of the tangent function

1. Place the insert point in the function.

2. Choose Compute> Rewrite>Tan.

Compute> Rewrite> Tan

sinx =
2tan( 1

2 x)
tan2( 1

2 x)+1
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Chapter 4 | Trigonometry

Pythagorean Identities
TocomputePythagorean identities

1. Place the insert point in an expression.

2. Choose Compute> Simplify, or
Compute> Rewrite> Sin and Cos.

3. Use basic techniques for simplifying such expressions.

Compute> Simplify
sin2 x+ cos2 x = 1

Compute> Rewrite> Sin and Cos, Simplify
tan2 x− sec2 x = sin2 x

cos2 x −
1

cos2 x =−1

Addition Formulas
Tocompute addition formulas

1. Place the insert point in an expression.

2. Choose Compute> Expand.

Compute> Expand
sin(x+ y) = cosxsiny+ cosysinx sin

(
x+ π

2

)
= cosx

cos(x+ y) = cosxcosy− sinxsiny cos
(
x− π

2

)
= sinx

Combine and Expand act as reverse operations in many cases.

Compute> Combine> Trigonometric Functions
cosxsiny+ cosysinx = sin(x+ y)
cosxcosy− sinxsiny = cos(x+ y)

Multiple-Angle Formulas
You can obtain multiple-angle formulas with Expand.

To reduce amultiple-angle expression
• Place the insert point in the expression and choose Compute>

Expand.

Compute> Expand
sin2θ = 2cosθ sinθ cos2θ = cos2 θ − sin2 θ
tan2θ =− 2tanθ

tan2 θ−1

sin6θ = 6cos5 θ sinθ −20cos3 θ sin3 θ +6cosθ sin5 θ
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Inverse Trigonometric Functions

Combining and Simplifying Trigonometric Expressions Tip
There are many possible forms for
trigonometric expressions. To get expressions
in the form you want, you can experiment with
different combinations of commands.

Products and powers of trigonometric functions and hyperbolic
functions are combined into a sum of trigonometric functions or hy-
perbolic functions whose arguments are integral linear combinations
of the original arguments.
To simplify sumsof products andpowers of trigonometric expressions

1. Place the insert point in the expression.

2. Choose Compute>Combine>Trigonometric Functions.

Compute> Combine> Trigonometric Functions
sinxsiny = 1

2 cos(x− y)− 1
2 cos(x+ y)

sin2 x = 1
2 −

1
2 cos(2x)

sinxcosy = 1
2 sin(x− y)+ 1

2 sin(x+ y)
sin5 xcos5 x = 5

256 sin(2x)− 5
512 sin(6x)+ 1

512 sin(10x)

Here is another example where Expand and Combine act as re-
verse operations.

Compute> Expand
1
2 cos(x− y)− 1

2 cos(x+ y) = sinxsiny
1
2 sin(x− y)+ 1

2 sin(x+ y) = cosysinx

Simplify also combines and simpliđes trigonometric expressions.
Tip
The inverse trigonometric functions can be
entered by typing the function name in
mathematics mode or by choosing Insert>
Math Objects>Math Name and selecting
from a list. You can also type the 3-letter
trigonometric name with an exponent of−1.

Compute> Simplify
sin3a+4sin3 a = 3sina

Inverse Trigonometric Functions
ăefollowing typeof question arises frequentlywhenworkingwith

the trigonometric functions: for which angles x is sinx = y? ăere
are many correct answers to these questions, since the trigonometric
functions are periodic. ăe inverse trigonometric functions provide
solutions that lie within restricted ranges. ăe angle returned by these
functions is measured in radians, not in degrees.

Inverse function Domain Range
arcsinx or sin−1 x [−1,1]

[
−π

2 ,
π
2

]
arccosx or cos−1 x [−1,1] [0,π]
arctanx or tan−1 x (−∞,∞)

(
−π

2 ,
π
2

)
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Chapter 4 | Trigonometry

ăe other standard inverse functions are the following:

Inverse function Domain Range
arcsecx or sec−1 x (−∞,−1]∪ [1,∞)

[
0, π

2

)
∪
(π

2 ,π
]

arccscx or csc−1 x (−∞,−1]∪ [1,∞)
[
−π

2 ,0
)
∪
(
0, π

2

]
arccotx or cot−1 x (−∞,∞)

[
−π

2 ,0
)
∪
(
0, π

2

]
Youcan check the relationships between the inverse functionswith

Check Equality.

Compute> Check Equality
arcsecx = arccos 1

x is TRUE
arccotx = arctan 1

x is TRUE
arccscx = arcsin 1

x is TRUE

Combining and Rewriting Inverse Trigonometric Functions
ăe sum of inverse tangent functions can be combined.

Compute> Combine> Arctan
arctanx+ arctany =−arctan 1

xy−1 (x+ y)

arctanx− arctany = arctan x−y
xy+1

ăe Rewrite commands convert from one inverse trigonometric
function to another.

Compute> Rewrite> Arcsin

arctanx =−signIm(ix)
(

arcsin 1√
x2+1
− 1

2 π
)

cos−1 x = 1
2 π− arcsinx

ăe sign imaginary function of a complex variable z is given by

signIm(z) =

 1 if Im(z)> 0 or z < 0
0 if z = 0
−1 if Im(z)< 0 or z > 0

ăus if x is real, then

arctanx =


−
(

arcsin 1√
x2+1
− 1

2 π
)

if x > 0

0 if x = 0
arcsin 1√

x2+1
− 1

2 π if x < 0
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Compute> Rewrite> Arccos
arcsinx = 1

2 π− arccosx

Compute> Rewrite> Arctan
arcsinx = 2arctan x√

1−x2+1
arccosx = 1

2 π−2arctan x√
1−x2+1

Compute> Rewrite> Arccot

arctanx = arccot 1
x cos−1 x = 1

2 π−2arccot
(√

1−x2+1
x

)
Trigonometric Equations and Inverse Functions

With Solve> Exact, solutions of trigonometric equations may be
given in terms of inverse trigonometric functions that you can evaluate
numerically. You can get numerical results directly by starting with
decimal notation in the equation.

For real solutions only, đrst evaluate assume(x, real). To return
to the default, evaluate unassume(x).

Notation
The union symbol∪ is used for OR. The letter
Z denotes the set of integers.

Compute> Evaluate
assume(x, real) = R

Compute> Solve> Exact
sinx = 7/10, Solution:

{
π− arcsin 7

10 +2πk |k ∈ Z
}
∪
{

arcsin 7
10 +2πk |k ∈ Z

}
sinx = 0.7, Solution: {6.2832k+0.77540 | k ∈ Z}∪{6.2832k+2.3662 |k ∈ Z}

tan2 x− cot2 x = 1, Solution:
{

arcsin
√

2√√
5+1

+πk|k ∈ Z
}
∪
{
−arcsin

√
2√√
5+1

+πk|k ∈ Z
}

Compute> Evaluate Numeric

arctan
√

1
2

√
5− 1

2 ≈ 0.66624

Toobtain a principal solutiononly
1. Choose Tools> Preferences>Computation.

2. Click the Engine tab.

3. Check Principal Value Only.
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Compute> Solve> Exact (Principal Value Only)
sin t = sin2t , Solution: 0

8tanx−13+5tan2 x = 3, Solution: arctan
(

4
5

√
6− 4

5

)
tan2 x− cot2 x = 1, Solution: arcsin

√
2√√
5+1

Hyperbolic Functions
Certain functions, known as the hyperbolic sine, hyperbolic co-

sine, hyperbolic tangent, hyperbolic cotangent, hyperbolic secant, and
hyperbolic cosecant, occur as combinations of the exponential func-
tions ex and e−x having the same relationship to the hyperbola that
the trigonometric functions have to the circle. It is for this reason that
they are called hyperbolic functions.

Note
The hyperbolic functions are “trigtype”
functions, allowing you to enter arguments
without parentheses.

Hyperbolic functions

sinhx =
ex− e−x

2
cschx =

1
sinhx

=
2

ex− e−x

coshx =
ex + e−x

2
sechx =

1
coshx

=
2

ex + e−x

tanhx =
sinhx
coshx

=
e2x−1
e2x +1

cothx =
coshx
sinhx

=
e2x +1
e2x−1

ăe function names used for the basic hyperbolic functions are
sinh, cosh, tanh, coth, sech, and csch. Most of these function names
automatically turnupright andgraywhen typed inmathematicsmode.
When they donot, choose Insert>MathObjects>MathName, type
the name in the Name box, and select Apply. Note

The hyperbolic cosine function occurs naturally
as a description of the curve formed by a
hanging cable.

­20 ­10 0 10 20

10

x

y

28cosh x
28 −20

Toobtain exponential expressions for the hyperbolic functions
1. Place the insert point in a hyperbolic function.

2. Choose Compute> Rewrite> Exponential.

Compute> Rewrite> Exponential
sinhx = 1

2 ex− 1
2 e−x coshx = 1

2 ex + 1
2 e−x

tanhx =
e2x−1
e2x +1

Tođnd values of hyperbolic functions
• Place the insert point in the expression and choose Compute>

Evaluate Numeric.
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Compute> Evaluate Numeric
sinh1≈ 1.1752 cosh2≈ 3.7622 tanh3≈ 0.99505

To solve equations involving hyperbolic functions
• Place the insert point in the equation and choose Compute >

Solve> Exact or Compute> Solve>Numeric.

Compute> Solve> Exact
sinhx+ coshx = 3, Solution: {ln3+2iπk |k ∈ Z}

Compute> Solve> Numeric
sinhx+ coshx = 3, Solution: {[x = 1.0986]}

Toobtain addition formulas for hyperbolic functions
• Place the insert point in an expression and choose Compute>

Expand.

Compute> Expand
sinh(x+ y) = coshxsinhy+ coshysinhx
cosh(x+ y) = coshxcoshy+ sinhxsinhy

To rewrite hyperbolic expressions in terms of sinh and cosh
1. Place the insert point in an expression.

2. Choose Compute> Rewrite> Sinh and Cosh.

Compute> Rewrite> Sinh and Cosh

tanhx+ sinhx tanhx = sinhx
coshx +

sinh2 x
coshx

Products and powers of hyperbolic functions can be combined
into a sumof hyperbolic functionswhose arguments are integral linear
combinations of the original arguments.
Tocombine products andpowers of hyperbolic functions

1. Place the insert point in the expression.

2. Choose Compute > Combine > Hyperbolic Trigonometric
Functions

Compute> Combine> Hyperbolic Trigonometric Functions
sinhxsinhy = 1

2 cosh(x+ y)− 1
2 cosh(x− y)

sinhxcoshy = 1
2 sinh(x+ y)+ 1

2 sinh(x− y)
coshxcoshy = 1

2 cosh(x+ y)+ 1
2 cosh(x− y)
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Inverse Hyperbolic functions
Since the hyperbolic functions are deđned in terms of exponential

functions, the inverse hyperbolic functions can be expressed in terms
of logarithmic functions.

Inverse Hyperbolic functions Domain

arcsinhx = sinh−1 x = ln
(

x+
√

x2 +1
)

x ∈ R

arccoshx = cosh−1 x = ln
(

x+
√

x2−1
)

x≥ 1

arctanhx = tanh−1 x = 1
2 ln
(

1+ x
1− x

)
−1 < x < 1

Toenter the inverse hyperbolic functionnames
1. Choose Insert>Math Name.

2. Type the function name in the Name box, and choose OK.

Toobtain logarithmic expressions for these functions, use theRewrite
command.

Compute> Rewrite> Logarithm
arcsinhx = ln

(
x+
√

x2 +1
)

arcsecx = ln
(

1
x + i
√

1− x2
)
(−i)

To đnd values of the inverse hyperbolic functions, use Evaluate
Numeric.

Compute> Evaluate Numeric
arcsinh5 = 2.3124
cosh−1 10 = 2.9932

Tosolve equations involving inversehyperbolic functions, use Solve
> Exact or Solve>Numeric.

Compute> Solve> Exact
arcsinhx− arccoshx = 0.3, Solution: 1.3395

ăe following special values are implemented:

Compute> Evaluate
arcsinh0 = 0 sinh−1 0 = 0
arccosh1 = 0 cosh−1 1 = 0
arctanh0 = 0 tanh−1 0 = 0
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Complex Numbers and Complex Functions
Complex numbers are numbers of the form a+bi where a and b

are real numbers and i2 = −1. See Complex Numbers, page 32, for
general information on working with complex numbers.

Argument of a Complex Number
ăe polar coordinate system is a coordinate system that describes

a point P in terms of its distance r from the origin and the angle θ
between the polar axis (that is, the x-axis) and the line OP, measured
in a clockwise direction from the polar axis. ăe point in the plane
corresponding to a pair (a,b) of real numbers can be represented in
polar coordinates P(r,θ) with

a = r cosθ and b = r sinθ

where r =
√

a2 +b2 is the distance from the point (a,b) to the origin
and θ is an angle satisfying tanθ = a

b .
ăe angle θ is called the amplitude or argument of z. Note that

the argument is not unique. However, any two arguments of z differ
by an integer multiple of 2π . ăe function that gives the argument
between −π and π is denoted argz. ăe form z = r (cos t + isin t)
for a complex number is called the (trigonometric) polar form of z.

Tođnd the argument of a complex number
1. Type arg in mathematics mode. It will automatically turn to a

gray math name when you type the last letter.

2. Type the number enclosed in parentheses.

3. Choose Compute> Evaluate, or

Choose Compute> Evaluate Numeric.

4. Choose Compute> Simplify if required.

Compute> Evaluate, Compute> Simplify

arg(3+5i) = arctan 5
3

arg
(
52−3i

)
=−arctan

(
sin(3ln5)
cos(3ln5)

)
= 2π− ln125
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Compute> Evaluate Numeric
arg(3+5i)≈ 1.0304

arg
(
52−3i

)
≈ 1.4549

Forms of a Complex Number
A form of writing a complex number that involves r and θ rather

than x and y, where r = |z|=
√

a2 +b2 and θ = arctan a
b , is called a

polar form of the complex number. ăis leads to three standard forms
for complex numbers:

Rectangular Trigonometric Polar Exponential Polar

z = a+ ib z = r (cosθ + isinθ) z = reiθ

Toput a complex number in exponential polar form
1. Place the insert point in the number.

2. Choose Compute> Rewrite> Polar.

Compute> Rewrite> Polar
3+5i =

√
34ei(arctan 5

3)

16π−
√

2i =
√

2e
(

arctan
√

2
16π

)
(−i)√128π2 +1

Toput a complex number in rectangular form
1. Place the insert point in the number.

2. Choose Compute> Rewrite> Rectangular.

Compute> Rewrite> Rectangular
√

34eiarctan 5
3 = 3+5i

√
2exp

(
−iarctan 1

16

√
2

π

)√
128π2 +1 =

√
2cos

(
1
π
√

2arctan 1
16

)√
128π2 +1

− i
√

2sin
(

1
π
√

2arctan 1
16

)√
128π2 +1

Compute> Simplify
√

2
√

128π2+1√
1

128π2 +1
− i
√

128π2+1

8π
√

1
128π2 +1

= 16π− i
√

2

For the Euler identity

reit = r (cos t + isin t)
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use Rewrite to change from exponential polar form to trigonometric
polar form.
Tochange fromexponential polar form to trigonometric polar form

• Place the insert point in the expression.

• Choose Compute> Rewrite> Sin and Cos.

Compute> Rewrite> Sin and Cos
reit = r (cos t +(isin t))

Complex Powers and Roots of Complex Numbers
Euler’s identity reit = r (cos t + isin t) provides a method of tak-

ing complex powers of complex numbers. If z ̸= 0 and w are complex
numbers, write z = reit and w = a+ ib, with r,a,b real numbers and
r positive. ăen the principal value of zw is given by

zw =
(
reit)a+ib

=
(

elnr
)a+ib (

eit)a+ib
= ea lnreib lnreitae−bt

= ea lnr−btei(at+b lnr) = rae−bt (cos(ta+b lnr)+ isin(ta+b lnr))

ăis function is multi-valued because eiy = eiy+2πk for any integer k.
ăe Rewrite command computes the principal value.

Compute> Rewrite> Rectangular
ii = e−

1
2 π

52i = cos(2ln5)+ isin(2ln5)

DeMoivre’s Theorem
DeMoivre’s theorem says that if z = r (cosθ + isinθ) and n is a

positive integer, then DeMoivre’s Theorem
The exponential polar form of DeMoivre’s
Theorem is (

reit)n
= rneint

zn = (r (cos t + isin t))n = rn (cosnt + isinnt)

ToobtainDeMoivre'săeorem

1. Type (r (cos t + isin t))3.

2. Choose Compute> Expand.

3. Choose Compute> Simplify.

Compute> Expand
(r (cos t + isin t))3 = r3 cos3 t +3ir3 cos2 t (sin t)−3r3 cos t sin2 t− ir3

(
sin3 t

)
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Compute> Simplify
r3 cos3 t +3ir3 cos2 t sin t−3r3 cos t sin2 t− ir3 sin3 t = r3

(
cos(3t)+ ir3 sin(3t)

)
Complex Trigonometric and Hyperbolic Functions

All trigonometric, inverse trigonometric, andhyperbolic functions
are deđned for complex arguments. Arguments that are rational mul-
tiples of i are rewritten in terms of hyperbolic functions.

ăe function arcsinh produces values with imaginary parts in the
interval

[
−π

2 ,
π
2

]
.

Compute> Evaluate
sin5i = i(sinh5) arcsin5i = i(arcsinh5)

cos 5
4i = cosh 5

4 arccos 5
4i =

1
2 π + i

(
arcsinh 5

4

)
tan(−3i) = (tanh3)(−i) arctan(−3i) = (arctanh3)(−i)

Hyperbolic functions with arguments that are integermultiples of
πi/2 are simpliđed by Evaluate.

Compute> Evaluate
sinh

(πi
2

)
= i cosh(40iπ) = 1 cosh−1 0 = 1

2 iπ

For other complex arguments, use Expand to rewrite trigonomet-
ric and hyperbolic functions.

Compute> Expand
sin
(
5i+ 2π

3

)
= 1

2

√
3cosh5− 1

2 i(sinh5)
sinh(x+ iπ) =−sinhx

Use Rewrite to obtain a representation in terms of speciđc target
functions.

Compute> Rewrite> Sin and Cos
e2ix tanx = (sinx)(cos(2x)+isin(2x))

cosx

Forarcsin andarccos, thebranch cuts are the real intervals (−∞,−1)
and (1,∞). For arctan, the branch cuts are the intervals (−∞ · i, i] and
[i,∞ · i) on the imaginary axis. For arcsec and arccsc, the branch cut
is the real interval (−1,1). For arccot, the branch cut is the interval
[i,−i] on the imaginary axis. ăe values jump when the arguments
cross a branch cut.
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Compute> Evaluate
arcsin(−1.2) =−1.5708+0.62236i

arcsin
(
−1.2+ i

1010

)
=−1.5708+0.62236i

arcsin
(
−1.2− i

1010

)
=−1.5708−0.62236i

Note that arccot is deđnedby arccotx= arctan 1
x although arccot

does not rewrite itself in terms of arctan. As a consequence of this
deđnition, the real line crosses the branch cut and arccot has a jump
discontinuity at the origin.

Compute> Evaluate
arcsinh(sinh(3+25i)) = 3−8iπ +25i

With the default setting, Solve > Exact đnds complex as well as
real solutions to trigonometric equations.

Compute> Solve> Exact
tan2 x− cot2 x = 1

Solution:
{

arcsin
√
− 1

2

√
5− 1

2 +πk | k ∈ Z
}

∪
{

arcsin
√

1
2

√
5− 1

2 +πk | k ∈ Z
}

∪
{
−arcsin

√
− 1

2

√
5− 1

2 +πk | k ∈ Z
}

∪
{
−arcsin

√
1
2

√
5− 1

2 +πk | k ∈ Z
}

Note
In this example,√

−1
2

√
5− 1

2
≈ 1.272i

Toobtain the principal solutions only
1. Choose Tools> Preferences>Computation> Engine.

2. Check Principal Value Only.

Compute> Solve> Exact
tan2 x− cot2 x = 1, Solution: arcsin

√
2√√
5+1

Exercises
1. Deđne the functions f (x) = x3 + xsinx and g(x) = sinx2.

Evaluate f (g(x)), g( f (x)), f (x)g(x), and f (x)+g(x).

2. At Metropolis Airport, an airplane is required to be at an al-
titude of at least 800 ft above ground when it has attained a
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horizontal distance of 1 mi from takeoff. What must be the
(minimum) average angle of ascent?

3. Experimentwith expansions of sinnx in terms of sinx and cosx
for n = 1,2,3,4,5,6 and make a conjecture about the form of
the general expansion of sinnx.

4. Experiment with parametric plots of (cos t,sin t) and (t,sin t).
Attach the point (cos1,sin1) to the đrst plot and (1,sin1) to
the second. Explain how the two graphs are related.

5. Experimentwithparametric plots of (cos t,sin t), (cos t, t), and
(t,cos t), together with the point (cos1,sin1) on the đrst plot,
(cos1,1) on the second, and (1,cos1) on the third. Explain
how these plots are related.

6. To convert radians to degrees using ratios, write the equation
θ

360 =
x

2π , wherex represents the angle in radians. ChooseCom-
pute > Solve > Exact or Compute > Solve > Numeric and
name θ as the variable. Use this method to convert x = 13

600 π
radians to degrees.

7. To solĂe a triangle means to determine the lengths of the three
sides and the measures (in degrees or radians) of the three an-
gles.

a. Solve the right triangle with one side of length c = 2 and
one angle α = π

9 .
b. Solve the right triangle with two sides a = 19 and c = 23.

8. ăe law of sines

a
sinα

=
b

sinβ
=

c
sinγ

enables you to solve a triangle if you are given one side and two
angles, or if you are given two sides and an angle opposite one
of these sides. Solve the triangle with one side c = 2 and two
angles α = π

9 , β = 2π
9 .

9. Using both the law of sines and the law of cosines,

a2 +b2−2abcosγ = c2
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you can solve a triangle given two sides and the included angle,
or given three sides.

a. Solve the triangle with sides a = 2.34, b = 3.57, and in-
cluded angle γ = 29

216 π .

b. Solve the triangle with three given sides a = 2.53, b =
4.15, and c = 6.19.

10. Fill in the steps to show that ii = e−
π
2 . Find the general solu-

tion.

Solutions
1. Deđning functions f (x) = x3 + xsinx and g(x) = sinx2 and

evaluating gives

f (g(x)) = sin3 x2 + sinx2 sin
(
sinx2)

g( f (x)) = sin
(
x3 + xsinx

)2

f (x)g(x) =
(
x3 + xsinx

)
sinx2

f (x)+g(x) = x3 + xsinx+ sinx2

2. You can đnd the minimum average angle of ascent by consider-
ing the right triangle with legs of length 800ft and 5280ft. ăe
angle inquestion is the acute anglewith sine equal to 800√

8002+52802
.

Find the answer in radians with Compute > Evaluate > Nu-
meric:

arcsin
800√

8002 +52802
≈ 0.15037

Youcan express this angle indegrees byusing the following steps:

360× 0.15037
2π

≈ 8.6157

0.6157×60 = 36.942
θ ≈ 8◦37′

or solve the equation 0 .15037rad = x ◦ to get 8.6156, then
solve 0.6156◦ = x ′ to get 36.936.
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3. Note that

sin2x = 2sinxcosx
sin3x = 4sinxcos2 x− sinx
sin4x = 8sinxcos3 x−4sinxcosx
sin5x = 16sinxcos4 x−12sinxcos2 x+ sinx
sin6x = 32sinxcos5 x−32sinxcos3 x+6sinxcosx

We leave the conjecture up to you.

4. Figure 4a shows a circle of radius1with center at the origin. ăe
graph is drawn by starting at the point (1,0) and is traced in a
counter-clockwise direction. Figure 4b shows the y-coordinates
of the đrst đgure as the angle varies from 0 to 2π . ăe point
(cos1,sin1) ismarkedwith a small circle in the đrst đgure. ăe
corresponding point (1,sin1) is marked with a small circle in
the second đgure.

­1.0 ­0.5 0.5 1.0

­1.0

­0.5

0.5

1.0

x

y

4a. (cos t,sin t)

1 2 3 4 5 6
­1

0

1

x

y

4b. (t,sin t)

5. Figure 5a shows a circle of radius1with center at the origin. ăe
graph is drawn by starting at the point (1,0) and is traced in a
counter-clockwise direction.
Figure 5b shows the x-coordinates of the đrst đgure as the an-
gle varies from0 to2π . ăepoint (cos1,sin1) ismarkedwith a
small circle in theđrst đgure. ăecorrespondingpoint (cos1,1)
is marked with a small circle in the second đgure.
Figure 5c shows the graph in the second đgure with the hori-
zontal and vertical axes interchanged. Figure 5c shows the usual
view of y = cosx.

6. Write the equation θ
360 =

( 13
600 π)
2π . With the insert point in this

­1.0 ­0.5 0.5 1.0

­1.0

­0.5

0.5

1.0

x

y

5a. (cos t,sin t)

equation, choose Compute> Solve> Exact to get θ = 39
10 de-

grees, or choose Numeric to get θ = 3.9 degrees.

7. To obtain the solutions in the simple form shown below, choose
Compute> Engine Settings and check Principal Value Only.

a. Choose Compute > Deđnitions > New Deđnition for
each of the given values α = π

9 and c = 2. Evaluate β =
π
2 −α to getβ = 7

18 π . Evaluatecsinα to geta= 2sin 1
9 π

(= 0.68404). Evaluate ccosα to get b = 2cos 1
9 π (=

1.8794).
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b. Choose Compute > Deđnitions > New Deđnition to
each of the given values, a = 19 and c = 23. Place the in-
sert point in the equation a2+b2 = c2 and choose Com-
pute > Solve > Exact (Numeric) to get b = 2

√
42 (=

12.96). Place the insert point in each of the equations
sinα =

a
c
, cosβ =

a
c

in turn, and choose Compute >

Solve > Exact to get α = arcsin 19
23 ,β = arccos 19

23 ; or
place the insert point in each of the one-column matrices[

sinα = a/c
α ∈ (0,π/2)

]
and
[

cosβ = a/c
β ∈ (0,π/2)

]
in turn, and choose

Compute >Solve > Numeric to get α = 0.9721, β =
0.5987.

­1 0 1

1

2

3

4

5

6

x

y

5b. (cos t, t)

2 4 6

­1.0

­0.5

0.0

0.5

1.0

x

y

5c. (t,cos t)

8. Choose Compute > Deđnitions > New Deđnition to deđne
α = π

9 , β = 2π
9 , and c = 2. Evaluate γ = π −α − β to get

γ = 2
3 π . Deđne γ = 2

3 π . ChooseCompute> Solve>Exact to

solve the equations
a

sinα
=

c
sinγ

and
b

sinβ
=

c
sinγ

to get a=

4
3

√
3sin 1

9 π and b = 4
3

√
3sin 2

9 π . To get numerical solutions,
choose Compute> Solve>Numeric.

9. Solving general triangles.

a. Deđne eachofa= 2.34,b= 3.57, and γ = 29
216 π . Choose

Compute > Solve > Exact to to solve the equation a2 +
b2−2abcosγ = c2. You should get c = 1.7255. Deđne
c = 1.7255. Choose Compute> Solve> Exact to solve

the equations
a

sinα
=

c
sinγ

and
b

sinβ
=

c
sinγ

, or with

the insert point in each of the matrices a

c

b

α

β

γ

9. General triangle

 a
sinα

=
c

sinγ
α ∈ (0,π/2)

 and

 b
sinβ

=
c

sinγ
β ∈ (0,π/2)


chooseCompute>Solve>Numeric to getα = 0.58859
and β = 1.0104.
A triangle with three sides given is solved similarly: inter-
change the actions on γ and c in the steps just described.
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b. Deđne a = 2.53, b = 4.15, and c = 6.19. Choose Com-
pute > Solve > Exact to solve the equation a2 + b2 −
2abcosγ = c2 to get γ = 2.3458. Deđne γ = 2.3458.
Choose Compute > Solve > Exact to solve each of the

equations
a

sinα
=

c
sinγ

and
b

sinβ
=

c
sinγ

, or put the

insert point in each of the matrices a
sinα

=
c

sinγ
α ∈ (0,π/2)

 and

 b
sinβ

=
c

sinγ
β ∈ (0,π/2)


and chooseCompute>Solve>Numeric to getα = 0.29632
and β = 0.49948.

10. In polar form,

i = cos
π
2
+ isin

π
2
= ei π

2 .

ăen
ii =

(
ei π

2

)i
= e−

π
2 .

For the general solution, for any integer k,

i = cos
(π

2
+2πk

)
+ isin

(π
2
+2πk

)
= ei( π

2 +2πk)

and
ii =

(
ei( π

2 +2πk)
)i

= e−
π
2−2πk
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“Then you should say what youmean,” the March Hare went on. “I do, ” Alice hastily replied; “at least I mean what I say, that's the same thing, you
know.” “Not the same thing a bit!” said the Hatter. “Why, you might just as well say that `I see what I eat' is the same thing as `I eat what I see!' ”

Lewis Carroll (1832–1898), Alice in Wonderland.

D eđnitions enable you to deđne a symbol to be a mathemati- Function and Expression Names

Deöning Variables and Functions

Handling Deönitions

Formulas

External Functions

Trigtype Functions

cal object, and to deđne a function using an expression or a
collection of expressions. Function deđnition is a powerful

tool. Before elaborating on deđnitions, we discuss criteria for names
of functions, constants, and expressions.

Function and Expression Names
Amathematical expression is a collection of valid expression names

combined in amathematically correct way. ăenotation for a function
consists of a valid function name followed by a pair of parentheses
containing a list of variables, called arguments. Trigonometric func-
tions and certain others (trigtype functions) do not always require the
parentheses around the argument. ăe argument of a function can New in Version 6

Overbar for complex conjugate
Decorated characters as expression names
Passthru Code to Engine

also occur as a subscript.

• Examples ofmathematical expressions: x,a3b−2c, xsiny+3cosz,
a1a2−3b1b2

• Examples of ordinary functionnotation: a(x),G(x,y,z), f5 (a,b)
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Valid Names for Functions and Expressions or Variables
A variable or function name must be either

• A single character (other than a standard constant), withorwith-
out a subscript.

Or

• A custom Math Name, with or without a subscript.

Expression names, but not function names, may include decorated
characters such as Ẑ.

• Examples of valid expression names include αX , f123, gθ , Ω∞,
e2, r̃ (decorated character), Waldo (custom name), John3 (cus-
tom name with subscript).

• Examples of valid function names include αX , f123, gθ , Ω∞,
e2, sin, Alice (custom name), Lana2 (custom name with sub-
script).

• Examples of invalid function names include ∆F (two charac-
ters), π , e (standard constants), fab (two-character subscript),
r′ (reserved for derivative).

In the example of function names, the subscript on f123 is properly re-
garded as the number one hundred twenty-three, not “one, two, three.”

Custom Names
In general, function or expression names must be single charac-

ters or subscripted characters. However, the system includes a num-
ber of predeđned functions with names that appear to bemulticharac-
ter—such asgcd, cos, and lcm—but that behave like a single character
in the sense that they can be deleted with a single backspace. You can
create customnameswith similar behavior that are legitimate function
or expression names.

ăere are three types of custom names: Operator, Function, and
Variable. When you choose Name Type to be Operator, the custom
name behaves like ∑ or

∫
with regard to Operator Limit Placement.

When you choose Name Type to be Function or Variable, it behaves
like an ordinary character with regard to subscripts and superscripts.
Observe the different behaviors of these types for inline and displayed
situations:
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• Inline Operator: ∑n
k=1 ,

∫ 1
0 , operatorb

a

• Inline Function or Variable: a j
k, variabled

c

• Displayed Operator, and displayed Function or Variable:

n

∑
k=1

1∫
0

b
operator

a
a j

k variabled
c

Tocreate a custommathname
1. Choose Insert>Math Objects>Math Name.

2. Type a custom name in the text box under Name.

3. For Name Type, choose Operator or Function or Variable.

4. If you choose Operator, check your choice of Operator Limit
Placement.

5. If youwant this name to automatically graywhen typed inmath-
ematics mode, check Add Automatic Substitution.

6. Choose OK.
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ăe gray custom name appears on the screen at the insert point.
You can use this name to deđne a function or expression. You can copy
and paste or click and drag this grayed name on the screen, or you can
recreate it with the Math Name dialog.
Tocreate a decorated character

1. Type a character.

2. Select the character and choose Edit> Properties>Character
Properties.

3. Click the desired accent and choose OK.

Compute> Deönitions> New Deönition
a = 3
ã = x2 + y2

Compute> Deönitions> Evaluate
aã = 3x2 +3y2

Automatic Substitution
When automatic substitution is enabled, function names such as

sin, arcsin, and gcd automatically turn graywhen typed inmathemat-
ics. For a list of these names, choose Tools>Auto Substitution.
Toenable auto substitution inmathematics

• Choose Tools>Auto Substitution and under Enable auto sub-
stitution , check In Math.

If automatic substitution is not enabled in mathematics, no func-
tion names automatically gray and such names must be selected from
the Auto Substitution list or created by choosing Insert > Math Ob-
jects>Math Name.

You can evoke the automatic substitution behavior with new cus-
tom names using the Automatic Substitution dialog.
Tomake a customname automatically gray

1. Choose Tools>Auto Substitution.

2. Type the keystrokes that you wish to use. (ăis may be an ab-
breviated form of the custom name.)

3. Click the Substitution box to place the cursor there and, leaving
Auto Substitution open, choose Insert>MathObjects>Math
Name.
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4. Choose a custom name from the scroll-down list or type a cus-
tom name in the Name text box in the Math Name dialog.

Automatic substitution
For another example, see Automatic
Substitution, page 512.
For further details, choose Help> Index>
General Information and look under automatic
substitution.

5. Choose Apply. (ăe custom name will appear in gray in the
Substitution box of the Automatic Substitution dialog.)

6. In the Math Name dialog box, choose OK. (ăe Math Name
dialog will close.)

7. In the Auto Substitution dialog box, choose Save and choose
OK.

Deöning Variables and Functions
WhenyouchooseCompute>Deđnitions, the submenu that opens

containsđve items: NewDeđnition,Undeđne, ShowDeđnitions,Clear
Deđnitions, and Deđne MuPAD Name. ăe choice New Deđnition
can be applied both for deđning functions or variables and for naming
expressions.

Assigning Values to Variables, or Naming Expressions
You can assign a value to a variable by choosing Compute>Deđ-

nitions>New Deđnition. ăere are two options for the behavior of
the deđned variable, depending on the symbol you use for assignment.
ăe default behavior, triggered by =, is deferred evaluation, meaning
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the deđnition is stored exactly as you make it. ăe alternate behavior,
triggered by :=, is full evaluation,meaning the deđnition that is stored
takes into account earlier deđnitions in force that might affect it. See
Full Evaluation andAssignment page 105 for a discussion of the latter
option.

Deferred Evaluation
• Use an equal sign= to make an assignment for deferred evalu-

ation.

Toassign the value 25 to z for deferred evaluation
1. Type z = 25 in mathematics.

2. Leave the insert point in the equation.

3. Choose Compute>Deđnitions>New Deđnition.

ăereaĕer, until you exit the document or undeđne the variable,
the system recognizes z as 25. For example, evaluating the expression
“3+ z” returns “= 28.”

Another way to describe this operation is to say that an expression
such as x2 + sinx can be given a name. Type y = x2 + sinx, leave
the insert point anywhere in the expression, and choose Compute >
Deđnitions>New Deđnition. Note

These variables or names are single characters.
See page 100 for information on
multicharacter names.

Compute> Deönitions> New Deönition
y = x2 + sinx

Now, whenever you evaluate an expression containing y, every oc-
currence of y is replaced by the expression x2 + sinx.

Compute> Evaluate
y2 + x3 =

(
sinx+ x2

)2
+ x3

Functions and expressions
The symbol p represents the expression
x3−5x+1. It is not a function, so, for
example, p(2) is not the polynomial
evaluated at 2, but rather is
p(2) = 2p = 2x3−10x+2, the
product of p and 2.

ăevalue assigned can be anymathematical expression. For exam-
ple, you could deđne a variable to be

• A number: a = 245

• A polynomial: p = x3−5x+1

• A quotient of polynomials: b =
x2−1
x2 +1

• A matrix: z =
[

a b
c d

]
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• An integral: d =
∫

x2 sinxdx

You will đnd this feature useful for a variety of purposes.

Compound Deönitions with Deferred Evaluation
It is legitimate to deđne expressions in terms of other deđned ex-

pressions.
Tomake compounddeđnitionswith deferred evaluation

• Assign a value to a variable and then use that variable name in
the deđnition of a second variable.

Compute> Deönitions> New Deönition
r = 3p− cq s = nr+q

Compute> Evaluate
s = q+n(3p− cq)

Note
Redeöning r will change the evaluation of s.Full Evaluation and Assignment

With full evaluation, variables previously deđned are evaluated be-
fore the deđnition is stored. ăus, deđnitions of expressions can de-
pend on the order in which they are made.
Tomake an assignment symbol for full evaluation

• Type a colon followed by an equals sign :=.

Toassign the value25a to z for full evaluation
1. Type z := 25a in mathematics.

2. Leave the insert point in the equation.

3. Choose Compute>Deđnitions>New Deđnition.

ăereaĕer, until you exit the document or undeđne the variable z,
if a has not been previously deđned, the system recognizes z as 25a. If
a has previously been deđned to be x+ y, then the system recognizes
z as 25(x+ y) .

Try the following examples that contrast the two types of assign-
ments. Aĕer making the deđnitions, choose Compute>Deđnitions
> Show Deđnitions for each case.

1. Make the assignments a = 1, x := a, y = a, and a = 2 (in that
order), and evaluate x and y. ăe result should be x = 1, y = 2.
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2. Make the assignments a = b, x := a2, y = a2, and a = 6 (in
that order), and evaluate x and y. ăe result should be x = b2,
y = 36.

3. Deđne r = 3p−cq and then s= nr+q and t := nr+q. Evalu-
ating s and t will then give s= q+n(3p− cq), t = q+n(3p− cq).
Now deđne r = x + y. Evaluating s and t will now give s =
q+n(x+ y), t = q+n(3p− cq).

Functions of One Variable
By using function notation, you can use the same general proce-

dure to deđne a function as was described for deđning a variable.

Todeđne the function f whose value at x isax2 +bx+ c

1. Type the equation f (x) = ax2 +bx+ c.

2. Place the insert point in the equation.

3. Choose Compute>Deđnitions>New Deđnition.

Aĕer following this procedure, the symbol f represents the de-
đned function and it behaves like a function.

Compute> Deönitions> New Deönition
f (x) = ax2 +bx+ c

Tip
After deöning a function, you can make a table
of values for selected points in the domain of
the function. See Chapter 7 “Calculus,” page
205 for examples.

Compute> Evaluate
f (t) = at2 +bt + c f ′ (t) = b+2at
f (x+h) = c+b(h+ x)+a(h+ x)2

Compound Deönitions
ăe algebra of functions includes objects such as f + g, f − g,

f ◦ g, f g, and f −1. For the value of f + g at x, write f (x)+ g(x);
for the value of the composition of two deđned functions f and g,
write f (g(x)) or ( f ◦g)(x); and for the value of the product of two
deđned functions, write f (x)g(x). You can obtain the inverse (or in-
verse relation) for some functions f (x) by choosingCompute> Solve
> Exact with the equation f (y) = x and specifying y as the Variable
to Solve for.
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Tomake compounddeđnitions
1. Deđne functions by choosing Compute>Deđnitions>New

Deđnition, either as generic functions or in terms of an expres-
sion.

2. Combine these functions in standard ways and deđne the re-
sulting functions by choosing Compute > Deđnitions > New
Deđnition.

Deđne g(x) and h(x). ăen the following equations are examples
of legitimate deđnitions:

• f (x) = 2g(x)

• f (x) = g(x)+h(x)

• f (x) = g(x)h(x)

• f (x) = g(h(x)) or f (x) = (g◦h)(x)

• f (x) = g(x)/h(x) or f (x) =
g(x)
h(x)

Once you have deđned both g(x) and f (x) = 2g(x), then chang-
ing the deđnition of g(x) will change the value of f (x).

Subscripts as Function Arguments
A subscript can be interpreted either as part of the name of a func-

tion or variable, or as a function argument.
Todeđne a subscript as a function argument

1. Place the insert point in an equation such as ai = 3i with a
symbolic subscript and choose Compute>Deđnitions>New
Deđnition.

2. In the Interpret Subscript dialog that opens, check A function
argument.

Observe the different behavior in the following examples.

Compute> Deönitions> New Deönition
ai = 3i (subscript a function argument)
bi = 3i (subscript a part of the name)
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Compute> Evaluate
a2 = 6
b2 = b2

Choose Compute > Deđnitions > Show Deđnitions to see how
these deđnitions are listed: Note

A function cannot have both subscripted and
inline variables. For example, if you deöne
fa (y) = 3ay, then a is part of the function
name and y is the function argument.

Compute> Deönitions> Show Deönitions
ai = 3i (variable subscript)
bi = 3i

ăus ai denotes a function with argument i, and bi is only a sub-
scripted variable.

Compute> Deönitions> New Deönition
fa (y) = 3ay

Compute> Evaluate
fa (5) = 15a f3 (5) = 5 f3

Note
Note that fa is a function but f3 is just a
subscripted character.Piecewise-Deöned Functions

You can deđne functions of one variable that are described by dif-
ferent expressions on different parts of their domain. ăese functions
are referred to as piecewise-deĖned functions, case functions, ormulticase
functions. Most of the operations introduced in calculus are supported
for piecewise-deđned functions. You can evaluate, plot, differentiate,
and integrate piecewise-deđned functions.

Structure of a piecewise-deöned function
• ăe function deđnition must be speciđed in a two- or three-

column matrix with at least two rows, with the function values
in the đrst column, “if ” (text) or “i f ” (math) in the second col-
umn of a three-column matrix (and “if,” or any text, or no text,
in the second column of a two-columnmatrix), followed by the
range condition in the last (second or third) column. Note

For the null right delimiter, choose the dashed
vertical line. This line does not normally
appear in the printed document. It appears on
screen as a dashed red line only when Helper
Lines is checked in the Viewmenu.

• ăe matrix must be fenced with a leĕ brace and null right de-
limiter, as in the following examples.

To formamatrix for a piecewise-deđned function

1. Choose Insert Math Objects> Brackets and choose { for the
leĕ bracket and the null delimiter (dashed vertical line) for the
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right bracket.

2. Choose Insert>Math Objects>Matrix.

3. Set thenumbers forRows (numberof conditions) andColumns
(2 or 3), and choose OK. Caution

There are fairly strict conditions concerning the
format for the piecewise deönition of
functions.Todeđne apiecewise-deđned function f using amatrixwith three columns

1. Type f (x) = followed by a matrix enclosed in brackets as de-
scribed.

2. Type function values in the đrst column.

3. Type if in the second column in text or mathematics mode.

4. Type the range conditions in the third column.

5. Leave the insert point in the equation and choose Compute>
Deđnitions>New Deđnition.

Todeđne a piecewise-deđned function f using amatrixwith two columns
1. Type f (x) = followed by a matrix enclosed in brackets as de-

scribed. Tip
When entering piecewise-deöned functions,
choose View and turn on Helper Lines to see
important details.

2. Type function values in the đrst column.

3. (Optional) Type if in text mode in the second column.

4. Type the range conditions in mathematics mode in the second
column.

5. Leave the insert point in the equation and choose Compute>
Deđnitions>New Deđnition.

Functions should be entered as in the following examples.

109



i
i

“Compute60” — 2011/12/20 — 14:27 — page 110 — #120 i
i

i
i

i
i

Chapter 5 | Function Deönitions

Compute> Deönitions> New Deönition

f (x) =

 x+2 if x < 0
2 if 0≤ x≤ 1

2/x if 1 < x
(3×3 matrix)

g(t) =


t if t < 0
0 if 0≤ t < 1
1 if 1≤ t < 2
2 if 2≤ t < 3

6− t if 3≤ t

(5×2 matrix)

h(x) =
{

x+2 i f x < 1
3/x i f 1≤ x (2×3 matrix)

k (x) =
{

x+2 x < 1
3/x 1≤ x (2×2 matrix)

m(x) =
{

x+1 whenever x < 1√
x whenever 1≤ x (2×2 matrix)

Tip
To evaluate, plot, differentiate, or integrate
such a function, you can make the deönition
and then work with the function name f or
the expression f (x). You can also place the
insert point in the deöning matrix to carry out
such operations.

Compute> Evaluate
f (−1) = 1 f (1/2) = 2

f ′ (x) =


1 if x < 0
0 if 0 < x∧ x < 1
− 2

x2 if 1 < x

See page 155 for details on plotting piecewise-deđned functions.

Deöning Generic Functions
You can choose Compute>Deđnitions>NewDeđnition to de-

clare an expression of the form f (x) to be a function without spec-
ifying any of the function values or behavior. ăus you can use the
function name as input when deđning other functions or performing
various operations on the function.
Todeđne a generic function

1. Write an expression of the form f (x).

2. With the insert point in the expression, choose Compute >
Deđnitions>New Deđnition.
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Here, f is deđned as a generic function andg as a speciđc function.
ăe examples show how f and g interact.

Compute> Deönitions> New Deönition
f (x) g(x) = x2−3x

Compute> Evaluate
f (g(x)) = f

(
x2−3x

)
g( f (x)) = f 2 (x)−3 f (x)

Deöning Generic Constants
You can choose Compute>Deđnitions>NewDeđnition to de-

clare any valid expression name to be a constant.
Todeđne a generic constant

1. Write a valid constant name in mathematics.

2. Choose Compute>Deđnitions>New Deđnition.

Compute> Deönitions> New Deönition
a

Functions of Several Variables
Deđne functions of several variables in essentially the same way as

functions of one variable. Note
Just as in the case of functions of one variable,
the system always operates on expressions
that it obtains from evaluating the function at
a point in the domain of the function.

Todeđne a functionof several variables
1. Write an equation such as f (x,y,z) = ax+y2+2z or g(x,y) =

2x+ sin3xy.

2. With the insert point in the equation, choose Compute>Def-
initions>New Deđnition.

Assumptions About Variables
In some situations it is useful to restrict the domain of a variable.

For example, you may want the variable to assume only positive val-
ues or only real values. Such restrictions are made with the function
“assume.”ăe functions available formaking or checking or removing
assumptions are Note

The normal global default is the complex
plane. Variables are assumed to be complex
variables and solutions to equations include
complex solutions.

assume additionally about unassume

ăese functions place restraints on speciđc variables, provide infor-
mation on the restraints, or remove restraints. ăe function assume
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enables you to place a restraint on a variable. ăe function addition-
ally allows you to place additional restraints. ăe function about re-
turns information on the restraints. ăe function unassume removes
restraints.

Allowable assumptions include

real complex integer positive negative nonzero

ăe functions and assumptions listed above will automatically turn
upright and gray when typed in mathematics mode. ăe following
assumptions are also allowed for real variables x and y, and complex z: Note

After making the assumption
assume(x, real) = R, only real solutions
will be computed:

x < y x < 3 x ̸= 0 x≤ y x≥ 5
Im(z)> 0 Re(z)< 0 Re(z) ̸= 0

Toenter the names of the functions and assumptions
• Type thename inmathematicsmode. (Itwill automatically turn

gray.) Or

• Choose Insert > Math Objects > Math Name and type the
name in the input box or select from the list of names.

Tomake an assumption about a variable
1. In mathematics, type assume.

2. Choose Insert > Math Objects > Brackets and click the leĕ
paren ( . Tip

Use the keyboard shortcut Ctrl+9 or Ctrl+( to
enter expanding parentheses.3. Type the variable name, followed by a comma, followed by the

desired assumption.
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4. Choose Compute> Evaluate.

Compute> Evaluate
assume(x, real) = R

Compute> Solve> Exact
x2 =−1, No solution found.
x2 = 1, Solution: −1,1

Toplace an additional assumptionon a variablewithout removingprevious
assumptions

1. In mathematics, type additionally. Note
An additional assumption placed on a variable
using assumewould negate any previous
assumption.

2. Choose Insert>Math Objects> Brackets and click ( .

3. Inside the parentheses, type the variable name, followed by a
comma, followed by the desired assumption.

4. Choose Compute> Evaluate.

Evaluation of the expressions assume(n,positive) and
additionally(n, integer), followed by evaluation of the expression
about(n), produces the following output:

Compute> Evaluate
assume(n,positive) = (0,∞)

additionally(n, integer) = Z∩ (0,∞)

about(n) = Z∩ (0,∞)

To restrict the domain of a real variable x
1. Make the assumption that x is real.

2. Use the function additionally for additional restraints on x.

Compute> Evaluate
assume(x, real) = R
additionally(x < 10) = (−∞,10)
additionally(x≥−10) = [−10,10)

Compute> Solve> Exact
sinx = 0, Solution: −3π,−2π,−π,0,π,2π,3π

Toassume the variablen is positive
• Place the insert point in the expression assume(n,positive),

and choose Compute> Evaluate.
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Toclear the assumptions about a variable
• Select the variable and choose Compute > Deđnitions > Un-

deđne, or

Evaluate unassume(name of variable).

Compute> Deönitions> Undeöne
n

or
Compute> Evaluate
unassume(n)

Aĕer either procedure, you can check the status of the variable n
with the function about.

Compute> Evaluate
about(n) = n

ăis response indicates there are no assumptions on the variable n.
Note
If you assume that n is an integer, the system
will recognize thatn2 is a positive integer.

Compute> Evaluate
assume(n, integer) = Z
about

(
n2
)
= Z∩ [0,∞)∣∣n2 +1

∣∣= n2 +1

In the default mode, both real and complex solutions will be com-
puted:

Compute> Solve> Exact
x4 = 1, Solution: −i,−1, i,1

Assuming x is positive leads to only real positive solutions:

Compute> Evaluate
assume(x,positive) = (0,∞)

Compute> Solve> Exact
x2 = 1, Solution: 1
x4 = 1, Solution: 1

To restrict the domain of a complex variable z
• Make assumptions on the real and imaginary parts of z.

Compute> Evaluate
assume(Re(z)> 0) = (0,∞)+ iR
additionally(Im(z)< 0) = (0,∞)+ i(−∞,0)
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Handling Deönitions
Aĕer making deđnitions of functions or expressions, you need to

know techniques for keeping track of them. ăe choices on the Def-
initions submenu are New Deđnition, Undeđne, Show Deđnitions,
Clear Deđnitions, and Deđne MuPAD Name. ăe choice Show Def-
initions also appears on the Math toolbar as .

Showing Deönitions
Toview the complete list of currently deđned variables and functions

• Choose Compute>Deđnitions> Show Deđnitions.

A window opens showing the active deđnitions. ăe deđned vari-
ables and functions are listed in the order inwhich the deđnitionswere
made.

Removing and Changing Deönitions
To remove all deđnitions

• Choose Compute>Deđnitions>Clear Deđnitions.

To remove a single deđnition
• Select the deđning equation or select the name of the deđned

expression or function and choose Compute > Deđnitions >
Undeđne.

Tochange a deđnition
• Make anewdeđnitionusing the same functionor variable name.

You can select the equation or name by placing the insert point
within or on the right side of the equation or name that you wish to
remove, or you can select the entire equation, expression, or function
namewith themouse. You can đnd the equation or name in the Show
Deđnitions window if you do not have a copy readily at hand. Copy
an expression from this window into your document, then select the
expression and choose Undeđne.

Formulas
ăe Formula dialog provides a way to enter an expression and a

Compute operation. What appears on the screen is the result of the
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operation and depends upon active deđnitions of variables that ap-
pear in the formula. Formulas remain active in your document—that
is, changing deđnitions of relevant variables changes the data on the
screen.
To insert a formula

1. Choose Insert>Math Objects> Formula.

2. Type an expression in the input box. Note
With Helper Lines on, a Formula appears with
a colored background. The default is yellow.3. In theOperation area, select the operation youwant to perform

on the expression. (Click the arrow at the right of the box for a
list of available operations.)

4. Choose OK.

ăe results of the operation will be displayed in your document
window.
To recognize a formula on the screen fromabackground color

• Choose View and turn on Helper Lines.

Tochange the formula background color
1. Choose Tag>Appearance.

2. Check Modify Style Defaults.

3. Under Tag Properties, choose Special Objects.

4. Under Special Objects choose Formula and click Modify.

5. Select background color and choose OK.

6. Choose Save if you wish to make a permanent change in the
screen style, and choose OK.

Example Choose Insert > Math Objects > Formula. In the For-
mula box, type a, and under Operations choose evaluate. Choose
OK. ăe a will appear on your screen at the position of the insert
point. Now, at any point in your document, deđne a = sinx. ăe
variable a will be replaced by the expression sinx wherever a appears
in the document. Make another deđnition for a. ăe variable a will
again be replaced by the new deđnition everywhere a appears in the
document.
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Example Insert a 2× 2 matrix. With the insert point in the đrst
input box, choose Insert>Math Objects> Formula. In the Formula
box, type a. UnderOperations, choose Evaluate. ChooseOK. Repeat
for each matrix entry, typing b, a+ 2b, and (a−b)2, in turn, in the
formula box to get the matrix[

a b
a+2b (a−b)2

]
Now deđne a = sinx and b = cosx. ăe matrix will be replaced by
the matrix [

sinx cosx
sinx+2cosx (sinx− cosx)2

]
Deđne a = lnx and b = ex. ăe matrix will then be replaced by the
matrix [

lnx ex

lnx+2ex (lnx− ex)2

]

Example Insert a table with 2 columns and 5 rows. Insert formulas
x, y, z, and x+ y+ z in the column on the right.

Date Income
1/31/96 x
2/28/96 y
3/31/96 z

Total x+ y+ z

Deđne x = 20.56, y = 18.92, z = 23.45 to get the table

Date Income
1/31/96 20.56
2/28/96 18.92
3/31/96 23.45

Total 62.93

Formulas are useful for writingmultiple choice examinations with
variationsăenext example outlines away for constructing themman-
ually.

ăe questions in an examination depend on deđnitions that are
made globally for each document—they’re not local to each question
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or variant. ăismeans that you oĕen should use aMathName instead
of a single character name for variables. A sample question is shown in
the next example. ăe variables a1 and b1 shown in the next example
are math names.
Toenter aMathName in aFormulawindow

1. Choose Insert>Math Objects> Formula. Tip
Using a Math Name (see page 100) instead of a
single character name for each variable avoids
conøicts with other deönitions in the
document.

2. With the insert point in the Formula window, choose Insert>
Math Objects>Math Name.

3. Type or select a Math Name and choose OK.

Example You can create an examination with variations by making
different deđnitions for the variables such as the a1 and b1 shown in
the following question. Turn on Helper Lines in your document and
look for background color to check that all appropriate entries are for-
mulas.

1. For which values of the variable x is a1x−b1 < 0?

a. x < b1/a1

b. x > b1/a1

c. x > b1

d. x < b1

e. None of these

Deđne a1= 2 andb1= 5 by placing the insert point in each equa-
tion and choosing Compute > Deđnitions > New Deđnition. On
your screen you should see

1. For which values of the variable x is 2x−5 < 0?

a. x < 5/2

b. x > 5/2

c. x > 5

d. x < 5

e. None of these

Aĕerprinting aquiz,makedifferentdeđnitions for all the variables
such as a1 and b1 to obtain variations of the quiz.
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External Functions
You can access functions available to the computation engine that

do not appear as menu items. ăese can be either functions from one
of the libraries of the computation engine or user-deđned functions.

Functionsdeđnedwith theCompute>Deđnitions>DeđneMu-
PADNamedialog, with theirMuPADname correspondences, appear
in the Show Deđnitions window but they may not be removed by
Clear Deđnitions.

To remove a deđnedMuPADfunction
• Select the function name and choose Compute > Deđnitions
>Undeđne.

Accessing Functions in MuPAD Libraries
ăe following example deđnes the function divisors, which com-

putes the divisors of a positive integer.

Toaccess theMuPADfunctiondivisors and toname itD
1. Choose Compute>Deđnitions>Deđne MuPAD Name. Caution

Multiple notations for vectors are possible in
Scientiöc WorkPlace and Scientiöc Notebook,
including row or columnmatrices, and
n-tuples enclosed by either parentheses or
square brackets. However, to work with a
function deöned from the MuPAD libraries, you
must use MuPAD syntax for the function
arguments.

2. Respond to the dialog box as follows:

• MuPAD Name: numlib::divisors(x)

• Scientiđc Notebook (WorkPlace) Name: D(x)

• Check “ăat is built in to MuPAD” or “is automatically
loaded”

3. Choose OK.

Compute> Evaluate
D(24) = [1,2,3,4,6,8,12,24]

An extensive MuPAD library is included with your system. Here
is a short list of functions from the many examples that are available
using the Deđne MuPAD Name dialog.
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MuPAD Name Sample SWP/SNB Name
nextprime(n) p(n)
ithprime(n) I(n)
isprime(n) q(n)
numlib::phi(n) φ(n)
numlib::legendre(a,b) L(a,b)
numlib::divisors(x) d(x)
polylib::resultant(a,b,x) r(a,b,x)
lllint(a) L(a)

Note
See Appendix D for additional MuPAD
functions.

ăe following example deđnes the function ithprime, which pro-
duces the ith member of the sequence of prime integers.
Toaccess theMuPADfunction ithprime and toname it I

1. Choose Compute>Deđnitions>Deđne MuPAD Name.

2. In the MuPAD Name box, type ithprime(x).

3. In the Scientiđc WorkPlace (Notebook) Name box, type I (x)

4. Check “ăat is built in to MuPAD or is automatically loaded.”

5. Choose OK.

Compute> Evaluate
I (100) = 541 I (1000000000) = 22801763489

See page 453 for another example. In that section, the MuPAD
function nextprime is used.

ăe guidelines for valid function and expression names (see page
100) apply to the names that can be entered in the Deđne MuPAD
Name dialog box. You can give a multicharacter name to a function
as follows: with the Deđne MuPAD Name dialog box open and the
insert point in the Scientiđc WorkPlace/Scientiđc Notebook Name
box, choose Insert > Math Objects > Math Name, type the desired
function name, and click OK.

ăepreceding comments also apply to user-deđnedMuPADfunc-
tions discussed in the following section.

User-Deöned MuPAD Functions
You can access user-deđned functions written in the MuPAD lan-

guage. Write a MuPAD function or procedure with MuPAD or any
ASCII editor, and save to a đle đlename.mu. While in a ScientiĖc
WorkPlace (Notebook) document, choose Compute > Deđnitions >
Deđne MuPAD Name.
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Toaccess the functionmyfunc andname itM
1. Choose Compute>Deđnitions>Deđne MuPAD Name.

2. Respond to the dialog box as follows:

• MuPAD Name: typemyfunc(x).
• Scientiđc WorkPlace (Notebook) Name: type M(x).

• ăe MuPAD Name is a Procedure:

– Check In MuPAD format đle (.mu đle) for MuPAD
đle.

– Choose Browse and locate your đle.

3. Choose OK.

ăisprocedure deđnes a functionM(x) that behaves according to your
MuPAD program.

Example Create an ASCII đle with the following content.
myfunc := proc(x)
begin

return(sin(2*x));
end_proc;

Save the đle under the name myfunc.mu, and deđne the function M in
ScientiĖc Notebook or ScientiĖc WorkPlace according to the instruc-
tions preceding this example. You can then evaluate M (2).

Compute> Evaluate
M (2) = sin4

Passthru Code to Engine
You can also pass MuPAD code directly to the MuPAD engine.

ăis is similar to using Deđne MuPAD Name, but is convenient for
accessing a MuPAD function that you may only use once or twice. It
requires knowledge of the exact MuPAD syntax.
To solve the systemof equations2x+ y = 7,3x−2y = 0

1. Type the MuPAD code solve({2*x+y=7,3*x-2*y=0},{x,y}) in text.

2. Select the code with your mouse.

3. Choose Compute> Passthru Code to Engine.
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Compute> Passthru Code to Engine
solve({2*x+y=7,3*x-2*y=0},{x,y})

{[x = 2,y = 3]}

To list the numbersπ,
√

10,e,11/4,2.718 in increasing order
1. Type the MuPAD code sort([PI,sqrt(10),E,11/4,2.718]) in text.

2. Select the code with your mouse.

3. Choose Compute> Passthru Code to Engine.

Compute> Passthru Code to Engine
sort([sqrt(10),11/4,2.718])[
2.718, 11

4 ,
√

10
]

Trigtype Functions
ScientiĖcWorkPlace and ScientiĖcNotebook recognize two types of

functions—ordinary functions and trigtype functions. ăe functions
Γ(x) and exp(x) are examples of ordinary functions while sinx and
lnx are examples of trigtype functions. ăe distinction is that the ar-
gument of an ordinary function is always enclosed in parentheses and
the argument of a trigtype function oĕen is not.

Twenty six functions are interpreted as trigtype functions: the six
trigonometric functions, the corresponding hyperbolic functions, the
inverses of these functions written as “arc” functions (e.g. arctan(x)),
and the logarithmic functions log and ln. ăese functions are identi-
đed as trigtype functions because they are commonly printed differ-
ently from ordinary functions in books and journal articles.

You can reset your system so that all output is written with paren-
theses around arguments.
Todisable trigtype output

1. Choose Tools> Preferences>Computation>Output.

2. Check Use Parentheses for Trig Functions.

3. Choose OK.

Your system will continue to interpret sinx as a function with ar-
gumentx, but theoutput of all computationswill be of the form sin(x)
with the argument enclosed in parentheses.
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Determining the Argument of a Trigtype Function
ăere is no ambiguity in determining the argument of an ordi-

nary function because it is always enclosed in parentheses. However it
can be rather tricky to đnd the argument of a trigtype function. Con-
sider Γ(a+b)x and sin(a+b)x for example. It is clear that one in-
tends to evaluate Γ at a+ b and then multiply the result by x. How-
ever, with the similar construction sin(a+b)x, it is quite likely that
the sine function is intended to be evaluated at the product (a+b)x.
If this is not what is intended, the expression is normally written as
xsin(a+b), or as (sin(a+b))x.
Todetermine howan expression you enterwill be interpreted

• Place the insert point in the expression and choose Compute>
Interpret.

In the following examples, Use Parentheses for Trig Functions has
been checked.

Compute> Interpret
sinx/2 = 1

2 sin(x) sinx/y = sin
(

x
y

)
Roughly speaking, the algorithm that decides when the end of the

argument of a trigtype function has been reached when it đnds a+ or
− sign, but tends to keep going as long as things are still being mul-
tiplied together. ăere many exceptions, some of which are shown in
the following examples.

Compute> Interpret Argument of sin
sinx+5 = sin(x)+5 x
sin(a+b)x = sin(a+b)x (a+b)
sinx(a+b) = sin(x(a+b)) x(a+b)
sinxcosx = sin(x)cos(x) x
sinx(cosx+ tanx) = sin(x(cosx+ tanx)) x(cosx+ tanx)
(sinx)(cosx+ tanx) = (sin(x))(cosx+ tanx) x
sinxex = sin(xex) xex

ex sinx = ex sin(x) x

When in doubt, use extra parentheses or choose Compute > In-
terpret. Note that there is no ambiguity in the expression ex sinx.ăe
expression sinxex may or may not be interpreted in the way you in-
tended.

123



i
i

“Compute60” — 2011/12/20 — 14:27 — page 124 — #134 i
i

i
i

i
i

Chapter 5 | Function Deönitions

Exercises
1. Deđne a = 5. Deđne b = a2. Evaluate b. Now deđne a =

√
2.

Guess the value of b and check your answer by evaluation.

2. Deđne f (x) = x2 +3x+2. Evaluate

f (x+h)− f (x)
h

and simplify the result. Do computing in place to show inter-
mediate steps in the simpliđcation.

3. Deđne f (x) = x2−1, g(x) = 3x+2, h(x) = x2 +3x. Com-
pute f +g, ( f +g)h, and f h+gh. Compute ( f +g)◦h, and
f ◦h+g◦h.

4. Redeđne the function f (x)=max
(
x2−1,7− x2

)
as a piecewise-

deđned function.

5. Experimentwith theEuler phi functionφ(n), which counts the
number of positive integers k≤ n such that gcd(k,n) = 1. Test
the statement “If gcd(n,m) = 1 then φ(nm) = φ(n)φ(m)”
for several speciđc choices of n and m. Choose Compute >
Deđnitions > Deđne MuPAD Name to open a dialog. Type
numlib::phi(n) as theMuPADName, φ(n) as the ScientiđcWork-
Place/NotebookName, checkăat is Built IntoMuPADor au-
tomatically loaded, and click OK.

6. Choose Compute > Deđnitions > Deđne MuPAD Name to
open a dialog. Deđne d(n) by typing numlib::divisors(n) as
theMuPADname, d(n) as the ScientiđcWorkPlace/Notebook
Name, checkăat isBuilt IntoMuPADor automatically loaded,
and click OK. Explain what the function d(n) produces. (ăis
is an example of a set-valued function, since the function values
are sets instead of numbers.)

Solutions
1. If a = 5 then deđning b = a2 produces b = 25. Now deđne

a =
√

2. ăe value of b is now b = 2.
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2. Evaluate followed by Simplify yields

f (x+h)− f (x)
h

=
1
h

(
3h− x2 +(h+ x)2

)
= 2x+h+3

Select the expression= f (x+h)− f (x)
h and,with theCtrl keydown,

drag the expression to create a copy. Select the expression f (x+h)
and, with theCtrl key down, choose Evaluate. Add similar steps
(use Factor to rewrite 2xh+h2+3h) until you have the follow-
ing:

f (x+h)− f (x)
h

=
3h+3x+(h+ x)2 +2−

(
3x+ x2 +2

)
h

=
3h+3x+2hx+h2 + x2 +2−3x− x2−2

h

=
3h+2hx+h2

h
=

h(h+2x+3)
h

= h+2x+3

3. ăe sum is given by ( f +g)(x) = f (x)+g(x) so

( f +g)(x) =
(
x2−1

)
+(3x+2) = x2 +3x+1

ăe product is given by (( f +g)h)(x) = (( f +g)(x))(h(x))
so

(( f +g)h)(x)=
(
x2 +3x+1

)(
x2 +3x

)
= x4+6x3+10x2+3x

ăesumof theproducts is ( f h+gh)(x)= f (x)h(x)+g(x)h(x)
so

( f h+gh)(x) =
(
x2−1

)(
x2 +3x

)
+(3x+2)

(
x2 +3x

)
= x4 +6x3 +10x2 +3x

Deđne k (x) = f (x)+g(x) then ( f +g)◦h = k ◦h so

(( f +g)◦h)(x) = (k ◦h)(x) =
(
x2 +3x

)2
+1+3x2 +9x

= x4 +6x3 +12x2 +9x+1

Finally, ( f ◦h+g◦h)(x) = ( f ◦h)(x)+(g◦h)(x) so that
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( f ◦h)(x)+(g◦h)(x) =
((

x2 +3x
)2−1

)
+
(
3x2 +9x+2

)
= x4 +6x3 +12x2 +9x+1

ăisdemonstrates that bothproduct and compositiondistribute
over addition.

4. To redeđne f (x)=max
(
x2−1,7− x2

)
as a piecewise-deđned

function, đrst note that the equation x2− 1 = 7− x2 has the
solutions x =−2 and x = 2. ăe function f is given by

g(x) =

 x2−1 if x <−2
7− x2 if −2≤ x≤ 2
x2−1 if x > 2

As a check, note that f (−5) = 24, g(−5) = 24, f (1) = 6,
g(1) = 6, f (3) = 8, and g(3) = 8.

5. Construct the following table:

n φ(n)
1 1
2 1
3 2
4 2
5 4
6 2
7 6
8 4
9 6
10 4

n φ(n)
11 10
12 4
13 12
14 6
15 8
16 8
17 16
18 6
19 18
20 8

n φ(n)
21 12
22 10
23 22
24 8
25 20
26 12
27 18
28 12
29 28
30 8

Notice, for example, that

φ(4 ·5) = 8 = φ(4)φ(5)
φ(4 ·7) = 12 = φ(4)φ(7)
φ(3 ·8) = 8 = φ(3)φ(8)
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6. Construct the following table:

n φ(n)
1 1
2 [1,2]
3 [1,3]
4 [1,2,4]
5 [1,5]
6 [1,2,3,6]
7 [1,7]
8 [1,2,4,8]
9 [1,3,9]
10 [1,2,5,10]

n φ(n)
11 [1,11]
12 [1,2,3,4,6,12]
13 [1,13]
14 [1,2,7,14]
15 [1,3,5,15]
16 [1,2,4,8,16]
17 [1,17]
18 [1,2,3,6,9,18]
19 [1,19]
20 [1,2,4,5,10,20]

n φ(n)
21 [1,3,7,21]
22 [1,2,11,22]
23 [1,23]
24 [1,2,3,4,6,8,12,24]
25 [1,5,25]
26 [1,2,13,26]
27 [1,3,9,27]
28 [1,2,4,7,14,28]
29 [1,29]
30 [1,2,3,5,6,10,15,30]

Notice that d(n) consists of all the divisors of n.
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Plotting Curves and Surfaces

[The universe] cannot be understood until we have learned the language and can interpret the characters in which it is written. It is written in the
language of mathematics, and its characters are triangles, circles and other geometrical ögures, without which it is humanly impossible to

understand a single word of it... Galileo Galilei (1564–1642)

T he plotting capabilities of symbolic algebra systems are among Getting Started with 2D Plots

Interactive Tools for 2D Plots

Graph User Settings

2D Plots of Functions and
Expressions

Creating Animated 2D Plots

Creating 3D Plots

Creating Animated 3D Plots

their most powerful features. With the system you are using,
you can carry out operations interactively. You can plot func-

tions and expressions, examine the results, revise the plot and exam-
ine the results of the revision, add multiple functions to the plot, and
carry out a variety of other plotting procedures. ăis adds an exper-
imental dimension to problem solving that was not easily accessible
in the past. In the preceding chapter, several plots were provided to
illustrate properties of functions. You will đnd yourself creating plots
in many situations to help answer questions about the behavior of dif-
ferent functions or families of functions.

In this chapter, you will đnd techniques for creating plots, show-
ing how to plot lines and curves in the Euclidean plane, and lines,
curves, and surfaces in three-dimensional Euclidean space. ăese tech-
niques use the basic routines Rectangular, Polar, Implicit, and Para-
metric fromthePlot 2Dsubmenu, andRectangular,Cylindrical, Spher-
ical, Implicit, and Tube from the Plot 3D submenu. ăe submenus of New in Version 6

Reorient 3D Plots with click and drag
Interactive plot tools in document window
Smoother 2D Plots

Plot 2D, Plot 3D, and Calculus also contain a variety of specialized
plotting routines for advanced topics in calculus, vector calculus, and
differential equations. ăose plotting options are introduced and dis-
cussed elsewhere, along with the related mathematics.
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Getting Started With 2D Plots
You canplot an expression or function in severalways, as described

in the following sections. Most of these are variations on the following
basic procedure.
Toplot an expression involving one variable

1. Place the insert point in the expression.

2. Choose Compute> Plot 2D> Rectangular. Note
Shown here are both the expression x3 and its
plot on the default interval−6≤ x≤ 6.Compute> Plot 2D> Rectangular

x3

­6 ­4 ­2 2 4 6

­200

­100

100

200

x

y

A frame containing a plot of the expression appears aĕer the ex-
pression, either displayed or in line (that is, with the lower edge rest-
ing on the text baseline) and the insert point appears at the right of
the plot. In the plot layout section you will đnd information on repo-
sitioning and resizing the frame. Following that is information on re-
vising plots.

ăe đrst attempt at a plot uses the default parameters. ăere are
many settings you can adjust to obtain the view you prefer.
Toplot the function y = xsinxon the default interval−6≤ x≤ 6

1. Leave the insert point in the expression xsinx.

2. Choose Compute> Plot 2D> Rectangular.

Toadd the expression x2 to a plot
• Drag and drop the expression x2 onto the plot frame.
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Compute> Plot 2D> Rectangular
xsinx
x2

­6 ­4 ­2 2 4 6

10

20

30

x

y

Rectangular Coordinates
When you choose Compute > Plot 2D > Rectangular, the view

that appears is determined by inequalities of the form a≤ x ≤ b and
c≤ y≤ d. ăe standard default for the view is the region bounded by
−6≤ x≤ 6 and c≤ y≤ d, where c andd are chosenby theunderlying
computational system and depend on the shape of the function plot.
Tocreate a 2Dplotwith rectangular coordinates

1. Place the insert point in a mathematical expression with one
variable. Note

Shown here are both the expression x2 and its
plot on the default interval−6≤ x≤ 6.2. Choose Compute> Plot 2D>Rectangular.

Compute> Plot 2D> Rectangular
x2

­6 ­4 ­2 0 2 4 6

10

20

30

x

y

Polar Coordinates
In polar coordinates, you specify a point P by giving the angle θ

that the ray from the origin to the point P makes with the polar axis
and the distance r from the origin. ăe equations that relate rectan-
gular coordinates to polar coordinates are given by

x = r cosθ and y = r sinθ
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or equivalently,

x2 + y2 = r2 and tanθ =
y
x

When you choose Compute> Plot 2D> Polar, the view that ap-
pears is determined by the inequality−π ≤ θ ≤ π on the angle. ăe
view intervals are chosen by the underlying computational system and
depend on the shape of the function plot.

Tomake a 2Dplot in polar coordinates
1. Place the insert point in a mathematical expression with one

variable.

2. Choose Compute> Plot 2D>Polar.

To obtain the view shown in the following plots, check Equal Scal-
ing on Both Axes (see page 143).

Compute> Plot 2D> Polar
sin2θ 1− cosθ 1− sinθ +2sin3θ

­0.6­0.4­0.2 0.2 0.4 0.6

­0.6
­0.4
­0.2
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y

­2 ­1
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­0.5
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1.0

x

y

­2 ­1 1 2

­4

­3

­2

­1

1

x

y

Implicit Plots Note
Plotting with Implicit assumes rectangular
coordinates.

When you choose Compute> Plot 2D>Implicit, the view is de-
termined by inequalities of the form a ≤ x ≤ b and c ≤ y ≤ d. ăe
default values for the Plot Intervals are−6≤ x≤ 6 and−6≤ y≤ 6,
and the default View Intervals are determined by the underlying com-
puter algebra system.

Tocreate an implicit 2Dplotwith rectangular coordinates
1. Place the insert point in amathematical equationwith two vari-

ables.

2. Choose Compute> Plot 2D> Implicit.

132



i
i

“Compute60” — 2011/12/20 — 14:27 — page 133 — #143 i
i

i
i

i
i

Getting Started With 2D Plots

ăe following are default views.

Compute> Plot 2D> Implicit

x2 + y2 = 49 x2 + y2 = 25

­6 ­4 ­2 2 4 6

­5

5

x

y

­6 ­4 ­2 2 4 6

­5

5

x

y

Tip
For a more accurate representation of the
circle, go to the Axes page and check Equal
Scaling Along Each Axis (see page 143).

You canmake an implicit plot of the equation x = f (y) to plot the
inverse function or inverse relation of a function y = f (x).
Toplot the inverse functionor relationof a functiony = f (x)as an implicit
plot

• Reverse the variable names in the equation andmake an implicit
plot.

For example, to plot the cube root function y = x1/3, observe that
it is the inverse function to y= x3 and create an implicit plot of x= y3.
Revise the plot and set Plot Intervals to−5< x< 5 and−1.75< y<
1.75. ăedefault assigns y awider domain, therefore computingmany
points outside the view and producing a rather rough looking curve.

Compute> Plot 2D> Implicit
y3 = x

­5 ­4 ­3 ­2 ­1 1 2 3 4 5

­1.5
­1.0
­0.5

0.5
1.0
1.5

x

y

For the inverse relation of the sine function y = sinx, do an im-
plicit plot of x = siny. Changing the view appropriately will give the
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plot of the inverse sine function. For a smooth curve, revise the plot
and set the Plot Intervals to match the view that appears in the plot.

Tip
See page 135 for plotting arcsinx using a
parametric plot.

Compute> Plot 2D> Implicit
siny = x

­6 ­4 ­2 2 4 6

­6

­4

­2
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x

y

Default view

­1 1

­1.5

­1.0

­0.5

0.5

1.0

1.5

x

y

−1≤ x≤ 1
−π/2≤ y≤ π/2

Parametric Plots Note
A 2D parametric curve is deöned by a pair of
equations x = f (t), y = g(t). The curve is
the set of points ( f (t),g(t)), where t
ranges over an interval.

When you choose Compute> Plot 2D> Parametric, the default
values for the Plot Interval are −6 ≤ t ≤ 6 and the View Intervals
a≤ x≤ b and c≤ y≤ d are determined by the underlying computer
algebra system.

Toplot a 2Dparametric curvewith rectangular coordinates
1. Make the two deđning expressions the components of a vector.

You can use any of the standard notations for a vector, including
the forms [sin2t,cos3t], (sin2t,cos3t),

[
sin2t cos3t

]
,(

sin2t cos3t
)
,
[

sin2t
cos3t

]
, or
(

sin2t
cos3t

)
. (ăe last four

vectors are 1×2 and 2×1 matrices, respectively.)

2. Place the insert point in the vector.

3. Choose Compute> Plot2D> Parametric.

ăe following are default views.
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Compute> Plot 2D> Parametric
(6cosx,6sinx)

(
3cosx 3sinx

)

­6 ­4 ­2 2 4 6

­5

5

x

y

­3 ­2 ­1 1 2 3

­2

2

x

y

ăe following plot shows the parametric curve deđned by x =
sin2t , y = cos3t as the parametric plot of the vector [sin2t,cos3t]
with 0≤ t ≤ 2π and Equal Scaling Along Each Axis.

Compute> Plot 2D> Parametric
(sin2t,cos3t)

­1.0 ­0.5 0.5 1.0

­1.0

­0.5

0.5

1.0

x

y

Toplot the inverse functionor inverse relationof a function y = f (x)
• Make a parametric plot of the pair ( f (x),x).

For example, to plot the cube root function y = x1/3, observe that
it is the inverse function to y = x3 and create a parametric plot.

Compute> Plot 2D> Parametric(
x3,x

)

­8 ­6 ­4 ­2 2 4 6 8
­2

2

x

y

y = x1/3

ăeinverse relation of sinx follows. Adjust the view to get the plot
of sin−1 x.
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Compute> Plot 2D> Parametric
(sinx,x)

­1.0 ­0.5 0.5 1.0
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y

(sinx,x)

­1 1

­1.5

­1.0

­0.5

0.5

1.0

1.5

x

y

arcsinx

You can generate a regular pentagon with an enclosed đve-point
star by creating two parametric plots of (sin2πx,cos2πx) and chang-
ing the Plot Intervals and number of Points Sampled.

Compute> Plot 2D> Parametric
(sin2πx,cos2πx)
Points Sampled: 6

Plot Interval
0 < x < 1

Plot Interval
0 < x < 2 Combined

Inequality Plots
You can plot the set of points (x,y) such that g(x,y)< h(x,y).

Toplot an inequality
1. Enter an expression of the form g(x,y)< h(x,y).

2. With the insert point in the expression chooseCompute>Plot
2D> Inequality.
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Compute> Plot 2D> Inequality
y < x2

Blue

Red

­6 ­4 ­2 2 4 6

­6

­4

­2

2

4

6

x

y

Note
By default, the region inside the rectangular
region−6≤ x≤ 6,−6≤ y≤ 6 that
satisöes the inequality g(x,y)< h(x,y)
is shown in blue, and the region that does not
satisfy the inequality is in red.

Youcan change theđll andbackgroundcolors on the ItemsPlotted
page of the Properties of Function Graph dialog box (see page 140).

Compute> Plot 2D> Inequality
x+ y2 < 5

­4 ­2 2 4

­4

­2

2

4

x

y

Fill Color 2:
White

­4 ­2 2 4

­4

­2

2

4

x

y

Fill Color 2:
Light Gray

You can also plot the set of points (x,y) that satisfy multiple in-
equalities by placing the inequalities in a row matrix and choosing
Compute> Plot 2D> Inequality.
Toplotmultiple inequalities

1. Enter an expressionof the form
[

g1 (x,y)< h1 (x,y) g2 (x,y)< h2 (x,y) g3 (x,y)< h3 (x,y)
]
.

2. With the insert point in the expression, choose Compute >
Plot 2D> Inequality.
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Compute> Plot 2D> Inequality[
x+ y2 < 5 −x+ y2 < 5

] [
x+2y < 5 −x+ y < 3 x−3y < 4

]

­4 ­2 2 4
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­4
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2
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y

Other types of 2D plots
ăere are several other options under Compute > Plot 2D. See

Chapter 9 “VectorCalculus” forConformal (page379),Gradient (page
367), andVector Field (page 363). SeeChapter 10 “Differential Equa-
tions” for ODE (page 401). See Chapter 7 “Calculus” for Approxi-
mate Integral (page 238).

Interactive Tools for 2D Plots
Whenaplot frame is selected, several plotting tools becomevisible

just below other toolbars at the top of the screen.

ăe tool on the leĕ is Reset Viewpoint. Next is the SelectionTool,
then the Zooming Tool, the Moving Tool, and the õuery Tool.

Todisplay plotting tools
1. Click to the right of the plot.

2. Move the mouse to the insert point. (ăe arrow changes to a
hand.)

3. Click when you see a hand. (ăis creates a resizable frame and
brings the plotting tools into view.)

Or

• If a frame is visible, click the frame.
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Reset Viewpoint
Click the Reset Viewpoint tool to reset the viewpoint to a default

position.

Zooming In and Out
ăe Zooming Tool shows a small arrow pointing up and a larger

arrow pointing down.

Tozoom inor out
1. Click the Zooming Tool.

2. Move the mouse pointer over the view.

3. Click and drag towards the top of the screen to zoom out, or

Click and drag towards the bottom of the screen to zoom in.

Translating the View
Changing the Plot Intervals reveals different portions of a plot. To

see different portions of a plot in an interactive way, you can translate
the view with the Moving Tool. ăe Moving Tool shows four arrows,
similar to the north, south, east, west arrows commonly shown on a
map.

To translate the view
1. Select the Moving Tool.

2. Move the mouse pointer over the view.

3. Click and drag in the direction you want to translate the plot.

Plot Coordinates
ăe default tool for 2D plots is the õuery Tool. ăis is used to

view the coordinates of points on a plot.

Toviewplot coordinates
1. Select the õuery Tool.

2. Move the mouse pointer to a point of interest on the plot.

3. Press and hold the leĕ mouse button to view of coordinates.
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Graph User Settings
From the Graph User Settings dialog box, you can change proper-

ties of Items Plotted, Axes, Layout, Labelling, and View.

Toopen theGraphUser Settings dialog box
• Double click the gray plot frame.

If there is no visible plot frame,

1. Click to the right of the plot.

2. Move the mouse to the insert point. (ăe arrow changes to a
hand.)

3. Click when you see a hand. (ăis will create a resizable frame.)

4. Double click the blue frame.

ăere is a keyboard shortcut tomake theGraphUser Settings dia-
log box openwhen a plot is created, so that you can customize settings
before generating the plot.

Toopen theGraphUser Settings dialog boxwhile creating a plot
1. Place the insert point to the right of a mathematics expression

or function name.

2. Press Ctrl while choosing the plot command.

ăis brings up theGraphUser Settings dialog boxwith the tabbed
pages Items Plotted, Axes, Layout, Labelling, and View.

Items Plotted
From the Items Plotted page of the Graph User Settings dialog

box you can edit, add, and delete expressions to be plotted. ăis page
shows the Dimensions (2 or 3), the Plot Type (Rectangular, Polar,
Implicit, Inequality, Parametric, Conformal, Gradient, Vector Field,
ODE, or Approximate Integral), and whether or not the plot is ani-
mated.
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Editing a plot
Toedit a plot

1. Open theGraphUser Settings dialogbox, choose the ItemsPlot-
ted page, and select an Item Number.

2. Select theLineStyle (Solid,Dash, orDots), PointMarker (Squares,
Circles,Crosses,Diamonds, FilledSquares, FilledCircles, Filled
Diamonds, Stars, orXCrosses), Lineăickness (ăin,Medium,
or ăick), and Color.

3. If the graph has a discontinuity and you want asymptotes to be
plotted, uncheck Adjust Plot for Discontinuities.

Line Style
ăe line style can be solid, dash, or dots.

Compute> Plot 2D> Rectangular
xsinx

­5 5

­4
­2

2

Solid

­5 5

­4

­2

2

Dash

­5 5

­4

­2

2

Dots

Point Marker
Points canbeplottedbyusingSquares,Circles,Crosses,Diamonds,

Filled Squares, Filled Circles, Filled Diamonds, Stars, or X Crosses.
Here are examples of a few of these point markers:

Toplot points
1. Open the Graph User Settings dialog box.

2. On the Items Plotted page under Plot Style, check Point.

3. Select the Point Marker.

141



i
i

“Compute60” — 2011/12/20 — 14:27 — page 142 — #152 i
i

i
i

i
i

Chapter 6 | Plotting Curves and Surfaces

Compute> Plot 2D> Rectangular
xsinx
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Diamond

Line Thickness
ăe line thickness can be ăin, Medium, or ăick.

Compute> Plot 2D> Rectangular
xsinx

­5 5
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2

ăin

­5 5
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­2

2

Medium

­5 5

­4

­2

2

ăick

Tochange the line thickness

1. Open the Graph User Settings dialog box and choose the Items
Plotted page.

2. Select the line thickness (ăin, Medium, or ăick) and choose
OK.

Continuity
ăeoptionsNotSpeciđed,Adjust forDiscontinuities, ShowAsymp-

totes, andDon’tAdjust are available for discontinuous functions. Here
are the two most common choices:
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Compute> Plot 2D> Rectangular
x

1− x

­6 ­4 ­2 2 4 6
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Adjust Plot for
Discontinuities

­6 ­4 ­2 2 4 6
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­2

­1
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y

Don’t Adjust

Tochange themethod for plotting a discontinuous function
1. Open theGraphUser Settings dialogbox, select the item, choose

the Items Plotted page.

2. Select one of Not Speciđed, Adjust Plot for Discontinuities,
Show Asymptotes, and Don’t Adjust.

New Item
Toadd anew item to an existing graph

• Select an expression and drag it to the plot.
Or

1. Open theGraphUser Settings dialogbox, choose the ItemsPlot-
ted page, and click New.

2. Type or paste a new expression in the window and choose OK.

Todelete an item froman existing graph
1. Open the Graph User Settings dialog box and choose the Items

Plotted page.

2. Select an item number, click Delete, and choose OK.

Axes
From the Axes page of the Graph User Settings dialog box you

can change the Axes Scaling (Linear, Lin Log, Log Lin, or Log Log),
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choose Equal Scaling Along Each Axis, change the labels for the co-
ordinate axes, change the Axis Tick Marks (None, Low, Medium, or
High), turn the axes tips on or off, turn the grid lines on or off, and
change theAxesType (NotSpeciđed,Automatic,Normal, Boxed, Frame,
or None).

Axes Scaling

Toedit the axes scaling

1. Open Graph User Settings and choose the Axes page.

2. Select Linear (horizontal and vertical axes both linear scaling),
LinLog (horizontal axis linear andvertical axis logarithmic scal-
ing), Log Lin (horizontal axis logarithmic and vertical axis lin-
ear scaling), or Log Log (horizontal and vertical axes both log-
arithmic scaling).

Compute> Plot 2D> Rectangular
x2

0.0 0.5 1.0
0.0
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1.0

x

y

Linear

0.0 0.5 1.0
1e­6
1e­5
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Lin Log

0.00010.0010.01 0.1 1
1e­8
1e­7
1e­6
1e­5

0.0001
0.001

0.01
0.1

1
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y

Log Log

A Lin Log plot is a two-dimensional plot with the vertical axis
given in a log scale. Exponential functions f (x) = cbx plot as straight
lines on a Log coordinate system.
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Compute> Plot 2D> Rectangular
5(2x)

­6 ­4 ­2 0 2 4 6
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Linear plot of 5(2x)

­6 ­4 ­2 0 2 4 6

1

10

100

x

y

Lin Log plot of 5(2x)

A Log Log plot is a two-dimensional plot with both the vertical
and horizontal axes given in a logarithmic scale.

Note
Power functions f (x) = axn plot as
straight lines on a Log-Log coordinate system.

Compute> Plot 2D> Rectangular
x2/3

Plot Interval 0.1 < x < 1.1

0.2 0.4 0.6 0.8 1.0
0.2

0.4

0.6

0.8

1.0

Linear plot of x2/3 Log Log plot of x2/3

Youcan alsomake the scales equal along thehorizontal andvertical
axes.

Tomake the scaling equal along the horizontal and vertical axes
1. Open the Graph User Settings dialog box and choose the Axes

page.

2. Turn on Equal Scaling Along Each Axis.
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Axes Labels
ăe default labels for the axes are x and y for two-dimensional

plots, or x, y, and z for three-dimensional plots. You can edit the de-
fault labels.
Toedit the labels for the axes

1. Open the Graph User Settings dialog box and choose the Axes
page.

2. Type labels in the axis label boxes.

Axes Appearance
You can change the appearance of the tick marks and turn on or

off the axes tips and grid lines.
Toedit the number of tickmarks shownon the axes

1. Open the Graph User Settings dialog box and choose the Axes
page.

2. Edit the number of Axis Tick Marks by selecting None, Low,
Normal, or High.

To turn axes tips onor off
1. Open the Graph User Settings dialog box and choose the Axes

page.

2. Check or uncheck Axes tips on.

To turn grid lines onor off
1. Open the Graph User Settings dialog box and choose the Axes

page. Tip
The number of grid lines is determined by the
setting for tick marks (Low, Normal, or High).2. Check or uncheck Grid lines on.

Axes Type
You can change the axis type to beNot Speciđed, Automatic, Nor-

mal, Boxed, Frame, or None.
Toedit the axis type

1. Open the Graph User Settings dialog box and choose the Axes
page.

2. Select an Axes Type.
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Compute> Plot 2D> Rectangular
xsinx
Plot Interval 0.1 < x < 1.1
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Boxed

­4 ­2 0 2 4

­4

­2

0

2

x

y

Framed None

Layout
Layoutproperties include the size of a graphic, its placementwithin

your document, and the print and screen display attributes. ăe de-
faults for the layout can be changed on the Layout page of the Graph
User Settings dialog box.

Resizing the Frame
All plots have an attribute known as đt to frame. When you resize

the frame, the plot is resized with it. You can resize the frame either
with the mouse or with the Graph User Settings dialog box.
To resize the framewith themouse

1. Click to the right of the plot.

2. Move the mouse to the insert point. (ăe arrow changes to a
hand.)

3. Click when you see a hand. (ăis will create a resizable frame.)

4. Resize the frame by dragging one of the eight handles.

Or

1. If a gray frame is visible, click the frame.

2. Resize the frame by dragging one of the eight handles.

When the plot frame is selected, eight handles are visible and you
can resize the frame by dragging one of the handles. ăe corner han-
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dles leave the opposite vertex đxed while moving the two sides adja-
cent to the handle, creating a frame that has edges proportional to the

original frame ­5 5­4
. ăe edge handles move only the cor-

responding edge in or out. Either type of change stretches or shrinks a
plot in the view, along with the frame. Resizing the frame retains the
same domain and view intervals. For example, use one of the side han-

dles to create a tall and narrow frame
­6 6

­4

­2

2

or use one of the han-

dles on the toporbottomto create a short and fat frame ­6 ­4 ­2 2 4 6­5 .
ăe examples in the previous paragraph illustrate the use of inline

plots, one of the two placement options described in the next section.
Use the Graph User Settings dialog box to specify frame dimen-

sions precisely.
To resize the framewith theGraphUser Settings dialog box

1. Select the plot and open the Graph User Settings dialog box.

2. Click the Layout tab.

3. In the Size boxes for Width and Height, set the sizing options
you want.

4. Select desired units (inches, centimeters, picas, or points).

5. Choose OK.

Screen Display Attributes
ăemodel screen attributes can be turned on or off. When turned

on, placement anddisplay attributeswill be automatically determined.
When turned off, these attributes can be set manually for each plot.

Screen Display Layout
Tochange the screendisplay attributes of the frame andplot

1. Select the plot and open the Graph User Settings dialog box.
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2. Click the Layout tab.

3. Select oneof theScreenDisplayLayout attributes (Plot inFrame,
Plot Only, Frame Only, or Iconiđed).

4. Choose OK.

Compute> Plot 2D> Rectangular
xsinx

­5 5

­4

­2

2

Plot in Frame

­5 5

­4

­2

2

Plot Only Frame Only

Placement
With ScientiĖc Notebook, there are two choices for frame place-

ment—In Line andDisplayed. With ScientiĖcWorkPlace you can also
choose Floating.

Open the Graph User Settings dialog box to see how a frame is
placed in your document.
Toverify and/or change the placement

1. Select the frame and open the Graph User Settings dialog box.

2. Choose the Layout tab and check your choice for Placement.

In-Line Placement
An inline frame behaves like a word in the text, in the sense that

the frame is pushed along in the line when you enter additional items
to the leĕ of it.
Tochange a plot or graphic to in line

1. Select the frame and open the Graph User Settings dialog box.

2. Choose the Layout tab and change the Placement to In Line.

When theplacement is InLine, you canmove it upordownwithin
the line.
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Tomove an inline frameupor downwith themouse
1. Select the frame.

2. Drag the frame up or down.
Displayed frame placement versus
mathematics Display
Choose Displayed to center a plot. To minimize
vertical white space above and/or below the
plot, use the backspace or delete key to
remove any new paragraph symbols ¶ that
occur immediately before/after the plot. (To
see these symbols, choose View and select
Invisibles.)

The use of the mathematics display, which
treats the frame like mathematics, can lead to
unpredictable results when you preview or
print your document. If the frame appears red
on your screen, you can change the frame to
text mode by selecting it with the mouse and
clicking the Math/Text button.

You can drag the plot frame such that its lower edge is resting on

the text baseline like , is centered on the line like

, hangs with the upper edge at the text baseline

like , or rests anywhere in between.

Displayed Frames
When the placement isDisplayed, the frame appears on the screen

centered on a separate line like

Tochange a plot or graphic to displayed
1. Select the frame and open the Graph User Settings dialog box.

2. Choose the Layout tab and change the Placement toDisplayed.

Floating Frames
Floating placement is a typesetting option, available in ScientiĖc

WorkPlace or ScientiĖc Word only. Floating frames containing plots
aren’t anchored to a precise location in your document. Instead, they
are positioned when you typeset the document, according to the op-
tions you choose for placement: Here, On a Page of Floats, Top of
Page, or Bottomof Page. Floating frames can carry numbers, captions,
and keys. ăe number is created automatically by LATEX unless you
suppress it. If you don’t typeset, in the File > Preview screen or on
paper, Ĕoating frames behave like displayed frames.
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Tochange a plot or graphic toĔoating
1. Open the Graph User Settings dialog box. See Help> Search> øoating objects for

further information on øoating frames.
2. Choose the Layout tab and change the Placement to Floating.

2D Plots of Functions and Expressions
In the equation f (x) = xsinx, each of the two sides— f (x) and

xsinx—is an expression while f is a function. ăe function f is a rule
that assigns to each number the product of that number and the sine
of that number. ăus the function f deđned by the equation f (x) =
xsinx is the same function as the function g deđned by the equation
g(t) = t sin t . ăe expression xsinx (or f (x) org(x)) is different from
the expression t sin t (or f (t) or g(t)), since xsinx is tied to the vari-
able x, and t sin t is tied to the variable t .

Expressions
Toplot an expression involving a single variable

• Type the expression and choose Compute > Plot 2D > Rect-
angular.

Compute> Plot 2D> Rectangular

xsin
5
x

­5 ­4 ­3 ­2 ­1 1 2 3 4 5

2

4

x

y

y = xsin
5
x

Add the caption y = xsin 5
x by typing it into the Graph User Set-

tings > Labelling dialog box in the Caption entry đeld. (See page
140.)

151



i
i

“Compute60” — 2011/12/20 — 14:27 — page 152 — #162 i
i

i
i

i
i

Chapter 6 | Plotting Curves and Surfaces

Toadd an expression to a plot

• Select the expression with the mouse and drag it onto the plot.

Or

1. Open the Graph User Settings dialog box and click New. Drag x and−x to a plot of xsin 1
x to get

­1.0 ­0.5 0.5 1.0

­1.0

­0.5

0.5

1.0

x

y

y = xsin 1
x , y = x, y =−x

2. Type or paste the expression in the Plot Expression box.

Functions of Degrees
You can plot trigonometric functions written as functions of de-

grees rather than radians.

Toplot trigonometric functions of degrees

1. Type the expression(s) in your document window, using either
the red degree symbol in a superscript or the green degree sym-
bol from the Insert>Math Objects>Unit Names dialog box.

2. With the insert point in an expression, chooseCompute>Plot
2D> Rectangular.

3. With the plot selected, open the Graph User Settings dialog
box.

4. Click the Items Plotted tab and choose Variables and Intervals.

5. Change Plot Intervals to −180 < x < 180 (or other limits as
appropriate).

6. Choose OK.

Select and drag additional expressions onto the plot, as desired.
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Compute> Plot 2D> Rectangular
sinx◦

cos2x◦ (Select and drag to the frame.)

­150 ­100 ­50 50 100 150

­1.0

­0.5

0.5

1.0

x

y

y = sinx◦, y = cos2x◦

Note
To get this view, change the Plot Interval to
−180 < x < 180.

Compute> Plot 2D> Rectangular
sin2x◦+ cos3x◦

(Change Plot Intervals to−360 < x < 360)

­300 ­200 ­100 100 200 300

­2

­1

1

2

x

y

Deöned Functions
You can plot a deđned function. Recall

You can deöne a function such as
f (x) = xsinx by placing the insert point
in the expression and choosing Compute>
Deönitions> New Deönition.

Toplot a deđned function f of one variable
1. Select the function name f or select the expression f (x).

2. Choose Compute> Plot 2D< Rectangular.

Compute> Deönitions> New Deönition
g(x) = tansin

(
x2
)
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Compute> Plot 2D> Rectangular
g

­6 ­4 ­2 2 4 6

­1.5

­1.0

­0.5

0.5

1.0

1.5

x

y

g

Continuous and Discontinuous Plots
ăe appearance of the plot of a discontinuous function depends

on the setting for Adjust for Discontinuities.
Tochange the appearance of a discontinuous function

• From the Plot User Settings dialog box, select Not Speciđed,
Adjust for Discontinuities, Show Asymptotes, or Don’t adjust.

Compute> Plot 2D> Rectangular
x+1
x−1

­6 ­4 ­2 2 4 6

­6

­4

­2

2

4

6

x

y

Adjust for Discontinuities

­6 ­4 ­2 2 4 6

­6

­4

­2

2

4

6

x

y

Show Asymptotes
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ăis setting applies to individual items so it is possible to plot to-
gether two functions that require opposite settings.

ăere may be expressions that do not plot with the setting Adjust
for discontinuities, but that will plot with the setting Show Asymp-
totes. If you know before creating a plot that you wish to change this
setting (Not speciđed is the default), hold down the Ctrl key while
applying the plot command. ăe Graph User Settings dialog box will
open for you to edit before the system generates the plot.

For more examples of continuous and discontinuous piecewise-
deđned functions, see the following sections.

Plotting Piecewise-Deöned Functions
A piecewise-deđned function must be entered in a two- or three-

column matrix enclosed in expanding brackets—a leĕ brace and right
null bracket (see Piecewise-Deđned Functions, page 108 for details).

Toplot a piecewise-deđned function
1. Place the insert point in a matrix of a piecewise-deđned func-

tion.

2. Choose Compute> Plot 2D> Rectangular

Compute> Plot 2D> Rectangular x2−1 if x <−1
10−10x2 if −1≤ x≤ 1

x2−1 if 1 < x

­6 ­4 ­2 0 2 4 6

10

20

30

x

y

You can also plot a continuous graph from a discontinuous expres-
sion g(x) (or directly from the deđning matrix) by checking Show
Asymptotes, as described on page 154.
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Compute> Plot 2D> Rectangular x2−1 if x <−1
20− x2 if −1≤ x≤ 1
x2−1 if 1 < x

­6 ­4 ­2 0 2 4 6

10

20

30

x

y

Adjust for Discontinuities

­6 ­4 ­2 0 2 4 6

10

20

30

x

y

Show Asymptotes

Compute> Plot 2D> Rectangular
t if t < 0
0 if 0≤ t < 1
1 if 1≤ t < 2
2 if 2≤ t < 3

6− t if 3≤ t

­6 ­4 ­2 2 4 6

­6

­4

­2

2

x

y

Adjust for Discontinuities

­6 ­4 ­2 2 4 6

­6

­4

­2

2

x

y

Vertical Asymptotes

Special Functions
Greatest integer function and øoor function

ăe function ⌊x⌋ is the greatest integer function, or ęoor function.

Touse the greatest integer function (Ĕoor function)
1. Choose Insert>Math Objects> Brackets.
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2. Select the leĕ Ĕoor bracket ⌊ and choose OK.

Compute> Plot 2D> Rectangular
⌊x⌋

­6 ­4 ­2 2 4 6

­5

5

x

y

Note
You can get a continuous plot of this function
by checking Vertical Asymptotes.

Absolute value function
Touse the absolute value function

• Choose Insert>Math Objects> Brackets and select the verti-
cal brackets. Tip

You can also use the keyboard shortcut Ctrl+\
to insert expanding absolute values.ăe following shows the graph of f (x) = |sinx|.

Compute> Plot 2D> Rectangular
|sinx|

­6 ­5 ­4 ­3 ­2 ­1 0 1 2 3 4 5 6

1

x

y

Gamma function
ăe Gamma function Γ(x) extends the factorial function in the

sense that for each nonnegative integer n, Γ(n+1) = n!.
Touse theGamma function

1. Click the Uppercase Greek button on the Symbols toolbar.

2. Select Γ from the Greek panel that opens. Tip
You can also use the keyboard shortcut
Ctrl+g,G for the Greek letterΓ.ăe plot of the Gamma function displays the vertical asymptotes

along with the graph if Vertical Asymptotes is checked, and displays
only the graph when Adjust for Discontinuities is checked as in the
following example.
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Compute> Plot 2D> Rectangular
Γ(x)

­6 ­5 ­4 ­3 ­2 ­1 1 2 3 4 5 6

­10

10

x

y

Heaviside function

ăe Heaviside function Heaviside(x) =


0 if x < 0
1
2 if x = 0
1 if x > 0

is a

built-in function.
Compute> Plot 2D> Rectangular
Heaviside(x)

­6 ­4 ­2 0 2 4 6

1

x

y

Touse the Heaviside function

1. Choose Insert>Math Objects>Math Name.

2. Type Heaviside in the Name box of the dialog box that opens
and choose OK.

ăe Heaviside function provides an alternative method for creat-
ing piecewise-deđned functions. Note that

Heaviside(x−2)sin(x)+Heaviside(−x)cosx=

 sinx if x≥ 2
0 if 0≤ x≤ 2

cosx if x≤ 0
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Compute> Plot 2D> Rectangular
Heaviside(x−2)sin(x)+Heaviside(−x)cosx

­6 ­5 ­4 ­3 ­2 ­1 1 2 3 4 5 6

­1

1

x

y

Polygons and Point Plots
Youcanplot thepoints{(x1,y1) ,(x2,y2) ,(x3,y3) , . . . ,(xn,yn)},

or a polygon whose vertices lie at these points, by typing the vector

(x1,y1,x2,y2,x3,y3, . . . ,xn,yn)orby entering thematrix


x1 y1
x2 y2
x3 y3
...

...
xn yn

.

Toplot a polygon connecting points
1. Create a list of n pairs of points or an n× 2 matrix containing

the points.

2. Place the insert point in the list or matrix and choose Compute
> Plot 2D> Rectangular. Note

The beginning point (1,1) is also the last
point.Compute> Plot 2D> Rectangular

(1,1,2,1,2,2,1,2,1,1)
View Intervals: 0 < x < 3, 0 < y < 3

0 1 2 3
0

1

2

3

x

y
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Toplot points
1. Create a list of n pairs of points or an n× 2 matrix containing

the points.

2. Place the insert point in the list or matrix and choose Compute
> Plot 2D> Rectangular.

3. Double click the frame to open the Graph User Settings dialog
box.

4. On the Items Plotted page, change Plot Style to Point, Point
Marker to Circle, and choose OK.

Compute> Plot 2D> Rectangular
1 1
2 1
2 2
1 2

, View Intervals: 0 < x < 3, 0 < y < 3

0 1 2 3
0

1

2

3

x

y

Togenerate a regular pentagonwith an enclosedđve-point star
1. Place the insert point in the vector(

0,1,sin
2π
5
,cos

2π
5
,sin

4π
5
,cos

4π
5
,sin

6π
5
,cos

6π
5
,sin

8π
5
,cos

8π
5
,0,1

)
and choose Compute> Plot 2D> Rectangular.

2. Select the vector(
0,1,sin

4π
5
,cos

4π
5
,sin

8π
5
,cos

8π
5
,sin

2π
5
,cos

2π
5
,sin

6π
5
,cos

6π
5
,0,1

)
with the mouse and drag it to the frame.
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3. Graph User Settings > Axes, under Axes Scaling select Equal
Scaling Along Each Axis and under Axes Type select None.

4. Choose OK.

Compute> Plot 2D> Rectangular(
0,1,sin 2π

5 ,cos 2π
5 ,sin 4π

5 ,cos 4π
5 ,sin 6π

5 ,cos 6π
5 ,sin 8π

5 ,cos 8π
5 ,0,1

)(
0,1,sin 4π

5 ,cos 4π
5 ,sin 8π

5 ,cos 8π
5 ,sin 2π

5 ,cos 2π
5 ,sin 6π

5 ,cos 6π
5 ,0,1

)

You may đnd it convenient to combine Line and Point styles, as
in the following plot that combines a data cloud with a line of best đt.
(See page 436 in Chapter 11 “Statistics” for information on curves of
best đt.) ăat techniquewas used toobtain the expression 2792

647 + 957
647 x

used in the next example.

Compute> Plot 2D> Rectangular[
1 3 4 6 7 7 10 11
8 7 9 12 15 16 19 21

]T

2792
647 + 957

647 x (Select and drag to the frame.)

Graph User Settings, Item 1
Plot Style: Points
Point Marker: Squares

0 2 4 6 8 10 12
5

10

15

20

x

y
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You can create line graphs and bar charts with polygonal plots, as
demonstrated in the following two examples. ăe đrst example is a
line graph depicting the data

1 2 3 4 5 6
0.11 0.24 0.28 0.21 0.1 0.031

Compute> Plot 2D> Rectangular
(1,0,1,0.11)
Enter, select, and drag to the frame each of the following.
(2,0,2,0.24), (3,0,3,0.28), (4,0,4,0.21), (5,0,5,0.1), (6,0,6,0.031)

0 1 2 3 4 5 6
0.0

0.1

0.2

x

y

Following is a bar chart, or histogram, depicting the data

1-2 2-3 3-4 4-5 5-6 6-7
0.11 0.24 0.28 0.21 0.1 0.031

Compute> Plot 2D> Rectangular
(1,0,1,0.11,2,0.11)
Enter, select, and drag to the frame each of the following.
(2,0,2,0.24,3,0.24) (3,0,3,0.28,4,0.28,4,0) (4,0.21,5,0.21,5,0)
(5,0.1,6,0.1,6,0) (6,0.031,7,0.031,7,0)

0 2 4 6
0.0

0.1

0.2
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Plotting a Grid
Tocreate a grid

• Create a 2D plot

• Open the Graph User Settings dialog box, Axes page, and turn
grid lines on.

Compute> Plot 2D> Rectangular
x
grid lines on

­5 ­4 ­3 ­2 ­1 1 2 3 4 5

­5

­4

­3

­2

­1

1

2

3

4

5

x

y

Grid lines
The number of grid lines is determined by the
Tick Marks setting (None, Low, Medium, or
High) on the Axes page.

Envelopes
An interesting phenomenon occurs when simple curves are dis-

played as the “envelope” of a more complicated function. Such things
happen in practice when low-frequency waves (say, frequencies in the
audible range for the human ear) ride carrier waves broadcast from a
radio station.

Tocreate a plotwith an envelope
1. Type an expression R(x) for the envelope.

2. With the insert point in the expression, choose Compute >
Plot 2D> Rectangular.

3. Select and drag the product R(x)c(x) of the envelope and the
carrier wave to the plot.
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ăe following example shows the curve y= 4sinx+3cos3x “rid-
ing” on top of the carrier y = sin30x. To get an accurate plot, increase
the point sampled—from the Items Plotted page of the Plot Proper-
ties dialog box, raise ItemNumber to 2, chooseVariables and Intervals,
and raise the number of Points Sampled to 150 or higher.

Compute> Plot 2D> Rectangular
4sinx+3cos3x
Select and drag to the frame (4sinx+3cos3x)sin30x

­6 ­5 ­4 ­3 ­2 ­1 1 2 3 4 5 6

­5

5

x

y

Parametric Polar Plots
You can make a parametric polar plot using an expression of the

form (r (t) ,θ (t)) where r (t) is a function for the radius and θ (t) is
a function for the angle. You can use any of the forms (r (t) ,θ (t)),

[r (t) ,θ (t)],
(

r (t) θ (t)
)
, or

[
r (t)
θ (t)

]
, where the last two ex-

pressions are 1×2 and 2×1 matrices, respectively.
Tomake a parametric polar plot

• Place the insert point in a pair of expressions in one variable and
choose Compute> Plot 2D> Polar.

ăe polar plot of θ = r2 is the 2D polar plot of the vector
(
r,r2
)
.

Compute> Plot 2D> Polar(
r,r2
)

­5 5

­5

5

x

y

−6 < r < 6

­5 5

­5

5

x

y

0 < r < 6
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Both the radius r and the angle θ may be deđned in terms of some
third variable t . You can make the polar plot of the parametric curve
deđned by the equations r = 1− sin t , θ = cos t as the polar plot of
the vector (1− sin t,cos t). Revise the đrst plot, choosing Polar and
setting the Plot Intervals to 0≤ t ≤ 2π .

Compute> Plot 2D> Polar
(1− sin t,cos t)

1 2

­1.0

­0.5

0.0

0.5

1.0

x

y

Creating Animated 2D Plots
For an animated 2D plot, you specify a second variable. One of

the two variables will be designated as the Animation Variable. ăe
standard variable names are x for the horizontal axis and t for the Ani-
mation Variable. ăe default intervals for x and t are−6 < x < 6 and
−6 < t < 6. To change these settings, see page 166.

When the frame of an animated plot is selected, several plotting
tools become visible just below other toolbars at the top of the screen.

ăe tool on the leĕ is Reset Viewpoint. Next is the SelectionTool,
then the Zooming Tool, the Moving Tool, and the õuery Tool. ăe
remaining tools are designed to control the animation. ăese include
jumps to the beginning or the end, begin animation, a slider formanu-
ally moving through the animation sequence, and loop controls (Run
once, Back and forth, Loop), and speed controls (8× slower to 8×
faster).

Todisplay the animation tools
• Click to the right of the animated plot, move the mouse to the

insert point, and click when you see a hand. (ăis creates a re-
sizable frame and brings the animation tools into view.)
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Tocreate a 2Danimation
• Type an expression in x and t , and choose Compute> Plot 2D

Animated> Rectangular.

Compute> Plot 2D Animated> Rectangular
xt
□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□

□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□
Toedit the animation

1. Click the plot.frame to bring up the animation toolbar.

2. Reset Viewpoint, Animation Style, or Animation Speed.

ăe following animatedplot shows the graphofy= sin2x smoothly
transform itself into the graph of y = cos3x.

Compute> Plot 2D Animated> Rectangular
(1− t)sin2x+ t cos3x
□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□

□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□
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Tomake a parameterized animatedplot in rectangular coordinates

1. Type an expression of the form (x(s, t) ,y(s, t)).

2. Choose Compute> Plot 2D Animated> Parametric, or

Choose Compute> Plot 2D Animated> Rectangular.

To animate the following Lissajous đgure, select the frame and
open the Graph User Settings dialog box. Choose the Items Plotted
page, Variables and Intervals, and set 0 ≤ x ≤ 1 and 0 ≤ t ≤ 1. On
the Axes page turn on Equal Scaling Along Each Axis.

ăe đrst formula draws the small circle at the leading edge of the
đgure. ăe second formula shows a static đgure in light gray. ăe third
formula shows the animated curve.

Compute> Plot 2D Animated> Parametric

(sin8πt +0.02cos2πx,cos10πt +0.02sin2πx)

(sin8πx,cos10πx)

(sin8πxt,cos10πxt)

□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□

­1 1

­1

1

x

y

­1 1

­1

1

x

y

­1 1

­1

1

x

y

□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□

A circle of radius 1 with an arm of length 2 rolls around a second
circle of radius 1, leaving behind a smoke trail. ăe resulting curve is
called a Limaçon.
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Compute> Plot 2D Animated> Rectangular

(0.5+ cosπxt + cos2πxt,sinπxt + sin2πxt), 0 < x < 1, 0 < t < 2

Select and drag to the frame: (1/2+1/2cos2πx,1/2sin2πx)

Select and drag to the frame: (0.5+ cosπt +0.5cos2πx,sinπt +0.5sin2πx)

Select and drag to the frame: (0.5+ cosπt + xcos2πt,sinπt + xsin2πt)

□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□

□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□

Animated Plots In Polar Coordinates
In polar coordinates, you specify a point P by giving the angle θ

that the ray from the origin to the point P makes with the polar axis
and the distance r from the origin.

For an animated plot in polar coordinates you also need an anima-
tion variable such as t .

Tomake an animatedplot in polar coordinates
1. Type an expression in two variables.

2. Choose Compute> Plot 2D Animated> Polar.

ăe following animation shows the effect of the parameter t on
the polar equation r = sinθ t as a three-leaved rose changes into an
eight-leaved rose and đnally into a đve-leaved rose.

For this animation, open theGraphUser Settings dialogbox. Click
the ItemsPlotted tab, chooseVariables and Intervals, and set−3.14159≤
θ ≤ 3.14159 and 3≤ t ≤ 5. On the View page, select Equal Scaling
Along Each Axis.
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Creating Animated 2D Plots

Compute> Plot 2D Animated> Polar
sinθ t
□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□

□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□

Tomake a parameterized animatedplot in polar coordinates

• Type an expression of the form (r (s, t) ,θ (s, t)), and choose
Compute> Plot 2D Animated> Polar.

ăe following animation shows the effect of the parameter t in the
polar equation r = 1− t cosθ as t varies from−2 to 2. Note

The limaçon, also called the limaçon of Pascal,
is a polar curve of the form
r = b+acosθ .

For the following animation, select the frame and open the Graph
User Settings dialog box. Click the ItemsPlotted tab, chooseVariables
and Intervals, and set −3.14159 ≤ θ ≤ 3.14159 and −2 ≤ t ≤ 2.
On the View page, select Equal Scaling Along Each Axis.

Compute> Plot 2D Animated> Polar
(1− t cosθ ,θ)
□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□

□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□
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Chapter 6 | Plotting Curves and Surfaces

Animated Implicit Plots
Tomake an animated implicit plot

1. Type an equation in three variables.

2. With the insert point in the expression, choose Compute >
Plot 2D Animated> Implicit.

ăe following animation shows the effect of the parameter t on the
rectangular equation x2 + ty2 = 1 as t varies from −1 (which yields
a hyperbola) to+1 (which yields the unit circle). For this animation,
select the frame and open theGraphUser Settings dialog box. On the
Items Plotted page, choose Variables and Intervals, and set−2≤ x≤
2,−2≤ y≤ 2, and−1≤ t ≤ 1. Click the View tab and select Equal
Scaling Along Each Axis. (You may notice a substantial delay as an
animated implicit plot is generated.)

Compute> Plot 2D Animated> Implicit
x2 + ty2 = 1

□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□

□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□

Animated Inequality Plots
Toplot an animated inequality

1. Enter an expression of the form g(x,y, t)< h(x,y, t).

2. With the insert point in the expression, choose Compute >
Plot 2D Animated> Inequality.

In the following,−1 < x < 1,−1 < y < 1, and 0 < t < 1.
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Creating 3D Plots

Compute> Plot 2D Animated> Inequality

tx2 +(1− t)y2 < t (1− t)

□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□

□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□

Creating 3D Plots
ăe environment for plotting curves and surfaces in space is sim-

ilar to the environment for plotting in the plane. ăe view is a box, a
rectangular solid determined by inequalities of the form x0 ≤ x≤ x1,
y0 ≤ y≤ y1, and z0 ≤ z≤ z1. ăe frame is a rectangular region of the
computer screen.

ăe default view has the Plot Intervals −6 ≤ x ≤ 6, −6 ≤ y ≤
6, with the z-coordinates determined automatically from properties
of the plot. If you use other variable names, the order is determined
alphabetically.

Toplot an expression involving two variables

• Place the insert point in the expression and choose Compute>
Plot 3D> Rectangular.

ăe following plot shows the surface z = x3− 3xy2 with the de-
fault Plot Intervals for x and y, and the default View Intervals for x, y,
and z.

To make this plot, leave the insert point in the expression x3 −
3xy2 and choose Compute> Plot 3D> Rectangular.
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Chapter 6 | Plotting Curves and Surfaces

Compute> Plot 3D> Rectangular
x3−3xy2

­5

­400
­200

z

y
0

0

5
x

0

200 ­5

5

400

Toadd expressions involving two variables to an existing 3Dplot
• Select the expression and drag the expression onto the plot.

Or

1. Open the Graph User Settings dialog box.

2. Choose New and type or paste the expression in the Plot ex-
pression input box.

Compute> Plot 3D> Rectangular
x3−3xy2

0 (Type, select, and drag to the frame)

­5

­400
y
­200

z 0
0

5 x
0

­5

200

5

400

Interactive Tools for 3D Plots
Plots can be explored by using the Plot 3D toolbar.
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Creating 3D Plots

Toactivate the 3DInteractiveToolbar
1. Click to the right of a 3D plot.

2. Move the mouse to the Insert Point and click the hand that ap-
pears.

Description of tools from left to right
To reset the viewpoint

• Click the Reset Viewpoint tool.

Tođt the plot to the frame
• Click the Fit Contents tool.

To select a plot and copy as graphic
• Click the Selection tool and choose Edit>Copy .

To rotate the plot horizontally
• Click the Rotation tool and then click and drag across the plot.

Tozoom in [out]
• Click the Zooming tool and then click and drag towards the

bottom [top] of the window.

Tomove the plot
• Click theMoving tool and then click and drag in the direrction

you want the plot to move.

Toviewplot coordinates
• Click the õuery tool and then hover over a point on the plot.

To start or stop a slowor fast rotation
• Click one of the fourRotate tools. (A second clickwill stop that

rotation.)

To start or stop a slowor fast zoom
• Click the Zoom In tool or the Zoom Out tool. (ăe plus sign

to zoom in and theminus sign to zoom out. A second click will
stop that motion.)
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Chapter 6 | Plotting Curves and Surfaces

Tocontrol the speedof rotation and zoom

• Click the Action Speed tool and set the desired speed.

When the mouse pointer is over a 3D plot it turns into a double
arrow. Press the leĕ button and move the mouse to rotate the plot.
Release the leĕ button. ăe plot remains in its new position.

Tochange the orientationof a 3DPlot

1. Place the insert point over the plot and press and hold down the
leĕ mouse button.

2. Drag to the desired orientation and release the mouse button.

Deöned Functions
You can plot a deđned function of two variables in two different

ways. Tip
Recall that you deöne a function such as
f (x,y) = x2 + y2 by placing the insert
point in the expression and choosing Compute
> Deönitions> New Deönition.

Toplot a deđned function f of two variables

1. Select the function name f or select the expression f (x,y).

2. Choose Compute> Plot 3D> Rectangular.

Toadd adeđned functiongof two variables to a 3Dplot

1. Select the function name g or select the expression g(x,y).

2. Drag your selection onto the plot.

For the example that follows, deđne f (x,y)= x2+y2 andg(x,y)=
−5. ăis example shows 3D rectangular plots of both f (x,y) and
g(x,y), with Plot Intervals −6 ≤ x ≤ 6 and −6 ≤ y ≤ 6, and View
Intervals−6≤ x≤ 6,−6≤ y≤ 6, and−5≤ z≤ 40.
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Creating 3D Plots

Compute> Plot 3D> Rectangular
f (x,y)
g(x,y) (Type, select, and drag to the frame)

0
10

­5

20z

30

40

y
0

5

­5

x
0

5

Parametric Plots
Parameterized surfaces in rectangular coordinates are deđned by

three functions x = f (s, t), y = g(s, t), and z = h(s, t) of a two vari-
ables. ăese three functions canbepresented as a rowvector:

[
f (s, t) g(s, t) h(s, t)

]
or
(

f (s, t) g(s, t) h(s, t)
)
; a columnvector:

 f (s, t)
g(s, t)
h(s, t)

or

 f (s, t)
g(s, t)
h(s, t)

;

or as a fenced list: ( f (s, t),g(s, t),h(s, t)) or [ f (s, t),g(s, t),h(s, t)].
ăese are very general and allow you to generate a wide variety of in-
teresting plots.

Toplot a parameterized surface

1. Type expressions in a vector, making each expression a separate
component.

2. Place the insert point in the vector and chooseCompute>Plot
3D> Rectangular.

In the following plot, 0≤ s≤ 2π and 0≤ t ≤ π .
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Chapter 6 | Plotting Curves and Surfaces

Compute> Plot 3D> Parametric
[ssinscos t,scosscos t,ssin t]

Ellipsoid

ăe parameterized surface (acosθ cosϕ ,bsinθ cosϕ ,csinϕ) is
an ellipsoid that đts in a box of dimensions 2a×2b×2c.

Compute> Plot 3D> Parametric
(4sinϕ cosθ ,3sinϕ sinθ ,2cosϕ)

­1
­2

­2
0

0
­2

y 2
2 x

­4

4

z

0
1

2

Hyperboloid of two sheets

In the following example,0≤ s≤ 1.2 and−3.1416≤ t ≤ 3.1416.
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Creating 3D Plots

Compute> Plot 3D> Parametric
[2tanssin t,3tanscos t,secs]
[2tanssin t,3tanscos t,−secs]

­5
0

x
y

­5
0

5
5

­2
­1
0z
1

2

Hyperboloid of one sheet
In this example,−1≤ s≤ 1 and 3.1416≤ t ≤ 3.1416.
Compute> Plot 3D> Rectangular
[2secssin t,3secscos t, tans]

1

0
­1

­4
­2

z

y
0

2
4 2

0

x

­2

Implicit Plots
You can plot an equation involving three variables by choosing

Compute > Plot 3D > Implicit. You will đnd the Switch Variables
option in the Plot Components tabbed dialog useful when the vari-
ables are not interpreted as you intended.

Toobtain an implicit plot of an equation involving three variables
1. Type the equation in three variables.

2. Choose Compute> Plot 3D> Implicit.
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ăe next example shows a 3D implicit plot of x2 + y2 + z2 +1 =

(x+ y+ z+1)2 with Boxed axes, View Intervals−6≤ x≤ 6,−6≤
y≤ 6, and−6≤ z≤ 6.

Compute> Plot 3D> Implicit
x2 + y2 + z2 +1 = (x+ y+ z+1)2

5

y
0

­5

0

z

x

­5

0

­5

5

5

Curves in Space
A space curve is deđned by three functions x = f (t), y = g(t),

z = h(t) of a single variable. ăese three functions can be presented as
a row vector:

[
f (t) g(t) h(t)

]
or
(

f (t) g(t) h(t)
)
; a col-

umnvector:

 f (t)
g(t)
h(t)

or

 f (t)
g(t)
h(t)

; or as a fenced list: ( f (t) ,g(t) ,h(t))

or [ f (t) ,g(t) ,h(t)].

Toplot a space curve as a rectangular plot

1. Type the threedeđning expressions as the components of a three-
element vector.

2. Choose Compute> Plot 3D>Curve in Space, or

Choose Compute> Plot 3D> Rectangular.

In the following example,−6≤ t ≤ 6.
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Creating 3D Plots

Compute> Plot 3D> Curve in Space[
t 2sin t t2

]

20

10

0
­2

z

30

­1 ­5

00

y x
1

52

For the following,−3.1416≤ t ≤ 3.1416.

Compute> Plot 3D> Rectangular −10cos t−2cos(5t)+15sin(2t)
−15cos(2t)+10sin t−2sin(5t)

10cos(3t)



Tube Plots
You can create a “fat curve” by choosing Compute > Plot 3D >

Tube by specifying a radius for the curve in the Plot Properties dialog
box. ăis radius can be constant or can be a function of t . ăe Sample
Size is the number of computed points along the curve; the Number
of Tube Points is the number of computed points in a cross section
of the tube. Ranges refers to the range of computed values for the
parameter t . ăe View Intervals include intervals for x, y, and z of the
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form x0 ≤ x≤ x1, y0 ≤ y≤ y1, z0 ≤ z≤ z1.

Toplot a space curve as a tube plot

1. Type the three deđning expressions as a three-element vector.

2. Choose Compute> Plot 3D>Tube.

3. To change the radius, open thePlotProperties dialog and change
the setting on the Items Plotted page.

ăe “fat curve” is designed to show which parts of the curve are
close to the observer and which are far away. Otherwise, a curve in
space is difficult to visualize. In the following example, Radius is set
to 1, the Plot Interval is set to 0≤ t ≤ 6.28 (≈ 2π) and Surface Style
is set to Hidden Line. To draw the “thin curve” as a tube plot, set the
radius to 0 in the Radius box.

Compute> Plot 3D> Tube −10cos t−2cos(5t)+15sin(2t)
−15cos(2t)+10sin t−2sin(5t)

10cos(3t)



Radius 1 Radius 0

Surfaces of Revolution
By typing an expression in t for the radius and choosing the curve

tobe a straight line, you can get surfaces of revolution. In the following
example, the radius is set to 1−sin t , the range for t is−2π ≤ t ≤ 2π .
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Creating 3D Plots

Compute> Plot 3D> Tube
(t,0,0)

Radius 2− sin t

Polygonal Paths
To plot the polygon whose vertices lie at the points

{(x1,y1,z1) ,(x2,y2,z2) ,(x3,y3,z3) , . . . ,(xn,yn,zn)}

enter the three-column matrix


x1 y1 z1
x2 y2 z2
x3 y3 z3
...

...
...

xn yn zn

 or in a fenced list

(x1,y1,z1,x2,y2,z1,x3,y3,z1, . . . ,xn,yn,zn)

and choose Compute> Plot 3D> Rectangular. ăe points are con-
nected with straight-line segments in the order that they are listed, as
in the following box.
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Chapter 6 | Plotting Curves and Surfaces

Compute> Plot 3D> Rectangular 0 0 1 1 0
0 1 1 0 0
0 0 0 0 0

T

Select and drag to the frame each of the following: 0 0 1 1 0
0 1 1 0 0
1 1 1 1 1

T

,

 1 1 0 0
1 1 1 1
0 1 1 0

T

,

 1 1 0 0
0 0 0 0
0 1 1 0

T

Select and drag to the frame:

Rotate the box.

Transpose
The superscriptT represents the matrix
transpose, which interchanges rows and
columns.

Here are two stars, one of which Ĕoats above the other.
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Creating 3D Plots

Compute> Plot 3D> Rectangular 1 cos 4π
5 cos 8π

5 cos 12π
5 cos 16π

5 1
0 sin 4π

5 sin 8π
5 sin 12π

5 sin 16π
5 0

1 1 1 1 1 1

T

Select and drag to the frame:

 1 cos 4π
5 cos 8π

5 cos 12π
5 cos 16π

5 1
0 sin 4π

5 sin 8π
5 sin 12π

5 sin 16π
5 0

0 0 0 0 0 0

T

You can plot polygonal paths by adjusting the Points Sampled in
a rectangular plot. For Items 1 and 2 below, set Plot Intervals to 0 ≤
t ≤ 1, and Points Sampled to 6.

Compute> Plot 3D> Rectangular
(cos4πt,sin4πt,0)
Select and drag to the frame: (cos4πt,sin4πt,1)

Cylindrical Coordinates
In the cylindrical coordinate system, a point P is represented by

a triple (r,θ ,z), where (r,θ) represents a point in polar coordinates
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Chapter 6 | Plotting Curves and Surfaces

and z is the usual rectangular third coordinate. ăus, to convert from
cylindrical to rectangular coordinates, we use the equations

x = r cosθ y = r sinθ z = z

To go from rectangular to cylindrical coordinates, we use the equa-
tions

r2 = x2 + y2 tanθ =
y
x

z = z

ăe default assumption is that r is a function of θ and z. As usual,
you can plot several surfaces on the same axes by dragging expressions
onto a plot.

Expressions
Tomake a cylindrical plot of an expression

1. Type the expression in two variables.

2. With the insert point in the expression, choose Compute >
Plot 3D>Cylindrical.

ăe following example shows a plot of the cylinder r = 1 and a
cone r = 1− z, obtained as the 3D cylindrical plot of the expressions
1 and 1− z, with 0≤ θ ≤ 2π , and 0≤ z≤ 1.

Compute> Plot 3D> Cylindrical
1 1− z

Parameterized Surfaces in Cylindrical Coordinates
You can create a cylindrical plot of the parameterized surface

r = f (s, t), θ = g(s, t), z = h(s, t) by entering the expressions for
r,θ , and z into a vector

(
f (s, t) g(s, t) h(s, t)

)
or list

( f (s, t),g(s, t),h(s, t)) and choosing Compute > Plot 3D > Cylin-
drical.
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Creating 3D Plots

Tocreate a parameterized cylindrical plot
1. Type the three deđning expressions for r, θ , and z as the compo-

nents of a row vector
(

f (s, t) g(s, t) h(s, t)
)
or a column

vector

 f (s, t)
g(s, t)
h(s, t)

 or as a list ( f (s, t),g(s, t),h(s, t)).

2. With the insert point in the vector, chooseCompute>Plot 3D
>Cylindrical.

ăe following example shows the “spiral staircase” z = θ , a 3D
cylindrical plot of the vector [r,θ ,θ ], with 0 ≤ r ≤ 1, 0 ≤ θ ≤ 4π ,
and Surface Style set to Color Patch.

Compute> Plot 3D> Cylindrical
[r,θ ,θ ]

Spherical Coordinates
ăe spherical coordinates (ρ,θ ,ϕ) locate a point P in space by giv-

ing the distance ρ from the origin, the angle θ projected onto the xy-
plane (the polar angle), and the angle ϕ with the positive z-axis (the
vertical angle). ăe conversion into rectangular coordinates is given
by

x = ρ sinϕ cosθ y = ρ sinϕ sinθ z = ρ cosϕ

and the distance formula implies

ρ2 = x2 + y2 + z2
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ăedefault assumption is that ρ is a function of ϕ and θ . You can
use other names for the polar and vertical angles. Any two variables
you givewill be interpreted as the polar and vertical angles. Evenwhen
you use the standard notation, however, the roles of the variables may
be reversed in the default interpretation fromwhat you intended. You
can correct this interpretation with the Switch Variables option in the
Plot Properties dialog box.

You can plot more than one surface on the same axes by dragging
additional expressions to the plot or by adding additional items on the
Items Plotted page of the Plot Properties dialog.

Expressions
Tomake a spherical plot

1. Type an expression involving θ and ϕ .

1. Choose Compute> Plot 3D> Spherical.

A sphere and a cylinder can each be plotted as a function of the
radius. Following is a sphere of radius 2. Set 0 ≤ θ ≤ 2π and 0 ≤
ϕ ≤ π , check Equal Scaling on EachAxis, and chooseColor Patch for
Surface Style.

Compute> Plot 3D> Spherical
2

Changing the setting for Points Plotted of θ to 4 creates a solid
with a triangular cross section. In the following example, the plotting
intervals are set to−π ≤ θ ≤ π ,−1≤ z≤ 1, and 0≤ ϕ ≤ π .
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Creating 3D Plots

Compute> Plot 3D> Spherical
2

Deöned Functions
You can create a plot of a function deđned in spherical coordinates

ρ = ρ(θ ,ϕ).
Tomake a spherical plot of a deđned functionρ ofθ andϕ

1. Deđneρ as a function ofθ andϕ by choosingCompute>Def-
initions>New Deđnition.

2. Select the function name ρ or select the expression ρ(θ ,ϕ).

3. Choose Compute> Plot 3D> Spherical.

Example To plot the nautilus determined by the expression
(1.2)ϕ sin(θ), you can do any one of the following:

• Plot the expression (1.2)ϕ sin(θ) and then choose SwitchVari-
ables on the Items Plotted page of the Plot Properties dialog.
Use the ranges−1≤ ϕ ≤ 2π and 0≤ θ ≤ π to get the view of
the nautilus shown below.

• Deđne ρ(θ ,ϕ) = (1.2)ϕ sin(θ), plot the expression ρ(θ ,ϕ),
and then choose Switch Variables on the Items Plotted page of
the Plot Properties dialog. Use the ranges −1 ≤ ϕ ≤ 2π and
0≤ θ ≤ π to get the view of the nautilus shown below.

• Deđne the function ρ(ϕ ,θ) = (1.2)ϕ sin(θ) and plot the ex-
pressionρ(θ ,ϕ). (Note the variables are already switchedhere.)
Use the ranges−1≤ θ ≤ 2π and 0≤ ϕ ≤ π to get the view of
the nautilus shown below.
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Compute> Plot 3D> Spherical

ρ(θ ,ϕ)

Parameterized Surfaces in Spherical Coordinates
Parameterized surfaces in spherical coordinates are given by equa-

tions of the form ρ = f (s, t), θ = g(s, t), and φ = h(s, t).
ăese equations are very general and allow you to generate a wide

variety of interesting plots.

Toplot a parameterized surface
1. Type the deđning expressions as the three components of a vec-

tor, ( f (s, t),g(s, t),h(s, t)).

2. Place the insert point in the vector.

3. Choose Compute> Plot 3D> Spherical.

ăe 3D spherical plot of the vector [ρ,θ ,1] gives the cone φ = 1.
For the following plot, the view is set as−1≤ ρ ≤ 1 and 0≤ θ ≤

2π . ăe Surface Style is Color Patch, and the Surface Mesh is Mesh.
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Creating Animated 3D Plots

Compute> Plot 3D> Spherical

(ρ,θ ,1)

You can plot the surface deđned by ρ = s, θ = s2 + t2, φ = t
by entering the three expressions as coordinates of a vector. For the
following plot, take 0≤ s≤ 1 and−1≤ t ≤ 1.

Compute> Plot 3D> Spherical(
s s2 + t2 t

)

Creating Animated 3D Plots
For an animated plot, you specify a third animation parameter.

ăe default animation parameter is t .
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Chapter 6 | Plotting Curves and Surfaces

Animated 3D Plots in Rectangular Coordinates
Tomake an animatedplot in rectangular coordinates

1. Type an expression in three variables.

2. With the insert point in the expression, choose Compute >
Plot 3D Animated> Rectangular.

ăe next example shows a 3D animated plot with Boxed Axes and
Intervals −6 ≤ x ≤ 6, −6 ≤ y ≤ 6, −3 ≤ t ≤ 3, where t is the an-
imation variable. ăe surface changes from a hyperbolic paraboloid
(t < 0), to a paraboloid (t = 0), then to a hyperbolic paraboloid with
a different orientation (t > 0).

Compute> Plot 3D Animated> Rectangular

x2 + y2 + txy

□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□
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Tomake a parameterized animatedplot in rectangular coordinates

1. Type an expression of the form (x(r,s, t) ,y(r,s, t) ,z(r,s, t)).

2. Choose Compute> Plot 3D Animated> Parametric, or

Choose Compute> Plot 3D Animated> Rectangular.

ăe next example shows a surface of revolution generated by ro-
tating the graph of z = 2+siny about the y-axis with BoxedAxes and
Intervals−6≤ s≤ 6, 0≤ r ≤ 1, 0≤ t ≤ 1, where t is the animation
variable.
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Creating Animated 3D Plots

Compute> Plot 3D Animated> Parametric
((2+ sins)sin(2πtr) ,s,(2+ sins)cos(2πtr))

□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□
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Animated Curves in Three Space
Tomake an animated curve in space

1. Type an expression of the form (x(s, t) ,y(s, t) ,z(s, t)).

2. Choose Compute> Plot 3D Animated>Curve in Space.

Here is a curve that plays “follow the leader.”

Compute> Plot 3D Animated> Rectangular −10cos(t + s)−2cos(5(t + s))+15sin(2(t + s))
−15cos(2(t + s))+10sin(t + s)−2sin(5(t + s))

10cos(3(t + s))


0≤ s≤ 3, 0≤ t ≤ 6.28, Animation Variable: t
□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□

□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□
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Chapter 6 | Plotting Curves and Surfaces

Animated Plots in Cylindrical Coordinates
Tomake an animatedplot in cylindrical coordinates

1. Type an expression in three variables

2. With the insert point in the expression, choose Compute >
Plot 3D Animated>Cylindrical.

ăenext example shows a blooming Ĕower, with Intervals0≤ z≤
1, 0≤ θ ≤ 20, and 0≤ t ≤ 1.

Compute> Plot 3D Animated> Cylindrical
ztθ
□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□
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Tomake a parametric animatedplot in cylindrical coordinates

1. Type an expression of the form (r (u,v, t) ,θ (u,v, t) ,z(u,v, t))

2. With the insert point in the expression, choose Compute >
Plot 3D Animated>Cylindrical.

ăe next example shows a cone being generated as the line z = r
is rotated about the z-axis with Intervals 0 ≤ r ≤ 1, 0 ≤ s ≤ 1, and
0≤ t ≤ 1.
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Creating Animated 3D Plots

Compute> Plot 3D Animated> Cylindrical
(−1+2r,2πts,−1+2r)
□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□
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Animated Plots in Spherical Coordinates
Tomake an animatedplot in spherical coordinates

1. Type an expression in three variables.

2. With the insert point in the expression, choose Compute >
Plot 3D Animated> Spherical.

ăe next example shows a sphere growing from radius 1 to radius
2, with animation variable Interval 1≤ t ≤ 2 and Boxed Axes.

Compute> Plot 3D Animated> Spherical
t

□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□
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Chapter 6 | Plotting Curves and Surfaces

Tomake anparameterized animatedplot in spherical coordinates

1. Type an expression of the form (ρ (r,s, t) ,θ (r,s, t) ,ϕ (r,s, t))

2. With the insert point in the expression, choose Compute >
Plot 3D Animated> Spherical.

ăe next animation shows the surface that morphs from a sphere
into a surface shaped like a bagel. ăe Intervals are 0≤ r≤ 1, 0≤ s≤
1, and 0≤ t ≤ 1.

Compute> Plot 3D Animated> Spherical
(1− t cos2πr,2πs,πr)

□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□
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Animated 3D Implicit Plots
Tomake an animated implicit plot

1. Type an equation in four variables.

2. With the insert point in the expression, choose Compute >
Plot 3D Animated> Implicit.

ăenext animation showahyperboloidon two sheets thatmorphs
into a sphere. ăe intervals are−2≤ x≤ 2,−2≤ y≤ 2,−2≤ z≤ 2,
−1≤ t ≤ 1.
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Creating Animated 3D Plots

Compute> Plot 3D Animated> Implicit
x2 + ty2 + tz2 = 1

□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□
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Animated Tube Plot
Tomake an animated tube plot

1. Type an expression in one or two variables

2. With the insert point in the expression, choose Compute >
Plot 3D Animated>Tube.

3. In the Plot Properties dialog, on the Items Plotted page, change
Radius to an expression of your choice, using the same variables

ăe next animation shows a knot being drawn. ăe Intervals are
0≤ s≤ 2π and 0.01 < t < 1, and Radius is set to 3.

Compute> Plot 3D Animated> Tube[
−10cos ts−2cos5ts+15sin2ts −15cos2ts+10sin ts−2sin5ts 10cos3ts

][
−10coss−2cos5s+15sin2s −15cos2s+10sins−2sin5s 10cos3s

]
□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□

□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□
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Chapter 6 | Plotting Curves and Surfaces

Exercises
1. Choose Compute > Plot 2D > Implicit to plot the conic sec-

tions x2 + y2 = 1, x2− y2 = 1, and x+ y2 = 0 all on the same
coordinate axes.

2. Choose Compute > Plot 2D > Implicit to plot the conic sec-
tions (x− 1)2 +(y+ 2)2 = 1, (x− 1)2− (y+ 2)2 = 1, and
(x− 1)+ (y+ 2)2 = 0 on one pair of coordinate axes. With
the hand symbol visible over the view, translate the view so that
the curves match the curves in Exercise 1. In which direction
did the axes move?

3. Plot x2+y2 = 4 and x2−y2 = 1 together. Howmany intersec-
tion points are there? Zoom in on the one in the đrst quadrant
to estimate where the curves cross each other. Verify your esti-
mate by typing the formulas into a matrix and choosing Com-
pute> Solve>Numeric.

4. Plot the astroid x2/3 + y2/3 = 1.

5. Plot the folium of Descartes x3 + y3 = 6xy.

6. Plot the surface z = sinxy, with−4≤ x≤ 4 and−4≤ y≤ 4.
Compare the location of the ridges with the implicit plot of the
three curves xy = π

2 , xy = 3π
2 , and xy = 5π

2 .

7. A standard calculus problem involves đnding the intersection
of two right circular cylinders of radius 1. View this problem by
choosing Compute > Plot 3D > Rectangular to plot the two
parametric surfaces [s,cos t,sin t] and [cos t,s,sin t]. Obtain a
second view by creating a tube plot of [0,0, t] and setting the
radius to

√
2
√

1− t2 and number of tube points to 5.

8. Do the two space curves

[(2+ sin t)10cos t, (2+ cos t)10sin t,3sin3t]

and
[20cos t,20sin t,−3sin3t]

intersect? Choose Compute> Plot 3D> Tube and rotate the
curves to đnd out.
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Exercises

9. View the intersection of the sphere x2 + y2 + z2 = 1 and the
plane x+y+z = 1

2 by expressing these equations in parametric
form and choosing Compute> Plot 3D>Rectangular. Verify
that the points of intersection lie on an ellipse (it is actually a
circle) by solving x+y+z = 1

2 for z, substituting this value into
the equation x2+y2+z2 = 1, and calculating the discriminant
of the resulting equation. 1.

­2 ­1 1 2

­2

­1

1

2

x

y

10. Explore themeaning of contours by plotting the surface z = xy.
Rotate the surface until only the top face of the cube is visible,
and interpret themeaning of the curves that you see. Rotate the
cube until the top face just disappears, and interpret the mean-
ing of the contours that appear.

2.
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­1.0

­0.5

0.5

1.0

x

y

Solutions
1. Compute> Plot 2D> Implicit: x2+y2 = 1,x2−y2 = 1,x+

y2 = 0

(Take −2 ≤ x ≤ 2 and −2 ≤ y ≤ 2. Choose Equal Scaling
Along Each Axis.)

2. Compute>Plot 2D> Implicit: (x−1)2+(y+2)2 = 1,(x−1)2−
(y+2)2 = 1,(x−1)+(y+2)2 = 0

(Take −1 ≤ x ≤ 3 and −4 ≤ y ≤ 0. Choose Equal Scaling
Along Each Axis.)

3. Compute> Plot 2D> Implicit: x2 + y2 = 4,x2− y2 = 1

(Take −5 ≤ x ≤ 5 and −5 ≤ y ≤ 5. Choose Equal Scaling
Along Each Axis.)

Compute> Solve>Numeric:

x2 + y2 = 4
x2− y2 = 1
x ∈ (1,2)
y ∈ (1,2)

Solution : {x = 1.58113883,y = 1.224744871}

4. Compute> Plot 2D> Implicit: |x|2/3 + |y|2/3 = 1

(Take−1≤ x≤ 1 and−1≤ y≤ 1.)

Without the absolute values, you obtain only the đrst quadrant
portion of the graph.
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Chapter 6 | Plotting Curves and Surfaces

5. Compute> Plot 2D> Implicit: x3 + y3 = 6xy

(Take −5 ≤ x ≤ 5 and −5 ≤ y ≤ 5 and set the grid to 50 by
50.)

5a ­4 ­2 2 4

­4

­2

2

4

x

y

5b

Notice how the foliumofDescartes shows up as a level curve on
the surface z = x3 + y3−6xy.

Compute> Plot 3D> Rectangular: x3 + y3−6xy

Compute> Plot 3D> Rectangular: 0

(Use Patch&Contour and take−5≤ x≤ 5,−5≤ y≤ 5, Turn
16, and Tilt 10.)

6. Compute> Plot 3D> Rectangular: sinxy

(ChoosePatch andContour and take−4≤ x≤ 4,−4≤ y≤ 4,
Turn 108, and Tilt 17.)

Compute > Plot 2D > Implicit: xy = π/2,xy = 5π/2,xy =
3π/2

(Take−4≤ x≤ 4 and−4≤ y≤ 4.)

­4 ­2 2 4

­4

­2

2

4

x

y

7. Compute> Plot 3D> Rectangular: [s,cos t,sin t]

Drag [cos t,s,sin t]onto the plot, and set Plot Intervals at−2≤
s ≤ 2 and 0 ≤ t ≤ 2π . Compute > Plot 3D > Tube: [0,0, t],
set the Radius to

√
2×
√

1− t2, set Plot Intervals at−1≤ t ≤
1.
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8. Compute> Plot 3D>Tube:

 (2+ sin t)10cos t
(2+ cos t)10sin t

3sin3t


Drag

 20cos t
20sin t
−3sin3t

 onto the plot, set 0≤ t ≤ 2π , and set the 8.

radius for both items to 1.
Compute> Solve> Exact: (2+ sin t)10cos t = 20coss

(2+ cos t)10sin t = 20sins
3sin3t =−3sin3s


Solution : {t = 0,s = 0} ,{t = π,s = π}

9. ăe plane x+y+ z = 1/2 can be expressed in parametric form
as

(x,y,z) =
(

s, t,
1
2
− s− t

)
and the sphere x2 +y2 + z2 = 1 can be expressed in parametric
form as

(x,y,z) =
(√

1− s2 cos t,
√

1− s2 sin t,s
)

For the plane, take−1≤ s≤ 1,−1≤ t ≤ 1, style Patch&Con-
tour. For the sphere, take−1≤ s≤ 1 and 0≤ t ≤ 6.283 (2π),
style Hidden Line. Set Equal Scaling Along Each Axis.) Solv- 9.

0­1

­1

1

­1

1

0

2

1

ing for z on the plane gives z = 1
2 − x− y, giving the equation

for points on the intersection of the plane and sphere:

x2 + y2 +

(
1
2
− x− y

)2

= 1
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Chapter 6 | Plotting Curves and Surfaces

Expanding this expression yields the equation

2x2 +2xy+2y2− x− y− 3
4
= 0

for the curve of intersection. ăe discriminant B2−4AC is

22−4(2)(2) =−12 < 0

which indicates that the curve of intersection is an ellipse.

10. Here are three views:

­5

­20

0z y

x

0
­5

20

05
5

Wireframe

Contour

y
5

x z05

­5

0 ­5

Contour

ăe contours trace paths where the elevation is constant.
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Calculus

Nature laughs at the difficulties of integration. Pierre-Simon de Laplace (1749–1827)

T his chapter covers the standard topics from differential and Evaluating Calculus Expressions

Limits

Differentiation

Indeönite Integration

Methods of Integration

Deönite Integrals

Sequences and Series

Multivariate Calculus

integral calculus, including limits, sequences, and series. ăe
notion of a function is fundamental to the study of calculus.

Functions were introduced in Chapter 3 “Algebra,” with a descrip-
tion of procedures for naming expressions and functions. Basic in-
formation on working with functions and expressions is summarized
in Chapter 5 “Function Deđnitions,” along with additional informa-
tion on storing and retrieving deđnitions. In this chapter we assume
that youhave read andunderstandhow todeđne andmanipulate func-
tions. We give several examples in this chapter that illustrate connec-
tions between calculus and the function plots introduced in Chapter
6 “Plotting Curves and Surfaces.”

Evaluating Calculus Expressions
You can evaluate calculus expressions in the same manner as ex-

pressions from algebra or trigonometry.
New in Version 6
Dot notation for derivatives
Specify center of a power series
Specify both dependent and independent
variables for implicit differentiation

Tocalculate a derivative or an integral
1. Enter a derivative or integral in standard mathematical nota-

tion.

2. Choose Compute> Evaluate.
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Chapter 7 | Calculus

Tocalculate the derivative d
dx xsinx

1. Choose Insert>Math Objects> Fraction

2. Type d in the numerator, and press tab to take the insert point
to the denominator.

3. Type dx and press spacebar to put the insert point back in line,
then type xsinx.

4. Leave the insert point in the expression d
dx xsinx and choose

Compute> Evaluate. Reminder
The mathematics shown to the right of the
gray bar depicts both what you enter,
d
dx xsinx, and the result of the command
Compute> Evaluate,= sinx+ xcosx.

Compute> Evaluate
d
dx xsinx = sinx+ xcosx

Tocalculate the deđnite integral
∫ π

0 xsinxdx
1. Choose Insert>Math Objects>Operator and select

∫
.

2. Choose Insert>Math Objects> Subscript and type the lower
limit 0 in the subscript box.

3. Press tab and enter the upper limit π in the superscript box. Symbol Toolbar
Selectπ from the Symbol toolbar.
To display the Symbol toolbar, choose View>
Toolbars> Symbol toolbar.

4. Press spacebar to put the insert point back in line, and type
xsinxdx.

5. Leave the insert point in the expression
∫ π

0 xsinxdx and choose
Compute> Evaluate. Integral and area

Compare the area under the curve
y = xsinx between 0 andπ and the area
of the rectangle having sides of length 1 and
π .

2

1

x

y

Compute> Evaluate∫ π
0 xsinxdx = π

Limits
ăe concept of a limit is fundamental to the study of calculus. It is

the central idea of the subject and is what distinguishes calculus from
earlier mathematics. ăe notion, which encompasses subtle concepts
such as instantaneous velocity, can be fully understood only through
experience and experimentation. With ScientiĖc WorkPlace and Sci-
entiĖc Notebook, you have a variety of tools for computing and exper-
imenting with limits.
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Notation for Limits
ăe limit of f as x approaches a is L, written

lim
x→a

f (x) = L

if for each number ε > 0 there exists a number δ > 0 such that
| f (x)−L|< ϵ whenever 0 < |x−a|< δ . Informally, limx→a f (x) = L, if f (x)

gets close toL as x gets close to a.Tođnd a limit of the form limx→a f (x)
1. Choose Insert>Math and type lim.

2. Choose Insert > Math Objects> Subscript and enter the sub-
script x→ a. When you type the name lim, it will turn

from red to gray as you type the third letter.
3. Press spacebar to put the insert point back in line, then type a

mathematical expression f (x).

4. Choose Compute> Evaluate.

Compute> Evaluate

lim
x→1

x2−1
x−1 = 2

Limit
The result limx→1

x2−1
x−1 = 2 is reasonable

since x ̸= 1 implies x2−1
x−1 = x+1, which

is close to 2when x is close to 1.

Limits of rational functions are not always apparent. You cannot
evaluate the following expression at x = −3/2, because the denomi-
nator is 0 for this value of x. ăe expression does, however, have a limit
at−3/2.

Compute> Evaluate

lim
x→−3/2

4x4+6x2+19x+6x3+15
2x3+5x2+5x+3

=− 25
7

Factoring the numerator and denominator suggests a method for
evaluating this limit by direct substitution.

Compute> Factor

4x4 +6x2 +19x+6x3 +15 = (2x+3)(x+1)
(
2x2−2x+5

)
2x3 +5x2 +5x+3 = (2x+3)

(
x2 + x+1

)
If an expression has a removable singularity, factoring in placemay

allow you to đll in the steps leading to evaluation by direct substitu-
tion. ăis is illustrated in the following example, where the second
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step removes the singularity from the expression. Copy the entire ex-
pression aĕer an equals sign, and carry out in-place operations.

lim
x→−3/2

4x4 +6x3 +6x2 +19x+15
2x3 +5x2 +5x+3

= lim
x→−3/2

(2x+3)(x+1)
(
2x2−2x+5

)
(2x+3)(x2 + x+1)

= lim
x→−3/2

(x+1)
(
2x2−2x+5

)
(x2 + x+1)

=

[
(x+1)

(
2x2−2x+5

)
(x2 + x+1)

]
x=−3/2

= −25
7

You can do the substitution (see Substitution, page 47) in the pre-
ceding example as follows:
To substitute a value into an expression

1. Select the expression
(x+1)(2x2−2x+5)

x2+x+1
with themouse, and copy

and paste in a new line.

2. Choose Insert > Math Objects> Brackets and select the leĕ
dashed line and right vertical line.

3. Choose Insert>Math Objects> Subscript.

4. Enter the subscript x = −3/2, and choose Compute > Evalu-
ate.

Compute> Evaluate

(x+1)(2x2−2x+5)
x2+x+1

∣∣∣∣
x=−3/2

=− 25
7

You can also carry out a replacement using the editing features.
Todo an automatic replacement ofmathematics

1. Select the expression
(x+1)(2x2−2x+5)

x2+x+1
with the mouse.

2. Choose Edit> Find and Replace.

3. Fill in the choices in the dialog box in mathematics mode.

a. Search for: x
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b. Replace with: (−3/2)

ăe result is the expression

((−3/2)+1)
(

2(−3/2)2−2(−3/2)+5
)

(−3/2)2 +(−3/2)+1

Special Limits
You can compute one-sided limits, limits at inđnity, and inđnite

limits.

Compute> Evaluate

lim
x→0+

x
|x| = 1 lim

x→0−
x
|x| =−1

lim
x→2+

x+2
x−2 = ∞ lim

x→2
x+2
x−2 = undefined

lim
x→0

sin
( 1

x

)
= limx→0

(
sin 1

x

)
limx→0+

sinx
x = 1

Tables of Values and Plots
You can generate a table of values by applying a function to a vec-

tor of domain values and then concatenating matrices, or you can do
it in one step by deđning appropriate auxiliary functions. ăe limit

lim
x→0

sinx
x

= 1 is of special interest. Aĕer evaluating this limit, the fol-

lowing paragraphs examine the behavior of the function f (x) = sinx
x

near the origin, đrst by looking at numerical evidence and then at plots
containing the origin. Twomethods are then illustrated for construct-
ing a table of values for this function.

Compute> Evaluate
lim
x→0

sinx
x = 1

To see numerical evidence that limx→0
sinx

x = 1, you can evaluate
the expression sinx

x for several values of xnear0. First deđne a function
f to be equal to this expression so that it can be evaluated easily, then
evaluate numerically at several points near zero.

Compute> Deönitions> New Deönition
f (x) = sinx

x

Compute> Evaluate Numeric
f (0.1)≈ 0.99833 f (0.01)≈ 0.99998 f (−0.01)≈ 0.99998
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Note that the function values appear to approach 1. ăe graph of
y = sinx

x on an interval containing 0 gives additional strong evidence
that limx→0

sinx
x = 1.

Compute> Plot2D> Rectangular
sinx

x
(−0.5,1,−0.5,0.96,0.5,0.96,0.5,1,−0.5,1)

­6 ­4 ­2 2 4 6

­0.2

0.2

0.4

0.6

0.8

1.0

x

y

y = sinx
x

­0.4 ­0.2 0.0 0.2 0.4
0.96

0.98

1.00

x

y

y = sinx
x

Creating a Table of Values Using Auxiliary Functions
ăematrix commandFillMatrix is useful for creating tables of val-

ues.
Tocreate a table of values using auxiliary functions

1. Deđne the function f (x).

2. Deđne a function g(n) to provide a sample of values of the in-
dependent variable.

3. Deđne the function h(i, j) = (2− j)g(i)+( j−1) f (g(i)).

4. Choose Compute>Matrices> Fill Matrix.

5. SetColumns to 2 and setRows tomatch the size of your sample.

6. Under Fill with, choose Deđned by function.

7. In the input box for function name, type h. Choose OK.
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ăe following example illustrates this procedure for the function

f (x) =
sinx

x
, with a sample of 10 values for the independent variable.

Example We create a table of values for the function y =
sinx

x
.

Compute> Deönitions> New Deönition

f (x) =
sinx

x
g(i) = i∗10−2

h(i, j) = (2− j)g(i)+( j−1) f (g(i))

Choose Insert>MathObjects>Brackets, select square brackets,
and leave the insert point in the input box.

Compute>Matrices> Fill Matrix
(Rows 10, Columns 2, Matrix Type: Deđned by Function, Function h

1
100 100sin 1

100
1

50 50sin 1
50

3
100

100
3 sin 3

100
1

25 25sin 1
25

1
20 20sin 1

20
3

50
50
3 sin 3

50
7

100
100
7 sin 7

100
2

25
25
2 sin 2

25
9

100
100
9 sin 9

100
1

10 10sin 1
10



In the matrix that results, the numbers in the đrst column are val-
ues of the independent variable, and the numbers in the second col-
umn are the corresponding function values.

Evaluate numerically to put the matrix in numeric format.
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Compute> Evaluate Numeric

1
100 100sin 1

100
1

50 50sin 1
50

3
100

100
3 sin 3

100
1

25 25sin 1
25

1
20 20sin 1

20
3

50
50
3 sin 3

50
7

100
100
7 sin 7

100
2

25
25
2 sin 2

25
9

100
100
9 sin 9

100
1

10 10sin 1
10



≈



0.01 0.99998

0.02 0.99993

0.03 0.99985

0.04 0.99973

0.05 0.99958

0.06 0.9994

0.07 0.99918

0.08 0.99893

0.09 0.99865

0.1 0.99833


Togenerate a table of values by concatenatingmatrices

1. Type the equation f (x)=
sinx

x
and, with the insert point in the

equation, choose Compute>Deđnitions>New Deđnition.

2. Type the equation g(i, j) = 0.01i

3. Choose Compute>Matrices> Fill Matrix.

4. Specify somenumberof rows,1 column, checkDeđnedbyFunc-
tion, type g in the Item/Function/List box, and choose OK.

5. Choose Compute>Matrices>Map Function.

6. Type f in the Function or Expression box, and choose OK.

With the same function as in the previous example, this gives 1.0×10−2

2.0×10−2

3.0×10−2

 result of map

 0.99998
0.99993
0.9985


and concatenating produces 1.0×10−2

2.0×10−2

3.0×10−2


 0.99998

0.99993
0.9985

 , concatenate:

 0.01 0.99998
0.02 0.99993
0.03 0.9985


208



i
i

“Compute60” — 2011/12/20 — 14:27 — page 209 — #219 i
i

i
i

i
i

Differentiation

(See Concatenate and Stack Matrices, page 292, for details on con-
catenating matrices.)

Differentiation
ăe derivative f ′ of a function f is deđned by the equation

f ′(x) = lim
h→0

f (x+h)− f (x)
h

ăe derivative of a function f at the point x is the slope of the graph
of f at the point (x, f (x)).

Notation for Derivative
You can use a variety of notations for the derivative, including the

forms
d
dx

,
dn

dxn , Dx, Dxx, Dx2 , Dxy, Dxsyt ,
∂
∂x

, and
∂ n

∂xs∂yt

Tocompute a derivative
1. Enter an expression using one of the above forms. Notation

Choose Tools> Preferences> Computation
> Derivatives to change default options for
derivatives.

2. With the insert point in the expression, choose Compute >
Evaluate.

Compute> Evaluate
d
dx

(
x3
)
= 3x2 d4

dx4

(
3x8
)
= 5040x4

∂
∂x

(
sin2 x

)
= sin(2x) Dx5y2

(
x9y3

)
= 90720x4y

∂ 5

∂x2∂y3 (sinxcosy) =−sinxsiny
Caution
There is a difference between f (n) (the nth
derivative of f ) and f n (the nth power of
f ).

If f is deđned as a function of one variable, then the forms f ′(x),
f ′′(x), …, and f (n)(x) are recognized as đrst, second, and nth deriva-
tives, respectively.

Compute> Deönitions> New Deönition
f (x) = sinxcosx

Compute> Evaluate
f ′ (x) = cos2 x− sin2 x f (4) (x) = 16cosxsinx
f ′′ (x) =−4cosxsinx f 4 (x) = cos4 xsin4 x

ăe following examples include some time-saving steps for key-
board entry.
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Toenter a derivative of the form d
dx x2

1. Place the insert point where you want the derivative to appear,
even in an existing input box.

2. Choose Insert > Math Objects > Fraction, and type the nu-
merator.

3. Move to the denominator by pressing down arrow, or pressing
tab, or clicking the denominator input box; and type the de-
nominator (usually similar to dx).

4. Press rightarrow or spacebar to leave the fraction, and type the
mathematical expression.

Toenter a derivative of the form f (3) (x)
1. Choose Insert>Math and type f .

2. Choose Insert>Math Objects> Superscript.

3. Choose Insert> Brackets and select parentheses.

4. Type 3 in the input box.

5. Press rightarrow twice to leave the superscript.

6. Choose Insert>MathObjects>Brackets and select parenthe-
ses.

7. Type x in the input box.

Tođnd the derivative of x2

1. Place the insert point in the expression d
dx

(
x2
)
.

2. Choose Compute> Evaluate.

You obtain the same result from any of the following expressions.

dx2

dx
d
dx

x2 d
dx

(
x2) ∂

∂x

(
x2)

Dxx2 Dx
(
x2) ∂x2

∂x
∂
∂x

x2

ăe “prime” notation works only for deđned functions, not for
expressions.
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Compute> Evaluate
(x+ sinx)′

d
dx (x+ sinx) = cosx+1

Caution
Evaluate applied to (x+ sinx)′ does not
give the derivative.

A derivative is applied to the term directly to the right of the op-
erator, as illustrated in the following two examples.

Compute> Evaluate
∂ 2

∂x2 x2 +3x = 3x+2

∂ 2

∂x2

(
x2 +3x

)
= 2

Parentheses
Making good use of expanding brackets
(fences) eliminates many common types of
ill-formed expressions.

Using good notation is important. ăe program may accept am-
biguous notation, but it may lead to an unexpected output. Experi-
ment with expressions such as

∂ 2

∂x2

(
(x2 +3x

)
and

∂ 2

∂x2 {x
2 +3x

to see examples of how ill-formed expressions are interpreted. Choose
Compute> Interpret to observe the interpretation of an expression.

ăederivative of a piecewise-deđned function is again a piecewise-
deđned function. (SeePiecewise-DeđnedFunctions, page108 formore
information on piecewise-deđned functions.)

Compute> Deönitions> New Deönition

f (x) =
{

x if x < 0
3x2 if x≥ 0

Compute> Evaluate

d
dx f (x) =

{
6x if 0 < x
1 if x < 0

It is not necessary to name a piecewise function in order to take its
derivative.

Compute> Evaluate

d
dx

 x+2 if x < 0
2 if 0 < x < 1

2/x if 1 < x

=


1 if x < 0
0 if 0 < x∧ x < 1
− 2

x2 if 1 < x

ăe symbol∧means that both of the conditions 0 < x and x < 1
are true. ăis is equivalent to the compound inequality 0 < x < 1.
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Plotting Derivatives
You can plot several functions on the same graph. In particular, a

function can be plotted together with one or more of its derivatives.
Deđning the function đrst is oĕen convenient.

Compute> Deönitions> New Deönition
f (x) = x4−7x3 +14x2−8x

Toview the graphof f with its đrst and secondderivatives
1. Type f (x) and, with the insert point in f (x), choose Compute

> Plot 2D> Rectangular.

­1 1 2 3 4 5

­50

50

100

x

y

f (x), f ′ (x), f ′′ (x)

2. Type f ′(x), select it and drag it to the frame

3. Type f ′′(x), select it and drag it to the frame.

Open the Graph User Settings dialog and change settings to dis-
tinguish the three curves. You can change line thickness or line color
for each curve. Another way to distinguish the graphs is by determin-
ing the values at 0. Use Evaluate (or inspection) to đnd f (0) = 0,
f ′(0) =−8, and f ′′(0) = 28.

It is not necessary to deđne the functions. You can plot an expres-
sion and drag the đrst and second derivatives to the plot, as indicated
below.

Compute> Plot 2D> Rectangular
sin2x d

dx (sin2x) d2

dx2 (sin2x)

­6 ­4 ­2 2 4 6

­4

­2

2

4

x

y

It is possible to specify the symbol f (x) tobe an arbitrary, or generic,
function. Simply deđne f (x) to be a function, without associating it
with a formula. (See Deđning Generic Functions, page 110.)
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Compute> Deönitions> New Deönition
f (x)
g(x)

Standard rules of calculus apply to generic functions.

Compute> Evaluate

d
dx ( f (x)+g(x)) = ∂ f (x)

∂x + ∂g(x)
∂x

d
dx

∫ x

0
f (t)dt = f (x)

Dx ( f (x)g(x)) = f (x)Dxg(x)+g(x)Dx f (x)

Dx
f (x)
g(x) =−

( f (x)Dxg(x)−g(x)Dx f (x))
g2(x)

Implicit Differentiation
Variables can be linked to one another implicitly via an equation

rather than in an explicit way. For example, xy = 1 implicitly deter-
mines y as a function of x. ăis example is easily solved to give the ex-
plicit formula y = 1/x. Many other equations cannot easily be solved
for one of the variables. Also, some equations, such as x2+y2 = 1, do
not determine a function, but pieces of the curves determined by such
equations are functions. Implicit Differentiation, an item on the Cal-
culus submenu, đnds derivatives from an equation without explicitly
solving the equation for any one variable.

You specify the differentiation variable—that is, the independent
variable. It is important to remember this variable in order to interpret
the result, because the derivative is returned in the prime notation y′.

Tođnd aderivative of an implicitly deđned function

1. Place the insert point in the equation.

2. Choose Compute>Calculus> Implicit Differentiation.

3. Place the insert point in the solution and solve for the derivative
with Solve> Exact.
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Compute> Calculus> Implicit Differentiation
xy+ sinx = y (Independent variable x, Dependent variable y)
Solution: cosx+ y(x)+ xy′ (x) = y′ (x)
xyz− x2y = 0 (Independent variable t , Dependent variables x,y,z)
Solution: x(t)y(t)z′ (t)−2x(t)y(t)x′ (t)+ x(t)z(t)y′ (t)

+y(t)z(t)x′ (t)− x(t)2 y′ (t) = 0

Note that in the đrst example above, y′ = dy/dx. In the second
example above, x′ = dx/dt , y′ = dy/dt , and z′ = dz/dt .
To ignore special cases

• Choose Tools > Preferences > Computation > Engine, and
check Ignore Special Cases.

Compute> Solve> Exact
y+ xy′+ cosx = y′ (Variable(s) to Solve For: y′),
Solution: 1

x−1 (−y− cosx)
xyz′−2xyx′+ xzy′+ yzx′− x2y′ = 0 (Variable(s) to Solve For: z′)
Solution: 1

xy

(
2xyx′− xzy′− yzx′+ x2y′

)
Use ImplicitDifferentiation combinedwithword processing edit-

ing features to đnd the second derivative y′′.

1. Leave the insert point in y′ = − y+cosx
x−1 , and choose Compute

>Calculus> Implicit Differentiation. Type x for the Indepen-
dent variable and y for the Dependent variable. Choose OK.
ăis returns the equation

∂y′ (x)
∂x

=
cosx+ y(x)

(x−1)2 +
sinx− y′ (x)

x−1

2. Use editing techniques to replace ∂y′(x)
∂x by y′′ and to replace

y′ (x) by− y(x)+cosx
x−1 .

3. Apply Compute> Simplify to obtain the following:

y′′ =
cosx+ y(x)

(x−1)2 +
sinx−

(
− y(x)+cosx

x−1

)
x−1

=
2cosx+2y(x)− sinx+ xsinx

(x−1)2
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You can use Implicit Differentiation to đnd an equation of a tan-
gent line. Find the derivative y′, evaluate at a point on the curve to
đnd the slope of the tangent at that point, and use the point-slope for-
mula to đnd the equation for the tangent line. You can then plot the
graph of the equation together with the tangent line. In the following
example, we đnd the equation for the tangent line at the point (1,1)
on the curve x3 +3x2y = 2y3 +2.
Tođnd the equationof a tangent line

1. Place the insert point in the equation x3 +3x2y = 2y3 +2 and
choose Compute>Calculus> Implicit Differentiation (Inde-
pendent variable x, Dependent variable y) to obtain

Solution: 6xy(x)+3x2 +3x2y′ (x) = 6y2 (x)y′ (x)

2. Remove all the (x) and choose Solve > Exact (Variable(s) y′)
for the result

Solution:


/0 if x2 +2xy ̸= 0∧ x2 = 2y2

C if x2 +2xy = 0∧ x2 = 2y2{
− x2+2xy

x2−2y2

}
if x2 ̸= 2y2

­6 ­4 ­2 2 4 6

­6

­4

­2

2

4

6

x

y

x3 +3x2y = 2y3 +2
Tangent line at (1,1)

3. For the slope at the point (1,1) on the curve, enclose the ex-
pression in expanding brackets, add limits in a subscript, and
choose Evaluate. ăis yields[

2xy+ x2

2y2− x2

]
x=1,y=1

= 3

4. Place the insert point in thepoint-slope formulay−1= 3(x−1)
and choose Solve>Exact (Variable(s) y) to đnd the formula for
the tangent line in standard form: y = 3x−2.

5. Place the insert point in the equation x3 +3x2y = 2y3 +2 and
chooseCompute>Plot 2D> Implicit to plot the curve. Select
and drag the equation for the tangent line to the plot.

Numerical Solutions to Equations
You can use both exact and numerical methods for solving equa-

tions, as illustrated in the following three examples.
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Compute> Solve> Exact
5x3−5x2 = x, Solution: 0, 1

2 −
3

10

√
5, 3

10

√
5+ 1

2
5.0x3−5.0x2 = x, Solution: 0,−0.17082,1.1708

Compute> Solve> Numeric
5x3−5x2 = x, Solution: {[x = 1.1708] , [x =−0.17082] , [x = 0.0]}

Iteration
You can also obtain numerical solutions formany equations of the

form f (x) = x by using Iterate from theCalculus submenu. ăis tech-
nique works for functions satisfying | f ′(x)|< 1 near the intersection
of the curve y = f (x) and the line y = x. You start with an estimate
x0 for the root, and Iterate returns the list of values

f (x0), f ( f (x0)) , f ( f ( f (x0))) , f ( f ( f ( f (x0)))) , . . .

up to the number of iterations you specify. In appropriate situations,
these values converge to a root of the equation f (x) = x. For example,
solve the equation cosx = x.

Compute> Deönitions> New Deönition
f (x) = cosx

Choosing Compute > Calculus > Iterate opens a dialog. In the
box, type f (x) as the Expression, 1.0 as Initial evaluation point, and
10 as the Number of iterates. With Digits Shown in Results set to 5,
you receive the following vector of iterates:

Compute> Calculus> Iterate
Expression: f (x)
Initial evaluation point: 1.0
Number of iterates: 5

1.0
0.54030
0.85755
0.65429
0.79348
0.70137


ăese entries are the initial value, followed by the values

f (1.0), f ( f (1.0)), . . . , f ( f ( f ( f ( f ( f ( f ( f ( f ( f (1.0))))))))))
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Iteration

0.0 0.5 1.0 1.5
0.0

0.5

1.0

x

y
You can generate these numbers geometrically by starting at the

point (1,0) and moving vertically to the curve y = cosx, then hori-
zontally to the line y = x, then vertically to the curve y = cosx, then
horizontally to the line y = x, and so forth, as illustrated in the đgure.

ăis đgure can be generated by plotting cosx and x as usual, then
selecting the matrix

1.0 0
1.0 0.5403
0.5403 0.5403
0.5403 0.85755
0.85755 0.85755
0.85755 0.65429
0.65429 0.65429
0.65429 0.79348
0.79348 0.79348
0.79348 0.70137
0.70137 0.70137


and dragging it to the frame. ăis matrix can be created from two
copies of the column computed previously, modiđed appropriately,
usingMatrices>Concatenate. (See Concatenate and StackMatrices,
page 292 for details on concatenating matrices.)

Newton’s Method
ăe iterationmethod in the previous section canwork very slowly.

However, it provides the basis for Newton’s method , which is usually
much faster than direct iteration. Newton’s method is based on the
observation that the tangent line is a good local approximation to the
graph of a function.

Let (x0, f (x0)) be a point on the graph of the function f . ăe
tangent line is given by the equation

y− f (x0) = f ′(x0)(x− x0)

ăis line crosses the x-axis when y = 0. ăe corresponding value of x
is given by

x = x0−
f (x0)

f ′(x0)

In general, given an approximation xn to a zero of a function f (x),
the tangent line at the point (xn, f (xn)) crosses the x-axis at the point
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(xn+1,0) where

xn+1 = xn−
f (xn)

f ′(xn)

ăe Newton iteration function for a function f is the function g de-
đned by

g(x) = x− f (x)
f ′(x)

Given a đrst approximation x0, Newton’s method produces a list x1, Newton’s method

­0.4 ­0.2 0.2 0.4

­0.3
­0.2
­0.1

0.1
0.2
0.3

x

y

x− x3

x2, . . ., xn of approximations to a zero of f . In the graph, f (x) = x−
x3, x0 = 0.44, x1 ≈−0.41, x2 ≈ 0.27, and x3 ≈−0.048.
ăis đgure can be generated by plotting x−x3 as usual, zooming in to
change the viewing rectangle, then selecting the matrix

0.44 0
0.44 0.90475
−0.41 0
−0.41 0.91712

0.27 0
0.27 0.96377
−0.048 0
−0.048 0.99885


and dragging it to the frame.

You can use Newton’s method to solve the equation x = cosx.

Compute> Deönitions> New Deönition
f (x) = x− cosx

g(x) = x− f (x)
f ′(x)

With Digits Rendered set at 20, you receive the vector of values
shown below.

Compute> Calculus> Iterate
Expression g(x); Initial evaluation point 0.7; Number of iterates 5

Iterates:

0.7
0.73943649784805819543
0.7390851604651073986
0.73908513321516080562
0.73908513321516064166
0.73908513321516064166
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ăese values converge to the display precision in four iterations.
As a check, use Evaluate to verify that Tip

A graph of y = cosx and y = x displays
the approximate solution to the equation
x = cosx.

­4 ­2 2 4

­2

2

x

y

With the insert point near the point of
intersection, press the left mouse button to
view the coordinates.

cos(0.73908513321516064166) = 0.73908513321516064165

A graph of y = cosx and y = x displays the approximate solution
to the equation x = cosx.
You can observe that there is only one solution, so you do not need
to specify the interval for the solution. Type the equation cosx = x,
leave the insert point in the equation, and choose Compute > Solve
>Numeric.

Compute> Solve> Numeric
cosx = x, Solution : {[x = 0.7390851332]}

Optimization
Many of the applications of differentiation involve đnding a value

of x that yields a localmaximumor localminimumvalue of some func-
tion f (x). A good way to begin the investigation, when you know the
function f (x) either implicitly or explicitly, is to examine a plot of the
function. Tip

For most purposes, we suggest using øoating
point coefficients for optimization problems.
Although Compute> Solve> Exact will give
symbolic solutions to equations with rational
coefficients, for many equations the solutions
are very long, full of nested radicals, and
awkward to work with.

A plot suggests that the function f (x) = cosx+ sin3x has nu-
merous extreme values.

Compute> Plot 2D> Rectangular
cosx+ sin3x

­5 ­4 ­3 ­2 ­1 1 2 3 4 5

­2

2

x

y

You can locate extreme values by solving f ′(x) = 0 with Solve >
Numeric, since the function f (x) = cosx+ sin3x is everywhere dif-
ferentiable.

In these examples, Digits Rendered is set at 5
on the Tools> Preferences> Computation
> Output dialog. See Appendix C
“Customizing the Program for Computing” for
details on changing this setting.

Compute> Solve> Numeric
d
dx (cosx+ sin3x) = 0
Solution: {[x = 1.6833]}

ăis calculation yields only one critical number, although the graph
indicates many more. You can specify the interval for a solution by
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placing the equation in a one-column matrix and entering a solution
interval in the second row.

Compute> Solve> Numeric
d
dx(cosx+ sin3x) = 0

x ∈ (0,2)
, Solution: [x = 0.4728]

Another strategy is to give the function a Ĕoating point coefficient
and then use an exact method.

Compute> Deönitions> New Deönition
f (x) = 1.0cosx+ sin3x

Compute> Solve> Exact
f ′(x) = 0, Solution: {6.2832k+ z | k ∈ Z,
z ∈ {−2.6688,−1.4583,−0.58534,0.47280,1.6833,2.5563}}

Indeed, the absolute minimum f (−2.6688) ≈ −1.8787 occurs
at x ≈ −2.6688 (and at−2.6688+ 2πn for any integer n), and the
absolute maximum f (0.4728)≈ 1.8787 occurs at x ≈ 0.4728 (and
at 0.4728+2πn for any integer n).

Example ăe extreme values of y = x3−5x+1 can be found directly.

Compute> Calculus> Find Extrema
x3−5x+1, Candidate(s) for extrema:

{
10
9

√
15+1,− 10

9

√
15+1

}
,

at
{[

x = 1
3

√
15
]
,
[
x =− 1

3

√
15
]}

Floating-point coefficients produceĔoating-point approximations.
ăus, applying Find Extrema to x3− 5.0x+ 1.0 gives numerical ap-
proximations to the extreme values.

Compute> Calculus> Find Extrema
x3−5.0x+1.0 Candidate(s) for extrema: {−3.3033,5.3033},

at {[x =−1.2910] , [x = 1.2910]}

Geometrically, thepoints (−1.291,5.3033) and (1.291,−3.3033)
represent a high point and a low point, respectively.
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r Compute> Plot 2D> Rectangular
x3−5x+1, (−1.291,5.3033), (1.291,−3.3033)

­4 ­3 ­2 ­1 1 2 3 4

­40

­20

20

40

x

y

(­1.291,5.3033)

(1.291,­3.3033)

Example Tođnd theminimumdistancebetween thepoint (−2,2.25)
and the graph of the function f (x) = cos3x− sin2x, đrst plot the
graph of f on the interval−5≤ x≤ 1 and drag the point (−2,2.25)
and the circle (−2+2cos2πx,2.25+2sin2πx) with center
(−2,2.25) and radius 2 to the plot frame. ăe plot shows that there
are three regions of the graph of f that are all roughly a distance2 from
the point (−2,2.25).

Compute> Plot 2D> Rectangular
cos3x− sin2x (−5≤ x≤ 1)
(−2,2.25) Point Marker: Circle
(−2+2cos2πx,2.25+2sin2πx) (0≤ x≤ 1)

­5 ­4 ­3 ­2 ­1 1

­2

­1

1

2

3

4

Let

g(x) =
√
(−2− x)2 +(2.25− f (x))2

denote the distance between the point (−2,2.25) and the point
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(x, f (x)) on the graph of f . ăere are three candidates for a point
on the graph of f closest to the point (−2,2.25). Locate a minimum
value of g by setting the derivative equal to 0 and solving numerically
in appropriate intervals.

Compute> Solve> Numeric
g′ (x) = 0

x ∈ (−4,−3) , Solution: [x =−3.8667]

g′ (x) = 0
x ∈ (−2.5,−1.5) , Solution: [x =−1.9212]

g′ (x) = 0
x ∈ (−1,0) , Solution: [x =−0.3959]

Compare these trial solutions to locate the minimum.

Compute> Evaluate Numeric
g(−3.8667)≈ 1.9898 g(−1.9212)≈ 2.0283 g(−0.3959)≈ 1.9823

ăe minimum distance is 1.9823.

Curve Sketching
A default plot may well obscure some of the subtle, and even not

so subtle, detail of a plot. You may need to adjust both the domain
and the range to obtain a useful plot. For example, let us examine the
graph of the function f (x) = x2− 20x+ 100. In the default plot,
a decreasing curve is visible, not giving much clue about the overall
shape of the graph.

Tip
For a better ideal about the overall shape of
the graph, experiment with plot intervals such
as 0≤ x≤ 20 to get the view

0 5 10 15 20
0

50

100

x

y

x2−20x+100

Compute> Plot 2D> Rectangular
x2−20x+100

­6 ­4 ­2 0 2 4 6

100

200

x

y

As a striking example of frustration, the đrst attempt at plotting
the equation 7x2 +36xy−50y2 +594x−2363y−26500 = 0 will
not create a visible plot because there are no points on the graph in the
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default region −6 < x < 6, −6 < y < 6. Again, you can zoom out
and experiment with different views and obtain the following:

Compute> Plot 2D> Implicit

7x2 +36xy−50y2 +594x−2363y−26500 = 0

­50 50

­40

­20

x
y

When feasible, the view of a graph should be adjusted so that the
pointswhere these extremevalues occur are included in the view. Zoom-
ing and panning can help you to accomplish this.
To locate the relative extreme values of a graph

• Solve f ′(x) = 0.

In the following example, we locate extreme values of the function Default plot

­6 ­4 ­2 2 4 6

­40

­20

20

40

60

80

100

x

y

x6−5x3 +10x2−40x

(x2−4)2

f (x) =
x6−5x3 +10x2−40x

(x2−4)2

ăe default plot of this expression gives a good view of the three ex-
treme values.

You can đnd the points where extreme values might occur with
Solve.

Compute> Solve> Exact
d
dx

[
x6−5x3 +10x2−40x

(x2−4)2

]
= 0, Solution:

RootOf (−40Z +90Z2−10Z3 + 5
2 Z4−12Z5 +Z7 +80)

You canđnd approximate real roots of this seventh-degree polyno-
mial with Numeric from the Solve submenu. In the following, Digits
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Rendered is set at 5 on the Output page of the Tools>Computation
dialog box.

Compute> Solve> Numeric
2(−40Z +90Z2−10Z3 + 5

2 Z4−12Z5 +Z7 +80)
Solution: {[Z = 2.2359] , [Z = 3.0327] , [Z =−3.8864] ,
[Z =−0.90484+1.6422i] , [Z =−0.90484−1.6422i,
[Z = 0.21375−0.90433i] , [Z = 0.21375+0.90433i]}

ăethree real roots of f ′ give two localminimums: f (−3.8864)=
32.812 and f (3.0327) = 22.553, and one local maximum:
f (2.2359) = 29.656.

You can gain additional insight into the graph of a rational func-
tion by rewriting it as a polynomial plus a fraction.

Compute> Polynomials> Divide
x6−5x3+10x2−40x

(x2−4)
2 = x2− 5x3−58x2+40x+128

(x2−4)
2 +8

Select anddrag thepolynomialx2+8 to theplot to see both curves
in the same picture. Note how well the graph of y = x2 + 8 matches
the graph of y = f (x) for large values of x.

Compute> Plot 2D> Rectangular
x6−5x3+10x2−40x

(x2−4)
2 and x2 +8

­10 ­8 ­6 ­4 ­2 2 4 6 8 10
­20

20

40

60

80

100

x

y

Todetermine concavity of a graph
• Find intervals where the second derivative is positive or nega-

tive.
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To locate the intervals where the graph of f (x) = x4+3x3−x2−
3x is concave upward, evaluate f ′′(x) to obtain f ′′(x)= 12x2+18x−
2, and solve the inequality 12x2 +18x−2 > 0.

Compute> Solve> Exact
12x2 +18x−2 > 0

Solution:
(
−∞,− 1

48

√
35
√

48− 3
4

)
∪
(

1
48

√
35
√

48− 3
4 ,∞

)
To solve more complicated inequalities or systems of inequalities,

you can set expressions equal to zero and test for sign changes.
One way to answer the question of where the graph of

f (x) =
x6−5x3 +10x2−40x

(x2−4)2

is concave upward is to đnd the sign of the second derivative.

Compute> Deönitions> New Deönition
f (x) = x6−5x3+10x2−40x

(x2−4)
2

ApplyEvaluate andFactor to đnd the secondderivative as the quo-
tient of two polynomials.

Compute> Evaluate, Compute> Factor

f ′′(x) =
2(x8−16x6−5x5+270x4−400x3+320x2−1200x+160)

(x−2)4(x+2)4

Since the denominator is always nonnegative, it is sufficient to in-
vestigate the sign of the numerator. Apply Solve > Numeric to the
equation

0 = x8−16x6−5x5 +270x4−400x3 +320x2−1200x+160

to đnd the real solutions

[x≈ 0.13759] , [x≈ 2.3414]

Compute the value at any point to the leĕ, between, and to the right
of these solutions, using Evaluate Numeric:

f ′′(0) ≈ 1.25
f ′′(1) ≈ −21.481

f ′′(2.4) ≈ 40.964
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Taking into account the vertical asymptotes, the graph is concave
upward on the intervals (−∞,−2), (−2,0.1376), and (2.3414,∞),
and concavedownwardon the intervals (0.13759,2) and (2,2.3414).

Indeönite Integration
An antiderivative of a function f (x) is any function g(x) whose

derivative is f (x). If g(x) is an antiderivative of f (x), then g(x)+C
is another antiderivative. In fact, every antiderivative is of the form
g(x)+C for some constantC.

ăe indeđnite integral of f (x) is the family of all antiderivatives of
f (x) and is denoted

∫
f (x)dx.

Toevaluate an indeđnite integral
• Place the insert point anywhere in an integral and choose Eval-

uate.

Compute> Evaluate∫ (
2x2 +3x+5

)
dx = 1

6 x
(
4x2 +9x+30

)
ăe system does not automatically return the constant of integra-

tion—oĕen called the arbitrary constant—so you must remain alert Spacing
It is common, although hardly necessary, to
add a thin space between f (x) and dx in an
integral

∫
f (x) dx. The Thin Space (found

under Insert + Spacing + Horizontal Space) is
for readability only, and in no way affects the
way in which an integral is interpreted by the
underlying computing engine.

and add the constant when needed. Simply type+C to change from∫ (
2x2 +3x+5

)
dx =

2
3

x3 +
3
2

x2 +5x

to ∫ (
2x2 +3x+5

)
dx =

2
3

x3 +
3
2

x2 +5x+C

Such constants are needed, for example, if you have a formula for ac-
celeration and you want to đnd an expression for velocity.

You can evaluate indeđnite integrals of piecewise-deđned func-
tions. You can deđne a function from a piecewise expression, or work
directly with the piecewise expression, as shown in the following ex-
amples. Turn on Helper Lines to see the null brackets on the right.

Compute> Deönitions> New Deönition

f (x) =
{

x if x < 0
3x2 if x≥ 0
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Compute> Evaluate∫
f (x)dx =

{ 1
2 x2 if x≤ 0
x3 if 0 < x

∫ {
x if x < 0
3x2 if x≥ 0 dx =

{ 1
2 x2 if x≤ 0
x3 if 0 < x

Interpreting an Expression
ăe computer algebra system interprets many expressions that

might be considered ambiguous. You can check the interpretation
without evaluating an expression.

To interpret an expressionwithout evaluation
• Place the insert point in the expression and choose Compute>

Interpret.

Compute> Interpret
xy/z = xy

z
∫

ax3 =
∫

ax3 d

sinx/y = sin
(

x
y

) ∫
x3a =

∫
x3ad

Even though the interpretations of the integral expressions do not
indicate the variable of integration, they show that the expressions are
interpreted as indeđnite integrals. If such an expression is evaluated, a
choice will be made, generally based on the alphabetical order of the
characters.

Compute> Evaluate∫
ax3 = 1

4 ax4 ∫
yx3 = 1

4 x4y∫
x3a = 1

4 ax4 ∫
x3y = 1

4 x4y

If f is not deđned as a function, then it is treated as a variable or
constant.

Compute> Evaluate∫
f = 1

2 f 2∫
f (x)dx = 1

2 f x2

In these expressions, f behaves the same as any other variable, and
f (x) is interpreted as simply the product of f and x.
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Methods of Integration
Even though you can evaluatemany integrals directly, several stan-

dard techniques of integration—such as integration by parts, change
of variables by substitution, and partial fractions—are also available
in ScientiĖcWorkPlace and ScientiĖc Notebook. ăese techniques were
necessary before computational systems were available, and are still
important to the understanding of calculus.

Integration by Parts
ăe integration by parts formula states that∫

udv = uv−
∫

vdu

ăis formula comes from the product formula for differentials

d (uv) = udv+ vdu

and the linearity of integration, which implies that∫
d (uv) =

∫
udv+

∫
vdu

and the fundamental theorem of calculus, which allows you to replace∫
d (uv) by uv in the formula for integration by parts.

Touse integrationby parts
1. Place the insert point in an integral.

2. Choose Compute>Calculus> Integrate by Parts.

3. In the dialog box, type an appropriate expression for the Part to
Differentiate.

4. Choose OK.

For the integral
∫

x lnxdx, for example, choosing lnx for the Part
to Differentiate gives the following result:

Compute> Calculus> Integrate by Parts (Part to Differentiate: lnx)∫
x lnxdx = 1

2 x2 ln(x)−
∫ 1

2 xdx

Since
∫ 1

2 xdx can easily be integrated, this solves the problem of
integrating x lnx. Note that in this example, u = lnx and dv = xdx,
so that du = 1

x dx and v = 1
2 x2.
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Change of Variable
It follows from the chain rule that if u= g(x), then du= g′(x)dx.

ăis yields the change of variable formula for integration:∫
f (g(x))g′(x)dx =

∫
f (u)du

Toperforma change of variable
1. Enter the integral

∫
xsinx2 dx.

2. Choose Compute>Calculus>Change Variable.

3. In the dialog box, type an appropriate substitution u = g(x).

4. Choose OK.

For the integral
∫

xsinx2 dx, the substitution u = x2 gives the fol-
lowing:

Compute> Calculus> Change Variable
(Expression for u: x2)∫

xsinx2 dx =
∫ 1

2 sin(u) du

ăis replaces the problem of integrating xsinx2 by two much eas-
ier problems: đrst integrating 1

2 sinu and then replacing u by x2 in the
result. Note that u = g(x) = x2, f (u) = sinu, and du = 2xdx.

For the integral
∫

x5
√

x3 +1dx, the substitution u = x3 + 1 is
useful.

Compute> Calculus> Change Variable
(Expression for u: x3 +1)∫

x5
√

x3 +1dx =
∫ 1

3
√

u(u−1) du

Compute> Evaluate∫ 1
3
√

u(u−1) du = 2
45 u

3
2 (3u−5)

ăen do an in-place replacement with u = x3 +1:

2
15

u5/2− 2
9

u3/2 =
2

15
(
x3 +1

)5/2− 2
9
(
x3 +1

)3/2
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Partial Fractions
ăe method of partial fractions is based on the fact that a fac-

torable rational function can be written as a sum of simpler fractions.
Notice how evaluation of the following integral gives the answer as a
sum of terms.

Compute> Evaluate∫ 3x2 +2x+4
(x−1)(x2 +1)

dx = 9
2 ln(x−1)− ln(x− i)

( 3
4 +

1
4 i
)
− ln(x+1)

( 3
4 −

1
4 i
)

To gain an appreciation for how this calculation might be done
internally, consider the method of partial fractions.

Touse themethodof partial fractions
• Replace a rational function by its partial fractions expansion be-

fore carrying out its integration.

Example Here is howyouuse thismethodon the integral
∫ 3x2+2x+4

(x−1)(x2+1)
dx.

1. Enter the rational expression 3x2+2x+4
(x−1)(x2+1)

.

2. With the insert point in this expression, choose Compute >
Calculus> Partial Fractions or choose Compute> Polynomi-
als> Partial Fractions.

3x2 +2x+4
(x−1)(x2 +1)

=
9

2(x−1)
−

3
2 x− 1

2
x2 +1

ăus

∫ 3x2 +2x+4
(x−1)(x2 +1)

dx =
∫ ( 9

2(x−1)
−

3
2 x− 1

2
x2 +1

)
dx

3. Write the preceding integral as a sum of three integrals.∫ 9
2(x−1)

dx− 3
2

∫ x
x2 +1

dx+
1
2

∫ 1
x2 +1

dx
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4. Evaluate each of these integrals.∫ 9
2(x−1)

dx =
9
2

ln(x−1)

−3
2

∫ x
x2 +1

dx = −3
4

ln
(
x2 +1

)
1
2

∫ 1
x2 +1

dx =
1
2

tan−1 (x)

5. ăe original integral is the sum of the expressions above on the
right,∫ 3x2 +2x+4

(x−1)(x2 +1)
dx=

9
2

ln(x−1)− 3
4

ln
(
x2 +1

)
+

1
2

arctanx− 1
4

π

whichdiffers fromthe answerpreviously computeddirectlywith
Evaluate only by a constant.

Deönite Integrals
ăe deĖnite integral

∫ b
a f (x)dx of a function f (x) deđned on the

interval [a,b] is given by∫ b

a
f (x)dx = lim

∥P∥→0

n

∑
i=1

f (x̄i)∆xi

where x̄i is a point in the ith subinterval of the partition

P = {a = x0 < x1 < x2 < · · ·< xn = b}

of the interval [a,b], ∆xi = xi−xi−1, and∥P∥=max{∆xi}. ăe sum

n

∑
i=1

f (x̄i)∆xi

is called a Riemann sum. ăe function f is integrable on [a,b] if the
preceding limit exists.

If f is integrable on [a,b], then∫ b

a
f (x)dx = lim

n→∞

b−a
n

n

∑
i=1

f
(

a+ i
b−a

n

)
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In particular, if f is continuous on [a,b], then f is integrable on [a,b].
For positive-valued functions f , the sum

b−a
n

n

∑
i=1

f
(

a+ i
b−a

n

)

can be interpreted as the sum of areas of rectangles of base b−a
n with

height determined by the value of the function f at right endpoints Right boxes

­1.0 ­0.5 0.0 0.5 1.0

0.5

1.0

x

y
of subintervals. For example, assume a = −1, b = 1, n = 10, and
f (x) = 1

x2+1 . ăen

1− (−1)
10

n

∑
i=1

f
(
−1+ i

1− (−1)
10

)

represents the sum of the areas of the 10 rectangles in the đgure. (See
Leĕ and Right Boxes, page 240, for a discussion of Riemann sums us-
ing leĕ and right boxes.)

Entering and Evaluating Deönite Integrals
Toenter a deđnite integral

1. Choose Insert>Math Objects>Operator and choose
∫
.

2. Choose Insert>MathObjects> Subscript, and type the lower
limit.

3. Press tab and type the upper limit of integration. (Limits of in-
tegrationwork the same as any other subscripts or superscripts.)

4. Press the spacebar or the rightarrow to move out of the super-
script, and type the rest of the expression.

Toevaluate a deđnite integral
• Leave the insert point in the expression and choose Evaluate or

Evaluate Numeric.

Compute> Evaluate∫ 1
0 x2
√

x3 +1dx = 4
9

√
2− 2

9

Compute> Evaluate Numeric∫ 1
0 x2
√

x3 +1dx≈ 0.40632
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Integrals involving absolute values or piecewise-deđned functions
can be treated as any other function.

Compute> Evaluate∫ 2
−2

∣∣x2−1
∣∣ dx = 4

Tounderstand this computation, determine the intervals forwhich
x2−1 is positive or negative, and write the integral as a sum of several
integrals with the absolute value sign removed.

Compute> Solve> Exact
x2−1 > 0, Solution: (1,∞)∪ (−∞,−1)

So
∣∣x2−1

∣∣= x2−1 forx<−1orx> 1, and
∣∣x2−1

∣∣=−(x2−1
)
=

1− x2 for−1 < x < 1. ăen you can write the integral as the sum of
the following three:

∫ 2

−2

∣∣x2−1
∣∣ dx=

∫ −1

−2

(
x2−1

)
dx+

∫ 1

−1

(
1− x2) dx+

∫ 2

1

(
x2−1

)
dx

Compute> Evaluate∫ −1
−2
(
x2−1

)
dx = 4

3
∫ 1
−1
(
1− x2

)
dx = 4

3
∫ 2

1
(
x2−1

)
dx = 4

3

You can đnd the deđnite integral of a piecewise function either by
integrating the expression directly or by deđning a piecewise function
f (x).

Compute> Deönitions> New Deönition

f (x) =
{

x2 if x < 0
x if x≥ 0

Compute> Evaluate∫ 3
−2 f (x)dx = 43

6

∫ 3

−2

({
x2 if x < 0
x if x≥ 0

)
dx = 43

6

To understand this computation, write the integral as a sum of in-
tegrals involving ordinary functions. ăis yields

∫ 3

−2
f (x)dx =

∫ 0

−2
x2 dx+

∫ 3

0
xdx =

8
3
+

9
2
=

43
6
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Methods of Integration with Deönite Integrals
Methods thatwere introduced for indeđnite integration—integra-

tion by parts, change of variables, and partial fractions—can also be
applied to deđnite integrals. See Methods of Integration, page 228
for general details about these methods.

To integrate by partswith a deđnite integral
1. Place the insert point in a deđnite integral.

2. Choose Compute>Calculus> Integrate by Parts.

3. Type in the dialog box an appropriate expression for the Part to
Differentiate.

4. Choose OK.

Compute> Calculus> Integrate by Parts
(Part to Differentiate: lnx)∫ 2

1 x lnxdx = 2ln2−
∫ 2

1
1
2 xdx

Touse a change of variableswith a deđnite integral
1. Place the insert point in a deđnite integral.

2. Choose Compute>Calculus>Change Variable.

3. Type in the dialog box an Expression for u, and choose OK.

Compute> Calculus> Change Variable
(Expression for u: x3 +1)∫ 2

0 x5
√

x3 +1dx =
∫ 9

1
1
3
√

u(u−1) du

ăis gives an integral that can be computed by elementary meth-
ods. Note that the limits have changed to match the new variable.

Touse partial fractionswith a deđnite integral
• Replace a rational expression with its partial fractions expan-

sion.

Compute> Calculus> Partial Fractions
3x2+2x+4
(x−1)2 = 8

x−1 +
9

(x−1)2 +3
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ăus∫ 7

3

3x2 +2x+4
(x−1)2 dx=

∫ 7

3
3dx+

∫ 7

3

9

(x−1)2 dx+
∫ 7

3

8
x−1

dx= 12+3+8ln3

Compute> Evaluate∫ 7
3 3dx = 12

∫ 7
3

8
x−1 dx = 8ln3∫ 7

3
9

(x−1)2 dx = 3
∫ 7

3
3x2+2x+4
(x−1)2 dx = 8ln3+15

Improper Integrals
If the proper integral

∫ b
a f (x) dx exists for every b≥ a, the limit∫ ∞

a
f (x) dx = lim

b→∞

∫ b

a
f (x) dx

deđnes an improper integral of the Ėrst kind. ăe integral is said to con-
verge if this limit exists and is đnite.
Tocompute an improper integral of theđrst kind

• Place the insert point in the integral and choose Evaluate or
Evaluate Numeric.

Compute> Evaluate∫ ∞
1 x−2 dx = 1

∫ ∞
1 x−1 dx = ∞∫ ∞

0 e−3x dx = 1
3

∫ 0
−∞ e−3x dx = ∞∫ ∞

−∞ e−x2
dx =

√
π

∫ ∞
0 sinxdx = undefined

Compute> Evaluate Numeric∫ ∞
−∞ e−x2

dx≈ 1.7725
∫ ∞

0
sinx
ex dx≈ 0.5

A deđnite integral for which the integrand has a discontinuity or
a place where it is not deđned within the interval of integration is an
improper integral of the second kind. ăe discontinuity may occur
either in the interior or at one or both endpoints of the interval of
integration.
Toevaluate an improper integral of the secondkind

1. Place the insert point in the integral.
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2. Choose Compute> Evaluate. or

Compute> Evaluate Numeric.

Compute> Evaluate∫ 1
0 lnxdx =−1

If f has a discontinuity at a point c, and both
∫ c

a f (x) dx and∫ b
c f (x) dx are convergent, then

∫ b
a f (x) dx=

∫ c
a f (x) dx+

∫ b
c f (x) dx.

If either diverges, then so does
∫ b

a f (x) dx.

Compute> Evaluate∫ 3
1

dx
x−1 = ∞

∫ 1
0 ln |x| dx =−1∫ 1

1/2
dx

x−1 =−∞
∫ 0
−1 ln |x| dx =−1∫ 3

1/2
dx

x−1 = undefined
∫ 1
−1 ln |x| dx =−2

­1.0 ­0.5 0.0 0.5 1.0

­10

­5

x

y

ln |x|

Use special care when working with improper integrals and make
certain that answers look reasonable. Limits that straddle a discon-
tinuity, such as

∫ 1
−1

1
x2 dx or

∫ π
−π

1+sinx
(x−cosx)2 dx, should be avoided en-

tirely. ăe latter will take a very long time to return a result and then
simply returns the form you entered. Any time the system appears to
hang up like this, examine the expression for a discontinuity.

Note that the indeđnite integral
∫

1+sinx
(x−cosx)2 dx produces a solu-

tion:

Compute> Evaluate∫
1+sinx

(x−cosx)2 dx =− 1
x−cosx

A naive approach to this problem, namely computing the indeđnite
integral and evaluating at the endpoints,

­3 ­2 ­1 1 2 3

2

4

6

8

10

x

y

1+sinx
(x−cosx)2

[
− 1

x− cosx

]π

−π
=− 1

π−1
− 1

π +1
=
−2π

π2−1

gives an answer that is quite wrong. It is important to observe that
the function 1+sinx

(x−cosx)2 is not deđned when x = cosx. ăis improper

integral is examined further in the exercises at the end of this chapter.
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Assumptions about Variables
ăe four functions assume, additionally, about, and unassume,

werediscussed inChapter 5 “FunctionDeđnitions,” beginningonpage
111. We review this topic brieĔy to add an example of their applica-
tion in calculus. ăe function assume enables you to place a restraint
on a speciđc variable or on all variables. ăe function additionally al-
lows you to place additional restraints on the same variable. ăe func-
tion about shows which restraints are active. ăe function unassume
removes restraints.

Consider the following integral.

Compute> Evaluate

∫ 1
0 x2n−1 dx =

{
∞ if n = 0∫ 1

0 x2n−1 dx if n ̸= 0

ăis integral cannot be computed with no restraints because it
converges for n≥ 0, but fails to converge for n < 0. You can evaluate
this integral aĕer applying the function “assume” to restrict possible
values of n.

Compute> Evaluate
assume(n,positive) = (0,∞)∫ 1

0 x2n−1 dx = 1
2n

ăe available assumptions on variables include real, complex,
integer, positive, negative, and nonzero. When typed in mathemat-
ics mode, these function names turn upright and gray. ăese assump-
tions can be made locally (for a speciđc variable) or globally. Addi-
tional information aboutmaking assumptions is available onpage 111.

Deönite Integrals from the Deönition
You can use text editing and computing in place to đll in the steps

for đnding deđnite integrals from the deđnition.

Example Deđne f by the equation f (x) = x3. Calculate the integral∫ 4
1 f (x)dx as follows.

1. Enter the equation∫ 4

1
f (x)dx = lim

n→∞

n

∑
i=1

f
(

1+ i
4−1

n

)
4−1

n
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2. Select the term to the right of the summation sign.

3. Press and hold down theCtrl key and choose Compute> Eval-
uate, then choose Compute> Factor.

4. Select the series.

5. PressCtrl+Evaluate, then chooseCompute>Expand, then add
parentheses.

6. With the insert point in the expression, choose Compute >
Evaluate.

ăese steps produce the following sequence of expressions:∫ 4

1
f (x)dx = lim

n→∞

n

∑
i=1

f
(

1+ i
4−1

n

)
4−1

n

= lim
n→∞

n

∑
i=1

3
(n+3i)3

n4

= lim
n→∞

(
189
2n

+
135
4n2 +

255
4

)
=

255
4

For comparison, you can compute this integral directly:

Compute> Evaluate∫ 4

1
x3 dx = 255

4

Pictures of Riemann Sums
You can plot pictures of Riemann sums obtained from midpoints,

leĕ endpoints, or right endpoints of subintervals. ăechoices areMid-
dle Boxes, Leĕ Boxes, Right Boxes, and Leĕ and Right Boxes.

Middle Boxes
ăe Riemann sum determined by the midpoints is given by

b−a
n

n−1

∑
i=0

f
(

a+
b−a

2n
+ i

b−a
n

)
which is the sum of the areas of rectangles whose heights are deter-
mined by midpoints of subintervals.
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Tomake aMiddleBoxes plot
1. Place the insert point inside the expression you want to plot.

2. Choose>Compute>Calculus> Plot Approximate Integral.
A Middle Boxes plot will appear with default interval settings.

3. Click the plot to select the frame, or double-click the plot to
select the view.

4. Choose Edit> Properties and select the Items Plotted page.

a. Reset Number of Boxes as desired.

b. Choose Variables and Intervals and reset the Plot Interval
as desired.

5. Choose OK twice to close the dialog.

Example ăe following Middle Boxes plot uses 0− 1 < x < 7 and
Number of Boxes is 6.

Compute> Calculus> Plot Approximate Integral
sin3x+3cosx
Edit> Properties (Reset Number of Boxes and Plot Interval)

RiemannMiddle:  4.43

­1 1 2 3 4 5 6 7

­2

2

4

x

y

For the expression sin3x+ 3cosx, with six rectangles and limits
−1 and7, the approximatingMiddleBoxesRiemann sum is as follows:

Compute> Calculus> Approximate Integral
(Formula: Midpoint; Subintervals: 6; Lower Bound: -1; Upper Bound: 7)
sin3x+3cosx
Approximate integral (midpoint rule) is 4

3 ∑5
i3=0

(
sin(4i3−1)+3cos

( 4
3 i3− 1

3

))
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Compare with the actual value:

Compute> Evaluate Numeric
4
3 ∑5

i3=0
(
sin(4i3−1)+3cos

( 4
3 i3− 1

3

))
≈ 4.5222∫ 7

−1 (sin3x+3cosx) dx≈ 4.3480

Experiment by increasing the number of
subintervals.

Left Boxes and Right Boxes

In general, the leĕ endpoint approximationLn for
∫ b

a
f (x)dxwith

n subdivisions is given by

∫ b

a
f (x)dx≈ Ln =

b−a
n

n−1

∑
i=0

f
(

a+ i
b−a

n

)

and the right endpoint approximation Rn for
∫ b

a
f (x)dx with n sub-

divisions is given by∫ b

a
f (x)dx≈ Rn =

b−a
n

n

∑
i=1

f
(

a+ i
b−a

n

)
Tomake aLeĕ [Right]Boxes plot

1. Place the insert point inside the expression to be plotted.

2. Choose Compute>Calculus> Plot Approximate Integral. A
Middle Boxes plot will appear with default range settings.

3. Click the plot to select the frame, or double-click the plot to
select the view.

4. Choose Edit> Properties and select the Items Plotted page.

a. Check Leĕ [Right] Boxes. Reset the number of boxes as
desired.

b. Choose Variables and Intervals and reset the Plot Interval
as desired.

c. Select Show Info option (No Info, Approximated Value,
Approximated and Exact Values, Both Values and Error)

5. Choose OK twice to close the dialog.
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Compute> Calculus> Plot Approximate Integral
sin3x+3cosx
(Formula: Leĕ [Right, Both] Boxes; Subintervals: 6; Lower Bound: -1; Upper Bound: 7)

RiemannLeft:  2.86
Integral:  4.35

2 4 6
­2

2

4

x

y

RiemannRight:  5.02
Integral:  4.35

2 4 6
­2

2

4

x

y

RiemannLeft:  2.86

Integral:  4.35
RiemannRight:  5.02
Integral:  4.35

2 4 6
­2

2

4

x

y

For the expression sin3x+3cosx, with six rectangles and−1 ≤
x≤ 7, the approximating Leĕ [Right] Riemann sums are

4
3

5

∑
k=0

(
sin
(

3
(
−1+

4
3

k
))

+3cos
(
−1+

4
3

k
))

≈ 2.8647 (Leĕ)

4
3

6

∑
k=1

(
sin
(

3
(
−1+

4
3

k
))

+3cos
(
−1+

4
3

k
))

≈ 5.0228 (Right)

Upper Boxes and Lower Boxes
An upper [lower] Riemann sum is given by∫ b

a
f (x) dx≈

n

∑
i=1

f (x̄i) ∆xi

where x̄i is a point in the ith subinterval xi−1 ≤ x≤ xi of the partition

P = {a = x0 < x1 < x2 < · · ·< xn = b}
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such that f (x̄i)=max{ f (x) : xi−1 ≤ x≤ xi} [ f (x̄i) = min{ f (x) : xi−1 ≤ x≤ xi}].

Tomake a plot of an upper [lower] sum
1. Place the insert point inside the expression to be plotted.

2. Choose Compute>Calculus> Plot Approximate Integral. A
Middle Boxes plot will appear with default range settings.

3. Open the Graph User Settings dialog.

a. Check Upper [Lower] Boxes. Reset the number of boxes
as desired.

b. Choose Variables and Intervals and reset the Plot Interval
as desired.

c. Select desired Plot Info.

4. Choose OK twice to close the dialog.

Compute> Calculus> Plot Approximate Integral
sin3x+3cosx
(Formula: Lower [Upper, Both] Boxes; Subintervals: 6; Lower Bound: -1; Upper Bound: 7)

RiemannLower: ­7.05

2 4 6

­2

2

4

x

y
RiemannUpper:  14.21

2 4 6

­2

2

4

x

y

RiemannUpper:  14.21
.
.
RiemannLower: ­7.05

2 4 6
­2

2

4

x

y
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Upper Absolute and Lower Absolute Boxes
An upper [lower] absolute Riemann sum is given by

∫ b

a
f (x) dx≈

n

∑
i=1

f (x̄i) ∆xi

where x̄i is a point in the ith subinterval xi−1 ≤ x≤ xi of the partition

P = {a = x0 < x1 < x2 < · · ·< xn = b}

such that

| f (x̄i)| = max{| f (x)| : xi−1 ≤ x≤ xi}
[ | f (x̄i)| = min{| f (x)| : xi−1 ≤ x≤ xi}].

Tomake a plot of an upper [lower] absolute sum

1. Place the insert point inside the expression to be plotted.

2. Choose Compute>Calculus> Plot Approximate Integral. A
Middle Boxes plot will appear with default range settings.

3. Open the Graph User Settings dialog.

a. CheckUpper [Lower] Absolute Boxes. Reset the number
of boxes as desired.

b. Choose Variables and Intervals and reset the Plot Interval
as desired.

c. Select desired Plot Info.

4. Choose OK twice to close the dialog.
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Compute> Calculus> Plot Approximate Integral
sin3x+3cosx
(Formula: Lower [Upper, Both] Absolute; Subintervals: 6; Lower Bound: -1; Upper Bound: 7)

RiemannLowerAbs:  1.29

2 4 6

­2

2

4

x

y
RiemannUpperAbs:  5.87

2 4 6

­2

2

4

x

y

RiemannUpperAbs:  5.87
.
.
RiemannLowerAbs:  1.29

2 4 6
­2

2

4

x

y

Trapezoidal Sums
ăe formula for the trapezoid rule approximation Tn is given by

∫ b

a
f (x)dx≈ Tn =

b−a
2n

(
f (a)+2

n−1

∑
i=1

f
(

a+ i
b−a

n

)
+ f (b)

)

with an error bound of∣∣∣∣Tn−
∫ b

a
f (x)dx

∣∣∣∣≤ K
(b−a)3

12n2

where K is any number such that | f ′′(x)| ≤ K for all x ∈ [a,b].
Tomake a trapezoid plot

1. Place the insert point inside the expression to be plotted.

2. Choose Compute>Calculus> Plot Approximate Integral. A
Middle Boxes plot will appear with default range settings.
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3. Open the Graph User Settings dialog.

a. CheckApproximationMethod: Trapezoid. Reset thenum-
ber of boxes as desired.

b. Choose Variables and Intervals and reset the Plot Interval
as desired.

c. Select desired Plot Info.

4. Choose OK twice to close the dialog.

Compute> Calculus> Plot Approximate Integral
sin3x+3cosx
(Formula: Trapezoid; Subintervals: 6; Lower Bound: -1; Upper Bound: 7)

Trapezoid:  3.94

­1 1 2 3 4 5 6 7

­2

2

4

x

y

Simpson’s Rule
Simpson’s rule gives the approximation Sn (n an even positive in-

teger) for an arbitrary function f by

∫ b

a
f (x)dx≈ Sn =

b−a
3n

(
f (a)+ f (b)+4

n/2

∑
i=1

f
(

a+(2i−1)
b−a

n

)
+2

−1+n/2

∑
i=1

f
(

a+2i
b−a

n

))

ăe error bound for Simpson’s rule is given by∣∣∣∣Sn−
∫ b

a
f (x)dx

∣∣∣∣≤ K
(b−a)5

180n4

where K is any number such that
∣∣∣ f (4)(x)∣∣∣ ≤ K for all x ∈ [a,b]. In

particular, Simpson’s rule is exact for integrals of polynomials of de-
gree at most 3 (because the fourth derivative of such a polynomial is
identically zero).
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Tomake a Simpsonplot
1. Place the insert point inside the expression to be plotted.

2. Choose Compute>Calculus> Plot Approximate Integral. A
Middle Boxes plot will appear with default range settings.

3. Open the Graph User Settings dialog.

a. CheckApproximationMethod: Trapezoid. Reset thenum-
ber of boxes as desired.

b. Choose Variables and Intervals and reset the Plot Interval
as desired.

c. Select desired Plot Info.

4. Choose OK twice to close the dialog.

Compute> Calculus> Plot Approximate Integral
sin3x+3cosx
(Formula: Simpson; Subintervals: 6; Lower Bound: -1; Upper Bound: 7)

Simpson:  4.33

­1 1 2 3 4 5 6 7

­2

2

4

x

y

Approximation Methods
You can use themidpointmethod, the trapezoidal rule, and Simp-

son’s rule for approximating deđnite integrals. To apply each of these
approximation methods, place the insert point in a mathematical ex-
pression, choose Compute > Calculus > Approximate Integral, and
then choose the appropriate method in the dialog box.

Midpoint Rule
In general, the midpoint approximation Mn for

∫ b
a f (x)dx with n

subdivisions is given by∫ b

a
f (x)dx≈Mn =

b−a
n

n−1

∑
i=0

f
(

a+
b−a

2n
+ i

b−a
n

)
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with an error bound of∣∣∣∣Mn−
∫ b

a
f (x)dx

∣∣∣∣≤ K
(b−a)3

24n2

where K is any number such that | f ′′(x)| ≤ K for all x ∈ [a,b].

Toapproximate
∫ b

a f (x) dxusing themidpointmethod

1. Place the insert point in an expression of the form
∫ b

a f (x) dx.

2. Choose Compute>Calculus>Approximate Integral.

3. In thedialog that appears, chooseMidpoint and specify thenum-
ber of Subintervals.

Or

1. Place the insert point in an expression f (x).

2. Choose Compute>Calculus>Approximate Integral.

3. In the dialog, choose Midpoint, specify the number of Subin-
tervals, and specify Lower Bound and Upper Bound.

To obtain the following output, in the dialog that appears, specify
10 Subintervals. ăe system returns a summation that you can evalu-
ate numerically.

Compute> Calculus> Approximate Integral∫ π
0 xsinxdx Approximate integral (midpoint rule) is

1
10 π

9
∑

i3=0

1
10 π

(
i3 + 1

2

)
sin 1

10 π
(
i3 + 1

2

)
For the following output, specify 10 Subintervals, type 0 as Lower

Bound, and type 3.14159 as Upper Bound.

Compute> Calculus> Approximate Integral
xsinx Approximate integral (midpoint rule) is

0.31416
9
∑

i4=0
(0.31416i4 +0.15708)sin(0.31416i4 +0.15708)

Compare these results with direct computations of the integral.

247



i
i

“Compute60” — 2011/12/20 — 14:27 — page 248 — #258 i
i

i
i

i
i

Chapter 7 | Calculus

Compute> Evaluate Numeric
1

10 π
9
∑

i3=0

1
10 π

(
i3 + 1

2

)
sin 1

10 π
(
i3 + 1

2

)
≈ 3.1545

0.31416
9
∑

i4=0
(0.31416i4 +0.15708)sin(0.31416i4 +0.15708)≈ 3.1545∫ π

0 xsinxdx≈ 3.1416

Left Boxes and Right Boxes
In general, the leĕ endpoint approximationLn for

∫ b
a f (x)dx with

n subdivisions is given by

∫ b

a
f (x)dx≈ Ln =

b−a
n

n−1

∑
i=0

f
(

a+ i
b−a

n

)

and the right endpoint approximation Rn for
∫ b

a f (x)dx with n sub-
divisions is given by∫ b

a
f (x)dx≈ Rn =

b−a
n

n

∑
i=1

f
(

a+ i
b−a

n

)
Toapproximate

∫ b
a f (x) dxusing leĕ [right] boxes

1. Place the insert point in the expression
∫ b

a f (x) dx.

2. Choose Compute>Calculus>Approximate Integral

3. In the dialog that appears, choose Leĕ [Right] Boxes and spec-
ify the number of Subintervals.

Or

1. Place the insert point in the expression f (x).

2. Choose Compute>Calculus>Approximate Integral.

3. In the dialog, choose Leĕ [Right] Boxes, specify the number of
Subintervals, and specify Lower Bound and Upper Bound.

For the following output, in the dialog that appears, select Leĕ
Boxes and specify 10 Subintervals. ăe system returns a summation
that you can evaluate numerically.
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Compute> Calculus> Approximate Integral∫ π/2
0 xsinxdx Approximate integral is 1

20 π
9
∑

i5=0

1
20 πi5 sin 1

20 πi5

For the following output, in the dialog that appears, select Right
Boxes and specify 10 Subintervals.

Compute> Calculus> Approximate Integral∫ π/2
0 xsinxdx Approximate integral is 1

20 π
10
∑

i5=1

1
20 πi5 sin 1

20 πi5

For the following output, specify Leĕ Boxes, specify 10 Subinter-
vals, and type 0 as Lower Bound and 1.5708 as Upper Bound.

Compute> Calculus> Approximate Integral

xsinx Approximate integral (leĕ boxes) is 0.15708
9
∑

i7=0
0.15708i7 sin0.15708i7

For the following output, specify Right Boxes, specify 10 Subin-
tervals, and type 0 as Lower Bound and 1.5708 as Upper Bound.

Compute> Calculus> Approximate Integral

xsinx Approximate integral (right boxes) is 0.15708
10
∑

i8=1
0.15708i8 sin0.15708i8

Evaluate numerically to compare these outputs with one another
and with the integral.

Compute> Evaluate Numeric
1

20 π
9
∑

i5=0

1
20 πi5 sin 1

20 πi5 ≈ 0.87869

1
20 π

10
∑

i6=1

1
20 πi6 sin 1

20 πi6 ≈ 1.1254

0.15708
9
∑

i7=0
0.15708i7 sin0.15708i7 ≈ 0.87869

0.15708
10
∑

i8=1
0.15708i8 sin0.15708i8 ≈ 1.1254∫ π/2

0 xsinxdx≈ 1.0

ăeleĕboxes underestimate this integral, and the right boxes over-
estimate it.
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Trapezoid Rule
ăe formula for the trapezoid rule approximation Tn is given by

∫ b

a
f (x)dx≈ Tn =

b−a
2n

(
f (a)+2

n−1

∑
i=1

f
(

a+ i
b−a

n

)
+ f (b)

)

with an error bound of∣∣∣∣Tn−
∫ b

a
f (x)dx

∣∣∣∣≤ K
(b−a)3

12n2

where K is any number such that | f ′′(x)| ≤ K for all x ∈ [a,b].

Toapproximate a deđnite integral using the trapezoid rule

1. Place the insert point in an expression of the form
∫ b

a f (x) dx.

2. Choose Compute>Calculus>Approximate Integral.

3. In the dialog that appears, choose Trapezoid and specify the
number of Subintervals.

Or

1. Place the insert point in an expression f (x).

2. Choose Compute>Calculus>Approximate Integral.

3. In the dialog, select Trapezoid, specify the number of Subinter-
vals, and specify Lower Bound and Upper Bound.

To obtain the following output, specify 10 Subintervals.

Compute> Calculus> Approximate Integral∫ π
0 xsinxdx Approximate integral (trapezoid rule) is 1

10 π ∑9
i5=1

1
10 πi5 sin

( 1
10 πi5

)
Toobtain the followingoutput, specify 10Subintervals, 0 asLower

Bound, and 3.14159 as Upper Bound.

Compute> Calculus> Approximate Integral
xsinx Approximate integral (trapezoid rule) is

0.31416
9
∑

i10=1
0.31416i10 sin0.31416i10 +1.3095×10−6

250



i
i

“Compute60” — 2011/12/20 — 14:27 — page 251 — #261 i
i

i
i

i
i

Deönite Integrals

Compute> Evaluate Numeric
1

10 π
9
∑

i9=1

1
10 πi9 sin 1

10 πi9 ≈ 3.1157
∫ π

0 xsinxdx≈ 3.1416

0.31416
9
∑

i10=1
0.31416i10 sin0.31416i10 +1.3095×10−6 ≈ 3.1157

Simpson’s Rule
Simpson’s rule gives the approximation Sn (n an even positive in-

teger) for an arbitrary function f by∫ b

a
f (x)dx ≈ Sn

=
b−a

3n

(
f (a)+ f (b)+4

n/2

∑
i=1

f
(

a+(2i−1)
b−a

n

)

+2
−1+n/2

∑
i=1

f
(

a+2i
b−a

n

))
ăe error bound for Simpson’s rule is given by∣∣∣∣Sn−

∫ b

a
f (x)dx

∣∣∣∣≤ K
(b−a)5

180n4

where K is any number such that
∣∣∣ f (4)(x)∣∣∣ ≤ K for all x ∈ [a,b]. In

particular, Simpson’s rule is exact for integrals of polynomials of de-
gree at most 3 (because the fourth derivative of such a polynomial is
identically zero).
Toapproximate

∫ b
a f (x) dxusing Simpson's rule

1. Place the insert point in the expression
∫ b

a f (x) dx.

2. Choose Compute>Calculus>Approximate Integral.

3. In the dialog that appears, select Simpson and specify Number
of Subintervals.
Or

1. Place the insert point in the expression f (x).

2. Choose Compute>Calculus>Approximate Integral.

3. In the dialog, select Simpson, specify the number of Subinter-
vals, and specify Lower Bound and Upper Bound.
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For the following output, select Simpson and specify 10 Subinter-
vals in the dialog that appears.

Compute> Calculus> Approximate Integral∫ π
0 xsinxdx Approximate integral is

1
30 π

(
2

4
∑

i11=1

1
5 πi11 sin 1

5 πi11 +4
5
∑

i11=1

1
10 π (2i11−1)sin 1

10 π (2i11−1)

)
For the following output, select Simpson, specify 10 Subintervals,

and type 0 as Lower Bound and 3.14159 as Upper Bound.

Compute> Calculus> Approximate Integral

xsinx Approximate integral is 0.20944
4
∑

i12=1
0.62832i12 sin0.62832i12+

0.41888
5
∑

i12=1
(0.62832i12−0.31416)sin(0.62832i12−0.31416)+ 8.7299×10−7

Compare these results by evaluating numerically:

Compute> Evaluate Numeric

1
30 π

(
2

4
∑

i11=1

1
5 πi11 sin 1

5 πi11 +4
5
∑

i11=1

1
10 π (2i11−1)sin 1

10 π (2i11−1)

)
≈ 3.1418

0.20944
4
∑

i12=1
0.62832i12 sin0.62832i12

+0.41888
5
∑

i12=1
(0.62832i12−0.31416)sin(0.62832i12−0.31416)

+8.7299×10−7 ≈ 3.1414∫ π
0 xsinxdx≈ 3.1416

Example To đnd the number of subdivisions required to approximate∫ 1
0 e−x2

dx using Simpson’s rule with an error of at most 10−5, you
need to đnd an upper bound for the fourth derivative of e−x2

on the
interval [0,1]. Oneway you cando this is byplotting the fourthderiva-
tive on the interval [0,1]. Deđne f (x) = e−x2

. ăen evaluate the ex-
pression f (4)(x)

f (4)(x) = 12e−x2 −48x2e−x2
+16x4e−x2
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and with the insert point in this expression, choose Compute > Plot
2D> Rectangular. Fourth derivative

0.2 0.4 0.6 0.8 1.0

­5

0

5

10

x

yFrom the graph, you can see that f (4)(x) has amaximum value on this
interval of f (4)(0) = 12. Solve the inequality

12
(1−0)5

180n4 ≤ 10−5

to đnd the potential solutions{
n≤−10

3

√
3 4√6

}
,{n = 0} ,

{
10
3

√
3 4√6≤ n

}
Since n must be an even positive integer, and also n ≥ 10

3

√
3 4√6 =

9.036, we take n = 10. Calculating,

S10≈
1

30
+

1
30

e−1+
2

15

5

∑
i=1

e−(
1
5 i− 1

10)
2
+

1
15

4

∑
i=1

e−
1

25 i2 ≈ 0.7468249483

Direct evaluation using Evaluate Numeric yields∫ 1

0
e−x2

dx≈ 0.7468241328

and the approximation just computed is indeed within the speciđed
margin of error since

|0.7468241328−0.7468249483|= 8.155×10−7 < 10−5

Numerical Integration
Many integrals (such as

∫ 1
0 e−x2

dx and
∫ π

0
sin t

t dt) cannot be eval-
uated exactly, but you can obtain numerical approximations by choos-
ing Evaluate Numeric. See page 508 for information on changing set-
tings that affect these approximations.

Compute> Evaluate Numeric∫ 1
0 e−x2

dx≈ 0.7468241328∫ π
0

sin t
t

dt ≈ 1.851937052
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Example Given a curve y = f (x), the arc length between x = a and
x = b is given by the integral

∫ b

a

√
1+( f ′(x))2dx

For example, given f (x)= xsinx, whichhas derivative f ′(x)= sinx+
xcosx, you can đnd the length of the arc between x = 0 and x = π
by applying EvaluateNumeric. Integrals associated with arc lengths of
curves can almost never be evaluated exactly.

Compute> Deönitions> New Deönition
f (x) = xsinx

Compute> Evaluate∫ π
0

√
1+( f ′(x))2dx =

∫ π
0

√
xsin(2x)− cos2 x+ x2 +2dx

Compute> Evaluate Numeric∫ π
0

√
xsin(2x)− cos2 x+ x2 +2dx≈ 5.04040692

Curves in the plane or three-dimensional space can be represented
parametrically.

Example In the following we compute the arc length of the circular
helix (cosθ ,sinθ ,θ) for 0 ≤ θ ≤ 2π and then plot a view of this
helix.

Compute> Deönitions> New Deönition
x = cosθ
y = sinθ
z = θ

Compute> Evaluate Numeric∫ 2π

0

√(
dx
dθ

)2

+

(
dy
dθ

)2

+

(
dz
dθ

)2

dθ ≈ 8.8858
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Compute> Plot 3D> Rectangular
(cosθ ,sinθ ,θ)

10

x
1

y

2

­1­1

z
4

6

(cosθ ,sinθ ,θ)

Tip
Rotate such plots on your screen with your
mouse to better visualize the curve.

Example In polar coordinates arc length is given by the integral

∫ β

α

√
r2 +

(
dr
dθ

)2

dθ

Following are the plot and arc length for the spiral r = θ with 0 ≤
θ ≤ 6.2832.

Compute> Plot 2D> Polar
(θ ,θ) (Plot Interval 0≤ θ ≤ 6.2832)

­2 2 4 6

­4

­2

2

x

y

Compute> Deönitions> New Deönition
r = θ

Compute> Evaluate∫ 2π
0

√
r2 +

( dr
dθ
)2

dθ = 1
2 arcsinh(2π)+π

√
4π2 +1
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Compute> Evaluate Numeric
1
2 arcsinh(2π)+π

√
4π2 +1≈ 21.25629415

Visualizing Solids of Revolution
Problems of đnding volumes and surface areas can be simpliđed by

visualizing the solid.

Rectangular Coordinates
Assume the curve y = 1− x2 is rotated about the x-axis to form a

solid. First, sketch the curve.

Compute> Plot 2D> Rectangular
1− x2

­1.0 ­0.5 0.0 0.5 1.0

0.5

1.0

x

y

ăen use a tube plot to visualize the surface.

Compute> Plot 3D> Tube (Radius: 1− x2)
(0,x,0)

­1

x

1.0

0.5

z 0.0

0.50.0

y
11.0

­1.0
­1.0 ­0.5

­0.5

0
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ăe volume is given by the integral

∫ 1

−1
πy2 dx = π

∫ 1

−1

(
1− x2)2

dx

Compute> Evaluate
π
∫ 1
−1
(
1− x2

)2 dx = 16
15 π

ăe surface area is given by

∫
2πyds = 2π

∫ 1

−1

(
1− x2)√1+

(
d
dx

(1− x2)

)2

dx

Compute> Evaluate

2π
∫ 1
−1
(
1− x2

)√
1+
( d

dx (1− x2)
)2

dx = 2π
(

7
16

√
5− 17

32 ln
(
−2+

√
5
))

Compute> Evaluate Numeric
2π
(

7
16

√
5− 17

32 ln
(
−2+

√
5
))
≈ 10.96548466

Consider theproblemof rotating the circlex2+(y−2)2 = 1 about
the x-axis. We đrst sketch the circle.

Compute> Plot 2D> Rectangular
(cos t,2+ sin t)

­1 0 1

1

2

3

To rotate this circle about the x-axis, use a tube plot with spine
(2cos t,0,2sin t) and radius 1.
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Compute> Plot 3D> Tube (Radius: 1)
(2cos t,0,2sin t)

­2

x
0

2

y

­1
1

­2

z 0

2

Adifferential of volume is equal to (2πy)2xdy and hence the vol-
ume is equal to the integral

4π
∫ 3

1
y
√

1− (y−2)2 dy

Compute> Evaluate

4π
∫ 3

1 y
√

1− (y−2)2 dy = 4π2

ăe result 4π2 is intuitive because the volume is generated by ro-
tating a circle of area π and the center of the circle travels a distance of
4π .

Parametric Equations

To đnd the volume generated by rotating the region bounded by
the x-axis and one cycle of the curve x = t + sin t , y = 1− cos t , we
đrst draw the curve.
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Compute> Plot 2D> Rectangular
(t− sin t,1− cos t)

0 1 2 3 4 5 6
0

1

2

x

y

Use a tube plot to visualize the solid of revolution.

Compute> Plot 3D> Tube (Radius: 1− cot t)
(0, t− sin t,0)

­2
­1

x

2

4
2

y 6 2

0
­2
­1
0z
1

1
0

To compute the volume, note that a differential of volume is given
by πy2 dx and hence the volume is∫ 2π

0
πy2 dx = π

∫ 2π

0
(1− cos t)2 (1− cos t) dt

= π
∫ 2π

0
(1− cos t)3 dt

Compute> Evaluate
π
∫ 2π

0 (1− cos t)3 dt = 5π2

Polar Coordinates
Tođnd the volumeof the solid generated by rotating r = 1−cosθ

(0≤ θ ≤ π) about thex-axis, wenote thatx= r cosθ =(1− cosθ)cosθ
and y = r sinθ = (1− cosθ)sinθ .

259



i
i

“Compute60” — 2011/12/20 — 14:27 — page 260 — #270 i
i

i
i

i
i

Chapter 7 | Calculus

Compute> Plot 2D> Polar
1− cosθ

­2.0 ­1.5 ­1.0 ­0.5 0.0

0.5

1.0

x

y

Use a tube plot to visualize the surface of revolution.

Compute> Plot 3D> Tube (Radius: (1− cos t)sin t)
(0,(1− cos t)cos t,0)

1

z ­1

0

­2
­1

y 0 1

0

x

­1

Sequences and Series
A sequence can be thought of as an inđnite list, and a series as a

sum of the terms of a sequence.

Sequences
A sequence {an}∞

n=1 is a function whose domain is the set of posi-
tive integers. Calculate limits of sequences by selecting an expression
such as limn→∞

(
1+ 1

n

)n and choosing Compute > Evaluate, or by
deđning an, writing limn→∞ an, and choosing Compute> Evaluate.

Compute> Evaluate
limn→∞

(
1+ 1

n

)n
= e
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ăe terms of the sequence can be deđned as function values, with
the subscript as function argument (see page 107).

Todeđne the sequencean =
(
1+ 1

n

)n

1. With the insert point in the equation an =
(
1+ 1

n

)n, choose
Compute>Deđnitions>New Deđnition.

2. In the Interpret Subscript dialog that appears, check Subscript
is function argument and choose OK.

Compute> Deönitions> New Deönition
(check Subscript is function argument)
an =

(
1+ 1

n

)n

Compute> Evaluate
limn→∞ an = e

Tocompute several terms of a sequence
1. With the insert point in mathematics, type seq. (It should turn

gray.)

2. Type the number of terms in the form n = 1..4 as a subscript,
to obtain seqn=1..4

3. Type the general expression and choose Evaluate.

Compute> Evaluate
seqn=1..4

((
1+ 1

n

)n
)
= 2, 9

4 ,
64
27 ,

625
256

seqn=1..4

((
1.0+ 1

n

)n
)
= 2.0,2.25,2.3704,2.4414

seqx=1..5 cosx = cos1,cos2,cos3,cos4,cos5

A sequence such as
{(

1+ 1
n

)n
}∞

n=1
can be visualized graphically

by plotting the expression
(
1+ 1

n

)n at integer values of n. You can
generate this đgure by plotting

(
1+ 1

n

)n, then revising the Items Plot-
ted page so that the Plot Style is Point, the Point Marker is Circle, the
Plot Interval is 1 to 50, and the Sample Size is 50.
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Compute> Plot 2D> Rectangular(
1+ 1

n

)n

0 10 20 30 40 50
0

1

2

x

y

Finite sequences
For further information on önite sequences,
see page 28.

ăis plot indicates that limn→∞
(
1+ 1

n

)n ≈ 2.7. Indeed, Evaluate
yields e and Evaluate Numeric produces e≈ 2.718281828.

Series
ăe partial sums of the series ∑∞

k=1 ak are the đnite sums sn =

∑n
k=1 ak. ăese partial sums form a sequence {sn}. If limn→∞ sn = s

exists, then s is called the sum of the series ∑∞
k=1 ak. To sum a series,

place the insert point in the series and choose Evaluate. (See page 41
for details on entering the symbols ∑∞

k=1 ak.)

Compute> Evaluate
∞
∑

n=1
(0.99)n = 99.0

∞
∑

n=0

20n

n!
= e20

∞
∑

n=1

(−1)n

n =− ln2
∞
∑

n=1

1
n2 = 1

6 π2

∞
∑

n=1

1
n3 = ζ (3)

∞
∑

n=1
sinnπ = undefined

Occasionally, a result is obtained that may be obscure, such as the

response to
∞
∑

n=1

1
n3 . ăis series and the values of the zeta function ζ (·)

can be estimated numerically.

Compute> Evaluate Numeric
∞
∑

n=1

1
n3 ≈ 1.202056903

ζ (3)≈ 1.202056903

To suma series in a form similar to∑∞
n=1 an, enter an equation such

as an = n2

2n and choose Compute > Deđnitions > New Deđnition.
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Check Subscript is function argument in the Interpret Subscript box
that opens.

Compute> Deönitions> New Deönition
(Subscript is function argument)
an =

n2

2n

Compute> Evaluate
∑∞

n=1 an = 6

Ratio Test
Aseries∑∞

n=1 an conĂerges absolutely if∑∞
n=1 |an| converges, inwhich

case the series ∑∞
n=1 an also converges. ăe ratio test states that a series

∑∞
n=1 an converges absolutely (and therefore converges) if

lim
n→∞

∣∣∣∣an+1

an

∣∣∣∣= L < 1

To apply the ratio test to the series ∑∞
n=1

n2

2n , deđne an = n2

2n and
compute lim

n→∞

an+1

an
to đnd if it is less than 1.

Compute> Deönitions> New Deönition
(Subscript is function argument)
an =

n2

2n

Compute> Evaluate

lim
n→∞

an+1

an
=

1
2

ăus, L= 1
2 , which is less than1, so the series converges absolutely.

Root Test
ăe root test states that a series ∑∞

n=1 an converges absolutely (and
therefore converges) if

lim
n→∞

n
√
|an|= L < 1

To apply the root test to the series ∑∞
n=1

n2

2n , deđne an = n2

2n and
compute lim

n→∞
n
√
|an| to đnd if it is less than 1.
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Compute> Deönitions> New Deönition
(Subscript is function argument)
an =

n2

2n

Compute> Evaluate

lim
n→∞

n
√
|an|=

1
2

ăus,L= 1
2 , which is less than1, showing that this series converges

absolutely.

Integral Test
ăe integral test states that a series ∑∞

n=1 an converges absolutely
if there exists a positive decreasing function f such that f (n) = |an|
for each positive integer n and∫ ∞

1
f (x)dx < ∞

To verify convergence of the series ∑∞
n=1

n2

2n using the integral test,

deđne f by f (x) = x2

2x , compute
∫ ∞

1

x2

2x dx and determine if it is đnite.

Compute> Deönitions> New Deönition
f (x) = x2

2x

Compute> Evaluate, Compute> Evaluate Numeric∫ ∞

1

x2

2x dx = (ln4+ln2 2+2)
2ln3 2

≈ 5.805497209

ăus, this integral is đnite. (Although for f (x) = x2

2x , it is true that
f (1)< f (2)< f (3), you can verify that f is decreasing for x > 3. In
fact,

f ′(x) =
2
2x x− 1

2x x2 ln2

is positive only on the interval 0 < x < 2
ln2 = 2.8854, so f is decreas-

ing on 3 < x < ∞. Since convergence of a series depends on the tail
end of the series only, it is sufficient that the sequence of terms be even-
tually decreasing.)
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Maclaurin Series
ăe Maclaurin series of a function f is the series

∞

∑
n=0

f (n)(0)
n!

xn

where f (n)(0) indicates the nth derivative of f evaluated at 0. It is a
power series expanded about x = 0.
Toexpand a function f (x) in aMaclaurin series

1. Place the insert point in the expression f (x).

2. Choose Compute> Power Series.

3. Specify Variable, Center, and Order.

4. Choose OK.

With f (x) = sinx
x and 10 terms, the result is as follows.

Compute> Power Series (Variable x; Center 0; Order 10)
sinx

x
Series expansion 1− 1

6 x2 + 1
120 x4− 1

5040 x6 + 1
362880 x8 +O

(
x10
)

ăe O
(
x10
)
term indicates that all the remaining terms in the se-

ries contain at least x10 as a factor.
Plot 2D provides an excellent visual comparison between a func-

tion and an approximating polynomial.

Compute> Plot 2D> Rectangular
sinx

x
1− 1

6 x2 + 1
120 x4

­5 ­4 ­3 ­2 ­1 1 2 3 4 5

0.5

1.0

1.5

2.0

x

y
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To determine which graph corresponds to which equation, evalu-
ate one of the expressionswhere the graphs show some separation. For
example, sin4

4 ≈−0.1892006238, and hence the graph of sinx
x is the

one that is negative at x = 4.
You can deđne a generic function and reproduce the general for-

mula for a power series.

Compute> Deönitions> New Deönition
f (x)

Compute> Power Series
(Variable x, Center 0, Order 5)
f (x) Series expansion f (0)+ x f ′ (0)+ 1

2 x2 f ′′ (0)+ 1
6 x3 f (3) (0)+ 1

24 x4 f (4) (0)+O
(
x5
)

ăe following are additional examples of Maclaurin series expan-
sions.

Compute> Power Series (Variable x; Center 0; Order 7,10,7 resp.)
ex Series expansion 1+ x+ 1

2 x2 + 1
6 x3 + 1

24 x4 + 1
120 x5 + 1

720 x6 +O
(
x7
)

sinx Series expansion x− 1
6 x3 + 1

120 x5− 1
5040 x7 + 1

362880 x9 +O
(
x10
)

ex sinx Series expansion x+ x2 + 1
3 x3− 1

30 x5− 1
90 x6− 1

630 x7 +O
(
x8
)

Remember that output can be copied and pasted (with ordinary
word-processing tools) to create input for further calculations. In par-
ticular, select and delete the +O(xn) expression to convert the series
into a polynomial. It is reassuring to note that, if the đrst few terms of
the Maclaurin series for ex are multiplied by the đrst few terms of the
Maclaurin series for sinx, then the result is the same as the đrst few
terms of the Maclaurin series for ex sinx.

Compute> Expand(
1+ x+ 1

2 x2 + 1
6 x3 + 1

24 x4 + 1
120 x5

)(
x− 1

6 x3 + 1
120 x5

)
= 1

14400 x10 + 1
2880 x9− 1

360 x7− 1
90 x6− 1

30 x5 + 1
3 x3 + x2 + x

Taylor Series
ăe Maclaurin series is a special case of the more general Taylor

series. ăe Taylor series of f expanded about x = a is given by

∞

∑
n=0

f (n)(a)
n!

(x−a)n

and hence is expanded in powers of x−a and centered about a.
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Toexpand a function f (x) in aTaylor series in powers of x−a
1. Place the insert point in the expression f (x).

2. Choose Compute> Power Series.

3. Specify Variable x, Center a, and Order.

4. Choose OK.

To đnd the Taylor series of lnx expanded about x = 1, choose
Power Series. In the dialog box, type the variable x, type the center
1, and select the desired order of the approximating polynomial.

Compute> Power Series (Variable x; Center 1; Order 5)
lnx Series expansion x−1− 1

2 (x−1)2 + 1
3 (x−1)3− 1

4 (x−1)4 + 1
5 (x−1)5 +O

(
(x−1)6

)
A comparison between lnx and the polynomial

(x−1)− 1
2
(x−1)2 +

1
3
(x−1)3− 1

4
(x−1)4

is illustrated graphically in the following đgure. Note how closely the
polynomial đts the graph of lnx in the neighborhood of the point x =
1.

Compute> Plot 2D> Rectangular
lnx
(x−1)− 1

2 (x−1)2 + 1
3 (x−1)3− 1

4 (x−1)4

0.5 1.0 1.5 2.0 2.5

­2

­1

0

1

x

y

dashed line: polynomial
solid line: lnx
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Multivariable Calculus
Multivariable calculus extends the fundamental ideas of differen-

tial and integral calculus to functions of several variables. ăe Com-
pute menu commands that have been described for one-variable cal-
culus easily adapt to functions of several variables. We look đrst at
the general area of optimization, which calls upon many of the ideas
of differential calculus. Following that we will brieĔy consider Taylor
polynomials in two variables and total differentials, and then describe
the general approach for working with iterated integrals.

Optimization
Optimizationof functions of several variables requires special tech-

niques. ăe example immediately following demonstrates a direct ap-
proach, locating pairs where the partial derivatives are zero. Also see
Lagrange multipliers (page 271) and Compute > Calculus > Find
Extrema (page 220).

Extreme Values on a Surface
To đnd all candidates for the extreme values of a function such as

f (x,y) = x3−3xy+ y3, it is sufficient to locate all pairs (x,y) where
both partial derivatives are zero. Since only real solutions are perti-
nent, it is useful to assume the variables represent real numbers.

Compute> Evaluate
assume(x, real) = R
assume(y, real) = R

Compute> Deönitions> New Deönition
f (x,y) = x3−3xy+ y3

Compute> Solve> Exact
∂
∂ x f (x,y) = 0
∂
∂y f (x,y) = 0

, Solution: [x = 1,y = 1] , [x = 0,y = 0]

ăus the only candidates for real extreme values are (0,0) and
(1,1). You can identify the nature of these two points using the sec-
ond derivative test :[

Dxx f (x,y)Dyy f (x,y)− (Dxy f (x,y))2
]

x=0,y=0
=−9 < 0
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hence (0,0) represents a saddle point; and

[
Dxx f (x,y)Dyy f (x,y)− (Dxy f (x,y))2

]
x=1,y=1

= 27 > 0

and [Dxx f (x,y)]x=1,y=1 = 6 > 0

so the surface has a local minimum at (1,1).

You can visualize the local minimum at (1,1) by generating a plot
of the surface. To create the following plot, with the insert point in
the expression x3−3xy+y3, choose Compute> Plot 3D> Rectan-
gular. In the Items Plotted page of the Plot Properties dialog, choose
Hidden Line and Mesh. Choose Variables and Intervals and set the
Plot Intervals to−1≤ x≤ 2 and−1≤ y≤ 2. On the Axes page, set
Axes Type to Framed.

Compute> Plot 3D> Rectangular
x3−3xy+ y3

­1 x

1
2

y 0
­1

0
1

2
­5

0
z 5

10

ăe level curve x3−3xy+y3 = 0 goes through the point (0,0,0).
For a better view of this level curve, make a 2Dplot of x3−3xy+y3 =
0 and add the level curve x3−3xy+ y3 =−0.5 to the plot.
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Compute> Plot 2D> Implicit
x3−3xy+ y3 = 0
x3−3xy+ y3 =−0.5

­1 0 1 2
­1

0

1

2

x

y

ăe thick curve is the level curve at 0 and the thin curves are com-
ponents of the level curve at −0.5. ăis view gives an idea of where
the z-values are positive and where they are negative. Note that the
z-values on the surface z = x3−3xy+ y3 are negative inside the loop
in the đrst quadrant and in the lower leĕ corner of the xy-plane.

Extreme values of differentiable functions such as x3− 3xy+ y3

can also be found choosing Compute > Calculus > Find Extrema.
In general, each application of Find Extrema reduces the number of
variables by one and rephrases the problem in one less variable. Using
this method with two or more variables requires multiple appropriate
applications of the command.

Choose Compute > Calculus > Find Extrema for the following
examples. Use Ĕoating point coefficients for these problems to obtain
numeric solutions. It is convenient to restrict the computations to real
variables.

Compute> Evaluate
assume(x, real) = R
assume(y, real) = R

Compute> Calculus> Find Extrema (Variable y)
x3−3xy+ y3 Candidate(s) for extrema:

{
x3−2x

3
2 ,x3 +2x

3
2

}
,

at {[y =
√

x] , [y =−
√

x]}

Note that for y = ±
√

x, the expression x3− 3xy+ y3 simpliđes
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to x3∓2x
3
2 . To đnd the extreme values, apply the command again to

the simpliđed expressions.

Compute> Calculus> Find Extrema (Variable y)
x3−2x

3
2 Candidate(s) for extrema: {−1,0} , at {[x = 0] , [x = 1]}

x3 +2x
3
2 Candidate(s) for extrema: {0} , at {[x = 0]}

ăe solution y =
√

x yields the points (0,0) and (1,1), and y =
−
√

x yields the point (0,0). To determine the nature of these two
critical points, use the second derivative test (page 268).

Lagrange Multipliers
You can use Lagrange multipliers to đnd constrained optima. To

đnd extreme values of f (x,y) subject to a constraint g(x,y) = k, it is
sufficient to đnd all values of x, y, and λ such that

∇ f (x,y) = λ∇g(x,y)

and g(x,y) = k where ∇ is the gradient operator

∇ f (x,y) =
(

∂ f
∂x

(x,y),
∂ f
∂y

(x,y)
)

ăe variable λ is called the Lagrange multiplier.

Example To đnd x and y whose sum is 5 and whose product is as large
as possible

1. Deđne f (x,y) = xy and g(x,y) = x+ y.

2. Solve the equation ∇ f (x,y) = λ∇g(x,y) subject to g(x,y) =
5.

Compute> Deönitions> New Deönition
f (x,y) = xy g(x,y) = x+ y

Compute> Evaluate

∇ f (x,y) =

 y
x
0

 ∇g(x,y) =

 1
1
0



Compute> Solve> Exact
y = λ
x = λ

x+ y = 5
, Solution :

[
x = 5

2 ,y =
5
2 ,λ = 5

2

]
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Example Optimization problems may require numerical solutions in
given search intervals.

Compute> Evaluate

∇(x+2y) =

 1
2
0

 ∇(yex + xey) =

 ey + yex

ex + xey

0


Compute> Solve> Numeric
1 = λ (yex + ey)
2 = λ (ex + xey)

yex + xey = 5
x ∈ (0,10)
y ∈ (0,10)

λ ∈ (−5,5)

, Solution : [x≈ 1.6665,y≈ 0.45056,λ ≈ 0.25290]

For f (x,y) = x+2y and g(x,y) = yex+xey, these numbers give

g(1.6665,0.45056) ≈ 5.0001
f (1.6665,0.45056) ≈ 2.5676

ăepoint (1.6665,0.45056) gives a possible extremevalue for f (x,y)
satisfying the constraint g(x,y) = 5.

Taylor Polynomials in Two Variables
Let z be a function of two variables. ăe second-degree Taylor

polynomial of z at (a,b) is given by

T2 (x,y) = z(a,b)+Dxz(a,b)(x−a)+Dyz(a,b)(y−b)

+ 1
2 Dxxz(a,b)(x−a)2 +Dxyz(a,b)(x−a)(y−b)

+ 1
2 Dyyz(a,b)(y−b)2

Toevaluate a partial derivative of a function z at (a,b)
1. Evaluate the partial derivative at (x,y) using an expression such

as
∂
∂x z(x,y), Dxz(x,y), ∂ 2

∂x2 z(x,y), or Dxyz(x,y).

2. Evaluate at (a,b) using square brackets with the subscript x =
a,y = b.

ăese steps can be combined into a single step:
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Compute> Evaluate[
∂
∂x

(
x2y
)]

x=1,y=2
= [4]

To đnd the second-degree Taylor polynomial of z = 1
1+x2+y2 at

(0,0), đrst deđne the function z(x,y), then compute the second de-
gree Taylor polynomial as follows:

Compute> Deönitions> New Deönition
z(x,y) = 1

1+x2+y2

Compute> Evaluate
z(0,0) = 1 [Dxz(x,y)]x=0,y=0 = [0]
[Dyz(x,y)]x=0,y=0 = [0] [Dxxz(x,y)]x=0,y=0 = [−2]

[Dxyz(x,y)]x=0,y=0 = [0] [Dyyz(x,y)]x=0,y=0 = [−2]

ăese steps yield the second degree Taylor polynomial

T2 (x,y) = 1− x2− y2

ăe following plot has Plot Intervals−0.5≤ x≤ 0.5 and−0.5≤
y ≤ 0, Turn 75 and Tilt 75. ăis cutaway plot shows how well the
second-degreeTaylor polynomial (the lower surface)matches the func-
tion z near (0,0).

Compute> Plot 3D> Rectangular
1

1+x2+y2

1− x2− y2 (Drag to the plot.)

­0.4 x

0.2
y

­0.2 0.4
0.0­0.2

0.6

0.0

0.8
z

­0.4

1.0
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Total Differential
To compute the total differential of a function of two variables,

deđne a function u(x,y), represent each differential by a Math Name
(du, dx, and dy) so that it will be treated as a variable. ăen evaluate
the expression

du =
∂
∂x

u(x,y)dx+
∂
∂y

u(x,y)dy

A similar procedure produces the total differential of a function of
three variables.

Compute> Deönitions> New Deönition
u(x,y) = x3y2

Tocreate the grayed functionnamesdu,dx, anddy
1. Choose Insert>Math Objects>Math Name.

2. Type the function name in the Name box and choose OK.

Compute> Evaluate
du = ∂

∂x u(x,y)dx+ ∂
∂y u(x,y)dy = 3x2y2 dx+2x3ydy

Iterated Integrals
You can enter and evaluate iterated integrals. If a ≤ b, f (x) ≤

g(x) for all x ∈ [a,b], and k(x,y) ≥ 0 for all x ∈ [a,b] and all y ∈
[ f (x),g(x)], then the iterated integral∫ b

a

∫ g(x)

f (x)
k(x,y)dydx

can be interpreted as the volume of the solid bounded by the three
inequalities a≤ x≤ b, f (x)≤ y≤ g(x), and 0≤ z≤ k(x,y).

Example Find the volume of the solid under the surface z = 1+ xy
and above the triangle with vertices (1,1), (4,1), and (3,2).

1. Plot the triangle with the given vertices.

2. Find the equations of the bounding lines:
y = 1

2 x+ 1
2

y = 5− x
y = 1
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3. Solve for x in terms of y: x = 2y−1
x = 5− y

0 1 2 3 4
0

1

2

x

y
4. Set up and evaluate an iterated integral:

∫ 2
1
∫ 5−y

2y−1 (1+ xy) dxdy = 55
8

ăe solid can be viewed as a parameterized surface.
Toview the integral

∫ b
a
∫ g(x)

f (x) k(x,y)dydx as the volumeof a solid
1. Plot the expression (x, f (x)(1− s)+g(x)s,k (x, f (x)(1− s)+g(x)s)).

2. Revise the plot, setting the intervals toa≤ x≤ b and0≤ s≤ 1.

3. Drag eachof the expressions (x, f (x) ,sk (x, f (x))), (x,g(x) ,sk (x,g(x))),
(a,y,sk (a,y)), and (b,y,sk (b,y)) to the plot frame.

4. Revise theplot, setting the intervals for the fourth itemto f (a)≤
y≤ g(a),0≤ s≤ 1 and the intervals for theđĕh itemto f (b)≤
y≤ g(b) and 0≤ s≤ 1.

Example In the following, the x- and y-coordinates are interchanged
to view the integral

∫ 2
1
∫ 5−y

2y−1 (1+ xy) dxdy.

Compute> Plot 3D> Rectangular (Intervals: 0≤ s≤ 1, 1≤ x≤ 4, 1≤ y≤ 2)
((5− y)(1− s)+(2y−1)s,y,1+ y((5− y)(1− s)+(2y−1)s))
(2y−1,y,s(1+ y(2y−1)))
(5− y,y,s(1+ y(5− y)))
(x,1,s(1+ x))
(Revise the plot by changing the intervals for the fourth item to 1≤ x≤ 4, 0≤ s≤ 1.)

x

3 4

y

2
0

2

1

z 4

6

21
00
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Here are two examples of iterated integrals.

Compute> Evaluate, Compute> Evaluate Numeric∫ 1
0
∫ x

0 x2 cosydydx = cos1+2sin1−2≈ 0.22324∫ 3
0
∫ x/3

0 ex2
dydx = 1

6 e9− 1
6 ≈ 1350.3

Following is an example illustrating a method for reversing the or-
der of integration.

Example Attempting to evaluate the double integral∫ 1

0

∫ 1

√
y

√
x3 +1dxdy

exactly leads to frustration. However, you can reverse the order of in-
tegration by looking carefully at the region of integration in the plane.

0.0 0.5 1.0
0.0

0.5

1.0

x

y

ăis region is bounded above by y = x2 and below by y = 0. ăe
new integral is ∫ 1

0

∫ x2

0

√
x3 +1dydx

ăis double integral can be evaluated directly. You can gain some in-
sight by iterated integration. ăe inner integral is just∫ x2

0

√
x3 +1dy = x2

√
x3 +1

You can integrate the resulting outer integral
∫ 1

0 x2
√

x3 +1dx by
choosingCompute>Calculus>Change Variable, say with u = x3+
1. ăen choosingCompute>Evaluate andCompute>EvaluateNu-
meric, yields∫ 1

0

√
(x3 +1)x2 dx =

∫ 2

1

1
3
√

udu =
4
9

√
2− 2

9
≈ 0.4063171388

For double and triple indeđnite integrals you can use either re-
peated integral signs or the double and triple integrals available in the
Operators dialog. Analogous to single indeđnite integrals, for which
you must add an arbitrary constant to the result of computing an in-
deđnite integral, for a double integral

∫∫
f (x,y) dxdy you must add

an arbitrary function of the form φ (x)+ψ (y). For a triple integral∫∫∫
f (x,y,z) dxdydz youmust add an arbitrary function of the form

φ (x,y)+ψ (y,z)+λ (x,z).
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Toenter and evaluate a double or triple integral
1. Choose Insert>Math Objects>Operator.

2. Select the double or triple integral and choose OK.

3. Enter the function and the differentials. (ăe latter are neces-
sary.)

4. With the insert point in the integral, choose Compute> Eval-
uate.

5. For a double integral, add an arbitrary function of the form
φ (x) + ψ (y); for a triple integral, add φ (x,y) + ψ (y,z) +
λ (x,z).

Compute> Evaluate (add “arbitrary functions”)∫∫
xydxdy = 1

4 x2y2+ φ (x)+ψ (y)∫∫
xsinxcosydxdy = (sinx− xcosx)siny+ φ (x)+ψ (y)∫∫∫
xy2zdxdydz = 1

12 x2y3z2 +φ (x,y)+ψ (y,z)+λ (x,z)

Exercises
1. Verify the formula d

dx

(
x8
)
= 8x7 by startingwith the deđnition

of derivative and choosing submenu items such as Expand and
Simplify.

2. Use Newton’s method on the function f (x) = x2 +1, starting
with x0 = 0.5. What conclusions can you draw?

3. Find the equation of one line that is tangent to the graph of

f (x) = x(x−1)(x−3)(x−6)

at two different points.

4. For 0 < k < 1, the elliptic integral E =
∫ π/2

0

√
1− k sin2 tdt

has no elementary solution. Use a series expansion of the inte-
grand to estimate E .

5. Find all the solutions to xy = yx for unequal positive integers x
and y.
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6. Blood Ĕowing through an artery Ĕows fastest at the center of
the artery, and slowest near thewalls of the arterywhere friction
is a factor. In fact, the velocity is given by the formula v(r) =
α(R2− r2), where α is a constant, R is the radius of the artery,
and r is the distance from the center.

Set up an integral that gives the total blood Ĕow through an
artery. Show that if an artery is constricted to one-half of its
original radius, the blood Ĕow (assuming constant blood pres-
sure) is reduced to 1

16 of its original Ĕow.

7. ăe mass of an object traveling at a velocity v with rest mass m0
is given by

m = m0

(
1− v2

c2

)−1/2

where c is the speed of light. Use a Maclaurin series expansion
to show the increase in mass at low velocities.

8. Evaluate
∫

2x cosbxdx.

9. Evaluate
∫ π
−π

1+ sinx

(x− cosx)2 dx. Hint: Don’t try to do it directly.

10. Evaluate limh→0+
∫ ∞

0 sin(x1+h)dx.

11. ăe Fundamental ăeorem of Calculus says that if f is contin-
uous on a closed interval [a,b], then

a. If g is deđned by g(x) =
∫ x

a f (t)dt for x ∈ [a,b], then
g′(x) = f (x), and

b. If F is any antiderivative of f , then
∫ b

a f (x)dx = F(b)−
F(a).

Demonstrate that these twoconditionshold for eachof the three
functions f (x) = x3, f (x) = xex, and f (x) = sin2 xcosx.

12. ăe arithmetic-geometric mean of two positive numbers a > b
was deđned by Gauss as follows. Let a0 = a and b0 = b. Given
an and bn, let an+1 be the arithmetic mean of an and bn, and
bn+1 the geometric mean of an and bn:

an+1 =
an +bn

2
and bn+1 =

√
anbn
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Usingmathematical induction, you can show that an > an+1 >
bn+1 > bn and deduce that both series {an} and {bn} are con-
vergent, and, in fact, that limn→∞ an = limn→∞ bn.
Compute the arithmetic-geometric mean of the numbers 2 and
1 to đve decimal places.

13. Two numbers x and y are chosen at random in the unit interval
[0,1]. What is the average distance between two suchnumbers?

Solutions
1. By deđnition,

d
dx

(
x8) = lim

h→0

(x+h)8− x8

h

= lim
h→0

8x7h+28x6h2 + · · ·+28x2h6 +8xh7 +h8

h

= lim
h→0

(
8x7 +28x6h+ · · ·+28x2h5 +8xh6 +h7

)
= 8x7

2. Deđning g by g(x) = x− f (x)/ f ′(x), chooseCompute>Cal-
culus> Iterate to obtain

0.5
−0.75

0.29167
−1.5684
−0.4654
0.84164


If this result seems to be headed nowhere, it is doing so for good
reason. ăe function f is always positive, so it has no zeroes.
Newton’smethod is searching for something that does not exist.

3. It is sufficient to đnd three numbers a, b, and m that satisfy
f ′(a) = m, f ′(b) = m, and f (b)− f (a)

b−a = m. Put these three
equations inside a 3× 1 matrix and choose Compute > Solve
> Exact to get several solutions, including the real solutions[

a =
5
2
− 1

2

√
21,b =

5
2
− 1

2

√
21,m =−8

]
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Chapter 7 | Calculus[
a =

5
2
− 1

2

√
21,b =

1
2

√
21+

5
2
,m =−8

]
[

a =
1
2

√
21+

5
2
,b =

5
2
− 1

2

√
21,m =−8

]
[

a =
1
2

√
21+

5
2
,b =

1
2

√
21+

5
2
,m =−8

]
[

a =
5
2
,b =

5
2
,m =−8

]
ăree of the solutions are not allowed, because the problem re-
quires a ̸= b. ăe two remaining solutions have the roles of a
and b reversed. Assuming a < b, that leaves the solution[
a = 5

2 −
1
2

√
21,b = 1

2

√
21+ 5

2 ,m =−8
]
. Evaluating and ex-

panding,

f (a) =

(
5
2
− 1

2

√
21
)(

3
2
− 1

2

√
21
)(
−1

2
− 1

2

√
21
)(
−7

2
− 1

2

√
21
)

= −21+4
√

21

so that

y = f (a)+m(x−a)

= −21+4
√

21−8
(

x− 5
2
+

1
2

√
21
)

= −1−8x

Plot the two curves x(x−1)(x−3)(x−6) and−1−8x, just
for visual veriđcation. Use a viewing window with domain in-
terval−1≤ x≤ 6.5 to generate the following picture.

2 4 6

­40

­20

20

40

60

x

y

4. ăe series is given by
√

1− k sin2 t = 1 +
(
− 1

2 k
)

t2 +( 1
6 k− 1

8 k2
)

t4 +O
(
t5
)
. ăus, an estimate for E is given by

E ≈
∫ π/2

0

[
1+
(
− 1

2 k
)

t2 +
( 1

6 k− 1
8 k2) t4]dt

=
1
2

π− 1
48

π3k+
1

160
π5
(

1
6

k− 1
8

k2
)
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As a check, k = 1 yields 1.0045 compared with the exact value∫ π/2

0

√
1− sin2 tdt = 1

and k = 0 yields 1
2 π , which agrees precisely with∫ π/2

0
dt =

1
2

π

5. Compute natural logs on both sides and separate variables to
get lnx

x = lny
y . Plot lnx

x on the interval 1≤ x ≤ 10. Locate the
extreme values of lnx

x by solving d
dx

( lnx
x

)
= 0. Note that 2 is the

only integer between 1 and e, and verify that 24 = 42 is true.

6. ăeĔow is givenby the integral
∫ R

0 α(R2−r2)2πrdr = 1
2 απR4.

If R is reduced by one-half, then R4 is reduced to 1
16 of the orig-

inal amount.

7. ăe series expansion is given by

m0

(
1− v2

c2

)−1/2

= m0 +
1

2c2 v2m0 +
3

8c4 v4m0 +O
(

v5
)

If
v
c

is small, then the model m≈ m0 +
1
2

m0
c2 v2 is useful for es-

timating the increased mass.

8. Evaluation yields∫
2x cosbxdx =

2x (bsinbx+ cosbx ln2)
b2 + ln2 2

9. ăe integral ∫ π

−π

1+ sinx

(x− cosx)2 dx

is improper, because x− cosx = 0 has a root (≈ 0.73909) be-
tween−π and π . Evaluate Numeric gives∫ .739

−π

1+ sinx

(x− cosx)2 dx ≈ 7018.2, and∫ π

.7392

1+ sinx

(x− cosx)2 dx ≈ 5201.4
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Chapter 7 | Calculus

Change “Digits rendered” to10, in theOutputpageof theTools
>Preference>Computationdialog box. Solving cosx= xnu-
merically gives x≈ 0.7390851332.

Using this as a limit, Evaluate Numeric gives∫ 0.73908

−π

1+ sinx

(x− cosx)2 dx ≈ 116400.4055 and∫ π

0.73909

1+ sinx

(x− cosx)2 dx ≈ 122772.6822

providing some evidence that both integrals diverge.

10. You obtain the result limh→0+
∫ ∞

0 sin(x1+h)dx = 1. ăis re-
sult is reasonable, because the integral f (h) =

∫ ∞
0 sin(x1+h)dx

can be viewed as a convergent alternating series for h > 0, and
g(y) =

∫ y
0 sinxdx = 1− cosy ranges in value between 0 and

2, with an average value of 1.

11. We need to show that for each of the three functions f (x) = x3,
f (x) = xex, and f (x) = sin2 xcosx, (a) and (b) hold:

(a) If g is deđned by g(x) =
∫ x

a f (t)dt for x ∈ [a,b], then
g′(x) = f (x).

(b) If F is any antiderivative of f , then
∫ b

a f (x)dx = F(b)−
F(a).

For f (x) = x3, g(x) =
∫ x

a t3 dt = 1
4 x4 − 1

4 a4 and g′(x) =
d
dx

( 1
4 x4− 1

4 a4
)
= x3. ăe antiderivatives of f are of the form

F(x) =
∫

x3 dx = 1
4 x4 +C for different constantsC. Now

F(b)−F(x) =
[ 1

4 x4 +C
]x=b

x=a =
1
4 b4− 1

4 a4

which is the same as
∫ b

a x3 dx = 1
4 b4− 1

4 a4.

For f (x) = xex, g(x) =
∫ x

a tet dt = xex− ex− aea + ea and
g′(x) = d

dx (xex− ex−aea + ea) = xex. ăe antiderivatives of

f are of the form F(x) =
∫

xex dx = xex−ex +C for different
constantsC. Now

F(b)−F(x) = [xex− ex +C]x=b
x=a = beb− eb−aea + ea
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which is the same as
∫ b

a xex dx = beb− eb−aea + ea.
For f (x) = sin2 xcosx,

g(x)=
∫ x

a
sin2 t cos t dt = 1

4 sinx− 1
4 sina+ 1

12 sin3a− 1
12 sin3x

and

g′(x) =
d
dx

( 1
4 sinx− 1

4 sina+ 1
12 sin3a− 1

12 sin3x
)

= 1
4 cosx− 1

4 cos3x

To check to see if this is the same as f (x), apply Compute >
Combine>TrigonmetricFunctions to the expression sin2 xcosx
to see that indeed sin2 xcosx = 1

4 cosx− 1
4 cos3x. ăe an-

tiderivatives of f are of the form

F(x) =
∫

sin2 xcosxdx = 1
4 sinx− 1

12 sin3x+C

for different constantsC. Now

F(b)−F(x) =
[ 1

4 sinx− 1
12 sin3x

]x=b
x=a

= 1
4 sinb− 1

4 sina+ 1
12 sin3a− 1

12 sin3b

while∫ b

a
sin2 xcosxdx = 1

4 sinb− 1
4 sina+ 1

12 sin3a− 1
12 sin3b

12. Since the arithmetic-geometricmean lies between an and bn for
all n, we know the arithmetic-geometric mean to đve decimal
places when these two numbers agree to that many places.

• a1 =
2+1

2
=

3
2
= 1.5 and b1 =

√
2∗1 =

√
2 ≈ 1.

41421

• a2 =
3
2 +
√

2
2

= 3
4 +

1
2

√
2= 1.45711 andb2 =

√
3
2

√
2≈

1.45648

• a3 =

3
2+
√

2
2 +

√
3
2

√
2

2
=

3
8
+

1
4

√
2+

1
4

√
6 4√2≈ 1.45679

and b3 =

√(
3
4 +

1
2

√
2
)√

3
2

√
2≈ 1.45679
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Chapter 7 | Calculus

13. An average value can be determined by evaluating an integral.
ăe average distance between x and y is given by∫ 1

0

∫ 1

0
|x− y| dydx =

1
3
.

ăis can be veriđed using the following steps:∫ 1

0

∫ 1

0
|x− y| dydx =

∫ 1

0

∫ x

0
|x− y| dydx+

∫ 1

0

∫ 1

x
|x− y| dydx

=
∫ 1

0

∫ x

0
(x− y) dydx+

∫ 1

0

∫ 1

x
(y− x) dydx

=
1
6
+

1
6
=

1
3
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Matrix Algebra

One cannot escape the feeling that these mathematical formulas have an independent existence and an intelligence of their own, that they are
wiser than we are, wiser even than their discoverers. Heinrich Hertz (1857–1894)

M atrices are used throughoutmathematics and in relatedđelds Creating and Editing Matrices

Standard Operations

Row Operations and Echelon
Forms

Equations

Matrix Operators

Polynomials and Vectors
Associated with a Matrix

Vector Spaces Associated with a
Matrix

Normal Forms of Matrices

Matrix Decompositions

such as physics, engineering, economics, and statistics. ăe
algebra ofmatrices provides amodel for the study of vector

spaces and linear transformations.
A rectangular array of mathematical expressions is called a matrix.

Amatrix with m rows and n columns is called an m×n matrix. Matri-
ces are sometimes referred to simply as arrays, and an m× 1 or 1× n
array is also called a vector. Several methods for creating matrices are
described in the ensuing sections.

Entries in matrices can be real or complex numbers, or mathemat-
ical expressions with real or complex coefficients. Most of the choices
from the Matrices submenu operate on both real and complex matri-
ces. ăe QR and SVD factorizations discussed later in this chapter
assume real matrices.

Matrix entries are identiđed by their row and columnnumber. ăe
matrix can be considered as a function on pairs of positive integers.
If the matrix is given a name, this feature can be used to retrieve the
entries, with the arguments entered as subscripts.

Compute> Deönitions> New Deönition

A =

 −85 −55 −37
−35 97 50
79 56 49


New in Version 6
Map a function to a matrix
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Compute> Evaluate
A2,3 = 50
A3,3 = 49

Note that the subscripted row and column numbers are separated
by a comma.

Creating and Editing Matrices
You can create a matrix via the Matrix dialog box or from the Ma-

trices submenu. ăere is also a keyboard shortcut, described at the end
of this chapter.

Eachmethod involves different choices, as described in the follow-
ing paragraphs.
Tocreate amatrix

1. Choose Insert>Math Objects>Matrix.

2. Select the number of rows and columns by clicking in the low-
est, right-most box you want.

3. Choose OK.

4. Type or copy entries into the input boxes.

ăe entries can be any valid mathematical expression. Both real
and complex numbers are legitimate entries, as well as algebraic ex-
pressions. ăebuilt-in delimiters have the same appearance as expand-
ing brackets on the screen, but they require less horizontal space when
typeset.

Matrix Delimiters
You canmake choices in theViewmenu that affect the appearance

ofmatrices on the screen. Helper Lines and Input Boxes can be shown
or hidden. ăe default is to show them to make it easier to handle
entries on the screen. Matrix helper lines and input boxes normally do
not appear when you preview or print the document.

It is standard to enclose a matrix in brackets, either built-in or
added manually. ăese two options provide the same screen appear-
ance andmathematical properties. ăeydiffer only underTypeset—in
which case, the built-in brackets đtmore tightly around thematrix en-
tries than added brackets. If you have a matrix without built-in delim-
iters, you will generally want to add brackets around it. ăe result of
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an operation onmatrices usually appears with the same brackets as the
original matrices.

To set the defaultmatrix delimiters
1. Choose Tools>Computation>Matrices.

2. Select the desired option: none, [ ], or ( ).

Fill Matrix
You can generate a matrix whose entries are deđned by a function.

Todeđne aHilbertmatrix

1. Deđne f (i, j) =
1

i+ j−1
.

2. ChooseCompute>Matrices>FillMatrix>DeđnedbyFunc-
tion.

3. Type f in the box for the function name.

4. Set rows and columns. (Enter 2 or 3 for the following example.)

5. Choose OK.

Compute>Matrices> Fill Matrix> Deöned by Function
Function: f[

1 1
2

1
2

1
3

]  1 1
2

1
3

1
2

1
3

1
4

1
3

1
4

1
5


2×2 3×3

Todeđne aVandermondematrix

1. Deđne the function g(i, j) = x j−1
i .

2. ChooseCompute>Matrices>FillMatrix>DeđnedbyFunc-
tion.

3. Type g for the function name.

4. Set the Dimensions and choose OK.
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Compute>Matrices> Fill Matrix> Deöned by Function
Function: g, Rows: 4, Columns: 4

1 x1 x2
1 x3

1

1 x2 x2
2 x3

2

1 x3 x2
3 x3

3

1 x4 x2
4 x3

4


Todeđne a genericmatrix

1. Deđne the function a(i, j) = ai, j . Caution
Without the comma in the deönition of the
function a(i, j), the subscript i j would be
interpreted as a product.

2. ChooseCompute>Matrices>FillMatrix>DeđnedbyFunc-
tion.

3. Type a for the function name.

4. Set the Dimensions and choose OK.

Compute>Matrices> Fill Matrix> Deöned by Function
Function: a, Rows: 3, Columns: 3 a1,1 a1,2 a1,3

a2,1 a2,2 a2,3
a3,1 a3,2 a3,3


You can use the following trick to create a general matrix up to

9×9 with no commas in the subscripts.
Todeđne a genericmatrixwith no commas in the subscripts

1. Deđne the function b(i, j) = a10i+ j .

2. ChooseCompute>Matrices>FillMatrix>DeđnedbyFunc-
tion.

3. Type b for the function name.

4. Set the Dimensions and choose OK.

Compute>Matrices> Fill Matrix> Deöned by Function
Function: b, Rows: 3, Columns: 3 a11 a12 a13

a21 a22 a23
a31 a32 a33


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Todeđne a constantmatrix
1. ChooseCompute>Matrices>FillMatrix>DeđnedbyFunc-

tion.

2. Type 5 for the function name.

Compute>Matrices> Fill Matrix> Deöned by Function
Function: 5, Rows: 2, Columns: 2[

5 5
5 5

]
Band
Todeđne a bandmatrix

1. Choose Compute>Matrices> Fill Matrix> Band

2. Type a comma-delimited list such as a,b,c with an odd number
of entries in the List box.

3. Set the Dimensions and choose OK.

Compute>Matrices> Fill Matrix> Band

[
a 0
0 a

] [
b c
a b

] 
b c 0 0 0
a b c 0 0
0 a b c 0
0 0 a b c
0 0 0 a b


List: a List: a,b,c List: a,b,c

Rows: 2, Columns: 2 Rows: 2, Columns: 2 Rows: 5, Columns: 5

Create aBandmatrixwith the sigle digit0, the single digit1, or the
list 0,λ ,1 to get a zero matrix, an identity matrix, or a Jordan block,
respectively.

Compute>Matrices> Fill Matrix> Band 0 0 0
0 0 0
0 0 0

  1 0 0
0 1 0
0 0 1

  λ 1 0
0 λ 1
0 0 λ


List: 0 List: 1 List: 0,λ ,1

Rows: 3, Columns: 3 Rows: 3, Columns: 3 Rows: 3, Columns: 3
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Revising Matrices
You can add or delete rows, columns, or a full block of rows or

columns from a matrix. ăe alignment of rows and columns can be
reset. Entries in a rectangular block can be deleted or replaced.

Adding Rows and Columns
Toadd rows or columns to amatrix

1. Select the matrix by placing the insert point in a cell of the ma-
trix or by placing the insert point at the right of the matrix (but
not outside of any brackets).

2. Choose Edit > Insert Matrix Rows, or Edit > Insert Matrix
Columns.

3. Make appropriate choices fromthedialog that appears and choose
OK.

Deleting Rows and Columns
Todelete a block of rows or columns

1. Select a block of rows or columns with the mouse or with
Shiĕ+arrow.

2. Press Del.

You can also use the procedure described above to delete entries
from a rectangular block that does not include a complete row or col-
umn of a matrix.

ăe choices Insert Row(s) and Insert Column(s) appear on the
Edit menu only when a matrix is selected. If they do not appear, repo-
sition the insertionpoint or select thematrixwith click anddrag, being
careful to select only the inside of the matrix—that is, not including
the exterior Helper Lines.
To lengthen a vector represented as ann×1or1×nmatrix

• Place the insert point in the last input box and press Enter.

To shorten a vector represented as ann×1or1×nmatrix
• Place the insert point in the last input box and press Backspace.

You can start with a display box, or the input boxes that appear
with the fraction, radical, or bracket buttons, andmake similar changes
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Changing Alignment
Tochange the alignment of entries

1. Select the matrix using the mouse.

2. Choose Edit > Properties and make appropriate choices from
the dialog box that appears.

Replacing a Rectangular Block
Youcan replace a rectangular block in an existingmatrixwithCopy

and Paste or with Fill Matrix.
To replace a rectangular blockwithCopy andPaste

1. Copy a rectangular matrix to the clipboard with Edit>Copy.

2. With the mouse or Shiĕ+arrow, select a rectangular portion of
the same dimensions in any matrix and choose Edit> Paste.

Tochange amatrixwithFillMatrix
1. Select a rectangular portion of the matrix with the mouse or

Shiĕ+arrow.

2. Choose Compute>Matrices> Fill Matrix.

3. Choose one of the items from the dialog.

4. Choose OK.

ăe selected region of the matrix is đlled with the entries that you
chose.

Example To change the lower-right 2× 2 corner of the matrix to
the zeromatrix, select the lower-right 2×2 corner of thematrix using
themouse. ChooseCompute>Matrices>FillMatrix. ChooseZero.
Choose OK.

1 1 9 4
5 3 −1 5
−6 1 2 3

9 5 5 4
8 7 8 9




1 1 9 4
5 3 −1 5
−6 1 2 3

9 5 0 0
8 7 0 0


ăe lower-right corner is replaced by the 2× 2 zero matrix. No new
matrix is created.
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You can delete a block of entries in a matrix by selecting a rectan-
gular portion of the matrix with the mouse and pressing del.

Example To delete the entries in the lower-right 2× 2 corner of
the matrix, select the lower-right 2×2 corner of the matrix using the
mouse and press del.


8 −9 4
0 5 −6
1 2 3
5 5 4
7 8 9




8 −9 4
0 5 −6
1 2 3
5 □ □
7 □ □


Concatenate and Stack Matrices

You can merge two matrices horizontally into one if they have the
same number of rows. You can merge two matrices vertically into one
if they have the same number of columns.

Toconcatenate twomatriceswith the samenumber of rows
1. Place two matrices adjacent to each other.

2. Leave the insert point in one of the matrices.

3. Choose Compute>Matrices>Concatenate.

Compute>Matrices> Concatenate(
1 2
3 4

)(
5 6
7 8

)
Concatenation

(
1 2 5 6
3 4 7 8

)
(

x+1 2
3y 4t +2

)(
5+w√

7z

)
Concatenation

(
x+1 2 5+w

3y 4t +2
√

7z

)
To stack twomatriceswith the samenumber of columns

1. Place two matrices adjacent to each other.

2. Leave the insert point in one of the matrices.

3. Choose Compute>Matrices> Stack.
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Compute>Matrices> Stack 1 2
3 4
−5 7

( 5 6
)
Stack


1 2
3 4
−5 7
5 6


(

x+1 2
3y 4t +2

)(
w+5 z

√
7
)
Stack

 x+1 2
3y 4t +2

w+5 z
√

7


Reshaping Lists and Matrices

A list of expressions entered inmathematics and separated by com-
mas can be turned into amatrix whose entries, reading leĕ to right and
top to bottom, are the entries of the list in the given order.
Tomake amatrix froma list

1. Place the insert point within the list.

2. Choose Compute>Matrices> Reshape.

3. Specify the number of columns.

ăe number of rows depends on the length of the list. Extra input
boxes at the end are leĕ blank.

Compute>Matrices> Reshape (3 columns)

45,21,8,19,0,5,15,6,

 45 21 8
19 0 5
15 6 □


A matrix đlled with data can be reshaped, with the new matrix

corresponding to the same list as the original data.
To reshape amatrix

1. Place the insert point in the matrix.

2. Choose Compute>Matrices> Reshape.

3. Specify the new number of columns.

Compute>Matrices> Reshape (3 columns)[
−85 −55 −37 −35

97 50 79 56

]
,

 −85 −55 −37
−35 97 50

79 56 □


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Standard Operations
You can perform standard operations on matrices, such as addi-

tion, subtraction, scalar multiplication, and matrix multiplication, by
evaluating expressions entered in natural notation.

Matrix Addition and Scalar Multiplication
Youadd twomatrices of the samedimensionby adding correspond-

ing entries. ăe numbers or other expressions used as matrix entries
are called scalars. You multiply a scalar with a matrix by multiplying
every entry of the matrix by the scalar.

To perform matrix addition and multiplication and other opera-
tions with scalars and matrices, place the insert point anywhere inside
the expression, and choose Compute> Evaluate.

Compute> Evaluate 1 −2
4 3
−5 7

+
 5 6

8 7
3 9

=

 6 4
12 10
−2 16


Note that the sum appears with the same brackets as the original

matrices.

Compute> Evaluate(
a11 a12
a21 a22

)
+

(
b11 b12
b21 b22

)
=

(
a11 +b11 a12 +b12
a21 +b21 a22 +b22

)

a
[

1 2
4 3

]
=

[
a 2a

4a 3a

]

a
[

1 2
4 3

]
−b
[

5 6
8 7

]
=

[
a−5b 2a−6b

4a−8b 3a−7b

]
Inner Products and Matrix Multiplication

ăeproduct of a 1×n matrix with an n×1 matrix (the product of
two vectors) produces a scalar (called the inner product or dot product
in case the matrices are real). ăe matrix product of an m× k matrix
with a k×n matrix is an m×n matrix obtained by taking such prod-
ucts of rows and columns, the i jth entry of the product AB being the
product of the ith row of A with the jth column of B.
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Compute> Evaluate(
a b

)( c
d

)
= ac+bd

(
a b
u v

)(
c
d

)
=

(
ac+bd
uc+ vd

)
(

1 2
4 3

)(
5 6
8 7

)
=

(
21 20
44 45

)
[

5 6
8 7

]3

=

[
941 942
1256 1255

]

Complex numbers
The inner product of two vectors
u = (u1,u2, . . . ,un) and
v = (v1,v2, . . . ,vn) with complex
components is given by

u ·v =
n

∑
k=1

ukv∗k

where v∗k is the complex conjugate of vk .

To put an exponent on a matrix, place the insert point immedi-
ately to the right of the matrix, choose Insert > Math Objects > Su-
perscript, and type the exponent in the input box.

Rows and Columns
You can đnd the vector that is the nth row or column of a ma-

trix A with the functions row(A,n) and col(A,n). ăese function
names automatically gray when typed in mathematics mode if Au-
tomatic Substitution is enabled. Otherwise, you can create them by
choosing Insert>Math Object>Math Name.

Compute> Evaluate

row
([

1 2
4 3

]
,2
)

=
[

4 3
]

col
([

1 2
4 3

]
,2
)
=

[
2
3

]
Identity and Inverse Matrices

ăen×n identitymatrix I has ones down themaindiagonal (upper-
leĕ corner to lower-right corner) and zeroes elsewhere. ăe3×3 iden-
tity matrix, for example, is

I =

 1 0 0
0 1 0
0 0 1


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ăe inverse of an n× n matrix A is an n× n matrix B satisfying
AB = I. To đnd the inverse of an invertible matrix A, place the insert
point in the matrix and choose Compute > Matrices > Inverse; or
type A with−1 as a superscript and choose Compute> Evaluate.

Compute>Matrices> Inverse(
5 6
8 7

)
Inverse:

(
− 7

13
6
13

8
13 − 5

13

)

Compute> Evaluate(
5 6
8 7

)−1

=

(
− 7

13
6

13
8

13 − 5
13

)
To check that this matrix satisđes the deđning property, evaluate

the product.

Compute> Evaluate(
5 6
8 7

)( − 7
13

6
13

8
13 − 5

13

)
=

(
1 0
0 1

)
Choose Compute> Evaluate Numeric to get a numerical approx-

imation of the inverse. ăe accuracy of this numerical approximation
depends on properties of the matrix, as well as on the settings for Dig-
its and Digits Rendered (see Appendix C, Customizing the Program
for Computing).

Compute> Evaluate Numeric(
5 6
8 7

)−1

≈
(
−0.53846 0.46154
0.61538 −0.38462

)
Checking the product of amatrix with its inverse gives you an idea

of the degree of accuracy of the approximation.

Compute> Evaluate(
5 6
8 7

)(
−0.53846 0.46154

0.61538 −0.38462

)
=

(
0.99998 −0.00002
−0.00002 0.99998

)
Since (An)−1 =

(
A−1

)n, you can compute negative powers of in-
vertible matrices.
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Compute> Evaluate(
5 6
8 7

)−3

=

(
− 1255

2197
942
2197

1256
2197 − 941

2197

)
ăe m×n matrix with every entry equal to zero is the identity for

addition; that is, for any m×n matrix A,

A+0 = 0+A = A

and the additive inverse of a matrix A is the matrix (−1)A.

Compute> Evaluate
a11 a12 a13

a21 a22 a23

a31 a32 a33

a41 a42 a43

+

−a11 −a12 −a13

−a21 −a22 −a23

−a31 −a32 −a33

−a41 −a42 −a43

=


0 0 0
0 0 0
0 0 0
0 0 0


Polynomials with Matrix Values

You can apply a polynomial function of one variable to a matrix.
Toevaluate a polynomial p(x) at a squarematrixA

• With the insert point in the expression p(A), choose Compute
> Evaluate.

Compute> Deönitions> New Deönition

p(x) = x2−5x−2

A =

[
2 −2
−4 0

]
Compute> Evaluate

p(A) =
[

0 6
12 6

]
Note
The expression−5

[
1 2
4 3

]
−2 is not,

strictly speaking, a proper expression.
However, when evaluated, the önal 2 is

interpreted in this context as
[

2 0
0 2

]
, or

twice the 2×2 identity matrix.

You can also deđne the function f (x) = x2− 5x− 2x0 and eval-
uate f at a square matrix.

Compute> Deönitions> New Deönition
f (x) = x2−5x−2x0

Compute> Evaluate

f
([

1 2
4 3

])
=

[
2 −2
−4 0

]
297



i
i

“Compute60” — 2011/12/20 — 14:27 — page 298 — #308 i
i

i
i

i
i

Chapter 8 | Matrix Algebra

Operations on Matrix Entries
To operate on one entry of a matrix, select the entry, press and

hold the Ctrl key, and choose a command. ăe program will perform
the operation in place, leaving the rest of the matrix unchanged. Be-
cause you are in a word-processing environment, you can edit indi-
vidual entries (click in the input box and then edit) and apply other
word-processing features to entries, such as copy and paste or click and
drag.

Many of the commands on theComputemenuoperate directly on
the entries when applied to amatrix, as can be seen from the following
examples.

Compute> Factor[
5 6
8 7

]
=

[
5 2×3
23 7

]
Compute> Evaluate d

dx sinx
∫

6x2dx
d2

dx2 lnx x+3x

=

[
cosx 2x3

− 1
x2 4x

]

Compute> Evaluate Numeric[
sin2 π e
ln5 x+3x

]
≈
[

0.0 2.7183
1.6094 4.0x

]
Compute> Combine> Trigonometric Functions[

sin2 x+ cos2 x 6x2

4sin4xcos4x sinxcosy+ sinycosx

]
=

[
1 6x2

2sin(8x) sin(x+ y)

]
Compute> Evaluate

d
dx

[
x+1 2x3−3
sin4x 3secx

]
=

[
1 6x2

4cos(4x) 3
cos2 x sinx

]
Row Operations and Echelon Forms

One of the elementary applications of matrix arrays is storing and
manipulating coefficients of systems of linear equations. ăe various
steps that you carry out in applying the technique of elimination to a
system of linear equations

298



i
i

“Compute60” — 2011/12/20 — 14:27 — page 299 — #309 i
i

i
i

i
i

Row Operations and Echelon Forms

a11x1 +a12x2 + . . .+a1nxn = b1

a21x1 +a22x2 + . . .+a2nxn = b2
...

...
...

am1x1 +am2x2 + . . .+amnxn = bm

can be applied equally well to the matrix of coefficients and scalars
a11 a12 . . . a1n b1
a21 a22 . . . a2n b2
...

... . . .
...

...
am1 am2 . . . amn bm


For this and numerous other reasons, you perform elementary rowop-
erations on matrices. ăe goal of elementary row operations is to put
the matrix in a special form, such as a row echelon form, in which the
number of leading zeroes increases as the row number increases.

ăe Matrices menu provides the choices Fraction-free Gaussian
Elimination, Gaussian Elimination, and Reduced Row Echelon Form
for obtaining a row echelon form. ăe last of these produces the re-
duced row echelon form satisfying the following conditions:

• ăe number of leading zeroes increases as the row number in-
creases.

• ăe đrst nonzero entry in each nonzero row is equal to 1.

• Each column that contains the leading nonzero entry for any
row contains only zeroes above and below that entry.

Gaussian Elimination and Row Echelon Form
ăe three row echelon forms that can be obtained from the Ma-

trices submenu are illustrated in the following examples.

Compute>Matrices> Fraction-free Gaussian Elimination[
a b
c d

]
Fraction Free Gaussian Elimination:

[
a b
0 ad−bc

]
[

8 2 3
2 −5 8

]
Fraction Free Gaussian Elimination:

[
8 2 3
0 −44 58

]
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Compute>Matrices> Gaussian Elimination[
a b
c d

]
Gaussian Elimination:

[
a b
0 (ad−bc)

a

]
[

8 2 3
2 −5 8

]
Gaussian Elimination:

[
8 −5 8
0 22 −29

]
Compute>Matrices> Reduced Row Echelon Form[

a b
c d

]
Reduced Row Echelon Form:

[
1 0
0 1

]
[

8 2 3
2 −5 8

]
Reduced Row Echelon Form:

[
1 0 31

44

0 1 − 29
22

]
Elementary Row Operations

You can perform elementary row operations bymultiplying on the
leĕ by appropriate elementary matrices—the matrices obtained from
an identitymatrix by applying an elementary rowoperation. ăe tech-
nique is illustrated in the following examples.

To create an elementary matrix, choose Compute > Matrices >
Fill Matrix> Identity and edit the identity matrix. Choose Compute
> Evaluate to get the following products.

• Add λ times row 3 to row 1 1 0 λ
0 1 0
0 0 1

 −5 −2 −1
3 −6 2
1 4 1

=

 λ −5 4λ −2 λ −1
3 −6 2
1 4 1


• Interchange rows 2 and 3 1 0 0

0 0 1
0 1 0

 −50 −12 −18
31 −26 −62
1 −47 −91

=

 −50 −12 −18
1 −47 −91
31 −26 −62


• Multiply row 2 by λ 1 0 0

0 λ 0
0 0 1

 80 −2 −18
33 −26 82
14 −47 −91

=

 80 −2 −18
33λ −26λ 82λ
14 −47 −91


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You can performother rowor columnoperations that are available
in the MuPAD library, as in the following example.

Example To access the MuPAD function swapRow and name it S

1. Choose Compute>Deđnitions>Deđne MuPAD Name.

2. Respond to the dialog box as follows:

• MuPAD Name: linalg::swapRow(x,i,j)

• Scientiđc WorkPlace (Notebook) Name: S(x, i, j)

• In the area titledăeMuPADName is a Procedure, check
ăat is built in to MuPAD or is automatically loaded.

3. Check OK.

ăis procedure deđnes a function S(x, i, j) that interchanges the
rows i and j of a matrix x. Deđne

x =

 −85 −55 −37 −35
97 50 79 56
49 63 57 −59


and evaluate S(x,1,2) to get

S(x,1,2) =

 97 50 79 56
−85 −55 −37 −35
49 63 57 −59



Equations
Elementarymethods for solving systems of equations are discussed

on page 55. ăe algebra ofmatrices provides youwith additional tools
for solving systems of linear equations, both directly and by translating
into matrix equations.

Systems of Linear Equations
You identify a system of equations by entering the equations in an

n× 1 matrix, with one equation to a row. When you have the same
number of unknowns as equations, put the insert point anywhere in
the system, and choose Compute > Solve > Exact. ăe variables are
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found automaticallywithout having to be speciđed, as in the following
example.

Compute> Solve> Exact

x+ y−2z = 1
2x−4y+ z = 0
2y−3z =−1

, Solution:
[
x = 17

8 ,y =
11
8 ,z =

5
4

]
To solve a system of equations with two equations and three un-

knowns, you must specify Variables to Solve for in a dialog box. Put
the insert point anywhere in thematrix and choose Compute> Solve
> Exact. A dialog box opens asking you to specify the variables. Type
the variable names, separated by commas.

Compute> Solve> Exact
(Variable(s) to Solve for : x,y)

2x− y = 1
x+3z = 4 , Solution: [y =−6z+7,x =−3z+4]

(Variable(s) to Solve for : x,z)

2x− y = 1
x+3z = 4 , Solution:

[
x = 1

2 +
1
2 y,z = 7

6 −
1
6 y
]

Matrix Equations
ăe system of equations

a11x1 +a12x2 + . . .+a1nxn = b1

a21x1 +a22x2 + . . .+a2nxn = b2
...

...
am1x1 +am2x2 + . . .+amnxn = bm

is the same as the matrix equation
a11 a12 . . . a1n
a21 a22 . . . a2n
...

... . . .
...

am1 am2 . . . amn




x1
x2
...

xn

=


b1
b2
...

bm


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Example To put the system of equations

x+ y−2z = 1
2x−4y+ z = 0
2y−3z =−1

in matrix form, multiply the coefficient matrix

 1 1 −2
2 −4 1
0 2 −3

 by

the vector

 x
y
z

.

 1 1 −2
2 −4 1
0 2 −3

 x
y
z

=

 x+ y−2z
2x−4y+ z

2y−3z

=

 1
0
−1


You can solve matrix equations by choosing Compute > Solve >

Exact. ăere are advantages to solving systems of equations in thisway,
and oĕen you can best deal with systems of linear equations by solving
the matrix version of the system.

Compute> Solve> Exact 1 1 −2
2 −4 1
0 2 −3

 x
y
z

=

 1
0
−1

, Solution:


17
8

11
8
5
4


[

2 −1 0
1 0 3

] x
y
z

=

[
1
4

]
, Solution:

 4−3t̂3
7−6t̂3

t̂3


In the đrst case, you can also solve the equation by multiplying

both the leĕ and right sides of the equation by the inverse of the coef-
đcient matrix, and evaluating the product.

Compute> Evaluate x
y
z

=

 1 1 −2
2 −4 1
0 2 −3

−1 1
0
−1

=


17
8
11
8
5
4


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You can convert a system of linear equations to a matrix, and a
matrix to a system of equations by choosing Compute > Rewrite >
Equations as Matrix and Compute>Rewrite>Matrix as Equations,
respectively
Toconvert a systemof equations to amatrix

1. Place the insert point in a system of equations that has been cre-
ated as a list or one-column matrix.

2. Choose Compute> Rewrite> Equations as Matrix.

3. In the dialog that appears, type the variables separated by com-
mas. Choose OK.

Compute> Rewrite> Equations as Matrix
(Variable(s): x,y)

{x+2y = 3,3x−5y = 0}, Corresponding matrix:
[

1 2 3
3 −5 0

]
(Variable(s): x,y,z) x+ y−2z = 1

2x−4y+ z = 0
2y−3z =−1

, Corresponding matrix:

 1 1 −2 1
2 −4 1 0
0 2 −3 −1


Tochange amatrix to a systemof equations

1. Place the insert point in an m×n matrix.

2. Choose Compute> Rewrite>Matrix as Equations.

3. In the dialog that appears, type the variables separated by com-
mas and choose OK.

Compute> Rewrite>Matrix as Equations
(Variable List: x,y)(

1 1 −1
2 −3 1

)
, Corresponding equations: {x+ y =−1,2x−3y = 1}

Compute> Rewrite>Matrix as Equations
(Variable List: x,y,z) 1 1 −2 1

2 −4 1 0
0 2 −3 −1

, Corresponding equations: {x+ y−2z = 1,2x−4y+ z = 0,2y−3z =−1}
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ăe response is a list of equations. If you want these equations in
a one-column matrix, use Matrices> Reshape, and specify 1 column.

Compute>Matrices> Reshape

{x+ y =−1,2x−3y = 1},
{

x+ y =−1
2x−3y = 1

}
Rotation Matrices

ăe matrix product

(
cosθ −sinθ
sinθ cosθ

)(
x
y

)
=

(
xcosθ − ysinθ
ycosθ + xsinθ

)

has the effect of rotating the vector
(

x
y

)
through an angle θ in a

counter-clockwise direction about the origin. You can visualize this
by using an animation.

Compute> Plot 2D Animated> Rectangular(
cosθ −sinθ
sinθ cosθ

)(
x
0

)
0≤ θ ≤ 2π , 0≤ x≤ 1
□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□

­1 1

­1

1

x

y

­1 1

­1

1

x

y

­1 1

­1

1

x

y

□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□

You can also rotate a parametric curve. In the following, the curve(
x2,x3

)
is rotated through an angle θ , as θ increases from 0 to 2π .
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Chapter 8 | Matrix Algebra

Compute> Plot 2D Animated> Rectangular(
cosθ −sinθ
sinθ cosθ

)(
x2

x3

)
0≤ θ ≤ 2π ,−1≤ x≤ 1

□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□

­1.0 ­0.5 0.5 1.0

­1.0

­0.5

0.5

1.0

x

y

­1.0 ­0.5 0.5 1.0

­1.0

­0.5

0.5

1.0

x

y

­1.0 ­0.5 0.5 1.0

­1.0

­0.5

0.5

1.0

x

y

□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□

ăefollowingdepicts the rotatationof the surface (x,y,sinx+ cosy)
about the y-axis.

Compute> Plot 3D Animated> Rectangular cosθ 0 −sinθ
0 1 0

sinθ 0 cosθ

 x
y

sinx+ cosy


0≤ θ ≤ 2π ,−6≤ x≤ 6,−6≤ y≤ 6

□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□

□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□

ăis three-dimensional animation uses one of these 3×3 rotation
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matrices: cosθ −sinθ 0
sinθ cosθ 0

0 0 1

  cosθ 0 −sinθ
0 1 0

sinθ 0 cosθ

  1 0 0
0 cosθ −sinθ
0 sinθ cosθ


Rotate about z axis Rotate about y axis Rotate about x axis

Matrix Operators
Amatrix operator is a function that operates onmatrices. ăeMa-

trices menu contains a number of matrix operators.

Trace
ăe trace of an n× n matrix is the sum of the diagonal elements.

ăis operation applies to square matrices only.

Tocompute the trace of a squarematrix
1. Place the insert point in the matrix.

2. Choose Compute>Matrices>Trace.

Compute>Matrices> Trace(
a b
c d

)
Trace: a+d

 −85 −55 −37
−35 97 50
79 56 49

Trace: 61

Transpose and Hermitian Transpose
ăe transpose of an m×n matrix is the n×m matrix that you ob-

tain from the đrst matrix by interchanging the rows and columns.

Tocompute the transpose of amatrix
1. Place the insert point in the matrix.

2. Choose Compute>Matrices>Transpose.

Compute>Matrices> Transpose(
a b
c d

)
Transpose:

(
a c
b d

)
You can also compute the transpose of a matrix or vector by using

the superscript T .
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Compute> Evaluate(
a b c
d e f

)T

=

 a d
b e
c f


(

a
b

)T ( c
d

)
= ac+bd

ăe last example demonstrates a common way to take the inner prod-
uct of vectors.

ăeHermitian transpose of amatrix is the transpose togetherwith
the replacement of each entry by its complex conjugate. It is also re-
ferred to as the adjoint or Hermitian adjoint or conjugate transpose
of a matrix (not to be confused with the classical adjoint or adjugate,
discussed elsewhere in this chapter.)

Tocompute theHermitian transpose of amatrix
1. Place the insert point in the matrix.

2. Choose Compute>Matrices>Hermitian Transpose.

Compute>Matrices> Hermitian Transpose(
2+ i −i
4− i 2+ i

)
Hermitian Transpose:

(
2− i 4+ i

i 2− i

)
You can also compute the Hermitian transpose of a matrix using

the superscript H .

Compute> Evaluate(
i 2+ i

4i 3−2i

)H

=

(
−i −4i

2− i 3+2i

)
Tocompute theHermitian transpose of amatrixwithnon-numeric

entries, đrst assume real variables. Note
Type assume and real in mathematics
mode, and they will turn upright and gray.

Compute> Evaluate Compute> Evaluate
assume(a, real) = R assume(e, real) = R
assume(b, real) = R assume( f , real) = R
assume(c, real) = R assume(g, real) = R
assume(d, real) = R assume(h, real) = R
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Compute>Matrices> Hermitian Transpose(
a+ ib c+ id
e+ i f g+ ih

)
Hermitian Transpose:

(
a− ib e− i f
c− id g− ih

)
Determinant

ăedeterminant of an n×n matrix (ai j) is the sum and difference
of certain products of the entries. Speciđcally,

det(ai j) = ∑
σ
(−1)sgn(σ) a1σ(1)a2σ(2) · · ·anσ(n)

whereσ ranges over all thepermutations of{1,2, . . . ,n} and (−1)sgn(σ)

=±1, depending on whether σ is an even or odd permutation. Note
Determinants apply to square matrices only.Tocompute the determinant of a squarematrix

1. Place the insert point in the matrix.

2. Choose Compute>Matrices>Determinant.

Compute>Matrices> Determinant[
a b
c d

]
Determinant: ad−bc

 −85 −55 −37
−35 97 50

79 56 49

 Determinant: −121529

 a1,1 a1,2 a1,3
a2,1 a2,2 a2,3
a3,1 a3,2 a3,3

Determinant: a1,1a2,2a3,3−a1,1a2,3a3,2−a2,1a1,2a3,3
+a2,1a1,3a3,2 +a3,1a1,2a2,3−a3,1a1,3a2,2

You can compute the determinant by enclosing the matrix in ver-
tical expanding brackets or by using the function det, then choosing
Compute> Evaluate.

Tip
Create vertical brackets by selecting the matrix
and typing Ctrl+\ or by choosing Insert>
Math Objects> Brackets and clicking | .

Compute> Evaluate∣∣∣∣ −35 50
79 49

∣∣∣∣ =−5665 det
[

a b
c d

]
= ad−bc

det
[
−35 50

79 49

]
=−5665

∣∣∣∣∣∣
−85 −55 82
−35 97 −17

42 33 −65

∣∣∣∣∣∣= 223857

To obtain the function det, type the letters det in mathematics,
and they will turn gray when the t is typed. You can also choose Insert
>Math Objects>Math Names and select det from a list.
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Adjugate
ăe adjugate or classical adjoint of a matrix A is the transpose of

the matrix of cofactors of A. ăe i, j cofactor Ai j of A is the scalar
(−1)i+ j detA(i| j), where A(i| j) denotes the matrix that you obtain
from A by removing the ith row and jth column.

Compute>Matrices> Adjugate(
a b
c d

)
Adjugate:

(
d −b
−c a

)
 a b c

d e f
g h j

Adjugate:

 e j− f h −b j+ ch b f − ce
−d j+ f g a j− cg −a f + cd
dh− eg −ah+bg ae−bd




9 6 7 −5
4 −8 −3 92
−3 −6 7 6

5 −5 0 −1

Adjugate:


3384 469 −3183 7130
3329 301 −3200 −8153
4068 −261 6896 −2976
275 840 85 −1116



ăe product of a matrix with its adjugate is diagonal, with the en-
tries on the diagonal equal to the determinant of the matrix.

(
a b
c d

)(
d −b
−c a

)
=

(
ad−bc 0

0 ad−bc

)

ăis relationship yields a well-known formula for the inverse of an in-
vertible matrix A:

A−1 =
1

detA
adjugateA
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Compute> Evaluate

det


9 6 7 −5
4 −8 −3 92
−3 −6 7 6
5 −5 0 −1

 = 77531

1
77531


9 6 7 −5
4 −8 −3 92
−3 −6 7 6
5 −5 0 −1




3384 469 −3183 7130
3329 301 −3200 −8153
4068 −261 6896 −2976
275 840 85 −1116

=


1 0 0 0
0 1 0 0
0 0 1 0
0 0 0 1


Permanent

ăepermanent of an n×n matrix (ai j) is the sum of certain prod-
ucts of the entries. Speciđcally,

permanent(ai j) = ∑
σ

a1σ(1)a2σ(2) · · ·anσ(n)

where σ ranges over all the permutations of {1,2, . . . ,n}. ăis oper-
ation applies to square matrices only.

Tocompute the permanent of amatrix
1. Place the insert point in the matrix.

2. Choose Compute>Matrices> Permanent.

Compute>Matrices> Permanent[
a b
c d

]
Permanent: ad +bc a1,1 a1,2 a1,3

a2,1 a2,2 a2,3
a3,1 a3,2 a3,3

Permanent:

a1,1a2,2a3,3 +a1,1a2,3a3,2 +a2,1a1,2a3,3 +a2,1a1,3a3,2 +a3,1a1,2a2,3 +a3,1a1,3a2,2

Maximum and MinimumMatrix Entries
ăe functions max and min applied to a matrix with integer en-

tries will return the entry with maximum or minimum value.

311



i
i

“Compute60” — 2011/12/20 — 14:27 — page 312 — #322 i
i

i
i

i
i

Chapter 8 | Matrix Algebra

Compute> Evaluate

max

 −85 −55 −37 −35 97
50 79 56 49 63
57 −59 45 −8 −93

 = 97

min


92 43 −62 77 66
54 −5 99 −61 −50
−12 −18 31 −26 −62

1 −47 −91 −47 −61

=−91

Matrix Norms
ChoosingCompute>Matrices>Normgives theEuclideannorm

of a vector or matrix. ăe Euclidean norm, or 2-norm, of a vector is
the Euclidean length of the vector: Norm notation

Type Ctrl+| (Ctrl+Shift+\) to enter the norm
brackets ∥ ∥.∥∥∥∥ a

b

∥∥∥∥= √a2 +b2

∥∥∥∥∥∥∥∥
a
b
c
d

∥∥∥∥∥∥∥∥=
√

a2 +b2 + c2 +d2

ăe Euclidean norm, or 2-norm, of a matrix A with real or complex
entries is its largest singular value—the number deđned by

∥A∥= max
x ̸=0

∥Ax∥
∥x∥

ăis can also be computed as max
{√
|Ei|
}

where the Ei’s range over

the eigenvalues of the matrix AAH .

Compute>Matrices> Norm(
2 3
5 7

)
Norm: 9.3268

 2 −1 0
−1 2 −1

0 −1 2

Norm: 3.4142

(
3
4

)
Norm: 5

 1 1
2 1
1 1

Norm:
√

1
2

√
73+ 9

2

(
2+3i 5

6 −7+2i

)
Norm: 9.9378

(
3+4i
1−5i

)
Norm:

√
51
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ăe Euclidean norm of a matrix can also be obtained with double
brackets.

Toput norm symbols around amatrix
1. Select the matrix by using the mouse.

2. Choose Insert>MathObjects>Brackets, and select the norm
symbols.

3. Choose OK.

Compute> Evaluate∥∥∥∥ 0.2 0.3
0.5 0.7

∥∥∥∥= 0.93268
∥∥∥∥ 5 7
−13 6

∥∥∥∥ = 14.454

∥∥∥∥ 2+3i 5
6 −7+2i

∥∥∥∥= 9.9378

ăe 1-norm of a matrix is the maximum among the sums of the
absolute values of the terms in a column:

∥A∥1 = max
1≤ j≤n

(
n

∑
i=1

∣∣ai j
∣∣)

Togenerate the 1-norm
• Type 1 as a subscript on the norm brackets.

Compute> Evaluate∥∥∥∥ a b
c d

∥∥∥∥
1
= max(|a|+ |c| , |b|+ |d|)

∥∥∥∥ 0.2234 0.3158
−0.5624 0.7111

∥∥∥∥
1
= 1.0269

∥∥∥∥ 5 7
−13 6

∥∥∥∥
1
= 18

∥∥∥∥ 5+3i 7
−13 6−5i

∥∥∥∥
1
=
√

34+13

ăe ∞-norm of a matrix is the maximum among the sums of the
absolute values of the terms in a row:

∥A∥∞ = max
1≤i≤n

(
n

∑
j=1

∣∣ai j
∣∣)
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Togenerate the∞-norm

• Enter ∞ as a subscript on the norm brackets.

Compute> Evaluate∥∥∥∥ a b
c d

∥∥∥∥
∞
= max(|a|+ |b| , |c|+ |d|)

∥∥∥∥ 0.2234 0.3158
−0.5624 0.7111

∥∥∥∥
∞
= 1.2735

∥∥∥∥ 5 7
−13 6

∥∥∥∥
∞
= 19

∥∥∥∥ 5+3i 7
−13 6−5i

∥∥∥∥
∞
= 13+

√
61

ăeHilbert-Schmidt norm (or Frobenius norm) ∥A∥F of amatrix
A is the square root of the sumsof the squares of the terms of thematrix
A. ăis is also sometimes called the Euclidean norm, although it is not
the same as the 2-norm (see page 312).

∥A∥F =

 ∑
1≤ j≤n
1≤i≤n

∣∣ai j
∣∣2 1

2

Compute> Evaluate∥∥∥∥ 5+3i 7
−13 6−5i

∥∥∥∥
F
=
√

313
∥∥∥∥ a b

c d

∥∥∥∥
F
=

√(
|a|2 + |b|2 + |c|2 + |d|2

)
∥∥∥∥ 5 7
−13 6

∥∥∥∥
F
= 3
√

31
∥∥∥∥ 0.2234 0.3158
−0.5624 0.7111

∥∥∥∥
F
= 0.98569

Spectral Radius
ăe spectral radius of a real symmetric matrix is the largest of the

absolute values of the eigenvalues of the matrix.

Compute>Matrices> Spectral Radius 5 −3 1
−3 0 5
1.0 5 4

Spectral Radius: 7.7627
[

5 −4
−4 3.0

]
Spectral Radius: 8.1231
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Compute>Matrices> Eigenvalues 5 −3 1
−3 0 5
1.0 5 4

Eigenvalues: 7.7627,5.6174,−4.3801

[
5 −4
−4 3.0

]
Eigenvalues: 8.1231,−0.12311

Condition Number
ăe condition number of an invertible matrix A is the product of

the 2-norm of A and the 2-norm of A−1. ăis number measures the
sensitivity of some solutions of linear equations Ax = b to perturba-
tions in the entries of A and b. ăe matrix with condition number 1
is perfectly conditioned.

Compute>Matrices> Condition Number[
0 1
1 0

]
, condition number: 1.0


1 1

2
1
3

1
4

1
2

1
3

1
4

1
5

1
3

1
4

1
5

1
6

1
4

1
5

1
6

1
7

, condition number: 15514.0

Compute>Matrices> Condition Number[
18 7
3 −4

]
Condition Number: 4.0315

[
1 1
1 1.00001

]
Condition Number: 4.0×105

ăeseđnal twomatrices are extremely ill-conditioned. Small changes
in some entries of A or b may result in large changes in the solution to
linear equations of the form Ax = b in these two cases.
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Exponential Functions
A natural way to deđne eM is to imitate the power series for ex

ex = 1+ x+
1
2

x2 +
1
6

x3 +
1

24
x4 + · · ·

eM = 1+M+
1
2

M2 +
1
6

M3 +
1

24
M4 + · · ·

and more generally,

etM =
∞

∑
k=0

(tM)k

k!

Toevaluate the expression eM (or exp(M)) for amatrixM
• Leave the insert point in the expression eM and choose Com-

pute> Evaluate.

Compute> Deönitions> New Deönition

A =

[
1 2
0 3

]
B =

[
1 2
0 1

]

C =

 0 1 0
0 0 1
0 0 0

 D =

 1 3 0
0 1 0
0 0 1


Compute> Evaluate

eA =

[
e e3− e
0 e3

]
etA =

[
et e3t − et

0 e3t

]

exp(A) =
(

e −e+ e3

0 e3

)
exp(tA) =

[
et −et + e3t

0 e3t

]
Compute> Evaluate

eA+B =

[
e2 −2e2 +2e4

0 e4

]
DetCD−1 =

 1 t 3t + 1
2 t2

0 1 t
0 0 1


eAeB =

[
e2 2e2− e

(
e− e3

)
0 e4

]
eDtCD−1

=

 1 t t2
( 3

t +
1
2

)
0 1 t

( 3
t +1

)
−3

0 0 1


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Note that one of the properties of exponents that holds for real
numbers fails for matrices. ăe equality eA+B = eAeB requires that
AB = BA, and this property fails to hold for thematrices in the exam-
ple. However, exponentiation preserves the property of similarity, as
demonstrated by DetCD−1 = eDtCD−1

.

Polynomials and Vectors Associated with a Matrix
A square matrix has a characteristic and a minimal (minimum)

polynomial. ăecharacteristic polynomial determines eigenvalues and
eigenvectors of thematrix. Eigenvalues are an important feature of any
dynamical system. One important application is to the solution of a
system of ordinary differential equations.

Characteristic Polynomial and Minimal Polynomial
ăe characteristic polynomial of a square matrix A is the determi-

nant of the characteristic matrix xI−A.

Compute>Matrices> Characteristic Polynomial 4 1 0
0 4 0
0 0 4

Characteristic Polynomial: X3−12X2 +48X−64

Compute> Evaluate

X

 1 0 0
0 1 0
0 0 1

−
 4 1 0

0 4 0
0 0 4

=

 −4+X −1 0
0 −4+X 0
0 0 −4+X



det

 −4+X −1 0
0 −4+X 0
0 0 −4+X

= (X−4)3

ăeminimal polynomial of a squarematrix A is themonic polyno-
mial p(x) of smallest degree such that p(A) = 0. ăis is oĕen called
the minimum polynomial of A.

By the Cayley-Hamilton theorem, f (A) = 0 if f (x) is the charac-
teristic polynomial of A. ăe minimal polynomial of A is a factor of
the characteristic polynomial of A.
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Compute>Matrices>Minimal Polynomial 4 1 0
0 4 0
0 0 4

Minimal Polynomial: X2−8X +16

Compute> Factor
X2−8X +16 = (X−4)2

Example ăis example illustrates the Cayley-Hamilton theorem.

Deđne p(X) = X2−8X +16X0 and A =

 4 1 0
0 4 0
0 0 4

.

Choose Compute> Evaluate to get

p(A) =

 0 0 0
0 0 0
0 0 0


ăe minimal and characteristic polynomial operations have to re-

turn a variable for the polynomial. In the preceding examples, they
returned X . However, the variable used depends on the matrix entries
and you do not need to avoid X in the matrix. You will be asked to
supply a name for the polynomial variable.

Compute>Matrices>Minimal Polynomial
(Polynomial Variable λ )(

3X x
5 y

)
Minimal Polynomial: λ 2 +(−3X− y)λ +3Xy−5x

Eigenvalues and Eigenvectors
Given a matrix A, the matrix commands Eigenvectors and Eigen-

values on the Matrices submenu đnd scalars c and nonzero vectors v
for which Av = cv. If there is a Ĕoating-point number in the matrix,
the result is a numerical solution. Otherwise, the result is an exact sym-
bolic solution or no solution. When a solution is not found, change
at least one entry to Ĕoating point to obtain a numeric solution.

ăese scalars and vectors are sometimes called characteristic values
and characteristicvectors. ăe eigenvalues, or characteristic values, are
roots of the characteristic polynomial.
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Compute>Matrices> Eigenvalues(
cosα −sinα
sinα cosα

)
Eigenvalues: cosα +(isinα) ,cosα− (isinα)

ăismatrix has characteristic polynomial X2−2X cosα +1. Re-
placingX by the eigenvaluecosα+ isinα and applyingSimplify gives

(cosα + isinα)2−2(cosα + isinα)cosα +1 = 0

demonstrating that eigenvalues are roots of the characteristic polyno-
mial. Note the different results obtained using integer versus Ĕoating-
point entries.

Compute>Matrices> Eigenvalues(
1 2
3 4

)
Eigenvalues: 1

2

√
33+ 5

2 ,
5
2 −

1
2

√
33

(
1.0 2
3 4

)
Eigenvalues: 5.3723,−0.37228

When you choose Compute > Matrices > Eigenvectors, the sys-
tem returns eigenvectors paired with the corresponding eigenvalues.
ăe eigenvectors are grouped by eigenvalues, making the multiplicity
for each eigenvalue apparent. Symbolic solutions will be returned in
some cases. When a symbolic solution is not found, change at least
one entry to Ĕoating point to obtain a numeric solution.

Compute>Matrices> Eigenvectors 49 −69 99
23 −81 20
48 1.0 −87

Eigenvectors:


 0.93733

0.18622
0.29451

↔ 66.398


 0.1599

0.88794
0.43127

↔−67.144,


 0.54043

0.11389
−0.83364

↔−118.25

 5 −6 −6
−1 4 2
3 −6 −4

Eigenvectors:


 1
− 1

3
1

↔ 1,


2

1
0

 ,

2
0
1

↔ 2
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In the preceding example, 1 is an eigenvalue occurring with mul-
tiplicity 1, and 2 is an eigenvalue occurring with multiplicity 2. ăe
deđning property Av = cv is illustrated in the following example:

Compute> Evaluate 5 −6 −6
−1 4 2

3 −6 −4

 2
1
0

=

 4
2
0

= 2

 2
1
0


 5 −6 −6
−1 4 2

3 −6 −4

 2
0
1

=

 4
0
2

= 2

 2
0
1


 5 −6 −6
−1 4 2

3 −6 −4

 −3
1
−3

=

 −3
1
−3


Positive Deönite Matrices

A square matrix is called Hermitian if it is equal to its conjugate
transpose. A Hermitian matrix with real entries is the same as a sym-
metric matrix.

A Hermitian matrix A is positive deĖnite if all the eigenvalues of A
are positive. Otherwise, the computational engine MuPAD classiđes
A as indeĖnite.

An indeđnite Hermitian matrix A is sometimes classiđed as posi-
tive semideĖnite if all the eigenvalues of A are nonnegative; as negative
deĖnite if all the eigenvalues are negative; and as negative semideĖnite
if all the eigenvalues are nonpositive.

Compute>Matrices> Deöniteness Tests[
2 −1
−1 2

]
is positive deđnite

[
1 −1
−1 1

]
is indeđnite

[
2 −i
i 1

]
is positive deđnite

[
−2 i
−i −2

]
is indeđnite
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Compute>Matrices> Eigenvalues[
2 −1
−1 2

]
Eigenvalues: 3,1

[
1 −1
−1 1

]
Eigenvalues: 0,2

[
2 −i
i 1

]
Eigenvalues: 3

2 −
1
2

√
5, 1

2

√
5+ 3

2

[
−2 i
−i −2

]
Eigenvalues: −3,−1

Vector Spaces Associated with a Matrix
Four vector spaces are naturally associated with an m× n matrix

A: the row space, the column space, and the leĕ and right nullspaces.
A basis for a vector space is a linearly independent set of vectors

that spans the space. Commands on the Matrices submenu đnd bases
for these vector spaces. ăese bases are not unique and differentmeth-
ods may compute different bases.

The Row Space
ăe row space of a matrix A is the vector space spanned by the row

vectors of A. Any choice of row basis has the same number of vectors
and spans the same vector space. However, there is no natural choice
for the vectors that make up a row basis.

You can đnd other bases for the row space by choosing Compute
>Matrices>Reduced Row Echelon Form, or by choosing Compute
>Matrices>Fraction-FreeGaussianElimination and then taking the
nonzero rows from the result.

Tođnd abasis for the row space
1. Leave the insert point in the matrix.

2. Choose Compute>Matrices> Row Basis.
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Compute>Matrices> Row Basis[
−1 3

5 −15

]
Row Basis:

[
−1 3

]

−85 −55 −37 −35

97 50 79 56
49 63 57 −59
−36 8 20 −94

 Row Basis:

[[
−85 −55 −37 −35

]
,
[

97 50 79 56
]
,
[

49 63 57 −59
]]

Compute>Matrices> Reduced Row Echelon Form
−85 −55 −37 −35

97 50 79 56
49 63 57 −59
−36 8 20 −94

Reduced Row Echelon Form:


1 0 0 133337

68264

0 1 0 − 74049
34132

0 0 1 − 3085
9752

0 0 0 0


ăe nonzero rows in the preceding matrix give the following basis

for the row space:[
1 0 0 133337

68264

]
,
[

0 1 0 − 74049
34132

]
,
[

0 0 1 − 3085
9752

]
Compute>Matrices> Fraction Free Gaussian Elimination
−85 −55 −37 −35

97 50 79 56
49 63 57 −59
−36 8 20 −94

 Fraction Free Gaussian Elimination:


−85 −55 −37 −35

0 1085 −3126 −1365
0 0 136528 −43190
0 0 0 0


ăe nonzero rows in the preceding matrix give the following basis

for the row space:[
−85 −55 −37 −35

]
,
[
0 1085 −3126 −1365

]
,
[
0 0 136528 −43190

]
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Compute>Matrices> Gaussian Elimination


−85 −55 −37 −35

97 50 79 56
49 63 57 −59
−36 8 20 −94

Gaussian Elimination:


49 63 57 −59

0 380
7

3032
49 − 6730

49

0 0 4876
95 − 617

38

0 0 0 0


ăe nonzero rows in the preceding matrix give the following basis

for the row space:

[
−85 −55 −37 −35

]
,
[
0 − 217

17
3126
85

273
17

]
,
[
0 0 19504

155 − 1234
31

]

The Column Space
ăe column space of a matrix A is the vector space spanned by the

columns of A.

Tođnd abasis for the column space

1. Leave the insert point in the matrix.

2. Choose Compute>Matrices>Column Basis.

Compute>Matrices> Column Basis
−85 −55 −37 −35
97 50 79 56
49 63 57 −59
−36 8 20 −94

Column Basis:



−85
97
49
−36

 ,

−55
50
63
8

 ,

−37
79
57
20




You can also take the transpose of A and apply to the transpose the
various other methods demonstrated in the previous section, because
the column space of A is the same as the row space of AT .

The Left and Right Nullspaces
ăe (right) nullspace is the vector space consisting of all n×1 vec-

tors X satisfying AX = 0. You đnd a basis for the nullspace by choos-
ing Compute>Matrices>Nullspace Basis.
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Compute>Matrices> Nullspace Basis
−85 −55 −37 −35

97 50 79 56
49 63 57 −59
−36 8 20 −94

Nullspace Basis:


− 133337

68264
74049
34132
3085
9752

1


ăe leě nullspace is the vector space consisting of all 1×m vectors

Y satisfying YA = 0. You đnd a basis for the leĕ nullspace by đrst
taking the transpose of A and then choosing Compute>Matrices>
Nullspace Basis.

Compute> Evaluate
−85 −55 −37 −35

97 50 79 56
49 63 57 −59
−36 8 20 −94


T

=


−85 97 49 −36
−55 50 63 8
−37 79 57 20
−35 56 −59 −94


Compute>Matrices> Nullspace Basis
−85 97 49 −36
−55 50 63 8
−37 79 57 20
−35 56 −59 −94

Nullspace Basis:


−1

0
−1

1


To check that this vector is in the leĕ nullspace, take the transpose

of the vector and check the product.

Compute> Evaluate
−1

0
−1

1


T 
−85 −55 −37 −35

97 50 79 56
49 63 57 −59
−36 8 20 −94

=
[

0 0 0 0
]

Orthogonal Matrices
An orthogonal matrix is a real matrix for which the inner product

of any two different columns is zero and the inner product of any col-
umnwith itself is one. ăematrix is said tohaveorthonormal columns.
Such a matrix necessarily has orthonormal rows as well.
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Compute>Matrices> Orthogonality Test 0 0 1
1 0 0
0 1 0

 orthogonal? TRUE
(

0 1
1 1

)
orthogonal? FALSE

The QR Factorization and Orthonormal Bases
Any real matrix A with at least as many rows as columns can be

factored as a product QR, where Q is an orthogonal matrix—that is,
the columns of Q are orthonormal (the inner product of any two dif-
ferent columns is 0, and the inner product of any column with itself
is 1) and R is upper-right triangular with the same rank as A. If the
original matrix A is square, then so is R. If A is a square matrix with
linearly independent columns, R is invertible.
Toobtain theQR factorization

1. Leave the insert point in a matrix.

2. Choose Compute>Matrices>QR Decomposition.

Compute>Matrices> QR Decomposition(
3 0
4 5

)
QR Decomposition:

(
3
5 − 4

5
4
5

3
5

)(
5 4
0 3

)
 −4 2

1 −1
0 2

QR Decomposition:

 − 4
17

√
17 − 1

102

√
2
√

17 1
6

√
2

1
17

√
17 − 2

51

√
2
√

17 2
3

√
2

0 1
6

√
2
√

17 1
6

√
2



√

17 − 9
17

√
17

0 6
17

√
2
√

17

0 0


When A is a squarematrix with linearly independent columns, the

two matrices Q and A = QR have the same column spaces.

Example ăe preceding product comes from the following linear
combinations. (

3
4

)
= 5

(
3
5
4
5

)
+0

(
− 4

5
3
5

)

and (
0
5

)
= 4

(
3
5
4
5

)
+3

(
− 4

5
3
5

)
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Observe that the columns of A are linear combinations of the columns
of Q. ăen, since both column spaces have dimension 2 and one con-
tains the other, it follows that they must be the same space.

ăis conversionof the columnsofA into theorthonormal columns
of Q is referred to as the Gram–Schmidt orthogonalization process.
In general, since R is upper-right triangular, the subspace spanned by
the đrst k columns of the matrix A = QR is the same as the subspace
spanned by the đrst k columns of the matrix Q.

Rank and Dimension
ăe rank of a matrix is the dimension of the column space. It is

the same as the dimension of the row space or the number of nonzero
singular values.

Compute>Matrices> Rank
−8 −5 7 −2

7 5 9 5
1 0 −16 −3
8 5 −7 2

Rank: 2

Compute>Matrices> Row Basis
−8 −5 7 −2

7 5 9 5
1 0 −16 −3
8 5 −7 2

Row Basis:
[[
−8 −5 7 −2

]
,
[

7 5 9 5
]]

Compute>Matrices> Column Basis
−8 −5 7 −2

7 5 9 5
1 0 −16 −3
8 5 −7 2

Column Basis:



−8

7
1
8

 ,

−5

5
0
5




Normal Forms of Matrices
Any equivalence relation on a set of matrices partitions the set of

matrices into a collection of equivalence classes. A normal form, or
canonical form, for a matrix is a choice of another matrix that displays
certain invariants for that equivalence class, usually together with an
algorithm for constructing the form from the given matrix.

Two such equivalence relations are similarity and equivalence. Two
n×n matrices A and B are similar if there is an invertible n×n matrix
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C such that B =C−1AC. Two m×n matrices A and B are equivalent
if one can be obtained from the other by a sequence of elementary row
and column operations. In other words, B = QAP for some invertible
matrices Q and P.

When the context ismatrices over the integers, “invertible” should
be interpreted as “unimodular;” that is, both thematrix and its inverse
have integer entries—in particular, a unimodular matrix has determi-
nant 1. When the context is matrices over the ring F [x] for a đeld F ,
“invertible”means both thematrix and its inverse have entries in F [x].

Smith Normal Form
Every matrix A over a principal ideal domain (PID) is equivalent

to a diagonal matrix of the form

diag(1, . . . ,1, p1, p2, . . . , pk,0, . . . ,0)

where for each i, pi is a factor of pi+1. ăis matrix, which is uniquely
determined by A, is called the Smith normal form of A. ăe diagonal
entries of the Smith normal formof amatrixA are the invariant factors
of A. ăe Smith normal form of A can be obtained as a matrix S =
QAP where Q and P are invertible over the PID.

Integer Matrices
ăe Smith normal form of an integermatrix A is amatrix S =QAP

where Q and P are unimodular—nonsingular matrices with integer
entries whose inverses also have integer entries. In particular, Q and P
have determinant 1. You can đnd the Smith normal form of a square
integer matrix.

Compute>Matrices> Smith Normal Form 2 9 5
3 4 3
4 1 −1

 Smith Normal Form:

 1 0 0
0 1 0
0 0 56


ăe following product illustrates the equivalence relation. ăe

two new matrices that occur are unimodular.

 2 9 5
3 4 3
4 1 −1

=

 2 9 −5
3 4 −3
4 1 −2

 1 0 0
0 1 0
0 0 56

 1 0 21
0 1 27
0 0 1


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Matrices overF [x]
It is a remarkable fact that two n×n matrices with entries in a đeld

F are similar if and only if their characteristicmatrices xI−A and xI−
B are equivalent. ăese characteristic matrices are matrices over the
principal ideal domainF [x], and two squarematriceswithpolynomial
entries are equivalent if and only if they have the same Smith normal
form. ăe entries can be any polynomials with rational or symbolic
coefficients.

Compute>Matrices> Smith Normal Form(
x2 −2i

(
x3 + x2

)
+2x2

0
√

2i
(
x3 + x2

) )
Smith Normal Form:

(
x2 0
0 x2 + x3

)
ăe Smith normal form can be used to test whether two matrices

are similar. ăe đeld in question can be the rationals or any đnite đeld
extension of the rationals. We illustrate this with an example.

Example Take two similar matrices: A =

[
1 2
3 4

]
and

B=

[
1 9
−3 4

]−1 [ 1 2
3 4

][
1 9
−3 4

]
=

[ 61
31 − 319

31

− 24
31

94
31

]

ăese matrices have the following characteristic matrices:

xI−A =

[
x 0
0 x

]
−
[

1 2
3 4

]
=

[
x−1 −2
−3 x−4

]

xI−B=

[
x 0
0 x

]
−

[ 61
31 − 319

31

− 24
31

94
31

]
=

[
x− 61

31
319
31

24
31 x− 94

31

]

with Smith normal forms both equal to[
1 0
0 x2−5x−2

]
See page 331 for another example relating Smith normal forms

and characteristic polynomials.

Hermite Normal Form
Given a matrix A with entries in a PID, the Hermite normal form

of A is a row echelon matrix H = QA where Q is invertible in the
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ring of matrices over the PID. ăe đrst nonzero entry in each row is
fromaprespeciđed set of nonassociates, and the entries above that đrst
nonzero entry are from a prespeciđed set of representatives of the ring
modulo that entry. If the PID is the ring of integers, the đrst nonzero
entry in each row is a positive integer ni j , and the entries above that
đrst nonzero entry are oĕen chosen from the set

{
0,1,2, ...,ni j−1

}
.

Compute>Matrices> Hermite Normal Form(
7 34 46
4 20 27

)
Hermite Normal Form:

(
1 2 3
0 4 5

)
[

2 5
−4 5

]
Hermite Normal Form:

[
2 5
0 15

]
Companion Matrix and Rational Canonical Form

ăe companion matrix of a monic polynomial a0 + a1X + · · ·+
an−1Xn−1 +Xn of degree n is the n×n matrix with a subdiagonal of
ones, đnal column

[
−a0 −a1 · · · −an−1

]T
and other entries zero.

Compute> Polynomials> Companion Matrix

x4 +3x2−2x+1, Companion:


0 0 0 −1
1 0 0 2
0 1 0 −3
0 0 1 0


(System Variable x)

x3 +ax2 +bx+ c, Companion:

 0 0 −c
1 0 −b
0 1 −a


Note that the đrst of the following matrices is the companion ma-

trix of its own characteristic and minimal polynomials.
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Compute>Matrices>Minimal Polynomial
0 0 0 0 −a
1 0 0 0 −b
0 1 0 0 −c
0 0 1 0 −d
0 0 0 1 −e

Minimal Polynomial: X5+ eX4+dX3+ cX2+bX +a

A rational canonical form, sometimes called a Frobenius form, is a
block diagonal matrix with each block the companion matrix of its
own minimal and characteristic polynomials. Each of the minimal
polynomials of these blocks is a factor of the characteristic polynomial
of the original matrix. ăe polynomials that determine the blocks of
the rational canonical form sequentially divide one another.

Choosing Compute>Matrices>Rational Canonical Form pro-
duces a factorization of a square matrix as PBP−1, where B is in ratio-
nal canonical form. ăe matrix B will have entries from the smallest
subring of the complex numbers containing the entries of the origi-
nal matrix. ăe invertible matrices will have entries from the smallest
subđeld of the complex numbers containing the entries of the origi-
nal matrix. For example, if the matrix has integer entries, the rational
canonical form will also, and the invertible matrices will have rational
entries.

Compute>Matrices> Rational Canonical Form

 1 2 3
4 5 6
7 8 9

 Rational Canonical Form:

 1 1 30
0 4 66
0 7 102

 0 0 0
1 0 18
0 1 15




1 −2 1

0 −17
9

11
9

0
7
54

− 2
27


Notice that the rational canonical form in the preceding exam-

ple is the companion matrix of its minimal polynomial X3−15X2−
18X . Now look at the companion matrix of this same matrix.

Compute> Evaluate

x

 1 0 0
0 1 0
0 0 1

−
 1 2 3

4 5 6
7 8 9

=

 x−1 −2 −3
−4 x−5 −6
−7 −8 x−9


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Compute>Matrices> Smith Normal Form x−1 −2 −3
−4 x−5 −6
−7 −8 x−9

Smith Normal Form:

 1 0 0
0 1 0
0 0 −18x−15x2 + x3


Notice that the polynomial occurring in the preceding Smith nor-

mal form is the same polynomial as occurred earlier.

Compute>Matrices> Rational Canonical Form 5 −6 −6
−1 4 2

3 −6 −4

 Rational Canonical Form:

 3 9 2
0 −1 −
1 5 1

 0 −2 0
1 3 0
0 0 2

 1 −1 −2
0 −1 0
−1 6 3


ăere are two blocks in the preceding rational canonical form:

1. ăecompanionmatrix
[

0 −2
1 3

]
ofX2−3X+2= (X−1)(X−2)

2. ăe companion matrix [2 ] of X−2

Compute>Matrices> Characteristic Polynomial, Compute> Factor 5 −6 −6
−1 4 2

3 −6 −4

 ,
characteristic polynomial: X3−5X2 +8X−4 = (X−1)(X−2)2

Compute>Matrices>Minimal Polynomial, Compute> Factor 5 −6 −6
−1 4 2

3 −6 −4

 ,
minimal polynomial: X2−3X +2 = (X−1)(X−2)

Note
The Smith normal form of the characteristic
matrix of A displays the factors of the
characteristic polynomial of A that determine
the rational canonical form of A.ăe characteristic matrix xI−A of the preceding matrix A is

x

 1 0 0
0 1 0
0 0 1

−
 5 −6 −6
−1 4 2

3 −6 −4

=

 x−5 6 6
1 x−4 −2
−3 6 x+4


Compute>Matrices> Smith Normal Form 5 −6 −6
−1 4 2

3 −6 −4

Smith Normal Form:

 1 0 0
0 2 0
0 0 2


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ăe previous examples illustrate a relationship among the Smith
normal form, the characteristicmatrix, and the rational canonical form
of a matrix.

Jordan Normal Form
ChoosingCompute>Matrices> JordanNormal Formproduces

a factorization of a square matrix as PJP−1, where J is in Jordan nor-
mal form. ăis form is a block diagonal matrix with each block an ele-
mentary Jordan matrix. More speciđcally, the Jordan normal form of
an n×n matrix A with k linearly independent eigenvectors is a matrix
of the form

J(A) =


Jn1 (λ 1) 0 · · · 0

0 Jn2 (λ 2) · · · 0
...

...
. . .

...
0 0 · · · Jnk (λ k)


where n1 + n2 + · · ·+ nk = n, and each diagonal block Jni (λ i) is an
ni×ni elementary Jordan matrix of the form

Jni (λ i) =


λ i 1 · · · 0 0
0 λ i · · · 0 0
...

...
. . .

...
...

0 0 · · · λ i 1
0 0 · · · 0 λ i


ăe matrix J (A) is similar to A and its form is as nearly diagonal as
possible among all matrices of the form P−1AP.

Compute>Matrices> Jordan Normal Form 2 −1 0
−1 2 −1
0 −1 2

=

 1
4

1
4 − 1

2
1
4

√
2 − 1

4

√
2 0

1
4

1
4

1
2

 2−
√

2 0 0
0

√
2+2 0

0 0 2

 1
√

2 −1
1 −

√
2 1

−1 0 1


ăus, the Jordan normal form of

A =

 2 −1 0
−1 2 −1

0 −1 2


is

J

 2 −1 0
−1 2 −1

0 −1 2

=

 2 0 0
0
√

2+2 0
0 0 −

√
2+2


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Normal Forms of Matrices

In this case, J(A) is diagonal, so each Jni (λ i) is a 1× 1 matrix. ăe
matrix A has the characteristic and minimal polynomial

−4+10X−6X2 +X3 = (X−2)
(

X−2−
√

2
)(

X−2+
√

2
)

whose roots
{

2, 2+
√

2, 2−
√

2
}

are thediagonal entries of the Jor-
dan normal form.

Compute>Matrices> Jordan Normal Form
2 0 0 0
1 2 0 0
0 0 2 0
0 0 −3 2

=


1 0 0 0
0 1 0 0
0 0 − 1

3 0
0 0 0 1




2 0 0 0
1 2 0 0
0 0 2 0
0 0 1 2




1 0 0 0
0 1 0 0
0 0 −3 0
0 0 0 1


ăus, the Jordan normal form is

J




2 0 0 0
1 2 0 0
0 0 2 0
0 0 −3 2


=


2 0 0 0
1 2 0 0
0 0 2 0
0 0 1 2


In this case, Jn1 (λ 1) = Jn2 (λ 2) =

[
2 0
1 2

]
, the companion

matrix of the minimal polynomial of

A =


2 0 0 0
1 2 0 0
0 0 2 0
0 0 −3 2


ăe characteristic polynomial of the matrix A is (X−2)4 with re-
peated roots {2, 2, 2, 2}, and the minimal polynomial of A is X2−
4X +4 = (X−2)2.

Compute>Matrices> Jordan Normal Form
2 0 0 0
0 2 0 0
0 0 2 0
0 0 0 2

=


1 0 0 0
0 1 0 0
0 0 1 0
0 0 0 1




2 0 0 0
0 2 0 0
0 0 2 0
0 0 0 2




1 0 0 0
0 1 0 0
0 0 1 0
0 0 0 1


ăe preceding matrix is already in Jordan normal form. Its mini-

mal polynomial is X−2 and its characteristic polynomial is (X−2)4,
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Chapter 8 | Matrix Algebra

the same characteristic polynomial as the previous one, but a different
minimal polynomial and a different Jordan normal form.

Compute>Matrices> Jordan Normal Form([
1 2
−1 −1

])
=

[
i −i

1
2 −

1
2 i 1

2 +
1
2 i

][
−i 0
0 i

][ 1
2 −

1
2 i 1

1
2 +

1
2 i 1

]

In this case, Jn1 (λ 1) = [i] and Jn2 (λ 2) = [−i] are 1×1 matrices.

ăe matrix
[

1 2
−1 −1

]
has the characteristic and minimal polyno-

mial x2 +1 = (x+ i)(x− i).

Matrix Decompositions

ăere are various ways to decompose a matrix into the product of
simplermatrices of special types. ăese decompositions are frequently
useful in numerical matrix calculations.

Singular Value Decomposition
Any m×n realmatrix A can be factored into a product A =UDV ,

withU andV real orthogonal m×m and n×n matrices, respectively,
and D a diagonal matrix with positive numbers in the đrst rank-A en-
tries on the main diagonal, and zeroes everywhere else. ăe entries on
themain diagonal of D are called the singular values of A. ăis factor-
ization A = UDV is called a singular value decomposition (SVD) of
A.

Compute>Matrices> Singular Values 5 −5 −3
−3 0 5
1.0 5 4

Singular Values: [10.053,4.6119,3.5588]

[
5 −5 −3
−3 0 5

]
Singular Values: [8.8882,3.7417]
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Matrix Decompositions

Compute>Matrices> Singular Value Decomposition 5 −5 −3
−3 0 5

1 5 4

=

 0.72152 0.19119 0.66547
−0.45504 −0.59348 0.66387
−0.52187 0.78181 0.34121

 ·
 10.053 0 0

0 4.6119 0
0 0 3.5588

 0.44273 −0.61841 −0.64927
0.76285 0.64032 −8.9706×10−2

0.47122 −0.45558 0.75525


ăese two outer matrices fail the orthogonality test because they

are numerical approximations only. You can check the inner products
of the columns to see that they are approximately orthogonal.

Compute>Matrices> Singular Values(
1 2.0
3 4

)
Singular Values: [5.4650,0.36597]

Compute>Matrices> Singular Value Decomposition(
1 2
3 4

)
=

(
0.40455 −0.91451
0.91451 0.40455

)(
5.4650 0

0 0.36597

)(
0.57605 0.81742
0.81742 −0.57605

)
PLU Decomposition

Any m× n real or complex matrix A can be factored into a prod-
uct A = PLU , with L and U lower and upper triangular m×m and
m× n matrices, respectively, with 1’s on the main diagonal of L, and
with P a permutation matrix. ăis factorization A = PLU is called
the PLU decomposition of A. ăe matrices P and L are invertible and
the matrixU is a row echelon form of A.

Compute>Matrices> PLU Decomposition 1 2 3
2 4 6
3 2 1

 PLU Decomposition:

 1 0 0
0 0 1
0 1 0

 1 0 0
3 1 0
2 0 1

 1 2 3
0 −4 −8
0 0 0


[

0.532 1.95
1.5 0.0013

]
PLU Decomposition:

[
0 1
1 0

][
1.0 0.0

0.35467 1.0

][
1.5 0.0013
0.0 1.9495

]
(

5i
√

2
−7 2π/3

)
PLU Decomposition:

(
1 0
0 1

)(
1 0
7
5 i 1

)(
5i

√
2

0 2
3 π− 7

5 i
√

2

)
335



i
i

“Compute60” — 2011/12/20 — 14:27 — page 336 — #346 i
i

i
i

i
i

Chapter 8 | Matrix Algebra

Note that theupper triangularmatrix in theđrst line of the preced-
ing example is the same as that in the following example. In general,
the upper triangular matrix in the PLU decomposition is the echelon
form of the original matrix obtained by Gaussian elimination.

Compute>Matrices> Fraction Free Gaussian Elimination 1 2 3
2 4 6
3 2 1

Fraction Free Gaussian Elimination:

 1 2 3
0 −4 −8
0 0 0


QR Decomposition Keyboard Shortcuts

To create a matrix with a keyboard shortcut

• Press Ctrl+k and then press
m, or

• Press Ctrl+k and then press
Shiĕ+m.

ăe đrst choice produces a matrix
with the same attributes as your
most recently created matrix. ăe
second choice produces a 2×2
matrix.

A real m× n matrix A with m ≥ n can be factored as a product
QR, where Q is an orthogonal m×m matrix (the columns of Q are
orthonormal—that is, QQT is the m×m identity matrix) and R is
upper-right triangular with the same rank as A. If the original matrix
A is square, then so is R. If A has linearly independent columns, then
R is invertible. (See more examples on page 325.)

ăeQRdecomposition is oĕenused to solve the linear least squares
problem, and is the basis for a particular eigenvalue algorithm, called
the QR algorithm.
Toobtain theQR factorization

• With the insert point in a matrix, choose choose Compute >
Matrices>QR Decomposition.

Compute>Matrices> QR Decomposition( √
2

2 0√
2

2 1

)
QR Decomposition:

( 1
2

√
2 − 1

2

√
2

1
2

√
2 1

2

√
2

)(
1 1

2

√
2

0 1
2

√
2

)
 1 1

0 −2
3 −1

QR Decomposition:

 1
10

√
10 3

35

√
5
√

7 3
14

√
14

0 − 1
7

√
5
√

7 1
7

√
14

3
10

√
10 − 1

35

√
5
√

7 − 1
14

√
14

 √10 − 1
5

√
10

0 2
5

√
5
√

7
0 0


Cholesky Decomposition

For a real square matrix that happens to be symmetric (A = AT )
and positive deđnite (all eigenvalues are positive), there is a particu-
larly efficient triangular decomposition, signiđcantly faster than alter-
native methods for solving linear equations.

An n×n real symmetric positive-deđnitematrix A can be factored
into a product A = GGT , with G a real positive-deđnite lower trian-
gular n×n matrix. ăis factorization A=GGT is called theCholesky
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decomposition of A.

Compute>Matrices> Cholesky Decomposition[
2 −1

−1 2

]
Cholesky Decomposition:

[ √
2 0

− 1
2

√
2 1

2

√
2
√

3

][ √
2 − 1

2

√
2

0 1
2

√
2
√

3

]
[

2.0 −1.0
−1.0 2.0

]
Cholesky Decomposition:

[
1.4142 0
−0.70711 1.2247

][
1.4142 −0.70711

0 1.2247

]


1 1
2

1
3

1
2

1
3

1
4

1
3

1
4

1
5

Cholesky Decomposition:


1 0 0
1
2

1
6

√
3 0

1
3

1
6

√
3 1

30

√
5




1 1
2

1
3

0 1
6

√
3 1

6

√
3

0 0 1
30

√
5


Exercises

1. ăe vectors u =
[

1 1 0
]
and v =

[
1 1 1

]
span a

plane in R3. Find the projection matrix P onto the plane, and
đnd a nonzero vector b that is projected to zero.

2. For the matrix 
2 0 0 0
1 2 0 0
0 0 2 0
0 0 −3 2


đnd the characteristic polynomial, minimal polynomial, eigen-
values, and eigenvectors. Discuss the relationships among these,
and explain the multiplicity of the eigenvalue.

3. Which of the following statements are correct for the matrix

A =

[
1 1 1
1 0 2

]
? ăe set of all solutions x =

 x1
x2
x3

 of the

equation Ax =

[
0
0

]
is the column space of A; the row space

of A; a nullspace of A; a plane; a line; a point.

4. Show that det

 x y 1
a b 1
c d 1

 = 0 is the equation of the line

through the two points (a,b) and (c,d).
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Chapter 8 | Matrix Algebra

Vandermonde Matrix
1 x1 x2

1 x3
1

1 x2 x2
2 x3

2

1 x3 x2
3 x3

3

1 x4 x2
4 x3

4


(see page 287)

5. Show that the 4×4 Vandermonde matrix has determinant

(x2− x1)(x3− x1)(x3− x2)(x1− x4)(x2− x4)(x4− x3) .

Solutions
1. ăe projection matrix P onto the plane in R3 spanned by the

vectorsu= [1,1,0] andv= [1,1,1] is theproductP=A
(
AT A

)−1 AT ,
where u and v are the columns of A.

P=

 1 1
1 1
0 1

 1 1
1 1
0 1

T  1 1
1 1
0 1

−1 1 1
1 1
0 1

T

=

 1
2

1
2 0

1
2

1
2 0

0 0 1



Note that Pw is a linear combination of u and v for any vector
w = (x,y,z) in R3, so P maps R3 onto the plane spanned by u
and v.

1
2

1
2 0

1
2

1
2 0

0 0 1


 x

y
z

=

 1
2 x+ 1

2 y
1
2 x+ 1

2 y
z

 =

(
x+ y

2
− z
)  1

1
0

+z

 1
1
1



To đnd a nonzero vector b that is projected to zero, leave the in-
sertion point in the matrix P and choose Compute>Matrices
>Nullspace Basis.

1
2

1
2 0

1
2

1
2 0

0 0 1

Nullspace Basis:


 −1

1
0



2. ăematrix


2 0 0 0
1 2 0 0
0 0 2 0
0 0 −3 2

has characteristic polynomial

(X−2)4, minimal polynomial 4−4X +X2 = (X−2)2, and
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eigenvalues2. To compute eigenvectors, đrst change at least one
entry to Ĕoating point.




0.0
0.0
0.0
1.0


 ↔ 2.0,




0.0
1.0
0
0


↔ 2.0




0.0
0.0
0.0
0.0


 ↔ 2.0,




0.0
0.0
0.0
0.0


↔ 2.0

ăe minimal polynomial is a factor of the characteristic poly-
nomial. ăe eigenvalue 2 occurs with multiplicity 4 as a root of
the characteristic polynomial (X−2)4 . ăe eigenvalue 2 has
two linearly independent eigenvectors. Note that


2 0 0 0
1 2 0 0
0 0 2 0
0 0 −3 2




0
0
0
1

 =


0
0
0
2

= 2


0
0
0
1




2 0 0 0
1 2 0 0
0 0 2 0
0 0 −3 2




0
1
0
0

 =


0
2
0
0

= 2


0
1
0
0



3. ăe solutions of this equation are in R3, and the column space
of A is a subset of R2, so these solutions cannot be the column
space of A. ăey do form the nullspace of A by the deđnition
of nullspace; consequently, this set is a subspace of R3. ăe

product of A with the đrst row of A is
[

1 1 1
1 0 2

] 1
1
1

=[
3
3

]
, which is not

[
0
0

]
, so the solution set is not the row

space of A. To determine the nature of this space, solve the sys-
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Chapter 8 | Matrix Algebra

tem of equations by choosing Compute> Solve> Exact to get

[
1 1 1
1 0 2

] x1
x2
x3

=

[
0
0

]
, Solution:

 −2t1
t1
t1


ăe subspace is the line that passes through the origin and the
point

[
−2 1 1

]
.

4. Solving the equation det

 x y 1
a b 1
c d 1

 = 0 for y gives the

solution y =
xd− xb+ cb−ad

c−a
, which can be rewritten as

y =
d−b
c−a

x+
cb−ad

c−a
. If c ̸= a, this is the equation of the line

through the twopoints (a,b) and (c,d). Ifc= a,det

 x y 1
a b 1
a d 1

=

xb− xd+ad−ab = 0 has the solution x = a, the equation of
the line through the points (a,b) and (a,d).

5. Choose Evaluate, then Factor to obtain∣∣∣∣∣∣∣∣∣
1 x1 x2

1 x3
1

1 x2 x2
2 x3

2

1 x3 x2
3 x3

3

1 x4 x2
4 x3

4

∣∣∣∣∣∣∣∣∣=(x2− x1)(x3− x1)(x3− x2)(x1− x4)(x2− x4)(x4− x3)
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Vector Calculus

The calculus is the greatest aidwe have to the application of physical truth in the broadest sense of theword. William Fogg Osgood (1864–1943)

V ector calculus is the calculus of functions that assign vectors Vectors

Gradient, Divergence, Curl, and
Related Operators

Plots of Vector Fields and
Gradients

Scalar and Vector Potentials

Matrix-Valued Operators

Plots of Complex Functions

to points in space. It is concerned with differentiation and
integration of vector đelds, primarily in 3-dimensional Eu-

clidean space.
Vector calculus operations are of particular importance in solving

physical problems. ăey can be applied to problems such as đnding
the work done by a force đeld in moving an object along a curve or
đnding the rate of Ĕuid Ĕow across a surface.

Vectors
ăe term vector is used to indicate a quantity that has both mag-

nitude and direction. A vector is oĕen represented by an arrow or a
directed line segment. ăe length of the arrow represents the magni-
tude of the vector and the arrow points in its direction. Two directed
line segments are considered equivalent if they have the same length
and point in the same direction. In other words, a vector v can be
thought of as a set of equivalent directed line segments.

A two-dimensional vector is an ordered pair a = (a1,a2) of real
numbers. A three-dimensional vector is anordered triplea=(a1,a2,a3)
of real numbers. More generally, an n-dimensional vector is an ordered
n-tuplea=(a1,a2, . . . ,an)of real numbers. ăenumbersa1,a2, . . . ,an
are called the components of a.
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Chapter 9 | Vector Calculus

Notation for Vectors
You can represent vectors in any of the following ways.

• n-tupleswithinparentheses or square brackets: (2,−1,0), (x1,x2,x3),
[3,2,1], [x1,x2,x3]

• 1× n matrices:
[

1 2 3
]
,
[

5 −1 3 17 −8 2
]
,[

x1 x2 x3 x4
]

• n×1 matrices:

 1
0
−1

,
[

35
−4

]
,
(

x1
x2

)

ăis Ĕexibility allows you to use the output of previous work as
input, without undue worry about the shape of the output. For pur-
poses of clear exposition, you will đnd it preferable to use consistent
notation for vectors. Calculations involving vectors

Although vectors may be represented in
various ways, the result of an operation on
vectors will be returned in matrix form.

Tocreate a vector inmatrix form
1. Choose Insert>Math Objects>Matrix.

2. Set the number of rows (or columns) to 1 and the number of
columns (or rows) to the dimension of the vector.

3. Type the values for the components in the input boxes.

4. Select the vectorwith themouse and choose Insert>MathOb-
jects> Brackets and click a leĕ bracket to enclose the vector in
expanding brackets.

Tocreate a vector in list form
1. Choose Insert>MathObjects>Brackets and click a leĕbracket.

2. With the insert point inside the expanding brackets, type the
vector components, separated by commas.

Plots of vectors in 2D and 3D
Toplot the vectora =

1. Deđne a =
(

3 2
)
.

2. Place the insert point in the expression xa.

3. Choose Compute> Plot 2D> Rectangular.
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4. Revise the plot. Change the Plot Interval to 0≤ x≤ 1.

Or

1. Place the insert point in the matrix
(

0 0
3 2

)
.

2. Choose Compute> Plot 2D> Rectangular.

Compute> Plot 2D> Rectangular(
0 0
3 2

)

0 1 2 3
0.0

0.5

1.0

1.5

2.0

x

y

(3,2) Plot of 2D vector
With Axes Type Boxed, the vector should
appear as the diagonal of a rectangle.

Toplot the vectora = ( 3 2 1 )

1. Deđne a =
(

3 2 1
)
.

2. Place the insert point in the expression xa.

3. Choose Compute> Plot 3D> Rectangular.

4. Revise the plot, changing the Interval to 0≤ x≤ 1.

Or

1. Place the insert point in the matrix
(

0 0 0
3 2 1

)
.

2. Choose Compute> Plot 3D> Rectangular.
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Compute> Plot 3D Rectangular(
0 0 0
3 2 1

)

1.0

z 0.5

0.0

1
y

02

x
0123

Plot of 3D vector
With Axes Type Boxed, the vector should
appear as the diagonal of a box. Rotate the
plot on your screen for better visualization.

Vector Sums and Scalar Multiplication
ăe sum of two vectors [x1,x2, ...,xn] and [y1,y2, ...,yn] is deđned

by

[x1,x2, ...,xn]+ [y1,y2, ...,yn] = [x1 + y1,x2 + y2, ...,xn + yn]

ăe product of a scalar a and a vector [x1,x2, ...,xn] is deđned by

a [x1,x2, ...,xn] = [ax1,ax2, ...,axn]

Toevaluate a vector sum

• Type the expression inmathematicsmode and chooseCompute
> Evaluate.

Compute> Evaluate
(x1,x2,x3)+(y1,y2,y3) =

[
x1 + y1 x2 + y2 x3 + y3

]
(2,−1,0)+(2,3,−5) =

[
4 2 −5

]
[1,2,3,4.3]− [3,−5.1,6,0] =

[
−2 7.1 −3 4.3

]
(6,−1+ i)+(2−3i,3) =

[
8−3i 2+ i

]
Vector output
Although the vectors for the input can be in
any standard form, the output is always a
matrix.
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Compute> Evaluate(
a
b

)
+

(
c
d

)
=

(
a+ c
b+d

)
[

1
2

]
−
[
−3
1

]
=

[
4
1

]
[

x y
]
+
[

w z
]
=
[

w+ x y+ z
]

Compute> Plot 3D> Rectangular[
0 0 0
2 1 1

] [
0 0 0
1 2 2

] [
0 0 0
3 3 3

]
[

2 1 1
3 3 3

] [
1 2 2
3 3 3

]

0
1

0

x

b

1

az

32

y

2

2

a + b

1
3 0

3
Vector sum
The vector suma+b appears as the diagonal
of a parallelogramwith edge vectors a andb.
Rotate the plot for better visualization.

Toevaluate the product of a scalarwith a vector
• Type the expression inmathematicsmode and chooseCompute
> Evaluate.

Compute> Evaluate

a
[

x1 x2 x3
]
=
[

ax1 ax2 ax3
]

6
[

2 3 −5
]
=
[

12 18 −30
]

i
√

3
[

2 −6i 5−3i
]
=
[

2i
√

3 6
√

3 (3+5i)
√

3
]
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Dot Product
ăe dot product (or inner product) of two vectors (a1,a2, ...,an)

and (b1,b2, ...,bn) with real entries is deđned by

(a1,a2, ...,an) · (b1,b2, ...,bn) = a1b1 +a2b2 + · · ·+anbn

and the inner product of two vectors with complex entries is deđned
by Complex Conjugate

To use overbar notation for complex conjugate,
choose Tools> Preferences> Computation
> Input and check “Overbar accent means
conjugate.”

(a1,a2, ...,an) · (b1,b2, ...,bn) = a1b∗1 +a2b∗2 + · · ·+anb∗n

where b∗ = x− iy is the complex conjugate of b = x+ iy. For real
numbers b, it is clear that b∗ = b, so these two deđnitions are consis-
tent. ăe dot product can also be obtained by matrix multiplication:

(a1,a2, ...,an)·(b1,b2, ...,bn)=
[

a1 a2 ... an
]


b∗1
b∗2
...

b∗n

=


a1
a2
...

an


T 

b∗1
b∗2
...

b∗n


Toenter the dot used for the dot product

• Select · from the Binary Operations tab ±÷ .

Tocompute a dot product
1. Type the expression.

2. With the insert point in the expression, choose Compute >
Evaluate.

Compute> Evaluate
(1,2,3) · (3,2,1) = 10
[3x,−1,5] · [1,1,1] = 3x+4
(1+2i,−3i) · (5,1− i) = 8+7i(

1+2i −3i
)( 5

(1− i)∗

)
= 8+7i

ăe standard default on variables returns complex solutions. You
can change this default with the function assume.
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Compute> Evaluate
(u,v,w) · (x,y,z) = ux∗+ vy∗+wz∗

assume(u, real) = R
assume(v, real) = R
assume(w, real) = R
assume(x, real) = R
assume(y, real) = R
assume(z, real) = R
(u,v,w) · (x,y,z) = ux+ vy+wz

Note
Type assume, real, and complex in
mathematics mode, and they will turn upright
and gray.

For the following examples of dot products with n = 3, deđne

a =
[

1 2 3
]
, b =

 1
0
−1

 , c = [3,2,1] , d = (2,−1,0)

by placing the insert point in each equation and choosingCompute>
Deđnitions>New Deđnition.

Compute> Evaluate
a · c = 10 a ·b =−2 c ·d = 4

Cross Product
ăe cross product of three-dimensional vectorsa=(a1,a2,a3) and

b = (b1,b2,b3) is deđned by

a×b = (a2b3−a3b2,a3b1−a1b3,a1b2−a2b1)

Toenter the cross used for the cross product
• Select× from the Binary Operations panel under ±÷ .

Tocompute a cross product
• Place the insert point in the cross product and chooseCompute
> Evaluate.

For the following examples, use the vectors a =
[

1 2 3
]
,

b =

 1
0
−1

, c = [3,2,1], and d = (2,−1,0) deđned in the previ-

ous section.

347



i
i

“Compute60” — 2011/12/20 — 14:27 — page 348 — #358 i
i

i
i

i
i

Chapter 9 | Vector Calculus

Compute> Evaluate

a×b =
[
−2 4 −2

]
a× c =

(
−4 8 −4

)
c×d =

(
1 2 −7

)
 0.35
−0.73

1.2

×
 0.85

0.32
−0.77

=

 0.1781
1.2895
0.7325


[

1 −2 5
]
×
[

5 3 −5
]
=
[
−5 30 13

]
An important geometric property of the cross product is that the

vector u×v is perpendicular to both u and v. In the following exam-
ple, deđne u =

[
1 1 0

]
, v =

[
1 0 1

]
, and w = u× v =[

1 −1 −1
]
. Plot these three vectors and revise the plot (on the

Axes page, select Equal Scaling Along Each Axis).

Compute> Plot 3D Rectangular[
0 0 0
1 1 0

] [
0 0 0
1 0 1

] [
0 0 0
1 −1 −1

]

­1.0

w

0

u
0.0

­1.0 x

­0.5

v

z

0.5

1.0

0.0

0.5

­0.5

y
1

1.0

Cross product
Rotate the plot on your screen to observe that
vectorw is perpendicular to both u and v.

Standard Basis
ăree-dimensional vectors are oĕen written in terms of the stan-

dard basis:

i = (1,0,0)
j = (0,1,0)
k = (0,0,1)
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ăe cross product of the two vectors a1i+a2j+a3k and b1i+b2j+
b3k can then be computed by using the determinant∣∣∣∣∣∣

i j k
a1 a2 a3
b1 b2 b3

∣∣∣∣∣∣= i(a2b3−a3b2)−j(a1b3−b1a3)+k(a1b2−a2b1)

Compute> Evaluate∣∣∣∣∣∣
i j k
1 2 3
1 0 −1

∣∣∣∣∣∣=−2i+4j−2k

Triple Cross Product
Since the cross product of two vectors produces another vector,

it is possible to string cross products together. Use the same vectors
a, b, c, and d as before for these triple vector products. Note that dif-
ferent choices of position for parentheses generally produce different
results. ăis demonstrates that the cross product is not an associative
operation.

ăe default order of operations for products is from leĕ to right.
Tocompute a triple cross product

1. Enter the cross product with appropriate choices of parentheses

2. With the insert point in the expression, choose Compute >
Evaluate.

For the following examples, use the vectors a =
[

1 2 3
]
,

b =

 1
0
−1

, c = [3,2,1], and d = (2,−1,0) deđned earlier.

Compute> Evaluate

a×b× c =
[

8 −4 −16
]

(a×b)× c =
[

8 −4 −16
]

a× (b× c) =
[

16 4 −8
]

a× ((b× c)×d) =
[

0 0 0
]

(a× (b× c))×d =
[
−8 −16 −24

]
To obtain intermediate results, select a subexpression that is sur-

rounded by parentheses and hold the Ctrl key down while evaluating.
ăis technique does an in-place computation, as illustrated in the fol-
lowing examples.
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Ctrl+Compute> Evaluate Compute> Evaluate

a× (b× c) = a×

 2
−4
2

 a×

 2
−4
2

=
(

16 4 −8
)

(a×b)× c =
(
−2 4 −2

)
× c

(
−2 4 −2

)
× c =

(
8 −4 −16

)
Triple Scalar Product Tip

Whenmixing cross products with scalar
products, use parentheses for clarity. As
always, careful and consistent use of
mathematical notation is in order. Whenever
in doubt, add an extra set of parentheses to
clarify an expression.

A triple scalar product is the dot product of one vector with the
cross product of two vectors.
Tocompute a triple scalar product

1. Enter the triple scalar productwith appropriate choices of paren-
theses.

2. With the insert point in the expression, choose Compute >
Evaluate. Caution

(1,0,1) · (1,2,3)× (3,2,1) is not
interpreted as a triple scalar product, but as the
product of the scalar (1,0,1) · (1,2,3) =
4with the vector (3,2,1).

Ctrl+Evaluate, Compute> Evaluate
(1,0,1) · ((1,2,3)× (3,2,1)) =−8
((1,0,1)× (1,2,3)) · (3,2,1) =−8

(1,0,1) · (1,2,3)× (3,2,1) =
(

12 8 4
)

Tođnd the volumeof theparallelepiped spannedby the vectorsA,B, andC Volume
The volume of the parallelepiped spanned by
three vectorsA,B, andC is equal to
|A · (B×C)|.

• Evaluate the absolute valueof the triple scalar productA·(B×C).

Toplot the parallelepiped spannedby the vectorsA,B, andC
1. Deđne each of the vectors A, B, andC.

2. With the insert point in the expression sA+ tB, choose Com-
pute> Plot 3D> Rectangular.

3. Revise the plot intervals to 0≤ s≤ 1 and 0≤ t ≤ 1.

4. Select and drag to the plot each of the expressions sA+tC, sB+
tC, A+ sB+ tC, sA+B+ tC, and sA+ tB+C.

Compute> Deönitions> New Deönition
A = [0,1,1] B = [1,0,1] C = [1,1,0]

The volume of a parallelipiped does not
depend on the order in which the triple scalar
product is computed.

Compute> Evaluate
|A · (B×C)|= 2 |B · (C×A)|= 2 |C · (A×B)|= 2
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Compute> Plot 3D> Rectangular
sA+ tB (0≤ s≤ t , 0≤ s≤ 1)
sA+ tC, sB+ tC, A+ sB+ tC, sA+B+ tC, sA+ tB+C

2

2

1

x

0

2
y

z

1

0

1

0

Tip
Any three-dimensional object can be rotated
on the screen to view the back side.

ăetriple product (a1,a2,a3)·[(b1,b2,b3)× (c1,c2,c3)] can also
be interpreted as the determinant Volume of a parallelepiped

It is clear from this equation that if all the
vertices of a parallelepiped have integer
coordinates, then the volume is also an integer.

∣∣∣∣∣∣
a1 a2 a3
b1 b2 b3
c1 c2 c3

∣∣∣∣∣∣ = a1b2c3−a1b3c2−b1a2c3

+b1a3c2 + c1a2b3− c1a3b2

Vector Norms
You can compute vector norms ∥v∥n for vectors v = (v1, ...,vk)

and positive integers n and for ∞, where

∥v∥n =

(
k

∑
i=1
|vi|n

)1/n

∥v∥∞ = max(|vi|)

with entries vi either real or complex, as illustrated by the following
examples.

Tocompute a vector norm
1. Select the vector, choose Insert > Math Objects > Brackets,

and choose the norm symbols. Choose OK. Norm symbol
Type Ctrl+| to enter the norm symbol ∥ ∥ .

2. Choose Insert > Subscript, and type a positive integer or the
symbol ∞.

351



i
i

“Compute60” — 2011/12/20 — 14:27 — page 352 — #362 i
i

i
i

i
i

Chapter 9 | Vector Calculus

3. With the insert point in the vector, choose Compute> Evalu-
ate.

Compute> Evaluate
∥(a,b,c)∥1 = |a|+ |b|+ |c|

∥(a,b,c)∥3 =
3
√
|a|3 + |b|3 + |c|3

∥(−1,2,1)∥5 =
5
√

34
∥(a,b,c,d)∥∞ = max(|a| , |b| , |c| , |d|)
∥[8,−10,2]∥∞ = 10∥∥∥∥( a

b

)∥∥∥∥
2
=
√

a2 +b2

Euclidean norm
The default ∥v∥ is the 2-norm, which is also
known as the Euclidean norm. It computes the
magnitude, or length, of a vector. The 2-norm
does not require a subscript.

You can also obtain the 2-norm by choosingCompute>Matrices
>Norm.

Compute>Matrices> Norm(
a b c

)
, 2-norm:

√
|a|2 + |b|2 + |c|2

[8,−10,2+ i], 2-norm: 13

Before doing the next set of examples, make the following deđni-
tion.

Compute> Deönitions> New Deönition
v = [3,2,1]

Compute> Evaluate, Compute> Evaluate Numeric
∥v∥1 = 6 ∥v∥1 ≈ 6.0
∥v∥2 =

√
14 ∥v∥2 ≈ 3.7417

∥v∥6 =
6
√

794 ∥v∥6 ≈ 3.043
∥v∥20 =

20
√

3487832978 ∥v∥20 ≈ 3.0
∥v∥∞ = 3 ∥v∥∞ ≈ 3.0

Interesting tidbit
This series of examples suggests that

lim
n→∞
∥v∥n = ∥v∥∞

Example ăe area of the parallelogram in the plane with vertices
(0,0), (a1,a2), (b1,b2), and (a1 +b1,a2 +b2) is given by

∥(a1,a2,0)× (b1,b2,0)∥

In particular, the area of the parallelogram spanned by the two vectors
(1,2) and (2,1) is given by

∥(1,2,0)× (2,1,0)∥= 3
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ăis parallelogram appears in the following plot.

Compute> Plot 2D> Rectangular
(0,0,1,2,3,3,2,1,0,0), Equal Scaling Along Each Axis

0 1 2 3
0

1

2

3

x

y

Since A · B = ∥A∥∥B∥cosθ , where θ is the angle between the
vectors A and B, you can use the dot product to đnd the angle between
two vectors.

Compute> Evaluate
(1,2,−3) · (−2,1,2) =−6
∥(1,2,−3)∥∥(−2,1,2)∥cosθ = 3

√
14cosθ

ăe angle between the vectors (1,2,−3) and (−2,1,2) is given
by the principal solution to the equation −6 = 3(cosθ)

√
14. For

this, choose Tools > Preferences > Computation, Engine page, and
check Principal Value Only.

Compute> Solve> Exact, Compute> Evaluate Numeric
−6 = 3(cosθ)

√
14, Solution: π + arccos 1

7

√
14≈ 4.148446

ăus the angle between these two vectors is approximately
2.1347rad or roughly 122.31 ◦.

Planes and Lines inR3

A vector equation of the plane through the point (x0,y0,z0) and
orthogonal to the vector (a,b,c) is given by

[(x,y,z)− (x0,y0,z0)] · (a,b,c) = 0
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Tođnd an equationof the plane through three points
1. For the points (x0,y0,z0), (x1,y1,z1), and (x2,y2,z2), com-

pute the differences

u = (x0,y0,z0)− (x1,y1,z1)

and

v = (x0,y0,z0)− (x2,y2,z2)

2. Compute the cross product

n = u×v

3. Simplify the equation

[(x,y,z)− (x0,y0,z0)] ·n = 0

Example Tođndan equationof theplane through thepoints (1,1,0),
(1,0,1), and (0,1,1), we đrst compute the vectors

u = (1,1,0)− (1,0,1) = (0,1,−1)
v = (1,1,0)− (0,1,1) = (1,0,−1)

and the cross product

n = (0,1,−1)× (1,0,−1) = (−1,−1,−1)

and simplify the equation

[(x,y,z)− (1,1,0)] · (−1,−1,−1) = 0
−x+2− y− z = 0

x+ y+ z = 2

We plot this plane by đrst solving for z.

Compute> Solve> Exact (Variable: z)
x+ y+ z = 2, Solution: 2− y− x
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Compute> Plot 3D> Rectangular
2− y− x (Intervals: 0≤ x≤ 2, 0≤ y≤ 2,−2≤ z≤ 2)

2 2

1

z

0

x
1

0

y

­1
­2

0

1

2

A vector form of this plane is given by

[
0 1 1

]
+ s
[

0 1 −1
]
+ t
[

1 0 −1
]

Filled parallelogram
If s and t are restricted to the unit interval
(0≤ s≤ 1, 0≤ t ≤ 1), then the plot of
w+ su+ tv is a ölled parallelogramwith
edgesu and v.

Compute> Plot 3D> Rectangular[
0 1 1

]
+ s
[

0 1 −1
]
+ t
[

1 0 −1
]

(Intervals: 0≤ s≤ 1, 0≤ t ≤ 1)

1.02.0

0.0

x
y

1.5
0.5

0

­1
1.0

z

1

Toplot theđlled trianglewith edgesa andb, starting at the point c

• With the insert point in the expression c + sta + s(1− t)b,
choose Compute> Plot 3D> Rectangular.
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Compute> Plot 3D> Rectangular[
0 1 1

]
+ st

[
0 1 −1

]
+ s(1− t)

[
1 0 −1

]
(Intervals: 0≤ s≤ 1, 0≤ t ≤ 1)

0.0

0.0z

0.5

1.0

y

1.0

x

1.5

0.5

2.0 1.0

A vector equation of the line through the point (a,b,c) in the di-
rection of m = (u1,u2,u3) is given by

(x,y,z) = (a,b,c)+ t (u1,u2,u3)

ăis is equivalent to the system of three parametric equations

x = a+ tu1

y = b+ tu2

z = c+ tu3

Tođnd the equationof a line through twopoints
1. For the two points (a1,b1,c1) and (a2,b2,c2), compute the

difference

(a1,b1,c1)− (a2,b2,c2) = (a1−a2,b1−b2,c1− c2)

to đnd a vector that is parallel to the line.

2. An equation for the line is

(x,y,z) = (a1,b1,c1)+ t (a1−a2,b1−b2,c1− c2)
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Example To đnd an equation of the line through the two points
(1,2,3) and (2,1,2), đrst compute a vector

m = (1,2,3)− (2,1,2) = (−1,1,1)

that is parallel to the line, then simplify the equation

(x,y,z) = (1,2,3)+ t (−1,1,1) = (1− t,2+ t,3+ t)

ăe line can now be plotted.

Compute> Plot 3D> Rectangular
(1− t,2+ t,3+ t)

2.0

3.8

3.6

z
3.4

3.2

1.0 0.83.0 0.6 0.4

x

0.2 0.0

y
2.5

4.0

3.0

Lines and other curves in space can sometimes be more easily vi-
sualized by using a fat curve.

Compute> Plot 3D> Tube
(1− t,2+ t,3+ t) (Radius= 0.05)

2.0
y

2.5

x

3.0
1.0

0.0
0.5

3.5

z

3.0

4.0
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Gradient, Divergence, Curl, and Related Operators
ăree operations are of particular importance in vector calculus:

• gradient: measures the rate and direction of change in a scalar
đeld; the gradient of a scalar đeld is a vector đeld.

• divergence: measures a vector đeld’s tendency to originate from
or converge upon a given point.

• curl: measures a vector đeld’s tendency to rotate about a point;
the curl of a vector đeld is another vector đeld.

ăe operators gradient, divergence, curl, and the Laplacian are im-
plemented with their usual notation ∇, ∇·, ∇×, and ∇ ·∇, respec-
tively, followed by Evaluate. ăey also appear as special commands
on the Vector Calculus menu. Directional derivatives have a similar
implementation.

To enter the nabla symbol ∇ select the nabla from the Miscella-
neous Symbols tab ∞∂ .

Gradient
If f (x1,x2, . . . ,xn) is a scalar function of n variables, then the vec-

tor(
∂ f
∂x1

(c1,c2, . . . ,cn) ,
∂ f
∂x2

(c1,c2, . . . ,cn) , . . . ,
∂ f

∂xn1
(c1,c2, . . . ,cn)

)
is the gradient of f at the point (c1,c2, . . . ,cn) and is denoted ∇ f .
For n = 3, the vector ∇ f at (a,b,c) is normal to the level surface
f (x,y,z) = f (a,b,c) at the point (a,b,c). Potential energy and force

In physics, f represents potential energy, and
∇ f represents force.

Tocompute the gradient of a function f (x,y,z)
1. Place the insert point in the expression ∇ f (x,y,z).

2. Choose Compute> Evaluate.

Or

1. Place the insert point in the expression f (x,y,z).

2. Choose Compute> Vector Calculus>Gradient.
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Compute> Evaluate

∇(xyz) =

 yz
xz
xy


Compute> Vector Calculus> Gradient

xyz, Gradient is

 yz
xz
xy


You can also operate on a function name aĕer deđning the func-

tion. For example, if f is deđned by the equation f (x,y,z) = xyz ,
then you can evaluate ∇ f (x,y,z).

Compute> Evaluate

∇ f (x,y,z) =

 yz
xz
xy


ăedefault basis variables are x,y,z, in that order. You can change

the default by setting new basis variables.

To specify basis variables
1. Choose Compute> Vector Calculus> Set Basis Variables.

2. Enter a new set of basis variables in the dialog that appears. ăe
basis variables should be inmathematicsmode, separated by red
commas.

3. Choose OK.

Aĕer setting u,v,w as basis variables, the computing engine re-
gards c as a constant.

Compute> Evaluate

∇
(
cuv+ v2w

)
=

 cv
cu+2vw

v2


In the following example, we regard xy as the value of a function

of the default basis variables x, y, and z.
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Chapter 9 | Vector Calculus

Compute> Evaluate

∇(xy) =

 y
x
0


Divergence

A vector Ėeld is a vector-valued function. If

F(x,y,z) = [p(x,y,z),q(x,y,z),r(x,y,z)]

is a vector đeld, then the scalar

∇ ·F =
∂ p
∂x

(a,b,c)+
∂q
∂y

(a,b,c)+
∂ r
∂ z

(a,b,c)

is the divergence of F at the point (a,b,c). ăe dot product notation
is used because the symbol ∇ can be thought of as the vector operator

∇ =

(
∂
∂x

,
∂
∂y

,
∂
∂ z

)
Tocompute the divergence of a vector đeldF(x,y,z)

• Place the insert point in the expression ∇ ·F(x,y,z) and choose
Compute> Evaluate.

ăe default is that the đeld variables are x, y, and z, in that order. If
you want to label the đeld variables differently, or change the order of
the variables, reset the default with Set Basis Variables on the Vector
Calculus submenu.

For the following example, chooseCompute>Deđnitions>New
Deđnition to deđne the vector đelds F , G, H , and J.

Compute> Deönitions> New Deönition
F = [yz,2xz,xy] H =

[
yz 2xz xy

]
G = (xz,2yz,z2) J =

 x2

xy
2xz


Computedivergenceby choosingCompute>Evaluate, or by choos-

ing Compute> Vector Calculus>Divergence.

Compute> Evaluate
∇ ·F = 0 ∇ ·H = 0
∇ ·G = 5z ∇ · J = 5x
∇ · (xz,2yz,z2) = 5z ∇ ·

[
ax,bxy,cz2

]
= a+bx+2cz
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Compute> Vector Calculus> Divergence
[yz,2xz,xy], Divergence is 0

[
yz 2xz xy

]
, Divergence is 0

(
xz,2yz,z2

)
, Divergence is 5z

 x2

xy
2xz

, Divergence is 5x

Curl
IfF(x,y,z) = (p(x,y,z),q(x,y,z),r(x,y,z)) is a vector đeld, then

the vector

∇×F =

(
∂ r
∂y
− ∂q

∂ z
,

∂ p
∂ z
− ∂ r

∂x
,

∂q
∂x
− ∂ p

∂y

)
is called the curl of F . ăe default is that the đeld variables are x, y, and
z, in that order. If you wish to label the đeld variables differently, reset
the default with Set Basis Variables on the Vector Calculus submenu.
Tocompute the curl of a vector đeldF (x,y,z)

1. Enter the curl in standard notation.

2. Choose Compute> Evaluate.
Or

1. Place the insert point in a vector đeld.

2. Choose Compute> Vector Calculus>Curl.

ăe vector đeld F in the following example is deđned to be F =
[yz,2xz,xy], as in the previous section.

Compute> Evaluate

∇× (yz,2xz,xy) =

 −x
0
z

 ∇×F =

 −x
0
z



∇×

 ax2

bxy
2cxz

=

 0
−2cz

by


Compute> Vector Calculus> Curl

(yz,2xz,xy), Curl is

 −x
0
z

  x2

xy
2xz

, Curl is

 0
−2z

y


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In terms of the basis

i = (1,0,0)
j = (0,1,0)
k = (0,0,1)

the curl of F can be interpreted as the determinant

∇×F =

∣∣∣∣∣∣∣∣
i j k
∂
∂x

∂
∂y

∂
∂ z

p(x,y,z) q(x,y,z) r (x,y,z)

∣∣∣∣∣∣∣∣= i
(

∂ r
∂y
− ∂q

∂ z

)
+j
(

∂ p
∂ z
− ∂ r

∂x

)
+k
(

∂q
∂x
− ∂ p

∂y

)

Laplacian
ăe Laplacian of a scalar đeld f (x,y,z) is the divergence of ∇ f

and is written The name of this operator comes from its
relationship to the Laplace’s equation

∂ 2 f
∂x2 +

∂ 2 f
∂y2 +

∂ 2 f
∂ z2 = 0

∇2 f = ∇ ·∇ f

= ∇ ·
(

∂ f
∂x

,
∂ f
∂y

,
∂ f
∂ z

)
=

∂ 2 f
∂x2 +

∂ 2 f
∂y2 +

∂ 2 f
∂ z2

ăe default đeld variables for the Laplacian are x, y, and z, in that
order. If you wish to label the đeld variables differently, reset the de-
fault with Set Basis Variables on the Vector Calculus submenu.
Tocompute theLaplacian of a scalar đeld f (x,y,z)

1. Type the Laplacian in standard notation.

2. Choose Compute< Evaluate.
Or

1. Place the insert point in a scalar đeld.

2. Choose Compute> Vector Calculus> Laplacian.

Compute> Evaluate
∇2 (x+ y2 +2z3

)
= 12z+2 ∇ ·∇

(
x+ y2 +2z3

)
= 12z+2

Compute> Vector Calculus> Laplacian
x+ y2 +2z3, Laplacian is 12z+2 1−2y+6z2, Laplacian is 12
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Directional Derivatives
ăe directional derivative of a function f at the point (a,b,c) in

the direction u = (u1,u2,u3) is given by the inner product of ∇ f and
u at the point (a,b,c). ăat is, for a vectoru of unit length and a scalar
function f ,

Du f (a,b,c) = ∇ f (a,b,c) ·u

=
∂ f
∂x

(a,b,c)u1 +
∂ f
∂y

(a,b,c)u2 +
∂ f
∂ z

(a,b,c)u3

Tocomputethedirectionalderivativeof f (x,y,z) inthedirectionu=(u1,u2,u3)

1. Enter the dot product (∇( f (x,y,z))) · (u1,u2,u3). Note that
the expression ∇( f (x,y,z)) is enclosed in parentheses.

2. Leave the insert point in the expression.

3. Choose Compute> Evaluate, or

Choose Compute> Evaluate Numeric.

In the following example, we compute the directional derivative of
f (x,y,z) = xyz in the direction

u =
(

cos
π
8

sin
π
9
,sin

π
8

sin
π
9
,cos

π
9

)
Compute> Evaluate
(∇(xyz)) ·

(
cos π

8 sin π
9 ,sin π

8 sin π
9 ,cos π

9

)
= xycos 1

9 π + 1
2 xz
(
sin 1

9 π
)√

2−
√

2+ 1
2 yz
(
sin 1

9 π
)√√

2+2

Compute> Evaluate Numeric
(∇(xyz)) ·

(
cos π

8 sin π
9 ,sin π

8 sin π
9 ,cos π

9

)
≈ 0.93969xy+0.13089xz+0.31599yz

Plots of Vector Fields and Gradients
A function that assigns a vector to each point of a region in two-

or three-dimensional space is called a vector Ėeld. ăe gradient of a
scalar-valued function of two variables is a vector đeld.
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Plots and Animated Plots of 2D Vector Fields
ăe operation Compute> Plot 2D>Vector Field requires a pair

of expressions in two variables representing the horizontal and vertical
components of the vector đeld.

Toplot a two-dimensional vector đeld
1. Type a pair of two-variable expressions, representing the hori-

zontal and vertical components of a vector đeld, into a vector.

2. Leave the insert point in the vector, and choose Compute >
Plot 2D> Vector Field.

To visualize the vector đeld F(x,y) = [x+ y,x− y], place the in-
sert point in the vector [x+ y,x− y], and chooseCompute>Plot 2D
> Vector Field.

Compute> Plot 2D> Vector Field
[x+ y,x− y]

­6 ­4 ­2 2 4 6

­6

­4

­2

2

4

6

x

y

At a point (x,y) on a solution curve of a differential equation of

the form
dy
dx

= f (x,y) the curve has slope f (x,y). You can get an
idea of the appearance of the graphs of the solution of a differential
equation from the direction Ėeld—that is, a plot depicting short line
segments with slope f (x,y) at points (x,y). ăis can be done using
Plot 2D> Vector Field and the vector-valued function

F (x,y) =

(
1, dy

dx

)
∥∥∥(1, dy

dx

)∥∥∥
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that assigns to each point (x,y) a vector of length one in the direction
of the derivative at the point (x,y).

ăe direction đeld for the differential equation dy/dx = y−x2 is
the two-dimensional vector đeld plot of the vector valued function

F (x,y) =

(
1,y− x2

)
∥(1,y− x2)∥

Compute> Plot 2D> Vector Field 1√(
1+ |y− x2|2

) , y− x2√(
1+ |y− x2|2

)


­6 ­4 ­2 2 4 6

­6

­4

­2

2

4

6

x

y

­6 ­4 ­2 2 4 6

­6

­4

­2

2

4

6

x

y

Several of the solution curves are depicted in the plot on the right.

Toplot an animated two-dimensional vector đeld
1. Type a pair of three-variable expressions, representing the hori-

zontal and vertical components of a vector đeld, into a vector.

2. Leave the insert point in the vector and chooseCompute>Plot
2D Animated> Vector Field.

To visualize the animated vector đeld [x+ ty,x− ty], place the in-
sert point in the vector [x+ ty,x− ty], and choose Compute > Plot
2DAnimated>Vector Field. From the Items Plotted page of the Plot
Properties dialog, choose Intervals and set−1≤ t ≤ 1.

365



i
i

“Compute60” — 2011/12/20 — 14:27 — page 366 — #376 i
i

i
i

i
i

Chapter 9 | Vector Calculus

Compute> Plot 2D Animated> Vector Field
[x+ ty,x− ty] (Interval−1≤ t ≤ 1)

□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□

­5 5

­5

5

x

y

­5 5

­5

5

x

y

­5 5

­5

5

x

y

□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□
Plots and Animated Plots of 3D Vector Fields

ăe operation Compute> Plot 3D>Vector Field requires three
expressions in three variables representing the rectangular components
of the vector đeld.
Toplot a three-dimensional vector đeld

1. Type three three-variable expressions, representing the x-, y-,
and z-components of a vector đeld, into a vector.

2. Leave the insert point in the vector and choose Plot 3D>Vec-
tor Field. Tip

The three-dimensional version is often a
challenge to visualize. Rotate a 3D plot on the
screen for a better view.

Compute> Plot 3D> Vector Field
[−y/z,x/z,z]

­1

x
0

y

1

­1

0z

­1

0 11

To rotate the view
• Press the leĕmouse button as youmove themouse over the plot.
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Animated views and boxed axes can be helpful in visualizing a vec-
tor đeld.
Toplot an animated three-dimensional vector đeld

1. Type three four-variable expressions, representing the three com-
ponents of a vector đeld with an animation variable, into a vec-
tor

2. Leave the insert point in the vector, and choose Compute >
Plot 3D Animated> Vector Field.

To visualize the vector đeld [x+ ty+ z,x+ y− tz, tx− y+ z] as t
varies from −1 to 1, place the insert point in the vector, and choose
Compute > Plot 3D Animated > Vector Field. Change the interval
for the animation variable to−1≤ t ≤ 1.

Compute> Plot 3D Animated> Vector Field
[x+ ty+ z,x+ y− tz, tx− y+ z] (Interval−1≤ t ≤ 1)

□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□

­5
­5 0

0

­5
0 5

5

­5
­5

0

­5 0
0 5

5

­5
­5 0

0

­5
0 5

5

□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□

Plots and Animated Plots of 2D Gradient Fields
Scalar-valued functions of two variables can be visualized in sev-

eral ways. Given the function f (x,y) = xysinxy, choosing Compute
> Plot 3D>Rectangular produces a surface represented by the func-
tion values.

Another way to visualize such a function is to choose Compute>
Plot 2D > Gradient. ăis choice produces a plot of the vector đeld
that is the gradient of this expression, plotting vectors at grid points
whose magnitude and direction indicate the steepness of the surface
and the direction of steepest ascent.
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Chapter 9 | Vector Calculus

ăe vector đeld that assigns to each point (x,y) the gradient of f
at (x,y) is called the gradient Ėeld associated with the function f .

xysinxy

­3 ­2 ­1 1 2 3

­3

­2

­1

1

2

3

x

y

Gradient đeld

−
(
cos2 x+ cos2 y

)2

­2 ­1 1 2

­2

­1

1

2

x

y

Gradient đeld

Toplot a gradient đeld
1. Type an expression f (x,y).

2. Choose Compute> Plot 2D>Gradient.

For example, type the expression x2 + 2y2, and choose Compute
> Plot 2D>Gradient. ăis procedure produces a plot of the vector
đeld that is the gradient of this expression. ăe đrst plot shows the
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relative steepness, the second is the surface, and the third shows the
contour lines.

Compute> Plot 2D> Gradient
x2 +2y2

­6 ­4 ­2 2 4 6

­6

­4

­2

2

4

6

Gradient đeld

Compute> Plot 3D> Rectangular
x2 +2y2

Turn: 0 Tilt: 0
Contour

Toplot an animated gradient đeld
1. Type an expression f (x,y, t).
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2. With the insert point in the expression, choose Compute >
Plot 2D Animated>Gradient.

Type the expression

1/
(

10+(x+3cos t)2 +(y+3sin t)2
)

and choose Compute > Plot 2D Animated > Gradient. ăis pro-
duces an animated plot of the vector đeld that is the gradient of this
expression.

ăe following animation shows a point of attraction that moves
around a circle of radius 3. Set the interval for the animation variable
to−3.1416≤ t ≤ 3.1416.

Compute> Plot 2D Animated> Gradient

1/
(

10+(x+3cos t)2 +(y+3sin t)2
)

□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□
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□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□

Plots and Animated Plots of 3D Gradient Fields
ăe gradient đeld for a scalar-valued function f (x,y,z) of three

variables is a three-dimensional vector đeld where each vector repre-
sents the direction ofmaximal increase. ăe surface represented by the
function values is embedded in four-dimensional space, so you must
use indirect methods such as plotting the gradient đeld to help you
visualize this surface.
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Compute> Plot 3D> Gradient
xz+ xy+ yz

­4
­2

0
­4

x

­2
z

­4

0

2

2­2

4

y
0

4
42

Anotherway to visualize the function f (x,y,z) is to plot a series of
implicit plots of surfaces of constant values. ăe gradient đeld points
from surfaces of lower constant values to surfaceswith higher constant
values.

Compute> Plot 3D> Implicit
xz+ xy+ yz = 1 xz+ xy+ yz =−1

2
x

0

z

4

­4­2

2
0

­2
­4

4 ­4
­2

2 4

y
0

xz+ yz+ xy = 1

­4
­2
0z

4
2

­4­2

x
0 0

42

y
2

4
­2

­4

xz+ yz+ xy =−1

Toplot an animated gradient đeld in 3D
1. Type an expression f (x,y,z, t).
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2. With the insert point in the expression, choose Compute >
Plot 3D Animated>Gradient.

For example, type 1/
(

10+(x+ t)2 +(y+ t)2 +(z+ t)2
)

and
choose Compute > Plot 3D Animated > Gradient. ăis procedure
produces an animatedplot of the vector đeld that is the gradient of this
expression. ăe following animation shows the interest generated in a
đsh tank as a tasty morsel moves from one corner to the opposite cor-
ner of the tank. From the Items Plotted page of the Plot Properties di-
alog, chooseVariables, Intervals, andAutomation and set−6≤ t ≤ 6.

Compute> Plot 3D Animated> Gradient
1/
(

10+(x+3cos t)2 +(y+3sin t)2
)

□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□
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□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□

Scalar and Vector Potentials
ăe Scalar Potential command on the Vector Calculus menu pro-

duces the inverse of the gradient in the sense that it đnds a scalar func-
tion whose gradient is the given vector đeld, or it tells you that such a
function does not exist. ăe vector potential has an analogous inter-
pretation in terms of the curl.

Scalar Potential
A scalar potential exists for a vector đeld F if and only if the curl

is 0:
∇×F = 0

ăat is, the vector đeld is irrotational.
ăe following are examples of scalar potential with the standard

basis variables.
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Compute> Vector Calculus> Scalar Potential

(x,y,z) Scalar potential is 1
2 x2 + 1

2 y2 + 1
2 z2

(x,z,y) Scalar potential is 1
2 x2 + yz

(y,z,x) Scalar potential does not exist.

ăe vector đeld (y,z,x) does not have a scalar potential because its
curl is not 0.

Compute> Evaluate

∇× (y,z,x) =

 −1
−1
−1

 ̸=
 0

0
0


In the next example, chooseCompute>Evaluate and then choose

Compute > Vector Calculus > Scalar Potential. Because the vector
đeld is a gradient, it has the original function as a scalar potential.

Compute> Evaluate

∇
(
xy2 + yz3

)
=

 y2

z3 +2xy
3yz2


Compute> Vector Calculus> Scalar Potential y2

z3 +2xy
3yz2

 Scalar potential is xy2 + yz3

You would normally expect the scalar potential of the vector đeld(
cv,cu+2vw,v2

)
to be ucv+v2w; that is, you expect c to be treated

as a constant. When the number of variables differs from the num-
ber of components in the đeld vector, a dialog box asks for the đeld
variables. In this case, you can type u,v,w to get the expected result.

ăedialog box also appearswhen you ask for the scalar potential of
a vector đeld that speciđes fewer than three variables, such as (y,x,0).
Type x,y,z in the dialog box to get the expected result xy for the scalar
potential of this vector đeld.

Vector Potential
A vector potential exists for a vector đeld F⃗ if and only if

divF = ∇ ·F = 0
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ăat is, the vector đeld is solenoidal.
Unless otherwise speciđed, the operators curl and vector potential

apply to scalar or vector functions of a set of exactly three standard ba-
sis variables. ăe default is x,y,z, but you can use other sets of basis
variables by choosing Compute > Vector Calculus > Set Basis Vari-
ables and changing the default variables.

Start with ∇×(xy,yz,zx) =

 −y
−z
−x

 to get the following vector

potential.

Compute> Vector Calculus> Vector Potential −y
−z
−x

 Vector potential is

 xy− 1
2 z2

yz
0



Notice that we did not get the original vector đeld when we asked
for a vector potential of its curl. ăat is because the vector potential
is determined only up to a đeld whose curl is zero. You can verify that
this is the case. First, calculate the difference of the two vectors. ăen
compute the curl of the difference.

Compute> Evaluate xy
yz
zx

−
 xy− 1

2 z2

yz
0

=

 1
2 z2

0
xz



∇×

 1
2 z2

0
xz

=

 0
0
0



Try the same experiment aĕer changing thebasis variables tou,v,w
by choosing Compute>Vector Calculus> Set Basis Variables. Note
that a vector đeld can be written either as the triple (u,v,w) or as a
column matrix.
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Compute> Vector Calculus> Vector Potential −v
−w
−u

 Vector potential is

 uv− 1
2 w2

vw
0



(v,w,u) Vector potential is

 1
2 w2−uv
−vw

0



Matrix-Valued Operators

Matrix-valued operators include the Hessian, the Jacobian, and
the Wronskian matrices.

Hessian

ăeHessian is the n×nmatrix



∂ 2 f
∂x2

1

∂ 2 f
∂x1∂x2

· · · ∂ 2 f
∂x1∂xn

∂ 2 f
∂x2∂x1

∂ 2 f
∂x2

2
· · · ∂ 2 f

∂x2∂xn

...
...

. . .
...

∂ 2 f
∂xn∂x1

∂ 2 f
∂xn∂x2

· · · ∂ 2 f
∂x2

n



of second partial derivatives of a scalar function f (x1,x2, . . . ,xn)of n
variables.

ăeorder of the variables affects theorderingof the rows and columns
of theHessian. For the following examples, the list of variables is x,y,z.
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Compute> Vector Calculus> Hessian

xyz, Hessian is

 0 z y
z 0 x
y x 0

 x2 + y3, Hessian is

 2 0 0
0 6y 0
0 0 0



a3 +b3, Hessian is

 0 0 0
0 0 0
0 0 0

 wxyz, Hessian is

 0 wz wy
wz 0 wx
wy wx 0



Choose Compute > Vector Calculus > Set Basis Variables and
type a,b,c in the input box to change the basis vectors.

Compute> Vector Calculus> Hessian

a3 +b3, Hessian is

 6a 0 0
0 6b 0
0 0 0


Choose Compute > Vector Calculus > Set Basis Variables and

type a,b in the input box to change the basis vectors.

Compute> Vector Calculus> Hessian

a3 +b3, Hessian is
[

6a 0
0 6b

]

Choose Compute > Vector Calculus > Set Basis Variables and
type x,y,z,w in the input box to change the basis vectors.

Compute> Vector Calculus> Hessian

x2z+ y3w, Hessian is


2z 0 2x 0
0 6wy 0 3y2

2x 0 0 0
0 3y2 0 0


376



i
i

“Compute60” — 2011/12/20 — 14:27 — page 377 — #387 i
i

i
i

i
i

Matrix-Valued Operators

Jacobian
ăe Jacobian is the n×nmatrix

∂ f1

∂x1

∂ f1

∂x2
· · · ∂ f1

∂xn

∂ f2

∂x1

∂ f2

∂x2
· · · ∂ f2

∂xn
...

...
. . .

...
∂ fn

∂x1

∂ fn

∂x2
· · · ∂ fn

∂xn


of partial derivatives of the entries in a vector đeld

( f1 (x1,x2, . . . ,xn) , f2 (x1,x2, . . . ,xn) , . . . , fn (x1,x2, . . . ,xn))

Jacobians resemble Hessians in that the order of the variables in the
variable list determines the order of the columns of the matrix. In the
following examples, the variable list is x,y,z. To verify these examples,
choose Compute > Vector Calculus > Jacobian while the insertion
point is in the given vector đeld.

Compute> Vector Calculus> Jacobian

(yz,xz,xy), Jacobian is

 0 z y
z 0 x
y x 0



(
x2z,x+ z,xz2

)
, Jacobian is

 2xz 0 x2

1 0 1
z2 0 2xz


Set the basis variables to a,b,c.

Compute> Vector Calculus> Jacobian

(
x2z,y+ c,yz2

)
, Jacobian is

 0 0 0
0 0 1
0 0 0


Wronskian

ăeWronskianwith respect to functions f1, f2, . . . , fn deđned on
an interval I, oĕen denoted by W ( f1 (x) , f2 (x) , . . . , fn (x)), is
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Chapter 9 | Vector Calculus

deđned as

det


f1 (x) f2 (x) · · · fn (x)

f (1)1 (x) f (1)2 (x) · · · f (1)n (x)
...

... · · ·
...

f (n−1)
1 (x) f (n−1)

2 (x) · · · f (n−1)
n (x)


ăematrix is theWronskianmatrix. Observe thatW ( f1 (x) , f2 (x) , . . . , fn (x))
is a function deđned on the interval I. To compute the Wronskian,
take the determinant of the Wronskian matrix.

Compute> Vector Calculus>Wronskian

(
x3−3x2,3x2−7,x4 +5x2

)
, Wronskian matrix is

 x3−3x2 3x2−7 x4 +5x2

3x2−6x 6x 4x3 +10x
6x−6 6 12x2 +10


Compute>Matrices> Determinant x3−3x2 3x2−7 x4 +5x2

3x2−6x 6x 4x3 +10x
6x−6 6 12x2 +10

, determinant: −6x6 +84x4−336x3−210x2

It follows that the Wronskian of the functions

f1 (x) = x3−3x2

f2 (x) = 3x2−7
f3 (x) = x4 +5x2

is given by

W
(
x3−3x2,3x2−7,x4 +5x2)=−6x6 +84x4−210x2−336x3

Consider the special casewhere there are two functions. Wedeđne
two generic functions f1 and f2. Note

Two functions are proportional if and only if
f2(x)
f1(x)

is a constant, which is equivalent to

d
dx

(
f2(x)
f1(x)

)
= 0. Since d

dx

(
f2(x)
f1(x)

)
=

f1(x)
∂ f2(x)

∂x − f2(x)
∂ f1(x)

∂x
( f1(x))

2 this is equivalent

to the Wronskian being zero.

Compute> Deönitions> New Deönition
f1 (x) f2 (x)

Compute> Vector Calculus>Wronskian

( f1 (x) , f2 (x)), Wronskian matrix is

[
f1 (x) f2 (x)
∂ f1(x)

∂x
∂ f2(x)

∂x

]

378



i
i

“Compute60” — 2011/12/20 — 14:27 — page 379 — #389 i
i

i
i

i
i

Plots of Complex Functions

Compute>Matrices> Determinant[
f1 (x) f2 (x)
∂ f1(x)

∂x
∂ f2(x)

∂x

]
, determinant: f1 (x)

∂ f2(x)
∂x − f2 (x)

∂ f1(x)
∂x

Plots of Complex Functions
A complex-valued function F(z) of a complex variable is a chal-

lenge to graph, because the natural graph would require four dimen-
sions. One of the techniques for visualizing such functions is to make
conformal plots.

Conformal Plots
A conformal plot of a complex function F(z) is the image of a two-

dimensional rectangular grid of horizontal and vertical line segments.
ăe default is an 11×11 grid, with each of the intervals 0≤Re(z)≤
1 and 0 ≤ Im(z) ≤ 1 subdivided into 10 equal subintervals. If F(z)
is analytic, then it preserves angles at every point at which F ′(z) ̸=
0; hence, the image is a grid composed of two families of curves that
intersect at right angles.

To create a conformal plot of F (z) =
z−1
z+1

, put the insert point

in the expression, and chooseCompute>Plot 2D>Conformal. ăe
number of grid lines and the view can be changed in the Plot Proper-
ties tabbed dialogs.

Compute> Plot 2D> Conformal
z−1
z+1

­1.0 ­0.8 ­0.6 ­0.4 ­0.2 0.0 0.2

0.2

0.4

0.6

0.8

1.0
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In the following example,

• Re(z) and Im(z) both range from−3 to 3.

• ăeView Intervals are set at−2≤Re(z)≤ 4 and−3≤ Im(z)≤
3.

• ăe Grid Size has been increased to 40 by 40.

• Samples perHorizontalGridLine andSamples perVerticalGrid
Line have both been increased to 60.

Compute> Plot 2D> Conformal
z−1
z+1

­2 ­1 1 2 3 4

­3

­2

­1

1

2

3

x

y

Animated Conformal Plots
Tocreate an animated conformal plot of a complex function

• Place the insert point in the expression, and choose Compute
> Plot 2D Animated>Conformal.

ăe number of grid lines and the view can be changed in the Plot
Properties dialogs. Following is an animation of (z− t)/(z+ t) as t
varies from 1 to 2. In the following example,

• Re(z) and Im(z) both range from−3 to 3.

• t ranges from 1 to 2.

• ăeView Intervals are set at−2≤Re(z)≤ 4 and−3≤ Im(z)≤
3.
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Compute> Plot 2D Animated> Gradient
z− t
z+ t
□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□

­2 ­1 1 2 3 4

­3

­2

­1

1

2

3

­2 ­1 1 2 3 4

­3

­2

­1

1

2

3

­2 ­1 1 2 3 4

­3

­2

­1

1

2

3

□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□□

Exercises
1. Evaluate the directional derivative of f (x,y,z) = 3x−5y+2z

at (2,2,1) in the direction of the outward normal to the sphere
x2 + y2 + z2 = 9.

2. Find a vectorvnormal to the surface z=
√

x2 + y2+
(
x2 + y2

)3/2

at the point (x,y,z) ̸= (0,0,0) on the surface.

3. Let f (x,y,z) =
mM√

x2 + y2 + z2
denote Newton’s gravitational

potential. Show that the gradient is given by

∇ f (x,y,z) =− mM

(x2 + y2 + z2)3/2

 x
y
z


4. Let u1 (t) ,u2 (t) ,u3 (t) be three functions having third-order

derivatives. Show that the derivative of the Wronskian
W (u1 (t) ,u2 (t) ,u3 (t)) is the determinant∣∣∣∣∣∣∣∣∣∣∣

u1 (t) u2 (t) u3 (t)
d
dt

u1 (t)
d
dt

u2 (t)
d
dt

u3 (t)

d3

dt3 u1 (t)
d3

dt3 u2 (t)
d3

dt3 u3 (t)

∣∣∣∣∣∣∣∣∣∣∣
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Chapter 9 | Vector Calculus

In other words, the derivative of W (u1 (t) ,u2 (t) ,u3 (t)) may
be obtained by đrst differentiating the elements in the last row
of theWronskianmatrix of (u1 (t) ,u2 (t) ,u3 (t)) and then tak-
ing the derivative of the resulting matrix.

5. Starting with the function f (x,y) = sinxy, observe connec-
tions between the surface z = f (x,y), the gradient of f (x,y),
and the vector đeld of ∇ f (x,y).

6. Observe the vectorđeldof (sinxy,cosxy) anddescribe theĔow.
Is there a function g(x,y) whose gradient is (sinxy,cosxy)?

Solutions
1. ăedirectional derivative is givenbyDu f (x,y,z))=∇ f (x,y,z)·

u, where u is a unit vector in the direction of the outward nor-
mal to the sphere x2 + y2 + z2 = 9. ăe vector

∇
(
x2 + y2 + z2)=

 2x
2y
2z


is normal to the sphere x2 + y2 + z2 = 9, and at (2,2,1) this
normal is (4,4,2). A unit vector in the same direction is given
by

u =

 4
4
2

÷
∥∥∥∥∥∥
 4

4
2

∥∥∥∥∥∥= 1
6

 4
4
2

=

 2/3
2/3
1/3


Hence, ∇ f (x,y,z) ·u evaluated at (2,2,1) is− 2

3 .

2. A normal vector is given by

∇
(√

x2 + y2 +
(
x2 + y2)3/2− z

)
=


x√

x2+y2
+3x

√
x2 + y2

y√
x2+y2

+3y
√

x2 + y2

−1


=

1√
(x2 + y2)

(
x
(
1+3x2 +3y2) ,y(1+3x2 +3y2) ,−√(x2 + y2)

)
Hence, any scalar multiple of[

x
(
1+3x2 +3y2) ,y(1+3x2 +3y2) ,−√(x2 + y2)

]
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is also normal to the given surface.

3. Evaluate the expression

∇

(
mM√

x2 + y2 + z2

)
=


−Mm x

(x2+y2+z2)
3
2

−Mm y

(x2+y2+z2)
3
2

−Mm z

(x2+y2+z2)
3
2

=− mM

(x2 + y2 + z2)3/2

 x
y
z



ăis gives the Newtonian gravitational force between two ob-
jects of masses m and M, with one object at the origin and the
other at the point (x,y,z).

4. Evaluate each of d
dt

∣∣∣∣∣∣∣
u1 (t) u2 (t) u3 (t)

d
dt u1 (t) d

dt u2 (t) d
dt u3 (t)

d2

dt2 u1 (t) d2

dt2 u2 (t) d2

dt2 u3 (t)

∣∣∣∣∣∣∣ and

∣∣∣∣∣∣∣
u1 (t) u2 (t) u3 (t)

d
dt u1 (t) d

dt u2 (t) d
dt u3 (t)

d3

dt3 u1 (t) d3

dt3 u2 (t) d3

dt3 u3 (t)

∣∣∣∣∣∣∣. Each gives

u1 (t)
∂u2 (t)

∂ t
∂ 3u3 (t)

∂ t3 −u1 (t)
∂u3 (t)

∂ t
∂ 3u2 (t)

∂ t3 − ∂u1 (t)
∂ t

u2 (t)
∂ 3u3 (t)

∂ t3

+
∂u1 (t)

∂ t
u3 (t)

∂ 3u2 (t)
∂ t3 +

∂ 3u1 (t)
∂ t3 u2 (t)

∂u3 (t)
∂ t

− ∂ 3u1 (t)
∂ t3 u3 (t)

∂u2 (t)
∂ t

.

5. ăe surface z= sinxy has ridges along the hyperbolas xy= π
2 +

2nπ and valleys along the hyperbolas xy= 3π
2 +2nπ in the đrst

quadrant. ăe gradient ∇sinxy = (ycosxy,xcosxy) produces
a vector đeld whose vectors show the steepness of the surface
z= sinxy. Note that plotting the gradient of f (x,y) is the same
as plotting the vector đeld of ∇ f (x,y). ăe ridges and valleys
are indicated by vectors of zero length.
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­4
1

­2

x

z
­10

2
4

0
­2 2

y
4

­4 ­2

4
0

­4

y

4

2
­2­4 z

x
20

­4 ­2 2 4

­4

­2

2

4

x

y

gradient of sinxy

­4 ­2 2 4

­4

­2

2

4

x

y

vector đeld of (ycosxy,xcosxy)

6. A plot of the vector đeld (sinxy,cosxy) suggests an interesting
pattern of Ĕow. However, a search for a scalar potential fails.

­4 ­2 2 4

­4

­2

2

4

x

y

vector đeld of (sinxy,cosxy)

384



i
i

“Compute60” — 2011/12/20 — 14:27 — page 385 — #395 i
i

i
i

i
i

10
Differential Equations

Everything should be made as simple as possible, but not simpler. Albert Einstein (1879–1955)

A differential equation is an equation that includes differen- Ordinary Differential Equations

Systems

Numerical Methods

tials or derivatives of an unknown function. A solution to a
differential equation is any function that satisđes the given

equation. ăus f (x) = sinx is a solution to the differential equation
y′′+y = 0, because if y = sinx, then y′ = cosx and y′′ =−sinx, and
hence y′′+ y = sinx− sinx = 0. Differential equations are encoun-
tered in the study of problems in both pure and applied mathematics,
in the sciences, in engineering, and in business and the social sciences.

Ordinary Differential Equations
With the choices on the Solve ODE submenu you will be able to

đnd closed-form solutions to many differential equations. ăe solu-
tion is generally returned as an equation in y(x) and x (or whatever
variables were speciđed) with any arbitrary constants represented as
C1,C2, ...,Cn.
To solve a differential equation

1. Type the differential equation using standardmathematical no-
tation.

2. With the insert point in the equation, chooseCompute>Solve
ODE> Exact, Laplace, Numeric, or Series.
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Chapter 10 | Differential Equations

To solve a differential equationwith initial condition(s)
1. Place the differential equation in a one-column matrix or in a

display, with initial condition(s) in separate rows.

2. Place the insert point in the equation and, choose Compute>
Solve ODE>Numeric.

ăese different choices are explained inmore detail in the next few
sections.

Exact Solutions
Two methods, Exact and Laplace, return exact solutions to a lin-

ear differential equation. Laplace, which as its name suggests, uses the
Laplace transform to derive solutions, works for either homogeneous
or nonhomogeneous linear differential equations with constant coef-
đcients. Initial conditions are displayed in the solution. Exact is more
general in the sense that is works for some nonlinear differential equa-
tions as well.

Exact Method
To solve a differential equationby theExactmethod

1. Place the insert point in the differential equation.

2. Choose Compute> Solve ODE> Exact.

When a notation is used for differentiation that names the inde-
pendent variable, the variable is taken from context.

Compute> Solve ODE> Exact
dy
dx = xyODE Solution:

{
C1e

1
2 x2
}

To check this result, deđne y(x) = e
1
2 x2

C1. Replace y by y(x) in
the differential equation and evaluate both sides.

Compute> Evaluate
dy(x)

dx = xC1e
1
2 x2

xy(x) = xC1e
1
2 x2

For any given number C1, the solution describes a curve. Since
C1 may, in general, take on inđnitely many values, there is an inđ-
nite family of solution curves—or a one-parameter family of solution
curves—for this equation.

When a prime indicates differentiation, the independent variable
will be named if it is unambiguous; otherwise, a variable name must
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Ordinary Differential Equations

be speciđed. In the equations y′ = y, y′ = sinx and y′ = sinx+ t , the
independent variable is ambiguous and a dialog box appears asking for
the independent variable.

Compute> Solve ODE> Exact
y′ = y (Specify t)ODE Solution: {C1et}
dy
dx = sinxODE solution: {C1− cosx}
y′ = sinx (Specify t)ODE Solution: {C1 + t sinx}
y′ = sinx+ t (Specify x)ODE Solution: {C1− cosx+ tx}
y′ = sinx+ t (Specify t)ODE Solution:

{
C1 +

1
2 (t + sinx)2

}
ăere is a family of solutions, one for each choice of C1. ăe fol-

lowing đgure shows solutions for y′ = y corresponding to the choices
1
2 , 1, 2, 3, and 4 for C1. To replicate this plot, drag solutions to the
frame one at a time.

Compute> Plot 2D> Rectangular
1
2 ex

(Select and drag to the frame each of the following)
ex, 2ex, 3ex, 4ex

­1.0 ­0.8 ­0.6 ­0.4 ­0.2 0.0 0.2 0.4 0.6 0.8 1.0

5

10

x

y

Five solutions for y′ = y

Notation
A variety of notations for a differential
equation will be interpreted properly. The
examples illustrate some of this variety. The
Leibniz notationdy/dx and theDx notation
provide enough information so the
independent variable can be determined by
the computational engine. The prime notation
for derivative prompts a dialog in which you
can specify the independent variable.Compute> Solve ODE> Exact

dy
dx

= y+ xODE Solution: {C1ex− x−1}

Dxy− y = sinxODE Solution:
{

C1ex− 1
2 sinx− 1

2 cosx
}

y′+ xy = ax, (Specify x)ODE Solution:
{

a−C1e−
1
2 x2
}

Following is a plot of three particular solutions forDxy−y= sinx
corresponding to C1 = 1,2,3. To replicate this plot, drag the second
and third solutions to the frame one at a time.
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Compute> Plot 2D> Rectangular
ex− 1

2 cosx− 1
2 sinx

2ex− 1
2 cosx− 1

2 sinx (Select and drag to the frame)
3ex− 1

2 cosx− 1
2 sinx (Select and drag to the frame)

­1.0 ­0.8 ­0.6 ­0.4 ­0.2 0.0 0.2 0.4 0.6 0.8 1.0

2

4

6

x

y

ăree solutions for Dx y− y = sinx

Tip
The three solutions can be distinguished by
evaluation at 0. For example, the solution
withC1 = 1 crosses the y-axis at y = 1/2.

Compute> Solve ODE> Exact
y′′+ y = x2 (specify x), ODE solution:

{
x2−C1 sinx+C2 cosx−2

}
ăe following plot shows three solutions generatedwith constants

(C1,C2) = (1,1), (C1,C2) = (5,1), and (C1,C2) = (1,5). To repli-
cate this plot, drag the second and third solutions to the frame one at
a time.

Compute> Plot 2D> Rectangular
sinx+ cosx+ x2−2
5sinx+ cosx+ x2−2 (Select and drag to the frame)
sinx+5cosx+ x2−2 (Select and drag to the frame)

­3 ­2 ­1 1 2 3 4

­5

5

10

x

y

ăree solutions to y ′′+ y = x2

Tip
The particular solution
y(x) = sinx+5cosx+ x2−2 is the
one whose graph crosses the y-axis at y = 3.
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Compute> Solve ODE> Exact
xy′− y = x2 (specify x), ODE solution:

{
x2 +C1x

}
d2y
dx2 +

dy
dx = x+ y, ODE solution:

{
C1e−x( 1

2
√

5+ 1
2)− x+C1ex( 1

2
√

5− 1
2)−1

}
Laplace Method

Laplace transforms solve eitherhomogeneousornonhomogeneous
linear systems in which the coefficients are all constants. Initial con-
ditions appear explicitly in the solution.
To solve a differential equationby theLaplacemethod

• Place the insert point in the differential equation and choose
Compute> Solve ODE> Laplace.

Compute> Solve ODE> Laplace
dy
dx

= y, ODE Solution (Laplace): {C1ex}

y′+ y = x+ sinx, (Specify x), ODE Solution (Laplace){
x− 1

2 cosx+ 1
2 sinx+C1e−x−1

}
ăe following examples compare exact and Laplace solutions. In

each case, the ODE Independent Variable is x.

Compute> Solve ODE> Exact
y′ = sinx, ODE Solution: {C1− cosx}
y′ = y+ x, ODE Solution: {C1ex− x−1}
Dxy = cosx, ODE Solution: {C1 + sinx}

Compute> Solve ODE> Laplace
y′ = sinx, ODE Solution (Laplace): {C2− cosx}
y′ = y+ x, ODE Solution (Laplace): {−x−1,C1ex− x−1}
Dxy = cosx, ODE Solution (Laplace): {C1 + sinx}

Series Solutions
For many applications requiring a solution to a differential equa-

tion, a few terms of a Taylor series solution are sufficient.
Tođnd aTaylor series solution to a differential equation

1. Type the differential equation in standard mathematical nota-
tion.

2. With the insert point in the equation, chooseCompute>Solve
ODE> Series.
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3. In the dialog box, type the Variable, Center (Default 0), and
Order (Default 5) and choose OK.

In the following examples, notice that the initial condition y(0)
appears explicitly in each solution.

Compute> Solve ODE> Series
Dxy = y, Series solution is:

{
y(0)+ xy(0)+ 1

2 x2y(0)+ 1
6 x3y(0)+ 1

24 x4y(0)+O
(
x5
)}

y′ =
sinx

x
, Series solution is:

{
y(0)+ x− 1

18 x3 + 1
600 x5 +O

(
x7
)}

dy
dx

+ y = e−x2
, Series solution is:

{
y(0)− x(y(0)−1)+ x2

( 1
2 y(0)− 1

2

)
−x3

( 1
6 y(0)+ 1

6

)
+ x4

( 1
24 y(0)+ 1

24

)
+O

(
x5
)}

Heaviside and Dirac Functions
Laplace and Fourier transforms interact closely with theHeaviside

unit-step function and the Dirac unit-impulse function. ăe Dirac
and Heaviside functions are related by∫ x

−∞
Dirac(t)dt =Heaviside(x) and

d
dx

Heaviside(x)=Dirac(x)

ăeDirac function is not a function in the usual sense. It represents an
inđnitely short, inđnitely strongunit-area impulse. It satisđesDirac(x)
= 0 if x ̸= 0, and can be obtained as the limit of functions fn (x) sat-
isfying

∫ ∞
−∞ fn (x) dx = 1.

Dirac(x)

ăe Heaviside function satisđes

Heaviside(x) =


0 if x < 0
1
2 if x = 0
1 if x > 0

ăe value of the Heaviside function at 0 is taken to be 1
2 .

Neither the Dirac or Heaviside function is deđned for nonreal
complex numbers.

­2 ­1 0 1 2

0.5

1.0

x

y

Heaviside(x)
Compute> Evaluate
Heaviside(π) = 1 Heaviside(−e) = 0
Dirac(2) = 0

Toenter the nameof theDirac orHeaviside function
1. Choose Insert>Math Objects>Math Name.
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2. Type the function name in theName box with upper and lower
case as they appear above, and choose OK.

ăe Heaviside and Dirac functions respect conditions set by the Note
Type assume, positive, real, and
additionally in mathematics mode, and
they will turn upright and gray.

functions “assume” and “additionally.”

Compute> Evaluate
assume(x,positive) = (0,∞)

Heaviside(x) = 1

Compute> Evaluate
assume(x, real) = R
additionally(x ̸= 0) = R\{0}
Dirac(x) = 0

If you prefer to work with shorter names, you can deđne them as
follows. Results of computations will, however, return the long name.

Compute> Deönitions> New Deönition
δ (x) = Dirac(x) H (x) = Heaviside(x)

You can test these deđnitions by calculating an appropriate inte-
gral or derivative.

Compute> Evaluate∫ 1
−1 δ (x) dx = 1 H ′ (x) = Dirac(x)

­3 ­2 ­1 0 1 2 3

0.5

1.0

x

y

Heaviside(1− x)Heaviside(2+ x)

You can create characteristic functions with the Heaviside func-
tion. For example, the product Heaviside(1− x)Heaviside(2+ x)
gives the function that is 1 on the interval [−2,1] and 0 elsewhere.

Laplace Transforms
If f is a function on [0,∞], the functionL ( f ) = f̂ deđned by the

integral

f̂ (s) = L ( f (t) , t,s) =
∫ ∞

0
e−st f (t) dt

for those values of s for which the integral converges is the Laplace
transformof f , that is, it is the integral transformwithkernelK (s, t)=
e−st . ăe Laplace transform depends on the function f and the num-
ber s. ăe equation above also deđnes the Laplace operator L .

A constant coefficient linear differential equation in f (t) is trans-
formed into an algebraic equation in f̂ (s) by the operator L . A so-
lution can be found to the differential equation by đrst solving the
algebraic equation to đnd f̂ (s) and then applying the inĂerse Laplace
transform to determine f (t) from f̂ (s).

391



i
i

“Compute60” — 2011/12/20 — 14:27 — page 392 — #402 i
i

i
i

i
i

Chapter 10 | Differential Equations

Expressions involving exponentials, polynomials, trigonometrics
(sin, cos, sinh, cosh) with linear arguments, and Bessel functions
(BesselJ, BesselI) with linear arguments can be transformed.

ăe Laplace transform also recognizes derivatives and integrals,
the Heaviside unit-step function Heaviside(x), and the Dirac-delta
unit impulse function Dirac(x).

Computing Laplace Transforms
Tocompute theLaplace transformof an expression

• With the insert point in the expression, choose Compute >
Transforms> Laplace.

Compute> Transforms> Laplace
t , Laplace Transform is: 1

s2

t3/2− et + sinhat , Laplace Transform is: 3
√

π
4s5/2 − a

a2−s2 − 1
s−1

You can also compute a Laplace transform using the symbol L .
Tocompute aLaplace transformusing the symbolL

1. From the Miscellaneous Symbols panel, choose L .

2. Choose Insert>Math Objects> Brackets.

3. Click ( , and choose OK.

4. Inside the parentheses, type an expression in the variable t .

5. Choose Compute> Evaluate. Tip
The default variable of integration is t and the
default transform variable is s. The computing
engine evaluates a Laplace transform with t as
input variable and produces a solution using
the variable s.

Compute> Evaluate

L (t) = 1
s2 L

(
t3
)
= 6

s4 L (3sin t) = 3
s2+1

To compute the Laplace transform of an expression E with variable of inte-
gration x and transformvariable y

1. Place the insert point in L (E,x,y).

2. Choose Compute> Evaluate.

You can use other variable names by specifying the variable of in-
tegration and the transform variable as in the following examples.

Compute> Evaluate
L (x,x,y) = 1

y2 L
(
x3,x,s

)
= 6

s4 L
(
e2πw,w,u

)
=− 1

2π−u
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Computing Inverse Laplace Transforms
Tocompute the inverseLaplace transformof an expression

1. Place the insert point in the expression.

2. Choose Compute>Transforms> Inverse Laplace.

Compute> Transforms> Inverse Laplace
2
s3 , Is Laplace Transform of t2

1
s+α , Is Laplace Transform of e−at

1, Is Laplace Transform of Dirac(t)
Tip
The default variable for the inverse transform
is s, and the default output variable is t . The
inverse Laplace transform will interpret
correctly an expression with the variable s as
input.

You can also compute an inverse Laplace transform by evaluating
an expression of the form L −1 ( f (s)).

Tocompute an inverseLaplace transformusing the symbolL
• With the insert point in the expression L −1 ( f (s)), choose

Compute> Evaluate.

Compute> Evaluate
L −1

(
1
s2

)
= t L −1

(
6
s4

)
= t3 L −1

(
3

s2+1

)
= 3sin t

For other variable names, the variable of integration and the trans-
form variable must be speciđed, as in the following examples.

Compute> Evaluate
L −1

(
2
s3 ,s,x

)
= x2 L −1

( 1
x+α ,x,y

)
= e−αy L −1 (1,a,b) = Dirac(b)

If the range of parameters must be restricted, use the functions as-
sume and additionally.

ăe following two examples demonstrate the use of the Laplace
transform to solve a differential equation.

Example In order to solve the problem

f ′ (t)+a f (t) = 0, f (0) = b

deđne f (t) as a generic function and a and b as generic constants.
ăen evaluate both sides of the equation:

L
(

f ′ (t)+a f (t)
)
= L (0)
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to get
sL ( f (t) , t,s)− f (0)+aL ( f (t) , t,s) = 0

Solve this equation for L ( f (t) , t,s) to get

L ( f (t) , t,s) =
f (0)
s+a

=
b

s+a

Now use the inverse Laplace transform to get

f (t) = L −1
(

b
s+a

)
= be−ta

Check: Deđne f (t) = be−ta and evaluate f ′ (t)+a f (t) and f (0) to
get

f ′ (t)+a f (t) = 0
f (0) = b

Example Consider the second-order differential equation

y′′+ y = 0

with the initial conditions y(0) = 1 and y′(0) = −2. Deđne y(t) as
a generic function and apply Evaluate to L (y′′ (t)+ y(t) , t,s) to get

L
(
y′′ (t)+ y(t) , t,s

)
= s2L (y(t) , t,s)−sy(0)−y′ (0)+L (y(t) , t,s)

Solve the equation

s2L (y(t) , t,s)− sy(0)− y′ (0)+L (y(t) , t,s) = 0

for L (y(t) , t,s) with Solve> Exact to get

L (y(t) , t,s) =
sy(0)+ y′ (0)

s2 +1

Replace y(0) with 1 and y′ (0) with−2 to get

L (y(t) , t,s) =
s−2
s2 +1

Now take the inverse Laplace transform by applying Evaluate to the
expression

L −1
(

s−2
s2 +1

,s, t
)
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to get

L −1
(

s−2
s2 +1

,s, t
)
= cos t−2sin t

Check: If y(t) = cos t − 2sin t then y′′(t) = −cos t + 2sin t then
indeed y′′(t)+ y(t) = 0, y(0) = 1, and y′ (0) =−2.

Fourier Transforms
Fourier transforms provide techniques for solving problems in lin-

ear systems andprovide aunifyingmathematical approach to the study
of diverse đelds including electrical networks and information theory.

If f is a real-valued function on (−∞,∞), the function f̂ =F ( f )
deđned by the integral

f̂ (w) = F ( f (x) ,x,w) =
∫ ∞

−∞
e−iwx f (x)dx

for those values of w for which the integral converges is the Fourier
transformof f ; that is, it is the integral transformwithkernelK (w, t)=
e−iwt or K (w, t) = eiwt . ăe Fourier transform depends on the func-
tion f and the number w.

Computing Fourier Transforms
Tocompute theFourier transformof an expression

1. Place the insert point in the expression.

2. Choose Compute>Transforms> Fourier.

Compute> Transforms> Fourier
1, Fourier Transform is: 2π Dirac(w)
e−ix, Fourier Transform is: 2π Dirac(w−1)
e2πix, Fourier Transform is: 2π Dirac(2π +w)

You can also compute a Fourier transform using the symbol F .

Tocompute a Fourier transformusing the symbolF
1. From the Miscellaneous Symbols Panel, choose F .

2. Choose Insert>MathObjects>Brackets, click ( , and choose
OK.

3. Inside the parentheses, type an expression in terms of the vari-
able x.
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4. Choose Compute> Evaluate.

Compute> Evaluate
F (1) = 2π Dirac(w) F

(
e−ix

)
= 2π Dirac(w−1)

You can also specify both the expression variable and the trans-
form variable.

Compute> Evaluate
F (1,x,y) = 2π Dirac(y) F

(
e−iy,y,z

)
= 2π Dirac(z−1)

Computing Inverse Fourier Transforms
Tocompute the inverse Fourier transformof an expression

• With the insert point in the expression, choose Compute >
Transforms> Inverse Fourier.

Compute> Transforms> Inverse Fourier
1, Is Fourier Transform of Dirac(x)
e−5iw, Is Fourier Transform of Dirac(x+5)

Tocompute an inverse Fourier transformusing the symbolF−1

• With the insert point in the expression F−1 ( f (w)), choose
Compute> Evaluate.

Compute> Evaluate
F−1

(
−2 i

ω ,ω, t
)
= 2Heaviside(−t)−1

You can also specify the variable of integration and the transform
variable, as in the following examples.

Compute> Evaluate
F−1 (2π Dirac(h) ,h,s) = 1 F−1 (−2i/w,w, t) = 2Heaviside(−t)−1

For some of these expressions, Simplify gives a better form for the
solution.

Compute> Simplify
F−1 (−iπ Dirac(−ω +ω0)+ iπ Dirac(ω +ω0) ,ω , t) =−sin(tω0)

F−1
( 3

2 π Dirac(ω−4)+3π Dirac(ω)+ 3
2 π Dirac(ω +4) ,ω, t

)
= 3

4 e(−4i)t
(
e4it +1

)2
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Computing Fourier Transforms of Multiple Expressions
Tocompute the transforms and inverse transformsofmultiple expressions

• Type the expressions in a single column matrix preceded by the
symbol F or F−1 and choose Compute> Evaluate.

Compute> Evaluate

F

(
1

e2πix

)
=

(
2π Dirac(w)

2π Dirac(2π +w)

)
Systems

Systems consisting of more than one equation are handled in a
consistent manner. Such problems include initial-value problems and
systems of differential equations.

Exact Solutions
ăestatement of some problems requiresmore than one equation.

You enter systems with initial conditions, systems of differential equa-
tions, boundary-value problems, or a mixture of these problems using
n× 1 matrices, where n is the number of equations and conditions
involved.

Tocreate a systemof differential equations in amatrix
1. Choose Insert>Math Objects>Matrix.

2. Select 1 column, set the number of rows equal to the number of
equations, and choose OK.

3. Choose View and select Helper Lines and Input Boxes to show
where to enter the required equations.

4. Type the equations, one to a row.

Tocreate a systemof differential equations in a display
1. Choose Insert>Math Objects>Display.

2. Choose View and select Helper Lines and Input Boxes to show
where to type the required equations.

3. Type the equations, one to a row, pressing Enter to create each
new row as needed.
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To solve a systemof differential equations
1. Leave the insert point in the matrix or display.

2. Choose Compute> Solve ODE> Exact, or
Choose Compute> Solve ODE> Laplace.

Compute> Solve ODE> Exact
y′+ y = x
y(0) = 1 , (Independent Variable: x), ODE solution: {x+2e−x−1}

y′′+ y = 0
y(0) = 0

y′ (0) = 1
, (Independent Variable: x), ODE solution: {sinx}

Compute> Solve ODE> Laplace
y′′+ y = x2

y(0) = 1
y′(0) = 1

(Independent Variable: x), ODE solution (Laplace):
{

3cosx+ sinx+ x2−2
}

ăe following examples illustrate some of the different notations
you can use for entering and solving systems of differential equations.

Compute> Solve ODE> Laplace
dy
dx

= sinx

y(0) = 1
, ODE solution (Laplace): {2− cosx}

Dxxy− y = 0
y(0) = 1

y′ (0) = 0
, ODE solution (Laplace): {C1ex− e−x (C1−1)}

Dxxxy− y = 0
y(0) = 1

y′ (0) = 0
y′′(0) = 0

, ODE solution (Laplace):
{

1
3 ex + 2

3

(
cos 1

2

√
3x
)

e−
1
2 x
}

Anew independent variable is introduced in certain instanceswhere
none is provided.

Compute> Solve ODE> Laplace
y′ = x
x′ =−y (Independent Variable: t), ODE solution (Laplace):

{[
x(t) =C5eit +C6e−it ,y(t) = iC6e−it − iC5eit

]}
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Notice that an exact solution to this problem involves a two-parameter
family of solutions.

Compute> Solve ODE> Exact
y′ = x

x′ =−y
x(0) = 0
y(0) = 1

(Independent Variable: t), ODE solution: {[x(t) =−sin t,y(t) = cos t]}

Subscripted dependent variables are allowed.

Compute> Solve ODE> Laplace
Dxy1 + y1 = e2x

y1 (0) = 1 , ODE solution (Laplace):
{ 2

3 e−x + 1
3 e2x

}
Dxxy1− y1 = 0

y1(0) = 1
y′1 (0) = 0

, ODE solution (Laplace): {coshx}

ăe next two examples show solutions using Exact for nonlinear
equations. the command Laplace produces no result for these equa-
tions, as Laplace transforms are appropriate for linear equations only.

Compute> Solve ODE> Exact
y′ = y2 +4
y(0) =−2 , (Independent Variable: t), ODE solution:

{{
2tan

(
2t− 1

4 π +C5π
)

ifC5 ∈ Z
}}

(x+1)y′+ y = lnx
y(1) = 10 , (Independent Variable: x), ODE solution:

{
lnx− e−

t
x+1 (x+1)√e(lnx−10)

}
Series Solutions

ăe following examples illustrate series solutions to two types of
differential equations with boundary conditions.
To solve a differential equationby the seriesmethod

1. Enter the equation andboundary conditions in a display or one-
column matrix.

2. Place the insert point in the display or matrix and choose Com-
pute> Solve ODE> Series.

3. If theMathComputationArguments dialog appears, type a vari-
able, center, and order in the dialog box.
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For the following examples, the series center is 0 and order is 5 (the
default values).

Compute> Solve ODE> Series
y′ = y2 +4
y(0) =−2 ,(Variable: t), Series expansion:

{
−2+8t−16t2 + 128

3 t3− 320
3 t4 +O

(
t5
)}

Dxxy1− y1 = 0
y1(0) = 1
y′1 (0) = 0

, Series expansion:
{

1+
1
2

x2 +
1
24

x4 +O
(
x5
)}

Numerical Methods
Appropriate systems can be solved numerically. ăe numeric so-

lutions are functions that can be evaluated at points or plotted.

Numerical Solutions for Initial-Value Problems
An initial-value problem is a problem that has one or more condi-

tions speciđed.
To solve an initial-value problemnumerically

1. Start with a column matrix and enter an initial-value problem,
such as

y′ =−y
y(0) = 1 or y′ = sin(x+ y)−2y

y(0) = 1

with one equation per row.

2. Choose Compute> Solve ODE>Numeric.

Compute> Solve ODE> Numeric
y′ = sin(x+ y)−2y

y(0) = 1 (Variable: x), Functions deđned: y

ăis calculation deđnes a function y that can be evaluated at given
arguments. You can use the function to generate a table of values, and
as you will see in the next section, the function can be plotted.

Compute> Evaluate
y(1) = 0.54343
y(10.7) =−0.28601
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Togenerate a table of function values for a function y
1. Deđne the functiong(i)= 0.1i and chooseCompute>Matrix

> Fill Matrix.

2. In the dialog box, select 10 rows and 1 column, select Deđned
by function and type the function name g.

3. Select the column, and chooseMatrices>MapFunction. Type
y in the dialog box and choose OK.

Compute> Evaluate

y



0.1
0.2
0.3
0.4
0.5
0.6
0.7
0.8
0.9
1.0


=



0.89478
0.80888
0.73965
0.68471
0.64190
0.60918
0.58468
0.56661
0.55336
0.54343


ăis calculation generates a list of function values for y as x varies

from 0.1 to 1.

Graphical Solutions to Initial-Value Problems
Toplot numerical solutions to initial-value problems

1. Compute the numerical solution to an initial-value problem.

2. Select the function deđned.

3. Choose Compute> Plot 2D> Rectangular.

To đnd a solution to the initial-value problem y′ = sinxy, y(0) =
3, enter the two equations into a 2× 1 matrix, and choose Compute
> Solve ODE>Numeric.

Compute> Solve ODE> Numeric
y′ = sin(xy)

y(0) = 3 , Functions deđned: y

Now plot y by choosing Compute > Plot 2D > Rectangular or
Compute> Plot 2D>ODE.
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Chapter 10 | Differential Equations

Compute> Plot 2D> Rectangular
y

­6 ­4 ­2 0 2 4 6

1

2

3

x

y

Numerical Solutions to Systems of Differential Equations

Tođndnumerical solutions for systemsof differential equationswith initial
values

1. Enter the equations into an n×1 matrix or display.

2. Place the insert point into thematrix ordisplay and chooseCom-
pute> Solve ODE>Numeric.

Solve the following system numerically by entering the equations
into a 6×1 matrix and choosingCompute> SolveODE>Numeric.
ăree functions x, y, and z are returned as output.

Compute> Solve ODE> Numeric
x′ = x+ y− z

y′ =−x+ y+ z
z′ =−x− y+ z

x(0) = 1
y(0) = 1
z(0) = 1

, Functions deđned: x,y,z

ăe following table lists values of x, y, and z as the independent
variable t varies from 0 to 1.
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Numerical Methods

t x y z

0 1.0000 1.0000 1.0000
0.1 1.1158 1.0938 0.8842
0.2 1.2668 1.1695 0.7332
0.3 1.4582 1.2173 0.5418
0.4 1.6953 1.2253 0.3047
0.5 1.9830 1.1791 0.0170
0.6 2.3256 1.0619 −0.3256
0.7 2.7265 0.8542 −0.7265
0.8 3.1873 0.5344 −1.1873
0.9 3.7077 0.0777 −1.7077
1.0 4.2842 −0.5424 −2.2842

You can create a matrix with these values.

Togenerate a table of function values for numerical solutions x,y,z
1. With the insert point in the column at the right, choose Com-

pute>Matrices>Map Function. Type x in the dialog box.



0.0
0.1
0.2
0.3
0.4
0.5
0.6
0.7
0.8
0.9
1.0


2. Similarly, apply Map Function to get the y and z columns.

3. To create a matrix with all four columns, place the t , x, y, and z
columns next to one another and choose Compute>Matrices
>Concatenate.

4. To add a row at the top for labels, select the matrix by placing
the insert point immediately to the right of the matrix. Choose
Edit> Insert Rows.

5. To line up entries, select a column, choose Edit > Properties,
and change Column Alignment to Leĕ or Right.

Note
For matrices that do not have built-in
delimiters, you must select only the matrix,
not including brackets, to have Insert Rows
appear on a menu.

You can also take advantage of the fact that you are using a text ed-
itor tomove the values into a 12×4 table. ăis is only for the purpose
of creating a special appearance—a table does not behave mathemat-
ically as a matrix. To make a table that will print with lines, choose
Insert > Table. Copy the information from the matrix into the table
by selecting, clicking, and dragging each piece of data. Choose Edit>
Properties and add lines according to instructions in the Table Prop-
erties dialog box.
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Graphical Solutions to Systems of Ordinary Differential
Equations

You can create and plot matrices for each of x, y, and z of the pre-
ceding example.
Tocreatematrices andplot numerical solutions to initial-value problems

1. Concatenate the columns for t and x. Note
You can distinguish between the following
three curves by noting, for example, that
x(1.0)≈ 4.2842,
y(1.0)≈−0.5424, and
z(1.0)≈−2.2842.

2. Choose Compute> Plot 2D> Rectangular.

3. Generate a similar matrix using t and y and drag it to the plot
frame.

4. Generate a similar matrix using t and z and drag it to the plot
frame.

Compute> Plot 2D> Rectangular

0 1.0
0.1 1.116
0.2 1.267
0.3 1.458
0.4 1.695
0.5 1.98
0.6 2.326
0.7 2.726
0.8 3.187
0.9 3.708
1.0 4.284


Select and drag to the plot the matrix corresponding to t and y
Select and drag to the plot the matrix corresponding to t and z

0.1 0.2 0.3 0.4 0.5 0.6 0.7 0.8 0.9 1.0

­2

0

2

4

x

y

Curve in space
You can also visualize the solution by plotting
the points (x(t) ,y(t) ,z(t)) for
t = 0,0.1, . . . ,1.0.

1
2­2

­1

x
­0.5

0.0

0

z
3

0.5

1

y 41.0

Note that the numeric output for t between 0 and 1 does not pre-
dict long-range behavior. ăis system of differential equations de-
scribes a highly unstable system.
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Bessel Functions
ăe Bessel functions Iv (z) = BesselIv (z), Jv (z) = BesselJv (z),

Kv(z) = BesselKv (z), and Yv(z) = BesselYv (z) are rather compli-
cated oscillatory functions with many interesting properties. ăey are
deđned for complex arguments v and z.

ăe functions Jv(z) andYv(z) are solutions of the đrst and second
kind, respectively, to the Bessel equation

z2 d2w
dz2 + z

dw
dz

+
(
z2− v2)w = 0

ăey can be deđned in terms of the Γ function:

2 4 6 8 10

­0.4

­0.2

0.0

0.2

0.4

0.6

0.8

1.0

x

y

BesselJv (z), v = 0,1,2,3,4

2 4 6 8 10

­2

­1

0

1

x

y

BesselYv (z), v = 0,1,2,3,4

Jv (z) =

( z
2

)v

√
π Γ
( v+1

2

) ∫ π

0
cos(zcos t)sin t2vdt

Yv(z) =
Jv (z)cosvπ− J−v (z)

sinvπ

ăe functions Iv(z) and Kv(z) are solutions known as đrst and sec-
ond kind, respectively, to the modiđed Bessel equation

z2 d2w
dz2 + z

dw
dz
−
(
z2 + v2)w = 0

ăey can be deđned in terms of the Γ function:

Iv (z) =

( z
2

)v

√
π Γ
( v+1

2

) ∫ π

0
exp(zcos t)sin t2vdt

Kv(z) =
π
2

I−v (z)− Iv (z)
sinvπ

Custom names
The custom namesBesselI,BesselK,
BesselJ, andBesselY are automatically
interpreted as Bessel functions. Choose
Compute> Deönitions> New Deönition to
deöne the functions
Iv(z) = BesselIv (z),
Kv(z) = BesselKv (z),
Jv(z) = BesselJv (z), and
Yv(z) = BesselYv (z).

ăe Gamma Γ is deđned for all complex numbers except for the
nonpositive integers. ăe Gamma function satisđes Γ(n) = (n−1)!
if n is a positive integer.
Tocreate customnames for theBessel functions

1. Choose Insert>Math Objects>Math Name.

2. Type BesselI, BesselK, BesselJ, or BesselY in the Name box
with capital letters as indicated.

3. Click the Function radio button in the Name Type pane and
choose OK.
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Chapter 10 | Differential Equations

4. Type a subscript andpress the spacebar to return to the base line.

5. Type an argument enclosed in parentheses.

A Ĕoating-point value is returned if either of the arguments is a
Ĕoating-point number and the other argument is numerical, or when
you use Evaluate Numeric.

Compute> Evaluate
BesselI2+3i (3.5−5i) =−12.996−2.3116i
BesselJ2 (6.0+ i) =−0.37649−0.21941i

­2 ­1 1 2

­1

1

2

x

y

BesselIv (z), ν = 0,1,2,3,4

0.0 0.5 1.0 1.5 2.0
0

2

4

6

8

10

x

y

BesselKv (z), v = 0,1,2,3,4

Compute> Evaluate Numeric
BesselK2+3i (3−5i)≈ 0.0073755−0.0047928i
BesselY2 (3i)≈ 0.039159 −2.2452i

Explicit symbolic expressions are returned when the index v is a
half integer.

Compute> Evaluate
BesselJ1/2 (x) =

√
2√

π
√

x sinx

BesselY3/2 (x) =−
√

2√
π
√

x

(
sinx+ 1

x cosx
)

ăe negative real axis is a branch cut of the Bessel functions for
noninteger indices v. A jump occurs when crossing this cut:

Compute> Evaluate
BesselI−3/4 (−1.2) =−0.76061−0.76061i
BesselI−3/4

(
−1.2+10−10i

)
=−0.76061−0.76061i

BesselI−3/4
(
−1.2−10−10i

)
=−0.50858+0.20505i If øoating-point approximations are desired for

arguments that are exact numerical
expressions, then we recommend using a
øoating-point expression in the argument
rather than evaluating the result numerically.
In particular, for half-integer indices the
symbolic result is costly to compute and
øoating-point evaluation of the resulting
symbolic expression may be numerically
unstable. Increasing the number for Digits
Used in Computations may achieve a
satisfactory result, but as a general rule, the
use of a øoating-point expression in the
argument gives more accurate results.

ăe Bessel functions can be used in conjunction with other math-
ematical operations.

Compute> Evaluate
d
dx

BesselJ0 (x) =−BesselJ1 (x)

d
dx

BesselJ1 (x) = 1
x (xBesselJ0 (x)−BesselJ1 (x))

limx→∞ BesselJ2
(
x2 +1

)
= 0

limx→∞ BesselI3/2
(
x2 + i

)
=
√

2√
π (i∞+∞)
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Compute> Power Series
BesselY3(x)

x =− 16
πx4 − 2

πx2 − 1
4π +O(x)

Exercises
1. Find the general solution of the equation y′′−6y′+5y = 0.

2. Find the general solution of the equation x2y′′−3xy′−6y = 0.

3. Find the general solution of the equation 2x2y′ = xy+3y2.

4. Solve the initial-value problem y′+ y = 2, y(0) = 0.

5. Solve the initial-value problem dy
dx − y+3 = 0, y(0) = 1.

6. Solve the Bessel equation z2 d2w
dz2 + z dw

dz +
(
z2− v2

)
w = 0.

7. Solve the equation y′+ y2 +b+ax = 0 and verify that the re-
sult is indeed a solution.

8. By Newton’s law of cooling, the rate of change in the tempera-
ture of an object is dT

dt = k(T −R), where k is a constant that
depends on how well insulated the object is, T is the tempera-
ture of the object, and R is room temperature. A cup of coffee is
initially 160◦; 10 minutes later, it is 120◦. Assuming the room
temperature is a constant 70◦, give a formula for the tempera-
ture at any time t . What will the temperature of the coffee be
aĕer 20 minutes?

Solutions
1. Compute > Solve ODE > Exact (Independent Variable t):

y′′−6y′+5y = 0, Exact solution: C1e5t +C2et

2. Compute>SolveODE>Exact (IndependentVariablex): x2y′′−
3xy′−6y = 0, Exact solution: C1x2+

√
10 +C2x2−

√
10

3. Compute>SolveODE>Exact (IndependentVariablex): 2x2y′=
xy+3y2, Exact solution: y(x) = x3/2

3
√

x+C1x

4. Compute > Solve ODE > Laplace (Independent Variable t):
y′+ y = 2
y(0) = 0 , Laplace solution: y(t) = 2−2e−t
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5. Compute > Solve ODE > Exact:
dy
dx − y+3 = 0

y(0) = 1
Exact

solution: y(x) = 3−2ex

6. Compute>SolveODE>Exact: z2 d2w
dz2 +z dw

dz +
(
z2− v2

)
w=

0, Exact solution: C31 BesselJv (z)+C32 BesselYv (z).

7. Compute> Solve ODE> Exact: y′+ y2 +b+ax = 0, Exact

solution: −
C29 AiryAi

(
− 1

a
b+ax
3
√

1
a
,1

)
+AiryBi

(
− 1

a
b+ax
3
√

1
a
,1

)

AiryBi

(
− 1

a
b+ax
3
√

1
a
,0

)
3
√

1
a+C29 AiryAi

(
− 1

a
b+ax
3
√

1
a
,0

)
3
√

1
a

r

Compute>Deđnitions>New Deđnition: y(x) =

−
C29 AiryAi

(
− 1

a
b+ax
3
√

1
a
,1

)
+AiryBi

(
− 1

a
b+ax
3
√

1
a
,1

)

AiryBi

(
− 1

a
b+ax
3
√

1
a
,0

)
3
√

1
a+C29 AiryAi

(
− 1

a
b+ax
3
√

1
a
,0

)
3
√

1
a

Compute> Evaluate, Simplify: y′ (x)+y(x)2+b+ax = b−

1
a

AiryBi

(
− 1

a 3
√

1
a
(b+ax),0

)
3
√

1
a

2 (b+ax)+ 1
aC29

AiryAi

− 1

a 3
√

1
a
(b+ax),0


3
√

1
a

2 (b+ax)

AiryBi

(
− 1

a 3
√

1
a
(b+ax),0

)
3
√

1
a+C29 AiryAi

(
− 1

a 3
√

1
a
(b+ax),0

)
3
√

1
a

+ax = 0.

8. Compute > Solve ODE > Exact: dT
dt = k (T −70), Exact so-

lution: T (t) = 70+ ektC1

Compute > Solve > Exact: 160 =C1e0 +70
120 =C1ek10 +70

, Solution:{
k = 1

10 ln 5
9 ,C1 = 90

}
Compute>Deđnitions>NewDeđnition: C1 = 90, k= 1

10 ln 5
9

Compute>Deđnitions>NewDeđnition: T (t)= 70+ektC1

Compute> Evaluate: T (t) = 90e
1

10 t ln 5
9 +70

Compute> Evaluate Numeric: T (20) = 97.778◦
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Statistics

Statistics: the mathematical theory of ignorance. Morris Kline (1908–1992)

S tatistics is the science and art of obtaining and analyzing quan- Introduction to Statistics

Measures of Central Tendency

Measures of Dispersion

Distributions and Densities

Families of Continuous
Distributions

Families of Discrete Distributions

Random Numbers

Curve Fitting

titative data in order to make sound inferences in the face of
uncertainty. ăe word statistics is used to refer both to a set of

quantitative data and to a đeld of study. ăe đeld includes the devel-
opment and application of effective methods for obtaining and using
quantitative data.

Introduction to Statistics
You can perform statistical operations on data using the various

itemson theStatistics submenu. In addition to themenu items, a num-
ber of the standard statistical distribution functions and densities are
available, either built in or deđnable.

ăe items Mean, Median, Mode, Moment, õuantile, Mean De-
viation, Standard Deviation, and Variance on the Statistics submenu
take a single argument that can be presented as a list of data or as ama-
trix. ăe result of an operation is a number or, in the case of a matrix
or vector, a number for each column.

ăe items Correlation, Covariance, and Fit Curve to Data on the
Statistics submenu take a single argument that must be a matrix. For
the multiple regression curve-đtting commands, the columns must be
labeledwith variable names. ăe choiceCompute> Statistics>Ran-
dom Numbers allows you to get random samples from standard fam-
ilies of distributions.
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Lists and Matrices
You can store data in lists or in matrices. Numbers in a list should

be separated by commas, with the numbers and commas both inmath-
ematics mode. Lists can be plain or enclosed in brackets. A list of data
is also referred to as a set of data. A list can be reshaped into a matrix.
To reshape a comma-delimited list or set of data into amatrix

1. Place the insert point in the list or set, and choose Compute>
Matrices> Reshape.

2. In the dialog box that appears, type a number for Columns and
choose OK.

3. If brackets donot appear, select thematrixwith themouse, choose
Insert>MathObjects>Brackets, and select appropriate brack-
ets.

Compute>Matrices> Reshape

1,3.1,2,9.6,3,10.5,4,6.8,5,2.9,6,2.2, (Columns: 2)


1 3.1
2 9.6
3 10.5
4 6.8
5 2.9
6 2.2


Compute> Plot 2D Rectangular[

1 2 3 4 5 6
3.1 9.6 10.5 6.8 2.9 2.2

]T

1 2 3 4 5 6
2

4

6

8

10

x

y

For this plot, the matrix of points was used for two items. Item 1 is
a Point Plot with Point Marker set to Circle. Item 2 has Line Style
set to Dash. (See Reshaping Lists and Matrices, page 293, for more
examples.)
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Measures of Central Tendency
You can compute ordinary measures of central tendency. Several

of these, such as Mean, Median, Mode, Geometric Mean, and Har-
monic Mean, are items on the Statistics submenu.

Arithmetic Mean
ăemean (arithmeticmean, average) of thenumbers x1,x2, . . . ,xn

is the most commonly used measure of central tendency. It is the sum
of the numbers divided by the number of numbers.

∑n
i=1 xi

n

Tođnd themeanof the numbers in a list

1. Place the insert point in the list.

2. Choose Compute> Statistics>Mean.

Compute> Statistics>Mean
a,b,cMean(s) 1

3 a+ 1
3 b+ 1

3 c 23,5,−6,18,23,−22,5Mean(s) 46
7

16.5,22.1,6.9,14.2,9.0, Mean(s) 13.74

Choosing Compute > Statistics > Mean gives the means of the
columns. ApplyingMean again, this time to the list of columnmeans,
gives the mean of the matrix entries.

Compute> Statistics>Mean 23 5 −6
18 23 −22
5 0 0

Mean(s)
[ 46

3 ,
28
3 ,−

28
3

] [ 46
3 ,

28
3 ,−

28
3

]
Mean(s) 46

9

Notice that twoof the followingmatrices are interpreted as labeled
matrices, so the đrst row is ignored.
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Compute> Statistics>Mean
x y z
1 1 4
3 2 5
5 3 6
7 4 7

Mean(s)
[
4, 5

2 ,
11
2

]  a b
c d
f g

Mean(s)
[ 1

2 c+ 1
2 f , 1

2 d + 1
2 g
]

[
4, 5

2 ,
11
2

]
Mean(s) 4

[ 1
2 c+ 1

2 f , 1
2 d + 1

2 g
]
Mean(s) 1

4 c+ 1
4 d + 1

4 f + 1
4 g

Median
Amedian of a đnite list of numbers is a number such that at least

half the numbers in the set are equal to or less than it, and at least half
the numbers in the set are equal to or greater than it. If two different
numbers satisfy this criterion, MuPAD takes the smaller number as
the median. ăe value computed for a median may vary according to
different conventions.

You do not have to arrange the numbers in increasing order before
computing the median. Leave the insert point in a list or set of data, a
vector, or a matrix and choose Compute> Statistics>Median.

Compute> Statistics>Median
1,5,2 Median(s) 2 2,3,3,3 Median(s) 3
1,2,3,4 Median(s) 2 23,5,−6,18,23,−22,5,7 Median(s) 5

For a matrix, you obtain the medians of the columns. ăe second
of the followingmatrices is interpreted as a labeledmatrix, and the đrst
row is ignored.

Compute> Statistics>Median 23 5 −6
18 23 −22
5 0 0

Median(s) [18,5,−6]


a b
1 2
5 6
3 4

Median(s) [3,4]

Quantile
ăe qth quantile of a set, where q is a number between zero and

one, is a number Q satisfying the condition that the fraction q of the
numbers falls below Q and the fraction 1−q lies above Q. ăe 0.5th
quantile is a median or 50th percentile, whereas the 0.25th quantile is
a đrst quartile or 25th percentile, and so forth. Take the qth quantile
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of a matrix to đnd the qth quantiles of the columns.
ăe value of a quantile of a đnite set of numbers may vary accord-

ing to different conventions. ăe quantile is interpreted here accord-
ing to the algorithms implemented by theMuPAD computational en-
gine. You can đnd quantiles of a list of numbers, a set of numbers, a
vector, or columns of a matrix.

Compute> Statistics> Quantile
1,2,3,4,5,6,7,8,9,10 õuantile(s): 0.87,9

{5.6,7,8.3,57,1.4,37,2}õuantile(s): 0.25,2

[765,654,345,789]õuantile(s): 0.99,789[
1137
100

,
49
20

,−354
25

]
õuantile(s): 0.75, 1137

100 23 5 −6
18 23 −22
5 0 0

 õuantile(s): 0.33, [5,0,−22]

 23 5 −6
9 −3 7

18 23 −22

õuantile(s): 0.50, [18,5,−6]

Mode
A mode is a value that occurs with maximum frequency. To đnd

the mode or modes of a list of numbers or of the columns of a ma-
trix, leave the insert point in the list ormatrix and choose Compute>
Statistics > Mode. ăe computational engine also returns the multi-
plicity of the mode or modes.

Compute> Statistics>Mode
23,5,−6,18,23,−22,5 Mode(s) [23,5] ,2
1,1,5,5,5,7,7,8,9,9,9 Mode(s) [5,9] ,3 23 5 −6

18 23 −22
5 23 0

Mode(s) [[23,18,5] ,1, [23] ,2, [−6,−22,0] ,1]

ăe following matrix is interpreted as a labeled matrix, and the

modes returned are the modes of the matrix
[

3 4
1 2

]
.
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Compute> Statistics>Mode a b
3 4
1 2

Mode(s) [[3,1] ,1, [4,2] ,1]

Geometric Mean
ăe geometric mean of n nonnegative numbers x1,x2, . . . ,xn is the

nth root of the product of the numbers

n
√

x1x2 · · ·xn

ăe geometric mean is useful with data for which the ratio of any two
consecutive numbers is nearly constant, such as money invested with
compound interest.

To đnd the geometric mean of a set of nonnegative numbers, leave
the insert point in a list, set, vector, or matrix of numbers and choose
Compute > Statistics > Geometric Mean. For a matrix, the result is
a list of geometric means of the columns.

Compute> Statistics> Geometric Mean
3,56,14,2Geometric Mean(s) 4

√
4704 5.19,7.3Geometric Mean(s) 6.1552[

2.9 5.2 9.7
6.2 8.8 1.1

]
Geometric Mean(s) [4.2403,6.7646,3.2665]

You can also đnd the geometric mean directly from the deđning
formula, as follows.

Compute> Evaluate Numeric
4
√

3×56×14×2≈ 8.2816
5
√
(5.19)(7.3)(2.77)(3.67)(8)≈ 4.9859

More generally, you can compute the geometric mean by deđning
the function

G(z,n) = n

√
n

∏
i=1

zi

and a vector z = [z1,z2, . . . ,zn] and then evaluating G(z,n).

Compute> Deönitions> New Deönition
G(z,n) = n

√
∏n

i=1 zi

s = [3,56,14,2] t = [5.19,7.3,2.77,−3.67,−8]
u = [4,7,18] v = [4,7,13,18]
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Compute> Evaluate Compute> Evaluate Numeric
G(s,4) = 4

√
4704 G(s,4)≈ 8.2816

G(t,5) = 4.9859 G(t,5)≈ 4.9859
G(u,3) = 3√504 G(u,3)≈ 7.9581
G(v,4) = 4√6552 G(v,4)≈ 8.9969

If you invest $1 and earn 10% per year for six years, the value of
your investment in this and the succeeding years is

1.00, 1.10, 1.21, 1.33, 1.46, 1.61, 1.77

ăe geometric mean of these seven numbers is 1.33.

Harmonic Mean
ăe harmonic mean of n positive numbers x1,x2, . . . ,xn is the re-

ciprocal of the mean of the reciprocals.

n

∑n
i=1

1
xi

ăe harmonic mean can be used in averaging speeds, where the dis-
tances applying to each speed are the same.

To đnd the harmonic mean of a set of positive numbers, leave the
insertion point in a list, set, vector, or matrix of numbers, and choose
Compute> Statistics>Harmonic Mean. For a matrix or vector, the
result is a list of harmonic means of the columns.

Compute> Statistics> Harmonic Mean

a,b,c Harmonic Mean(s)
3

1
a +

1
b +

1
c

2,4,6,8 HarmonicMean(s) 96
25

0.67,1.9,6.2,5.8,4.7 HarmonicMean(s) 1.9491

You can also compute a harmonicmean directly from the deđning
formula. Following are the harmonic mean of 2, 4, 6, and 8, and the
harmonic mean of 0.67, 1.9, 6.2, 5.8, and 4.7, respectively.

Compute> Evaluate
4

1
2+

1
4+

1
6+

1
8
= 96

25

5
( 1

0.67 +
1

1.9 +
1

6.2 +
1

5.8 +
1

4.7

)−1
= 1.9491
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You can compute the harmonic mean by deđning the function

H(z,n) =
n

∑n
k=1

1
zk

and the vector z = [z1,z2, . . . ,zn] and then evaluating H (z,n).

Compute> Deönitions> New Deönition
H(z,n) =

n

∑n
k=1

1
zk

s = [2,4,6,8] t = [0.67,1.9,6.2,5.8,4.7]
u = [4,7,18] v = [4,7,13,18]

Compute> Evaluate Compute> Evaluate Numeric
H (s,4) = 96

25 H (s,4)≈ 3.84
H (u,3) = 756

113 H (u,3)≈ 6.6903
H (t,5) = 1.9491 H (t,5)≈ 1.9491
H (v,4) = 13104

1721 H (v,4)≈ 7.6142

If you average20m.p.h. driving fromyourhome to a friend’s home
and 30 m.p.h. driving back home over the same route, then your “av-
erage” speed for the round trip is the harmonic mean

2
1

20 +
1
30

= 24 m.p.h.

ăis computation gives the speed that you would have to travel if you
did the round trip at a constant speed, taking the same total amount
of time.

Measures of Dispersion
ăevariousmeasures of dispersiondescribe different aspects of the

spread, or dispersion, of a set of variates about their mean.

Mean Deviation
ăe mean deviation is the mean of the distances of the data from

the data mean. ăe mean deviation of x1,x2, . . . ,xn is
n

∑
i=1

∣∣∣xi−
∑n

j=1 x j

n

∣∣∣
n
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where the vertical bars denote absolute value. For example, the mean
deviation of {1,2,3,4,5} is

|1−3|+ |2−3|+ |3−3|+ |4−3|+ |5−3|
5

=
6
5

You can present the data as a list, vector, or matrix. In the latter case,
you get the mean deviations of the columns.

Compute> Statistics>Mean Deviation
1,2,3,4,5 Mean deviation(s) 6

5[
−85 −55 −37
−35 97 50

]
Mean deviation(s)

[
25,76, 87

2

]
Variance and Standard Deviation

ăe sample variance for x1,x2, . . . ,xn is the sum of the squares of
differences with the mean, divided by n−1.

n

∑
i=1

(
xi−

∑n
j=1 x j

n

)2

n−1

Tocompute sample variance
• Place the insert point in a list of data, in a vector, or in a matrix

and choose Compute> Statistics> Variance.

Compute> Statistics> Variance
5,1,89,4,29,47,18Variance(s) 21055

21 18.1
5.3
7.6

Variance(s) 46.563

 23 5 −6
18 23 −22

5 0 0

Variance(s)
[ 259

3 , 439
3 , 388

3

]

Note that the following matrix is treated as a labeled matrix and
the đrst row is ignored in the computation.

Compute> Statistics> Variance x y
a b
c d

Variance(s)
[
2
( 1

2 a− 1
2 c
)2
,2
( 1

2 b− 1
2 d
)2
]
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ăe square root of the variance is called the standard deviation. It
is the most commonly used measure of dispersion.√√√√∑n

i=1

(
xi−

∑n
j=1 x j

n

)2

n−1

Compute> Statistics> Standard Deviation
[5,1,89,4,29,47,18]Standard Deviation(s) 1

21

√
21
√

21055 18.1
5.3
7.6

Standard Deviation(s) 6.8237

 23 5 −6
18 23 −22
5 0 0

Standard Deviation(s)
[ 1

3

√
3
√

259, 1
3

√
3
√

439, 2
3

√
3
√

97
]

Note that the following matrix is treated as a labeled matrix, and
the đrst row is ignored.

Compute> Statistics> Standard Deviation x y
a b
c d

Standard Deviation(s)
[√

2
√( 1

2 a− 1
2 c
)2
,
√

2
√( 1

2 b− 1
2 d
)2
]

Covariance
ăe coĂariance matrix of an m× n matrix X = [xi j] is an n× n

matrix with (i, j)th entry

m

∑
k=1

(
xki−

∑m
s=1 xsi

m

)(
xk j−

∑m
t=1 xt j

m

)
m−1

Note that for each i, the (i, i)th entry is the variance of the data in the
ith column, making the variances of the column vectors occur down
the main diagonal of the covariance matrix. ăe deđnition of covari-
ance matrix is symmetric in i and j, so the covariance matrix is always
a symmetric matrix.
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Compute> Statistics>Mean 1 2
3 5
4 3

Mean(s)
[ 8

3 ,
10
3

]
 8.5 −5.5 −3.7
−3.5 9.7 5.0

7.9 5.6 4.9

Mean(s) [4.3,3.2667,2.0667]

Compute> Statistics> Variance 1 2
3 5
4 3

Variance(s)
[ 7

3 ,
7
3

]
 8.5 −5.5 −3.7
−3.5 9.7 5.0

7.9 5.6 4.9

Variance(s) [45.72,61.843,24.943]

Compute> Statistics> Covariance 1 2
3 5
4 3

Covariance matrix
[

2.3333 1.1667
1.1667 2.3333

]
 8.5 −5.5 −3.7
−3.5 9.7 5.0

7.9 5.6 4.9

Covariance matrix

 45.72 −39.3 −18.45
−39.3 61.843 38.018
−18.45 38.018 24.943


Moment

ăe rth moment of a set {x1,x2, . . . ,xn} about the point a is the
following sum:

1
n

n

∑
i=1

(xi−a)r

ăus, the mean is also known as the Ėrst moment about zero. ăe sec-
ondmoment about zero is the quantity µ2+σ2, where µ is themean
and σ2 is the variance of the data. ăe rthmoment about the mean is
the sum

1
n

n

∑
i=1

(
xi−

1
n

n

∑
j=1

x j

)r
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As easily seen, the đrst moment about the mean is always 0.

Example ăe3rd and4thmoments of the set{2,4,6,8,10,12,14,16,18}
about the mean are

1
9

9

∑
i=1

(
2i− 1

9

9

∑
j=1

2 j

)3

= 0

1
9

9

∑
i=1

(
2i− 1

9

9

∑
j=1

2 j

)4

=
3776

3
≈ 1258.7

Compute> Statistics>Moment
(Moment Number: 1, Give Origin: 0)

8.5
−5.5
−3.7

3.5

Moment(s): 0.7

(Moment Number: 2, Give Origin: 0)
8.5
−5.5
−3.7

3.5

Moment(s): 32.11

(Moment Number: 1, Give Origin: 0.5)(
0.123 0.703 0.445 0.284

)
Moment(s): −0.11125

(Moment Number: 2, Compute moment about the mean.)(
0.123 0.703 0.445 0.284

)
Moment(s): 4.5878×10−2

Correlation
In dealing with two random variables, we refer to the measure of

their linear correlation as the correlation coefficient. When two ran-
dom variables are independent, this measure is 0. If two random vari-
ables X and Y are linearly related in the sense Y = a+ bX for some
constants a and b, then the coefficient of correlation reaches one of
the extreme values +1 or −1. In either of these cases, X and Y are
referred to as perfectly correlated. ăe formula for the coefficient of
correlation for two random variables is

ρ = ρ (X ,Y ) =
Cov(X ,Y )

σ xσ y
=

σ xy

σ xσ y
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where σ x and σ y are the standard deviations of the two random vari-
ables.

To compute the coefficient of correlation between two samples,
enter the data as two columns of a matrix and choose Compute >
Statistics>Correlation. You can apply this operation to any size ma-
trix to get the coefficient of correlation for each pair of columns: the
number in the i, j position is the coefficient of correlation between
column i and column j. A correlation matrix is always symmetric,
with ones on the main diagonal.

Compute> Statistics> Correlation
43 −62
77 66
54 −5
99 −61

Correlation matrix:
[

1.0 7.4831×10−2

7.4831×10−2 1.0

]

 −50 −12 −18
31 −26 −62
1 −47 −91

Correlation matrix:

 1.0 −0.52883 −0.71054
−0.52883 1.0 0.97297
−0.71054 0.97297 1.0


ăe relationship

Cov(X ,Y )
σ xσ y

= ρ (X ,Y ) among correlation, co-

variance, and the standard deviations is illustrated in the following:

 −50 −12
31 −26
1 −47





Correlation matrix:
[

1.0 −0.52883
−0.52883 1.0

]

Covariance matrix:
[

1677.0 −381.5
−381.5 310.33

]
Standard Deviation(s):

[√
1677, 7

3

√
3
√

19
]

Evaluate Numeric:
−381.5√

1677× 7
3

√
3
√

19
≈−0.52881

Distributions and Densities
A cumulative distribution function F (x) of a random variable X is

the function F (x) = P(X ≤ x), the probability that X ≤ x. If F(x)
has a derivative f (x), then f (x) is nonnegative and is called the prob-
ability density function of x. ăe inĂerse distribution function G(α)
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satisđes G(F (x)) = x and F (G(α)) = α . ăe names for these func-
tions are obtained by adding Dist, Den, or Inv to the name of the dis-
tribution. For example, NormalDist, NormalDen, and NormalInv
are the three functions for the normal distribution. ăese function
names will automatically turn gray when typed in mathematics mode.

Cumulative Distribution Functions
A cumulative distribution function is a nondecreasing function

deđned on the interval (−∞,∞), with values in the interval [0,1]. ăe
deđnition of a distribution function generally describes only the val-
ues where the function is positive, the implicit assumption being that
the distribution function is zero up to that point. For discrete cumu-
lative distribution functions, the deđnition also gives only the values
where the function changes, the implicit assumption being that the
cumulative distribution function is a step function. Commonly, def-
initions of these functions are stated only for integers. ăe deđnition
of a density function also generally describes only the values where the
function is positive, the implicit assumption being that the function is
zero elsewhere.

ăese distribution and density functions satisfy the relationships

f (x) =
d
dx

F(x) and F(x) =
∫ x

−∞
f (u)du

Also note that the cumulative distribution function satisđes

lim
x→∞

F(x) = 1 and lim
x→−∞

F(x) = 0.

In ScientiĖc WorkPlace and ScientiĖc Notebook, cumulative distribu-
tion functions are named FunctionDist, and the density functions are
named FunctionDen. For example, the probability density functions
for the normal distributions are called NormalDen.

You can compute with several families of distributions: Normal,
Cauchy, Student’s t, Chi-Square, F, Exponential, Weibull, Gamma,
Beta, Uniform, Binomial, Poisson, and Hypergeometric.

Inverse Distribution Functions
For a distribution function F mapping (−∞,∞) into [0,1], the in-

verse distribution functionG performs the corresponding inverse map-
ping from (a subset of ) [0,1] into (−∞,∞); that is, G(F (x)) = x and
F (G(α)) = α . Equivalently, Prob[X ≤ G(α)] = F(x) = α . Note
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that the value that is exceeded with probability α is given by the func-
tion G(1−α). ăis function is also of interest.

Prob [X ≤ G(1−α)] = F(x) = 1−α = 1−Prob [X ≤ G(α)]

When cumulative distribution functions are named FunctionDist,
then the inverse cumulative distribution functions arenamedFunctionInv.
For example, NormalInv is the name of the inverse cumulative distri-
bution function for the normal distribution.

Distribution Tables
Depending on the particular family of distributions, the distribu-

tion tables in statistics books list function values for selected parame-
ters of one of the functions described earlier—either the cumulative
distribution, the inverse cumulative distribution, or the probability
density function. With access to these functions, not only can you
compute the tabular entries easily and accurately, but you can also đnd
the corresponding values directly for any variables and parameters to
any degree of accuracy you wish.

Families of Continuous Distributions
ăe relationship of the various distribution, inverse distribution,

and density functions to the entries in standard statistical tables is ex-
plained in the following sections for each of the families of distribu-
tions available.

Gamma Function
ăe Gamma function Γ(t) that appears in the deđnition of the

Student’s t distribution and the gamma distribution is the continu-
ous function Γ(t) =

∫ ∞
0 e−xxt−1dx deđned for positive real numbers

t . ăe Gamma function satisđes

Γ(1) = 1 and Γ(t +1) = tΓ(t)

and for positive integers k, it is the familiar factorial function

Γ(k) = (k−1)!

ăeGamma function symbol Γ is recognized as a function. For exam-
ple, place the insert point in the expression Γ(5) and choose Evaluate
to get Γ(5) = 24. Note that 24 = 4×3×2×1. (See page 157 for a
plot of the Gamma function.)
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Use Rewrite> Factorial to convert the Gamma function to a fac-
torial expression. (First you must assume that x is an integer.)

Compute> Evaluate
assume(x, integer) = Z

Note
Type assume and integer in mathematics
mode, and they will turn upright and gray.Compute> Rewrite> Factorial

Γ(x) = (x−1)!
(m

n

)
= m!

n!(m−n)!

UseRewrite>Gammato convert factorials, binomials, andmulti-
nomial coefficients to expressions in the Gamma function.

Compute> Rewrite> Gamma
(x−1)! = Γ(x) x!y!z! = Γ(x+1)Γ(y+1)Γ(z+1)(m

n

)
= Γ(m+1)

Γ(n+1)Γ(m−n+1)
­4 ­2 0 2 4

0.2

0.4

0.6

0.8

x

y

Normal density functions

­4 ­2 0 2 4

0.5

1.0

x

y

Normal distribution functions

Normal Distribution
ăe normal cumulative distribution function is deđned for all real

numbers µ and for positive σ by the integral

NormalDist(x; µ,σ) =
1

σ
√

2π

∫ x

−∞
e−

(u−µ)2

2σ2 du

of the normal probability density function

NormalDen(u; µ,σ) =
1

σ
√

2π
e−

(u−µ)2

2σ2

ăe inverse of the normal cumulative distribution function,
NormalInv, is also available. All three of these function names can
be typed in mathematics, and they will automatically turn gray as you
type the đnal letter.

ăe parameters µ and σ are optional parameters for mean and
standard deviation, with the default values 0 and 1 deđning the stan-
dard normal distribution

NormalDist(x) =
1√
2π

∫ x

−∞
e−

u2
2 du

A normal distribution table, as found in the back of a typical statis-
tics book, lists some values of the standard normal cumulative dis-
tribution function. Certain versions of the table list the values 1−
NormalDist(x).
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Note that the function NormalDist can be evaluated as a function
of one variable (with default parameters (0,1)) or as a function of one
variable and two parameters.

Compute> Evaluate Numeric
NormalDist(2.44)≈ 0.99266 NormalDist(2.44;1,2)≈ 0.76424
NormalDist(2.44;0,1)≈ 0.99266 NormalDen(2.44;1,2)≈ 0.15393

Graphsof thenormal density functions are the familiar bell-shaped
curves. ăe plots to the right show the density functions
NormalDen(x; µ ,σ) anddistribution functionsNormalDist(x; µ,σ)
for the parameters (µ,σ) = (0,1) ,(0,5) ,(0,0.5) ,(1,1)

Student’s t Distribution
ăe Student’s t cumulative distribution function TDist(x;v) is de-

đned by the integral

TDist(x;v) =
Γ( v+1

2 )

Γ( v
2)
√

πv

∫ x

−∞

(
1+

1
v

u2
)− v+1

2
du

of the density function

TDen(u;v) =
Γ( v+1

2 )

Γ( v
2)
√

πv

(
1+

1
v

u2
)− v+1

2

with shape parameter v, called degrees of freedom, that ranges over

­4 ­2 0 2 4

0.1

0.2

0.3

0.4

x

y

Student’s t density functions

­4 ­2 0 2 4

0.5

1.0

x

y

Student’s t distribution functions

the positive integers. ăe variance for a Student’s t distribution is v
v−2 ,

provided v > 2.
ăe function TInv(p;v) is the value of x for which the integral has

the value p, as demonstrated here:

Compute> Evaluate Numeric
TDist(63.66;1)≈ 0.995 TDist(−0.97847;3)≈ 0.2
TInv(0.995;1)≈ 63.657 TInv(0.2;3)≈ −0.97847

ăe plots to the right display the density and distribution func-
tions TDen(x;v) and TDist(x;v) for the parameters v = 1 and v =
15 with−5≤ x≤ 5.

Note that the Student’s t density functions resemble the standard
normal density function in shape, although these curves are a bit Ĕat-
ter at the center. It is not difficult to show, using the deđnitions of the
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two density functions, that limv→∞ TDen(u;v) = NormalDen(u),
the density function for the standard normal distribution.

Student’s t distribution tables list values of the inverse distribu-
tion function corresponding to probabilities (values of the distribu-
tion function) and degrees of freedom. For values of v above 30, the
normal distribution is such a close approximation for the Student’s t
distribution that tables usually provide values only up to v = 30.

Example Assuming a Student’s t distribution with 5 degrees of
freedom, determine a value c such that Pr(−c < T < c) = 0.90,
where Pr denotes probability. Now Pr(−c < T < c) = Pr(T ≤ c)−
Pr(T ≤−c) = TDist(c;5)−TDist(−c;5). So, you need to solve
TDist(c;5)−TDist(−c;5) = 0.90. ăe Student’s t distribution sat-
isđes TDist(c;5)+TDist(−c;5) = 1. So, the problem reduces to

2TDist(c;5)−1 = 0.90

TDist(c;5) =
0.90+1

2
= 0.95

ăe problem is solved by TInv(0.95;5) = 2.015.
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Chi-Square Distribution
ăe chi-square cumulative distribution function is deđned for non-

negative x and µ by the integral

ChiSquareDist(x; µ) =
1

Γ( µ
2 )2

µ
2

∫ x

0
u

µ
2−1e−

u
2 du

ăe integrand is the chi-square probability density function

ChiSquareDen(u; µ) =
1

Γ( µ
2 )2

µ
2

u
µ
2−1e−

u
2

ăe indexing parameter µ > 0 is the mean of the distribution; it
is referred to as the degrees of Ěeedom.

ăeplots to the right showdensity functionsChiSquareDen(x; µ)
and distribution functions ChiSquareDist(x; µ) for µ = 1,5,10,15
and 0≤ x≤ 25.

ăe function, ChiSquareInv(t;ν) gives the value of x for which

ChiSquareDist(x;ν) = t.

ăis relationship is demonstrated in the following examples:
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Compute> Evaluate Numeric
ChiSquareInv(0.1;5)≈ 1.6103 ChiSquareDist(2.366;3)≈ 0.5
ChiSquareInv(0.5;3)≈ 2.366 ChiSquareDist(1.6103;5)≈ 9.9999×10−2 ≈ 0.1

Achi-square distribution table shows values ofν down the leĕ col-
umn and values u of ChiSquareDist across the top row. ăe entry in
row ν and column u is ChiSquareInv(u;ν).

F Distribution
ăe F cumulative distribution function is given by the integral

FDist(x;n,m) =
Γ( n+m

2 )

Γ( n
2)Γ(

m
2 )

( n
m

) n
2
∫ x

0
u

n−2
2

(
1+

n
m

u
)− n+m

2
du

of the probability density function

FDen(u;n,m) =
Γ( n+m

2 )

Γ( n
2)Γ(

m
2 )

( n
m

) n
2

u
n−2

2

(
1+

n
m

u
)− n+m

2

ăe variable x can be any positive number, and n and m can be any
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positive integers. ăe F distribution is used to determine the valid-
ity of the assumption of identical standard deviations of two normal
populations. It is the distribution on which the analysis of variance
procedure is based.

ăe inverse distribution function FInv(p;n,m) gives the value of
x for which the integral FDist(x;n,m)has the value p. ăese function
names automatically turn gray when they are entered in mathematics
mode. ăe relationship between these two functions is illustrated in
the following examples.

Compute> Evaluate Numeric
FDist(0.1;3,5)≈ 4.3419×10−2

FDist(3.7797;2,5)≈ 0.90000
FInv(0.9;2,5)≈ 3.7797
FInv(0.043419;3,5)≈ 0.1

Standard F distribution tables list some of the values of the inverse
Fdistribution function. ăus, for example, the4.4thpercentile for the
F distribution having degrees of freedom (3,5) isFInv(0.044;3,5) =
0.1, and the 90th percentile for the F distribution having degrees of
freedom (2,5) is FInv(0.90;2,5) = 3.7797.
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ăeplots on the previous page show probability density functions
FDen(x;n,m) and cumulative distribution functions FDist(x;n,m)
for (n,m) = (1,1) ,(2,5) ,(3,15), and 0≤ x≤ 5.

Exponential Distribution
ăe exponential cumulative distribution functionwith parameter µ ,

ormean µ , is deđned by the integral

ExponentialDist(x; µ) =
1
µ

∫ x

0
e
−u
µ du = 1− e

−x
µ

of the exponential density function 0 5 10 15 20 25
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Exponential distribution

ExponentialDen(u; µ) =
1
µ

e
−u
µ

for x≥ 0, and is 0 otherwise.
ăe inĂerse exponential distribution function

ExponentialInv(α; µ) = µ ln
1

1−α

is the value of x for which the integral has the value α , as illustrated
by the following:

Compute> Evaluate Numeric
ExponentialInv(0.73;0.58)≈ 0.75941
ExponentialDist(0.75941;0.58)≈ 0.73000
ExponentialDen(0.75941;0.58)≈ 0.46552

ăeplots to the right showdensity functionsExponentialDen(x; µ)
and distribution functions ExponentialDist(x; µ), for the parame-
ters µ = 1,3,5 and 0≤ x≤ 25.

Weibull Distribution
ăeWeibull distributionwith scale parameter b > 0 and shape pa-

rameter a > 0 is deđned by the integral

WeibullDist(x;a,b) = ab−a
∫ x

0
ua−1e−uab−a

du = 1− e−xab−a

of the density function

WeibullDen(u;a,b) = ab−aua−1e−uab−a
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for x≥ 0, and is 0 otherwise.

ăe inĂerse Weibull distribution function

WeibullInv(α;a,b) = b
(

ln
1

1−α

) 1
a

is the value of x for which the integral has the value α , as illustrated
by the following:

Compute> Evaluate Numeric
WeibullDist(0.51431;0.5,0.3)≈ 0.73
WeibullInv(0.73;0.5,0.3)≈ 0.51431
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Plots show the probability density functions WeibullDen(x;a,b)
and cumulative distribution functionsWeibullDist(x;a,b) for param-
eters (a,b) = (0.5,1), (1,1), (3,0.5), and (3,1), and 0≤ x≤ 3.

Gamma Distribution
ăe gamma distribution is deđned for x > 0 by the integral

GammaDist(x;a,b) =
1

baΓ(a)

∫ x

0
ua−1e−

u
b du

where Γ(t) =
∫ ∞

0 e−uut−1du is theGamma function. ăe parameters
a and b are called the shape parameter and scale parameter, respec-
tively. ăe mean of this distribution is ab and the variance is ab2. ăe
probability density function for the gamma distribution is

GammaDen(u;a,b) =
1

baΓ(a)
ua−1e−

u
b

Plots show the probability density functions GammaDen(x;a,b)
and cumulative distribution functions GammaDist(x;a,b) for
(a,b) = (1,0.5) ,(1,1) , and (2,1) and 0≤ x≤ 4.
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Beta Distribution
ăe beta distribution is deđned for 0≤ x≤ 1 by the integral
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BetaDist(x;v,w) =
1

B(v,w)

∫ x

0
uv−1 (1−u)w−1 du

where B(v,w) =
∫ 1

0 uv−1 (1−u)w−1 du is the Beta function with pa-
rameters v and w.

ăe probability density function for the beta distribution is

BetaDen(u;v,w) =
uv−1 (1−u)w−1

B(v,w)

ăe parameters v and w are positive real numbers called shape param-
eters, and 0≤ u≤ 1. ăe mean of the beta distribution is

v
v+w

.

Compute> Evaluate Numeric
BetaDist(0.5;2,3)≈ 0.6875 BetaDen(0.5;2,3)≈ 1.5 BetaInv(0.6875;2,3)≈ 0.5

Plots show theprobability density functionsBetaDen(x;b,c) and
cumulative distribution functions BetaDist(x;b,c) for
(b,c) = (2,3), (5,1), (3,8), and 0≤ x≤ 1.
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Cauchy Distribution
ăe Cauchy cumulative distribution function is deđned for all real

numbers α , and for positive β , by the integral

CauchyDist(x;α,β ) =
1

πβ

∫ x

−∞

(
1+
(

u−α
β

)2
)−1

du

ăe integrand is the Cauchy probability density function

CauchyDen(u;α,β ) =
1

πβ
(

1+
(

u−α
β

)2
)

ăe median of this distribution is α . ăe Cauchy probability density
function is symmetric about α and has a unique maximum at α .

Plots show theprobability density functionsCauchyDen(x;α,β )
and cumulative distribution functions CauchyDist(x;α,β ) for the
parameters (α,β ) = (−3,1), (0,1.5), and (3,1), and−5≤ x≤ 5.

­4 ­2 0 2 4

0.1

0.2

0.3

x

y

Cauchy density functions

­4 ­2 0 2 4

0.2

0.4

0.6

0.8

x

y

Cauchy distribution functions

Uniform Distribution
ăeuniform cumulative distribution functionUniformDist(x;a,b)

for a < b is the function

UniformDist(x;a,b) =


0 i f x≤ a

x−a
b−a i f a≤ x≤ b
1 i f b≤ x

ăe probability density function of the uniform distribution on an
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interval [a,b], where a < b, is the function

UniformDen(x;a,b) =


0 i f x≤ a
1

b−a i f a≤ x≤ b
0 i f b≤ x

ăeuniform random variable is the continuous version of “choosing a
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number at random.” ăe probability that a uniform random variable
on [a,b]will have a value in either of two subintervals of [a,b] of equal
length is the same.

Plots showtheprobability density functionsUniformDen(x;a,b)
and cumulative distribution functions UniformDist(x;a,b) for
(a,b) = (0,1), (1.5,5), (3,15) and−5≤ x≤ 20.

Families of Discrete Distributions
Several of the standard distributions are functions of a discrete

variable, usually the integers. ăey are commonly plotted with bar
graphs or broken line (polygonal) graphs.

Binomial Distribution
ăe binomial distribution functions are functions of a nonnegative

integer x,

BinomialDist(x;n, p) =
x

∑
k=0

(
n
k

)
pkqn−k

with Bernoulli trial parameter (or sample size) a positive integer n,
Bernoulli probability parameter a real number p with 0 < p < 1,
and q = 1− p. (To enter binomial coefficients,

(n
k

)
= n!

k!(n−k)! , choose

Compute>MathObjects, select the binomial fraction
(□
□
)
and check

None for line.) ăe corresponding binomial probability density func-
tion is

BinomialDen(x;n, p) =
(

n
k

)
pxqn−x

for the same conditions on x, n, and p. ăe mean for this distribution
is np, and the variance is npq.

Binomial distribution tables found in statistics books give selected
values of either the binomial probability density function
BinomialDen(x;n, p) or the cumulative distribution function
BinomialDist(x;n, p).
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ăe binomial density BinomialDen(x;n, p) gives the probability
of x successes in n independent Bernoulli trials, when the probabil-
ity of success at each trial is p. It is by far the most common discrete
distribution, since people deal with many experiments in which a di-
chotomous classiđcation of the result is of primary interest. ăe name
binomial distribution comes from the fact that the coefficients(

n
k

)
=

n!
k!(n− k)!

are commonly called binomial coefficients.

Example ăeprobability that, in100 tosses of a coinwithPr(heads)
= 0.55, no more than 54 heads turn up, assuming a binomial distri-
bution, is Pr(X ≤ 54) = BinomialDist(54;100,0.55) = 0.45868.

ăe binomial distribution function with parameters n and p can
be approximated by the normal distribution with mean np and vari-
ance np(1− p); that is,

BinomialDist(x;n, p)≈ NormalDist(x;np,
√

np(1− p))

Such approximations are reasonably good if both np and n(1− p) are
greater than 5. For example, to đnd an approximate solution to the
preceding problem using a normal distribution, use

Pr(X ≤ 54)≈ NormalDist(54;55.0,4.9749) = 0.42035 0 50 100
0.0

0.2

0.4

0.6

0.8

1.0

x
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ăe plots to the right show the graph of NormalDist(x;55.0,4.

9749)with apoint plot ofBinomialDist(x;100,0.55), and the graph
of

NormalDen(x;55.0,4.9749)

with a point plot of BinomialDen(x;100,0.55) for 0≤ x≤ 100.

Poisson Distribution
ăe Poisson cumulative distribution function is a discrete function

deđned fornon-negative integers. ăePoissondistributionwithmean
µ > 0 is given by the summation

PoissonDist(x; µ) =
x

∑
k=0

µke−µ

k!
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ăe Poisson probability density function is

PoissonDen(k; µ) =
µke−µ

k!
for nonnegative integers k and real numbers µ > 0. A Poisson dis-
tribution table lists selected values of the Poisson probability density
function PoissonDen(k; µ).

Compute> Evaluate Numeric
PoissonDen(2;3)≈ 0.22404 PoissonDen(5;0.3)≈ 1.5002×10−5

ăePoisson distribution can be used to approximate the binomial
distribution when the probability is small and n is large; that is,

PoissonDist(k; µ)≈ BinomialDist(k; µ ,µ (1− p))

where µ = np. ăis distribution has been used as amodel for a variety
of random phenomena of practical importance.

Hypergeometric Distribution
Suppose that, from a population of M elements, of which x possess

a certain attribute, you draw a sample of n items without replacement.
ăenumber of items that possess the certain attribute in such a sample
is a hypergeometric variate. ăe hypergeometric cumulative distribu-
tion function is a discrete function deđned for nonnegative integers x.
ăe hypergeometric distribution with M elements in the population,
K successes in the population, and sample size n is deđned by the fol-
lowing summation of quotients of binomial coefficients for0≤ x≤ n:
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HypergeomDist(x;M,K,n) =
x

∑
k=0

(K
k

)(M−K
n−k

)(M
n

)
For x < 0, the distribution function is 0, and for x≥ n, the function
is 1. ăe hypergeometric probability density function is

HypergeomDen(k;M,K,n) =

(K
k

)(M−K
n−k

)(M
n

)
for integers k , K , n, and M satisfying 0 ≤ k ≤ n, 0 ≤ K ≤ M, and
0 < n≤M.

ăe hypergeometric distribution is the model for sampling with-
out replacement. ăe hypergeometric distribution can be approxi-
mated by the binomial distribution when the sample size is relatively
small.
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Example What is the probability of atmost đve successes when you
draw a sample of 10 from a population of 100, of which 30 members
are identiđed as successes?

ăe probability of exactly x successes is given by

HypergeomDen(x;100,30,10) .

ăus, the probability of at most đve successes is the sum of exactly 0,
1, 2, 3, 4, and 5 successes, or

HypergeomDist(5;100,30,10) = 0.96123.

ăe previous plots (created as polygonal plots) depict the functions

HypergeomDen(x;100,30,10) and HypergeomDist(x;100,30,10)

for 0≤ x≤ 10.

Random Numbers
ăerandom-number generators on theStatistics submenugive you

a set of random numbers from one of several families of distribution
functions. ăe choices in the dialog are Beta, Binomial, Cauchy, Chi-
Square, Exponential, F, Gamma, Normal, Poisson, Student’s t, Uni-
form, and Weibull. Choose Compute > Statistics > Random Num-
bers.

Choose a distribution from the dialog, specify howmany random
numbers you want, and enter appropriate parameters. Following are
sample results.

Compute> Statistics> Random Numbers
Beta, Order 3, Order 7: 0.31172, 0.28533, 7.8338×10−2, 0.14925, 0.41693
Binomial, Number of Trials 10, Probability of Success 0.5: 6,2,6,5,6
Cauchy, Median 10, Shape Parameter 5: 13.069,13.412,7.5245,−3.8907,12.29
Chi-Square, Degrees of Freedom 3: 0.91006, 2.2787, 4.4748, 2.7026, 1.5385
Exponential, Mean Time Between Arrivals 10: 16.851, 16.865, 8.8222, 32.037, 12.434
F, Degrees of Freedom 1 and 3: 1.1585×10−2, 1.3279×10−2, 0.18187, 1.5567, 1.8483
Gamma, Shape Parameter 2, Scale Parameter 5: 4.4875,7.3945,10.114,6.1566,21.808
Normal, Mean 3, Standard Deviation 7: 5.223,−4.8075,−5.5782,−1.1218, 1.357
Poisson, Mean Number of Occurrences 4: 2, 4, 1, 2, 5
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Compute> Statistics> Random Numbers
Student’s t, Degrees of Freedom 7: −3.6549×10−2,−0.35357,1.3031,−1.1615,1.1861
Uniform, Lower End of Range 0, Upper End of Range 20: 5.6016, 16.744, 10.275, 14.057, 10.136
Weibull, Shape Parameter 5, Scale Parameter 3: 2.2615,3.0731,3.0868,3.8504,2.4592

Curve Fitting
You have the tools to do general curve đtting in an intuitive man-

ner. Choose Compute > Statistics > Fit Curve to Data and make a
choice in the dialog box.

• For straight-line đts, choose Multiple Regression or Multiple
Regression (no constant).

• For best đts by polynomials, choose Polynomial of Degree [ ].

Linear Regression
Multiple Regression calculates linear-regression equations with

keyed or labeled data matrices. ăe result is an equation expressing
the variable at the head of the đrst column as a linear combination of
the variables heading the remaining columns, plus a constant (that is
missing if Multiple Regression (no constant) was chosen).
ăe equation produced is the best đt to the data in the least-squares
sense.

Compute> Statistics> Fit Curve to Data>Multiple Regression
(Location of Dependent Variable: First Column)

y x
0 1.1

0.5 1.5
1 1.9

1.5 2.4

Regression is: y = 1.159x−1.2493

Compute> Statistics> Fit Curve to Data>Multiple Regression
(Location of Dependent Variable: First Column)

z x y
1 0 1.1
2 0.5 1.1
4 1 1.9
5 1.5 1.9

Regression is: z = 2.0x+1.25y−0.375
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ăe choice Multiple Regression (no constant) gives the following
linear equations:

Compute> Statistics> Fit Curve to Data>Multiple Regression
(no constant; Location of Dependent Variable: First Column)

u v
0 1.1

0.5 1.5
1 1.9

1.5 2.4
2 2.9

Regression is: u = 0.56733v


z x y
1 0 1.1
2 0.5 1.1
4 1 1.9
5 1.5 1.9
7 2 2.9

Regression is: z = 2.1829x+0.91245y

 x y
a b
c d

Regression is: x = y
1.0(ab+ cd)

b2 +d2

Polynomial Fit
Polynomial of Degree [ ] calculates polynomial equations from la-

beled or unlabeled two-column data matrices. ăe result is a polyno-
mial of the speciđed degree that is the best đt to the data in the least-
squares sense. For the polynomial đt, the x column appears đrst.

To đnd the best đt by a polynomial of second degree to the set
of points (0,0.64) ,(0.5,0.09) ,(1,0.04) ,(1.5,0.49) ,(2,1.44), re-
move the parentheses and convert the entries into a two-column ma-
trix. To make this conversion, place the insert point in the list and
choose Compute>Matrices> Reshape; then specify two columns.

Compute>Matrices> Reshape
(2 columns)

0,0.64,0.5,0.09,1,0.04,1.5,0.49,2,1.44,


0 0.64

0.5 0.09
1 0.04

1.5 0.49
2 1.44


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Compute> Statistics> Fit Curve to Data
(Check Polynomial of Degree [ ], type 2, choose OK.)

0 0.64
0.5 0.09
1 0.04

1.5 0.49
2 1.44

, Polynomial đt: y = 1.0x2−1.6x+0.64

You can plot the points and polynomial on the same graph. You
will notice that these points were chosen such that they lie on the
parabola.

Compute> Plot 2D> Rectangular
0 0.64

0.5 0.09
1.0 0.04
1.5 0.49
2.0 1.44


64−1.6x+1.0x2

(For Item 1, change Plot Style to Point and Point Marker to Circle.)
(For Item 2, set Plot Intervals to 0 < x < 2.)

0.0 0.2 0.4 0.6 0.8 1.0 1.2 1.4 1.6 1.8 2.0
0.0

0.5

1.0

1.5

x

y

ăe Fit Curve to Data command operates on labeled matrices.

Compute> Statistics> Fit Curve to Data
(Polynomial of Degree 2)

x y
0 6
1 0.1
2 −3
3 2

, Polynomial đt: y = 6.265−9.685x+2.725x2

You can also đt data with polynomials of higher degree.
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Curve Fitting

Compute> Statistics> Fit Curve to Data (Polynomial of Degree 3)
0 0.64

0.5 0.09
1.0 8.04
1.5 0.49
2.0 −7.44

, Polynomial đt: y = 8.1143×10−2 +1.4114x+9.1143x2−5.92x3

­0.4 ­0.2 0.2 0.4 0.6 0.8 1.0 1.2 1.4 1.6 1.8 2.0

­10

x

y

Compute> Statistics> Fit Curve to Data (Polynomial of Degree 4)
1 12
3 4
5 6
7 8
9 18

, Polynomial đt:
y = 7.1563x2−22.042x−0.95833x3 +4.6875×10−2x4 +27.797

0 1 2 3 4 5 6 7 8 9 10

10

20

30

x

y

Overdetermined Systems of Equations

ăeSolve command has been extended to handle overdetermined
systems, returning the least-squares solution. Here we give an example
of an overdetermined system. Note that (as before) the least-squares
solution is the actual solution, when an actual solution exists.
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Compute> Solve> Exact
1 2
3 4
5 6
7 8

[ x
y

]
=


3
7

11
15

, Solution:
[

1
1

]

It is easy tomultiply both sides of amatrix equation byAT to check
that, when you “solve” AX = B, you are actually getting the solution
of
(
AT A

)
X = AT B. Here,

A =


1 2
3 4
5 6
7 8

 , X =

[
x
y

]
, B =


3
7
11
15

 .
Compute> Evaluate

AT A =

[
84 100

100 120

]

AT B =

[
184
220

]
ăis calculation gives the following equation, which has an exact

solution.

Compute> Solve> Exact[
84 100
100 120

][
x
y

]
=

[
184
220

]
, Solution:

[
1
1

]
Exercises

1. Consider a normal randomvariable withmean 50 and standard
deviation 10, and a random sample of size 80 from which we
are to compute the values of X̄ , the sample mean. What is the
probability of getting a value of X̄ as low as 46?

2. Suppose a workingwidget deteriorates very little with age. ăat
is, a widget that has been running for some timewill have nearly
the same failure probability during the following hour as it had
during its đrst hour of operation. ăen, the failure times have an
exponential distribution P(T ≤ t) of the form 1−e−

x
µ . Given
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that the widget has a mean life of 5 years, what is the probabil-
ity that the widget will have a lifetime exceeding 7.5 years? If
the widget is guaranteed for 2 years, what percentage of such
widgets can be expected to need replacement while under war-
ranty?

3. A widget has a mean life of 5 years with a standard deviation
of 2 years. Assuming a normal distribution, what is the prob-
ability that the widget will have a lifetime exceeding 7.5 years?
If the widget is guaranteed for 2 years, what percentage of such
widgets can be expected to need replacement while under war-
ranty?

4. ăemean of a continuous distribution with probability density
function f (u) is the integral

∫ ∞
−∞ u f (u)du = µ of the product

of the variable and the probability density function. ăe vari-
ance is the integral

∫ ∞
−∞ (u−µ)2 f (u)du. Find the mean and

variance for each of the continuous distributions discussed in
this chapter.

5. ăemeanof adiscrete distributionwithprobability density func-
tion f (u) is the sum ∑∞

−∞ u f (u) = µ , and the variance is

∞

∑
−∞

(u−µ)2 f (u) = σ2.

Find the mean and variance for the discrete distributions dis-
cussed in this chapter. If the probability density function for a
distribution is f (n) =

( 1
2

)n
, what is the mean of the distribu-

tion? What is the variance?

6. A die is cast until a 4 appears. What is the probability that it
must be cast more than 5 times?

7. A telephone switchboard handles 600 calls on average during a
single rush hour. ăeboard canmake amaximumof 20 connec-
tions per minute. Use the Poisson distribution to evaluate the
probability that the board will be overtaxed during any given
minute of a rush hour.

8. Find the probability that x2 ≤ 4 for a normal distribution with
mean 1 and standard deviation 1.
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Solutions
1. To solve this problem, you need to know that the distribution

of the mean of a sample of size n from a normal distribution of
mean µ and standard deviation σ is normal with mean µ and
standard deviation σ√

n . ăus, the probability is

Pr(X̄ ≤ 46) = NormalDist
(

46;50,
1
2

√
5
)

= NormalDist(46;50,1.118) = 1.7324×10−4

2. ExponentialDist(7.5;5) = 0.77687 = P(X ≤ 7.5), so the
probability that X is greater than 7.5 is 1−0.78 = 0.22.

ExponentialDist(2;5) = 0.32968=P(X ≤ 2), so the answer
to the second question is “about 33 percent.”

3. NormalDist(7.5;5,2)= 0.89435=P(X ≤ 7.5), so theprob-
ability that X is greater than 7.5 is 1− 0.894 = 0.106, or 10.6
percent.

NormalDist(2;5,2) = 6.6807× 10−2 = P(X ≤ 2), so the
answer to the second question is “about 7 percent.”

When the parameters are symbolic, there can
be problems in carrying out computations of
the integrals that give mean and variance. You
should have no difficulty when you specify
numerical parameters.

4. For the normal distribution, Evaluate gives∫ ∞

−∞
NormalDen(u; µ,σ)udu = µ∫ ∞

−∞
NormalDen(u; µ ,σ)(u−µ)2 du = σ2

For the Student’s t distribution, with đve degrees of freedom,
Evaluate gives

∫ ∞
−∞ uTDen(u;5)du = 0 for the mean and∫ ∞

−∞ u2 TDen(u;5)du = 25
3

√
5 for the variance.

5. Here is a sample solution. For the binomial distribution, Eval-
uate followed by Simplify gives the mean:

∞

∑
x=1

x
(

n
x

)
px (1− p)n−x = np(1− p)n−1

(
− 1
−1+ p

)n−1

= pn
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Evaluate followed by Simplify and then Factor gives the vari-
ance:

n

∑
x=0

(x− pn)2
(

n
x

)
px (1− p)n−x = pn− p2n = (1− p) pn

(ăe intermediate expression for the variance is complicated
and does not appear here. Also, you need to make the simpliđ-
cations (−1)2n = 1 and (−1)2n+1 =−1. Note that the symbol(n

x

)
is a binomial fraction, rather than amatrix. To enter a bino-

mial fraction, choose Insert > Math Objects > Binomial, and
choose None for Line.)

If the probability density function for a distribution is f (n) =( 1
2

)n forn≥ 0, themean of the distribution is∑∞
n=1 n

( 1
2

)n
= 2

and the variance is ∑∞
n=1 (n−2)2 ( 1

2

)n
= 2.

6. ăe probability of getting a 4 on a single cast is 1
6 , so the proba-

bility of getting a different result is 5
6 . ăe probability of casting

the die 5 times without getting a 4 is
( 5

6

)5
= 0.40188.

7. With 600 calls on average during rush hour, the average num-
ber of calls per minute is 10. ăe probability that the number
of connections in a given minute is less than or equal to 20 is
the sum∑20

k=0 PoissonDen(k,10)=∑20
k=0

10ke−10

k! = 0.99841.
ăus, the probability that the board will be overtaxed is 1−
0.99841 = 0.00159.

8. x2 ≤ 4 when −2 ≤ x ≤ 2. So Pr
(
x2 ≤ 4

)
= Pr(x ≤ 2)−

Pr(x≤−2)=NormalDist(2;1,1)−NormalDist(−2;1,1)=
0.84.
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12
Applied Modern Algebra

[On the concept of group:] ... what a wealth, what a grandeur of thought may spring fromwhat slight beginnings.
Henry Frederick Baker (1866–1956)

A pplied modern algebra provides techniques for sending and Solving Equations

Integers Modulo m

Other Systems Modulo m

Polynomials Modulo
Polynomials

Linear Programming

receiving conđdential messages, for assuring that recordings
always sound perfect, and for packing a lot of data into a very

small space. ăis chapter includes an introduction to some of the un-
derlying computational tools that make such applications possible.

Solving Equations
Many techniques in applied modern algebra are designed to solve

equations, from integer equations to polynomial equations to matrix
equations. In this section, we describe a few of the methods that can
be applied to such problems.

Integer Solutions
ăe solver can be restricted to the domain of integers. Choose

Compute > Solve > Integer to đnd integer roots of polynomial ex-
pressions with rational coefficients, and integer solutions to equations
of the same type.
Tođnd integer roots or integer solutions to an equation

1. Place the insert point in an expression or equation.

2. Choose Compute> Solve> Integer.
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Compute> Solve> Integer
41x+421x2−165x3−4x4 +4x5−105, Solution: {−7,3,5}
2x2−11x+15 = 3x2−16x+21, Solution: {2,3}

Continued Fractions
A simple continued Ěaction is an expression of the form

a0 +
1

a1 +
1

a2+
1

a3+
1

a4+
1

a5+..

where a0 is an integer and a1,a2, . . . are positive integers. ăere can
be either an inđnite or a đnite number of terms ai. A number is ra-
tional if and only if it can be expressed as a simple đnite continued
fraction. You can đnd rational approximations to irrational numbers
by expanding the irrational as a simple continued fraction, then trun-
cating the continued fraction to obtain a rational.

Continued fractions have been utilized within computer algo-
rithms for computing rational approximations to real numbers, as well
as solving indeterminate equations. Connections have been establish-
ed between continued fractions and chaos theory.

Use theMuPADcommand contfrac to construct a continued frac-
tion of the real numerical expression x to n signiđcant digits.
Todeđne a continued fractions command

1. Choose Compute>Deđnitions>Deđne MuPAD Name.

2. In the MuPAD Name box, type numlib::contfrac(x,n).

3. In the ScientiĖc WorkPlace (Notebook) Name box, type r (x,n).

4. Check “ăat is built in to MuPAD or is automatically loaded”
and choose OK.

Use the continued fractions command to generate continued frac-
tions.

Compute> Evaluate
r (π,10) = 3+ 1

7+ 1
15+ 1

1+ 1
292+ 1

1+ 1
1+..

ăetwodots at thebottom indicate an inđnite continued fraction.
However, you can easily truncate the continued fraction.
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Tođnd a good rational approximation toPI
1. Select the tail + 1

292+ 1
1+ 1

1+..

of the continued fraction and

delete it.

2. Evaluate the remaining đnite continued fraction.

Compute> Evaluate Compute> Evaluate Numeric
3+ 1

7+ 1
15+ 1

1

= 355
113 ≈ 3.1416 Rational Approximation

The rational number 355
113 is good

approximation toπ . This is to be expected,
because continued fractions provide good
rational approximations.

Recursive Solutions
Recursion đnds solutions to a recursion or a system of recursions.

To solve a recursionor a systemof recursions
• Place the insert point in a recursive equation, or in a system of

recursive equations entered in a column matrix or display, and
choose Compute> Solve> Recursion.

Compute> Solve> Recursion
y(n+2)+3y(n+1)+2y(n) = 0, Solution: {y(n) = (−1)n C1 +(−2)n C2}

You can also solve recursive equations written in sequence nota-
tion.

Compute> Solve> Recursion
xn +2xn+1 + xn+2 = 0, Solution: {xn = (−1)n (C1 +C2n)}
xn +3xn+1 + xn+2 = 0, Solution:

{
xn =C3

(
− 1

2

√
5− 3

2

)n
+C4

(
1
2

√
5− 3

2

)n}
You can specify initial conditions by listing a system of equations

in a column matrix.

Compute> Solve> Recursion
yn+2 +3yn+1 +2yn = 0

y0 =−2
y1 = 1

, Solution: yn = (−2)n−3(−1)n

Fibonacci Numbers
The Fibonacci numbers are deöned by

F0 = 0
F1 = 1
Fn = Fn−1 +Fn−2

ăis closed-form solution makes it easy to đnd speciđc terms. For
example, if you deđne y(n) = (−2)n−3(−1)n, then y(n) can be di-
rectly evaluated.

Compute> Evaluate
y(20) = 1048573
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Integers Modulo m
ăe Euclidean algorithm for integers leads to the notion of con-

gruence of two integers modulo a given integer. Mod Function
The mod function is a function of two
variables, with the function written between
the two variables. This usage is similar to the
common usage of+, which is also a function
of two variables with the function values
expressed as a+b, rather than the usual
functional notation+(a,b).

Two integers a and b are congruent modulo m if and only if a−
b is a multiple of m, in which case we write a ≡ b (modm). ăus,
15 ≡ 33 (mod9), because 15− 33 = −18 is a multiple of 9. Given
integersa andm, themod function is givenbyamodm= b if andonly
if a≡ b (modm) and 0≤ b≤ m−1; hence, amodm is the smallest
nonnegative residue of a modulo m.

ăe underlying computer algebra system does not understand the
congruence notation a≡ b(modm), but it does understand the func-
tion notation amodm. ăis section shows how to translate problems
in algebra and number theory into language that will be handled cor-
rectly by the computational engine.

Traditionally the congruence notation a ≡ b (modm) is written
with the modm enclosed inside parentheses since the modm clariđes
the expression a≡ b. In this context, the expression b (modm) never
appearswithout the precedinga≡. On the other hand, themod func-
tion is usually written in the form amodm without parentheses.
Toevaluate themod function

• Place the insert point in the expressionamodb and chooseCom-
pute> Evaluate.

Compute> Evaluate
23mod14 = 9

In terms of the ęoor function ⌊x⌋, the mod function is given by

amodm = a−⌊a/m⌋m

Compute> Evaluate
23−

⌊ 23
14

⌋
14 = 9

Multiplication Tables Modulo m
You can make tables that display the products modulo m of pairs

of integers from the set {0,1,2, . . . ,m−1}.
Toget amultiplication tablemodulomwithm=6

1. Type the equation g(i, j) = (i−1)( j−1) and choose Com-
pute>Deđnitions>New Deđnition.
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2. Choose Compute>Matrices> Fill Matrix

3. Select Deđned by Function.

4. Type g in the Enter Function Name box.

5. Select 6 rows and 6 columns and choose OK.

6. Type mod6 at the right of the matrix.

7. Choose Compute> Evaluate.

Compute> Evaluate
0 0 0 0 0 0
0 1 2 3 4 5
0 2 4 6 8 10
0 3 6 9 12 15
0 4 8 12 16 20
0 5 10 15 20 25

mod6 =


0 0 0 0 0 0
0 1 2 3 4 5
0 2 4 0 2 4
0 3 0 3 0 3
0 4 2 0 4 2
0 5 4 3 2 1


A more efficient way to generate the same multiplication is to de-

đne g(i, j) = (i−1)( j−1)mod6 and follow steps 2–6 above.
You can also đnd themultiplication table modm as the product of

a column matrix with a row matrix.

Compute> Evaluate
0
1
2
3
4
5


[

0 1 2 3 4 5
]

mod6 =


0 0 0 0 0 0
0 1 2 3 4 5
0 2 4 0 2 4
0 3 0 3 0 3
0 4 2 0 4 2
0 5 4 3 2 1


Make a copy of this lastmatrix. Add a new row at the top (position

1) and add a new column at the leĕ (position 1); đll in the blanks and
change the new row and column to Bold font, to get the following
multiplication table modulo 6:

Tip
A shortcut that creates the multiplication table
mod6 in essentially one step is to deöne

g(i, j) = |i−2| | j−2|mod6

and use Compute>Matrices> Fill Matrix
and the functiong to create a7×7 matrix.

× 0 1 2 3 4 5
0 0 0 0 0 0 0
1 0 1 2 3 4 5
2 0 2 4 0 2 4
3 0 3 0 3 0 3
4 0 4 2 0 4 2
5 0 5 4 3 2 1
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From the table, we see that 2 ·4mod6 = 2 and 3 ·3mod6 = 3.
You can generate an addition table by deđning g(i, j) = i+ j−

2mod6.

Example If p is a prime, then the integers modulo p form a đeld,
called a Galois đeld and denoted GFp. For the prime p = 7, you can
generate the multiplication table by deđning g(i, j) = (i− 1)( j−
1)mod7 and choosing Compute > Matrices > Fill Matrix, then se-
lecting Deđned by function from the dialog box. You can generate
the addition table in a similar manner using the function f (i, j) =
i+ j−2mod7.

· 0 1 2 3 4 5 6
0 0 0 0 0 0 0 0
1 0 1 2 3 4 5 6
2 0 2 4 6 1 3 5
3 0 3 6 2 5 1 4
4 0 4 1 5 2 6 3
5 0 5 3 1 6 4 2
6 0 6 5 4 3 2 1

+ 0 1 2 3 4 5 6
0 0 1 2 3 4 5 6
1 1 2 3 4 5 6 0
2 2 3 4 5 6 0 1
3 3 4 5 6 0 1 2
4 4 5 6 0 1 2 3
5 5 6 0 1 2 3 4
6 6 0 1 2 3 4 5

Inverses Modulo m Note
The inverse a−1 modm exists if and only if
a is relatively prime tom; that is, it exists if
and only if gcd(a,m) = 1. Thus, modulo
6, only 1 and 5 have inverses. Modulo any
prime, everynonzero residue has an inverse. In
terms of the multiplication table modulom,
the integera has an inverse modulom if and
only if 1 appears in row amodm (and 1
appears in column amodm).

If abmodm = 1, then b is called an inĂerse of amodulom, and we
write a−1 modm for the least positive residue of b. ăe computation
engine also recognizes both of the forms 1/amodm and 1

a modm for
the inverse modulo m.
Tocompute the inverse of an integermodulom

1. Type the inverse in standard notation .

2. Choose Compute> Evaluate.

Compute> Evaluate
5−1 mod7 = 3
1
5 mod7 = 3
1/5mod7 = 3

Note
The inverse of 5modulo7 is indeed3 because
5 ·3mod7 = 1.

ăe three notations ab−1 modm, a/bmodm, and a
b modm are all

interpreted as a(b−1 modm)modm; that is, đrst đnd the inverse of
b modulo m, multiply the result by a, and then reduce the product
modulo m.
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Compute> Evaluate
3/23mod257 = 56

Solving congruences Modulo m
To solve a congruence of the formax≡ b (modm)

• Multiply both sides by a−1 modm to get x = b/amodm.
Additional Solutions
Note that, since91 is a solution to the
congruence17x≡ 23 (mod127),
additional solutions are given by
91+127n, where n is any integer. In fact,
x≡ 91 (mod127) is just another way of
writing x = 91+127n for some integern.

ăe congruence 17x ≡ 23 (mod127) has a solution x = 91, as
the following two evaluations illustrate.

Compute> Evaluate
23/17mod127 = 91
17 ·91mod127 = 23

Pairs of Linear Congruences
Since linear congruences of the form ax ≡ b (modm) can be re-

duced to simple congruences of the form x≡ c (modm), we consider
systems of congruences in this latter form.

To solve a pair of linear congruences
• Reduce the problem to a single congruence.

Example Consider the system of two congruences

x ≡ 45 (mod237)
x ≡ 19 (mod419)

Checking, gcd(237,419) = 1, so 237 and 419 are relatively prime.
ăe đrst congruence can be rewritten in the form x = 45+237k for
some integer k. Substituting this value into the second congruence,
we see that

45+237k = 19+419r

for some integer r. ăis last equation can be rewritten in the form
237k = 19−45mod419, which has the solution

k = (19−45)/237mod419 = 60

Hence,
x = 45+237 ·60 = 14265
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Checking,14265mod237= 45 and14265mod419= 19. ăecom-
plete set of solutions is given by

x = 14265+237 ·419s≡ 14265 (mod99303)

ăus, the original pair of congruences has been reduced to a single
congruence,

x≡ 14265 (mod99303)

In general, if m and n are relatively prime, then one solution to the
pair

x ≡ a (modm)

x ≡ b (modn)

is given by
x = a+m [(b−a)/mmodn]

A complete set of solutions is given by

x = a+m [(b−a)/mmodn]+ rmn

where r is an arbitrary integer.

Systems of Linear Congruences
You can reduce systems of any number of congruences to a single

congruence by solving systems of congruences two at a time. ăeChi-
nese remainder theorem states that, if the moduli are relatively prime
in pairs, then there is a unique solution modulo the product of all the
moduli.
To solve a systemof congruences

• Reduce the system to a single congruence.

Example Consider the system of three linear congruences

x ≡ 45 (mod237)
x ≡ 19 (mod419)
x ≡ 57 (mod523)

Checking, gcd(237 · 419,523) = 1 and gcd(237,419) = 1; hence
this system has a solution. ăe đrst two congruences can be replaced
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by the single congruence x ≡ 14265 (mod99303); hence the three
congruences can be replaced by the pair

x ≡ 14265 (mod99303)
x ≡ 57 (mod523)

As before, 14265+ 99303k = 57+ 523r for some integers k and r.
ăus, k=(57−14265)/99303mod523= 134; hence x= 14265+
99303 ·134 = 13320867. ăis system of three congruences can thus
be reduced to the single congruence

x≡ 13320867(mod 51935469)

Powers Modulo m
Tocalculate large powersmodulom

• Evaluate an modm.

Compute> Deönitions> New Deönition
a = 2789596378267275
n = 3848590389047349
m = 2838490563537459

Compute> Evaluate
an modm = 262201814109828

Fermat’s Little ăeorem states that, if p is prime and 0 < a < p,
then

ap−1 mod p = 1

ăe integer 1009 is prime, and the following is no surprise.

Compute> Evaluate
21008 mod1009 = 1

Generating Large Primes
ăere is not a built-in function to generate large primes, but the

underlying computational system does have such a function. ăe fol-
lowing is an example of how to deđne functions that correspond to
existing functions in the underlying computational system.

In this example, p(x) is deđned as the ScientiĖc WorkPlace (Note-
book)Name for theMuPADfunction, nextprime(x), which generates the
next prime greater than or equal to x.
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Todeđne p(x)
1. Choose Compute>Deđnitions>Deđne MuPAD Name.

2. Type nextprime(x) as the MuPAD Name.

3. Type p(x) as the ScientiĖc WorkPlace (Notebook) Name.

4. UnderăeMuPADName is a Procedure, checkăat is Built In
to MuPAD or is Automatically Loaded.

5. Choose OK.

Test the function using Evaluate.

Compute> Evaluate
p(5) = 5
p(500) = 503
p(8290) = 8291
p(593756145682465582) = 593756145682465583

Other Systems Modulo m
ăemod function alsoworkswithmatrices andwith polynomials.

Matrices Modulo m
You can reduce the entries of an integer matrix modulo m.

To reduce amatrixAmodulom
1. Type the expression Amodm.

2. Choose Compute> Evaluate.

Compute> Evaluate[
5 8
9 4

]
mod3 =

[
2 2
0 1

]
 3 7 5

5 4 8
2 0 5

−1

mod11 =

 9 9 3
2 5 1
3 3 10


 3 7 5

5 4 8
2 0 5

 9 9 3
2 5 1
3 3 10

mod11 =

 1 0 0
0 1 0
0 0 1


Note
Evaluating a matrix modulom reduces each of
the entries of the matrix modulom.
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Example A 2×2 block cipher is given by[
y1
y2

]
=

[
a11 a12
a21 a22

][
x1
x2

]
mod26

where the xi’s represent plaintext, the yi’s represent ciphertext, and the
matrix entries are integers. For example,[

5 8
2 7

][
4
11

]
mod26 =

[
4
7

]
means that the plaintext pair [E,L] (two adjacent letters in the secret
message “Elroy was here”) gets mapped to the ciphertext pair [E,H],
using the correspondence A←→ 0, B←→ 1, C←→ 2, . . ., Z ←→
25.

Given the ciphertext, you can recover the plaintext by computing
the inverse of the two-by-two matrix modulo 26. For example,[

5 8
2 7

]−1

mod26 =

[
25 16
4 3

]
and hence [

25 16
4 3

][
4
7

]
mod26 =

[
4
11

]
recovers the original plaintext. You can handle longer messages by re-

placing the columnvector
[

E
L

]
by thematrix

[
E R Y A H R
L O W S E E

]
and calculating one matrix product[

25 16
4 3

][
4 17 24 0 7 17
11 14 22 18 4 4

]
mod26=

[
16 25 16 2 5 21
23 6 6 2 14 2

]
.

Polynomials Modulo m
ăe mod function can also be combined with polynomials to re-

duce each of the coefficients modulo m.
To reduce integer polynomial coefficientsmodulom

• Type modm immediately to the right of the polynomial and
choose Compute> Evaluate. Note

Evaluating a polynomial modulom reduces
each of the coefficients in the polynomial
modulom.

Compute> Evaluate
x5 +9x4− x3 +7x−2mod5 = x5 +4x4 +4x3 +2x+3

Given a prime p, the set of polynomials with coefficients reduced
modulo p is a ring, denoted by GFp[x].
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Tocalculate the product of polynomialsa(x) andb(x) inGFp[x]
1. Expand the product a(x)b(x).

2. Reduce the product modulo p.

To calculate the product of 4x5 + 5x + 3 and 6x4 + x3 + 3 in
GF7[x], do the following two operations.

Compute> Expand(
4x5 +5x+3

)(
6x4 + x3 +3

)
= 24x9 +4x8 +42x5 +23x4 +3x3 +15x+9

Compute> Evaluate
24x9 +4x8 +42x5 +23x4 +3x3 +15x+9mod7 = 3x9 +4x8 +2x4 +3x3 + x+2

ăe sum of 4x5 + 5x+ 3 and 6x4 + x3 + 3 in GF7[x] is slightly
simpler.

Compute> Evaluate(
4x5 +5x+3

)
+
(
6x4 + x3 +3

)
mod7 = 4x5 +6x4 + x3 +5x+6

To factor a polynomiala(x) inGFp [x]
1. Type the expression a(x)mod p. Note

The polynomial x16 + x factors as the
product of all of the irreducible polynomials of
degrees 1,2, and 4. In particular,
x2 + x+1 is the only irreducible
polynomial of degree2 inGF2 [x].

2. Choose Compute> Factor.

To factor x16 + x in GF2 [x], apply the command Factor to the ex-
pression x16 + xmod2.

Compute> Factor
x16 + xmod2 = x(x+1)

(
x2 + x+1

)(
x4 + x+1

)(
x4 + x3 +1

)(
x4 + x3 + x2 + x+1

)
Polynomials Modulo Polynomials

ăe Euclidean algorithm for polynomials leads to the notion of
congruence of polynomials modulo polynomials.

Two polynomials f (x) and g(x) are congruent modulo a polyno-
mial q(x) if and only if f (x)− g(x) is a multiple of q(x), in which
case we write

f (x)≡ g(x) (modq(x))

We write
g(x)modq(x) = h(x)
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if h(x) is a polynomial of minimal degree that is congruent to g(x)
modulo q(x).

To reduce a polynomial p(x)modulo a polynomialq(x)
• Place the insert point in the expression p(x)mod(q(x)) and

choose Compute> Evaluate.

Compute> Evaluate
x4 + x+1mod

(
x2 +4x+5

)
=−23x−54

To verify this calculation, note the following computation:

Compute> Polynomials> Divide
x4 + x+1

x2 +4x+5
= x2−4x+11+

−23x−54
x2 +4x+5

ăis result implies that indeed x4 + x+ 1mod
(
x2 +4x+5

)
=

−23x−54.

Greatest Common Divisor of Polynomials
ăe greatest common divisor of two polynomials p(x) and q(x) is a

polynomial d(x) of highest degree that divides both p(x) and q(x).
Tocomputethegreatestcommondivisoroftwopolynomials p(x)andq(x)

1. Type gcd in mathematics. (It will automatically turn gray.)

2. Place the insert point in the expression gcd(p(x) ,q(x)) and
choose Compute> Evaluate.

Compute> Deönitions> New Deönition
p(x) = 18x7−9x5 +36x4 +4x3−16x2 +19x+12
q(x) = 15x5−9x4 +11x3 +17x2−10x+8

Compute> Evaluate
gcd(p(x),q(x)) = 3x3 + x+4

Use the following procedure to verify that 3x3 + x+4 is indeed a
common divisor.

Compute> Polynomials> Divide
p(x)

3x3 + x+4
= 6x4−5x2 +4x+3

q(x)
3x3 + x+4

= 5x2−3x+2
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ăese results demonstrate that

p(x) =
(
6x4−5x2 +4x+3

)(
3x3 + x+4

)
and

q(x) =
(
5x2−3x+2

)(
3x3 + x+4

)
Multiplicity of Roots of Polynomials

A root a of a polynomial f (x) has multiplicity k if f (x) = (x−
a)kg(x), where g(a) ̸= 0. If k > 1, then

f ′(x)= k(x−a)k−1g(x)+(x−a)kg′(x)= (x−a)k−1(kg(x)+(x−a)g′(x))

and hence

gcd( f (x), f ′(x)) = (x−a)k−1h(x) ̸= 1

ăisobservationprovides a test formultiple roots: Ifgcd( f (x), f ′(x))
is a constant, then f (x) has no multiple roots; otherwise, f (x) has
at least one multiple root—in fact, each root of gcd( f (x), f ′(x)) is a
multiple root of f (x).

To test a polynomial f (x) formultiple roots
1. Deđne the polynomial f (x).

2. Type the expressiongcd( f (x) , f ′ (x)) and,with the insert point
in this expression, choose Compute> Evaluate.

3. Observe whether or not the result is a constant.

ăe graphs of

f (x)= 5537x5−34804x4+60229x3−29267x2+19888x+54692

and

g(x)= 5537x5−34797x4+60207x3−29260x2+19873x+54670

appear indistinguishable. Both appear to have a root near 3.1.
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Compute> Plot 2D> Rectangular
f (x) g(x)

1 2 3

20000

40000

60000

80000

x

y

1 2 3

20000

40000

60000

80000

x

y

However, the test for multiple roots gives a different result for the
two functions.

Compute> Evaluate
gcd( f (x), f ′(x)) = 791

(
x− 22

7

)
gcd(g(x),g′(x)) = 7

ăus, x = 22
7 is a root of f (x) of multiplicity at least two, whereas

g(x) has no multiple roots. Solving f (x) = 0 and g(x) = 0, the real
solutions are computed below. We show both symbolic exact and nu-
meric solutions.

Compute> Factor
f (x) = 113

(
x3 + x+1

)
(7x−22)2

g(x) = 7(7x−22)(113x−355)
(
x3 + x+1

)
To đnd an approximation to the roots of these two polynomials

with multiplicities, choose Compute> Polynomials> Roots.

Compute> Polynomials> Roots

f (x), roots:


−0.68233

3.1429
3.1429

0.34116−1.1615i
0.34116+1.1615i

 g(x), roots:


−0.68233

3.1416
3.1429

0.34116+1.1615i
0.34116−1.1615i



ăe polynomial g has two distinct roots that are extremely close,
whereas f has a root of multiplicity two at 22

7 ≈ 3.1429.

The Galois FieldGFpn

Assume that q(x) is an irreducible polynomial of degree n over
GFp; that is, assume that q(x) is of degree n and, whenever q(x) =
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a(x)b(x) for some a(x) and b(x) in GFp[x], either deg(a(x)) = 0 or
deg(b(x)) = 0.

Given two polynomials f (x) and g(x) in GFp[x], deđne the prod-
uct to be the polynomial ( f (x)g(x)modq(x))mod p and the sum to
be the polynomial ( f (x)+g(x))mod p.

With these deđnitions, the set of polynomials in GFp[x] of degree
less than n forms a đeld called theGalois Ėeld GFpn .

ăe set of polynomials in GF2[x] of degree less than 2 forms the
đeld GF22 = GF4.

ăe multiplication and addition tables for GF2 are given by

× 0 1
0 0 0
1 0 1

+ 0 1
0 0 1
1 1 0

ăe polynomial q(x) = x2+x+1 is an irreducible polynomial of de-
gree 2 over GF2. It is, in fact, the only one. ăe elements of GF4 are 0,
1, x, and 1+ x.

To đnd the product x ·x in GF4, reduce the product modulo x2+
x+1, then reduce the result modulo 2.

Compute> Evaluate(
x2 modq(x)

)
mod2 = x+1

ăus, x2 = x+1 in GF4.

You can generate the entire multiplication table efficiently using
matrix and modular arithmetic.

Compute> Evaluate
0
1
x

x+1

[ 0 1 x x+1
]
=


0 0 0 0
0 1 x x+1
0 x x2 x(x+1)
0 x+1 x(x+1) (x+1)2


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Compute> Evaluate
0 0 0 0
0 1 x x+1
0 x x2 x(x+1)
0 x+1 x(x+1) (x+1)2

modx2 + x+1 =


0 0 0 0
0 1 x x+1
0 x −x−1 −1
0 x+1 −1 x




0 0 0 0
0 1 x x+1
0 x −x−1 −1
0 x+1 −1 x

mod2 =


0 0 0 0
0 1 x x+1
0 x x+1 1
0 x+1 1 x


Sums require only reduction of polynomial sums modulo 2. ăe

multiplication and addition tables are given by

× 0 1 x x+1
0 0 0 0 0
1 0 1 x x+1
x 0 x x+1 1

x+1 0 x+1 1 x

+ 0 1 x x+1
0 0 1 x x+1
1 1 0 x+1 x
x x x+1 0 1

x+1 x+1 x 1 0

Given a polynomial f (x) = ax+b with a and b in GF2, consider
the binary representation (ab)2. ăe binary representations for the
multiplication and addition tables for GF4 are given by

× 00 01 10 11
00 00 00 00 00
01 00 01 10 11
10 00 10 11 01
11 00 11 01 10

+ 00 11 10 11
00 00 01 10 11
01 01 00 11 10
10 10 11 00 01
11 11 10 01 00

Converting frombinary todecimal, wehave0=(00)2,1=(01)2,
2 = (10)2, and 3 = (11)2. Using this shorthand notation for poly-
nomials, the multiplication and addition tables become

× 0 1 2 3
0 0 0 0 0
1 0 1 2 3
2 0 2 3 1
3 0 3 1 2

+ 0 1 2 3
0 0 1 2 3
1 1 0 3 2
2 2 3 0 1
3 3 2 1 0

Calculations in larger đniteGalois đelds can be donewithout gen-
erating addition and multiplication tables. In the following few para-
graphs, assume that β is a root of the irreducible polynomial q(x) of
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degree n used to generate GFpn . Since every element of GFpn satis-
đes the polynomial xpn − x modulo p, it follows that every nonzero
element u of GFpn satisđes the polynomial xpn−1−1 modulo p, and
hence the inverse of u is given by upn−2.

Let q(x) = x4 + x+ 1 and let β be a root of q(x), so that β 4 +

β +1 = 0. To calculate the inverse of β 3 +β 2 +1 in GF24 , carry out
the following steps:

Compute> Evaluate((
β 3 +β 2 +1

)14
modβ 4 +β +1

)
mod2 = β 2

Tocalculate the product of two elementsu and v inGFpn

1. Expand the product uv.

2. Evaluate the result modulo q(β ).

3. Evaluate the result modulo p.

Let q(x) = x4 + x+ 1 and let β be a root of q(x), so that β 4 +

β +1 = 0. To calculate the product of u = β 3 +β 2 +1 and v = β 2

in GF24 , carry out the following steps.

Compute> Expand(
β 3 +β 2 +1

)(
β 3 +β

)
= β 6 +β 5 +β 4 +2β 3 +β

Compute> Evaluate
β 6 +β 5 +β 4 +2β 3 +β mod β 4 +β +1 = β 3−2β 2−β −1
β 3−2β 2−β −1mod2 = β 3 +β +1

ăus
(

β 3 +β 2 +1
)(

β 3 +β
)
= β 3 +β +1 in GF24 .

ăese steps can also be combined.

Compute> Evaluate((
β 3 +β 2 +1

)(
β 3 +β

)
mod β 4 +β +1

)
mod2 = β 3 +β +1

Tocalculate the inverse of an elementu inGFpn

• Evaluate the expression
(
upn−2 modq(β )

)
mod p.

Compute> Evaluate((
β 3 +β 2 +1

)14
mod β 4 +β +1

)
mod2 = β 2((

β 3 +β 2 +1
)

β 2 mod β 4 +β +1
)

mod2 = 1
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ăis veriđes that β 2 is the inverse of β 3 +β 2 +1 in GF24 .

Example ăis setting provides the basis for the Bose-Chaudhuri-
Hocquenghem (BCH) Codes. Given the message word
(ar,ar−1, ...,a2,a1,a0)2 as a number in base 2, associate the polyno-
mial

a(x) = arxr +ar−1xr−1 + · · ·+a2x2 +a1x+a0

in GF2[x]. A codeword is then generated by the formula
a(x)q(x)mod2, where q(x) is a specially selected polynomial. Con-
sider the Galois đeld GF24 = GF16. Let α be a primitive element in
GF16, so that the nonzero elements ofGF16 are all powers ofα . In par-
ticular, this property holds if we take α to be a root of the irreducible
polynomial x4 + x+ 1. Let mi(x) be the minimal polynomial of α i.
If

q(x) = lcm[m1(x),m2(x), ...,m2t(x)]

then the corresponding BCH code corrects at least t errors.
Since α4 +α +1 = 0, it follows that

02 =
(
α4 +α +1

)2
=
(
α4)2

+α2 +1 =
(
α2)4

+α2 +1

Hence, m1(x) = m2(x). By the same reasoning, m2(x) = m4(x) =
m8(x). Likewise,

m3(x) = (x−α3)(x−α6)(x−α12)(x−α9) = x4+x3+x2+x+1

Hence, a double error-correcting code is generated by

q(x)= lcm[m1(x),m2(x),m3(x),m4(x)]mod2= x8+x7+x6+x4+1

Linear Programming
A linear programming problem consists of minimizing (or maxi-

mizing) a linear function subject to certain conditions or constraints
expressible as linear inequalities. ăe word “programming” is used
here in the sense of “planning.” ăe importance of linear program-
ming derives in part from its many applications and in part from the
existence of good general-purpose techniques for đnding optimal so-
lutions.
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The Simplex Algorithm
ăe basic purpose of the simplex algorithm is to solve linear pro-

grammingproblems. In the following example, the function f (x,y)=
x+ y is to be maximized subject to the two inequalities shown. ăe
function f (x,y) is the objective function, and the set of linear con-
straints is called the linear system.

Toenter a linear programmingproblemwith two constraints
1. Create a 3×1 matrix.

2. Type the function to be maximized in the đrst row.

3. Type the linear constraints in the subsequent rows.

4. Leave the insert point in the matrix.

5. Choose Compute> Simplex>Maximize.

Compute> Simplex>Maximize x+ y
4x+3y≤ 6
3x+4y≤ 4

, Maximum is at:
{

x = 12
7 ,y =−

2
7

}
Of course, these are the same coordinates that minimize−x− y.

In the following linear programming problem, place the insert point
in the matrix and choose Compute> Simplex>Minimize.

Compute> Simplex>Minimize −x− y
4x+3y≤ 6
3x+4y≤ 4

, Minimum is at:
{

y =− 2
7 ,x =

12
7

}
Feasible Systems

Two things may prevent the existence of a solution. ăere may be
no values of x and y satisfying the constraints. Even if there are such
values, there may be none maximizing the objective function. If there
are values satisfying the constraints, the system is called feasible.

ăe following example illustrates a set of inequality constraints
with no function to bemaximized orminimized. You can askwhether
the constraints are feasible—that is, whether they deđne a nonempty
set. Place the insert point in the matrix and choose Compute> Sim-
plex> Feasible.
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Compute> Simplex> Feasible?
4x+3y≤ 6
3x+4y≤ 4

x≥ 0
y≥ 0

, Is feasible? true
[

4x+3y≤ 6
4x+3y≥ 7

]
, Is feasible? false

Saying that the system
[

4x+3y≤ 6
4x+3y≥ 7

]
is not feasible implies,

in particular, that there are no values minimizing the objective func-

tion in the problem

 x+ y
4x+3y≤ 6
4x+3y≥ 7

. Geometrically, the two re-

gions that satisfy the inequalities are disjoint.

Standard Form
A system of linear inequalities is in standard formwhen all the in-

equalities are of the form≤. To convert a system of linear inequalities
to a system in standard form, choose Compute > Simplex > Stan-
dardize.

Compute> Simplex> Standardize
4x+3y≤ 6
3x+4y≤ 4

x≥ 0
y≥ 0

, System in standard form is:


−x≤ 0
−y≤ 0

3x+4y≤ 4
4x+3y≤ 6


With a linear function added, you can maximize the resulting lin-

ear programming problem.

Compute> Simplex>Maximize
x+3y

3x− y≤ 4
4x+3y≤ 6
−y≤ 0
−x≤ 0

, Maximum is at: {x = 0,y = 2}

The Dual of a Linear Program
ăeother item on the Simplexmenu isDual. It computes the dual

of a linear program.
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Compute> Simplex> Dual
x+ y

4x+3y≤ 6
3x+4y≤ 4

x≥ 0
−y≤ 0

, Dual system is:

 4u3 +6u4
u1−3u3−4u4 ≤−1
u2−4u3−3u4 ≤−1


Applying the simplex algorithmto these two linear programs yields

the following results.

Compute> Simplex>Maximize
x+ y

4x+3y≤ 6
3x+4y≤ 4

x≥ 0
−y≤ 0

, Maximum is at:
{

y = 0,x = 4
3

}

Compute> Simplex>Minimize

6u4 +4u3
1≤ 4u4 +3u3−u2
1≤ 3u4 +4u3−u1
u1 ≥ 0
u2 ≥ 0
u3 ≥ 0
u4 ≥ 0


, Minimum is at:

{
u1 = 0,u2 = 0,u4 = 0,u3 =

1
3

}

Exercises
1. Give a multiplication table for the integers modulo 11. From

the table, đnd the inverses of 2 and 3. Verify your answers by
evaluating 2−1 mod11 and 3−1 mod11.

2. Solve the congruence 5x+4≡ 8 (mod13). Verify your answer
by evaluating 5x+4mod13.

3. A jar is full of jelly beans. If the jelly beans are evenly divided
among đve children, there are three jelly beans leĕ over; and if
the jelly beans are evenly divided among seven adults, there are
đve jelly beans leĕ over. How many jelly beans are in the jar?
Are other solutions possible? If so, what are they?

4. What is the smallest 100-digit prime?
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5. If p is the smallest 100-digit prime, what is 2p−1 mod p? What
is 2(p−1)/2 mod p? What about 2(p−1)/4 mod p?

6. ăe matrix M =

 1 1 1
1 2 4
1 4 9

 is used as a block cipher mod-

ulo 26 to scramble letters in a message, three letters at a time.
Assume A←→ 0, B←→ 1, C←→ 2, and so forth. Descram-
ble the ciphertext FKBHRTMTU.

7. Find an irreducible polynomial of degree 3. Use this polyno-
mial to describe how to calculate sums and products in the đeld
GF27.

8. A barge company transports bales of hay and barrels of beer up
the Mississippi River. ăe company charges $2.30 for each bale
of hay and $3.00 for each barrel of beer. ăe bales of hay average
75 pounds and take up 5 cubic feet of space; the barrels of beer
weigh 100 pounds and take up 4 cubic feet of space. A barge
is limited to a payload of 150,000 pounds and 8,000 cubic feet.
Howmuch beer and howmuch hay should a barge transport to
maximize the shipping charges?

9. ăeRiemannHypothesis states that all of thenontrivial zeros of
the Riemann zeta function lie on the line Re(s) = 1

2 . Visualize
the Riemann zeta function along Re(s) = 1

2 by drawing a curve
in three-dimensional space.

10. Let Z30 denote the integers modulo 30. Write Z30 as a (dis-
joint) union of groups.

Solutions
1. Deđne the function f (i, j) = i j. ChooseCompute>Matrices

> Fill Matrix with 10 rows and 10 columns, and use the func-
tion f to generate a matrix. ăen, reduce the matrix mod11 to
get the following:
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1 2 3 4 5 6 7 8 9 10
2 4 6 8 10 1 3 5 7 9
3 6 9 1 4 7 10 2 5 8
4 8 1 5 9 2 6 10 3 7
5 10 4 9 3 8 2 7 1 6
6 1 7 2 8 3 9 4 10 5
7 3 10 6 2 9 5 1 8 4
8 5 2 10 7 4 1 9 6 3
9 7 5 3 1 10 8 6 4 2
10 9 8 7 6 5 4 3 2 1

Select the matrix and choose Edit > Insert Column(s). Add
one column at position 1. You have now added a column on the
leĕ. Repeat this procedure using Insert Row(s), adding a row at
position 1. Fill in the empty boxes with × and the integers 1
through 10 to generate the đnal multiplication table,

× 1 2 3 4 5 6 7 8 9 10
1 1 2 3 4 5 6 7 8 9 10
2 2 4 6 8 10 1 3 5 7 9
3 3 6 9 1 4 7 10 2 5 8
4 4 8 1 5 9 2 6 10 3 7
5 5 10 4 9 3 8 2 7 1 6
6 6 1 7 2 8 3 9 4 10 5
7 7 3 10 6 2 9 5 1 8 4
8 8 5 2 10 7 4 1 9 6 3
9 9 7 5 3 1 10 8 6 4 2
10 10 9 8 7 6 5 4 3 2 1

From the table, 2 ·6 = 1 implies 2−1 = 6, and 3 ·4 = 1 implies
3−1 = 4. As a check, 2−1 mod11 = 6 and 3−1 mod11 = 4.

2. ăe solution is given by x= (8−4)/5mod13= 6. As a check,
6 ·5+4mod13 = 8.

3. ăe problem requires the solution to the system

x ≡ 3 (mod5)
x ≡ 5 (mod7)

of congruences. ăe system is equivalent to the equation x =
3+5a = 5+7b, or 3+5a≡ 5 (mod7), which has a solution
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a = (5−3)/5mod7 = 6, which means x = 3+5a = 33 jelly
beans. Other possible solutions are x = 33+ 35n, where n is
any positive integer.

4. Deđne the function nextp as indicated in this chapter. ăen
nextp(1099) produces a number with lots of zeroes that ends in
289. ăe prime p can be written as p = 1099 +289.

5. Note that 2p−1 mod p = 1 and 2(p−1)/2 mod p = 1, whereas
2(p−1)/4 mod p produces another number with lots of zeroes
that ends in 288. More precisely, 2(p−1)/4 ≡ −1mod p. ăis
congruence illustrates the fact that, if p is a prime, then x2 ≡
1 (mod p) has only two solutions, x ≡ 1 (mod p) and x ≡
−1 (mod p).

6. We have

 1 1 1
1 2 4
1 4 9

−1

mod26 =

 24 5 24
5 18 3
24 3 25

. ăe

ciphertext F K B H R T M T U has a numerical equivalent of
[5,10,1,7,17,19,12,19,20]. Picking three at a time, we get 24 5 24

5 18 3
24 3 25

 5 7 12
10 17 19
1 19 20

mod26=

 12 7 5
0 8 20

19 18 13


ăevector [12,0,19,7,8,18,5,20,13] corresponds to theplain-
text M A T H I S F U N, or MATH IS FUN.

7. Deđning g(x) = x3 + x+ 1, we see that g(1)mod3 = 0, and
hence g(x) is not irreducible (since it has a root in GF3). How-
ever, if f (x)= x3+2x+1, then f (0)mod3= 1, f (1)mod3=
1, and f (2)mod3 = 1, and hence f (x) is irreducible. (If f (x)
were reducible, it would have a linear factor, and hence a root.)
An element ofGF27 can be thought of as a polynomial of degree
less than 3 with coefficients in GF3. Given the đeld elements
2x2 + x+2 and 2x+1, the product is((

2x2 + x+2
)
(2x+1)mod x3 +2x+1

)
mod3 = x2 +1,

and the sum is given by(
2x2 + x+2

)
+(2x+1)mod3 = 2x2.
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8. ăe objective function is 2.3h+ 3b. ăe constraints are 4h+
5b ≤ 8000, 75h+ 100b ≤ 150000, b ≥ 0, and h ≥ 0. With
the insert point in the display

2.3h+3b
5h+4b≤ 8000

75h+100b≤ 150000
b≥ 0
h≥ 0

choose Compute> Simplex>Maximize to get: Maximum is
4550 at h = 1000,b = 750.

9. Type
(
t,Re

(
ζ
( 1

2 + ti
))

, Im
(
ζ
( 1

2 + ti
)))

and choose Com-
pute > Plot 3D > Tube. Type (t,0,0) and drag it to the plot
frame. From the Plot Properties dialog, choose the Items Plot-
ted page. For Items 1 and 2, set Interval: 0 to 35, Points Sam-
pled: 99, Points per Cross Section: 7, Radius: 0.2 and set the
Surface Style to Hidden Line.

10
0

x
20

30

y
320­1

­2
1

2

z 0
­1

1

View the curve from several different angles. Note that the in-
tersection points display zeros of the Riemann zeta function.

10. Considerđrst thepositive integers< 30 that are relatively prime
to 30. Let G1 = {1,7,11,13,17,19,23,29} be the group of
units modulo 30.

In a similar fashion, for each divisor n of 30 deđne Gn to be the
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positive integers a < 30 such that gcd(a,30) = n. ăus

G1 = {1,7,11,13,17,19,23,29}
G2 = {2,4,8,14,16,22,26,28}
G3 = {3,9,21,27}
G5 = {5,25}
G6 = {6,12,18,24}

G10 = {10,20}
G15 = {15}
G30 = {0}

For each of these subsets, create a multiplication table modulo
30 such as the following one for G2, for which 16 acts as an
identity.

2
4
8

14
16
22
26
28


[

2 4 8 14 16 22 26 28
]

mod30 =



4 8 16 28 2 14 22 26
8 16 2 26 4 28 14 22

16 2 4 22 8 26 28 14
28 26 22 16 14 8 4 2
2 4 8 14 16 22 26 28

14 28 26 8 22 4 2 16
22 14 28 4 26 2 16 8
26 22 14 2 28 16 8 4


Note that each of these sets is closed under multiplication, and
that each element appears once in each row and once in each
column. Since multiplication is certainly commutative and as-
sociative, it follows that each subset is in fact a group.
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A
Menus and Shortcuts for

Doing Mathematics

If I feel unhappy, I do mathematics to become happy. If I am happy, I do mathematics to keep happy. Alfréd Rényi (1921–1970)

T his appendix summarizes information about the Compute Compute Menu

Toolbar and Keyboard Shortcuts
for Compute Menu Commands

menu, corresponding commands on the Math Toolbar, and
keyboard shortcuts for these commands. Details and exam-

ples are given in the main text.

Compute Menu
• Calculus > Approximate Integral Apply approximation

methods Leĕ, Right, Leĕ and Right, Middle, Lower, Upper,
Lower andUpper, LowerAbsolute,UpperAbsolute, Lower and
Upper Absolute, Trapezoid, or Simpson for approximating def-
inite integrals by a mathematical expression.

• Calculus>Change Variables Simpliđes an indeđnite in-
tegral: specify a substitution and get the result of the substitu-
tion.

• Calculus > Find Extrema Given a mathematical expres- New in Version 6
Compute> Passthru Code to MuPAD
Compute> Rewrite>Mixed

sion, returns candidates for extrema.

• Calculus > Implicit Differentiation Given an equation
and a differentiation variable, performs differentiation.
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• Calculus> Integrate by Parts Simpliđes an indeđnite in-
tegral: specify the part to be differentiated and invoke the inte-
gration by parts method.

• Calculus > Iterate Find numerical approximations to a
root of an equation f (x) = x, starting with your estimate of a
root.

• Calculus > Partial Fractions Writes a factorable rational
function as a sum of simpler fractions. (Same as Polynomials>
Partial Fractions)

• Calculus > Plot Approximate Integral Plot pictures of
Riemann sumsobtained frommidpoints, leĕ endpoints, or right
endpoints of subintervals.

• Check Equality Verify equalities and inequalities. ăere
are three possible responses: true, false, and undecidable.

• Combine>Arctan Combines or simpliđes expressions in-
volving inverse tangent functions.

• Combine> Exponentials Combines or simpliđes expres-
sions involving exponential functions with base e.

• Combine>Hyperbolic Trigonometric Functions Prod-
ucts and powers of hyperbolic trigonometric functions are com-
bined into a sum of hyperbolic functions whose arguments are
integral linear combinations of the original arguments.

• Combine > Logs Combines or simpliđes expressions in-
volving logarithmic functions with base e.

• Combine > Powers Combines or simpliđes expressions
involving exponential functions with arbitrary base.

• Combine>TrigonometricFunctions Products andpow-
ers of trigonometric functions are combined into a sumof trigo-
nometric functions whose arguments are integral linear combi-
nations of the original arguments.

• Deđnitions> Clear Deđnitions Removes all active user-
deđned deđnitions from a document.
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• Deđnitions>Deđne MuPAD Name Allows users to ac-
cess functions available to the computation engine that do not
appear as menu items, either functions from one of the libraries
of the computation engine or user-deđned functions.

• Deđnitions>NewDeđnition Allows users to deđne new
functions and variables for computation.

• Deđnitions > Show Deđnitions Provides a list of all ac-
tive user-deđned deđnitions in a document.

• Deđnitions > Undeđne Removes a selected user-deđned
deđnition from a document.

• Evaluate Evaluate yields symbolic or numerical results, de-
pending on the input.

• Evaluate Numeric Evaluates and gives numerical results.

• Expand Expandpolynomial and rational products, trigono-
metric and exponential expressions.

• Factor Factorpolynomials and rational, trigonometric and
exponential expressions.

• Interpret Shows the interpretation of possibly ambiguous
expressions as made by the computing engine.

• Matrices>Adjugate Produces the adjugate or classical ad-
joint of a square matrix A, namely, the transpose of the matrix
of cofactors of A.

• Matrices>CharacteristicPolynomial Produces the char-
acteristic polynomial of a square matrix A, namely, the determi-
nant of the characteristic matrix xI−A.

• Matrices>CholeskyDecomposition Factors a real square,
symmetric, andpositive deđnitematrixA as a productA=GGT ,
with G a real positive-deđnite lower triangular square matrix.

• Matrices>Column Basis Produces a basis for the vector
space spanned by the columns of a matrix.

• Matrices > Concatenate Merges two matrices with the
same number of rows horizontally into one matrix.
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• Matrices > Condition Number Produces the condition
number of an invertible matrix A, the product of the 2-norm of
A and the 2-norm of A−1. ăis numbermeasures the sensitivity
of some solutions of linear equations Ax = b to perturbations
in the entries of A and b.

• Matrices>DeđnitenessTests Determineswhether aHer-
mitianmatrix (a square matrix equal to its conjugate transpose)
is positive deđnite, positive semideđnite, negative deđnite, or
negative semideđnite.

• Matrices > Determinant Produces the determinant of a
square matrix.

• Matrices> Eigenvalues Produces a list of eigenvalues of a
square matrix, that is, the roots of its characteristic polynomial.
ăe results are symbolic or numerical approximations depend-
ing on the matrix entries.

• Matrices > Eigenvectors Produces a list of eigenvectors
paired with eigenvalues of a square matrix, that is, the roots of
its characteristic polynomial. Given amatrixA, these are a scalar
c and a vector v with Av = cv. ăe results are symbolic or nu-
meric depending on the matrix entries.

• Matrices> Fill Matrix Create a matrix: choose from ma-
trix types Band, Deđned by Function, Identity, Jordan Block,
Random (integers between -1000 and 1000), and Zero (đlled
with zeroes).

• Matrices>Fraction-FreeGaussianElimination Elemen-
tary row operations are used to reduce a matrix of integers to
row echelon form with integer entries.

• Matrices > Gaussian Elimination Elementary row oper-
ations are used to reduce a matrix to row echelon form. ăe re-
sults are symbolic or numeric depending on the matrix entries.

• Matrices>Hermite Normal Form Produces, from a ma-
trix A with integer entries, a row echelonmatrix H = QA where
Q is invertible in the ring of matrices over the integers.

• Matrices>Hermitian Transpose Produces, from a com-
plex matrix, the Hermitian transpose.
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• Matrices > Inverse Produces the inverse of a square, in-
vertible matrix.

• Matrices> JordanNormalForm Produces a factorization
of a square matrix as PJP−1, where J is in Jordan normal form.

• Matrices>MapFunction Applies a function (either built-
in or user deđned) to the entries of a matrix or vector.

• Matrices > Minimal Polynomial Computes the monic
minimal polynomial of a square matrix.

• Matrices > Norm Computes the 2-norm, or Euclidean
norm, of a matrix A with real or complex entries. ăis is the
number deđned by ∥A∥ = maxx ̸=0 ∥Ax∥/∥x∥. In the special
case A is a vector, this is the Euclidean length of the vector.

• Matrices > Nullspace Basis Finds a basis for the vector
space consisting of all vectors X satisfying AX = 0.

• Matrices > Orthogonality Test Tests a real matrix to de-
termine if the inner product of any twodifferent columns is zero
and the inner product of every columnwith itself is one, and re-
ports true or false.

• Matrices > Permanent Computes the sum of certain
products of the entries of a square matrix (ai j), namely,
permanent(ai j) = ∑σ a1σ(1)a2σ(2) · · ·anσ(n) where σ ranges
over all the permutations of {1,2, . . . ,n}.

• Matrices > PLU Decomposition Factors a real matrix A
into a product A = PLU , with L and U real lower and upper
triangularmatrices with 1’s on themain diagonal of L, andwith
P a permutationmatrix. ăematricesP andL are invertible and
the matrixU is a row echelon form of A.

• Matrices>QR Decomposition Factors a real m×n ma-
trix A with m ≥ n as a product QR, where Q is an orthogonal
m×mmatrix andR is upper-right triangularwith the same rank
as A. If the original matrix A is square, then so is R. If A has lin-
early independent columns, then R is invertible.

• Matrices> Random Matrix Creates a matrix of integers.
Set dimensions and the range of random entries. Select amatrix
type—unrestricted, symmetric, antisymmetric, or triangular.
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• Matrices > Rank Reports the dimension of the vector
space generated by the columns of a matrix.

• Matrices > Rational Canonical Form Produces a block
diagonal matrix with each block the companion matrix of its
own minimum and characteristic polynomials.

• Matrices>ReducedRowEchelonForm Produces a row-
equivalent matrix in row echelon form in which the number
of leading zeros increases as the row number increases; the đrst
nonzero entry in each nonzero row is equal to 1; and each col-
umn that contains the leading nonzero entry for any row con-
tains only zeros above and below that entry.

• Matrices> Reshape Creates a matrix of speciđed dimen-
sions from a list. Also changes dimensions of a matrix.

• Matrices>Row Basis Produces a set of vectors that form
a basis for the vector space spanned by the rows of a matrix.

• Matrices>SingularValueDecomposition Factors anm×
n real matrix A can into a product A =UDV , withU andV real
orthogonal m×m and n×n matrices, respectively, and D a di-
agonalmatrix with positive numbers in the đrst rank(A) entries
on the main diagonal, and zeros everywhere else.

• Matrices > Singular Values Computes the nonnegative
scalars a for which there exist two nonzero vectors u and v so
that Av = au and AHu = av, where AH is the complex conju-
gate transpose of a complex matrix. ăese singular values ap-
pear as entries on the main diagonal of the diagonal matrix in
the singular value decomposition of A.

• Matrices> Smith Normal Form Given a matrix A over a
principal ideal domain (in particular, a matrix of integers), pro-
duces an equivalent diagonal matrix of the form diag(1, . . . ,1,
p1, p2, . . . , pk,0, . . . ,0) where for each i, pi is a factor of pi+1.

• Matrices > Spectral Radius Computes the largest of the
absolute values of the eigenvalues of a square matrix.

• Matrices>Stack Merges twomatriceswith the samenum-
ber of columns vertically into one matrix.
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• Matrices > Trace Computes the sum of the diagonal ele-
ments of a square matrix.

• Matrices>Transpose Interchanges the rows and columns
of a matrix.

• Passthru Code to Engine Allows users to enter and send
MuPAD code directly to the compute engine.

• Plot 2D > Approximate Integral Plots an expression to-
getherwithpictures ofRiemann sumsobtained frommidpoints,
leĕ endpoints, or right endpoints of subintervals.

• Plot 2D > Conformal Given a complex function F(z),
maps a two-dimensional grid from the plane into a second
(curved) grid determined by the images of the original grid lines
under F . Yields a set of curves in the plane with the property
that they also intersect at right angles at the points where F is
analytic.

• Plot 2D > Gradient Plots a rectangular array of arrows
that describe the gradient of an expression f (x,y).

• Plot 2D> Implicit Plots the graph of an equation in rect-
angular coordinates.

• Plot 2D> Inequality Plots points in the plane that satisfy
a given inequality of the form f (x)< g(x) or f (x)> g(x).

• Plot 2D>ODE Plots a function f given as the numerical
solution to an ordinary differential equation.

• Plot2D>Parametric Plots a parametric curve (x(t) ,y(t))
in rectangular coordinates.

• Plot2D>Polar Plots the polar graphof f (θ)or the polar
graph of a parametric curve (r (t) ,θ (t)).

• Plot 2D > Rectangular Plots the graph of an expression
f (x) in rectangular coordinates. Also plots the graph of a para-
metric curve (x(t) ,y(t)) in rectangular coordinates.

• Plot 2D > Vector Field Given an equation of the form
F (x,y) = [u(x,y) ,v(x,y)], plots a vector đeld in rectangular
coordinates.
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• Plot 2D Animated > Conformal Animates a conformal
plot as a parameter t increases over an interval a≤ t ≤ b.

• Plot 2D Animated > Gradient Animates a gradient as a
parameter t increases over an interval a≤ t ≤ b.

• Plot 2D Animated > Implicit Animates an implicit plot
as a parameter t increases over an interval a≤ t ≤ b.

• Plot 2D Animated > Inequality Animates an inequality
as a parameter t increases over an interval a≤ t ≤ b.

• Plot 2D Animated > Parametric Animates the plot of a
parametric curve as a parameter t increases over an interval a≤
t ≤ b.

• Plot 2DAnimated> Polar Animates a polar plot as a pa-
rameter t increases over an interval a≤ t ≤ b.

• Plot 2D Animated > Rectangular Animates a rectangu-
lar plot as a parameter t increases over an interval a≤ t ≤ b.

• Plot 2D Animated > Vector Field Animates a plot of a
vector đeld as a parameter t increases over an interval a≤ t ≤ b.

• Plot 3D>Curve in Space Plots a rectangular curve, given
a list or vector (x(t) ,y(t) ,z(t)).

• Plot3D>Cylindrical Plots the expression f (θ ,z) in cylin-
drical coordinates or the parameterized cylindrical surface
(r (s, t) ,θ (s, t) ,z(s, t)).

• Plot 3D>Gradient Plots a three-dimensional array of ar-
rows that describe gradient of the expression f (x,y,z).

• Plot 3D> Implicit Plots an equation f (x,y,z) = c.

• Plot 3D> Parametric Plots a parametric surface
(x(s, t) ,y(s, t) ,z(s, t)) in rectangular coordinates.

• Plot 3D>Rectangular Plots a surface given by an expres-
sion f (x,y) in rectangular coordinates. Also plots a parametric
surface (x(s, t) ,y(s, t) ,z(s, t)) in rectangular coordinates.
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• Plot 3D>Spherical Plot an expression f (θ ,ϕ) in spheri-
cal coordinates or a parameterized surface (ρ (s, t) ,θ (s, t) ,ϕ (s, t))
in spherical coordinates.

• Plot 3D>Tube Plots a fat curve (x(t) ,y(t) ,z(t)) of ra-
dius r (t).

• Plot 3D > Vector Field Plots a vector đeld F (x,y,z) =
[u(x,y,z) ,v(x,y,z) ,w(x,y,z)] in rectangular coordinates.

• Plot 3DAnimated>Curve in Space Animates a curve in
space as a parameter t increases over an interval a≤ t ≤ b.

• Plot 3D Animated > Cylindrical Animates a cylindrical
plot as a parameter t increases over an interval a≤ t ≤ b.

• Plot 3D Animated > Gradient Animates a gradient as a
parameter t increases over an interval a≤ t ≤ b.

• Plot 3D Animated > Implicit Animates an implicit plot
as a parameter t increases over an interval a≤ t ≤ b.

• Plot 3D Animated > Parametric Animates a parametric
plot as a parameter t increases over an interval a≤ t ≤ b.

• Plot 3D Animated > Rectangular Animates a rectangu-
lar plot as a parameter t increases over an interval a≤ t ≤ b.

• Plot 3DAnimated> Spherical Animates a spherical plot
as a parameter t increases over an interval a≤ t ≤ b.

• Plot 3D Animated> Tube Animates a tube plot as a pa-
rameter t increases over an interval a≤ t ≤ b.

• Plot 3DAnimated>Vector Field Animates a vector đeld
as a parameter t increases over an interval a≤ t ≤ b.

• Polynomials>Collect Rewrites a polynomial by collect-
ing all coefficients of terms of the polynomial.

• Polynomials>CompanionMatrix Produces the compan-
ionmatrix of amonic polynomiala0+a1X+· · ·+an−1Xn−1+
Xn of degree n, which is the n×n matrix with a subdiagonal of
ones, đnal column

[
−a0 −a1 · · · −an−1

]T and other
entries zero.
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• Polynomials>Divide Rewrites a rational quotient of poly-
nomials f (x)/g(x)with rational coefficients to the formq(x)+
r(x)/g(x), where r(x) andq(x) are polynomials anddegr(x)<
degg(x).

• Polynomials>Partial Fractions Writes a factorable ratio-
nal function as a sum of simpler fractions.

• Polynomials > Roots Finds real and complex roots of a
real or complex polynomial with rational coefficients. It đnds
roots symbolically for polynomials of degree 4 or less, and đnds
the roots numerically for polynomials of higher degree.

• Polynomials > Sort Rewrites a polynomial by collecting
the numeric coefficients of terms of a polynomial expression
and returns the terms in order of decreasing degree.

• Power Series Produces the Taylor series of a function ex-
panded about a speciđed point.

• Rewrite>Arccos Rewrites an inverse trigonometric func-
tion in terms of arccos.

• Rewrite>Arccot Rewrites an inverse trigonometric func-
tion in terms of arccot.

• Rewrite>Arcsin Rewrites an inverse trigonometric func-
tion in terms of arcsin.

• Rewrite>Arctan Rewrites an inverse trigonometric func-
tion in terms of arctan.

• Rewrite>Cos Rewrites a trigonometric function in terms
of the cosine function.

• Rewrite> Equations as Matrix Converts a system of lin-
ear equations to the matrix of its coefficients.

• Rewrite>Exponential Rewrites an expression in terms of
the natural exponential function.

• Rewrite>Factorial Rewrites an expression in termsof fac-
torials.

• Rewrite>Float Rewrites an expression in termsofĔoating-
point numbers.
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• Rewrite>Gamma Rewrites a factorial expression in terms
of the gamma function.

• Rewrite > Logarithm Rewrites an expression in terms of
the natural logarithm.

• Rewrite > Matrix as Equations Takes a matrix and pro-
duces a list of linear equations with the matrix entries as coeffi-
cients.

• Rewrite>Mixed Converts a fraction to a mixed number.

• Rewrite > Normal Form Combines rational polynomial
expressions over a common denominator.

• Rewrite>Polar Rewrites a complexnumber inpolar form
reiθ .

• Rewrite > Rational Rewrites a Ĕoating-point number as
a quotient of integers; rewrites an inverse in rational notation.

• Rewrite>Rectangular Rewrites a complexnumber in rect-
angular form a+bi.

• Rewrite>Sin Rewrites a trigonometric expression in terms
of the cosine function.

• Rewrite > Sin and Cos Rewrites a trigonometric expres-
sion in terms of the sine and cosine functions.

• Rewrite>SinhandCosh Rewrites an exponential expres-
sion in terms of the hyperbolic sine and cosine functions.

• Rewrite>Tan Rewrite a trigonometric expression in terms
of the tangent function.

• Simplex > Dual Gives the dual of a linear programming
problem.

• Simplex>Feasible? Testswhether ornot a set of constraints
is feasible.

• Simplex>Maximize Finds themaximumvalue of a linear
expression subject to a feasible system of constraints.
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• Simplex>Minimize Finds theminimum value of a linear
expression subject to a feasible system of constraints.

• Simplex>Standardize Rewrites a linear programmingprob-
lem in standard form.

• Simplify Simpliđes an algebraic expression, rationalizes de-
nominators.

• Solve > Exact Finds an exact solution to an equation or
system of equations.

• Solve> Integer Finds integer roots of polynomial expres-
sions with rational coefficients, and integer solutions to equa-
tions of the same type.

• Solve>Numeric Computes an approximateĔoating-point
solution to an equation or an approximate Ĕoating-point solu-
tion in a given interval.

• Solve > Recursion Solves a recursion or system of recur-
sions.

• SolveODE>Exact Computes an exact solution to an or-
dinary differential equation.

• Solve ODE > Laplace Uses the Laplace method to com-
pute a solution to an ordinary differential equation.

• Solve ODE > Numeric Computes an approximate solu-
tion to an ordinary differential equation.

• Solve ODE> Series Computes an approximate đnite se-
ries solution to an ordinary differential equation.

• Statistics>Correlation Computes the coefficient of cor-
relation between two samples.

• Statistics > Covariance Computes the n× n covariance
matrix of an m×n matrix.

• Statistics>FitCurve toData>MultipleRegression Cal-
culates linear-regression equations from keyed or labeled data
matrices. ăe equation produced is the best đt to the data in
the least-squares sense.
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• Statistics>FitCurve toData>Polynomial ofDegreen Cal-
culates polynomial equations from labeled or unlabeled two-
columndatamatrices. ăe result is a polynomial of the speciđed
degree that is the best đt to the data in the least-squares sense.

• Statistics > Geometric Mean Calculates the nth root of
the product of numbers in a comma delimited list or a vector,
and calculates the nth roots of the products of numbers in
columns of an n×m matrix for n≥ 2.

• Statistics>Harmonic Mean Calculates the reciprocal of
the mean of the reciprocals of numbers in a comma delimited
list or a vector, and calculates the harmonic means for columns
of an n×m matrix for n≥ 2.

• Statistics > Mean Calculates the arithmetic mean, or av-
erage, of numbers in a comma delimited list or a vector, and cal-
culates the arithmeticmeans of numbers in columns of ann×m
matrix for n≥ 2.

• Statistics > Mean Deviation Calculates the mean of the
distances of the data from the data mean for data in a comma
delimited list or in a vector, and calculates the mean deviations
of data in columns of an n×m matrix for n≥ 2.

• Statistics>Median Calculates a number such that at least
half the numbers in a data set are equal to or less than it, and at
least half the numbers in the data set are equal to or greater than
it for data in a commadelimited list or in a vector, and calculates
the medians of data in columns of an n×m matrix for n≥ 2.

• Statistics>Mode Finds the valueor values that occurwith
maximum frequency in a data set, and also gives themultiplicity
of each of the modes for data in a comma delimited list or in a
vector, and calculates the modes of data in columns of an n×m
matrix for n≥ 2.

• Statistics > Moment Computes the 1st, 2nd, and higher
moments about themean or about a speciđed point for data in a
comma delimited list or in a vector, and calculates themoments
of data in columns of an n×m matrix for n≥ 2.
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• Statistics>õuantile Computes the qth quantile of a set,
where q is a number between zero and one. ăe result is a num-
ber Q for which the fraction q of the numbers falls below Q and
the fraction1−q lies aboveQ for data in a commadelimited list
or in a vector, and calculates the quantiles of data in columns of
an n×m matrix for n≥ 2.

• Statistics>RandomNumbers Produces a list of random
numbers from one of several families of distribution functions.
You specify the distribution, the size of the set, and appropriate
parameters.

• Statistics>StandardDeviation Computes the square root
of the variance of a data set, giving a measure of variation from
the mean for data in a comma delimited list or in a vector, and
calculates the standard deviations for columns of an n×m ma-
trix for n≥ 2.

• Statistics > Variance Computes the sample variance for
data in a comma delimited list or in a vector, and computes the
sample variances for columns of an n×m matrix for n≥ 2. For
a data set of size n, the sample variance is the sum of the squares
of differences with the mean, divided by n−1.

• Transforms> Fourier Computes the Fourier transform

F ( f (x) ,x,w) =
∫ ∞

−∞
e−iwx f (x)dx

of a function f (x).

• Transforms> InverseFourier Computes the inverseFourier
transform of a function.

• Transforms > Inverse Laplace Finds the inverse Laplace
transform of a function.

• Transforms> Laplace Computes the Laplace transform

L ( f (t) , t,s) =
∫ ∞

0
e−st f (t) dt

of a function f (t).
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• Vector Calculus>Curl Computes the curl

▽×F =

(
∂ r
∂y
− ∂q

∂ z
,

∂ p
∂ z
− ∂ r

∂x
,

∂q
∂x
− ∂ p

∂y

)
of a function F (x,y,z) = (p(x,y,z) ,q(x,y,z) ,r (x,y,z)).

• Vector Calculus>Divergence Computes the divergence

▽ ·F =
∂ p
∂x

(a,b,c)+
∂q
∂y

(a,b,c)+
∂ r
∂ z

(a,b,c)

of a function F (x,y,z) = (p(x,y,z) ,q(x,y,z) ,r (x,y,z)).

• Vector Calculus > Gradient Computes the gradient ▽ f
of a scalar function f (x1,x2, . . . ,xn)of n variables.

• Vector Calculus > Hessian Compute the n× n Hessian

matrix
[

∂ 2 f
∂xi∂x j

]
of second partial derivatives of a scalar func-

tion f (x1,x2, . . . ,xn)of n variables.

• VectorCalculus> Jacobian Computes the n×n Jacobian

matrix
[

∂ fi

∂x j

]
of partial derivatives of the entries in a vector

đeld

( f1 (x1,x2, . . . ,xn) , f2 (x1,x2, . . . ,xn) , . . . , fn (x1,x2, . . . ,xn))

• Vector Calculus> Laplacian Computes the Laplacian

∇2 f = ∇ ·∇ f

= ∇ ·
(

∂ f
∂x

,
∂ f
∂y

,
∂ f
∂ z

)
=

∂ 2 f
∂x2 +

∂ 2 f
∂y2 +

∂ 2 f
∂ z2

of a scalar đeld f (x,y,z).

• Vector Calculus > Scalar Potential Computes the scalar
potential or informs that such a function does not exist.

• Vector Calculus> Set Basis Variables Allows the user to
enter a new set of basis variables.
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• VectorCalculus>Vector Potential Computes the vector
potential of a vector đelds. ăevector potential of a vector đelds
is a vector đeld whose curl is the given vector đeld.

• VectorCalculus>Wronskian Computes theWronskian,
the determinate of the n× n matrix

[
f (i−1)

j (x)
]
, of a vector

đeld ( f1 (x) , f2 (x) , . . . , fn (x)).

Toolbar and Keyboard Shortcuts for Compute Menu

Math Toolbar and Keyboard Shortcuts
Tooltips identify the buttons on the toolbars in the program win-

dow. To see the button name, hold the mouse pointer on a toolbar
button for several seconds until the tooltip appears.

Following areMathToolbar andkeyboard shortcuts for commands
on the Compute menu.

Button Compute Menu Keyboard Shortcut

Evaluate Ctrl+e

Evaluate Numeric

Deđnitions>New Deđnition Ctrl+=

Deđnitions> Show Deđnitions

Interpret Ctrl+shiĕ+/ or Ctrl+?

Solve> Exact

Simplify

Expand

Plot 2D> Rectangular

Plot 3D> Rectangular
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Entering Mathematics

Time is the most valuable thing a man can spend. Theophrastus (372 BC–287 BC)

K eyboard shortcuts are available for many common tasks. ăe Entering Mathematics and Text

Entering Mathematical Objects

Entering Symbols and Characters

Entering Units of Measure

keyboard shortcuts for performing basic mathematical oper-
ations and entering symbols, characters, and the most com-

mon mathematical objects are faster to use than the mouse. ăe lists
on the following pages summarize shortcuts related speciđcally to en-
tering mathematics. For many additional shortcuts, consult Creating
Documents with ScientiĖc WorkPlace and ScientiĖc Word, Version 6 or
choose Help and search for keyboard shortcuts.

We use standard computer conventions to give keyboard instruc-
tions. ăe names of keys in the instructions match the names shown
on most keyboards. Ctrl (Windows) and Cmd (Mac) are synony-
mous, as are Enter (Windows) and Return (Mac). Names of keys are
always shown in Windows format. Mac users should substitute Mac
keys (e.g., Cmd and Return) as appropriate.

A plus sign (+) between the names of two keys indicates that you
must press the đrst key and hold it down while you press the second
key. For example, Ctrl+gmeans that you press and hold down theCtrl
key, press g, and then release both keys.

Entering mathematics is straightforward. Working right in the
programwindow, youuse familiar notation to entermathematical char-
acters, symbols, and objects into your document. Simple commands
let you create displayed or inline mathematics.

Editing mathematics is equally straightforward. You can use stan-
dard clipboard and drag-and-drop operations to cut, copy, paste, and
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delete selections. You can also use the search and replace features to
locate or change mathematical information.

Entering Mathematics and Text
During information entry you are either entering text or mathe-

matics, and the results obtained from keystrokes and other user inter-
face actions will differ depending on whether you are entering text or
math. ăus we refer to being in either text mode or math mode. ăe
default state is text mode; it is easy to toggle between the two modes
and it is also easy to determine what mode you are in.

When you toggle to mathematics, the Math/Text button changes
to an “M” and the program

• Displays the insert point between brackets for mathematics.

• Interprets anything you type asmathematics, displaying it in red
in the program window.

• Italicizes alphabetic characters and displays numbers upright.

• Automatically formats mathematical expressions, inserting cor-
rect spacing around operators such as + and relations such as =.

• Advances the insert point to thenextmathematical objectwhen
you press the spacebar.

To switch from text tomathematics from the keyboard
• Press Ctrl+m.

Subsequent editing inmathmodewill continue until you press the
spacebar at the end of math. Subsequent editing in text mode will
enter text objects.

To switch from text tomathematics from the Insertmenu
• Choose Insert>Math.

Subsequent editing will enter math objects.

To switch frommathematics to text from the keyboard
• Press Spacebar once or twice.
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To switch frommathematics to text from the Insertmenu
• Choose Insert>Text.

Subsequent editing will enter text objects.
Unless you actively change to mathematics, the program displays

a “T” on the Standard toolbar.

To toggle betweenmathematics and text from the StandardToolbar
• To toggle entry mode to Math, click the “T” on the standard

toolbar.

ăe “T” changes to “M” and the insert point changes to red and
appears between brackets. Subsequent editingwill entermath objects.

• To toggle entry mode to Text, click the “M” on the standard
toolbar.

ăe “M” changes to “T” and the insert point changes to black.
Subsequent editing will enter text objects.

Entering Mathematical Objects
Tip
Expanding parentheses, brackets, and braces
grow to an appropriate size, depending on
what they enclose, such as fractions or
matrices. Their use also tends to minimize
errors associated with unbalanced fences.

You can enter mathematical objects from the keyboard, from the
Math toolbar, and from the Insert>Math Objects menu. ăe menu
operation Insert > Math Objects has been used throughout the pre-
vious chapters. ăe keyboard and toolbar choices are summarized in
the following tables.

Tooltips identify the buttons on the toolbars in the program win-
dow. To install theMath toolbar, if it does not appear in your program
window, choose View>Toolbars and check Math toolbar.

Math Toolbar

To see the button name, hold the mouse pointer on a toolbar button
for several seconds until the tooltip appears.

Toentermath objects from theMath toolbar or the keyboard
• Click the appropriate button, or

• Hold the Ctrl key down and press the indicated key
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Insert Menu Button Press Ctrl+key

Math Objects> Fraction □
□ /

Math Objects> Radical
√
□ r

Math Objects> Superscript Nx h or up arrow
Math Objects> Subscript Nx l or down arrow
Math Objects> Brackets, [ ] [□] [
Math Objects> Brackets, ( ) (□) ( or 9
Math Objects> Brackets, { } {□} {
Math Objects> Brackets, ⟨ ⟩ ⟨□⟩ <

Math Objects> Brackets, | | |□| \
Math Objects> Brackets, ∥ ∥ ∥□∥ |
Math Objects>Operators, ∑ ∑ 7
Math Objects>Operators,

∫ ∫
i or 8

Math Objects>Unit Name ĕ lb See page 496

Math Objects>Display d
Math Objects>Operators ∑

∫
Math Objects>Math Name sin

cos

Math Objects> Binomial
(□
□
)

Math Objects>Decoration

Entering Symbols and Characters

ăere are many useful symbols and characters that can be entered
directly from the keyboard. ăe following table summarizes many of
those that are commonly used in mathematics.

Toenter symbols and characters from the keyboard

• Press Ctrl+k and press the key indicated in the following table.
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To enter Press Ctrl+k
then press To enter Press Ctrl+k

then press

→ 1 ⊂ c or &
↑ 2 ∨ v
← 3 • b
↓ 4 ∇ n
⊇ 5 ⇓ $
∩ 6 ⇒ !
⊆ 7 ⇑ @
∪ 8 ⇐ #
(□) 9 or 0 or ( or ) ⊃ %
≡ - ∼= _
̸= = ± +
≈ w ℵ W
∈ e /∈ E
√
□ r or R ∞ I⊗

t or T ℘ P∫
i {□} { or }

/0 o ∀ A
∏ p

⊕
S

[□] [ or ] ⋄ D
∠ a ÷ X
∑ s · C
∂ d ∧ V
□
□ f or F ¬ N

N□ h or H ≤ <

N□ l or L ≥ >

× x ∃ z

Last matrix created m
[

□ □
□ □

]
M
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ToenterGreekLetters from theKeyboard Examples
Type Ctrl+g, g for γ (lowercase gamma),
Ctrl+g, G forΓ (uppercase gamma) and
Ctrl+g,D for∆. Note that the shortcut Ctrl+g,
A does nothing, asA is already the symbol for
the uppercase alpha.

1. Press and hold the control key down and type the letter g.

2. Release the control key and type a Roman letter corresponding
to the desired Greek letter.

Lowercase Roman letters yield lower-case Greek. Uppercase Roman
letters yield uppercase Greek. Many uppercase Roman letters agree
exactly with their Greek equivalents, and for these, no Ctrl+g pređx is
needed.

To enter
Press Ctrl+g
then press To enter

Press Ctrl+g
then press

alpha α a pi π p

beta β b Pi Π P

gamma γ g varpi ϖ v

Gamma Γ G rho ρ r

delta δ d varrho ϱ R

Delta ∆ D sigma σ s

varepsilon ε e Sigma Σ S

epsilon ϵ E varsigma ς T

zeta ζ z tau τ t

eta η h upsilon υ u

theta θ y Upsilon ϒ U

vartheta ϑ Z phi ϕ f

ăeta Θ Y Phi Φ F

iota ι i varphi φ j

kappa κ k chi χ q

varkappa κ K psi ψ c

lambda λ l Psi Ψ C

Lambda Λ L omega ω w

mu µ m Omega Ω W

nu ν n digamma 𝟋 I

xi ξ x
Xi Ξ X
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ăe Greek characters are mapped to U.S. keyboards like this:

Uppercase Greek

Lowercase Greek

Toenter symbols andcharacters fromtheSymbols toolbarorSymbols side-
bar

• Click the symbol or character you want on the Symbol pane on
the sidebar.
Or

1. Click the symbol palette you want on the Symbols toolbar.

2. From the list of available symbols, click the symbol you want.

Toenter symbols and characters usingTeXcommands
If you are very familiar with TEX and know the TEX command for

an object or operation, you can enter it in a TEX đeld or, if you know
the TEX name for a character or symbol, from the keyboard.
Toenter aTeXđeld

• Choose Insert>Typeset Object>TeX Field.

• Type the TEX command in the dialog box.
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Toenter a character or symbol using itsTeXname
1. Type Ctrl+space.

2. Type the character or symbol name without the leading back-
slash (\).

3. Press Enter.

TEX is case-sensitive. ăe TEX name for δ is delta and the TEX
name for ∆ is Delta. Choose Help> Index>General Reference and
search on Keyboard Shortcuts for more information.

In addition to the Greek alphabet, here are a few other examples.

Character
or symbol

TEX
name

Character
or symbol

TEX
name

Character
or symbol

TEX
name

ℵ aleph . . . dots ∥ parallel
∠ angle /0 emptyset ∂ partial
≈ approx e euro ± pm
⊥ bot ∃ exists ∏ prod
• bullet ∀ forall ⊂ subset
∩ cap ≥ geq ∑ sum
· cdot ∈ in ∴ therefore
· · · cdots ∞ inĕy × times
c/ cents

∫
int ⊤ top

◦ circ ≤ leq
... vdots

∼= cong ∓ mp ∨ vee
∪ cup ∇ nabla ∧ wedge
. . . ddots ̸= ne
÷ div /∈ notin

Entering Units of Measure
Enter units ofmeasure fromthe Insertmenuor fromthekeyboard.

Toenter units from the Insertmenu
1. Choose Insert>Math objects>Unit Name.

496



i
i

“Compute60” — 2011/12/20 — 14:27 — page 497 — #507 i
i

i
i

i
i

Entering Units of Measure

2. When theUnitName dialog box appears, select ameasurement
category and a unit, then click Apply.

Units are automatically recognized and can be entered from the
keyboard. Following the general guidelines given below, and a table
of unit pređxes, are tables giving speciđc keyboard shortcuts for each
of the built-in physical quantities.

Toenter units from the keyboard
1. Choose Insert>Math.

2. Type ‘u’ followed by the unit symbol, with the exceptions:

• Type ‘mc’ for ‘micro’ in place of µ whichwill appear in the
unit symbol.

• Type ‘uhr’ for the hour symbol h.

• Type ’uda’ for the day symbol d.

• Type ’use’ for the second symbol s.

• Type ‘ume’ for the meter symbol m.

• Type ‘uan’ for the angstrom symbol Å.

• Type ‘uCo’ for the Coulomb symbol C.

• Type ‘uTe’ for the Tesla symbol T.

• Type ‘uli’ for the Liter symbol l.

• Type ‘ohm’ (aĕer the pređx) for the symbols for ohm (and
its derivatives) Ω.

• Type ‘ucel’ and ‘u f ahr’ for degrees Celsius ◦C and de-
grees Fahrenheit ◦F, respectively.

• Type ‘udeg’ for the degree symbol (plane angle) ◦.

• Type ‘udmn’ and ‘uds’ for (degree) minute ′ and (degree)
second ′′, respectively.

Autorecognition is case sensitive, so type upper case where indi-
cated. ăe unit symbol should turn greenwhen you type the last char-
acter.
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Unit preöxes
Preöx Factor Symbol Preöx Factor Symbol

kilo 103 k milli 10−3 m

mega 106 M micro 10−6 µ (mc)
giga 109 G nano 10−9 n

tera 1012 T pico 10−12 p

peta 1015 P femto 10−15 f

exa 1018 E atto 10−18 a

Activity
To enter Unit Symbol In Math, type
Becquerel Bq uBq
Curie Ci uCi

Amount of substance
To enter Unit Symbol In Math, type
Attomole amol uamol
Examole Emol uEmol
Femtomole fmol u f mol
Gigamole Gmol uGmol
Kilomole kmol ukmol
Megamole Mmol uMmol
Micromole µmol umcmol
Millimole mmol ummol
Mole mol umol
Nanomole nmol unmol
Petamole Pmol uPmol
Picomole pmol upmol
Teramole Tmol uT mol

Area
To enter Unit Symbol In Math, type
Acre acre uacre
Hectare hectare uhectare
Square foot ft2 u f t (insert exponent)
Square inch in2 uin (insert exponent)
Square meter m2 ume (insert exponent)

Tip
To enter units such as ft2, ft3, in2, in3,
m2, and m3, type the unit symbol and then
choose Insert>Math Objects> Superscript
and type the appropriate number.
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Current
To enter Unit Symbol In Math, type
Ampere A uA
Kiloampere kA ukA
Microampere µA umcA
Milliampere mA umA
Nanoampere nA unA

Electric capacitance
To enter Unit Symbol In Math, type
Farad F uF
Microfarad µF umcF
Millifarad mF umF
Nanofarad nF unF
Picofarad pF upF

Electric charge
To enter Unit Symbol In Math, type
Coulomb C uCo

Electric conductance
To enter Unit Symbol In Math, type
Kilosiemens kS ukS
Microsiemens µS umcS
Millisiemens mS umS
Siemens S uS

Electrical potential difference
To enter Unit Symbol In Math, type
Kilovolt kV ukV
Megavolt MV uMV
Microvolt µV umcV
Millivolt mV umV
Nanovolt nV unV
Picovolt pV upV
Volt V uV
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Electric resistance
To enter Unit Symbol In Math, type
Gigaohm GΩ uGohm
Kiloohm kΩ ukohm
Megaohm MΩ uMohm
Milliohm mΩ umohm
Ohm Ω uohm

Energy
To enter Unit Symbol In Math, type
British thermal unit Btu uBtu
Calorie cal ucal
Electron volt eV ueV
Erg erg uerg
Gigaelectronvolt GeV uGeV
Gigajoule GJ uGJ
Joule J uJ
Kilocalorie kcal ukcal
Kilojoule kJ ukJ
Megaelectronvolt MeV uMeV
Megajoule MJ uMJ
Microjoule µJ umcJ
Millijoule mJ umJ
Nanojoule nJ unJ

Force
To enter Unit Symbol In Math, type
Dyne dyn udyn
Kilonewton kN ukN
Meganewton MN uMN
Micronewton µN umcN
Millinewton mN umN
Newton N uN
Ounce-force ozf uoz f
Pound-force lbf ulb f
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Frequency
To enter Unit Symbol In Math, type
Exahertz EHz uEHz
Gigahertz GHz uGHz
Hertz Hz uHz
Kilohertz kHz ukHz
Megahertz MHz uMHz
Petahertz PHz uPHz
Terahertz THz uT Hz

Illuminance
To enter Unit Symbol In Math, type
Footcandle fc u f c
Lux lx ulx
Phot phot uphot

Length
To enter Unit Symbol In Math, type

Ångström Å uan
Attometer am uame
Centimeter cm ucm
Decimeter dm udme
Femtometer fm u f me
Foot ft u f t
Inch in uin
Kilometer km ukme
Meter m ume
Micrometer µm umcme
Mile mi umi
Millimeter mm umme
Nanometer nm unme
Picometer pm upme

Luminance
To enter Unit Symbol In Math, type
Stilb sb usb

Luminous øux
To enter Unit Symbol In Math, type
Lumen lm ulm
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Luminous intensity
To enter Unit Symbol In Math, type
Candela cd ucd

Magnetic øux
To enter Unit Symbol In Math, type
Maxwell Mx uMx
Microweber µWb umcWb
Milliweber mWb umWb
Nanoweber nWb unWb
Weber Wb uWb

Magnetic øux density
To enter Unit Symbol In Math, type
Gauss G uGa
Microtesla µT umcT
Millitesla mT umT
Nanotesla nT unT
Picotesla pT upT
Tesla T uTe

Magnetic inductance
To enter Unit Symbol In Math, type
Henry H uHe
Microhenry µH umcH
Millihenry mH umH

Mass
To enter Unit Symbol In Math, type
Atomic mass unit u uu
Centigram cg ucg
Decigram dg udg
Gram g ugr
Kilogram kg ukg
Microgram µg umcg
Milligram mg umg
Pound-mass lb ulbm
Slug slug uslug
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Plane angle
To enter Unit Symbol In Math, type
Degree ◦ udeg
Microradian µrad umcrad
Milliradian mrad umrad
Minute ′ udmn
Radian rad urad
Second ′′ uds

Power
To enter Unit Symbol In Math, type
Gigawatt GW uGWa
Horsepower hp uhp
Kilowatt kW ukWa
Megawatt MW uMWa
Microwatt µW umcWa
Milliwatt mW umWa
Nanowatt nW unWa
Watt W uWa

Pressure
To enter Unit Symbol In Math, type
Atmosphere atm uatm
Bar bar ubar
Kilobar kbar ukbar
Kilopascal kPa ukPa
Megapascal MPa uMPa
Micropascal µPa umcPa
Millibar mbar umbar
Mercury mmHg ummHg
Pascal Pa uPa
Torr torr utorr

Mercury
Millimeters at 0◦C.

Solid angle
To enter Unit Symbol In Math, type
Steradian sr usr

503



i
i

“Compute60” — 2011/12/20 — 14:27 — page 504 — #514 i
i

i
i

i
i

Appendix B | Menus and Shortcuts for Entering Mathematics

Temperature
To enter Unit Symbol In Math, type
Celsius ◦C ucel
Fahrenheit ◦F u f ahr
Kelvin K uK

Time
To enter Unit Symbol In Math, type
Attosecond as uas
Day d uda
Femtosecond fs u f s
Hour h uhr
Microsecond µs umcs
Millisecond ms ums
Minute min umn
Nanosecond ns uns
Picosecond ps ups
Second s use
Year y uy

Volume
To enter Unit Symbol In Math, type

Cubic foot ft3 u f t (insert exponent)
Cubic inch in3 uin (insert exponent)
Cubic meter m3 ume (insert exponent)
Gallon (US) gal ugal
Liter l uli
Milliliter ml uml
Pint pint upint
õuart qt uqt
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C
Customizing the Program

for Computing

Wherever there is number, there is beauty. Proclus Diadochus (412–485)

T he program window has an updated look with streamlined Customizing the Toolbars

Customizing the Sidebars

Customizing the Compute
Settings

Customizing the Plot Settings

Automatic Subsitution

layouts for the toolbars and symbol panels. As before, amouse-
activated tooltip gives the name of each toolbar button and

panel symbol. Most tools work the same way they did in earlier ver-
sions. ăe Version 6 system offers a number of ways to customize its
features.

Use Preferences in the Tools menu to customize the universal and
local settings. ăe Computation choices replace the previous Com-
putation Setup and Engine Setup. You will đnd some new features in
these dialogs.

You candeđne automatic substitution sequences for text andmath-
ematics, thus speeding the entry of the text and mathematical expres-
sions you usemost oĕenwith an enhanced automatic substitution fea-
ture.

You can enter content quicklywith fragments. WithVersion 6 you
can create fragments containing XHTML code, TEX code, graphics,
or anything else that can go on the clipboard. Fragments are no longer
limited to TEX strings. Fragments and many other text editing short-
cuts are documented in themanualCreatingDocuments with ScientiĖc
WorkPlace and ScientiĖc Word, as well as in the Help.
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Customizing the Toolbars
ăe Version 6 program window has three customizable toolbars.

• ăe Standard toolbar contains buttons for invoking common
đle operations and the text boxes for tag lists.

• ăe Editing toolbar buttons invoke ordinary editing tools.

• ăe Math toolbar buttons insert mathematical objects directly
into your document or open dialog boxes so that you can make
additional speciđcations. Certainbuttons invoke commoncom-
putational operations.

ăe Symbol toolbar has palettes of buttons for adding a wide vari-
ety of symbols to your documents. With the exception of those on the
Symbol toolbar, the buttons on the toolbars are identical in function
to commands on the menus. Point the mouse at each toolbar button
for a few seconds to display a brief tooltip that identiđes the button.
As with menu commands, buttons that appear dimmed are unavail-
able.

ăe default screen displays the đrst three of these toolbars.

Toaddor remove toolbars
1. Choose View>Toolbars.

2. Check or uncheck the desired toolbars.

Tocustomize a toolbar
1. Place the insert point in one of the toolbars and click the right

button.

2. Choose Customize Toolbars.

3. Click and drag buttons from the panel to a toolbar.

With the Customize toolbar dialog box open, you can also add
a new toolbar, restore the default set of toolbars, drag a button to a
different position on a toolbar, or drag a button from one toolbar to
another. You can show icons only, icons and text, or text only. ăe
icons can be small or normal.
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Customizing the Sidebars
ăeVersion6 sidebars display several palettes thatmakedocument

editing easier. You can toggle the display of sidebars on either side of
the document window, and you can choose which palettes to display
in either sidebar using the Add drop-down menu.

You can toggle the display of either sidebar. Note the small graphic
on the inside border of each, containing two arrowheads separated by
a column of dots. Click this graphic to toggle the sidebar display. You
can also toggle the sidebar display from the View menu.

Customizing the Compute Settings
Choose Tools > Preferences > Computation to change default

behavior for Scope, Input,Output,Matrices,Derivatives, Entities, and
Engine. Mac users choose SWPPro> Preferences>Computation.

Scope
WhenDefault is chosen, the settings apply to all documents. With

Scope set to ăis Document Only, the settings speciđed apply only to
the open document.

Input
On the Input page, you can customize notation that activates sev-

eral behaviors.

Base of Log
ăe default interpretation for logx is the same as lnx, namely the

natural logarithm with base e. You can uncheck this option, so that
logx = log10 x.

Dot Accent
ăere are several different notation recognized for a derivative.

(See Chapter 7 “Calculus” for a description of these.) ăe default
includes the use of Newton’s notation for differentiation, also called
the dot notation, placing a dot over the function name to represent
a derivative. If x = f (t), then ẋ and ẍ represent the đrst and second
derivative, respectively, of x with respect to t . ăis notation is com-
mon in physics and other applied mathematics. You can uncheck this
option.
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Bar Accent
ăeuse of a bar over a complex expression is commonly used to de-

note the complex conjugate: ifa andb are real numbers, thena+ ib=
a− ib. You can use this notation or disable it. An asterisk is also used
for this purpose: if a and b are real numbers, then (a+ ib)∗ = a− ib.

i
ăeimaginary unit canbedenoted either by the letter i, or .ıı (Imag-

inaryI)

j
In electrical engineering and related đelds, the imaginary unit is

oĕen denoted by j to avoid confusion with electrical current. ăe
Python programming language also uses j to denote the imaginary
unit. MATLAB associates both i and j with the imaginary unit. You
can set j as the default notation for the imaginary unit.

e
ăe number e can be denoted either by the letter e, or as ee (Expo-

nentialE).

Output
ăe appearance of mathematical expressions produced as the re-

sult of a computation can be customized.

Scientiöc Notation Output
Numbers with many digits are oĕen presented in scientiđc nota-

tion, such as the speed of light in a vacuum 2.99792458×108 ms−1.
You can set numbers for Digits Rendered (the number of digits dis-
played), the Upper ăreshold (digits to the leĕ of the decimal before
switching to scientiđc notation) and Lower ăreshold (zeros to the
right of the decimal before switching to scientiđc notation).

Rational Numbers
You can reset the system so that fractions resulting from a compu-

tation are presented as mixed numbers, yielding computations such as
4 2

3 +5 1
4 = 9 11

12 . ăe default is for computations to result in, possibly
improper, fractions: 4 2

3 +5 1
4 = 119

12 .

Trigonometric Functions
ScientiĖc WorkPlace and ScientiĖc Notebook recognize two types

of functions—ordinary functions and trigtype functions. ăe distinc-
tion is that the argument of an ordinary function is always enclosed
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in parentheses and the argument of a trigtype function oĕen is not. If
you checkUse Parentheses for Trig Functions, then computations will
produce trigonometric functionswith parentheses enclosing the argu-
ment. See Trigtype Functions, page 122, for a complete list of trigtype
functions and other details.

Inverse trigonometric and hyperbolic functions have two possible
notations, sin−1 x = arcsinx for example, and both are used by de-
fault. You can disable the use of the “arc” pređx for inverse functions
by unchecking the option Use “arc” pređx for inverse Trig Functions.

Matrices
You can reset the default matrix delimiter. ăe original default is

square brackets.

Default matrix delimiter
ăechoices for defaultmatrix delimiter areNone, square brackets,

and parentheses.

Derivatives
ăere are many choices of notation for derivatives. ăese settings

can guarantee a uniform choice for output. ăe factory default is to
use notation that agrees with the input.

Derivative Output Notation
ăe choices for Derivative Output Notation are input notation,

d/dx, D, primes, and dots.

Derivatives as Primes
ăe usual notation for higher derivatives is f (n) (x). ăis setting

lets you designate for which n the system switches from prime nota-
tion to the (n)notation. A setting of 4, for example, gives the sequence
of notations f , f ′, f ′′, f ′′′, f (4), f (5), ...

Prime Notation
By default, a prime aĕer a function name means derivative. You

can uncheck this option and disable it.

Entities
ăese settings allow you to change the appearance of several enti-

ties that result from a computation.

Imaginary i Output
Set the output for the imaginary unit as i, j, or .ıı (ImaginaryI).
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DifferentialD Output
Reset theoutput for thedifferentialD asD (CapitalDifferentialD).

Differentiald Output
Reset the output for the differential d as dd (DifferentialD).

Exponential e Output
Reset the output for the exponential e as ee (ExponentialE).

Engine
Engine on

ăe default is for the engine to be on. If you wish to temporarily
disable the computation engine, simply uncheck Engine on. (When
editing a large document, some activities are faster with the engine
off.)

Digits
ăis setting determines the number of digits employed in compu-

tations. Set the number higher for increased accuracy, and lower for
increased computation speed.

Solve Options
ăese options determine the appearance of solutions to equations.

Maximum Degree
For many polynomial equations of degree greater than 4, explicit

solutions in terms of radicals do not exist. In these cases, implicit solu-
tions are given in terms of roots of a polynomial. When the equation is
a polynomial equation with degree 3 or 4, the explicit solution can be
very complicated—and too large to preview, print, or save. To avoid
this complication, you can set the engine to return solutions that are
not rational solutions in implicit form for smaller degree polynomials
as well.

See Equations With One Variable, page 53, for examples.

Principal Value Only
Use this setting to get simpliđed solutions. For example, the de-

fault for Solve > Exact applied to sinx = 1
2 returns the complete so-

lution {
1
6

π +2πk | k ∈ Z
}
∪
{

5
6

π +2πk | k ∈ Z
}
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With Principal Value Only checked, the solution returned is

1
6

π

Ignore Special Cases
Use this setting to get simpliđed solutions. For example, the de-

fault for Solve> Exact applied to ex = y (variable x) returns the solu-
tion {

{lny+2iπk | k ∈ Z} if y ̸= 0
/0 if y = 0

With Ignore Special Cases checked, the solution returned is

{lny+2iπk | k ∈ Z}

Note thatwithboth Ignore SpecialCases andPrincipalValueOnly
checked the solution returned is simply lny.

Debugging
You can investigate possible syntax errors in mathematics being

sent to or returned by the computing engine by creating logs of the
process.

Customizing the Plot Settings
Choose Tools > Preferences > Plots to change the settings for

Axes, Layout, Labelling, and View.

Axes
ăe Axes Scaling options are Linear, Lin Log, Log Lin, and Log

Log. ăe option Lin Log uses linear scaling along the horizontal axis
and logarithmic scaling along the vertical axis. Log Lin uses logarith-
mic scaling along the horizontal axis and linear scaling along the ver-
tical axis.

Check Equal Scaling Along Each Axis for plotting geometric ob-
jects, such as circles, where youwant the scaling to be the same onboth
axes.

You can change the axis labels to other letters of names. ăe Axis
Tick Marks can be None, Low, Normal, or High. Arrow tips at the
positive ends of the axes can be turned on or off. You can turn onGrid
Line for 2D plots.

ăe Axes Type choices are Not Speciđed, Automatic, Normal,
Boxed, Frame, or None.
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Layout
You can change theDefault Size forNewPlots in Pixels (1in= 75

Pixels).
ăeDefaultPlacement forNewPlots choices are In line,Displayed,

or Floating. Floating plots can be placed at the Top of page, Bottom
of page, On a page of Ĕoats, Here, or Force Here. ăe placement can
be Leĕ, Right, Inside, Outside, of Full width.

View
Set the Background color by choosing from a color from the Ba-

sic colors or by entering numeric values. For 3D plots, you can check
Orthogonal projection, Keep up vector, or Use default view intervals.
You can also set the Initial View Intervals.

Automatic Substitution
You can create your own names for variables and functions that

will be automatically recognized.

To recognizebob as the variableRobert
1. Choose Tools>Automatic Substitution.

2. Type bob in the Keystrokes box

3. Choose Type of Substitution: Simple substitution.

4. Choose Context for Substitution: In Math.

5. Choose Enable or Disable Auto Substitution: In Math.

6. Leave the insert point in the Substitution entry box.

7. Choose Insert>Math Objects>Math Name.
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8. Type Robert in the Name box.

9. Choose Name Type: Variable.

10. Check ăis is an engine string.

11. Check Add automatic substitution.

12. Choose Apply. (ăe name ‘Robert’ should appear in the Sub-
stitution Box in the Automatic Substitution box.)

13. In the Automatic Substitution dialog, choose Save.

Compute> Deönitions> New Deönition
(In mathematics, type bob.)
Robert = 17

Compute> Evaluate
Robert2 = 289

For additional examples and information about automatic substi-
tution, see Automatic Substitution, page 102, choose Help> Search,
or consult the manual Creating Documents with ScientiĖc WorkPlace
and ScientiĖc Word.

513



i
i

“Compute60” — 2011/12/20 — 14:27 — page 514 — #524 i
i

i
i

i
i



i
i

“Compute60” — 2011/12/20 — 14:27 — page 515 — #525 i
i

i
i

i
i

D
MuPAD Functions
and Expressions

There is nothing so troublesome to mathematical practice ... than multiplications, divisions, square and cubical extractions
of great numbers ... I began therefore to consider ... how I might remove those hindrances. John Napier (1550–1617)

Constants

Compute Menu Items

Functions and Expressions

C onstants and functions are available either as items on the
Compute menu or through evaluating mathematical expres-
sions. ăere are alsomany built-in functions and expressions.

MuPAD equivalents are given for all of these and, where needed, a
brief description of the constant, function, or expression.

ăe two menu items Compute > Deđnitions > Deđne MuPAD
Name and Compute > Passthru to Engine offer additional ways to
take advantage of the computational capabilities of MuPAD. ăis ap-
pendix concludes with a brief discussion of each of these items.

Constants
Common constants can be expressed in ordinary mathematical

notation. See page 507 in Appendix C “Customizing the Program
for Computing” for some choices for the appearance of some of the
constants.

If a name such as gamma does not automatically gray when typed
in mathematics, then choose Insert > Math Objects > Math Name
and select or type the name.
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SWP/SNB MuPAD Comments
e exp(1) or E base of natural logs
i or j (see page 89) I imaginary unit:

√
−1

π PI circular constant

gamma EULER lim
n→∞

(
n
∑

m=1

1
m − lnn

)
∞ inđnity positive real inđnity
true TRUE Boolean true
false FALSE Boolean false

FAIL or undecidable
This is the translation for MuPAD’s FAIL,
UNKNOWN, or UNDEFINED. Either the answer
cannot be determined or a nonexistent
function was used.

Compute Menu Items

Following is a summary of Compute menu items and the equiva-
lent functions or procedure in MuPAD. Items marked with are
programmed, generally using several MuPAD functions and proce-
dures.

Other MuPAD functions can be used by choosing Compute >
Deđnitions>Deđne MuPAD Name and with Compute> Passthru
Code to Engine (see Chapter 5 “Function Deđnitions”).

Compute MuPAD
Evaluate eval
Evaluate Numeric Ĕoat
Simplify simplify
Factor factor
Factor ifactor
Expand expand
Check Equality testeq

Compute> Combine MuPAD
Exponentials combine
Logs combine
Powers simplify
Trig Functions simplify
Arctan combine
Hyperbolic Trig Functions combine
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Compute> Rewrite MuPAD
Rational numeric::rationalize
Float Ĕoat
Mixed
Exponential rewrite
Factorial rewrite
Gamma rewrite
Logarithm rewrite
Sin and Cos rewrite
Sinh and Cosh rewrite
Sin rewrite
Cos rewrite
Tan rewrite
Arcsin rewrite
Arccos rewrite
Arctan rewrite
Arccot rewrite
Polar
Rectangular rectform
Normal Form normal
Equations as Matrix linalg::expr2Matrix
Matrix as Equations

Compute> Solve MuPAD
Exact solve
Numeric numeric::fsolve
Integer Dom::Integer, solve
Recursion solve, rec

Compute> Polynomials MuPAD
Collect collect
Divide div
Partial Fractions parfrac
Roots solve
Sort polylib::sortMonomials
Companion Matrix linalg::companion
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Compute> Calculus MuPAD
Integrate by Parts intlib::by parts
Change Variables intlib::changevar
Partial Fractions parfrac
Approximate Integral student::trapezoid
Approximate Integral student::simpson
Approximate Integral student::riemann
Plot Approximate Integral
Plot Approximate Integral Animated
Find Extrema
Iterate
Implicit Differentiation diff

Compute> Solve ODE MuPAD
Exact ode::solve
Laplace ode::laplace
Numeric numeric::odesolve2
Series ode::series

Compute> Power Series MuPAD
Power Series series
Power Series taylor

Compute> Transforms MuPAD
Fourier transform::fourier
Inverse Fourier transform::invfourier
Laplace transform::laplace
Inverse Laplace transform::invlaplace

Compute> Vector Calculus MuPAD
Gradient linalg::grad
Divergence linalg::divergence
Curl linalg::curl
Laplacian linalg::laplacian
Jacobian linalg::jacobian
Hessian linalg::hessian
Wronskian ode::wronskianMatrix
Scalar Potential scalarpot
Vector Potential linalg::vectorPotential
Set Basis Variables
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Compute>Matrices MuPAD
Adjugate linalg::adjoint
Characteristic Polynomial linalg::charPolynomial
Cholesky Decomposition linalg::cholesky
Column Basis linalg::basis
Concatenate linalg::concatMatrix
Condition Number norm
Deđniteness Tests linalg::isPosDef
Determinant linalg::det
Eigenvalues linalg::eigenvalues
Eigenvectors linalg::eigenvectors
Fill Matrix
Fraction-free Gaussian Elimination linalg::gaussElim
Gaussian Elimination linalg::gaussElim
Hermite Normal Form linalg::hermiteForm
Hermitian Transpose conjugate + linalg::transpose
Inverse numeric::inverse
Jordan Normal Form linalg::jordanForm
Map Function map
Minimum Polynomial linalg::minpoly
Norm norm
Nullspace Basis linalg::nullspace
Orthogonality Test linalg::isUnitary
Permanent linalg::permanent
PLU Decomposition numeric::factorLU
QR Decomposition numeric::factorQR
Random Matrix linalg::randomMatrix
Rank linalg::rank
Rational Canonical Form linalg::rationalForm
Reduced Row Echelon Form linalg::GaussJordan
Reshape
Row Basis linalg::basis
Singular Values numeric::singularvalues
Singular Value Decomposition numeric::singularvectors
Smith Normal Form linalg::HermiteForm
Spectral Radius numeric::spectralradius
Stack linalg::stackMatrix
Trace linalg::tr
Transpose linalg::transpose
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Compute> Simplex MuPAD
Dual linopt::dual
Feasible
Maximize linopt::maximize
Minimize linopt::minimize
Standardize

Compute> Stat.> Fit Curve to Data MuPAD
Multiple Regression stats::reg
Multiple Regression (No Constant) stats::linReg
Polynomial of Degree n stats::reg

Compute> Stat.> Random Numbers MuPAD
Beta stats::betaRandom
Binomial stats::binomialRandom
Cauchy stats::cauchyRandom
Chi-Square stats::chisquareRandom
Exponential stats::exponentialRandom
F stats::fRandom
Gamma stats::gammaRandom
Normal stats::normalRandom
Poisson stats::poissonRandom
Student’s t stats::tRandom
Uniform stats::uniformRandom
Weibull stats::weibullRandom

Compute> Statistics MuPAD
Mean stats::mean
Median stats::median
Mode stats::modal
Correlation stats::correlation
Covariance
Geometric Mean stats::geometric
Harmonic Mean stats::harmonic
Mean Deviation
Moment
õuantile stats::a_quantil
Standard Deviation stats::stdev
Variance stats::variance
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Compute> Plot 2D MuPAD
Rectangular plotfunc2d or plot::Function2d
Polar plot::polar
Implicit plot::Implicit2d
Parametric plot::Curve2d
Conformal plot2d
Gradient
Vector Field plot::VectorField2d
ODE plot::Ode2d

Compute> Plot 3D MuPAD
Rectangular plotfunc3d or plot::Function2d
Cylindrical plot::Cylindrical
Spherical plot::Spherical
Implicit plot::Implicit3d
Tube plot::Tube
Gradient
Vector Field

Compute> Plot 2D Animated MuPAD
Plot 2D Animated + Rectangular plotfunc or plot::Function2d
Plot 2D Animated + Polar plot::polar
Plot 2D Animated + Implicit plot::Implicit2d
Plot 2D Animated + Parametric plot::Curve2d
Plot 2D Animated + Conformal plot::Conformal
Plot 2D Animated + Gradient
Plot 2D Animated + Vector Field plot::VectorField2d
Plot 2D Animated + ODE plot::Ode2d

Compute> Plot 3D Animated MuPAD
Plot 3D Animated + Rectangular plotfunc3d or plot::Function3d
Plot 3D Animated + Cylindrical plot::Cylindrical
Plot 3D Animated + Spherical plot::Spherical
Plot 3D Animated + Implicit plot::Implicit3d
Plot 3D Animated + Tube plot::Tube
Plot 3D Animated + Gradient
Plot 3D Animated + Vector Field
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Functions and Expressions

ăere are a number of built-in functions that you can evaluatewith
Compute > Evaluate. Some are entered directly in mathematics and
some use a Math Name. If a function name does not automatically
turn graywhen typed inmathematics (manydo), choose Insert>Math
Objects>Math Name and type the function name in the Name box.
ăe following lists show the MuPAD function names that are used to
implement the built-in functions.

Algebra and Number Theory
SWP/SNB MuPAD√

x or x1/2 sqrt(x)
n
√

x x^(1/n)
|x| or abs(x) abs(x)
max(a,b,c) or a∨b∨ c max(a,b,c)
min(a,b,c) or a∧b∧ c min(a,b,c)
gcd(x2 +1,x+1) gcd(x^2+1,x+1)
lcm(x2 +1,x+1) lcm(x^2+1,x+1)⌊ 123

34

⌋
Ĕoor(123/34)⌈ 123

34

⌉
ceil(123/34)(6

2

)
binomial(6,2)

x! x!
123mod17 123 mod 17
an modm powermod(a,n,m)
3x3 +2xmodx2 +1 divide + Rem
{a,b}∪{b,c} {a,b} union {b,c}

{a,b}∩{b,c} {a,b}intersect{b,c}
signum(x) sign(x)

Trigonometry
SWP/SNB MuPAD SWP/SNB MuPAD
sinx or sin(x) sin(x) cotx or cot(x) cot(x)
cosx or cos(x) cos(x) secx or sec(x) sec(x)
tanx or tan(x) tan(x) cscx or csc(x) csc(x)
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Trigonometry
SWP/SNB MuPAD
arcsinx or sin−1 x or arcsin(x) or sin−1(x) arcsin(x)
arccosx or cos−1 x or arccos(x) or cos−1(x) arccos(x)
arctanx or tan−1 x or arctan(x) or tan−1(x) arctan(x)
arccotx or cot−1 x or arccot(x) or cot−1 (x) arccot(x)
arcsecx or sec−1 x or arcsec(x) or sec−1 (x) arcsec(x)
arccscx or csc−1 x or arccsc(x) or csc−1 (x) arccsc(x)

Exponential, Logarithmic, and Hyperbolic Functions
SWP/SNB MuPAD
ex or exp(x) exp(x)
logx or lnx ln(x)
log10 x or log10(x) ln(x)/ln(10)
sinhx or sinh(x) sinh(x)
coshx or cosh(x) cosh(x)
tanhx or tanh(x) tanh(x)
cothx or coth(x) coth(x)
cosh−1 x or cosh−1(x) arccosh(x)
sinh−1 x or sinh−1(x) arcsinh(x)
tanh−1 x or tanh−1(x) arctanh(x)

Calculus
SWP/SNB MuPAD
d
dx (xsinx) diff(x*sin(x),x)

f ′,D f ,D D(f )

f ′(3) D(f )(3)∫
xsinxdx int(x*sin(x),x)∫ 1

0 xsinxdx int(x*sin(x),x = 0..1)

limx→0
sinx

x limit(sin(x)/x,x=0)

∑∞
i=1

i2
2i sum(i^2/2^i, i = 1..inđnity)
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Complex Numbers
SWP/SNB MuPAD Comments
Re(z) Re(z) Real part a of z = a+bi
Im(z) Im(z) Imaginary part b of z = a+bi

|z| abs(z) |z|=
√
(Re(z))2 +(Im(z))2

csgn(z)

 1 if Re(z)> 0; or Re(z) = 0 and Im(z)> 0
0 if z = 0
−1 if Re(z)< 0; or Re(z) = 0 and Im(z)< 0

signum(z) sign(z)

{ z
|z|

if z ̸= 0

0 if z = 0

z∗ or z conjugate(z) z∗ = Re(z)− Im(z) i

arg(z) atan(Im(z)/Re(z)) z = |z|eiarg(z)

Linear Algebra
SWP/SNB MuPAD Comments(

1 2 3
4 5 6

)
array(1..2,1..3,[[1,2,3],[4,5,6]]) matrix

AB A*B matrix product

A−1 A^(-1) matrix inverse

AT linalg::transpose(A) matrix transpose

Amod17 map(A, x -> x mod 17)

AH conjugate + linalg::transpose Hermitian transpose

AB−1 A*B^(-1)

A−1 mod17 map(A^(-1), x -> x mod 17)

∥x∥n norm(x,n) n-norm

∥x∥F norm(x,Frobenius) Frobenius norm

∥x∥∞ norm(x,Inđnity) inđnity norm
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Vector Calculus
SWP/SNB MuPAD Comments
∇xyz linalg::grad(x*y*z,[x,y,z]) gradient
∥(1,−3,4)∥p norm( SWPmatrix(1,3,[[1,-3,4]]),p) p-norm
v×w linalg::crossProduct(S,T) cross product
S ·T linalg::scalarProduct(S,T)
∇ · (x,xy,y− z) linalg::divergence([x,x*y,y-z],[x,y,z]) divergence
∇× (x,xy,y− z) linalg::curl([x,x*y,y-z],[x,y,z]) curl

∇2 (x2yz3
)

linalg::divergence(linalg::grad(x^2*y*z^3,[x,y,z]),[x,y,z]) Laplacian

Differential Equations
SWP/SNB MuPAD Comments
F ( f (t) , t,w) transform::fourier(expr,t,w) Fourier transform
F−1 ( f (t) , t,w) transform::ifourier(expr,t,w) inverse Fourier transform
L ( f (s) ,s, t) transform::laplace(expr,t,s) Laplace transform
L −1 ( f (s) ,s, t) transform::ilaplace(expr,s,t) inverse Laplace transform
Dirac(x), Dirac(x,n) dirac(x), dirac(x,n) Dirac function, nth derivative of Dirac function

Heaviside(x) heaviside(x) Heaviside function


0 if x < 0
1
2 if x = 0
1 if x > 0

Statistics
SWP/SNB Comments
NormalDist, NormalDen, NormalInv Normal distribution
TDist, TDen, TInv Student’s t distribution
ChiSquareDist, ChiSquareDen, ChiSquareInv Chi Square distribution
FDist, FDen, FInv F distribution
ExponentialDist, ExponentialDen, ExponentialInv Exponential distribution
WeibullDist, WeibullDen, WeibullInv Weibull distribution
GammaDist, GammaDen, GammaInv Gamma distribution
BetaDist, BetaDen, BetaInv Beta distribution
CauchyDist, CauchyDen, CauchyInv Cauchy distribution
UniformDist, UniformDen Uniform distribution
BinomialDist, BinomialDen Binomial distribution
PoissonDist, PoissonDen Poisson distribution
HypergeomDist, HypergeomDen Hypergeometric distribution
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Special Functions
SWP/SNB MuPAD Comments
BesselIv (z) besselI(v,z) Alternate notation: Iv(z)
BesselKv (z) besselK(v,z) Alternate notation: Kv(z)
BesselJv (z) besselJ(v,z) Alternate notation: Jv(z)
BesselYv (z) besselY(v,z) Alternate notation: Yv(z)

Beta(x,y) beta(x,y) Beta function:
Γ(x)Γ(y)
Γ(x+ y)

dilog(x) dilog(x)
∫ x

1
ln t

1− t
dt

erf(x) erf(x) error function: 2√
π
∫ x

0 e−t2
dt

1− erf(x) erfc(x) complementary error function
F ( f (t) , t,w) transform::fourier(f(t),t,w) Fourier transform
LambertW(x) lambertW(x) LambertW(x)eLambertW(x) = x
L ( f (t), t,s) transform::laplace(f(t),t,s) Laplace transform
polylog(k,x) heaviside(x) polylogarithm: polylog(k,x) = ∑∞

n=1
xn

nk

bernoulli(n) bernoulli(n) nth Bernoulli number
t

et−1 = ∑∞
n=1 bernoulli(n) tn

n!

bernoulli(n,x) bernoulli(n,x) nth Bernoulli polynomial
text

et−1 = ∑∞
n=1 bernoulli(n,x) tn

n!
Chi(z) hyperbolic cosine integral:

gamma+lnz−
∫ z

0
1−cosh t

t dt (arg(z)< π)
Ci(x) Ci(x) cosine integral: gamma+ lnx−

∫ x
0

1−cos t
t dt

Ei(x) eint(x) exponential integral:
∫ x
−∞

et

t dt

Γ(z) igamma(z,0) Gamma function:
∫ ∞

0 e−ttz−1dt

Γ(a,z) igamma(a,z) incomplete Gamma function:
∫ ∞

z e−tta−1dt

Si(x) Si(x) sine integral:
∫ x

0
sin t

t dt

Shi(x) hyperbolic sine integral:
∫ x

0
sinh t

t dt

Psi(x) psi(x) Psi function: ψ (x) = d
dx lnΓ(x)

Psi(x,n) psi(x,n) nth derivative of Psi function

ζ (s) zeta(x) Zeta function: ζ (s) = ∑∞
n=1

1
ns for s > 1
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A
about, 112, 237
absolute convergence, 263
absolute value

complex number, 33
integration, 233
number, 27
plots, 157
symbol, 27

acre, 498
activity, 498
addition

complex numbers, 33
general, 7
matrices, 294
numbers, 20
polynomials, 40
trigonometric formulas, 82
vectors, 344

additionally, 112, 237
adjoint

classical adjoint, 310
Hermitian transpose, 308

adjugate, 310
algebra of functions, 106
allowable assumptions, 112

ambiguous notation, 8, 211
amount of substance, 498
ampere, 499
amplitude, 89
and, logical

intersection, 32
logical operator, 31
minimum or meet, 28

angle
conversions, 35
degrees and radians, 77
notation, 77, 503

ångström, 501
animated plots

2D plots, 165
3D plots, 172, 189
gradient đeld 2D, 367
gradient đeld 3D, 370
vector đeld 2D, 365
vector đeld 3D, 367

antiderivative, 226
Approximate Integral

Leĕ Boxes, 240, 248
Lower Absolute Boxes, 243
Lower Boxes, 241
Midpoint, 246

Right Boxes, 240, 248
Simpson, 245, 251
Trapezoid, 244, 250
Upper Absolute Boxes, 243

approximation
continued fractions, 446
Evaluate Numeric, 26
integrals, 246
linear regression, 436
Newton’s method by iteration,

217
numerical integration, 253
polynomial đt to data, 437
power series, 265
rational, 446
Riemann sums, 238

Approximatre Integral
Upper Boxes, 241

arbitrary constant, 8
arbitrary functions, 212
arc length, 254
area, 498
arg, 89
argument

complex number, 89
function, 99
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ordinary and trigtype
functions, 123

arithmetic mean, 411
arithmetic-geometric mean, 278
arrows, 10
assigning values to variables, 47,

59
assignment

deferred evaluation, 104
deđning variables, 103
full evaluation, 105

assume
assumptions about variables,

111
calculus example, 237
real, 49

asymptotes, 141
atmosphere, 503
automatic selection, 12
automatic substitution, 102, 512
average, 411
Axes Scaling, 511
Axes Type

2D plots, 144, 146
axis scaling, 143

B
band matrix, 289
bar, 503
bar chart, 162
base of log, 67, 507
basic guidelines, 7
basis

column space, 323
nullspaces, 323
orthonormal, 325
rank of matrix, 326
row space, 321
variables, 359

BCH code, 463

becquerel, 498
Bernoulli

number, 526
polynomial, 526

Bessel functions, 392, 405
beta

distribution, 430
function, 526

binary
operations, 10
relations, 10, 12
representation, 461

binomial
coefficients, 22, 432
distribution, 432
Rewrite Factorial, 23

block cipher, 455
blood Ĕow problem, 278
brackets

built-in delimiters, 286
choosing and entering, 5
expanding, 6

British thermal unit, 500

C
Calculus, see calculus

Approximate Integral, 246
Change Variable, 229
Change Variables, 234
Find Extrema, 220, 270
Implicit Differentiation, 111,

213
Integrate by Parts, 228, 234
Iterate, 216
Partial Fractions, 230, 234
Plot Approx. Integral, 238

calculus, seeCalculus
deđnite integral, 231
derivative, 209
evaluate expression, 201

indeđnite integral, 226
limit, 202
Newton’s method, 217
plotting derivatives, 212

calorie, 500
candela, 502
carrier waves, 163
case function, 62, 108
Cauchy distribution, 431
Cayley-Hamilton theorem, 317
ceiling function, 29
celsius, 504
center

graphics, 6
mathematics, 6
text, 6

chain rule, 213
Change from i to j, 508
Change Variable, 229
characteristic

matrix, 328
polynomial, 317
value, 318
vector, 318

Check Equality, 30
chi-square distribution, 426
Chinese remainder theorem, 452
Cholesky Decomposition, 336
circle center and radius, 74
Clear Deđnitions, 115
code word, 463
coefficient of correlation, 420
cofactor, 310
Collect, 44
column

matrix, 290
select, 15
space, 323

Combine
Arctan, 84
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Exponentials, 65
Hyperbolic Trig Functions, 87
Logs, 67
Powers, 65
Trig Functions, 83

companion matrix, 329
completing a square, 71
complex conjugate, 33, 346, 508
complex numbers

absolute value, 33
argument, 89
assume, 112
basic operations, 32
complex conjugate, 33
complex powers and roots, 91
form, 89
imaginary unit i or j, 32
polar form, 90
real and imaginary part, 33
rectangular form, 33, 90
trigonometric form, 90

complex or real default, 49
components, 341
composition of functions, 106
compound units, 35
Compute menu, 516
computing, 7
computing in place, 16
Concatenate, 208, 292
concave upward, 225
Condition Number, 315
conformal plot, 379
congruence

inverse modulo m, 450
matrix modulo m, 454
modulo m, 448
modulo polynomial, 456
polynomials modulo

polynomials, 456
solving linear congruences,

451
conjugate, 33
conjugate transpose, 308
constant of integration, 226
constants

generic constants, 111
MuPAD constants, 515
π, i,e, 8

constrained optima
Find Extrema, 270
Lagrange multipliers, 271

constraints, 463
conventions, 2
correlation, 420
cosecant, 76
cosine, 75
cotangent, 76
coulomb, 499
covariance, 418
cross product, 347
cubic meter, 504
cumulative distribution function,

421
curie, 498
curl, 361
current, 499
cursor, 4
curve đtting, 436, 437
curve sketching, 222
curves in space

polygonal paths, 181
rectangular plot, 178
tube plots, 179

custom name, 100
custom settings

Change from i to j, 32
imaginary unit, 32
input, 507
scope, 507
sidebars, 507

toolbars, 506
customer support, ix
customizing computation

settings, see Settings
cylindrical coordinates, 184

D
data

2D plots, 159
3D plots, 181
convert list to matrix, 293, 410
đtting curves to data, 436
random numbers, 435
reshape lists and matrices, 293

day, 504
decimal notation, 23
deferred evaluation, 104
Deđne MuPAD Name, 446
deđned function

2D plots, 153
3D plots, 174
valid names, 100

deđnite integral
midpoint rule, 246
notation, 232
Simpson’s rule, 245, 251
trapezoid rule, 244, 250
using the deđnition, 237

Deđniteness Tests, 320
deđnition, see assignment

deferred evaluation, 104
deđning a variable, 59
full evaluation, 105
function of one variable, 106
function of several variables,

111
generic constant, 111
generic function, 110, 212
making a deđnition, 59
remove a deđnition, 115
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subscripted function, 107
valid names, 100

Deđnitions, see deđnition
Clear Deđnitions, 115
Deđne MuPAD Name, 119
New Deđnition, 59, 103, 106,

107
Show Deđnitions, 115
Undeđne, 115

degrees
degrees and radians, 77
keyboard shortcut, 503
notation and behavior, 77
plot trig functions, 152
unit names, 504

delimiters, 11
DeMoivre’s theorem, 91
derivative

2D plot, 212
deđnition, 209
directional, 363
implicit, 213
notation, 202, 209, 507, 509
piecewise-deđned functions,

211
Descartes, folium, 196
determinant, 309
difference of sets, 32
differential, 274
differential equations

Bessel functions, 392, 405
direction đeld, 364
exact method, 386
graphical solutions, 401
initial-value problems, 400,

401
Laplace method, 389
linear, 386
numerical solutions, 400, 402
ordinary, 385

series solutions, 389
Solve ODE, 400
systems of equations, 402

digits in computations, 510
Digits Rendered, 508
Digits rendered, 66, 67
Dirac function, 390
direction, 356
direction đeld, 364
directional derivative, 363
discontinuities, 142
display, 14

graphics, 6
mathematics, 6
text, 6

distribution, see statistics
continuous distributions, 423
discrete distributions, 432
function, 421
tables, 423

divergence, 360
divide

division, 20
divisors, 119
general, 7
integers, 21
polynomials, 41

domain, 111
dot product, 294, 308, 346
double integral, 276
double-angle formulas, 82
dual of a linear program, 465
dyne, 500

E
e, 8, 508, 515
echelon forms, 298
Eigenvalues, 318
Eigenvectors, 318
electric

capacitance, 499
charge, 499
conductance, 499
potential difference, 499
resistance, 500

electron volt, 500
elementary

Jordan matrix, 332
matrix, 300
number theory, 21
row operations, 300

ellipsoid, 176
elliptic integral, 277
email technical support, ix
empty set, 32, 49
energy, 500
Engine settings

Debugging, 511
Engine on, 18
Ignore Special Cases, 68
Maximum Degree, 510
Principal Value Only, 68

envelope, 163
equality

Check Equality, 30
logical operators, 31

equations, trigonometry, 78
equivalent matrices, 327
erf, 526
erg, 500
error function, 526
Euclidean

algorithm for polynomials,
456

norm, 312, 314
plane, 75

Euler identity, 90
Evaluate

add numbers, 20
at endpoints, 47, 204
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calculus expression, 201
expression, 7
matrices, 294
multiply numbers, 20
polynomial, 40
series, 262

Evaluate Numeric, 26
evaluation

deferred evaluation, 103
full evaluation, 103, 105

exact solutions, 52
exp, 66
Expand

complex trigonometric
functions, 92

polynomial, 40
expanding brackets, 5
exponential distribution, 428
exponential equations, 68
exponential function

complex numbers, 90
laws of exponents, 66
matrices, 316
notation, 65

exponential integral, 526
exponents, 5, 24
expressions

naming expressions, 103
plotting expressions, 151
valid names, 100

external functions, 119
extreme values

Find Extrema, 220, 270
Lagrange multipliers, 271
on a curve, 219
on a surface, 268

F
F distribution, 427
Factor

integer, 21
polynomial, 44

factorial, 22, 423
fahrenheit, 504
farad, 499
feasible system, 464
fence, 5
Fermat’s little theorem, 453
Fill Matrix

Band, 289
example, 206

Find Extrema, 220
đnite đeld, 459
Ĕoating point, 23, 26
Ĕoor function, 448

greatest integer, 29
foot, 501
footcandle, 501
force, 500
Formula, 115
Fourier transform, 395
fraction

mixed number, 21
notation, 8
rationalize denominator, 25
template, 5

frequency, 501
Frobenius form, 330
Frobenius norm, 314
full evaluation, 105
function name, 99

subscripts as function
arguments, 107

valid names, 100
functions, see distributions

absolute value, 33
algebra and number theory,

522
assume real, 49
beta function, 430

built-in, 522
calculus, 523
ceiling, 29
complex numbers, 524
deđning case functions, 108
deđning generic functions, 110
deđnitions, 59
differential equations, 525
Ĕoor, 29
Gamma, 423
greatest integer, 29
Im, 33
inverse, 60
istrue, 31
linear algebra, 524
menu items, 516
MuPAD , 522
notation, 99
piecewise deđnition, 108
plotting, 151
Re, 33
smallest integer, 29
special functions, 526
statistics, 525
step, 29
tables of equivalents, 515
trigonometry, 522
trigtype, 122
valid names, 100
vector calculus, 525

fundamental theorem
algebra, 49
calculus, 278

G
gallon, 504
Galois đeld

integers mod p, 450
inverse, 462
irreducible polynomial, 459
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product, 462
Γ, 526
gamma, 515
gamma distribution, 429
Gamma function

deđnition, 526
plot, 157
statistics, 423

gauss, 502
Gaussian Elimination, 299
gcd

integers, 22
polynomials, 46, 457

generic constants, 111
generic functions, 110, 212
Geometric Mean, 414
GF16, 462
GF4, 460
GFpn , 460
gradient

đeld, 367
optimization, 271
vector calculus, 358

gram, 502
Gram-Schmidt

orthogonalization, 326
Graph User Settings, 140
graphical solutions

initial-value problems, 401
systems of ODEs, 404

greatest common divisor
integers, 22
polynomials, 46

greatest integer function, 29
Greek letters, 9
green unit symbol, 77
grid, 163

H
Harmonic Mean, 415

Heaviside function, 158, 390
hectare, 498
help

additional information, x
discussion forum, x
technical support, ix

henry, 502
Hermite Normal Form, 328
Hermitian Transpose, 308
hertz, 501
Hessian, 375
highlight, 5
Hilbert matrix, 287
Hilbert-Schmidt norm, 314
histogram, 162
horsepower, 503
hour, 504
hyperbolic

cosine integral, 526
function inverse, 88
functions, 86
sine integral, 526

hyperboloid, 176
hypergeometric distribution, 434

I
i, 8, 509
Ignore Special Cases, 68, 511
ill-formed expressions, 211
illuminance, 501
imaginary

part, 33
unit, 32, 508

Implicit
Plot 2D, 132
Plot 3D, 177

Implicit Differentiation, 213
improper integrals

deđnite integrals, 235
example, 236, 278

in-place computations, 16, 203
inch, 501
indeđnite integral, 226
index symbol, 8
inequality

numbers, 30
plot, 136
solve, 58

∞-norm, 313
initial conditions, 386
initial-value problems, 400
inline plots, 148
inner product

matrices, 294
parallelepiped volume, 350
using transpose, 308
vectors, 346

input settings
Base of Log, 67
Input page, 507

Insert, seeMath Objects
Math, 1, 4, 20
Math Objects, 492
Text, 4, 20

insert point, 4
integer

modulo m, 448
restraint, 112
solutions, 445

integrable function, 231
integral

blood Ĕow problem, 278
change of variable, 234
computing volumes, 274
deđnite, 231
improper, 235
indeđnite, 226
integration by parts, 234
iterated, 274
notation, 202
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numerical integration, 253
partial fractions, 234
piecewise-deđned functions,

226
integral test, 264
integral transform, 391
Integrate by Parts, 228
interactive plot tools, 138
interchange matrix rows, 301
Interpret, 8, 211, 227
intersection, 32
inverse

distribution function, 422
function, 60
function plot, 135
hyperbolic functions, 88
matrices, 296
modulo m, 450
trigonometric functions, 83

inverse function, 106
irreducible polynomial, 459
irrotational, 372
Is prime, 119
istrue, 31
iterated integral

deđnite integrals, 274
indeđnite integrals, 276

iteration
Newton iteration function,

218
solving equations, 216

Ithprime, 120

J
Jacobian, 377
join, 28, 31
Jordan Normal Form, 332
joule, 500

K
kelvin, 504

keyboard conventions, 2
keyboard shortcuts

algebra, 69
common tasks, 11
entering units, 34, 497
Greek characters, 494
matrix, 336
symbols and characters, 492
TeX commands, 495

kilogram, 502

L
Lagrange multiplier, 271
Laplace method, 389
Laplace transform, 391
Laplacian, 362
law of cosines, 94
law of sines, 94
layout properties, 147
lcm

integers, 22
polynomials, 46

least common multiple
integers, 22
polynomials, 46

least positive residue, 450
least-squares solution, 439
Leĕ Boxes, 240, 244, 245, 248
length

units of length, 501
vector, 312

level curve, 269
limit, 202

at inđnity, 205
inđnite, 205
notation, 203
one-sided, 205

line
graph, 162
style, 141

vector equation, 356
linear programming, see Simplex

constraints, 464
dual, 465
objective function, 464
standard form, 465

linear regression, 436
list of data, 410
liter, 504
local maximum, 219
local minimum, 219
local minimum and maximum on

a surface, 268
logarithmic function, 65
logarithms

base, 67
notation, 67

logical operators, 31
long division

integers, 21
polynomials, 41

Lower Absolute Boxes, 243
Lower Boxes, 241
lumen, 501
luminance, 501
luminous Ĕux, 501
luminous intensity, 502
lux, 501

M
MacKichan Soĕware, ix
Maclaurin series, 265
magnetic

Ĕux, 502
Ĕux density, 502
inductance, 501, 502

making assumptions about
variables, 237

mass, 502
Math Name, 100
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Math Objects
Binomial, 23
Brackets, 6, 62
Display, 6, 55
Formula, 115
Fraction, 5, 20
Math Name, 100
Matrix, 15, 55
Operator, 41, 202
Radical, 5, 25
Subscript, 5, 24
Superscript, 5, 24
Unit Name, 34

Math toolbar, 9
Math/Text button, 4
mathematics mode, 4, 490
Matrices, seematrix

Adjugate, 310
Characteristic Polynomial, 317
Cholesky Decomposition, 336
Column Basis, 323
Concatenate, 292
Condition Number, 315
Deđniteness Tests, 320
Determinant, 309
Eigenvalues, 315, 318
Eigenvectors, 318
Fraction-Free Gaussian

Elimination, 299
Gaussian Elimination, 299
Hermite Normal Form, 328
Hermitian Transpose, 308
Inverse, 295
Jordan Normal Form, 332
Minimal Polynomial, 317
Norm, 312, 352
Nullspace Basis, 323
Orthogonality Test, 324
Permanent, 311
PLU Decomposition, 335

QR Decomposition, 325, 336
Rank, 326
Rational Canonical Form, 329
Reduced Row Echelon Form,

299
Reshape, 293, 410
Row Basis, 321
Singular Value

Decomposition, 334
Singular Values, 334
Smith Normal Form, 327
Spectral Radius, 314
Stack, 292
Trace, 307
Transpose, 307

matrix, seeMatrices
addition, 294
additive inverse, 297
adjugate, 310
algebra, 285
alignment, 291
brackets, 286
classical adjoint, 310
cofactor, 310
column space, 323
companion matrix, 329
convert equations to matrix,

304
convert matrix to equations,

304
deđnition, 285
deleting rows and columns,

290
determinant, 309
echelon forms, 298
elementary, 300
elementary row operations,

300
entries, 285
equations, 302

equivalence, 327
exponential functions, 316
Frobenius form, 330
identity, 295
insert rows and columns, 290
inverse, 296
Jordan form, 332
matrix equations, 302
matrix multiplication, 294
maximum entry, 311
minimum entry, 311
modulo m, 454
normal form, 327, 328
notation, 286
nullspace, 323
operations on entries, 298
orthogonal, 325, 336
orthonormal columns, 325
polynomial expressions, 297
positive deđnite, 320
powers, 294, 296
product, 294
projection matrix, 338
rational canonical form, 330
replacing a block of cells, 291
row operations, 298
row space, 321
scalar multiplication, 294
screen appearance, 286, 287
similar, 326
swap rows, 301
transpose, 307
unitary, 334

matrix operator
adjugate, 310
condition number, 315
determinant, 309
Euclidean norm, 312
exponential function, 316
Hermitian transpose, 308
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Hilbert-Schmidt (Frobenius)
norm, 314

∞-norm, 313
maximum and minimum, 311
norm, 312
1-norm, 313
permanent, 311
trace, 307
transpose, 307

maximum
degree, 53, 510
đnite sequence, 29
join, 28
matrix entries, 311
numbers, 28
optimization, 219

maxwell, 502
Mean

Geometric Mean, 414
Harmonic Mean, 415
Mean, 411

Mean Deviation, 416
Median, 412
meet, 28, 31
meter, 501
methods of integration

change of variable, 229, 234
integration by parts, 228, 234
partial fractions, 230, 234

Middle Boxes, 238
midpoint rule, 246
mile, 501
minimal polynomial, 317
minimum

đnite sequence, 29
matrix entries, 311
meet, 28
numbers, 28
optimization, 219
polynomial, 317

minute, 503, 504
miscellaneous symbols, 10
mixed number, 21
mixed number output, 508
mod function, 448
mode, 413
modern algebra, 445
modulo, 448
mole, 498
moment, 419
mouse pointer, 4
multicase function, 62, 108
multiple choice examination

formula, 118
multiple integral, 274
Multiple Regression, 436
multiple roots, 458
multiple-angle formulas, 82
multiplication

general, 7
inner product, 294
matrices, 294
matrices by scalars, 294
numbers, 20
polynomials, 40
vector cross product, 347
vector dot product, 346
vector with scalar, 345

multiplicity of a root, 458
multivariable calculus, 268
MuPAD

constants, 515
engine, 18
functions, 119, 516
swapRow, 301

N
nabla symbol, 358
naming expressions

deđnitions, 103

valid names, 100
naming functions

subscripts as arguments, 107
valid names, 100

natural linear notation, 8
negated relations, 10
negative, 112
New Deđnition

assignment, 103
function, 60, 106
function and expression

names, 100
variables, 59

newton, 500
Newton iteration function, 218
Newton’s method, 217, 218
nextprime, 119, 453
no rules, 7
nonzero, 112
Norm, 312
normal distribution, 424
notation, 2
null delimiter, 108
nullspace, 323
number theory

lcm and gcd, 22
prime numbers, 21

numbers
basic operations, 23
complex numbers, 32
mathematics mode, 19
mixed numbers, 21
real numbers, 23
symbolic, 23

numerical
integration, 253
results, 26
solutions to ODEs, 400

O
objective function, 464
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ohm, 500
1-norm, 313
one-parameter family, 386
Operator, 100, 202
optimization

Find Extrema, 270
Lagrange multipliers, 271
local extremes, 219
several variables, 268

or, logical
logical operator, 31
maximum or join, 28
union, 32

order of integration, 276
ordered pair, 341
ordered triple, 341
ordinary differential equation

initial conditions, 386
series solutions, 389, 399
solve systems, 397

orientation of 3D plot, 174
orthogonal matrix, 324, 334
Orthogonality Test, 324
orthonormal, 324, 325, 334, 336
ounce-force, 500
output

differential , 510
exponential, 510
imaginary i, 509

output settings, 508
overdetermined systems, 439

P
parallelepiped, 350
parallelogram, 352
parametric equations, 258
parametric plot, 134
parametric polar plot, 164
parentheses and trig type

functions, 76

partial derivatives
extreme values on a surface,

268
notation, 209

Partial Fractions
algebra, 43
integration, 230

partial sums, 262
pascal, 503
Passthru Code to Engine, 121
pentagon, 136, 160
percentile, 412
Permanent, 311
Phi, 119
ϕ , 119
phot, 501
Physical õuantity, see units
π , 8, 515
piecewise-deđned function

deđnite integral, 233
deđnition, 62
derivative, 211
indeđnite integral, 226
notation, 108

pint, 504
plane

in 3-space, 354
vector equation, 353

plane angle, 503
Plot 2D

Approximate Integral, 239
Conformal, 379
Gradient, 367
Implicit, 132
Inequality, 136
ODE, 401
Parametric, 134
Polar, 131, 164
Rectangular, 131
Vector Field, 364

Plot 2D Animated
Conformal, 380
Gradient, 370
Implicit, 170
Inequality, 170
Parametric, 167
Polar, 168
Rectangular, 165
Vector Field, 365

Plot 3D
Curve in Space, 178
Cylindrical, 183
Gradient, 370
Implicit, 177
Parametric, 175
Rectangular, 171
Spherical, 185
Tube, 179, 256
Vector Field, 366

Plot 3D Animated
Curve, 191
Cylindrical, 192
Gradient, 372
Implicit, 194
Parametric, 190
Rectangular, 173, 190
Spherical, 193
Tube, 195
Vector Field, 367

Plot Approximate Integral
Leĕ Boxes, 240
Lower Absolute Boxes, 243
Lower Boxes, 241
Middle Boxes, 238
Right Boxes, 240
Upper Absolute Boxes, 243
Upper Boxes, 241

plot coordinates, 139
plot inverse function, 135
Plot Properties, 140
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Items Plotted, 140
plotting

adding expression, 130
discontinuities, 142
envelope, 163
expressions, 129, 151
grid, 163
inverse, 133, 135
multiple expressions, 152
piecewise function, 155
points, 141
Riemann sums, 238
tools, 138, 165
zoom tool, 139

PLU Decomposition, 335
point marker, 141
point plots, 159
Poisson distribution, 433
polar

coordinates, 90, 131
form, 89, 90
plots, 259

polygon, 181
polygonal path plot, 159
Polynomials, see polynomials

Collect, 44
Companion Matrix, 329
Divide, 41, 224
Partial Fractions, 43, 230
Roots, 48, 49
Sort, 44

polynomials
collecting and ordering terms,

44
congruent, 456
Factor, 44
general form, 39
greatest common divisor, 457
irreducible, 459
long division, 41

matrix values, 297
modulo m, 455
modulo polynomials, 456
roots of 3rd- and 4th-degree

polynomials, 50
roots of đĕh and higher degree

polynomials, 51
roots of second-degree

polynomials, 49
positive, 112
positive deđnite symmetric

matrix, 320
potential

scalar, 372
vector, 373

pound-force, 500
pound-mass, 502
power, 503
Power Series, 265
powers

complex powers, 91
modulo m, 453
notation, 24
power series, 265

pressure, 503
prime number, 21
Principal Value Only, 68, 93, 510
probability density function, 421
problems and solutions

algebra, 70
applied modern algebra, 466
calculus, 277
differential equations, 407
function deđnitions, 124
matrices, 337
numbers and units, 36
plotting, 196
statistics, 440
trigonometry, 93
vector calculus, 381

product
formula, 213
polynomials, 40

program resources, ix
projection matrix, 338
Psi function, 526
Pythagorean identities, 82

Q
QR Decomposition, 325, 336
õuantile, 412
quart, 504
quotient of polynomials, 41
quotient rule, 213

R
radian, 503
radical notation, 24
Random Numbers, 435
Rank, 326
ratio test, 263
rational canonical form, 330
rational expression, 41
rationalize denominator, 25
real

assume, 112
default for real roots, 49
real part of complex number,

33
recognizing constants, 8
rectangular coordinates, 131
recursion, 447
regression, 436
removing deđnitions, 115
reshape

list, 293
lists and matrices, 410
matrix, 293

residue, 448
resize a plot, 147
restraints on variables, 111
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restrict domain, 111
resultant, 119
revise matrix, 290
Rewrite

Arccos, 85
Arccot, 85
Arcsin, 84
Arctan, 85
Cos, 81
Equations as Matrix, 304
Exponential, 86
Factorial, 23, 423
Float, 24, 26
Gamma, 424
Logarithm, 88
Matrix as Equations, 304
Mixed, 21
Normal Form, 42
Polar, 90
Rational, 23, 42
Rectangular, 48, 90
Sin, 81
Sin and Cos, 81, 82, 91, 92
Sinh and Cosh, 87
Tan, 81

Riemann sum, 231, 238
Right Boxes, 240, 248
root test, 263
roots

complex roots, 91
exponential notation, 24
numbers, 24
polynomials, 48
radical notation, 24

rotate 3D plot, 174
row echelon forms, 299
row operations, 298
row space, 321
rows, 15, 290

S
scalar potential, 372
scientiđc notation, 26, 508
scope, 507
secant, 76
second, 503, 504
second derivative, 225
selection

automatic, 12
mathematics in a display, 14
mathematics in a matrix, 15
operating on, 16
replacing, 16
user, 15
with the mouse, 5, 16

sequence
đnite, 29
notation, 260
terms as functions, 261

series
integral test, 264
Maclaurin, 265
notation, 262
ratio test, 263
root test, 263
solution, 399
Taylor, 266, 389

set of data, 410
sets

difference, 32
empty set, 32
intersection, 32
union, 32

sidebars, 507
siemens, 499
sigma, 41
similar matrices, 326
similar triangles, 75
Simplex

Dual, 465

Feasible, 464
Maximize, 464
Minimize, 464
Standardize, 465

Simplify
built-in function, 24
mixed numbers, 21
polynomial, 50

Simpson, 245, 251
sine, 75
sine integral, 526
singular value decomposition,

334
singular values, 334
slug, 502
smallest integer function, 29
smallest nonnegative residue, 448
Smith Normal Form, 327
solenoidal, 374
solid angle, 503
solid of revolution

parametric plots, 258
polar plots, 259
rectangular plots, 256
tube plots, 256

solution to ODE, 385
Solve

Exact, 52, 54, 215
Integer, 445
Numeric, 56, 215
Recursion, 447

solve
equations, 13
systems of linear equations,

301
the function ”solve”, 54

Solve ODE
Exact, 386, 398
Laplace, 389, 398
Numeric, 400
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Series, 389
Solve Options

Ignore Special Cases, 68, 511
Maximum Degree, 510
Principal Value Only, 68, 510

solving equations, see Solve
by iteration, 216
inverse trig functions, 85
matrix equations, 302
Newton’s method, 217
trigonometric equations, 78

solving triangles, 94
Sort, 44
Spectral Radius, 314
stacking matrices, 292
Standard deviation, 418
star plot, 136
Statistics, see statistics

Correlation, 420
Covariance, 418
Fit Curve to Data, 436
Geometric Mean, 414
Harmonic Mean, 415
Mean, 411
Mean Deviation, 416
Median, 412
Mode, 413
Moment, 419
õuantile, 412
Random Numbers, 435
Standard Deviation, 417
Variance, 417

statistics, see Statistics
cumulative distributions, 421
distribution
beta, 430
binomial, 432
Cauchy, 431
chi-square, 426
exponential, 428

F, 427
gamma, 429
hypergeometric, 434
normal, 424
Poisson, 433
Student’s t, 425
uniform, 431
Weibull, 428

inverse distribution function,
422

multiple regression, 436
polynomial đt to data, 437
probability density function,

421
statistics functions

BetaDen, 430, 431
BetaDist, 430
BinomialDen, 432
BinomialDist, 432
CauchyDist, 431
ChiSquareDen, 426
ChiSquareDist, 426
ExpenentialDen, 428
ExponentialDist, 428
FDen, 427
FDist, 427
GammaDen, 429
GammaDist, 429
HypergeomDen, 434
HypergeomDist, 434
NormalDen, 424
NormalDist, 424
PoissonDen, 433
PoissonDist, 433
TDen, 425
TDist, 425
UniformDen, 431
UniformDist, 431
WeibullDen, 428
WeibullDist, 428

step function, 29
steradian, 503
stere, 504
stilb, 501
Student’s t distribution, 425
subscript

as function argument, 107
on function name, 100
template, 5

substitution
automatic substitution, 102
change of variable, 229
evaluation, 47, 204

subtraction, 7, 20
summation notation, 41
superscript, 5
surface area, 257
surface of revolution, 180, 257
swap matrix rows, 301
Symbol sidebar, 11
symbolic real numbers, 23
Symbols

shortcuts, 492
toolbar, 9

system of congruences, 452
system of ODEs, 397, 402
systems of equations

differential equations, 402
equations to matrix, 304
linear equations, 302
matrix to equations, 304
notation, 55
solving, 55

T
table of values

from a function, 205
using auxiliary functions, 206

table with formulas, 117
tables of equivalents
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compute menu items, 516
functions, 522

tables of units, 497
tangent function, 76
tangent line, 215, 277
tautology, 31
Taylor polynomials

one variable, 267
two variables, 272

Taylor series, 266
technical support, ix
techniques of integration

change of variable, 229, 234
integration by parts, 228, 234
partial fractions, 230, 234

telephone MacKichan, ix
temperature, 504
tesla, 502
test for multiple roots, 458
Text/Math button, 4
three-dimensional vector, 341
time, 504
Toggle Text/Math button, 4
toll-free number, ix
torr, 503
total differential, 274
Trace, 307
Transforms

Fourier, 395, 396
Inverse Fourier, 396
Inverse Laplace, 393
Laplace, 391

translate view, 139
Transpose, 307
trapezoid rule, 244, 250
trigonometric

form of z, 89
inverse functions, 83

trigonometry
identities, 80

simplifying expressions, 83
solution of triangles, 94
solving trigonometric

equations, 78
trigonometric functions, 75

trigtype functions
argument defaults, 123
parentheses, 76

triple cross product, 349
troubleshooting, ix
Tube, 256
tube plot, 179
two-dimensional vector, 341
2-norm, 312, 352

U
unassume, 112
Undeđne, 115
uniform distribution, 431
union, 32
unit circle, 75
Unit Name, 34
unit pređxes, 498
unitary matrix, 334
units

activity, 498
amount of substance, 498
angle, 503
area, 498
arithmetic operations, 35
compound names, 35
converting, 35
current, 499
degree, 77
electric capacitance, 499
electric charge, 499
electric conductance, 499
electric resistance, 500
electrical potential difference,

499

energy, 500
force, 500
frequency, 501
illuminance, 501
keyboard shortcuts, 497
length, 501
luminance, 501
luminous Ĕux, 501
magnetic Ĕux, 502
magnetic Ĕux density, 502
magnetic inductance, 501, 502
mass, 502
physical units, 33
plane angle, 503
power, 503
pressure, 503
solid angle, 503
temperature, 504
time, 504
volume, 504

Upper Absolute Boxes, 243
Upper Boxes, 241
user selection, 16
user-deđned

functions, 106

V
valid names for deđnitions, 100
Vandermonde matrix, 287
variables

deferred evaluation, 105
deđnitions, 59
full evaluation, 105
making assumptions, 111, 237
valid names, 100

Variance, 417, 418
vector

components, 341
cross product, 347
deđnition, 341
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dot product, 294, 346
inner product, 294, 346
length, 312
matrix notation, 285
norm, 351
notation, 342
product with scalar, 345
sum, 344
triple cross product, 349
triple scalar product, 350

Vector Calculus
Curl, 361
Divergence, 360
Gradient, 358
Hessian, 375
Jacobian, 377
Laplacian, 362
Scalar Potential, 373

Set Basis Variables, 359, 362,
374

Vector Potential, 374
Wronskian, 378

vector calculus, 341
vector equation

line, 356
plane, 353

vector đeld
divergence, 360
plot, 363
solenoidal, 374

vector space
column space, 323
nullspaces, 323
row space, 321

vertical notation, 8
View Intervals

Plot 3D, 171
volt, 499
volume

iterated integral, 274
surface of revolution, 257
units, 504

W
watt, 503
weber, 501, 502
Weibull distribution, 428
Wronskian, 377

Y
year, 504

Z
zeta function, 262, 526
zoom in and out, 139
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