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1 Using Existing SIMPLIS Syntax Files 

The additional SIMPLIS examples not discussed in this guide are listed below. All these examples are available 

in the SIMPLIS examples folder.  
 

Example 1:  Regression of GNP  
 Data File: = None 
 Input Files: EX1A.SPL, EX1B.SPL 

Example 2:  Prediction of Grade Averages 
 Data File: None 
 Input Files: EX2A.SPL, EX2B.SPL 

Example 3:  Union Sentiment of Textile Workers 
 Data File: None 
 Input Files: EX3A.SPL, EX3B.SPL 

Example 4:  Ability and Aspiration 
Data File: EX4.COR 
 Input Files: EX4A.SPL, EX4B.SPL 

Example 5:   Nine Psychological Variables 
 Data File: EX5.COR 
 Input Files: EX5A.SPL, EX5B.SPL 

Example 6:  Stability of Alienation 
 Data File: None 
 Input Files: EX6A.SPL, EX6B.SPL, EX6C.SPL 

Example 7:  Performance and Satisfaction 
 Data File: EX7.DAT 
 Input Files: EX7A.SPL, EX7B.SPL 

Example 8:  Peer Influences on Ambition 
 Data Files: EX8.LAB, EX8.COR, EX8.STD 
 Input Files: EX8A.SPL, EX8B.SPL, 
EX8C.SPL,EX8D.SPL 

Example 9:   Panel Model for Political Efficacy 
 Data Files: PANEL.LAB, PANELUSA.PME, 
PANELUSA.ACP 
 Input Files: EX9A.SPL, EX9B.SPL 

Example 10:  Testing Equality of Factor 
Structures 
 Data File: EX10.COV 
 Input Files: EX10A.SPL, EX10B.SPL, EX10C.SPL, 
EX10D.SPL 

Example 11:  Parental Socioeconomic 
Characteristics 
 Data File: None 
 Input Files: EX11A.SPL, EX11B.SPL 
 

Example 12: Testing Equality of Regressions 
 Data File: EX12.DAT  
 Input Files: EX12A.SPL, EX12B.SPL, EX12C.SPL 

Example 13:  Mean Difference in Verbal Ability 
 Data File: EX12.DAT  
 (Note: Same Data File as for Example 12) 
 Input Files: EX13A.SPL, EX13B.SPL 

Example 14:  Nine Psychological Variables with 
Factor Means 
 Data Files: EX14.LAB, EX14.DAT 
 Input File: EX14.SPL 
 

Example 15:  Regression of Verbal7 on Verbal5 
 Data File: EX12.DAT  
 (Note: Same Data File as for Example 12) 
 Input Files: EX15A.SPL, EX15B.SPL 

Example 16:  Head Start Summer Program 
 Data File: EX16.DAT 
 Input Files: EX16A.SPL, EX16B.SPL, EX16C.SPL, 
EX16D.SPL 

Example 17:  Hypothetical Model 
 Data Files: EX17.COV, EX17.COR 
 Input Files: EX17A.SPL, EX17B.SPL 

 

 

 

To run a SIMPLIS example, select the Open option from the File menu to obtain the Open dialog box. Select (for 

example) ex10a.spl from the SIMPLIS examples folder. Click Open when done.  
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Click the Run LISREL icon button to run ex10a.spl. Alternatively, use the File, Run LISREL option. 

 

 
 

Note that a path diagram is obtained by entering the command "Path Diagram" in the file ex10a.spl, just below 

the line Sample Size = 900 as shown above. The path diagram is displayed in the path diagram window. 
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A text editor window is also opened. A selection of the output contained in ex10a.out is displayed below.  

 

 
 

Once a path diagram is produced, the LISREL menu bar will display a different selection of options, as shown 

next. 

 

 
 

After a path diagram has been obtained, one may select the Draw menu to add paths, change text, etc. The items 

on this menu correspond to the Draw toolbox displayed next to it on the window shown below. 
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The default values shown on the path diagram are the parameter estimates. By selecting the Estimations option 

from the View menu, one may alternatively select the t-values, modification indices, etc. 

 

 
 
 

One may change the number of decimals displayed in the path diagram by selecting SIMPLIS outputs from the 

Output menu. On the dialog box displayed, change the number of decimals from the default value of 2. 

 

 
 

 

The SIMPLIS Outputs dialog box is shown below: 
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The LISREL syntax that corresponds to the SIMPLIS command language in ex10a.spl may be built from the path 

diagram. To do so, select the Setup, Build LISREL Syntax option as shown in the next image. 

 

 
 

 

A LISREL project file (ex10a.lpj) is produced, containing the corresponding LISREL syntax, as shown below.  
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1.1 Changing the Appearance of the Output 

While the output file is opened, one may use the Edit menu to perform various operations such as finding a 

keyword (Find), replacing text (Replace), inserting files (Insert File), etc. 

 

 
 

When output is displayed, one may also use the Options menu to change the font type and size of the text.  

 

2 Using Existing LISREL Syntax Files 

LISREL syntax examples not discussed in detail in this guide are contained in the LISREL examples folder, as 

shown in the table below. *.prl files are in the PRELIS examples folder. 

 
 
Example 1:  Hypothetical model estimated by ML 
  Data File:   EX1.COV 
  Input File:  EX1.LIS 
 

Example 3.1:  Analysis of reader reliability in essay 
scoring 
  Data File:   None 
  Input Files: EX31A.LIS, EX31B.LIS,  EX31C.LIS 

Example 3.2:  Ability and aspiration 
  Data File:   None 
  Input Files: EX32A.LIS, EX32B.LIS 
 

Example 3.3:  Estimating the dis-attenuated correlation 
  Data File:   EX33.COV 
  Input File:  EX33.LIS 

Example 3.4:  Nine Psychological Variables 
 Data File:   EX34.COR 
 Input Files: EX34A.LIS, EX34B.LIS 
 

Example 4.1:  Regression of GNP on economic factors 
 Data File:   EX41.RAW 
 Input File:  EX41.LIS 

Example 4.2:  Stepwise regression 
 Data File:   EX42.COV 
 Input File:  EX42.LIS 

Example 4.3:  ANOVA and ANCOVA 
 Data File:   EX43.RAW 
 Input Files: EX43A.LIS, EX43B.LIS, EX43C.LIS 

Example 4.4:  Bivariate regression 
 Data File:   EX44.RAW 
 Input File:  EX44.LIS 

Example 4.5:  Ambition and attainment 
 Data File:   None 
 Input Files: EX45A.LIS, EX45B.LIS 

Example 4.6:  Klein's model I of US economy 
 Data File:   EX46.DAT 
 Input Files: EX46A.LIS, EX46B.LIS, 
             EX46C.LIS 

Example 5.1: Verbal ability in grades 4 and 5 
 Data File:   EX51.COV 
 Input File:  EX51.LIS 
 

Example 5.2:  Role behavior of farm managers 
 Data Files:  EX52A.COV, EX52B.COV 
 Input Files: EX52A.LIS, EX52B.LIS 

Example 5.3:  Educational attainment 
 Data File:   EX53.COR 
 Input Files: EX53A.LIS, EX53B.LIS, EX53C.LIS 

Example 5.4:  Social status and social participation 
 Data File:   EX54.COR 
 Input File:  EX54.LIS 

Example 5.5:  Peer influences on ambition 
 Data Files:  EX55.LAB, EX55.COR 
 Input Files: EX55A.LIS, EX55B.LIS 
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Example 5.6:   Performance and satisfaction 
 Data File:   EX56.DAT 
 Input File:  EX56.LIS 

Example 6.1: Three subtests of SAT 
 Data File:   None 
 Input File:  EX61.LIS 

Example 6.2:   Second-order factor analysis 
 Data File:   EX62.DAT 
 Input File:  EX62.LIS 

Example 6.3:  The rod and frame test 
 Data File:   EX63.COV 
 Input File:  EX63.LIS 

Example 6.4:  Stability of alienation 
 Data File:   EX64.COV 
 Input Files: EX64A.LIS, EX64B.LIS, EX64C.LIS, 
EX64D.LIS 

Example 6.5:  Change in verbal and quantitative ability  
between grades 7 and 9 
 Data File:   EX65.DAT 
 Input Files: EX65A.LIS, EX65B.LIS 

Example 6.6:  A simplex model for academic 
performance 
 Data File:   EX66.COR 
 Input Files: EX66A.LIS, EX66B.LIS, 
             EX66C.LIS, EX66D.LIS 

Example 7.1:  Attitudes of morality and equality 
Data Files:  EX71.RAW, EX71.PML, EX71.ACP 
Input Files: EX71.PRL, EX71.LIS 

Example 7.2:  A panel model for political efficacy 
 Data Files:  PANEL.LAB, PANELUSA.RAW, 
PANELUSA.PME, PANELUSA.ACE,  PANELUSA.ACP 
 Input Files: EX72A.PRL, EX72B.PRL, EX72A.LIS, 
EX72B.LIS 

Example 7.3:   Factor analysis of dichotomous 
variables 
 Data Files:  LSAT6.DAT, EX73.PML, EX73.ACP 
 Input Files: EX73.PRL, EX73.LIS 

Example 7.4:   Analysis of covariance matrices with 
WLS 
 Data Files:  EX74.RAW, EX74.CML, EX74.ACC 
 Input Files: EX74.PRL, EX74.LIS 

Example 7.5:   Estimating and testing a correlation 
structure 
 Data Files:  EX75.KML, EX75.ACK 
 Input File:  EX75.LIS 

Example 8.1:   Gosta's bad sample 
 Data Files:  EX81.SIG, EX81.COV 
 Input Files: EX81A.LIS, EX81B.LIS, EX81C.LIS, 
EX81D.LIS, EX81E.LIS 

Example 8.2:   Hypothesis testing and power calculation 
Data Files:  EX82.COV, EX82.SIG 
 Input Files: EX82A.LIS, EX82B.LIS, EX82C.LIS, 
EX82D.LIS 

Example 9.1:  Testing equality of factor structures 
 Data File:   EX91.DAT 
 Input Files: EX91A.LIS, EX91B.LIS, EX91C.LIS, 
EX91D.LIS, EX91E.LIS 

Example 9.2:  Testing equality of factor correlation 
matrices 
 Data File:   EX92.COV 
 Input File:  EX92.LIS 

Example 9.3:   Son's and parents' reports of parental 
socioeconomic characteristics 
 Data File:   None 
 Input File:  EX93.LIS 

Example 9.4:   Subjective and objective social class 
 Data File:   EX94.DAT 
 Input File:  EX94.LIS 

Example 10.1:   Nine psychological variables with 
factor means 
 Data File:    EX101.DAT, EX101.LAB 
 Input File:   EX101.LIS 

Example 10.2:   Head start summer program 
 Data File:    EX102.DAT 
 Input File:   EX102.LIS 

Example 10.3:   Estimating a correlation from 
incomplete data 
 Data File:    EX103.DAT 
 Input File:   EX103.LIS 

Example 10.4:   Berkeley guidance study 
 Data Files:   GIRLS.COV, BOYS.COV,  GIRLS.MEA, 
BOYS.MEA  
 Input Files:  EX104A.LIS, EX104B.LIS, EX104C.LIS 

 
Select the Open option from the File menu to obtain the Open dialog box. Select (for example) the file ex31a.lis. 

Click Open when done. The contents of the file ex31a.lis are displayed.  
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To run LISREL, click the Run LISREL icon button. Make sure that the Run LISREL icon button is selected when 

running LISREL or SIMPLIS syntax and that the Run PRELIS icon button is selected when running PRELIS syntax. 

 

 
 

To produce the path diagram shown below, the keyword PD (Path Diagram) was entered between the lines 

containing the words Esayabil and OU in ex31a.lis.  

 

 
 

The file ex31a.out is also produced. This file may be viewed by either closing the path diagram window or by 

clicking on the output window, which is partially hidden behind the path diagram window.  
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2.1 Creating Syntax by Drawing Path Diagrams 

 

LISREL allows the user to create LISREL or SIMPLIS syntax by drawing the appropriate path diagram on the 

screen and then building the corresponding syntax directly from the path diagram. This procedure will be 

demonstrated by fitting a CFA (Confirmatory Factor Analysis) model to the data. To obtain correct standard 

errors of the estimators of the parameters, the CFA model should be fitted to the observed covariance matrix. 

However, in order to illustrate the various features of the program, the model will be fitted to the observed 

correlation matrix. 

 

In confirmatory factor analysis, one builds a model assumed to describe or account for the empirical data in 

terms of relatively few parameters. The model is based on a priori information about the data structure in the 

form of a specified theory or hypothesis or knowledge from previous studies based on extensive data. 

 

Holzinger & Swineford (1939) collected data on twenty-six psychological tests administered to 145 seventh- 

and eighth-grade children in the Grant-White school in Chicago. Six of these tests were selected and for this 

example it was hypothesized that these measure two common factors: visual perception and verbal ability such 

that the first three variables measure visual perception and the last three measure verbal ability. The six selected 

variables and their intercorrelations are given below: 

 
VIS PERC 1.000                
CUBES 0.318 1.000              
LOZENGES 0.436 0.419  1.000          
PAR COMP 0.335 0.234  0.323 1.000       
SEN COMP 0.304 0.157  0.283 0.722 1.000     
WORDMEAN 0.326 0.195  0.350 0.714 0.685  1.000 

 

The path diagram for this model is given below: 

 

 
 

The corresponding SIMPLIS syntax file is: 

 
Six Psychological Variables-A Confirmatory Factor Analysis  
Observed variables  
‘VIS PERC’ CUBES LOZENGES ‘PAR COMP’ ‘SEN COMP’ WORDMEAN  
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Correlation Matrix From File EX5.COR  
Sample Size: 145  
Latent Variables: Visual Verbal  
Relationships:  
‘VIS PERC’ - LOZENGES = Visual  
‘PAR COMP’ - WORDMEAN = Verbal  
Number of decimals = 4  
Print Residuals  
End of Problem 

 

Some important aspects contained in the SIMPLIS syntax file given above are  

o The correlation matrix is read from an external file 

o There are two latent variables in the model: Visual and Verbal 

o The statement Number of decimals = 4 specifies that we wish to have the results in the output file 

given to an accuracy of four decimals. LISREL uses two decimals by default. 

 

2.2 Title, Labels and Data  

 

Select the File, New option and click on Path Diagram. In the Save As dialog box, select a filename and a folder 

in which the path diagram should be saved. For the present example the folder chosen is splex and the file name 

selected is cfa6.pth. When done, click Save. 

 

 
 

From the Output menu select SIMPLIS Outputs. The dialog box below will appear.  
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Customize this dialog box according to your preferences. For example, change the Number of Decimals in the 

Output option to 4. Make sure that the Invoke Path Diagram check box (the default) is checked. When done, 

click OK.  

 

Before drawing the path diagram, select Toolbars from the View menu and ensure that the items shown below 

are selected. These are: Toolbar, Status Bar, Typebar, Variables, Drawing Bar. Also check the Grid Lines option. 

 

 

 
 

Select the Title and Comments option from the Setup menu to obtain the Title and Comments dialog box. 
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The first item on the Title and Comments dialog box is the Title for the analysis. Provision is also made for any 

additional Comments that the user may wish to enter. After typing in the title and (optionally) the comments, 

click on Next to go to the Group Names dialog box. 

 

 

 
 

Since the present example is based on the analysis of one correlation matrix, nothing is entered in the space 

allowed for Group Labels and Next is clicked to go to the Labels dialog box. The default number of variables 

shown on the Labels dialog box is 3, these being CONST, VAR 1 and VAR 2. Click in the CONST textbox and 

change the name to VIS PERC. Enter the label CUBES in the VAR 1 textbox and LOZENGES in the VAR 2 text 

box. Move the mouse cursor into the LOZENGES textbox and use the down arrow to create a fourth text box. 

Type in PAR COMP and repeat the procedure for SEN COMP and WORMEAN.   

 

  
 

In a similar manner, use the down arrow key to create text boxes in the Latent Variables column and enter the 

names Visual and Verbal.  
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When done with the assignment of names, click the Next button to go to the Data dialog box. 

 

 
 

Select Correlations from the Statistics from: drop-down list box and also Correlations from the Matrix to be 

analyzed drop-down list box. In the Number of Observations string field type 145. For File type, select External 

ASCII Data and use the Browse button to locate exs.cor in the SIMPLIS examples folder. Click OK when done.  

 

2.3 Drawing the Path Diagram  
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We now proceed with the actual drawing of the path diagram. Start by clicking on the VIS PERC label under the 

Observed variables portion of the Labels window. Hold the mouse button down and "drag" the label to the draw 

area indicated by the grid lines. A rectangular-shaped object will appear on this part of the screen when the 

mouse button is released as shown below. Note also that 

 

• The observed variables are assumed to be X (or independent) variables unless appropriate squares under 

the Y-column are clicked. 

 

• The latent variables are assumed to be KSI (or independent) variables unless appropriate squares under 

the Eta-column are clicked. 

 

 

 
 

 

Repeat the same procedure for each of the remaining 5 variables by clicking on a label (left mouse button) and 

dragging the object to the draw area on the screen. The result of these operations should look similar to the 

image given below: 
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The rectangles representing the six observed variables can be properly aligned by going through the following 

steps: 

 

o Choose Select all from the Edit menu or draw a rectangle with the mouse pointer around all the 

objects to be included. 

 

o Move the mouse pointer to the vicinity of the selected objects and click the right mouse button. The 

menu shown below will appear on the draw part of the screen.  

 

o Select the Align>Left option. Once this is done, select the Even Space > Vertically option. One can, 

alternatively, use the Align option on the Image menu to achieve this. 
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The rectangular objects will now be aligned and one can proceed by dragging the latent variables, Visual and 

Verbal to the path diagram window. Note that latent variables are represented by elliptically shaped objects. 

 

 
 

 

Finally, arrows can be drawn pointing from the latent variables to the observed variables. To accomplish this, 

click on the single-headed arrow of the Draw toolbar (seen on the right of the picture given below) and move the 

mouse pointer to within one of the elliptically shaped objects. With the left mouse button held down, drag the 

arrow to within a rectangular-shaped object. Release the mouse button when the colors of both objects change. 

Note that the Draw menu on the main menu bar can also be used when drawing path diagrams. Related draw 

tool options are contained in this menu. 
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Proceed in a similar fashion to graphically display the relationships between the observed and latent variables as 

shown on the next image. 

 

 

 
 

 

Select the Build SIMPLIS Syntax option from the Setup menu. SIMPLIS syntax (not shown below) will be built 

from the path diagram and is stored in a system file named cfa6.spj. Click the Run LISREL icon button to fit the 

CFA model to the data. Parameter estimates are shown on the path diagram given below. 
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By modifying the path diagram, model specifications may be changed. The covariance between Visual and 

Verbal may, for example, be fixed at a value of 0.5 by clicking (right mouse button) on the two-headed arrow 

representing this covariance. This will enable the pop-up menu shown below. Select the Fix option using the left 

mouse button. Once done, select the Set Value… option. 
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Click the Run LISREL icon button to fit the revised CFA model to the data. The path diagram, 2 -fit statistic and 

RMSEA are shown below. 

 

 
 

3 Multi-Sample Analyses Using Path Diagrams 

 

In the previous sections we showed how LISREL models may be specified and estimated by drawing the 

appropriate path diagram from which the SIMPLIS or LISREL syntax is created. The examples used were based 

on data from a single sample. The path diagram can, however, also be used to create syntax for models based on 

data from several samples simultaneously, according to a multiple-group LISREL model with some or all 

parameters constrained to be equal over groups.  

 

Consider a set of G mutually exclusive groups of individuals. It is assumed that a number of variables have been 

measured on a number of individuals from each of these populations. This approach is particularly useful in 

comparing a number of treatment and control groups regardless of whether individuals have been assigned to 

the groups randomly or not.  

 

Any LISREL model may be specified and fitted for each group of data. However, LISREL assumes by default that 

the models are identical over groups, i.e., all relationships and all parameters are the same in each group. Thus, 

only differences between groups need to be specified.  
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3.1 Testing Equality of Factor Structures  

 

Table 1 below gives sample covariance matrices for two samples ( 1N = 865, 2N  = 900, respectively) of 

candidates who took the Scholastic Aptitude Test in January 1971. The four measures are, in order, VERBAL40, 

a 40-item verbal aptitude section, VERBAL50, a separately timed 50-item verbal aptitude section, MATH35, a 35-

item math aptitude section, and MATH25, a separately timed 25-item math aptitude section.  

 
Table 1: Covariance Matrices for SAT Verbal and Math Sections 
 
Covariance Matrix for Group 1 
               
Tests VERBAL40 VERBAL50 MATH35 MATH25 
VERBAL40 63.382          
VERBAL50 70.984 110.237       
MATH35 41.710 52.747 60.584    
MATH25 30.218 37.489 36.392 32.295 

 
Covariance Matrix for Group 2 
 
 
Tests 

VERBAL40 VERBAL50 MATH35 MATH25 

VERBAL40 67.898          
VERBAL50 72.301 107.330       
MATH35 40.549 55.347 63.203    
MATH25 28.976 38.896 39.261 35.403 

  

The data are used here to illustrate how one can test equality of factor loadings and factor correlations in a 

confirmatory factor analysis model, while allowing the error variances to be different. 

 

We regard VERBAL40 and VERBAL50 as indicators of a latent variable Verbal and MATH35 and MATH25 as 

indicators of a latent variable Math. The model we consider is shown in the figure below.  

   

 
 

  There are three sets of parameters in the model:  

 

o the four factor loadings corresponding to the paths from Verbal and Math to the observed variables,  

o the correlation between Verbal and Math, and  

o the four error variances of the observed variables.  

 



24 
 

 

 

We begin by constructing a data file pdex10.cov containing the two covariance matrices. In free format, each 

covariance matrix can be written on one line.  

 

 

 
 

We assume that all parameters are the same in both groups. The syntax file pdex10a.spl is:  

 
Group 1: Testing Equality Of Factor Structures Model A: Factor Loadings, Factor Correlation, Error Variances Invariant 
Observed Variables: VERBAL40 VERBAL50 MATH35 MATH25  
Covariance Matrix from File PDEX10.COV  
Sample Size = 865  
Latent Variables: Verbal Math  
Relationships: VERBAL40 VERBAL50 = Verbal  
MATH35 MATH25 = Math  
Group 2: Testing Equality Of Factor Structures  
Covariance Matrix from File PDEX10.COV  
Sample Size = 900  
Set the error variances of VERBAL40-MATH25 free 
End of Problem  
 

In the syntax above, the data in the covariance matrices and the sample sizes are different. The names of the 

variables, observed as well as latent, are the same, and the model is the same.  

 

Select the New option from the File menu and select Path Diagram in the New dialog box. Click OK when done. 

Enter the name pdex10.pth. When done, click Save.  

 

It is possible to control specific SIMPLIS default features such as Maximum Number of Iterations or Method of 

Estimation. From the Output menu, select SIMPLIS Outputs.  

 

 
 

The SIMPLIS Outputs dialog box will appear. Customize this dialog box according to your preferences, for 

example, by changing the Number of Decimals in the Output option to 4 and by making sure that the Invoke path 

diagram option is selected. Click OK when done. 

 

 



25 
 

 

 

 
 

Before drawing the path diagram, select Toolbars from the View menu and ensure that the items shown below 

are selected. These are: Toolbar, Status Bar, Typebar, Variables, Drawing Bar. Optionally, check the Grid Lines 

option. 

 

 

 
 

 

Select the Title and Comments option from the Setup menu to obtain the Titles and Comments dialog box. 
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The first item on the Setup dialog box is the Title for the problem. Provision is also made for any additional 

Comments that the user may wish to enter. After typing in the title and (optionally) the comments, click Next to 

go to the Group Names dialog box. 

 

 
 

Next we enter a description for each group. Group labels can be inserted by clicking on the first string field, 

entering the label for the first group and then using the down arrow on the computer keyboard to create the next 

group’s string field. When done, click Next to go to the Labels dialog box. 

 

 

 
 

The default number of variables shown on the Labels dialog box is 3, these being CONST, VAR 1 and VAR 2. 

Move the mouse pointer to the Observed Variables box and click in the string field of CONST. Rename this 

variable to VERBAL40. Press the "down arrow" on the keyboard to move to the second observed variable string 

field and enter the label VERBAL50. Proceed in a similar way to enter the labels MATH35, MATH 25 and the labels 

Verbal and Math for the latent variables. Click Next when done to go to the Data dialog box. 
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From the Data dialog box, select Covariances from the Statistics from: drop-down list box and also Covariances 

from the Matrix to be analyzed drop-down list box. Enter 865 in the Number of Observations string field. For File 

type select External ASCII Data.  

 

 
 

Click the Browse button to select the path and name of the file that contains the values of the covariance 

matrices of the 2 groups. For the present example, the file is pdex10.cov, which was created earlier in this 

section. Click Open when done.  

 



28 
 

 

 

From the Data dialog box, select the second group from the Groups: drop-down list box. Proceed as outlined 

above to enter the number of observations (900), file type and matrix to be analyzed.  

 

3.2 Drawing the Path Diagram  

 

We now proceed with the actual drawing of the path diagram. Start by clicking on the VERBAL40 label under the 

Observed variables portion of the Variables window. Hold the mouse button down and drag the label to the 

draw area. A rectangular-shaped object will appear on this part of the screen when the mouse button is released 

as shown below. Repeat this procedure until all observed variables are dragged to the drawing area as shown in 

the next image.  

 

Note also that: 

 

• The observed variables are assumed to be X (or independent) variables unless appropriate check boxes 

under the Y-column are checked. 

• The latent variables are assumed to be Ksi (or independent) variables unless appropriate check boxes 

under the Eta-column are checked.  

 

 
 

Proceed by dragging the latent variables, Verbal and Math, to the draw area of the path window. Note that the 

latent variables are represented by elliptically shaped objects. 

Finally, arrows can be drawn pointing from the latent variables to the observed variables. To accomplish this, 

click on the single-headed arrow of the Draw toolbar (seen on the right of the picture given below). As an 

alternative, use the Draw menu on the main menu bar. The related drawing tool options may be selected from 

this menu. 

 

Once the single-headed arrow (or One-way Path option) has been selected, move the mouse pointer to within 

one of the elliptically shaped objects. With the left mouse button held down, "drag" the arrow to within a 

rectangular-shaped object. When the colors of both objects change (see diagram below) release the mouse 

button.  

 



29 
 

 

 

 
 

Proceed in a similar way to graphically display the relationships between the observed and latent variables: 

 

 
 

Select Build SIMPLIS Syntax from the Setup menu. SIMPLIS syntax will be built from the path diagram and is 

stored in a system file named pdex10.spj shown below.  
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Click the Run LISREL icon button to fit the multi-sample model to the data. The parameter estimates and 
2  

goodness-of-fit index are shown on the path diagram displayed below:  

 

 
 

The values shown on the path diagram are the parameter estimates. This is the default selection. It is, however, 

also possible to view the t-values, modification indices or expected changes by selecting the View menu on the 

main menu bar. Alternatively, use the drop-down list by clicking in the Estimates: pane as shown below. To 
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view t-values, select the T-values option. The figure below shows how this is done and also indicates the t-

values on the path diagram.  

 

 

 
 

To view the corresponding t-values for the second group, select group 2 on the menu bar. The resultant changes 

in the path diagram are shown in the next image. 

 

 
 

In the example above, the error variances, factor loadings and factor covariance are constrained to be equal 

(invariant) across the two groups. To test for invariance of factor loadings and covariance only, the error 

variances can be freed as follows. Make sure that the path diagram is displayed, and then select Group 2 from 

the Groups: text box. Right-click in the error variance of VERBAL40 and click the Free option.  Repeat this 

procedure for the remaining three error variances, and then select the Setup, Build SIMPLIS Syntax option. 
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The actions described above result in a new SIMPLIS project file that contains the syntax required to free the 

error variances across groups. 

  

When done, click the Run LISREL icon. The output file reveals two solutions, one for each group. The value of  
2  is reported only after the second group. 

 

In a multi-sample analysis, the 
2  is a measure of fit of all models in all groups, and, in general, this 

2  cannot 

be decomposed into a 
2  for each group separately. For our example, 

2  is 10.87 with 7 degrees of freedom (p 

= 0.14), so that the model does fit the data.  

 

4 Analysis of Ordinal Data using an asymptotic covariance matrix. 

 

Aish and Jöreskog (1990) analyzed data on political attitudes. Their data consist of six ordinal variables 

measured on the same people at two occasions. Labels assigned to the 12 variables are as follows: NOSAY1, 

VOTING1, COMPLEX1, NOCARE1, TOUCH1, INTERES1 (first occasion) and NOSAY2, VOTING2, COMPLEX2, 

NOCARE2, TOUCH2 and INTERES2 (second occasion). These data are saved in the LISREL system data file 

panelusa.lsf. 

 

In this example, the following concepts are illustrated: 

 

o calculation of polychoric correlations and asymptotic covariances  

o drawing a path diagram for a given model  

o creation of variable names for the path diagram  

o creating LISREL and or SIMPLIS syntax from the path diagram  

o the basic model and its components  

o estimation types and the conceptual path diagram  
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o saving the path diagram in graphics format. 
 

4.1 Calculation of Correlations and Asymptotic Covariance Matrix 

Select the Open option from the File menu to obtain the Open dialog box. Select LISREL Data (*.lsf) from the 

Files of type: drop-down list box. Select panelusa.lsf and click Open when done. The PRELIS system file (*.lsf) 

is displayed in the form of a spreadsheet as shown below: 

 

 
 

Select Output Options from the Statistics menu to obtain the Output dialog box. The Output Options dialog box 

allows the user to save various matrices as well as the raw data as files. Select Correlations (to be saved as a 

LISREL System File (also referred to as a LISREL summary data file) with extension *.dsf) from the Moment 

Matrix drop-down list box. Check the LISREL System Data check box. Also check the Save to File check box 

below Asymptotic Covariance Matrix and enter the name panelusa.acm in the string field. With the required 

selections made, click OK to run PRELIS. Note that PRELIS computes polychoric correlations for all variables 

that are defined as ordinal, provided that the number of distinct values of the variables is less than 15. 

 

 

 
 

 

A portion of the PRELIS output is given below: 
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4.2 Drawing a Path Diagram 

 

In this example we use PRELIS to compute the polychoric correlation matrix and corresponding asymptotic 

covariance matrix of these correlations. The next step is to create a path diagram from which the LISREL or 

SIMPLIS syntax may be built.  

 

Select the New option from the File menu to obtain the New dialog box. From the New dialog box, select Path 

Diagram and click OK when done. 

 

 
 

The Save As dialog box will appear. Save the new path diagram as panelusa.pth. 

 

Before proceeding to the next step, ensure that the Toolbar, Status Bar, Type Bar, Variables and Drawing Bar 

options are selected, see below. 
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Select the Title and Comments option from the Setup menu to obtain the Title and Comments dialog box.  Use 

the Title and Comments dialog box to enter a title and to add additional comments as shown in the example 

below: 

 

 

 
 

Click Next to go to the Group Names dialog box. Since the present example is based on the analysis of a single 

group, we can leave this dialog box blank and go to the variable names (Labels) dialog box by clicking Next. 

 

4.3 Reading Variable Names from the DSF File 

The data system file panelusa.dsf, which was created during the PRELIS analysis, contains the variable names, 

the location of the asymptotic covariance matrix, and the matrix of polychoric correlation coefficients. The 

variable names can be read in by clicking Add/Read Variables on the Labels dialog box. 

 

 
 

 In doing so, the Add/Read Variables dialog box is activated and on this dialog box click the Read from File: 

LISREL Summary File radio button. 
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Click Browse to select the file panelusa.dsf. Click Open to return to the Add/Read Variables dialog box. 

 

 
 

Click OK to obtain the list of twelve names shown in the Labels dialog box below. To complete the information 

in this dialog box, add the names of the two latent variables Efficac1 and Efficac2 in the Latent Variables window. 

See the notes at the bottom of the Labels window. To start typing a name, click anywhere within the Latent 

Variables window and type in the name. Alternatively, use the Add Latent Variables button. 
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Once names for the observed and latent variables are entered, click Next to go to the Data dialog box. Select 

Correlations from the Statistics from drop-down list box.  

 
Note:  

 

Since the location of the asymptotic covariance matrix is stored in the *.dsf file, it is not necessary to enter the 

weight matrix details on the Data dialog box. 

 

At this point, one may view the contents of the panelusa.dsf file by clicking the Edit button. A portion of the 

correlation matrix is shown below. Note that only the lower triangular halve contains correlation values.  

 

 

 
 

Close the spreadsheet to return to the path diagram environment. The list of variable names will appear on the 

left side on the computer screen. Define the variables NOSAY1, VOTING1, COMPLEX1, NOSAY2, VOTING2 and 

COMPLEX2 as Y-variables by checking the appropriate boxes under the heading Y. Also check the Eta-variable 

boxes to define Efficac1 and Efficac2 as Eta latent variables. 

 

The observed values to be used in the drawing of the path diagram can be dragged to the path diagram area by 

clicking on a variable name (mouse left button). By holding this button down, a variable can be dragged to a 

desired position. 
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Drag the two latent variables to the path diagram window. To create paths between variables we proceed as 

follows: Click on the single headed arrow icon button on the Draw toolbar as shown. Move the mouse cursor to 

the middle of the Efficac1 ellipse, and then click the left mouse button. Hold the button down while dragging the 

arrow to within the NOSAY1 rectangle. The colors of both objects should change. Repeat the procedure to add 

the remaining paths as illustrated: 
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4.4 Creating LISREL and/or SIMPLIS Syntax from the Path Diagram  

 

Prior to building the SIMPLIS or LISREL syntax, we adjust the default number of decimals from 2 to 4. This is 

accomplished by selecting the Output, LISREL outputs, Estimations… option. 

 

 

 
 

 

The method of estimation is also changed from Maximum Likelihood to Weighted Least Squares by selecting the 

Output, LISREL output, Estimations option. 

 

 
 

 

Select Build LISREL Syntax from the Setup menu to obtain the following LISREL project window that displays 

the contents of the LISREL syntax file panelusa.lpj. 
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Click the Run LISREL icon button to start the analysis. The path diagram shows the estimated parameter values 

and 2 -value. 

 

 
 

Often researchers prefer to set one factor loading each set that are indicators of a specific latent variable (factor) 

equal to one. This can be accomplished by editing the contents of the .lpj file or by right clicking on a factor 

loading, and then fixing its value to one. The resultant .lpj file is shown below. 
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The corresponding SIMPLIS input syntax can be built from the path diagram obtained by running LISREL. This is 

accomplished by selecting the Build SIMPLIS Syntax option from the Setup menu. 

 

A selection of the SIMPLIS syntax (panelusa.spj) is displayed in the SIMPLIS project window as shown in the 

next image. 

 

 
 

This syntax produces a model that consists of X-variables and Y-variables, a KSI latent variable and an Eta latent 

variable. Click the Run LISREL icon button to run the analysis. It is interesting to note that the Y-only model and 

the model shown below are equivalent. 
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4.5 The Basic Model and its Components 

 

The model shown above is called the Basic Model, which can be divided into the X-Model, the Y-Model and the 

Structural Model. Each of these models may be viewed separately by clicking on the Basic Model drop-down list 

box to obtain the list of models. 

 

 

 
 

 

 

By selecting the X-Model model type, this portion of the path diagram is displayed. The X-Model selection and Y-

Model selection are shown below. 
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The selection of the Structural Model option produces that part of the path diagram: 

 

 
 

 

Finally, the selection of the correlated errors option produces the following diagram. Note that use was made of 

the two-headed arrow to add the error covariance paths to the diagram. 
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When the Run LISREL icon button is clicked, the following path diagram is obtained. From this display, it is 

seen that the 
2 -value has significantly decreased as a result of the addition of the error covariances. 
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4.6 Estimation Types and the Conceptual Path Diagram 

 

LISREL also allows the user to view the parameter Estimates, Completely Standardized Solution, Conceptual 

Diagram, T-values, etc. by clicking on View (main menu bar) or by clicking on the Estimates drop-down list box 

as shown below: 

 

 
 

 

The selection of the Conceptual Diagram option produces a path diagram that contains only variable names and 

paths between variables. A black and white display of the path diagram can be obtained by selecting the Black 

and White option from the Image menu. 

 

 
 

4.7 Saving the Path Diagram in Graphics Format 

 

The conceptual path diagram, or one with an alternative selection from the Estimations bar, can be saved as a 

Windows Metafile (*.emf) file, which may be included as a graphic in, for example, Microsoft Word or 

Powerpoint. To save as a *.emf file, select the Export as Metafile option from the File menu. 
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5 Empty Path Diagrams 

5.1 Motivation   

Empty path diagrams can be used in teaching to discuss various types of models. The commands for creating 

empty path diagram are explained here. After the empty path diagram has been produced, user can start drawing 

the paths (arrows). 

 

5.2 Examples   

 
Example 1 

 

If no relationships are specified, LISREL treats all observed variables as x-variables and all latent variables as 

Ksi-variables. 

 
 
 
Raw Data from File NPV.LSF 
Latent Variables: Visual Verbal Speed 
Path Diagram 
End of Problem 

 

The LISREL model is (omitting intercepts) 

 

x= +x Λ ξ δ  

Example 2 

 

This example illustrates a model with only x- and y-variables. 

 
Observed Variables: Y1 - Y3 X1 X2 
Covariance matrix: 
14.610 
-5.250 11.017 
-8.057 11.087 31.971 
-0.482 0.677 1.559 1.021 
-18.857 17.861 28.250 7.139 215.662 
Sample Size 173 
Y-Variables Y1-Y3 
Path Diagram 
End of problem 

 

The LISREL model is (omitting intercepts) 

 

= + +y By Γx ζ
 

 
 
Example 3 

 

The next example illustrates a model with y-, Eta- and Ksi-variables (but no x-variables and omitting intercepts) 

 
Raw Data from File NPV.LSF 
Latent Variables: Visual Verbal Speed Ksi 
Y-Variables ’VIS PERC’ - SCCAPS 
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Eta-Variables Visual - Speed 
Path Diagram 
End of Problem 

 

The LISREL model is 

 

y= +y Λ η ε
 

= +η Γξ ζ
 

 
Example 4 

 

The last example illustrates a model with only y- and Eta-variables (omitting intercepts) 

 
Observed Variables: Y1-Y7 
Correlation Matrix 
(20F4.3) Symmetric 
1000 
5561000 
456 4901000 
439 445 5621000 
415 418 496 5121000 
399 383 456 469 5511000 
387 364 445 442 500 5441000 
Sample Size 1600 
Latent Variables Eta1-Eta7 
Y-Variables Y1-Y7 
Eta-Variables Eta1-Eta7 
Path Diagram 
End of Problem 
 

The LISREL model is 

 

y= +y Λ η ε
 

= +η Bη ζ  
 

 

6 Using SIMPLIS Project Files 

 

LISREL allows the user to create SIMPLIS syntax by making use of a dialog box keypad. This keypad, see 

illustration below, is operated by clicking (left mouse button) on the appropriate symbol. Note that the <== 

symbol represents the backspace key while the symbol <--| denotes the enter key. The path diagram produced 

by running the program can subsequently be modified to change the model specifications. 
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As an illustration, we consider path analysis for latent variables, which, in its most general form, is a structural 

equation system for a set of latent variables classified as dependent or independent. In the application described 

below, the system is recursive (see the LISREL 8: SIMPLIS command language guide.) 

 

Recursive models are particularly useful for analyzing data from longitudinal studies in psychology, education 

and sociology. The characteristic feature of a longitudinal research design is that the same measurements are 

used on the same people at two or more occasions. Wheaton, et al. (1977) reported on a study concerned with 

the stability over time of attitudes such as alienation, and the relation to background variables such as education 

and occupation. Data on attitude scales were collected from 932 persons in two rural regions in Illinois at three 

points in time: 1966, 1967, and 1971. The variables used for the present example are the Anomia subscale and 

the Powerlessness subscale, taken to be indicators of Alienation. This example uses data from 1967 and 1971 

only.  

 

The background variables are the respondent’s education (years of schooling completed) and Duncan’s Socio-

economic Index (SEI). These are taken to be indicators of the respondent’s socio-economic status (Ses). The 

sample covariance matrix of the six observed variables is given below:  

 
   y1   y2   y3   y4   x1  x2 
ANOMIA67 11.834                
POWERL67  6.947  9.364             
ANOMIA71  6.819  5.091 12.532          
POWERL71  4.783  5.028  7.495  9.986       
EDUC -3.839 -3.889 -3.841 -3.625 9.610    
SEI* -2.190 -1.883 -2.175 -1.878 3.552 4.503 

 

*The variable SEI has been scaled down by a factor of 10. 

 

The path diagram for this model is shown below: 
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Notes: 

  

o The error terms of ANOMIA and POWERL are specified to be correlated over time. 

o The four one-way arrows to the right of the diagram represent the measurement errors in ANOMIA67, 

POWERL67, ANOMIA71 and POWERL71 respectively. 

o The two-way arrows on the right indicate that some of the measurement errors are correlated. The 

covariance between the two error terms for each variable can be interpreted as a specific error 

variance. For other models for the same data, see Jöreskog & Sörbom (1989, pp. 213-223). 

 

To set up this model for SIMPLIS is straightforward as shown in the following syntax file: 

 
Stability of Alienation  
Observed Variables  
ANOMIA67 POWERL67 ANOMIA71 POWERL71 EDUC SEI  
Covariance matrix 
11.834                
 6.947  9.364              
 6.819  5.091  12.532          
 4.783  5.028    7.495  9.986       
-3.839 -3.889  -3.841 -3.625 9.610    
-2.190 -1.883  -2.175 -1.878 3.552 4.503 

Sample Size 932  
Latent Variables Alien67 Alien71 Ses  
Relationships  
ANOMIA67 POWERL67 = Alien67  
ANOMIA71 POWERL71 = Alien71  
EDUC SEI = Ses  
Alien67 = Ses  
Alien71 = Alien67 Ses  
Set Error Covariance of ANOMIA67 and ANOMIA71 Free 
Set Error Covariance of POWERL67 and POWERL71 Free 
Path Diagram 
End of Problem 

 
Notes: 
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• The model is specified in terms of relationships. The first three lines under Relationships specify 

the relationships between the observed and the latent variables. For example, ANOMIA71 POWERL71 = 

Alien71 means that the observed variables ANOMIA71 and POWERL71 depend on the latent variable 

Alien71. 

• The Line Alien71 = Alien67 Ses means that the latent variable Alien71 depends on the two latent variables 

Alien67 and Ses. This is one of the structural relationships. 

 

6.2 Building the SIMPLIS Syntax   

 

The files ex6a.spl and ex6b.spl in the SIMPLIS examples folder both contain the numeric values of the 

covariance matrix of the observed variables. 

 

From the File menu, select Open and locate ex6a.spl. Use the mouse cursor (left button down) to mark the 

covariances as shown below. Use the Edit menu and click Copy or, alternatively, press the Ctrl - C keys on the 

keyboard.  

 

From File, New select Syntax Only and click OK. Use the Edit, Paste function to copy the contents of the 

clipboard to the syntax window or, alternatively, use the Ctrl - V keys on the keyboard. Use the File, Save As 

option to save the covariances to the file wheaton.cov. 

 

 

 
 

 

Select the New option from the File menu and select SIMPLIS Project in the New dialog box. Click OK to open 

the Save As dialog box.  

 

Select a filename and a folder in which the SIMPLIS project should be saved. For the present example the 

filename selected is SIMPLIS6.spj. When done, click Save to go to the SIMPLIS project (SPJ) window. 
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Before generating syntax, you may optionally select SIMPLIS Outputs from the Output menu. Customize this 

dialog box according to your preferences; for example, change the Number of Decimals in the Output option to 

4. When done, click OK.  

 

The following step is to provide information regarding Title and Comments, Groups, Variables, and Data. Select 

the Titles and Comments option from the Setup menu. The first item on the Title and Comments dialog box is 

the title for the problem. After typing in the title and (optionally) the comments, click on Next to go on with the 

setup. 

 

 
 

 

Since the present example is based o n the one group only, nothing is entered in the space allowed for Group 

Labels, and Next is clicked to go to the Labels dialog box. 

 

The default number of variables shown on the Labels dialog box is 3, these being CONST, VAR 1 and VAR 2. 

Click in the CONST textbox and change the name to ANOMIA67. Enter the label POWERL67 in the VAR 1 textbox 
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and ANOMIA71 in the VAR 2 text box. Move the mouse cursor into the ANOMIA71 textbox and use the down 

arrow to create a fourth text box. Type in POWERL71 and repeat the procedure for EDUC and SEI.   

 

In a similar manner, use the down arrow key to create text boxes in the Latent Variables column and enter the 

names Alien67, Alien71 and Ses. Note that a label name, which may include blanks, may not exceed 8 characters.  

 

 
 

On the Data dialog box select Covariances from the Statistics from: drop-down list box. Type 932 in the Number 

of Observations string field. For File type, select External ASCII data and use the Browse button to select 

wheaton.cov.  
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6.3 Building and Completing the SIMPLIS Syntax 

 

Select Build SIMPLIS Syntax from the Setup menu to create the basic SIMPLIS syntax. The Build SIMPLIS Syntax 

option on the Setup menu provides the user with a skeleton of SIMPLIS commands. There are a few commands 

that must be included to complete the SIMPLIS syntax. The first of these commands is: 

 
ANOMIA67 POWERL67=Alien67 

 

To add a line in the syntax window, move the mouse cursor to the end of the keyword Relationships and click 

once. Now move the cursor to the Enter key ( <--| ) on the keypad and click to insert a blank line below the 

Relationships line. 

 

To enter the line 

 
ANOMIA67 POWERL67 = Alien67 

 

proceed as follows: 

 

• Click on the observed variable ANOMIA67 (First variable under the heading Observed) and with the 

mouse button held down drag the variable name to the syntax window.  

• Repeat by dragging the variable name POWERL67 next to ANOMIA67. To continue, click on the "=" key 

and then drag the latent variable name Alien67 (first variable under the heading Latent). 

 

To complete, move the mouse cursor to the end of the line 

 
ANOMIA67 POWERL67 = Alien67 

 

and click. Then click on the enter key and repeat the steps outlined above to insert the lines: 

 
ANOMIA71 POWERL71 = Alien71 
EDUC SEI = Ses 
Alien67 = Ses 
Alien71 = Alien67 Ses 

Finally, enter the commands: 

 
Set Error Covariance of ANOMIA67 ANOMIA71 free 

and 

 
Set Error Covariance of POWERL67 POWERL71 free 

 

by using the keypad and by dragging the variable names to the appropriate positions. The completed syntax 

should correspond to the lines shown in the SPJ window below: 
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To run SIMPLIS, click the Run LISREL icon button on the main menu bar. A path diagram as shown below is 

produced, as well as the usual output file.  

 
 

7 Using LISREL Project Files 

 

LISREL allows the user to create LISREL syntax interactively by making use of a set of menus. As an illustration, 

we consider a second-order factor analysis model. 

 
Second-order factor analysis 

 

The following equation 

 

y= +y Λ η ε  

 

is in the form of a factor analysis model for y  with first order factors η  and measurement errors  ε . Now 

suppose that the variables η  in turn can be accounted for by a set of so called second-order factors ξ , so that 
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= +η Γξ ς  

 

where Γ  is a matrix of second-order factor loadings and ς  is a vector of unique components for η . 

 

To illustrate the model, we use data on some cognitive ability tests. The standard deviations and correlations of 

two forms of each of five tests are given in the table below. The sample size (N) is 267. 

 
Table 2: Correlations and Standard Deviations for Some Cognitive Tests 
 

GESCOM-A   2.42 1 

GESCOM-B   2.80 0.74 1 
CONWORD-A 3.40 0.33 0.42 1 

CONWORD-B 3.19 0.34 0.39 0.65 1 

HIDPAT-A       1.94 0.26 0.21 0.15 0.18 1 

HIDPAT-B        1.79 0.23 0.24 0.22 0.21 0.77 1 

THIROUND   5.63 0.15 0.12 0.14 0.11 0.17 0.20 1 

THIBLUE     3.10 0.14 0.14 0.14 0.15 0.06 0.09 0.42 1 

VOCABU_A 3.05 -.04 0.03 0.09 0.16 0.06 0.09 0.19 0.21 1 

VOCABU_B 2.25 0.02 0.02 0.10 0.23 0.024 0.07 0.09 0.21 0.72 1 

 

 

We shall examine the hypothesis that the two forms of each test are tau-equivalent, except for the two-word 

fluency tests Things Round and Things Blue that are only assumed to be congeneric. The five true scores are 

postulated to depend on two factors, the first, Speed Closure, being measured by the first three tests and the 

second, Vocabulary, being measured by the last two tests. The model specification is: 

 

 
 

Here * denotes parameters to be estimated and "0" and "1" are fixed parameters. The LISREL syntax file for this 

model is as follows: 

 
Second order factor analysis 
DA NI=10 NO=267 
LA FI=EX62.DAT 
KM FI=EX62.DAT 
SD FI=EX62.DAT 
MO NY=10 NE=5 NK=2 GA=FI PH=ST PS=DI 
LE 
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GESCOM CONWOR HIDPAT THINGS VOCABU 
LK 
SPEEDCLO VOCABUL 
VA 1 LY 1 1 LY 2 1 LY 3 2 LY 4 2 LY 5 3 LY 6 3 LY 7 4 LY 9 5 LY 10 5 
FR LY 8 4 GA 1 1 GA 2 1 GA 3 1 GA 4 2 GA 5 2 
ST 1 ALL 
OU SE TV SS NS 

 

The goodness-of-fit statistic 2  is 53.06 with 33 degrees of freedom. 

 

7.1 Building the LISREL Syntax 

 

From the File menu, select New to obtain the New dialog box. Select LISREL Project and click OK to obtain the 

Save As dialog box. 

 

 
 

Select the filename sofa.lpj. When done, click Save. 

 

The following step is to provide information regarding the title, additional comments to be included in the 

syntax file, the data file and the variables in it. This is accomplished by selecting the Title and Comments option 

from the Setup menu. The Title and Comments dialog box appears. Enter a title and (optional) comments in the 

Title string field and the Comments text box. 

 

 

 
 

Since the present example is based on the analysis of a single group, nothing is entered in the space allowed for 

Group Labels, and Next is clicked to go to the Labels dialog box. 

 

The default number of variables on the Labels dialog box is 2, these being VAR 1 and VAR 2. Since the present 

analysis calls for 10 variables, the mouse cursor is moved to the Observed Variables box. By pressing the Insert 

key on the computer keyboard eight times, provision is made for eight additional observed variables, and 
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therefore the total number becomes ten. Alternatively, the Add List option may be used and var3-var10 entered 

(or, for example, X3-X10). If the Add List option was used, click OK to return to the Labels dialog box. Variable 

labels can alternatively be read in from an existing *.lsf or *.dsf file. See the section on LISREL system files for 

more information on this option. 

 

A label may be assigned to each of the 10 variables by clicking on the corresponding button (numbered 1,2,3, 

…, under the Observed Variables column). The background color of the space allowed for entering the variable 

name will change and one can go ahead and type the appropriate label. For the present example, the labels are 

GESCOM A, GESCOM B, CONWOR A, CONWOR B, HIDPAT A, HIDPAT B, THIROUND, THIBLUE, VOCABU A and 

VOCABU B respectively. Note that a label name, which may include blanks, may not exceed 8 characters. Note 

also that the labels for the variables may instead be entered by, for example, clicking on VAR 1. Type in 

GESCOM A and use the down arrow on the keyboard to create the next space. Type GESCOM B and continue in a 

similar fashion until all the labels are typed in. 

 

Since we have 7 latent variables, Gescom, Conwor, Hidpat, Things, Vocabu, Speedclo and Vocabu1, the procedure 

outlined above for the observed variables is repeated by selecting Add List on the Latent Variables portion of the 

Labels dialog box. Add var1-var7 and click on OK (alternatively the keyboard down arrow may be used). Assign 

labels to these latent variables by clicking on the number of each variable. Finally, click Next to go to the Data 

dialog box. 

 

 
 

From the Data dialog box, select Covariances from the Statistics from: drop-down list box and also Covariances 

from the Matrix to be analyzed drop-down list box. Type 267 in the Number of Observations string field. For File 

type, select External ASCII Data and then click Browse to go to the Browse dialog box. 
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Select the ASCII file sofa.cov. Click Open to return to the Data dialog box, and then select Next to go to the 

Define Observed Variables dialog box. 

 

The program will now produce the Define Observed Variables dialog box, on which the user may select Y-

variables and X-variables from the list of Variable Names. Since the present application calls for Y-variables 

only, all of the variable names are selected as Y-variables. This is achieved by sequentially clicking on each 

variable number box and then on the Select as Y option. Alternatively, with the left mouse button down, drag 

from variable number 1 to number 10, release the mouse button and click on the Select as Y button. 
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Click Next to go to the Define Latent Variables dialog box. 

 

The latent variables consist of 5 Eta-variables and 2 Ksi-variables. Click on the appropriate square under 

Variable Names and then choose Select Eta for the Eta-variables (the first 5) or Select Ksi for the Ksi-variables 

(the last 2 variables). Once this is done, click Next to go to the Model Parameters dialog box. 

 

 

 
 

The Model Parameters dialog box shown below allows the user to: 

 

o specify the form and mode of the matrices listed, 

o specify which elements are fixed and which are free, and 

o assign values to the elements of each of the matrices. 
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Since some changes need to be made to the default specifications for the Lambda-Y matrix, highlight the 

Lambda-Y Full Matrix, Fixed option by clicking on it. This action will cause the words Full Matrix and Fixed to 

appear in the Matrix From and Matrix Mode fields respectively. Proceed by clicking Specify to obtain the dialog 

shown below. 

  

 
 

The initial dialog box will indicate that all the elements of Lambda-Y are fixed and equal to zero. The steps 

required to obtain the pattern shown in the dialog box below corresponding to the statements is given next. 

 
VA 1.0 LY(1,1) LY(2,1) LY(3,2) LY(4,2) LY(5,2) LY(6,3) LY(7,4) LY(9,5) LY(10,5) 
FR LY(8,4), 
 

o Click on the first rectangle next to the variable description button (that is under the heading Gescom) 

and use the computer keyboard to type in the value of 1, then press the keyboard Enter button.  

o Proceed in a similar fashion to enter 1 in the second row, and finally a 1 in the rectangle 

corresponding to the row VOCABU B and column Vocabu. 
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o By clicking on the rectangle in the row THIBLUE and column Things and then on the Free button, the 

color of the rectangle will change to indicate that LY(8,4) is free. 

 

Note that one may move the mouse pointer to a vertical divider line on the dialog box below. Column widths 

can subsequently be adjusted by clicking the left button and dragging the vertical line to the left or the right of 

its present position. 

 

 
 

 

The input specifications require BETA to be a full matrix with all elements fixed at a value of 0. Since this is the 

default, one can proceed to specify the pattern and values for the GAMMA matrix. 

 

 
 

 

Highlight the Gamma Full Matrix, Fixed option and click on Specify.  
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Use the dialog box shown above to specify the following statements 

 
FR GA(1,1) GA(2,1) GA(3,1) GA(4,2) GA(5,2) 
VA 1.0 GA(1,1) GA(2,1) GA(3,1) GA(4,2) GA(5,2) 

  

This is accomplished by clicking on the rectangle that corresponds to the Eta-variable Gescom and the Ksi-

variable Speedclo. Use the computer keyboard to type in 1 and click again to activate this rectangle. Then select 

the Free button to change the status of the GA(1,1) parameter to free. Continue in a similar fashion to obtain the 

pattern shown above. 

 

Since the default settings for the parameter matrices Psi and Theta-Epsilon are correctly set at the default values 

(see dialog box below), click on Next to go to the Constraints dialog box. 

 

 
 

 

In the present example, no constraints are imposed on the elements of the parameter matrices and therefore the 

Next button is clicked to go to the Output Selections dialog box.  
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The Output Selections dialog box enables the user to create an output file that contains selected parts of the 

LISREL printout. Make the appropriate selections by clicking on the boxes at the left of the different options. 

Once this is done, click Next to go to the final dialog box, which is the Save Matrices dialog box. 

 

 
 

Any of the matrices or statistics shown on the dialog box illustration below may be selected by clicking on the 

boxes.  
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As an example, we selected Lambda-Y, Gamma and t-values. These files will have the same filename as the 

LISREL project file but with different file extensions, these being *.lys, *.gas, and *.tvs respectively. 

 

Click OK to return to the LISREL project (LPJ) window. The LISREL syntax, saved in the file sofa.lpj, is shown 

below: 

 

 
 

Click the Run LISREL icon button on the main menu bar to run the problem. 

 

The path diagram for this example is shown below and the output is saved to the file sofa.out. 
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One may modify the path diagram by deleting, fixing or adding paths. 

  

8 Analysis with Missing Data 

8.1 Single-Group Analysis with Missing Data 

Data on attitude scales were collected from 932 persons in two rural regions in Illinois at three points in time: 

1966, 1967 and 1971. The variables used for the present example are the Anomia subscale and the 

Powerlessness subscale, taken to be indicators of Alienation. This example uses data from 1967 and 1971 only.  

 

The background variables are the respondent’s education (years of schooling completed) and Duncan’s 

Socioeconomic Index (SEI). These are taken to be indicators of the respondent’s socioeconomic status (SES).  
 
Observed Variables: Anomia 67, Powerlessness 67, Anomia 71, Powerlessness 71, 
 Education, SEI 
 
Latent Variables: SES, Alienation 67, Alienation 71 

 

The model shown in the path diagram below was fitted by running ex64d.lis (in the LISREL examples folder). 
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By adding SI=filename to the OU line of the syntax file, the fitted covariance matrix may be saved to an external 

file. 

 

Subsequently, a data set of size 1500, with 15% of the values missing at random, was simulated by regarding 

the fitted covariance matrix as the true population covariance matrix. This data set is stored as the text file 

wmas.dat. A corresponding *.lsf file, containing the variable names, missing value code, number of records and 

the data is stored as wmas.lsf. Select File, New, Path Diagram and save the path. In the dialog box below, we 

used the name sgroup.pth. 

 

Click Save when done and select the Title and Options option from the Setup menu. Enter a title and optional 

comments. Click Next to proceed to the Group Names dialog box and again click Next to proceed to the Labels 

dialog box. 

 

 
 

 

Click the Add/Read Variables button and on the Add/Read Variables dialog box select LISREL System data file 

from the Read from file drop-down list. Use the Browse button to locate wmas.lsf. 
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Click OK when done and add the latent variable names as shown below. By default, LISREL uses the file 

selected for reading in variable names as the data file. It is therefore not necessary to proceed to the Data menu. 

Click OK to return to the path diagram window. 

 

 

 
 

Mark the first four variables as Y-variables and the first two latent variables as Eta-variables. (Left) click on 

each variable name, and with the mouse button down, drag the variable to the path diagram (PTH) window.  
 

Start with the Y-variables first, then continue with the Eta-variables, then the Ksi-variables and finally the X-

variables. In other words, start with ANOMIA67 and end with SOCIOIND. 
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Click on the draw tool (single-headed arrow) and add all the paths as shown below. Start by moving the mouse 

cursor to the center of ALIEN67, and, with the mouse button down, drag the arrow to the center of ANOMIA67 and 

release the button.  

 

Once all the single paths have been drawn, click on the double-headed arrow. Move the cursor to the center of 

the error variance arrow of ANOMIA67, then, with the left mouse button held down, drag to the center of the 

error variance arrow of ANOMIA71. Repeat this procedure to allow for a covariance between POWER67 and 

POWER71. 

 

 
 

Select Build LISREL syntax from the Setup menu to produce the sgroup.lpj file. This file is displayed in the 

LISREL project (LPJ) window shown below. 

 

 

 
 

 

The syntax files missex4a.lis and missex4b.spl in the missing data examples subfolders of LISREL examples and 

SIMPLIS examples contain the corresponding LISREL and SIMPLIS syntax for fitting the model. Missing values 

for this analysis are indicated by a value of -9. A FIML analysis is carried out if the DA line in the LISREL syntax 

contains the keyword MI=<value>. This is required if the data file is not a LSF file: 
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DA NI=6 NO=1500 MI=-9 
LA 
ANOMIA67 POWER67 ANOMIA71 POWER71 EDUCATIN SOCIOIND 
RA FI=WMAS.DAT 
MO NY=4 NX=2 NE=2 NK=1 BE=SD PS=DI TE=SY 
LE 
ALIEN67 ALIEN71 
LK 
SES 
FR LY(2,1) LY(4,2) LX(2,1) TE(3,1) TE(4,2) 
VA 1 LY(1,1) LY(3,2) LX(1,1) 
PD 
OU SE TV MI ND=3 PT 

 

Click the Run LISREL icon button to obtain a path diagram and output file. Once the data are read, estimates are 

obtained of the means and covariances and a 2ln L−  value is printed. This value is the 2ln L−  value for the 

unrestricted model. 

 

Portions of the output file are shown below: 

 
(i) –2*Log(likelihood) and percentage cases missing  

 

The EM-algorithm is used to obtain estimates of the population means and covariances. LISREL uses these 

values to obtain starting values for the maximum likelihood procedure. Convergence is attained in 8 iterations, 

and at convergence 2ln L−  equals 35822.65. This value is also referred to as the 2ln L−  value for the saturated 

model.  
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 (iv) Global Goodness of Fit Statistics, Missing Data Case 
 

      -2ln(L) for the saturated model =       35822.647 
      -2ln(L) for the fitted model    =       35828.671 
                      Degrees of Freedom = 4 
      Full Information ML Chi-Square  = 6.02 (P = 0.20) 
  Root Mean Square Error of Approximation (RMSEA) = 0.018 

 

8.2 Multiple-groups with Missing Data 

 

Sörbom (1981) reanalyzed some data from the Head Start summer program previously analyzed by Magidson 

(1977). Sörbom used data on 303 white children consisting of a Head Start sample (N = 148) and a matched 

Control sample (N = 155). The children were matched on gender and kindergarten attendance, but no attempt 

had been made to match on social status variables.  

 

The variables used in Sörbom’s re-analysis were: 

 

1X  = Mother’s education (MOTHEDUC) 

2X  = Father’s education (FATHEDUC) 

3X = Father’s occupation (FATHOCCU) 

4X  = Family income (FAMILINC) 

1Y = Score on the Metropolitan Readiness Test (MRT) 

2Y  = Score on the Illinois Test of Psycholinguistic Abilities (ITPA) 

 

The following issues were examined: 

 



71 
 

 

 

• Test whether 
1X ,

2X , 3X  and 
4X  can be regarded as indicators of a single construct Ses (socioeconomic 

status) for both groups. Is the measurement model the same for both groups? Is there a difference in the 

mean of Ses between groups? 

• Assuming that 
1Y  and 

2Y  can be used as indicators of another construct Ability (cognitive ability), test 

whether the same measurement model applies to both groups. Test the hypothesis of no difference in the 

mean of Ability between groups. 

• Estimate the structural equation: 

  

 Ability Ses z = + +  

 

• Is   the same for the two groups? Test the hypothesis 0 =  and interpret the results.  

 

A conceptual path diagram for the model fitted to the data is shown below. 

 
 

The fitted covariance matrices obtained from ex16d.spl (in the SIMPLIS examples folder) were used to simulate 

a control group data set (sample size 550 and percentage missing 15%) and to simulate a Head Start data set 

(sample size of 600 and percentage missing 10%). 

 
 
Note: 

 

To invoke the FIML procedure for the analysis of missing data, the following three statements must be given in 

the SIMPLIS syntax in the order shown below. 

 
Missing Value Code <value> 
Sample Size: <nsize> 
Raw data from file <filename> 

 

The complete SIMPLIS syntax file is shown below. 

 
FIML: Example 1: SIMPLIS syntax 
Group = Control 
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Observed Variables: MOTHEDUC FATHEDUC FATHOCCU FAMILINC MRT ITPA 
Missing Value Code –9 
Sample Size: 550 
Raw Data from File CONTROL.DAT 
Latent Variables: Ses Ability 
Relationships: 
   MOTHEDUC            = CONST + 1*Ses 
   FATHEDUC - FAMILINC = CONST +   Ses 
   MRT                 = CONST + 1*Ability 
   ITPA                = CONST +   Ability 
   Ability = Ses 
Let the Errors of MOTHEDUC and FATHEDUC correlate 
Group = Head Start 
Missing Value Code –9 
Sample Size: 600 
Raw Data from File EXPERIM.DAT 
 
Relationships: 
   Ses     = CONST 
   Ability = CONST + Ses 
Set the Error Variances of MOTHEDUC - ITPA free 
Set the Variance of Ses free 
Set the Error Variance of Ability free 
Let the Errors of MOTHEDUC and FATHEDUC correlate 
LISREL Output: ND=3 
Path Diagram 
End of Problem 

 

If the data are stored in a LISREL system file (*.lsf), the Observed Variables, Missing Value Code, Sample Size and 

Raw data from file control.dat can be replaced with the statement 
 

Raw data from file control.lsf 

 

If a *.lsf file contains missing data, the user should ensure that a global missing value code is assigned. This can 

be done by using the Data, Define Variables option. Subsequently, we illustrate how to build the SIMPLIS (or 

LISREL) syntax by drawing a path diagram. 

 

Select the New option from the File menu. On the New dialog box, select Path Diagram and save the path 

diagram as mgroup.pth. These steps are described in detail in earlier sections of this guide. From the Setup 

menu, select Title and Comments and provide a title and any optional comments. When done, click Next to go to 

the Group Names dialog box. 
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Use the instructions on the bottom of the Group Names dialog box to enter group names, then click Next  to go 

to the Labels dialog box. 

 

 

 
 

The files control.lsf and experim.lsf contain the Group1 and Group2 data respectively. Click the Add/Read 

Variables button, select LISREL System File from the Add/Read Variables dialog box and use the Browse button 

to locate the file control.lsf. Click OK when done to return to the Labels dialog box. Use the Add Latent 

Variables button to insert the names Ses and Ability. 
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Click the Next button to go to the Data dialog box. Since a *.lsf file was selected in the previous step, the Data 

dialog box shows the File type: as LISREL System Data File and the filename as control.lsf. Use the Groups: drop-

down list box to select Group2=Head Start. Once this is done, use the Browse button to locate the file experim.lsf. 

Click Open to return to the Data dialog box. 

 

 
 

 

Click OK  when done. Select the variables MRT and ITPA as Y-variables and Ability as an Eta-variable. Drag 

variable names to the path diagram screen in the order MRT, ITPA, Ability, Ses, MOTHEDUC, FATHEDUC, 

FATHOCC, and FAMILINC. Use the draw toolbar to draw the paths as shown below. 
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A more detailed description of this process is given in preceding sections of this guide. 

 

 
 

 

When the path diagram is completed, use the Build SIMPLIS syntax option from the Setup menu to create the 

SIMPLIS syntax file which is displayed in the SIMPLIS project window, as shown below. 

 

 
 

Note that no relationships are given for Group2 under the Relationships keyword. This implies that all 

parameters are constrained to be equal across groups. 

 

Click the Run LISREL icon to create an output file and the path diagram shown below. 
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Since it is not realistic to assume equal error variances across groups, we can set each error variance free by 

moving the mouse to the appropriate arrow (e.g. MRT   0.96). Right click to obtain the menu below and select 

the Free option. Proceed in a similar way to free the error variances of ITPA, MOTHEDUC, FATHEDUC, 

FATHOCC and FAMILINC as well as the covariance (5.45) between MOTHEDUC and FATHEDUC. 

 

 
 

Also right click on the arrow between Ses and Ability to free that path. When this is done, rebuild the SIMPLIS 

syntax using the Build SIMPLIS syntax option on the File menu. 

 

A portion of the SIMPLIS project file showing the resultant relationships for group 2 is shown below. 
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Click the Run LISREL icon button to produce the path diagram shown below. 

 

 
 

When the missing value code, sample size and raw data file information are read in, the EM algorithm for 

estimating the means and covariances under the unrestricted model is started. From this portion of the output a 

percentage of 14.61% missing cases are reported for group 1 and 9.92% for group 2. 

 

Note that the estimated means and covariances are used to obtain starting values for the FIML procedure. In 

addition, a 2ln L−  value is reported for each group. This value is minus two times the log likelihood value 

obtained when no restrictions are imposed on means and covariance matrices. From the output it follows that 

the sum of the 2ln L−  values for the groups equals 11358.595 + 12716.065 = 24074.660. 

 

The FIML procedure converged in 6 iterations. Portions of the output file are given below. 

 
(i)  LISREL Estimates (Maximum Likelihood) for the control group 

 
     Number of Iterations =  6 
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      Measurement Equations 
 
      MRT = 0.86*Ability, Errorvar.= 1.06  , R**2 = 0.20 
           (0.11)                   (0.084) 
            7.78                     12.58 
 
      ITPA = 2.74*Ability, Errorvar.= 7.89 , R**2 = 0.26 
                                    (0.69) 
                                     11.41 
 

      MOTHEDUC = 1.14*Ses, Errorvar.= 12.70, R**2 = 0.093 
           (0.14)               (0.85) 
            8.42                 14.92 
 
      FATHEDUC = 1.07*Ses, Errorvar.= 6.15 , R**2 = 0.16 
           (0.098)              (0.43) 
            10.90                14.26 
 
      FATHOCC = 1.01*Ses, Errorvar.= 0.96 , R**2 = 0.51 
           (0.055)              (0.11) 
            18.35                8.39 
 
     FAMILINC = 0.78*Ses, Errorvar.= 0.74  , R**2 = 0.45 
               (0.047)              (0.076) 
               16.65                9.81 
 

  (ii)  Global Goodness of Fit Statistics, Missing Data Case 
 

     -2ln(L) for the saturated model =       24074.660 
     -2ln(L) for the fitted model    =       24106.532 
     Degrees of Freedom = 20 
     Full Information ML Chi-Square  =  31.872 (P = 0.0447) 
     Root Mean Square Error of Approximation (RMSEA) = 0.032 
 

The FIML 
2  is obtained as the difference between -2 ln L (24105.18) for the fitted model and -2 ln L for the 

unrestricted model and equals 31.872. 

 

9 Latent Variable Scores 

9.1 Calculation of Latent Variable Scores 

To obtain scores for the latent variables of a structural equation model, the following three steps are required. 

 
 
Step 1 

 

If the data are not available as a LISREL system data file (*.lsf) yet, use the Import Data in Free Format or Import 

External Data in Other Formats options from the File menu to create a  *.lsf file. 

 
 
Step 2 

 

Use this *.lsf file to compute the desired sample covariance or correlation matrix to which the structural 

equation model should be fitted.  This may be done by running the appropriate PRELIS syntax file or by using 
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the Output Options option from the Statistics menu.  Either action will result in the creation a LISREL data 

summary file (*.dsf).  A *.dsf file contains all the data information that LISREL requires to fit the structural 

equation model to the data. 

 
Step 3 

 

In SIMPLIS syntax, use the line 
 

System File from file <filename>.DSF 

 

to specify the data to be analyzed and insert the command line 
 

LSFfile <filename>.LSF 

 

after the Relationships paragraph where <filename> denotes the path and name of the *.lsf file. The System File 

command replaces the Observed Variables paragraph and the Sample Size line. 

 

In LISREL syntax, use the command line 

 
SY = <filename>.DSF 

 

to specify the *.dsf file and the 

 
LS = <filename>.LSF 

 

command line to specify the *.lsf file. The SY command replaces the LA and the DA commands. 

 

When done, run the syntax file by clicking the Run LISREL icon button. When the output file is displayed, open 

the relevant *.lsf file using the Open option from the File menu. The latent variable scores appear as the last set 

of columns of this file. 

  

 

9.2 An Illustrative Example 

 

Chow (2000) used five indicators of self esteem (Selfest) and four indicators of depression (Depress) to 

formulate a measurement model for the latent variables Self Esteem and Depression.  A path diagram of this 

measurement model is shown below. 
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The nine indicators were observed for a random sample size of 230 college graduates. The resulting raw data 

are listed in the PRELIS System File depression.lsf. A portion of the spreadsheet is shown below. 

 

 
 

The PRELIS syntax file depression.prl contains the required syntax to compute the sample covariance and to 

create the desired LISREL Data Summary File depression.dsf. This file is generated by selecting the Output 

Options option from the Statistics menu. The Output dialog box is shown below. Select Covariances and check 

the LISREL system data box. Click OK to run PRELIS. 
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The contents of depression.prl are listed below. 

 
SY= Depress.lsf 
OU MA=CM XM XB XT 

 

The SIMPLIS syntax file depress.spl is used to compute the latent variable scores for the latent variables Self 

Esteem and Depression. The contents of this file are listed below. 

 

 

 

If LISREL is executed, a LISREL system data file depressionnew.lsf is created with the latent variable scores as 

shown below.  
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The LISREL syntax file corresponding to the SIMPLIS syntax file depress.spl is shown below.  

 

 

 
 

10 Multilevel Confirmatory Factor Analysis 

The next example illustrates  

 

o importing of external data such as SPSS *.sav files 

o drawing a multiple-group path diagram 

o building SIMPLIS/LISREL syntax from a path diagram 

o fitting a multilevel structural equations model to the data 

 

The data set used in this example forms part of the data library of the Multilevel Project at the University of 

London, and comes from the Junior School Project (Mortimore et al, 1988).  Mathematics and language tests 

were administered in three consecutive years to more than 1000 students from 50 primary schools, which were 

randomly selected from primary schools maintained by the Inner London Education Authority.  The data set is 

stored as an SPSS for Windows file named jsp2.sav. 

 

It is convenient to work with LISREL system data files (*.lsf) since LISREL can read the variable names, the 

number of variables, the number of records and other relevant information directly from these files. It is 

therefore advantageous to convert files from other software packages to the *.lsf format. 

 

10.1 Import of External Data 

Use the Import External Data in Other Formats option from the File menu to obtain the Input Database dialog 

box. Select SPSS for Windows (*.sav) from the Files of type drop-down menu list and select jsp2.sav. Click 

Open to obtain the Save As dialog box. 
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Enter the name jsp2.lsf in the File name string field. By clicking the Save button a LISREL system data file is 

created and displayed in the form of a data spreadsheet. 

 

Although no missing value codes were assigned in jsp2.sav, data values of -9 indicate missing values and can be 

defined as such by selecting the Define Variables option from the Data menu. 

 

Click on MATH1 (or any other variable) to select it. Click Missing Values to obtain the Missing Values dialog 

box. Enter the value -9.0 in the Global Missing Value edit box and change the method of deletion from listwise to 

pairwise. The pairwise option ensures that recoding and computing of variables do not change the number of 

cases. 

 

 
 

10.2 Draw the Path Diagram 

Click the OK buttons of the Missing Values and Define Variables dialog boxes to return to the main window. Use 

the Save option from the File menu to save the changes to jsp2.lsf. Use the New option from the File menu to 

open the New dialog box and select the Path Diagram option from the New dialog box and assign a file name, for 

example, msemex.pth. By clicking the Save button, the path diagram window appears. 

 

Select the Title and Comments option from the Setup menu to open the Title and Comments dialog box.  Enter 

the title Multilevel CFA model for Numeric and Verbal Ability in the Title string field to produce the following Title 

and Comments dialog box. 
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Click Next to open the Groups dialog box. Enter the label Group1: Between Schools in the first string field. Use 

the down arrow key to create a string field for the second group. Enter the label Group2: Within Schools in the 

second string field to produce the following Groups dialog box. 

 

 
 

Click Next to proceed to the Labels dialog box. Since the observed variables are stored in the file jsp2.lsf, it is 

convenient to read the variable names from this file. Click Add/Read Variables to open the Add/Read Variables 

dialog box. Select the LISREL System File option from the Read from file drop-down list box.  

 

Use the Browse button to select the file jsp2.lsf to produce the following Add/Read Variables dialog box. Click 

OK to return to the Labels dialog box. 

 

 
 

Click Add Latent Variables to open the Latent Variables dialog box. Enter the label NABILITY for Numeric 

Ability to produce the following dialog box. 
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Click OK. Repeat the process to enter the label VABILITY for Verbal Ability. Click OK to produce the following 

Labels dialog box. 

 

 
 

Click OK to return to the path diagram window. Click and drag the observed variables MATH1, MATH2, MATH3, 

ENG1, ENG2 and ENG3 one by one into the path diagram window. Also click and drag the latent variables 

NABILITY and VABILITY one by one into the path diagram window to produce the following display. 

 

Use the one-directional arrow on the Draw toolbar to insert paths from NABILITY to MATH1, MATH2 and MATH3 

and also to insert paths from VABILITY to ENG1, ENG2 and ENG3 as shown below. 

 
Note: 

 

Once this arrow is selected, move the mouse to within an ellipse representing a latent variable. With the left 

mouse button down, drag the arrow to an observed variable. Release the mouse button when the arrow is in the 

rectangle representing the observed variable. 
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10.3 Build SIMPLIS/LISREL Syntax 

 

Select the Build SIMPLIS Syntax option from the Setup menu to produce the text editor window shown overleaf. 

Insert the command line $CLUSTER SCHOOL after the Raw Data from File command: 

 

 
 

Change the command line MATH1=NABILITY to MATH1=1*NABILITY to set the scale of NABILITY. Change the 

command line ENG1=VABILITY to ENG1=1*VABILITY to set the scale of VABILITY. Copy and paste the 

relationships of the Between Schools group to the Relationships paragraph of the Within Schools group. 

 

In the Relationships paragraph of the Within Schools group, insert the following SIMPLIS commands  

 
Set Variance of NABILITY Free 
Set Variance of VABILITY Free 
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Set Covariance NABILITY VABILITY Free 
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10.4 Fit the Model to the Data 

 

Click the Run LISREL icon button on the main toolbar to produce the path diagram for the between schools 

group shown below: 

 

 
 

 

LISREL produces an output file, msemex.out which contains the results of the analysis. See the Additional 

Topics Guide for more information on multilevel structural equation models. 


